Técnicas de colocación y edición de PCB
De un vistazo
- Comprende la diferencia entre objetos primitivos y agrupados, y cómo afecta a su colocación y manipulación en el editor de PCB.
- Aprende el flujo de edición habitual antes, durante y después de la colocación, incluidos los valores predeterminados, el acceso a Propiedades y el cambio de las unidades mostradas.
- Descubre los comandos de selección de PCB disponibles para trabajar con objetos superpuestos, jerarquías lógicas de redes, cobre conectado y selecciones de enrutado basadas en componentes.
Hay una gran variedad de objetos disponibles para diseñar una PCB. La mayoría de los objetos colocados en un documento de PCB definirán áreas de cobre o zonas sin cobre. Esto se aplica tanto a los objetos eléctricos, como las pistas y los pads, como a los objetos no eléctricos, como el texto y las cotas. Por lo tanto, es importante tener en cuenta el ancho de las líneas utilizadas para definir cada objeto y la capa en la que se coloca.
Existen dos tipos de objetos en el editor de PCB: objetos primitivos y objetos de grupo:
-
Los objetos primitivos son los elementos fundamentales del diseño e incluyen pistas, pads, vías, rellenos, arcos y objetos de texto. Se denominan «primitivos» por su naturaleza elemental o básica.
-
Cualquier conjunto de primitivas identificado como un objeto de diseño es un objeto de grupo. Algunos ejemplos de objetos de grupo son los componentes, las cotas y los vertidos de polígonos. Un objeto de grupo puede manipularse como un único objeto dentro del espacio de diseño. Por ejemplo, puede colocarse, seleccionarse, copiarse, modificarse, moverse y eliminarse.
Aspectos comunes de la colocación y edición de objetos
En Altium Designer, el proceso de colocación de un objeto es prácticamente el mismo, independientemente del objeto que se coloque. En su forma más sencilla, el proceso es el siguiente:
-
Seleccione el objeto que desea colocar desde una de las barras de herramientas o desde el menú Place .
-
Utilice el ratón para definir la ubicación del objeto en el espacio de diseño del editor de PCB y su tamaño (cuando corresponda).
-
Haga clic con el botón derecho (o pulse Esc) para finalizar el comando y salir del modo de colocación.
Edición antes de la colocación
Las propiedades predeterminadas de un objeto pueden cambiarse en cualquier momento en la página Editor de PCB – Valores predeterminados del cuadro de diálogo Preferences . Estas propiedades se aplicarán al colocar los objetos posteriores.

Utilice la columna Primitives para acceder a las propiedades de los objetos y editar los valores predeterminados según sea necesario.
Edición durante la colocación
Hay varios atributos que pueden editarse al colocar un objeto por primera vez. Para acceder a estos atributos, pulse la tecla Tab mientras esté en el modo de colocación para abrir el panel Properties asociado. Al pulsar la tecla Tab , se pausa la colocación para que pueda realizar los cambios necesarios en el objeto.
Ejemplo de cuadro de diálogo de propiedades de un objeto Pad .
Después de realizar los cambios, haga clic en el botón de pausa superpuesto en el espacio de diseño (
) para reanudar la colocación.
Edición después de la colocación
Una vez colocado un objeto, hay varias formas de editarlo. Estas se describen a continuación.
Panel o cuadro de diálogo de propiedades asociado
Este método de edición utiliza el modo del panel Properties y el cuadro de diálogo asociados para modificar las propiedades de un objeto colocado.
Después de la colocación, se puede acceder al cuadro de diálogo asociado de las siguientes formas:
-
Haciendo doble clic en el objeto colocado.
-
Situando el cursor sobre el objeto, haciendo clic con el botón derecho y eligiendo Properties en el menú contextual.
Después de la colocación, se puede acceder al modo asociado del panel Properties de una de las siguientes formas:
- Si el panel Properties ya está activo, seleccione el objeto.
- Después de seleccionar el objeto, seleccione el panel Properties desde el botón Panels situado en la parte inferior derecha del espacio de diseño o seleccione View » Panels » Properties en los menús principales.
Comandos de selección de objetos de PCB
Además de los comandos estándar de selección y deselección de objetos, el editor de PCB incluye varios comandos especiales que facilitan las operaciones de selección y deselección de objetos. Se accede a estos comandos desde los submenús Edit » Select y Edit » DeSelect de los menús principales. También se puede acceder a los comandos de selección desde el menú del botón
en Active Bar.
-
Select overlapped - utilícelo para seleccionar únicamente el siguiente objeto de diseño de un conjunto de objetos situados en la misma ubicación (superpuestos) sin utilizar una ventana emergente de selección. La selección sigue el siguiente orden de prioridad fijo, que se recorre cíclicamente al utilizar el comando de forma sucesiva:
- Pad
- Vía
- Pista/Arco
- Componente
- Polígono
- Región/Relleno
- Texto
Además, mientras utiliza la tecla Shift para añadir más objetos a la selección actual, puede utilizar Shift+Tab para recorrer cíclicamente la selección de los objetos superpuestos sin perder la selección original.
-
Select next (atajo: Tab) - con un objeto inicial seleccionado en el diseño, este comando permite ampliar la selección para incluir el siguiente objeto (u objetos) de nivel superior según la jerarquía lógica. Se admiten las siguientes secuencias cíclicas de selección lógica:
- Segmento de pista ---> Todas las pistas conectadas (contiguas) en la misma capa ---> Todo el cobre conectado ---> Todos los objetos eléctricos de la red asociada
- Pad conectado ---> Todas las pistas conectadas (contiguas) en la misma capa ---> Todo el cobre conectado ---> Todos los objetos eléctricos de la red asociada
- Pad sin conectar ---> Todos los objetos eléctricos de la red asociada
- Vía ---> Todas las pistas conectadas (contiguas) en las capas asociadas a la vía ---> Todo el cobre conectado ---> Todos los objetos eléctricos de la red asociada
- Cobre (región/vertido de polígono/relleno) ---> Todo el cobre conectado ---> Todos los objetos eléctricos de la red asociada
- Pad/vía libre ---> Todas las pistas conectadas (contiguas) en la misma capa que el pad o en las capas asociadas a la vía ---> Todo el cobre conectado ---> Todos los objetos eléctricos de la red asociada.
- Componente ---> Fanouts de vías, escapes, interconexión
Además, esta función permite ampliar la selección a varios objetos seleccionados en distintas redes del diseño.

Ejemplo de selección en varias redes, que se amplía desde los segmentos de pista seleccionados inicialmente hacia los niveles superiores de la jerarquía lógica.Este comando resulta especialmente útil al seleccionar redes enrutadas. Obtenga más información sobre Estrategias para seleccionar el enrutado.
-
Board - utilícelo para seleccionar todos los objetos situados dentro de los límites del contorno de placa definido.
-
Net - utilícelo para seleccionar todos los objetos eléctricos asociados a una red determinada.
Tras ejecutar el comando, puede hacer clic en un objeto eléctrico o una conexión para seleccionar todos los objetos eléctricos de la red asociada. Si conoce el nombre de la red que desea seleccionar, haga clic en un área del diseño sin objetos; se abrirá el cuadro de diálogo Net Name. Desde allí, puede introducir el nombre de la red deseada; esa red quedará seleccionada al cerrar el cuadro de diálogo. Si no está seguro del nombre de la red, escriba ? y, a continuación, haga clic en OK para abrir el cuadro de diálogo Nets Loaded, que muestra todas las redes cargadas actualmente para el diseño.
-
Connected Copper - utilícelo para seleccionar todos los objetos eléctricos conectados a la misma porción de cobre.
-
Physical Connection - utilícelo para seleccionar todas las pistas enrutadas físicamente entre pads. Haga clic en una pista, un pad o una vía; se seleccionarán todas las pistas contiguas hasta llegar a otro pad, incluidas las vías (los propios pads no se incluirán en la selección).
-
Physical Connection Single Layer - utilícelo para seleccionar todas las pistas enrutadas físicamente entre pads en una sola capa. Haga clic en una pista o una vía; se seleccionarán todas las pistas contiguas de la misma capa hasta llegar a otro pad (los propios pads y vías no se incluirán en la selección).
-
Component Connections - utilícelo para seleccionar todas las conexiones enrutadas que parten de los pads de un componente elegido (incluidas las pistas y las vías) hasta el siguiente pad encontrado en cada caso. Los propios pads no se incluirán en la selección.
También puede acceder al comando haciendo clic con el botón derecho sobre un componente colocado y eligiendo el comando Component Actions » Select Component Connections en el menú contextual.
-
Component Nets - utilícelo para seleccionar todas las redes (y los objetos que pertenecen a ellas) conectadas a un componente elegido en el documento actual.
También puede acceder al comando haciendo clic con el botón derecho sobre un componente colocado y eligiendo el comando Component Actions » Select Component Nets en el menú contextual.
-
Room Connections - utilícelo para seleccionar todas las conexiones enrutadas de pad a pad que se encuentren completamente dentro de los límites de la sala elegida en el documento actual.
También puede acceder al comando haciendo clic con el botón derecho sobre una sala colocada y eligiendo el comando Room Actions » Select Room Connections en el menú contextual.
-
All on Layer - utilícelo para seleccionar o deseleccionar todos los objetos de la capa actual.
-
Free Objects - utilícelo para seleccionar todos los objetos primitivos libres del diseño. Los componentes, las coordenadas, las cotas, los objetos de ajuste de longitud, los objetos OLE y los vertidos de polígonos son objetos agrupados y, por tanto, no se verán afectados por este comando.
-
All Locked - utilícelo para seleccionar todos los objetos del diseño que tengan activada la propiedad Locked .
-
Off Grid Pads - utilícelo para seleccionar todos los pads que no estén situados en la cuadrícula de ajuste actual.
Edición gráfica
Este método de edición permite seleccionar un objeto colocado directamente en el espacio de diseño y cambiar gráficamente su tamaño, forma o ubicación. La modificación de la forma o del tamaño (cuando corresponda) se realiza mediante los «tiradores» de edición que aparecen al seleccionar el objeto.

Ejemplo de tiradores de edición de un objeto de relleno seleccionado.
Haga clic en cualquier parte de un objeto alejada de los tiradores de edición (si los hay) para arrastrarlo y cambiar su posición. Según el tipo de objeto, puede girarlo o voltearlo mientras lo arrastra.
- Pulse Spacebar para girar el objeto en sentido antihorario o Shift+Spacebar para girarlo en sentido horario. El giro se realiza según el valor de Rotation Step definido en la página Editor de PCB – General del cuadro de diálogo Preferences.
- Pulse la tecla L para voltear el objeto al otro lado de la placa (cuando corresponda).
- Pulse las teclas X o Y para voltear el objeto respecto al eje X o al eje Y, cuando corresponda.
- Pulse la tecla Alt para restringir la dirección del movimiento al eje horizontal o vertical, según la dirección inicial del movimiento.
- Desplace el objeto en pequeños incrementos (según el valor actual de la rejilla de ajuste) pulsando las teclas de flecha mientras mantiene pulsada la tecla Ctrl . Desplácelo en incrementos mayores (10 veces el valor de la rejilla de ajuste) pulsando las teclas de flecha mientras mantiene pulsadas las teclas Ctrl+Shift.
Comandos de movimiento
La posición de un objeto puede cambiarse mediante los comandos del submenú Edit » Move de los menús principales o del submenú de movimiento en Active Bar.
-
Move - este comando se utiliza para mover cualquier objeto del documento actual. Todas las redes asociadas a un objeto permanecerán conectadas y las líneas de conexión seguirán al objeto cuando se mueva (se mostrarán o no según el modo de conexión activo). Las pistas enrutadas conectadas al objeto no se moverán.
-
Drag - este comando se utiliza para mover cualquier objeto del documento actual. Si el objeto tiene pistas o arcos conectados (por ejemplo, un componente, un pad o una vía), estos permanecerán conectados mientras se mueve el objeto.
-
Component - este comando permite mover componentes en el documento actual. Tras ejecutar el comando, haga clic en el componente del diseño que desea mover, desplácelo a la posición deseada y vuelva a hacer clic. También puede hacer clic en el espacio de diseño, lejos de cualquier objeto, para abrir el cuadro de diálogo Elegir componente. Utilice este cuadro de diálogo para localizar el componente que desea mover (ya sea saltando al componente o trayéndolo al cursor) y, a continuación, cambie su posición del mismo modo que se ha descrito anteriormente. Tenga en cuenta que esta función solo funcionará si el componente de destino not está bloqueado.
También puede acceder al comando haciendo clic con el botón derecho sobre un componente en el espacio de diseño y seleccionando el comando Component Actions » Move Component en el menú contextual.
-
Move Selection - este comando permite cambiar manualmente la posición de los objetos seleccionados en el documento actual. Todas las redes asociadas a un objeto de la selección permanecerán conectadas y las líneas de conexión seguirán al objeto cuando se mueva (se mostrarán o no según el modo de conexión activo). Las pistas enrutadas conectadas al objeto no se moverán.
-
Move Selection by X, Y - este comando se utiliza para desplazar la selección actual de objetos una cantidad precisa en las direcciones X o Y. Tras ejecutar el comando, se abrirá el cuadro de diálogo Get X/Y Offsets. Utilice este cuadro de diálogo para especificar los valores de incremento delta X o delta Y con los que mover la selección.

El cuadro de diálogo Get X/Y OffsetsOpciones y controles del cuadro de diálogo Obtener desplazamientos X/Y
- X Offset - utilice este campo para especificar la distancia que debe desplazarse la selección a lo largo del eje horizontal. Se pueden especificar valores positivos y negativos según la dirección de movimiento deseada. Utilice el botón situado a la derecha de este campo para alternar rápidamente el valor introducido entre positivo y negativo.
- Y Offset - utilice este campo para especificar la distancia que debe desplazarse la selección a lo largo del eje vertical. Se pueden especificar valores positivos y negativos según la dirección de movimiento deseada. Utilice el botón situado a la derecha de este campo para alternar rápidamente el valor introducido entre positivo y negativo.
- Toggle X/Y Offsets - haga clic en este botón para intercambiar rápidamente los valores de desplazamiento. El valor de X Offset se utilizará como valor de Y Offset y viceversa.
- Reset X/Y Offsets - haga clic en este botón para restablecer rápidamente ambos valores de desplazamiento a cero.
- Define X/Y Offsets Interactively - haga clic en este botón para calcular los desplazamientos de forma interactiva. Se le llevará al espacio de trabajo y se le pedirá que elija, sucesivamente, un punto inicial y uno final. Haga clic en las ubicaciones deseadas; los valores dX y dY se introducirán en los campos X Offset y Y Offset, respectivamente.
-
Rotate Selection - este comando se utiliza para girar los objetos seleccionados en el espacio de diseño en sentido antihorario o en sentido horario según un ángulo de rotación especificado. Tras ejecutar el comando, se abrirá el cuadro de diálogo Rotation Angle (Degrees). Introduzca el ángulo de rotación requerido, de 0.001° a 360.00° (resolución de 0.001°). Introduzca un valor positivo para girar en sentido antihorario o un valor negativo para girar en sentido horario. Haga clic en OK para cerrar el cuadro de diálogo; a continuación, sitúe el cursor y haga clic para definir el punto de referencia de la rotación. Los objetos seleccionados girarán alrededor del punto de referencia según el ángulo introducido.

El cuadro de diálogo Rotation Angle -
Flip Selection - voltea los objetos seleccionados horizontalmente (alrededor del eje Y) y los coloca en la capa correspondiente del lado opuesto de la placa. Por ejemplo, los objetos de Top Layer se trasladarán a Bottom Layer, los objetos de Top Overlay se trasladarán a Bottom Overlay, etc.
Comandos de alineación
Los objetos también se pueden mover cambiando su alineación. Para alinear objetos con otros objetos, haga clic con el botón derecho en un objeto seleccionado y seleccione Align. Como alternativa, utilice el submenú Edit » Align de los menús principales o el submenú de alineación de Active Bar. El submenú de alineación contiene varias opciones para distribuir los objetos seleccionados.
El comando Align se utiliza para acceder al cuadro de diálogo Align Objects, que proporciona controles para alinear rápidamente el conjunto de objetos de diseño seleccionados según sea necesario. Utilice el cuadro de diálogo para configurar las opciones de alineación Vertical y/o Horizontal de los objetos seleccionados según sea necesario y, a continuación, haga clic en OK para aplicar la alineación.

El cuadro de diálogo Align Objects
Opciones y controles del cuadro de diálogo de alineación de objetos
-
Horizontal - elija una de las siguientes opciones para determinar la alineación horizontal de los objetos seleccionados:
- No Change - mantiene sin cambios la alineación horizontal de los objetos.
- Left - alinea los objetos de modo que el borde exterior de sus primitivas situadas más a la izquierda tenga la misma coordenada X. Se utiliza como referencia el objeto cuya primitiva está más a la izquierda.
- Center - mueve los objetos horizontalmente para alinear sus centros. Después de hacer clic en OK, se le solicitará que haga clic para elegir el objeto de referencia.
- Right - alinea los objetos de modo que el borde exterior de sus primitivas situadas más a la derecha tenga la misma coordenada X. Se utiliza como referencia el objeto cuya primitiva está más a la derecha.
- Space equally - distribuye los objetos a intervalos iguales en dirección horizontal, entre el objeto situado más a la izquierda y el situado más a la derecha (que no se mueven).
-
Vertical - elija una de las siguientes opciones para determinar la alineación vertical de los objetos seleccionados:
- No Change - mantiene sin cambios la alineación vertical de los objetos seleccionados.
- Top - alinea los objetos de modo que el borde exterior de sus primitivas situadas más arriba tenga la misma coordenada Y. Se utiliza como referencia el objeto cuya primitiva está más arriba.
- Center - mueve los objetos verticalmente para alinear sus centros. Después de hacer clic en OK, se le solicitará que haga clic para elegir el objeto de referencia.
- Bottom - alinea los objetos de modo que el borde exterior de sus primitivas situadas más abajo tenga la misma coordenada Y. Se utiliza como referencia el objeto cuya primitiva está más abajo.
- Space equally - distribuye los objetos a intervalos iguales en dirección vertical, entre el objeto situado más arriba y el situado más abajo (que no se mueven).
El comando Position Component Text se utiliza para abrir el cuadro de diálogo Component Text Position, desde el que puede cambiar la posición del texto del designador y/o del comentario de uno o varios componentes seleccionados en el documento actual.

El cuadro de diálogo Component Text Position
El cuadro de diálogo se divide básicamente en dos áreas: el texto del designador y el del comentario. Tanto para el designador como para el comentario, se utiliza una representación gráfica de un componente como ayuda para mostrar dónde aparecerá el texto en función de la posición seleccionada. Para el texto están disponibles los siguientes nueve estilos de posición, todos ellos clasificados como «posiciones automáticas», lo que significa que el texto permanece en la posición elegida cuando el componente se mueve y gira:
- Left-Above
- Left-Center
- Left-Below
- Center-Above
- Center
- Center-Below
- Right-Above
- Right-Center
- Right-Below
Para dejar el texto en su posición actual sin modificarlo, mantenga activada la opción No Change.
El comando Align Left / Align Right / Align Top / Align Bottom permite alinear los objetos de diseño seleccionados por sus bordes izquierdo, derecho, superior e inferior, respectivamente. Tras ejecutar el comando, se utiliza como referencia el borde izquierdo/derecho/superior/inferior del objeto situado más a la izquierda/derecha/arriba/abajo, y todos los demás objetos de la selección se moverán hacia la izquierda/derecha/arriba/abajo, de modo que sus bordes izquierdos queden alineados con esta referencia.
El Align Left (maintain spacing) / Align Right (maintain spacing) / Align Top (maintain spacing) / Align Bottom (maintain spacing) permite alinear los objetos de diseño seleccionados por sus bordes izquierdo/derecho/superior/inferior, manteniendo una separación adecuada conforme a las reglas de diseño aplicables. Tras ejecutar el comando, se utiliza como referencia el borde izquierdo/derecho/superior/inferior del objeto situado más a la izquierda/derecha/arriba/abajo, y todos los demás objetos de la selección se desplazan hacia la izquierda/derecha/arriba/abajo para que sus bordes izquierdos queden alineados con esta referencia. Cada objeto se desplaza hacia la izquierda/derecha/arriba/abajo hasta quedar tan cerca del objeto de referencia como permita la regla de separación aplicable:
- Para alinear únicamente componentes, se respeta la regla de separación entre componentes.
- Para alinear únicamente objetos que no sean componentes, se respeta la regla de separación.
- Para alinear componentes y objetos que no sean componentes, se respeta la regla de separación.
El comando Align Horizontal Centers / Align Vertical Centers permite colocar los objetos seleccionados en una sola columna/fila, alineados por sus centros horizontales/verticales. Tras ejecutar el comando, el cursor cambia a una cruz y se le solicita que seleccione uno de los objetos de la selección; haga clic en él. Este pasa a ser el objeto de referencia. Todos los demás objetos de la selección se desplazan con respecto a este objeto de referencia, alineados por sus centros horizontales/verticales.
El comando Distribute Horizontally / Distribute Vertically permite igualar la separación horizontal/vertical de una selección de objetos. Tras ejecutar el comando, los objetos situados más a la izquierda y más a la derecha / más arriba y más abajo de la selección permanecen fijos en sus posiciones, y todos los demás objetos se distribuyen de manera equidistante entre ellos. La posición vertical/horizontal de los objetos no cambia.
El comando Increase Horizontal Spacing / Increase Vertical Spacing permite aumentar la separación horizontal/vertical de una selección de objetos. Tras ejecutar el comando, el objeto situado más a la izquierda/abajo permanece fijo, mientras que los demás objetos de la selección se desplazan hacia la derecha/arriba. El desplazamiento aumenta la distancia horizontal/vertical entre los puntos de referencia de objetos consecutivos en la cantidad especificada en el campo Step X / Step Y del Global Board Snap Grid predeterminado.
El comando Decrease Horizontal Spacing / Decrease Vertical Spacing permite reducir la separación horizontal/vertical de una selección de objetos. Tras ejecutar el comando, el objeto situado más a la izquierda/abajo permanece fijo, mientras que los demás objetos de la selección se desplazan hacia la izquierda/abajo. El desplazamiento reduce la distancia horizontal/vertical entre los puntos de referencia de objetos consecutivos en la cantidad especificada en el campo Step X / Step Y del Global Board Snap Grid predeterminado.
El comando Align To Grid se utiliza para desplazar los componentes seleccionados al punto más cercano de la cuadrícula de ajuste aplicable y modificada. Tras ejecutar el comando, los puntos de referencia de cada uno de los componentes seleccionados se desplazan al punto más cercano de la cuadrícula de ajuste aplicable.
El comando Move All Components Origin To Grid se utiliza para desplazar el punto de referencia de todos los componentes a la cuadrícula de ajuste actual. Tras ejecutar el comando, todos los componentes del espacio de diseño cuyos pads estén en la cuadrícula se desplazan para que sus puntos de referencia queden alineados con la cuadrícula de ajuste actual. De forma predeterminada, se genera automáticamente un informe, Move Component(s) Origin To Grid - <PCBDocumentName>.html, que se abre como documento activo y detalla qué componentes se han desplazado y cuáles no.
Mediante el panel PCB List
El panel PCB List permite mostrar los objetos de diseño en formato tabular, lo que facilita la inspección y modificación rápidas de sus atributos. Cuando se utiliza junto con el panel PCB Filter, permite mostrar únicamente los objetos incluidos en el ámbito del filtro activo, lo que facilita la selección y edición de varios objetos de diseño con mayor precisión y eficiencia.
Selección de la capa activa
La capa activa es la capa en la que se colocarán los objetos. Puede seleccionar la capa activa entre las capas visibles haciendo clic en la pestaña de esa capa en la parte inferior del espacio de diseño o mediante el desplegable Active Layer de la región Layers de la pestaña Layers & Colors del panel View Configuration.
También puede utilizar los siguientes atajos para seleccionar rápidamente la capa activa:
- * (en el teclado numérico): cambiar a la siguiente capa de señal habilitada.
-
Shift+* (en el teclado numérico): cambiar a la capa de señal habilitada anterior.
- + (en el teclado numérico): cambiar a la siguiente capa habilitada.
- - (en el teclado numérico): cambiar a la capa habilitada anterior.
Uso de Cortar/Copiar y Pegar
En el editor de PCB, puede cortar/copiar y pegar objetos dentro de un documento de PCB o entre distintos documentos; por ejemplo, los componentes de una PCB se pueden copiar a otro documento de PCB. Puede cortar/copiar objetos al portapapeles de Windows y pegarlos en otros documentos.
Al utilizar 2D Layout Mode, seleccione los objetos que desea cortar/copiar y haga clic en Edit » Cut (Ctrl+X) / Edit » Copy (Ctrl+C) en los menús principales, o elija el comando Cut/Copy en el menú contextual. El cursor cambia a una cruz y se le solicita que seleccione un punto de referencia. Este es una coordenada relativa a los objetos seleccionados y se utiliza para colocar la selección con precisión al utilizar el comando de pegado.
Para copiar los objetos de diseño seleccionados actualmente al portapapeles en formato de texto, puede utilizarse el comando Edit » Copy As Text de los menús principales. Esta información puede pegarse después en cualquier campo de texto o documento de texto externo. Los detalles copiados al portapapeles incluyen:
- El tipo de objeto.
- El designador y el comentario (para un objeto de componente).
- La ubicación del objeto en el espacio de diseño.
- La capa en la que se encuentra el objeto (o las capas inicial y final, en el caso de una vía).
Un ejemplo de un componente copiado como texto al portapapeles es:
Component Y1-25MHz (100.6mm,1.5mm) on Top Layer
Un ejemplo de una pista y una vía copiadas como texto al portapapeles es:
Track (20mm,6mm)(80mm,6mm) Top Layer
Via (45mm,6mm) Top Layer to Bottom Layer
Para colocar el último contenido cortado o copiado al portapapeles en el documento activo, seleccione el comando Edit » Paste en los menús principales o haga clic con el botón derecho en el espacio de diseño y seleccione el comando Paste en el menú contextual (atajo de teclado: Ctrl+V). El contenido más reciente del portapapeles aparecerá flotando junto al cursor. La posición del cursor respecto al contenido viene determinada por el punto de referencia definido al utilizar Cut o Copy para añadir la selección al portapapeles.
Para colocar el texto copiado de una aplicación OLE compatible en cualquier documento de PCB abierto, puede utilizarse el comando Edit » Paste Text de los menús principales. El texto se convierte y se pega como objetos de cadena de texto de PCB, en lugar de como un único objeto OLE. Los tipos de archivo compatibles incluyen formatos universales, como hojas de cálculo en formato CSV y XLS, y documentos de texto DOC y RTF.
Para controlar qué ocurre con determinados atributos de los objetos al pegarlos de nuevo en el espacio de diseño, puede utilizarse el comando Edit » Paste Special de los menús principales. Tras ejecutar el comando, se abrirá el cuadro de diálogo Paste Special.

El cuadro de diálogo Paste Special
Opciones y controles del cuadro de diálogo Pegado especial
Atributos de pegado
- Paste on current layer - active esta opción para pegar los objetos en la capa actual.
- Keep net name - active esta opción para conservar los nombres de red originales de los objetos.
- Duplicate designator - active esta opción para pegar un componente con el mismo designador, sin incrementarlo automáticamente.
- Add to component class - active esta opción para añadir el componente pegado a la misma clase de componentes que el componente de origen.
Botones
- Paste - haga clic para pegar el objeto con todos los atributos especificados.
- Paste Array - haga clic para abrir el cuadro de diálogo Configurar matriz de pegado, en el que puede configurar las opciones de pegado en matriz.
Según el contenido específico que se vaya a pegar, se pueden controlar los siguientes atributos:
-
Los objetos pueden pegarse en la capa actual, en lugar de seguir el comportamiento predeterminado de pegarlos en la misma capa de la que se copiaron los objetos de origen.
- Posibilidad de conservar los nombres de red asignados.
- Posibilidad de duplicar el designador (para un componente pegado).
- Posibilidad de añadir un componente pegado a la misma clase de componentes que el componente de origen.
Configure las opciones según sea necesario y, a continuación, haga clic en el botón Paste para iniciar la operación de pegado.
Al hacer clic en el botón Paste Array del cuadro de diálogo Paste Special, se abrirá el cuadro de diálogo Setup Paste Array, que permite pegar varias copias de los objetos del portapapeles en el documento actual.

El cuadro de diálogo Setup Paste Array
Opciones y controles del cuadro de diálogo Configurar matriz de pegado
Variables de colocación
- Item Count - el número de colocaciones repetidas que se realizarán. Por ejemplo, al introducir 4, se colocarán 4 copias del contenido actual del portapapeles.
-
Text Increment - introduzca el incremento automático para el texto mostrado (por ejemplo, el designador de un componente o un pad). Se admiten incrementos tanto alfabéticos como numéricos distintos de 1. Por ejemplo, si se establece el designador de un pad antes de copiarlo al portapapeles y se configura el campo Text Increment, pueden colocarse los siguientes tipos de secuencias de designadores de pads:
- Numérica (1, 3, 5)
- Alfabética (A, B, C)
- Combinación alfanumérica (A1, A2, o 1A, 1B, o A1, B1, o 1A, 2A, etc.)
Tipo de matriz
- Circular- active esta opción para pegar una matriz circular utilizando la configuración actual de Circular Array.
- Linear - active esta opción para pegar la matriz en línea recta utilizando la configuración actual de Linear Array.
Matriz circular
- Rotate Item to Match - si esta opción está activada, los elementos de la matriz se girarán con el mismo ángulo que el definido en su separación.
- Spacing (degrees) - la separación angular entre dos elementos pegados adyacentes.
Matriz lineal
- X-Spacing - introduzca la separación deseada en X entre dos elementos adyacentes.
- Y- Spacing - introduzca la separación deseada en Y entre dos elementos adyacentes.
Introduzca los valores adecuados en este cuadro de diálogo y, a continuación, haga clic en OK para colocar la matriz.
- Si va a colocar una matriz lineal, se le pedirá que seleccione su punto inicial. Sitúe el cursor y, a continuación, haga clic o pulse Enter para colocar la matriz.
- Si va a colocar una matriz circular, se le pedirá que seleccione el punto central de la matriz y, a continuación, su punto inicial. Sitúe el cursor en cada punto y haga clic o pulse Enter para colocar la matriz. Los objetos se colocarán en sentido antihorario alrededor del punto central indicado.
Prioridades al pegar objetos
Cuando se pega un objeto en una capa de cobre y este se superpone a un conjunto de objetos de distintos tipos, se le asigna la red del objeto con la mayor prioridad. Las prioridades son las siguientes (1 es la prioridad más alta):
- Pad
- Relleno
- Región
- Pista
- Arco
- Vía
- Vertido de polígono

La red del objeto con la mayor prioridad se asigna al objeto pegado. Aquí se muestra un objeto (pista) pegado sobre un conjunto de objetos de distintos tipos con diferentes redes asignadas. Como el pad es el objeto de mayor prioridad de este conjunto, su red (Pad_Net) se asignará al objeto pegado. Sitúe el cursor sobre la imagen para ver el resultado.
Cuando se pega un objeto en una capa de cobre y este se superpone a un conjunto de objetos del mismo tipo, se le asigna la red del objeto que se encuentra bajo el cursor al hacer clic para pegarlo.

La red del objeto situado bajo el cursor se asigna al objeto pegado. Aquí se muestra un objeto (pista) pegado sobre un conjunto de objetos del mismo tipo (pads). Como el pad 2 es el objeto que se encuentra bajo el cursor al hacer clic para pegar el objeto, la red de este pad (Pad2_Net) se asignará al objeto pegado. Sitúe el cursor sobre la imagen para ver el resultado.
Cuando se pega un conjunto de objetos conectados físicamente en una capa de cobre y los objetos de distintos tipos de este conjunto se superponen a objetos existentes con diferentes redes, la red del objeto de mayor prioridad de este conjunto se asignará a todos los objetos pegados. En este caso se aplican las prioridades indicadas anteriormente.

La red asignada al objeto de mayor prioridad se asigna al conjunto de objetos conectados físicamente. Aquí se muestra un conjunto de objetos conectados (de izquierda a derecha: relleno, región, pista, arco, vía y vertido de polígono) pegado sobre objetos (vías) con diferentes redes asignadas. Como el relleno es el objeto de mayor prioridad de este conjunto pegado, la red que se le asigne (Via1_Net) se asignará a cada objeto del conjunto. Sitúe el cursor sobre la imagen para ver el resultado.
Bloqueo de objetos de diseño
Los objetos de diseño pueden bloquearse para impedir que se muevan o se editen en el documento PCB mediante la activación de sus atributos Locked . Por ejemplo, si la posición o el tamaño de determinados objetos es fundamental, bloquéelos. El bloqueo puede realizarse en el panel Properties haciendo clic en el icono del candado de los objetos deseados, como se muestra en los siguientes ejemplos.
Ejemplos del icono Lock en el panel Properties para un componente y un pad seleccionados.
Para alternar el estado de la propiedad Locked de un objeto colocado que tenga la propiedad Locked , también puede hacer clic con el botón derecho sobre el objeto en el espacio de diseño y elegir el comando <ObjectType> Locked del menú contextual. Si el objeto ya está bloqueado, la entrada del comando en el menú mostrará una marca de verificación a la izquierda.
Si intenta mover o girar un objeto de diseño que tenga activada su propiedad Locked, aparecerá un cuadro de diálogo que le pedirá confirmación para continuar con la edición.
Bloqueo de primitivas de componentes
Si un componente de PCB tiene sus primitivas bloqueadas (la opción Primitives del modo Componente del panel Propiedades está en el estado , todas o la mayoría de las propiedades de estas primitivas no podrán modificarse mediante métodos de edición gráficos (por ejemplo, arrastrar y soltar) ni no gráficos (por ejemplo, mediante el panel Properties o List). Esto ayudará a evitar cambios accidentales en las primitivas de los componentes que puedan dar lugar a resultados incorrectos de ensamblaje y fabricación.
A modo de ejemplo, la imagen siguiente muestra el modo Pad del panel Propiedades para un pad que forma parte de un componente de PCB cuyas primitivas están bloqueadas. Observe que todas las propiedades del pad (excepto las propiedades Net y Testpoint) están atenuadas y no se pueden editar. Observe también que el icono
se muestra en el extremo derecho de Component del pad. campo, que indica que el componente principal tiene sus primitivas bloqueadas y que las propiedades del pad no se pueden modificar.

El modo Pad del panel Properties (a la izquierda) para un pad de un componente de PCB que tiene sus primitivas bloqueadas (a la derecha).
Edición reentrante
El editor de PCB incluye una potente función denominada re-entrant editing. Esta permite ejecutar una segunda operación mediante atajos de teclado sin finalizar la operación actual. La edición reentrante permite trabajar de forma más flexible e intuitiva. Por ejemplo, imagine que empieza a colocar una pista y se da cuenta de que debe eliminar otro segmento de pista. No es necesario salir del modo de enrutamiento interactivo. Pulse las teclas de acceso rápido E, D, elimine el segmento de pista correspondiente y, a continuación, pulse la tecla Esc para volver al enrutamiento interactivo del diseño.
Configuración de la apariencia del cursor de PCB
De forma predeterminada, el cursor de PCB es una pequeña cruz verde de 90 grados. Esto se puede configurar mediante los ajustes Cursor Type y Cursor Color, en la página Editor de PCB – General del cuadro de diálogo Preferences . Por ejemplo, una cruz grande de 90 grados que se extienda hasta los bordes de la ventana de diseño (opción Large 90) puede resultar útil al colocar y alinear objetos de diseño. Como alternativa, una cruz a 45 grados (opción Small 45) puede ser útil si las opciones de 90 grados son difíciles de distinguir de las líneas de la cuadrícula.
Compatibilidad con fuentes TrueType
El editor de PCB ofrece la posibilidad de utilizar fuentes basadas en trazos o TrueType para los objetos relacionados con texto de un diseño (cadenas de texto/marcos de texto, cotas, tablas de taladros y/o tablas de apilado de capas). La fuente se selecciona en el panel Properties correspondiente. Hay tres opciones de fuentes basadas en trazos disponibles: Default, Sans Serif y Serif. El estilo Default es una fuente vectorial sencilla que admite el trazado con pluma y el fototrazado vectorial. Las fuentes Sans Serif y Serif son más complejas y ralentizan la generación de salidas vectoriales, como Gerber. Las fuentes basadas en trazos están integradas en el software y no se pueden cambiar. Las tres fuentes incluyen el conjunto completo de caracteres ASCII extendidos de IBM, compatible con el inglés y otros idiomas europeos. Al utilizar fuentes TrueType, están disponibles las fuentes TrueType y OpenType (un superconjunto de TrueType) que se encuentren en la carpeta \Windows\Fonts. Esta función también ofrece compatibilidad completa con Unicode.
Las geometrías de los objetos de texto que utilizan fuentes TrueType se almacenan automáticamente en los documentos de PCB. Cuando los objetos de un documento de PCB utilizan una fuente TrueType, se mostrarán con la misma geometría de fuente al abrir el documento de PCB en otro ordenador, aunque esa fuente TrueType no esté instalada.
Cuando se selecciona un objeto que utiliza una fuente que falta, aparece un mensaje de advertencia en la parte superior del panel Properties. Al cambiar las propiedades del objeto que afectan a su texto (por ejemplo, la altura del texto o el propio texto), se abre el cuadro de diálogo Missing fonts, en el que puede seleccionar una fuente de sustitución (Replacement). Active la opción Apply to all text elements para aplicar la fuente de sustitución a todos los objetos del documento de PCB que utilicen la fuente que falta.
El cuadro de diálogo también aparece al cambiar las propiedades relacionadas con el texto desde el panel PCB List.
Al intentar editar varios objetos que utilizan distintas fuentes que faltan, el cuadro de diálogo permite seleccionar una sustitución para cada una de ellas.
Compatibilidad con la representación de arcos reales
Se admiten los arcos reales generados en el espacio de diseño tanto del editor de PCB como del editor de bibliotecas de PCB, en lugar de aproximaciones. Esta compatibilidad se extiende a los modos de diseño 2D/3D (y al modo de planificación de la placa en el editor de PCB). La representación de arcos reales se puede apreciar en los siguientes elementos:
-
Rellenos de polígonos (sólidos, tramados, sin relleno)
-
Recortes de rellenos de polígonos
-
Contorno de selección de rellenos de polígonos y regiones
-
Regiones
-
Expansiones de la máscara de soldadura y de la máscara de pasta
-
Resaltado de redes
-
Límites de separación
-
Superposición de infracciones (relleno de polígono independiente sobre una región o un relleno de polígono)
A continuación se muestran ejemplos de representación de arcos reales en rellenos de polígonos alrededor de otros objetos de una PCB.
Información de la red
Para los objetos de cobre de una PCB (pista, vía, polígono, etc.), se presenta la siguiente información en la sección Net Information del panel Properties cuando se selecciona el objeto:
- Los elementos superiores Net, Diff Pair y/o xSignal y la clase asociada en cada caso. Tenga en cuenta que las entradas Diff Pair y xSignal solo se muestran si el objeto forma parte de un par diferencial o de un xSignal, respectivamente.
-
Delay – el retardo de los objetos seleccionados y el retardo de los segmentos enrutados de toda la red. Incluye los valores de Propagation Delay de los pads y las vías, si se han definido para ellos.
-
Length – la suma total de las longitudes de los objetos seleccionados y el Signal Length total. El Signal Length es el cálculo preciso de la distancia total entre nodos. Los objetos colocados se analizan para resolver los objetos apilados o superpuestos y los recorridos sinuosos dentro de los pads; también se incluyen las longitudes de las vías. El Pin Package Length también se incluye si se ha definido para los pads. Si la red no está completamente enrutada, también se incluye la longitud Manhattan (X + Y) de la línea de conexión. Para obtener más información sobre la longitud de señal y sus aplicaciones, consulte la información sobre el panel PCB - Redes.
-
Max Current - la corriente máxima que pueden conducir los objetos Pista, Arco o Vía seleccionados, determinada mediante la fórmula de IPC-2221A (sección 6.2):
I = k * ΔT0.44 * A0.725
donde:
I = corriente [amperios]
A = área de la sección transversal [mils cuadrados] (ancho de pista * espesor del cobre de la pila de capas, o Apared, como se muestra a continuación)
ΔT = aumento de temperatura permitido respecto a la temperatura ambiente [°C]
k = constante, tal que:k = 0.048 para las capas externas
k = 0.024 para las capas internas -
Resistance - la suma de las resistencias de los objetos Pista, Arco y Vía seleccionados, determinada mediante la fórmula derivada:
R = (ρ * L / A)
donde:
R = resistencia [Ω]
ρ = resistividad del cobre [Ω*mm2/m]
L = longitud de pista [m] (o longitud de vía, como se describe a continuación)
A = área de la sección transversal = T * W [mm2] (o Apared, como se muestra a continuación)
T = espesor de pista (de la pila de capas) [mm]
W = ancho de pista [mm]Assumptions:
- Temperatura ambiente = 22 °C
- Aumento de temperatura permitido = 20 °C
- Espesor de la pared de cobre del orificio pasante = 0.018 mm
- Resistividad del cobre = 0.017 Ω*mm2/m

La región Net Information del panel Properties. Aquí se muestra un ejemplo para una pista seleccionada.
Haga clic en un enlace de la región Net Information para abrir la red, el par diferencial o el xSignal asociado en el panel PCB.
Asignación de redes a objetos
El editor de PCB ofrece varias formas de asignar redes a objetos primitivos:
- Cuando haya uno o más objetos seleccionados, utilice la lista desplegable del campo Nets en el panel Properties. En la lista desplegable aparecerán todas las redes del diseño de placa activo. Seleccione No Net para especificar que la pista no está conectada a ninguna red. También puede hacer clic en el icono Assign Net para elegir un objeto en el espacio de diseño: la red de ese objeto se asignará a los objetos seleccionados.
- Haga clic con el botón derecho sobre uno o más objetos seleccionados y, a continuación, elija Net Actions » Assign Net. Tras ejecutar el comando, aparecerá un cursor en cruz. Sitúe el cursor en cruz sobre la red a la que desee asignar los objetos y haga clic para seleccionar esa red.
- Para volver a sincronizar el nombre de red de las primitivas de enrutamiento con el nombre de red de los pads a los que se conectan, seleccione el comando Design » Netlist » Update Free Primitives From Component Pads en los menús principales. Tras ejecutar el comando, se abre un cuadro de diálogo de confirmación que pregunta si desea actualizar las redes de las primitivas libres con las redes de los pads de los componentes. Después de hacer clic en Yes, y partiendo de cada pad, se selecciona el cobre conectado y se establece el nombre de red de cada primitiva para que coincida con el del pad. Esta operación no afecta a la lista de conexiones interna de la PCB.
Para comprobar y confirmar que los objetos conectados físicamente tienen asignada la red correcta para pertenecer a esa red física (en este caso, physical net significa connected copper), puede utilizar el cuadro de diálogo Configure Physical Nets, al que se accede seleccionando el comando Design » Netlist » Configure Physical Nets en los menús principales. El software analiza el diseño y comprueba que todos los pads y los objetos que los conectan físicamente entre sí (pistas, arcos, rellenos, etc.) tienen asignado el mismo nombre de red. Cuando todos los objetos de la red son correctos, la red se muestra en verde. Si se detectan objetos que se tocan pero tienen asignada una red diferente, se marcan en rojo. Un ejemplo habitual de esta situación es cuando la huella de un componente contiene objetos de cobre adicionales. Cuando esta huella se carga durante la sincronización, el nombre de red asignado se aplica a cada pad, pero no al cobre adicional. El cuadro de diálogo es interactivo; haga clic en una red o primitiva para localizar ese objeto en el diseño mediante sondeo cruzado. Haga clic con el botón derecho o en el botón Menu para acceder a los comandos disponibles. La sección Action del cuadro de diálogo proporciona controles para especificar la acción necesaria para resolver los problemas con el cobre conectado. De forma predeterminada, las acciones se establecen automáticamente, pero pueden ajustarse según sea necesario. Una vez establecidas las acciones, haga clic en el botón Execute para actualizar las asignaciones de red.

El cuadro de diálogo Configure Physical Nets (con la opción Only Show Errors activada detrás y la opción Only Show Errors desactivada delante).
Opciones y controles del cuadro de diálogo Configure Physical Nets
-
Electrically Connected Copper - esta sección muestra los distintos grupos de primitivas de cobre que están conectadas eléctricamente, según lo detectado en el trazado del diseño. Para cada grupo, se presenta la siguiente información:
-
Primitive - en el nivel superior, esta entrada indica cuántas primitivas componen el cobre conectado. Las primitivas pueden mostrarse en una lista plana o agrupadas por tipo de primitiva. Esta última opción se configura activando Show Primitive Groups entre las opciones del botón Menu . En ese caso, las primitivas se dividirán en los siguientes grupos:
- Connected Component Primitives - muestra todas las primitivas de pads de componentes como elementos secundarios. A su vez, estas pueden agruparse por el componente al que pertenecen activando la opción Show Components del botón Menu .
- Connected Free Primitives - muestra todas las primitivas de cobre que no pertenecen a componentes como elementos secundarios, agrupadas a su vez por tipo de primitiva (rellenos, polígonos, pistas, vías).
-
Primitive - en el nivel superior, esta entrada indica cuántas primitivas componen el cobre conectado. Las primitivas pueden mostrarse en una lista plana o agrupadas por tipo de primitiva. Esta última opción se configura activando Show Primitive Groups entre las opciones del botón Menu . En ese caso, las primitivas se dividirán en los siguientes grupos:
- Original Net Names - este campo indica el nombre de red asignado actualmente a la primitiva, es decir, la red a la que está conectada actualmente. La entrada será una de las redes definidas para la placa. Sin embargo, si una primitiva no está conectada a ninguna red, tendrá la entrada <Unassigned>.
-
Status - este campo proporciona una entrada de estado de nivel superior para el grupo, que puede tener uno de cuatro estados:
- Blank - la asignación de redes para el grupo de cobre conectado es correcta y no requiere ninguna actualización. La entrada de nivel superior del grupo aparece en verde.
- 1. Update Required - Unassigned Nets - en este estado, ninguna de las primitivas del grupo tiene una red asignada. La entrada de nivel superior del grupo aparece en amarillo.
- 2. Update Required - Some Unassigned Nets - en este estado, algunas primitivas tienen asignada la misma red, pero otras no tienen ninguna red asignada. La entrada de nivel superior del grupo aparece en naranja.
- 3. Ambiguous - Multiple Net Names - en este estado, hay primitivas en el grupo que tienen asignadas redes diferentes. También puede haber primitivas sin asignar. La entrada de nivel superior del grupo aparece en rojo.
-
Action - esta sección ofrece controles para especificar la acción necesaria para resolver los problemas con el cobre conectado, así como el resultado de ejecutar los cambios configurados. Para cada grupo, se presenta lo siguiente:
-
Proposed Action - este campo se utiliza para determinar qué acción se debe realizar, si corresponde. En el nivel superior de un grupo, esta entrada puede establecerse en Update Net To o Don't Update Net To. Al actualizar, seleccione la nueva red de destino en el campo New Net Name. A partir de estos dos ajustes, el software calcula las acciones que se deben realizar en las primitivas secundarias y genera una de las siguientes propuestas:
- No Action Required - la primitiva ya está asignada o conectada a la red de destino.
- Update - incluir la primitiva en la actualización para asignarla o conectarla a la nueva red de destino.
- Don't Update - no incluir la primitiva en la actualización. Permanecerá conectada a su red actual.
- New Net Name - utilice este campo para establecer una nueva red de destino a la que se deben conectar las primitivas. La lista desplegable del campo muestra todas las redes detectadas entre las primitivas del grupo de cobre conectado. Si necesita utilizar otra red, haga clic con el botón derecho en el campo y utilice el comando Change Copper Net To Board Net del menú contextual. Se abrirá el cuadro de diálogo Choose Net, que muestra todas las redes definidas actualmente para la placa. Seleccione la red que necesite y haga clic en OK. Esa red se introducirá en el campo.
- Done - este campo indica si la acción de actualización se ha realizado correctamente o ha fallado después de pulsar el botón Execute y aplicar los cambios.
-
Proposed Action - este campo se utiliza para determinar qué acción se debe realizar, si corresponde. En el nivel superior de un grupo, esta entrada puede establecerse en Update Net To o Don't Update Net To. Al actualizar, seleccione la nueva red de destino en el campo New Net Name. A partir de estos dos ajustes, el software calcula las acciones que se deben realizar en las primitivas secundarias y genera una de las siguientes propuestas:
- Execute - cuando esté satisfecho con las acciones asignadas a la lista de redes, haga clic en este botón para actualizar las asignaciones de redes.
-
Menu - haga clic para acceder al siguiente menú de comandos, relacionados con la lista principal en general o con las primitivas seleccionadas actualmente. Los comandos son idénticos a los disponibles en el menú contextual de la sección de la lista principal.
- Update/Don't Update/No Action - utilícelo para alternar rápidamente la acción propuesta para las primitivas seleccionadas. En un nivel superior de la jerarquía de primitivas, utilícelo para alternar la acción propuesta para todos los elementos descendientes.
- Select All - utilícelo para seleccionar rápidamente todos los grupos de cobre conectado (las entradas de nivel superior de la lista).
- Select All With Same Status - con una entrada de nivel superior de un grupo de cobre conectado seleccionada, utilice este comando para seleccionar rápidamente todos los demás grupos de nivel superior con el mismo estado.
- Clear All Selected - utilícelo para deseleccionar todas las entradas de la lista.
- Expand All In Connected Copper - utilícelo para expandir rápidamente todos los grupos secundarios dentro del grupo de cobre conectado que tiene el foco actualmente.
- Expand All - utilícelo para expandir rápidamente todos los grupos de todos los grupos de cobre conectado de la lista.
- Expand Children - utilícelo para expandir rápidamente todos los grupos descendientes del grupo seleccionado actualmente.
- Collapse All In Connected Copper - utilícelo para contraer rápidamente todos los grupos secundarios dentro del grupo de cobre conectado que tiene el foco actualmente.
- Collapse All - utilícelo para contraer rápidamente todos los grupos de todos los grupos de cobre conectado de la lista.
- Collapse Children - utilícelo para contraer rápidamente todos los grupos descendientes del grupo seleccionado actualmente.
- Only Show Errors - active esta opción para mostrar solo los errores en el cuadro de diálogo. La lista solo mostrará los grupos de cobre conectado cuyo Status sea de nivel 1, 2 o 3. Desactívela para mostrar también el cobre conectado que está correctamente asignado.
- Show Components - active esta opción para agrupar las primitivas de pads de componentes según el componente al que pertenecen.
- Show Primitive Groups - active esta opción para agrupar las primitivas según su tipo.
- Animate Action Execution - active esta opción para que el cuadro de diálogo se desplace por la lista a medida que avanza la ejecución, mostrando de forma animada y en tiempo real el progreso de los cambios de redes. Si desactiva esta opción, los cambios se ejecutarán sin esa animación.
-
Warn On Netlist Change - active esta opción para recibir una advertencia cuando los cambios afecten a la lista de redes de la placa. Se abrirá el cuadro de diálogo Netlist Change, que le indicará cuántas primitivas cambiarán de red y que esto afectará a la lista de redes. Puede hacer clic en Continue o en Filter Affected para examinar con más detalle los cambios propuestos.

El cuadro de diálogo Netlist Change - Show Component Pads - active esta opción para mostrar en la lista las primitivas de componentes conectadas.
- Show Non Component Pads - active esta opción para mostrar en la lista las primitivas libres conectadas.
- Show Changes That Affect Netlist - active esta opción para mostrar únicamente una lista de las acciones propuestas (cambios) que afectarán a la lista de redes de la placa.
- Change Copper Net To - aparecen una o más entradas de menú de este tipo cuando hay pocas redes asignadas actualmente a las primitivas del grupo de cobre conectado que tiene el foco. Utilice una de estas entradas para seleccionar rápidamente la red de destino del campo New Net Name.
- Change Copper Net To Net - esta entrada de menú aparece cuando hay demasiadas redes asignadas actualmente a las primitivas de un grupo de cobre conectado para mostrarlas como entradas de menú individuales. Este comando permite acceder al cuadro de diálogo Choose Net, que muestra todas las redes asignadas actualmente a las primitivas del grupo. Seleccione la red que necesite y haga clic en OK; esa red se introducirá en el campo New Net Name del grupo de cobre conectado que tiene el foco.
- Change Copper Net To Board Net - utilice este comando si necesita utilizar una red distinta de las asignadas actualmente a las primitivas del grupo de cobre conectado que tiene el foco. Se abrirá el cuadro de diálogo Choose Net, que muestra todas las redes definidas actualmente para la placa. Seleccione la red que necesite y haga clic en OK; esa red se introducirá en el campo New Net Name.
- Show All Primitives - haga clic en este botón para mostrar rápidamente todas las primitivas. Este botón estará disponible si las opciones Show Component Pads y/o Show Non Component Pads están desactivadas en el menú.
También puede eliminar todas las redes del documento de diseño actual, vaciando así la lista de redes interna de la PCB. Esto puede ser útil si ha cambiado la información de las redes en los documentos esquemáticos de origen y desea resincronizar por completo la PCB con la información de la lista de redes del esquemático de origen. Para ello, seleccione Design » Netlist » Clear All Nets comando de los menús principales. Tras ejecutar el comando, se abrirá un cuadro de diálogo de confirmación que le advertirá de que esta operación borrará toda la información de las redes de la PCB. Después de hacer clic en Yes, se eliminará toda la información de las redes. Todas las pistas enrutadas permanecerán enrutadas, pero tendrán una asignación No Net. Se eliminarán todas las conexiones lógicas sin enrutar.
Para crear un archivo de lista de redes basado en la conectividad establecida por el enrutamiento del diseño actual, seleccione el comando Design » Netlist » Create Netlist From Connected Copper de los menús principales. Después de hacer clic en Yes en el cuadro de diálogo de confirmación que se abre, se crea una lista de redes (Generated <PCBDocumentName>.Net, añadida al panel Projects como documento libre en la subcarpeta Source Documents) en la misma carpeta que el documento de diseño de PCB y se abre automáticamente como documento activo. Cada red de la lista de redes recibe su nombre de uno de los pads a los que se conecta el cobre enrutado.

