Definición de líneas de plegado - Modo estándar

De un vistazo

Este artículo explica cómo definir, colocar, mover, eliminar y configurar líneas de flexión para regiones flexibles al trabajar en el modo rígido-flexible estándar de Altium Designer. También aclara en qué se diferencia este modo del modo rígido-flexible avanzado, cómo comprobar qué modo utiliza tu placa y qué vistas y paneles del editor se emplean para gestionar las flexiones con precisión. Si buscas una guía práctica para ajustar la posición, el ángulo, el radio, el ancho del área afectada y el orden de plegado en el modo correcto, esta guía te ayudará a trabajar con mayor confianza. Sigue leyendo y aplica estos pasos en tu próximo diseño.

- Aprende cuándo se pueden utilizar las líneas de flexión en el modo rígido-flexible estándar y en qué se diferencia este modo del rígido-flexible avanzado al definir las regiones de la placa.
- Consulta los pasos exactos para colocar, reposicionar, eliminar y alinear con precisión las líneas de flexión en el modo de planificación de la placa.
- Descubre qué propiedades de las líneas de flexión se pueden configurar, incluidos el ángulo de flexión, el radio, el ancho del área afectada y la secuencia de plegado para realizar comprobaciones de plegado en 3D.
Profundiza con IA:

El software de diseño de PCB de Altium dispone de dos modos de diseño rígido-flexible. El modo original, o estándar, denominado Rígido-flexible, admite diseños rígido-flexibles sencillos. Si su diseño tiene requisitos rígido-flexibles más complejos, como regiones flexibles superpuestas, deberá utilizar el modo Rígido-flexible avanzado (también conocido como rígido-flexible 2.0). El modo se selecciona en el menú Tools del Administrador de apilado de capas.

La diferencia fundamental entre los modos es que, en el modo original, la forma de la placa se divide en regiones de placa independientes mediante la colocación de una línea de división, que permanece como un objeto que define dónde termina una región de placa y comienza otra. En el modo avanzado, cada región de placa se coloca por separado o, si se corta una región más grande, esta se convierte en dos objetos de región independientes. En el modo avanzado, los bordes de las regiones de placa adyacentes definen dónde se unen esas dos regiones, y no la presencia de una línea de división. Debido a esta diferencia, no existe ningún objeto de línea de división cuando la placa está en el modo Rígido-flexible avanzado.

► Más información sobre el diseño de una PCB rígido-flexible

El menú View dispone de tres modos de trabajo del editor de PCB con atajos fáciles de recordar, lo que le permite alternar rápidamente entre:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

El comportamiento predeterminado al alternar entre los modos de vista 2D y 3D es conservar ajustes de zoom y orientación independientes para cada modo de vista. Si desea ver la misma ubicación y orientación de la placa al cambiar de modo, pulse Ctrl+Alt+2 o Ctrl+Alt+3, en lugar de 2 o 3.

¿Acaba de abrir una PCB y se pregunta si utiliza el modo rígido-flexible estándar o el avanzado?

Puede abrir el Administrador de apilado de capas para comprobarlo. También puede cambiar al modo de planificación de placa (atajo 1) y observar la barra activa:

Modo Rígido-flexible estándar
Modo Rígido-flexible avanzado

Para definir cómo debe doblarse una placa flexible, se colocan una o más líneas de doblado. La línea de doblado define en qué punto de la superficie de la región flexible se realizará el doblado. También define el ángulo y el radio de doblado, así como el ancho de la franja de superficie de la placa que se dobla. Las líneas de doblado se colocan y editan con el editor de PCB en Board Planning Mode (View » Board Planning Mode, o pulse el atajo 1).

Solo se puede colocar una línea de doblado en una región configurada como región Flex en Layer Stack Manager.


Se coloca una línea de doblado sobre la región flexible y se configura para que la placa pueda doblarse 180 grados. Este vídeo muestra cómo colocar una línea de doblado en el modo Rígido-flexible estándar.

Colocación de una línea de doblado

Para colocar una línea de doblado:

  1. Seleccione View » Board Planning Mode o pulse el atajo 1 para acceder a Board Planning Mode.

  2. Las líneas de doblado se colocan en Multi-Layer. Si la pestaña Mutli-Layer no está visible en la parte inferior del espacio de edición, habilite la capa en el panel View Configuration (atajo L para mostrar el panel).

  3. Seleccione el comando Design » Define Bending Line.

  4. Haga clic dentro de la región de placa donde se colocará la línea de doblado; un extremo de la línea se fijará al borde de la región más cercano al punto donde haya hecho clic y el otro extremo quedará unido al cursor.

  5. Sitúe el segundo extremo en la ubicación deseada y haga clic una vez para colocarlo.

  6. Permanecerá en el modo de colocación de líneas de doblado, listo para colocar otra si es necesario. De lo contrario, haga clic con el botón derecho o pulse Esc para salir del modo de colocación de líneas de doblado.

El panel PCB en el modo Layer Stack Regions muestra datos de Bending Lines. Haga doble clic en una entrada para abrir el cuadro de diálogo Línea de doblado. 

Se han colocado tres líneas de doblado en esta región de placa flexible. El ancho de la franja naranja corresponde al ancho del área afectada.
Se han colocado tres líneas de doblado en esta región de placa flexible. El ancho de la franja naranja corresponde al ancho del área afectada.

Cuando una región de placa se configura para utilizar un apilado de capas flexible, se añade automáticamente una línea de doblado vertical que pasa por su centro geométrico. Elimine esta línea de doblado o cambie su posición y configúrela según sea necesario.

Desplazamiento de una línea de doblado

Para modificar la ubicación de una línea de doblado existente:

  1. Seleccione View » Board Planning Mode (o pulse el atajo  1) para acceder a Board Planning Mode.
  2. Haga clic una vez para seleccionar la región de placa que contiene la línea de doblado. Se mostrarán los controles de todas las líneas de doblado de esa región.
  3. Para reubicar el extremo de una línea, haga clic en el nodo, mantenga pulsado el botón y arrástrelo hasta la ubicación deseada en el perímetro del contorno de la región de placa. El cursor quedará restringido a la cuadrícula de ajuste actual y/o a los objetos de diseño existentes.
  4. La ubicación del doblado se redefinirá según la nueva posición de la línea de doblado.

Seleccione y arrastre un nodo de extremo de una línea de doblado para cambiar la posición del doblado en la placa.
Seleccione y arrastre un nodo de extremo de una línea de doblado para cambiar la posición del doblado en la placa.

Posicionamiento preciso de una línea de doblado

Cuando se desplaza una línea de doblado, el control se ajusta a las posiciones de la cuadrícula de ajuste actual. Durante el desplazamiento, también puede ajustarse a objetos de diseño existentes, como líneas de una capa mecánica. La imagen siguiente muestra cómo se sitúa un control de línea de doblado en el extremo de una línea de la capa Mechanical 2 (resaltado con el número 1). Tenga en cuenta que la capa mecánica debe ser la capa de diseño activa para que funcione el ajuste.

El número 1 indica un control de línea de doblado que se ajusta a una línea de Mechanical 2; observe que esta es la capa activa.
El número 1 indica un control de línea de doblado que se ajusta a una línea de Mechanical 2; observe que esta es la capa activa.

Para mostrar el proceso anterior con más detalle, las imágenes siguientes muestran las líneas de construcción que se han colocado en Mechanical 2 en 2D Layout Mode y que definen con precisión los puntos de referencia superior e inferior que pueden utilizarse para colocar una línea de doblado a 45 grados.

La placa en modo de diseño 2D con las líneas de construcción que ayudan a colocar con precisión las líneas de doblado diagonales.La placa en modo de diseño 2D con las líneas de construcción que ayudan a colocar con precisión las líneas de doblado diagonales.

La placa en modo de planificación de placa con las líneas de doblado diagonales que se ajustaron a las líneas de construcción de Mechanical 2.La placa en modo de planificación de placa con las líneas de doblado diagonales que se ajustaron a las líneas de construcción de Mechanical 2.

Eliminación de una línea de doblado

Para eliminar una línea de doblado:

  1. Seleccione View » Board Planning Mode (o pulse el atajo 1) para acceder a Board Planning Mode.
  2. Haga clic en uno de sus extremos y mantenga pulsado el botón; a continuación, pulse la tecla Delete. También puede seleccionar y eliminar una entrada de línea de doblado en la región Bending Lines del panel PCB .

Cuando una región de placa se configura para utilizar un apilado de capas flexible, se añade automáticamente una línea de doblado vertical que pasa por su centro geométrico. Elimine esta línea de doblado o cambie su posición y configúrela según sea necesario.

Configuración de las propiedades de la línea de doblado

Las regiones de placa, las líneas de división y las líneas de doblado se inspeccionan y editan en Board Planning Mode (pulse 1). Las líneas de doblado pueden editarse de forma interactiva en el espacio de diseño o mediante PCB panel cuando está configurado en el modo Layer Stack Regions. Para mostrar el panel, haga clic en el botón Panels situado en la esquina inferior derecha de Altium Designer y, a continuación, seleccione PCB en el menú. En el panel, seleccione Layer Stack Regions en la lista desplegable de la parte superior. En este modo, el panel muestra:

  • Los apilados de capas de la placa disponibles en la región Layer Stacks.
  • Las regiones asignadas a esos apilados en la región Stackup Regions.
  • Las líneas de plegado definidas en la región seleccionada en la región Bending Lines.

Al acceder a Board Planning Mode, el panel PCB se configurará automáticamente en el modo Layer Stack Regions.

Para editar las propiedades de una línea de plegado en el panel PCB:

  1. Las líneas de plegado se pueden editar tanto en 2D Layout Mode (pulse 2) como en Board Planning Mode (pulse 1).
  2. Active la casilla Select en la parte superior del panel.
  3. Seleccione la región de la placa que contiene la línea de plegado en el área Stackup Regions del panel PCB .
  4. Seleccione la línea de plegado en la lista de la región Bending Lines del panel. La línea de plegado se resaltará (quedará seleccionada) en la placa si la opción Select del panel PCB está activada. También se puede eliminar una entrada de línea de plegado de la región Bending Lines.
  5. Haga doble clic en la entrada de la línea de plegado en la región Bending Lines para abrir el cuadro de diálogo Bending Line, como se muestra en la siguiente imagen.

  6. En el cuadro de diálogo Bending Line, edite dos de las tres primeras propiedades, por ejemplo, Radius (la distancia entre la superficie de plegado y el punto central del plegado) y Bending Angle (el ángulo que debe plegarse la superficie de la región flexible). La tercera propiedad, Affected area width (la anchura de la superficie que se plegará para los valores indicados de Radius y Bending Angle), se calculará automáticamente (se explica con más detalle a continuación). Tenga en cuenta que Affected area width de cada línea de plegado se muestra como una región sombreada en naranja.
  7. En el cuadro de diálogo Bending Line, configure Fold Index según sea necesario para definir la secuencia de plegado cuando se utilice el control deslizante Fold State del panel PCB o el comando View » Fold/Unfold, que permiten plegar la placa en modo 3D. El pliegue con el valor más bajo se aplica primero, y se continúa hasta el valor más alto.

Una región de la placa debe tener activada la casilla 3D Locked en el cuadro de diálogo Board Region para definir la referencia física del suelo para el modo de visualización 3D (donde Z = 0). Si no se hace esto, no se mostrará Affected area width para cada línea de plegado definida.

También se puede acceder al cuadro de diálogo Bending Line pulsando Tab mientras se coloca o se mueve un controlador de una línea de plegado, o haciendo doble clic en uno de estos controladores.

Resumen de la definición de pliegues

Una línea de plegado es un objeto lineal que se coloca a través de una región para definir la ubicación, el radio y el ángulo del pliegue que se aplicará a esa región flexible de la placa.

Definición de una línea de plegado:

  • Las líneas de plegado se colocan en el modo de planificación de la placa (atajo 1).
  • Para colocar una línea de plegado, ejecute el comando Design » Define Bending Line.
  • Coloque la línea de plegado de modo que atraviese la región flexible de la placa. No es necesario que el inicio y el final de la línea de plegado toquen con precisión cada borde de la región; el software la alargará automáticamente (si es demasiado corta) o la acortará (si es demasiado larga). Al menos un extremo de la línea de plegado debe tocar o sobrepasar el borde de la región.
  • Para editar las propiedades de una línea de plegado, haga clic en cualquier punto de la región para mostrar los vértices de todas las líneas de plegado de esa región y, a continuación:
    • Haga doble clic en el vértice de una línea de plegado para abrir el cuadro de diálogo Línea de plegado, o
    • Muestre el panel PCB y configúrelo en el modo Layer Stack Regions, donde podrá examinar y editar las regiones y las líneas de plegado.
    • Configure Bending Angle y Radius del pliegue según sea necesario.
    • Los pliegues se realizan en el orden de su Fold Index; utilice esta función cuando sea importante comprobar el orden de plegado.
  • Para mover una línea de plegado, haga clic en cada vértice y arrástrelo.
  • Para eliminar una línea de plegado, haga clic y mantenga pulsado uno de sus vértices y, a continuación, pulse Delete en el teclado.
  • Las líneas de plegado no se pueden aplicar al borde de un recorte de la placa. Si su placa lo requiere, cambie al modo rígido-flexible avanzado.
AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents