Création d’un modèle de simulation
En un coup d'œil
- Comment créer ou obtenir des modèles de simulation, notamment à partir de fichiers téléchargés auprès des fabricants, de modèles textuels copiés et de fichiers de sous-circuits rédigés manuellement.
- Comment créer, enregistrer, lier et modifier des modèles de simulation dans Altium Designer et dans un Workspace connecté.
- Quelles informations sont nécessaires pour définir correctement un modèle de simulation, notamment les noms des modèles, les fichiers référencés et les paramètres propres au modèle.
Pour simuler un circuit à l’aide du simulateur de circuits à signaux mixtes d’Altium Designer, tous les composants du circuit doivent être prêts pour la simulation, c’est-à-dire qu’un modèle de simulation doit être associé à chacun d’eux.
Le type de modèle et la manière de l’obtenir dépendent en grande partie du composant et, dans une certaine mesure, des préférences du concepteur. De nombreux fabricants de composants fournissent des modèles de simulation correspondant aux composants qu’ils fabriquent. Généralement, il suffit de télécharger le fichier de modèle requis et de l’associer au composant du schéma. En savoir plus sur l’ajout de modèles de simulation à la conception.
Certains modèles doivent être créés de toutes pièces, par exemple en utilisant la syntaxe hiérarchique des sous-circuits pour créer le fichier de modèle de sous-circuit requis (*.ckt).
Création d’un nouveau modèle de simulation
Certains modèles sont proposés par les fabricants et les fournisseurs sous forme de fichiers texte téléchargeables. Parfois, les données du modèle sont présentées sous forme de texte sur une page Web plutôt que dans un fichier à télécharger. Dans ce cas, vous pouvez créer un nouveau fichier de modèle dans Altium Designer et y copier-coller le contenu de la page Web. Utilisez la commande appropriée dans le sous-menu File » New » Mixed Simulation, comme illustré ci-dessous.

Commandes permettant de créer un nouveau fichier de modèle vide.
Vous pouvez ensuite copier-coller les informations du fichier de modèle dans l’éditeur de modèles.

Exemple de contenu textuel d’un modèle de simulation.
Création d’un modèle de simulation dans l’espace de travail
Altium Designer, associé à un espace de travail connecté, permet de créer et de gérer des modèles de simulation dans l’espace de travail. Une fois créé, un modèle de simulation de l’espace de travail peut être utilisé pour créer un ou plusieurs composants de l’espace de travail.
Bien que les modèles de simulation de l’espace de travail soient créés automatiquement lorsque vous ajoutez un fichier de modèle de simulation à un composant en cours de définition dans l’éditeur de composants en mode d’édition d’un seul composant puis enregistrez ce composant dans votre espace de travail, vous pouvez également créer des modèles de simulation directement dans l’espace de travail, comme décrit ci-dessous.
-
Ouvrez le panneau Components et activez l’affichage des modèles en cliquant sur le bouton
en haut du panneau, puis en sélectionnant Models.
-
Accédez à la catégorie Simulations et sélectionnez Create Component dans le menu du bouton
.

Accédez aux modèles de simulation dans le panneau Components et sélectionnez la commande permettant de créer un nouveau modèle -
Dans la boîte de dialogue Create New Item qui s’ouvre, saisissez les informations requises, assurez-vous que l’option Open for editing after creation est activée, puis cliquez sur OK. Le modèle de simulation de l’espace de travail est créé et l’éditeur temporaire SimModel s’ouvre, présentant un document
.SimModelcomme document actif dans l’espace de conception. Ce document est nommé d’après l’élément et sa révision, au format suivant :<Item><Revision>.SimModel(par exemple,SIM-001-0001-1.SimModel).
Exemple de modification de la révision initiale d’un modèle de simulation de l’espace de travail : l’éditeur temporaire SimModel fournit le document permettant de définir votre modèle de simulation. - Utilisez ce document pour définir le modèle de simulation de l’espace de travail selon vos besoins. Pour plus d’informations à ce sujet, consultez Définition du modèle de simulation.
- Enregistrez le modèle dans l’espace de travail à l’aide de la commande Save to Server située à droite de l’entrée du modèle de simulation dans le panneau Projects. La boîte de dialogue Edit Revision s’affiche. Vous pouvez y modifier le nom et la description, et ajouter des notes de publication si nécessaire. Le document et l’éditeur se ferment après l’enregistrement.
-
Le document contenant la définition source du modèle de simulation,
*.SimModel, est stocké dans la révision du modèle de simulation de l’espace de travail. Le modèle de simulation est présenté dans le panneau Components, dans la catégorie Simulations.
Modèle de simulation de l’espace de travail enregistré, affiché dans le panneau ComponentsLes données enregistrées dans l’espace de travail comprennent la définition du modèle dans le fichier
.SimModel, ainsi que tout fichier.mdlou.cktréférencé. Dans le panneau Explorer, passez à l’onglet de vue Preview, puis cliquez sur un fichier référencé pour afficher un aperçu de son contenu. Les paramètres du modèle sont également présentés, le cas échéant.
Parcourez le modèle de simulation de l’espace de travail enregistré dans le panneau Explorer. Passez à l’onglet de vue Preview pour consulter les données enregistrées.
Un modèle de simulation de l’espace de travail enregistré peut ensuite être associé à un composant de l’espace de travail lors de la définition de ce composant dans l’éditeur de composants, en mode d’édition d’un seul composant ou d’édition de composants par lots.
Définition du modèle de simulation
Les informations requises pour définir le modèle dans un fichier SimModel sont les suivantes :
-
Model Name – utilisez ce champ pour spécifier le nom du modèle. Lors de l'enregistrement dans l'espace de travail, cette entrée sera utilisée comme Name de la révision de l'élément de modèle de simulation.
Lorsque vous référencez un fichier MDL, le nom doit être celui qui apparaît sur la ligne
.MODELde la définition du modèle. Prenons l'exemple d'un modèle de diode dont la définition est la suivante :.MODEL 1N4002 D(IS=2.55E-9 RS=0.042 N=1.75 TT=5.76E-6 CJO=1.85E-11 + VJ=0.75 M=0.333 BV=100 IBV=1E-5 )Le nom du modèle est ici
1N4002. C'est ce nom qui doit être saisi dans le champ Model Name.Lorsque vous référencez un fichier CKT, le nom doit être celui qui apparaît sur la ligne
.SUBCKTde la définition du modèle. Prenons l'exemple d'un modèle de fusible dont la définition est la suivante :.SUBCKT FUSE 1 2 PARAMS: CURRENT=1 RESISTANCE=1m SW1 1 2 3 0 SMOD OFF BNLV 3 0 V=(abs(v(1,2)))
.MODEL SMOD SW (VT=\{(CURRENT*RESISTANCE)\} RON=1g ROFF=\{RESISTANCE\})
.ENDS FUSELe nom du modèle est ici
FUSE. C'est ce nom qui doit être saisi dans le champ Model Name. -
Model File – pour un modèle défini à l'aide d'un fichier
.mdlou.ckt, utilisez le bouton Browse pour sélectionner le fichier requis dans une bibliothèque disponible. - Description – saisissez une description du modèle, par exemple sa fonction. Lors de l'enregistrement dans l'espace de travail, cette entrée sera utilisée comme Description de la révision du modèle de simulation.
- Parameters – paramètres du modèle (voir Paramètres au niveau du modèle).
-
Model Preview – affichage en lecture seule du contenu du fichier
.mdlou.cktréférencé.
Paramètres au niveau du modèle
Le cas échéant, les paramètres au niveau du modèle peuvent être définis directement dans le fichier SimModel, puisqu'ils font naturellement partie de la définition d'un modèle. La zone Parameters du document est automatiquement renseignée avec les paramètres applicables au modèle choisi. Les valeurs des paramètres peuvent être modifiées directement sur place : cliquez sur le champ Parameter Value associé à un paramètre dans la liste et saisissez directement la valeur requise.

Définissez les paramètres du modèle dans le cadre de sa définition, en les modifiant directement sur place.
Modification d'un modèle de simulation de l'espace de travail
À tout moment, vous pouvez revenir à un modèle de simulation de l'espace de travail et le modifier directement. Sélectionnez la catégorie Simulations dans le panneau Components (l'option Models doit être activée dans le menu
du panneau pour accéder à cette catégorie), faites un clic droit sur l'entrée d'un modèle de simulation et choisissez la commande Edit dans le menu contextuel. L'éditeur temporaire s'ouvre à nouveau, avec le fichier contenant la définition source du modèle de simulation, inclus dans le modèle de simulation de l'espace de travail, ouvert pour modification. Effectuez les modifications nécessaires, puis enregistrez le document dans la révision suivante du modèle de simulation de l'espace de travail.
Génération de fichiers SimModel
Les fichiers SimModel peuvent être générés à partir du document de bibliothèque de schémas ou de bibliothèque de base de données actif à l'aide de la commande Tools » Generate SimModel Files.
Après le lancement de la commande, la boîte de dialogue Generate SimModel Files s'affiche. Chaque fichier SimModel (et la définition du modèle de simulation qu'il contient) est créé à partir du lien vers le modèle de simulation d'un composant de schéma dans la bibliothèque de schémas active (ou des informations de simulation d'un enregistrement de composant dans la bibliothèque de base de données active). Utilisez les commandes de la boîte de dialogue pour configurer la génération d'un ou de plusieurs fichiers SimModel selon vos besoins. Par défaut, un sous-dossier nommé Sim Models est créé. Si nécessaire, remplacez ce nom par un nom plus approprié. Si le dossier désigné existe, il sera utilisé ; sinon, il sera créé.

La boîte de dialogue Generate SimModel Files
Après avoir défini les options selon vos besoins, cliquez sur OK. La génération s'effectue et une boîte de dialogue de confirmation s'affiche une fois le processus terminé, indiquant le nombre de fichiers SimModel générés. Tous les fichiers .mdl, .ckt ou .scb référencés sont également stockés avec les fichiers SimModel.
Si vous migrez depuis une bibliothèque intégrée, les bibliothèques de schémas sources (SchLib) peuvent être obtenues en ouvrant le fichier IntLib dans Altium Designer et en choisissant d'extraire les bibliothèques sources. Lors de la génération de fichiers SimModel à partir d'une bibliothèque de base de données, seuls les composants des tables actuellement activées sont pris en compte.
La dénomination des fichiers SimModel dépend du type de bibliothèque source :
- Schematic Library - chaque fichier SimModel est nommé d'après le nom du modèle de simulation. Lorsque plusieurs composants de schéma incluent la même implémentation de modèle de simulation (modèle de simulation portant le même nom), un seul fichier SimModel est généré sous ce nom.
- Database Library - chaque fichier SimModel est nommé d'après le nom du modèle de simulation, tel qu'il est spécifié dans le champ Sim Model Name d'un enregistrement de composant. Lorsque plusieurs enregistrements de composants (dans les tables activées) incluent la même implémentation de modèle de simulation (même entrée dans le champ Sim Model Name), un seul fichier SimModel est généré sous ce nom.
Assistant de création de modèles SPICE
Certains modèles de composants analogiques intégrés à SPICE permettent d’utiliser un fichier de modèle associé (*.mdl) pour définir de manière paramétrique des caractéristiques comportementales avancées (par exemple, résistance à semi-conducteur, diode, BJT). La création manuelle de ce fichier de modèle, puis son association manuelle au composant de schéma requis, peuvent être assez fastidieuses. Le SPICE Model Wizard facilite cette tâche. Cet assistant permet de définir les caractéristiques d’un tel composant à partir de données recueillies par l’utilisateur. Les paramètres, saisis directement ou extraits des données fournies, sont automatiquement écrits dans un fichier de modèle, qui est ensuite associé au composant de schéma désigné.
Le SPICE Model Wizard offre une solution pratique et semi-automatisée pour créer et associer un modèle de simulation SPICE pour différents composants analogiques, intégrés à SPICE et nécessitant un fichier de modèle associé (*.mdl). Les caractéristiques comportementales du modèle sont définies à partir des informations que vous fournissez à l’assistant. La quantité d’informations requises dépend du type de composant pour lequel vous souhaitez créer un modèle : elle va de la simple saisie des paramètres du modèle à la saisie de données issues de la fiche technique du fabricant ou de mesures effectuées sur le composant physique lui-même.
Les sections suivantes décrivent l’utilisation de l’assistant, de son ouverture à la vérification du modèle.
Accéder à l’assistant
L’assistant est accessible depuis l’éditeur de symboles de schéma en choisissant la commande Tools » XSpice Model Wizard dans les menus principaux.

La page initiale du SPICE Model Wizard
Sur les deux pages suivantes de l’assistant, vous pourrez choisir :
- Le composant que vous souhaitez modéliser, dans la liste des types de composants pris en charge.
- Si le modèle SPICE généré doit être ajouté à un composant existant du document de bibliothèque ou à un nouveau composant créé par l’assistant et ajouté à ce document.
Types de composants pris en charge
L’assistant permet de créer des modèles SPICE pour les types de composants analogiques suivants :
- Diode
- Condensateur à semi-conducteur
- Résistance à semi-conducteur
- Interrupteur commandé en courant
- Interrupteur commandé en tension
- Transistor bipolaire à jonction
- Ligne de transmission avec pertes
- Ligne de transmission RC à paramètres uniformément répartis
Nommer le modèle
L’une des étapes les plus importantes au fil des pages de l’assistant consiste à attribuer un nom au modèle que vous créez. Vous ne pourrez d’ailleurs pas passer à l’étape de définition des paramètres de l’assistant tant que vous n’aurez pas saisi de nom.
Après la création, ce nom apparaîtra dans le champ Model Name de la boîte de dialogue Sim Model. Le fichier de modèle lui-même est également créé sous ce nom (<ModelName>.mdl). Lorsque vous utilisez l’assistant pour ajouter un modèle à un nouveau composant de bibliothèque, le nom spécifié pour le modèle est également utilisé pour nommer le composant.
Lorsque vous nommez le modèle, vous pouvez aussi saisir une courte description. Celle-ci peut indiquer la fonction du modèle (par exemple, Semiconductor Resistor) ou faire référence plus précisément à une valeur ou à une configuration (par exemple, NPN BJT).
Caractéristiques à modéliser
Après avoir nommé le modèle, vous accéderez à une ou plusieurs pages consacrées aux caractéristiques à modéliser. Les types de modèles pris en charge par l’assistant peuvent être répartis dans les deux groupes suivants :
- Les modèles nécessitant la saisie directe des valeurs de différents paramètres du modèle. Pour en savoir plus, consultez la section Modèles de composants créés par saisie directe des paramètres.
- Les modèles nécessitant la saisie de données à partir desquelles sont extraits les paramètres définissant les caractéristiques choisies du composant. Les données saisies proviennent soit de mesures directes effectuées sur le composant physique, soit de la fiche technique du fabricant. Pour en savoir plus, consultez la section Modèles de composants créés par extraction des paramètres à partir de données.
Générer le modèle
Après la définition des données ou paramètres requis, l’assistant affiche le modèle généré. Il s’agit du contenu qui sera enregistré dans le fichier MDL.

Aperçu du contenu du fichier de modèle généré.
Vous pouvez modifier le modèle directement sur cette page, ce qui vous permet de maîtriser entièrement sa définition.
Une fois la définition du modèle satisfaisante, cliquez sur Next pour passer à la dernière étape de l’assistant. Cliquez sur Finish pour enregistrer le modèle. Utilisez la boîte de dialogue Save SPICE Model File pour choisir l’emplacement d’enregistrement du fichier MDL obtenu. Par défaut, le fichier est enregistré dans le même répertoire que le document de bibliothèque de schémas. Vous pouvez également modifier le nom du fichier à ce stade, si vous le souhaitez.
Si vous avez demandé à associer le modèle à un nouveau composant, celui-ci sera créé et ajouté au document de bibliothèque.
Modèles de composants créés par saisie directe des paramètres
Pour les modèles de composants suivants, l’assistant n’extrait pas les paramètres à partir des données saisies. Les modèles sont créés par saisie directe des valeurs de leurs paramètres respectifs. Lors de la saisie des valeurs des paramètres, gardez les points suivants à l’esprit :
- Si aucune valeur n’est spécifiée pour un paramètre, aucune entrée correspondante ne figurera dans le fichier de modèle créé. Dans ce cas, la valeur par défaut stockée en interne dans SPICE sera utilisée. Autrement dit, si une valeur est spécifiée pour un paramètre dans un fichier de modèle, elle remplace la valeur par défaut de ce paramètre.
- Si la valeur affichée par défaut pour un paramètre dans l’assistant est « - » et qu’aucune valeur n’est explicitement saisie pour ce paramètre, une valeur par défaut de zéro, interne à SPICE, sera utilisée pour les calculs.
Condensateur à semi-conducteur
Les paramètres suivants peuvent être définis pour ce modèle de composant à l’aide de l’assistant. La saisie d’une valeur entraîne l’écriture du paramètre correspondant dans le fichier MDL généré.
CJ |
Capacité du fond de jonction (en F/m²). |
|
CJSW |
Capacité des parois latérales de la jonction (en F/m). |
|
DEFW |
Largeur par défaut du composant (en mètres). (Valeur par défaut = 1e-6). |
|
NARROW |
Réduction de largeur due à la gravure latérale (en mètres). (Valeur par défaut = 0). |
Résistance à semi-conducteur
Les paramètres suivants peuvent être définis pour ce modèle de composant à l'aide de l'assistant. La saisie d'une valeur entraîne l'écriture du paramètre correspondant dans le fichier MDL généré.
TC1 |
Coefficient de température du premier ordre (en ohms/°C). (Valeur par défaut = 0) |
|
TC2 |
Coefficient de température du second ordre (en ohms/°C²). (Valeur par défaut = 0) |
|
RSH |
Résistance par carré (en ohms). |
|
DEFW |
Largeur par défaut (en mètres). (Valeur par défaut = 1e-6). |
|
NARROW |
Rétrécissement dû à la gravure latérale (en mètres). (Valeur par défaut = 0). |
|
TNOM |
Température de mesure des paramètres (en °C). Si aucune valeur n'est spécifiée, la valeur par défaut attribuée à TNOM dans l'onglet Advanced de la boîte de dialogue Advanced Analyses Settings sera utilisée (valeur par défaut = 27). |
Interrupteur commandé en courant
Les paramètres suivants peuvent être définis pour ce modèle de composant à l'aide de l'assistant. La saisie d'une valeur entraîne l'écriture du paramètre correspondant dans le fichier MDL généré.
IT |
Courant de seuil (en ampères). (Valeur par défaut = 0). |
|
IH |
Courant d'hystérésis (en ampères). (Valeur par défaut = 0). |
|
RON |
Résistance à l'état passant (en ohms). (Valeur par défaut = 1). |
|
ROFF |
Résistance à l'état bloqué (en ohms). Par défaut, elle est définie sur 1/GMIN. GMIN est un paramètre SPICE avancé, spécifié dans l'onglet Advanced de la boîte de dialogue Advanced Analyses Settings. Il définit la conductance minimale (résistance maximale) de tout composant du circuit. Sa valeur par défaut est de 1e-12 mhos, ce qui donne une valeur par défaut de 1000 GΩ pour ROFF. |
Interrupteur commandé en tension
Les paramètres suivants peuvent être définis pour ce modèle de composant à l'aide de l'assistant. La saisie d'une valeur entraîne l'écriture du paramètre correspondant dans le fichier MDL généré.
VT |
Tension de seuil (en volts). (Valeur par défaut = 0). |
|
VH |
Tension d'hystérésis (en volts). (Valeur par défaut = 0). |
|
RON |
Résistance à l'état passant (en ohms). (Valeur par défaut = 1). |
|
ROFF |
Résistance à l'état bloqué (en ohms). Par défaut, elle est définie sur 1/GMIN. GMIN est un paramètre SPICE avancé, spécifié dans l'onglet Advanced de la boîte de dialogue Advanced Analyses Settings. Il définit la conductance minimale (résistance maximale) de tout composant du circuit. Sa valeur par défaut est de 1e-12 mhos, ce qui donne une valeur par défaut de 1000 GΩ pour ROFF. |
Ligne de transmission avec pertes
Les paramètres suivants peuvent être définis pour ce modèle de composant à l'aide de l'assistant. La saisie d'une valeur (ou l'activation d'une option) entraîne l'écriture du paramètre correspondant dans le fichier MDL généré.
R |
Résistance par unité de longueur (en ohms/unité). (Valeur par défaut = 0). |
|
L |
Inductance par unité de longueur (en henrys/unité). (Valeur par défaut = 0). |
|
G |
Conductance par unité de longueur (en mhos/unité). (Valeur par défaut = 0). |
|
C |
Capacité par unité de longueur (en farads/unité). (Valeur par défaut = 0). |
|
LEN |
Longueur de la ligne de transmission. |
|
REL |
Contrôle des points de rupture (en unités arbitraires). (Valeur par défaut = 1). |
|
ABS |
Contrôle des points de rupture (en unités arbitraires). (Valeur par défaut = 1). |
|
NOSTEPLIMIT |
Option qui, lorsqu'elle est activée, supprime la contrainte imposant des pas de temps inférieurs au retard de la ligne. (Par défaut = désactivée). |
|
NOCONTROL |
Option qui, lorsqu'elle est activée, empêche la limitation du pas de temps fondée sur des critères d'erreur de convolution. (Par défaut = désactivée). |
|
LININTERP |
Option qui, lorsqu'elle est activée, utilise une interpolation linéaire au lieu de l'interpolation quadratique par défaut pour le calcul des signaux retardés. (Par défaut = désactivée). |
|
MIXEDINTERP |
Option qui, lorsqu'elle est activée, utilise un critère pour déterminer si l'interpolation quadratique est applicable et, dans le cas contraire, utilise une interpolation linéaire. (Par défaut = désactivée). |
|
COMPACTREL |
Grandeur spécifique utilisée pour contrôler la compression des valeurs historiques utilisées pour la convolution. Par défaut, cette grandeur utilise la valeur spécifiée pour le paramètre de tolérance d'erreur relative de simulation (RELTOL), défini dans l'onglet Advanced de la boîte de dialogue Advanced Analyses Settings. |
|
COMPACTABS |
Grandeur spécifique utilisée pour contrôler la compression des valeurs historiques utilisées pour la convolution. Par défaut, cette grandeur utilise la valeur spécifiée pour le paramètre de tolérance d'erreur absolue sur le courant (ABSTOL), défini dans l'onglet Advanced de la boîte de dialogue Advanced Analyses Settings. |
|
TRUNCNR |
Option qui, lorsqu'elle est activée, permet d'utiliser la méthode itérative de Newton-Raphson pour déterminer un pas de temps approprié dans les routines de contrôle du pas de temps. (Par défaut = désactivée ; une méthode par essais successifs est alors utilisée, en divisant à chaque fois le pas de temps précédent par deux). |
|
TRUNCDONTCUT |
Option qui, lorsqu'elle est activée, supprime la réduction par défaut du pas de temps destinée à limiter les erreurs lors du calcul effectif des grandeurs liées à la réponse impulsionnelle. (Par défaut = désactivée). |
Ligne de transmission RC à paramètres uniformément répartis
Les paramètres suivants peuvent être définis pour ce modèle de composant à l'aide de l'assistant. La saisie d'une valeur entraîne l'écriture du paramètre correspondant dans le fichier MDL généré.
K |
Constante de propagation. (Valeur par défaut = 2). |
|
FMAX |
Fréquence maximale d'intérêt (en hertz). (Valeur par défaut = 1.0G). |
|
RPERL |
Résistance par unité de longueur (en ohms/mètre). (Valeur par défaut = 1000). |
|
CPERL |
Capacité par unité de longueur (en farads/mètre). (Valeur par défaut = 1.0e-15). |
|
ISPERL |
Courant de saturation par unité de longueur (en ampères/mètre). (Valeur par défaut = 0). |
|
RSPERL |
Résistance de la diode par unité de longueur (en ohms/mètre). (Valeur par défaut = 0). |
Modèles de composants créés par extraction de paramètres à partir de données
Pour les diodes et les transistors bipolaires (BJT), l’assistant extrait les informations relatives aux paramètres à partir des données que vous saisissez. Les paramètres extraits pour être inclus dans le fichier de modèle dépendent des caractéristiques particulières de la diode ou du transistor BJT que vous avez choisi de modéliser.
La méthode de saisie des données varie selon les caractéristiques. Dans certains cas, vous devrez saisir directement des valeurs numériques ; dans d’autres, des points relevés sur une courbe. Dans tous les cas, les données proviennent de mesures directes sur le composant, de la fiche technique du fabricant ou d’une combinaison des deux.
Lorsque vous devez saisir des données issues d’une courbe, entrez une série de points relevés sur le graphique source dans la grille fournie par l’assistant. Si vos données sont enregistrées au format de valeurs séparées par des virgules (*.csv), vous pouvez les importer à l’aide du bouton Import Data disponible. L’assistant utilise les données saisies pour extraire les paramètres requis pour le modèle. Les résultats de l’extraction sont présentés sur une page suivante de l’assistant : les valeurs des paramètres extraits, ainsi qu’un graphique comparant les données saisies aux valeurs calculées à l’aide de ces paramètres. L’image ci-dessous illustre un exemple de cet affichage des résultats.

Saisissez les données sources pour permettre à l’assistant d’extraire les paramètres requis pour le modèle.
Vous pouvez modifier les valeurs des paramètres extraits pour affiner davantage la précision du modèle de diode. Le graphique comparatif est mis à jour pour refléter les modifications.
Diode
Les sections suivantes détaillent chacune des caractéristiques que vous pouvez choisir de modéliser pour une diode. Chaque section présente les paramètres extraits et les données sources dont l’assistant a besoin pour les extraire.
Courant en polarisation directe
Les paramètres suivants servent à décrire les caractéristiques courant-tension en régime continu de la diode dans la zone de polarisation directe :
IS |
Courant de saturation (en ampères). |
|
N |
Coefficient d’émission. |
|
RS |
Résistance ohmique (en ohms). |
Pour extraire ces paramètres, une courbe du courant direct de la diode (IF) en fonction de sa tension directe (VF) est nécessaire. Cette courbe peut provenir de la fiche technique du fabricant ou de mesures effectuées sur un composant physique.
L’image ci-dessous présente un exemple de courbe issue d’une fiche technique, ainsi qu’un exemple de circuit de test permettant d’effectuer des mesures directes pour obtenir les données sources requises.

Exemples de courbe et de circuit pour les caractéristiques I-V d’une diode dans la zone de polarisation directe.
Les données sont saisies dans l’assistant sous la forme d’une série de points relevés sur la courbe source.
Capacité de jonction en polarisation inverse
Les paramètres suivants servent à décrire la capacité de la diode lorsqu’elle fonctionne dans la zone de polarisation inverse :
CJO |
Capacité de jonction à polarisation nulle (en farads). |
|
M |
Coefficient de gradation. |
|
VJ |
Potentiel de jonction (en volts). |
Pour extraire ces paramètres, une courbe de la capacité en polarisation inverse (Cd) en fonction de la tension inverse de la diode (VR) est nécessaire. Cette courbe peut provenir de la fiche technique du fabricant ou de mesures effectuées sur un composant physique.
L’image présente un exemple de courbe issue d’une fiche technique, ainsi qu’un exemple de circuit de test permettant d’effectuer des mesures directes pour obtenir les données sources requises. Ce circuit peut être utilisé si vous ne disposez pas d’un capacimètre.

Exemples de courbe et de circuit pour la capacité d’une diode dans la zone de polarisation inverse.
Les données sont saisies dans l’assistant sous la forme d’une série de points relevés sur la courbe source.
L’exemple de circuit présenté dans l’image ci-dessus repose sur l’équation suivante :
I = C * (dv/dt)
En isolant C dans cette équation, on obtient :
C = I/(dv/dt)
Le circuit produit une rampe de tension à partir de la source V1. Le calcul de la pente de cette rampe permet d’obtenir le terme dv/dt de l’équation. En divisant le courant mesuré dans la diode par la pente de la rampe de tension, on obtient la courbe de capacité de la diode.
Courant en polarisation inverse
Les paramètres suivants servent à décrire le courant du composant en polarisation inverse après claquage :
BV |
Tension de claquage inverse (en volts). |
|
IBV |
Courant à la tension de claquage (en ampères). |
Pour extraire ces paramètres, l’assistant nécessite la saisie des deux valeurs suivantes :
-
Valeur de la tension de claquage inverse.
-
Valeur du courant traversant la diode au point de claquage inverse.
Ces valeurs peuvent provenir de la fiche technique du fabricant ou de mesures effectuées sur un composant physique. Les fiches techniques présentent généralement les caractéristiques électriques en régime continu d’une diode sous forme de tableau. Il suffit donc de repérer ces valeurs et de les saisir exactement telles qu’elles sont indiquées.
Si les données sources sont présentées sous forme graphique, comme c’est généralement le cas pour les mesures effectuées directement sur un composant physique, vous devrez relever ces deux valeurs au point où la diode commence à entrer en claquage. L’image ci-dessous présente un exemple de courbe de ce type.

Relevé graphique des valeurs de courant et de tension au point de claquage inverse.
Bien que les valeurs affichées sur le graphique puissent être négatives, elles doivent être saisies uniquement sous forme de valeurs positives dans les champs correspondants de l’assistant.
Caractéristiques de recouvrement inverse
Le paramètre suivant sert à modéliser le temps de recouvrement inverse de la diode lors de son passage de la polarisation directe à la polarisation inverse :
TT |
Temps de transit (en secondes). |
Pour extraire ce paramètre, l’assistant nécessite la saisie du temps de recouvrement inverse de la diode (Trr), au point où le courant direct est égal au courant inverse (c’est-à-dire IR/IF=1). Cette donnée figure généralement dans les fiches techniques des fabricants de diodes de commutation sous la forme d’une simple valeur numérique.
L’image ci-dessous illustre la présentation de cette information dans la fiche technique d’un fabricant. La valeur qui nous intéresse dans l’image — celle à saisir dans l’assistant — est de 4 ns.

Obtention du temps de recouvrement inverse d’une diode.
Transistor bipolaire à jonction (BJT)
Lors de la création d'un modèle de transistor bipolaire à jonction (BJT), l'assistant de modèle SPICE vous demande de choisir les données sources à partir desquelles les paramètres seront extraits :
- Données mesurées – sélectionnez cette option si vos données sources proviennent de mesures effectuées sur un composant physique et si vous souhaitez développer un modèle précis décrivant tous les aspects du comportement en courant continu.
- Fiche technique du fabricant – sélectionnez cette option si vos données sources proviennent d'une fiche technique. Les fiches techniques ne contiennent généralement pas suffisamment d'informations pour modéliser tous les aspects du transistor BJT. Elles contiennent toutefois habituellement assez d'informations pour créer un modèle de composant utilisable uniquement dans la région active directe.
Les différences entre ces deux options concernent principalement la manière dont sont extraits les paramètres modélisant les caractéristiques courant-tension en courant continu du BJT. En ce qui concerne les capacités de jonction en polarisation inverse et les temps de transit, la méthode d'extraction des paramètres est identique pour les deux options.
Les sections suivantes détaillent chacune des caractéristiques que vous pouvez choisir de modéliser pour un transistor BJT, en fonction du type de données sources (données mesurées ou fiche technique). Elles présentent les paramètres extraits dans chaque cas ainsi que les données sources requises par l'assistant pour permettre leur extraction.
Caractéristiques modélisées à partir de données mesurées
Les caractéristiques suivantes peuvent être modélisées à partir de données issues de mesures effectuées directement sur le composant physique.
-
Forward-Bias Parameters
Les paramètres suivants servent à décrire les caractéristiques courant-tension en courant continu du BJT dans la région de polarisation directe :
IS
Courant de saturation de transport (en ampères).
BF
Bêta direct maximal idéal.
NF
Coefficient d'émission du courant direct.
RB
Résistance de base à polarisation nulle (en ohms).
RC
Résistance de collecteur (en ohms).
RE
Résistance d'émetteur (en ohms).
IKF
Courant de coude de la décroissance du bêta direct à fort courant (en ampères).
ISE
Courant de saturation de fuite B-E (en ampères).
NE
Coefficient d'émission du courant de fuite B-E.
VAF
Tension d'Early directe (en volts).
Les sections suivantes détaillent les données de mesure requises, dont la saisie permettra à l'assistant d'extraire ces paramètres.
-
Base-Emitter Voltage versus Base Current
Ces données servent à l'extraction initiale du paramètre RC. L'image ci-dessous présente un exemple de courbe de la tension base-émetteur (VBE) en fonction du courant de base (IB), ainsi qu'un exemple de circuit de test permettant d'effectuer les mesures nécessaires à l'obtention de ces données. Le circuit impose un courant dans la base tout en mesurant la tension base-émetteur en circuit ouvert.

Exemple de courbe et de circuit pour VBE en fonction de IB.Les données sont saisies dans l'assistant sous la forme d'une série de points relevés sur la courbe source.
-
Collector-Emitter Voltage versus Base Current
Ces données servent à l'extraction initiale du paramètre RE. L'image ci-dessous présente un exemple de courbe de la tension collecteur-émetteur (VCE) en fonction du courant de base (IB), ainsi qu'un exemple de circuit de test permettant d'effectuer les mesures nécessaires à l'obtention de ces données. Le circuit impose un courant dans la base tout en mesurant la tension collecteur-émetteur en circuit ouvert.

Exemple de courbe et de circuit pour VCE en fonction de IB.Les données sont saisies dans l'assistant sous la forme d'une série de points relevés sur la courbe source.
-
Forward Gummel Plot
Ces données servent principalement à extraire les paramètres IS, BF, NF, RB, IKF, ISE et NE. Elles servent également à optimiser les paramètres RC, RE et VAF. L'image ci-dessous présente un exemple de diagramme de Gummel, ainsi qu'un exemple de circuit de test permettant d'effectuer les mesures nécessaires à l'obtention de ces données. Le diagramme de Gummel représente :
-
Le courant de base en fonction de la tension base-émetteur (IB en fonction de VBE).
-
Le courant de collecteur en fonction de la tension base-émetteur (IC en fonction de VBE).
La tension base-collecteur (VBC) est maintenue à zéro volt.

Exemple de diagramme de Gummel en fonctionnement direct et de circuit de test.Les données sont saisies dans l'assistant sous la forme d'une série de points relevés sur le diagramme de Gummel source. Les valeurs brutes de IB et IC doivent être saisies – l'assistant appliquera la fonction LN aux données des courbes.
-
-
Collector Current versus Base-Emitter Voltage
Ces données servent à l'extraction initiale du paramètre VAF. L'image ci-dessous présente un exemple de courbe du courant de collecteur (IC) en fonction de la tension base-émetteur (VBE), ainsi qu'un exemple de circuit de test permettant d'effectuer les mesures nécessaires à l'obtention de ces données. Le circuit sert à générer deux courbes de IC en fonction de VBE, pour deux valeurs différentes de la tension base-collecteur (VBC). Les courbes doivent être mesurées à des courants aussi faibles que possible et avec une tension VBC aussi proche de zéro volt que possible en pratique.

Exemples de courbes et de circuit pour VBE en fonction de IC.Les données sont saisies dans l'assistant sous la forme d'une série de points dans deux tableaux, un pour chaque courbe de données sources. La valeur utilisée pour VBC doit également être saisie dans chaque cas.
-
-
Reverse-Bias Parameters
Les paramètres suivants servent à décrire les caractéristiques courant-tension en courant continu du BJT dans la région de polarisation inverse :
IS
Courant de saturation de transport (en ampères).
BR
Bêta inverse maximal idéal.
NR
Coefficient d'émission du courant inverse.
RB
Résistance de base à polarisation nulle (en ohms).
RC
Résistance de collecteur (en ohms).
RE
Résistance d'émetteur (en ohms).
IKR
Courant de coude de la décroissance du bêta inverse à fort courant (en ampères).
ISC
Courant de saturation de fuite B-C (en ampères).
NC
Coefficient d'émission du courant de fuite B-C.
VAR
Tension d'Early inverse (en volts).
Les sections suivantes détaillent les données de mesure requises, dont la saisie permettra à l'assistant d'extraire ces paramètres.
-
Reverse Gummel Plot
Ces données servent principalement à extraire les paramètres IS, BR, NR, RB, IKR, ISC et NC. Elles servent également à optimiser les paramètres RC, RE et VAR. L’image ci-dessous présente un exemple de tracé de Gummel ainsi qu’un exemple de circuit de test permettant d’effectuer les mesures nécessaires à l’obtention des données. Le tracé de Gummel illustre :
-
Le courant de base en fonction de la tension base-collecteur (IB en fonction de VBC).
-
Le courant d’émetteur en fonction de la tension base-collecteur (IE en fonction de VBC).
La tension base-émetteur (VBE) est maintenue à zéro volt.

Exemple de tracé de Gummel en inverse et de circuit de test.Les données sont saisies dans l’assistant sous forme d’une série de points issus du tracé de Gummel source. Les valeurs brutes de IB et IE doivent être saisies ; l’assistant appliquera la fonction LN aux données de la courbe.
-
-
Emitter Current versus Base-Collector Voltage
Ces données servent à l’extraction initiale du paramètre VAR. L’image ci-dessous présente un exemple de graphique du courant d’émetteur (IE) en fonction de la tension base-collecteur (VBC), ainsi qu’un exemple de circuit de test permettant d’effectuer les mesures nécessaires à l’obtention des données. Le circuit sert à générer deux courbes de IE en fonction de VBC, pour deux valeurs différentes de la tension base-émetteur (VBE). Les courbes doivent être mesurées à des courants aussi faibles que possible et avec une tension VBE aussi proche de zéro volt que possible en pratique.

Exemples de graphiques et de circuit pour IE en fonction de VBC.Les données sont saisies dans l’assistant sous forme d’une série de points dans deux tableaux, un pour chaque courbe de données source. La valeur utilisée pour VBE doit également être saisie dans chaque cas.
-
Caractéristiques modélisées à partir des données d’une fiche technique du fabricant
Les caractéristiques suivantes peuvent être modélisées à partir de données issues d’une fiche technique du fabricant.
-
Forward-Bias Parameters
Les paramètres suivants servent à décrire les caractéristiques courant-tension en continu du transistor bipolaire (BJT) dans la région de polarisation directe :
IS
Courant de saturation de transport (en ampères).
BF
Bêta direct maximal idéal.
NF
Coefficient d’émission du courant direct.
RE
Résistance d’émetteur (en ohms).
IKF
Courant de coude pour la décroissance du bêta direct à fort courant (en ampères).
ISE
Courant de saturation de fuite B-E (en ampères).
NE
Coefficient d’émission de fuite B-E.
Les sections suivantes détaillent les données nécessaires, dont la saisie permettra à l’assistant d’extraire ces paramètres.
-
Base-Emitter Voltage versus Collector Current
Ces données servent à extraire les paramètres IS, NF, RE et IKF. L’image ci-dessous présente un exemple de graphique de la tension base-émetteur (VBE) en fonction du courant de collecteur (IC), issu d’une fiche technique.
Les données sont saisies dans l’assistant sous forme d’une série de points issus du graphique source. Les valeurs brutes de IC doivent être saisies ; l’assistant appliquera la fonction LN aux données de la courbe.
La valeur du rapport bêta forcé de la courbe (β = IC/IB) doit également être saisie. Dans l’exemple de tracé de l’image ci-dessus, cette valeur est indiquée en haut à gauche du graphique ; il faut donc saisir la valeur 10.
-
DC Current Gain versus Collector Current
Ces données servent à extraire les paramètres BF, NE, ISE et IKF. L’image ci-dessous présente un exemple de graphique du gain en courant continu (hFE) en fonction du courant de collecteur (IC), issu d’une fiche technique.
Les données sont saisies dans l’assistant sous forme d’une série de points issus du graphique source. Pour garantir la précision, les valeurs du gain en courant continu doivent être saisies pour des valeurs faibles, moyennes et élevées du courant de collecteur.
-
-
Forward Early Voltage
Le paramètre suivant sert à modéliser l’effet de modulation de la largeur de base dans le modèle de transistor de Gummel-Poon :
VAF
Tension d’Early en direct (en volts).
Pour extraire ce paramètre, vous devez saisir un point de la courbe de l’admittance de sortie (hOE) en fonction du courant de collecteur (IC). L’image ci-dessous présente un exemple de cette courbe.
Relevez une valeur quelconque sur la courbe. Dans l’exemple de l’image ci-dessus, on peut relever IC = 1 mA et hOE = 30 µmhos.
Les données sont généralement présentées sous forme de tableau, comme dans l’exemple illustré ci-dessous.

Exemple de présentation de l’admittance de sortie sous forme de tableau.Les valeurs pertinentes dans l’image, à saisir dans l’assistant, sont 1 mA pour le courant de collecteur et 30 µmhos pour l’admittance de sortie (la valeur maximale est généralement utilisée).
Caractéristiques modélisées à partir de données mesurées ou fournies par le fabricant
Les caractéristiques suivantes peuvent être modélisées à partir de données issues d’une fiche technique du fabricant ou de mesures directes effectuées sur un composant physique.
-
Base-Emitter Capacitance
Les paramètres suivants servent à décrire la capacité de la jonction base-émetteur en polarisation inverse :
CJE
Capacité de déplétion B-E à polarisation nulle (en farads).
MJE
Facteur exponentiel de la jonction B-E.
VJE
Potentiel interne B-E (en volts).
Pour extraire ces paramètres, un graphique de la capacité de la jonction B-E polarisée en inverse (Cj) en fonction de la tension (VBE) est nécessaire. Si vous ne disposez pas d’un capacimètre, le circuit de test donné en exemple dans l’image ci-dessous peut servir à obtenir les données. L’image présente également des exemples de graphiques obtenus avec un tel circuit, représentant respectivement VBE et Cj en fonction du temps. Ces graphiques permettent de relever facilement les valeurs de VBE et de Cj aux mêmes instants.

Exemple de circuit et de graphiques pour la capacité de jonction B-E en polarisation inverse.Les données sont saisies dans l’assistant sous forme d’une série de points issus du ou des graphiques sources.
Le circuit donné en exemple dans l’image ci-dessus repose sur l’équation suivante :
I = C * (dv/dt)En résolvant cette équation pour C, on obtient :
C = I/(dv/dt)Le circuit produit une rampe de tension à partir de la source V1. Le calcul de la pente de cette rampe de tension permet d'obtenir le terme
dv/dtde l'équation. En divisant le courant mesuré dans la diode par la pente de la rampe de tension, on obtient la courbe de capacité de la diode. Les deux graphiques de l'image ci-dessus correspondent au circuit comme suit :-
Graphique du haut – VBE correspond à V1.
-
Graphique du bas – Cj correspond à q1[ie]/(dV1/dt).
-
-
Base-Collector Capacitance
Les paramètres suivants permettent de décrire la capacité de la jonction base-collecteur polarisée en inverse :
CJC
Capacité de déplétion B-C à polarisation nulle (en farads).
MJC
Facteur exponentiel de la jonction B-C.
VJC
Potentiel interne de la jonction B-C (en volts).
Pour extraire ces paramètres, il faut disposer d'un graphique de la capacité de la jonction B-C polarisée en inverse (Cj) en fonction de la tension (VBC). Si aucun capacimètre n'est disponible, le circuit de test donné en exemple dans l'image ci-dessous peut être utilisé pour obtenir les données. L'image présente également des exemples de graphiques obtenus avec un tel circuit, représentant respectivement VBC et Cj en fonction du temps. Ces graphiques permettent de relever facilement les valeurs de VBC et de Cj à des instants correspondants.

Exemple de circuit et de graphiques pour la capacité de la jonction B-C polarisée en inverse.Les données sont saisies dans l'assistant sous forme d'une série de points de données relevés sur le graphique source.
Le circuit donné en exemple dans l'image ci-dessus repose sur l'équation suivante :
I = C * (dv/dt)En isolant C dans cette équation, on obtient :
C = I/(dv/dt)Le circuit produit une rampe de tension à partir de la source V1. Le calcul de la pente de cette rampe de tension permet d'obtenir le terme
dv/dtde l'équation. En divisant le courant mesuré dans la diode par la pente de la rampe de tension, on obtient la courbe de capacité de la diode. Les deux graphiques de l'image ci-dessus correspondent au circuit comme suit :-
Graphique du haut – VBC correspond à V1.
-
Graphique du bas – Cj correspond à q1[ic]/(dV1/dt).
-
-
Collector-Substrate Capacitance
Les paramètres suivants permettent de décrire la capacité de la jonction collecteur-substrat polarisée en inverse :
CJS
Capacité collecteur-substrat à polarisation nulle (en farads).
MJS
Facteur exponentiel de la jonction de substrat.
VJS
Potentiel interne de la jonction de substrat (en volts).
Pour extraire ces paramètres, il faut disposer d'un graphique de la capacité de la jonction C-S polarisée en inverse (Cj) en fonction de la tension (VCS). Si aucun capacimètre n'est disponible, le circuit de test donné en exemple dans l'image ci-dessous peut être utilisé pour obtenir les données. L'image présente également des exemples de graphiques obtenus avec un tel circuit, représentant respectivement VCS et Cj en fonction du temps. Ces graphiques permettent de relever facilement les valeurs de VCS et de Cj à des instants correspondants.

Exemple de circuit et de graphiques pour la capacité de la jonction C-S polarisée en inverse.Les données sont saisies dans l'assistant sous forme d'une série de points de données relevés sur le graphique source.
Le circuit donné en exemple dans l'image ci-dessus repose sur l'équation suivante :
I = C * (dv/dt)En isolant C dans cette équation, on obtient :
C = I/(dv/dt)Le circuit produit une rampe de tension à partir de la source V1. Le calcul de la pente de cette rampe de tension permet d'obtenir le terme
dv/dtde l'équation. En divisant le courant mesuré dans la diode par la pente de la rampe de tension, on obtient la courbe de capacité de la diode. Les deux graphiques de l'image ci-dessus 24 correspondent au circuit comme suit :-
Graphique du haut – VCS correspond à V1.
-
Graphique du bas – Cj correspond à q1[is]/(dV1/dt).
-
-
Transit Times
Les paramètres suivants permettent de décrire le temps de transit du transistor bipolaire (BJT) :
TF
Temps de transit direct idéal (en secondes).
TR
Temps de transit inverse idéal (en secondes).
Pour extraire ces paramètres, l'assistant demande de saisir la fréquence de gain unitaire du transistor (fT). Il s'agit de la fréquence à laquelle le gain en courant du transistor devient égal à un. Cette donnée figure généralement dans les fiches techniques des fabricants sous forme d'une simple valeur numérique.
L'image ci-dessous montre comment cette information est présentée dans la fiche technique d'un fabricant. La valeur à retenir dans l'image, et à saisir dans l'assistant, est de 100 MHz.

Exemple de valeur du produit gain en courant-bande passante dans un tableau.
Paramètres non extraits par l'assistant
Les paramètres suivants sont difficiles à extraire des données de mesure et ne figurent généralement pas dans les fiches techniques des fabricants. Ils ne sont ni extraits par l'assistant ni ajoutés au fichier de modèle généré pour un transistor bipolaire. Bien qu'ils soient absents du fichier MDL, SPICE utilise tout de même ces paramètres lors de la simulation du transistor bipolaire, en leur attribuant leurs valeurs par défaut. Ces valeurs par défaut sont indiquées ci-dessous à titre de référence.
IRB |
Courant pour lequel la résistance de base a diminué de moitié vers sa valeur minimale (en ampères). (Valeur par défaut = infini). |
|
RBM |
Résistance de base minimale aux courants élevés (en ohms). (Valeur par défaut = RB). |
|
XTF |
Coefficient de dépendance de TF à la polarisation. (Valeur par défaut = 0). |
|
VTF |
Tension décrivant la dépendance de TF à VBC (en volts). (Valeur par défaut = infini). |
|
ITF |
Paramètre de courant élevé influant sur TF (en ampères). (Valeur par défaut = 0). |
|
PTF |
Excès de phase à la fréquence freq=1.0/(TF*2PI)Hz (en degrés). (Valeur par défaut = 0). |
|
XCJC |
Fraction de la capacité de déplétion B-C connectée au nœud de base interne. (Valeur par défaut = 1). |
|
XTB |
Exposant de température du bêta direct et inverse. (Valeur par défaut = 0). |
|
EG |
Énergie de bande interdite pour l'effet de la température sur IS (en eV). (Valeur par défaut = 1,11). |
|
XTI |
Exposant de température pour l'effet sur IS. (Valeur par défaut = 3). |
|
KF |
Coefficient de bruit de scintillation. (Valeur par défaut = 0). |
|
AF |
Exposant de bruit de scintillation. (Valeur par défaut = 1). |
|
FC |
Coefficient de la formule de capacité de déplétion en polarisation directe. (Valeur par défaut = 0,5). |
|
TNOM |
Température de mesure du paramètre (en ˚C). (La valeur par défaut de ce paramètre est égale à la valeur saisie pour le paramètre TNOM sur la page SPICE Options de la boîte de dialogue Analysis Setup. Cette valeur est de 27 ˚C par défaut). |
Vous pouvez bien entendu ajouter manuellement n’importe lequel de ces paramètres au fichier MDL, en spécifiant les valeurs à utiliser selon vos besoins.
