Importation de bibliothèques existantes dans votre espace de travail connecté

En un coup d'œil

Importez vos bibliothèques de composants existantes dans votre espace de travail connecté à l’aide de l’outil Library Importer d’Altium Designer. Cet article explique comment le mode Simple de cet outil automatise les importations courantes et comment le mode Avancé vous offre un contrôle accru sur les types de composants, les paramètres et les réglages d’importation. Il présente également les formats de bibliothèques pris en charge, les données transférées et les contrôles de validation qui permettent de détecter les problèmes d’importation. Poursuivez votre lecture pour trouver la méthode d’importation adaptée à vos bibliothèques et franchir une nouvelle étape vers la gestion centralisée des composants.

- Découvrez comment accéder à l’outil Library Importer et choisir entre les modes Simple et Avancé.
- Identifiez les bibliothèques et les données de composants pouvant être importées, ainsi que les principales limitations.
- Explorez les aperçus d’importation, la classification des composants, les réglages des paramètres et les rapports pour vérifier et affiner vos importations.
Approfondissez avec l'IA :

Altium Designer, associé à votre espace de travail connecté, offre un processus simplifié et hautement automatisé pour importer rapidement vos bibliothèques existantes dans cet espace de travail. L’interface de ce processus – le Library Importer – propose une solution en un clic qui analyse automatiquement les bibliothèques sélectionnées et les importe dans l’espace de travail auquel vous êtes actuellement connecté.

Prenant en charge tous les types de bibliothèques associés aux anciennes méthodes de gestion des composants (SchLib, PcbLib, IntLib, DbLib, SVNDbLib), l’importateur de bibliothèques est une solution dédiée à la création rapide de la bibliothèque de composants de l’espace de travail de votre entreprise, afin que vous puissiez bénéficier de ses nombreux avantages : intégrité élevée, stockage et gestion centralisés, réutilisation aisée des conceptions et informations sur la chaîne d’approvisionnement en temps réel.

L’importateur de bibliothèques propose un mode d’interface Simple minimaliste dans lequel les bibliothèques de composants sélectionnées, basées sur des fichiers ou des bases de données, sont importées sous forme de composants de l’espace de travail en une seule étape. L’importateur gère automatiquement la classification par type, le dossier source cible, l’inclusion des paramètres et leur type de valeur, ainsi que le transfert de toutes les données pertinentes. L’interface est également disponible dans un mode Advanced qui offre un aperçu complet de l’importation proposée, ainsi qu’un accès aux données et paramètres associés. Bien que l’importation s’effectue par défaut en un seul clic, l’importateur propose également des options de configuration avancées dans le panneau Properties, pour contrôler plus précisément son déroulement.

Quels éléments sont importés ?

Toutes les informations présentes dans une bibliothèque source d’origine sont importées dans les composants de l’espace de travail, notamment tous les modèles de domaine référencés (symboles schématiques, empreintes de PCB, modèles de simulation), les informations paramétriques, les choix de pièces affectés, les fichiers de fiches techniques, etc. Des modèles de composants sont également créés si nécessaire ; ils peuvent ensuite être affinés et utilisés pour les importations de bibliothèques suivantes.

Si plusieurs empreintes de PCB sont définies pour vos composants d’origine, l’importateur de bibliothèques transfère ces modèles et conserve l’empreinte actuellement définie par défaut. Si vous travaillez uniquement avec des bibliothèques de PCB, car seul le routage des PCB vous intéresse, l’importateur de bibliothèques permet d’importer uniquement ces bibliothèques. Il peut également être configuré en mode d’importation des modèles uniquement, dans lequel les types de modèles spécifiés sont importés depuis des bibliothèques intégrées ou de bases de données. Les bibliothèques comprenant plusieurs types de composants (bibliothèques monolithiques) sont elles aussi détectées et traitées automatiquement.

Bien que le processus d’importation doive traiter des bibliothèques sources basées sur des fichiers ou des bases de données pouvant utiliser diverses normes de formatage, ses mécanismes d’analyse automatique détectent les types de composants de la bibliothèque source (résistance, condensateur, etc.), ainsi que les noms des paramètres et leurs types de valeurs (volts, ohms, etc.). Le système effectue et gère plusieurs validations, par exemple pour garantir l’absence d’identifiants en double pour les composants de la bibliothèque de l’espace de travail obtenus, ou pour éviter de créer des modèles ou des modèles de composants en double, et veiller à ce que ces entités soient réutilisées par les composants (au moyen de liens) lorsque cela est nécessaire. Si des problèmes surviennent, le système les signale et suggère des solutions afin que l’importation puisse reprendre aussi rapidement et simplement que possible.

Les types de bibliothèques pouvant être importés sont les suivants :

  • Bibliothèque de schémas (*.SchLib).

  • Bibliothèque d’empreintes de PCB (*.PcbLib).

  • Bibliothèque intégrée (*.IntLib)

  • Bibliothèque de base de données (*.DbLib).

  • Bibliothèque de base de données SVN (*.SVNDbLib).

L’importation des informations de correspondance des broches (pour les modèles de simulation) n’est actuellement pas prise en charge.

Accéder à l’importateur de bibliothèques

L’importateur de bibliothèques est disponible lorsque vous êtes connecté à un espace de travail. Pour accéder à l’importateur en mode Simple :

  • Dans le panneau Components, choisissez l’option Import Library dans le menu . Si une bibliothèque basée sur des fichiers ou une base de données est actuellement sélectionnée dans la colonne Categories du panneau (ou dans le menu déroulant supérieur lorsque le panneau est en mode compact), l’importateur de bibliothèques s’ouvre pour cette bibliothèque. Lorsqu’un type de composant de la bibliothèque de l’espace de travail est sélectionné, la boîte de dialogue Windows standard Open s’ouvre pour vous permettre de rechercher et de sélectionner un fichier de bibliothèque à importer.

    Les bibliothèques basées sur des fichiers ou des bases de données actuellement disponibles dans le logiciel peuvent être consultées et gérées dans la boîte de dialogue Libraries Preferences, accessible depuis l’option Libraries Preferences du menu du bouton  dans le panneau Components.

    Vous pouvez également consulter et gérer les bibliothèques basées sur des fichiers actuellement installées sur la page Data Management – File-based Libraries de la boîte de dialogue Preferences.

  • Faites un clic droit sur un fichier de bibliothèque dans le panneau Projects et sélectionnez Import Library dans le menu contextuel.

  • Sélectionnez Tools » Import Library dans l’éditeur de symboles schématiques ou d’empreintes de PCB lorsqu’un fichier de bibliothèque local est ouvert.

  • Sélectionnez File » Import Library ou Tools » Import Library dans l’éditeur de bibliothèques de bases de données.

  • Dans la boîte de dialogue Libraries Preferences, sélectionnez une entrée de bibliothèque dans l’onglet Installed, puis cliquez sur la commande Import.

  • Faites glisser un fichier de bibliothèque depuis un dossier Windows vers le panneau Explorer.

Le mode simple propose des options permettant d’importer immédiatement la bibliothèque sélectionnée () ou d’ouvrir l’importateur de bibliothèques avec son interface graphique complète ().

L’importateur de bibliothèques en mode d’importation en un clic Simple.
L’importateur de bibliothèques en mode d’importation en un clic Simple.

Pour accéder directement à l’importateur de bibliothèques en mode d’interface Advanced, sélectionnez File » Library Importer dans le menu principal.

L’importateur de bibliothèques, lorsqu’il est ouvert dans son mode d’interface complet Advanced, prend également en charge l’importation en un clic.
L’importateur de bibliothèques, lorsqu’il est ouvert dans son mode d’interface complet Advanced, prend également en charge l’importation en un clic.

Mode simple

Le mode simple de l’importateur de bibliothèques présélectionne tous les aspects du processus d’importation en fonction de son analyse de la bibliothèque source et de l’espace de travail connecté. La boîte de dialogue Library Importer présente ensuite un récapitulatif de la structure d’importation, avec le nombre total d’éléments de chaque type. L’importation de la bibliothèque s’effectue en une seule étape à l’aide de la commande .

Ce mode d’interface simple convient aux formats de bibliothèques sources les plus courants, qui contiennent généralement des types de composants courants (résistances, condensateurs, circuits intégrés, etc.) et des valeurs de paramètres standardisées. Lors de l’analyse initiale, le système détermine le type des composants de la bibliothèque à partir des mots-clés des repères ou des paramètres (LD?, LED, etc.), puis recherche un modèle de composant correspondant dans l’espace de travail cible (LED). Ce modèle est appliqué à l’importation de ces composants et définit alors les paramètres d’importation, tels que le dossier cible (Components/LED), la correspondance des paramètres, les unités des valeurs des paramètres, etc. Des modèles adaptés sont disponibles dans l’espace de travail si l’option d’inclusion des données d’exemple a été sélectionnée lors de l’activation d’un espace de travail Altium 365 ou de l’installation d’Altium On-Prem Enterprise Server.

Les résultats de l’importation de la bibliothèque, sous forme de composants nouvellement créés dans l’espace de travail, sont visibles dans les panneaux Explorer et Components. Les composants importés comprennent tous les modèles, les paramètres tels qu’interprétés par les modèles de composants appliqués, les choix de pièces issus des données sources des liens fournisseurs, ainsi que tous les liens ou fichiers de référence.

Tous les modèles de composants créés par l’outil d’importation de bibliothèques sont accessibles dans le dossier Managed Content\Templates\Component Templates du panneau Explorer.

Si, pour une raison quelconque — par exemple, un résultat d’importation insatisfaisant — vous souhaitez supprimer un ensemble de composants, ceux sélectionnés dans le panneau Components peuvent être supprimés proprement en choisissant l’option Delete dans le menu contextuel accessible par clic droit. Les modèles associés aux composants sélectionnés peuvent également être supprimés (s’ils ne sont pas utilisés par d’autres composants).

Voici les points importants concernant le processus d’importation de bibliothèques :

  • Les bibliothèques monolithiques (celles qui contiennent plusieurs types de composants) sont automatiquement divisées en sous-groupes, chaque groupe représentant un type de composant présent dans la bibliothèque. Ces groupes sont traités comme des bibliothèques distinctes.

  • Une bibliothèque source dont le type de composant n’est pas reconnu (non détecté) sera importée sans interprétation, avec des types de composants non attribués, dans un dossier Components/Uncategorized de l’espace de travail. Avant de lancer l’importation, vous pouvez résoudre ce problème en appliquant le mappage des désignateurs ou le regroupement par paramètres en mode Advanced (interface complète). Vous pouvez également procéder à l’importation, puis modifier ultérieurement les paramètres et le dossier du composant dans le panneau Explorer.
  • Le processus d’importation de bibliothèques comprend une étape automatique de validation des composants. Les composants qui déclenchent une erreur de validation sont ignorés.
  • Si des modèles en double sont détectés dans la bibliothèque source à importer, un seul de ces modèles sera importé et lié aux composants obtenus dans l’espace de travail cible. Une notification appropriée s’affichera en haut de la boîte de dialogue Library Importer.
  • Les erreurs rencontrées au cours du processus peuvent être consultées dans le Importing Report, accessible à partir du bouton une fois l’importation terminée.

Mode avancé

L’interface graphique complète de l’outil d’importation de bibliothèques s’affiche en mode Advanced, qui permet un contrôle détaillé de la gestion des bibliothèques, des types de composants et des paramètres des composants. En association avec le panneau Properties, elle permet de configurer l’importation des bibliothèques de composants dans l’espace de travail selon vos besoins spécifiques. Notez que les paramètres de l’outil d’importation peuvent être enregistrés et restaurés en exportant/important des fichiers de configuration.

Le mode avancé est activé lorsque l’outil d’importation de bibliothèques est ouvert à l’aide de la commande File » Library Importer ou lorsque le bouton est sélectionné en mode simple. Les bibliothèques sont ajoutées à la section SOURCE LIBRARIES de l’outil d’importation (si elle n’est pas déjà renseignée) en faisant glisser un fichier de bibliothèque dans cette zone, en effectuant un clic droit sur <All Libraries> puis en sélectionnant Add Library dans le menu contextuel, ou en sélectionnant le bouton .

La section Import Preview répertorie les groupes de types de composants identifiés dans les bibliothèques sources — sous la forme Types () ou du Folder Structure proposé () — et comprend une vue en tableau de ces composants, organisée par paramètres (Components). Les valeurs des paramètres dans le tableau peuvent être modifiées à la volée, ce qui évite d’avoir à ouvrir et à modifier la bibliothèque source. La zone Details inférieure contient des informations supplémentaires issues du composant actuellement sélectionné : choix de pièces, modèles et fiches techniques.

Vous pouvez modifier le type de composant en effectuant un clic droit sur un type dans la liste Types et en sélectionnant la commande Change Component Type.

Quels que soient les options détaillées et les données présentées dans l’interface, la vue avancée de l’outil d’importation peut être utilisée de la même manière que la vue simple : il suffit de cliquer sur le bouton pour lancer le processus d’importation, sans autre intervention. Comme dans le processus en vue simple, l’outil d’importation a analysé la bibliothèque, déduit le type des composants qu’elle contient et appliqué le modèle de composant approprié. Ce modèle détermine à son tour le dossier cible de l’espace de travail, les schémas de nommage et les définitions de cycle de vie appliqués, ainsi que le mappage et l’interprétation des paramètres.

  • Utilisez le bouton (en haut à gauche) pour actualiser l’outil d’importation de bibliothèques. Toutes les bibliothèques sources et les données de l’espace de travail seront rechargées afin de prendre en compte les modifications survenues depuis l’ouverture de l’outil.
  • Utilisez le champ de recherche (en haut à droite) pour filtrer les entrées de composants selon une valeur de paramètre correspondante.

Bibliothèques monolithiques

Les bibliothèques sources contenant plusieurs types de composants sont détectées par les routines d’analyse de l’outil d’importation et réparties en groupes de sous-bibliothèques, qui peuvent être traités comme des bibliothèques distinctes par type. La détection du type de composant repose sur les désignateurs des composants sources (R?, C?, etc.) ainsi que sur les mots-clés (Resistor, Res, etc.) contenus dans les autres paramètres principaux des composants (description, identifiant, etc.).

Dans l’exemple ci-dessous, la bibliothèque source (ProjectABC.IntLib) a été automatiquement « divisée » selon les types de composants détectés (condensateurs, résistances, etc.). Ces types peuvent être sélectionnés dans la colonne Folder Structure (ou la colonne Types) pour afficher un aperçu des composants qui les constituent dans le tableau Components.

Les types de composants qui n’existent pas encore dans l’espace de travail, mais qui seront créés lors du processus d’importation, sont signalés par l’icône .

Notez que la présentation de la liste Components peut être modifiée de plusieurs façons :

  • Cliquez sur un en-tête de colonne pour trier la liste selon ce paramètre, puis cliquez à nouveau pour inverser l’ordre.

  • Dans le menu contextuel de l’en-tête accessible par clic droit :

    • Choisissez Clear Sorting pour rétablir l’ordre de tri par défaut de la liste (selon la colonne Name par ordre croissant).

    • Choisissez Best Fit pour adapter la largeur d’une colonne à son contenu.

    • Choisissez Select Best Fit All Columns pour adapter la largeur de toutes les colonnes disponibles à leur contenu.

    • Choisissez Select Columns pour accéder à la boîte de dialogue Select Columns, dans laquelle vous pouvez activer ou désactiver les colonnes de paramètres et modifier leur ordre dans la liste.

  • Cliquez sur l’icône de filtre () dans un en-tête pour limiter la liste à une valeur disponible de la colonne de paramètre, aux valeurs vides ou non vides, ou à un critère de filtre Custom. Le filtre appliqué s’affiche en bas de la liste, où il peut être activé ou désactivé (à l’aide de la case à cocher associée), modifié dans le Filter Editor ou supprimé. Sélectionner All via l’icône de filtre de l’en-tête () supprime également le filtre appliqué.

Composants non catégorisés

Si une entrée de sous-groupe de bibliothèque est nommée Uncategorized (et répertoriée comme Uncategorized sous Types ou Folder Structure et accompagnée de l’icône  icône), cela indique que l’outil d’importation n’a pas pu détecter ni attribuer de type à ce groupe de composants : le type de composant est alors défini sur None. Dans ce cas, les composants non identifiés (circuits intégrés logiques inverseurs) utilisent un préfixe de désignateur non reconnu (U?) et leurs paramètres ne contiennent aucun des mots-clés détectés, tels que IC, logic, etc.

Si l’importation est lancée, les composants sont importés avec un type non catégorisé, sans interprétation. Toutefois, si des paramètres clés ou standard sont présents (tels que Resistance, Capacitance, Tolerance, etc.), l’outil d’importation leur attribue automatiquement un type d’unité de paramètre approprié (Ohm, Farad, Percent, etc.).

Ce problème peut être résolu en associant manuellement les désignateurs utilisés pour ces composants au type de composant souhaité dans la boîte de dialogue Library Splitting, accessible à l’aide du bouton , disponible lorsque la bibliothèque source (ProjectABC.IntLib) est sélectionnée. La boîte de dialogue Library Splitting, avec ses valeurs par défaut, propose des commandes permettant de définir des options personnalisées de regroupement des bibliothèques pour les composants non catégorisés, en fonction de l’association des désignateurs aux types de composants et d’une répartition basée sur les paramètres.

Après avoir sélectionné l’option Map Designators  de la boîte de dialogue, choisissez le type de composant correspondant aux composants non catégorisés dans la liste déroulante Component Type (qui contient tous les types de composants disponibles). Confirmez l’association type-désignateur définie (le type de composant Logic aux désignateurs U?) à l’aide du bouton .

Le type de composant étant désormais défini par l’association appliquée, l’outil d’importation utilise le modèle de composant correspondant (Logic) pour configurer l’importation de la bibliothèque selon les paramètres du modèle (dossier, nommage, etc.).

  • La boîte de dialogue Library Splitting permet également de regrouper les composants répartis selon la valeur d’un paramètre spécifié (par exemple, un paramètre Category ou Component_Type), si celui-ci est défini dans la bibliothèque source. Pour ce faire, sélectionnez l’option Parameter Grouping de la boîte de dialogue, puis un paramètre approprié dans le menu déroulant.
  • Vous pouvez également sélectionner manuellement le type de composant d’une bibliothèque dans la section General du panneau Propriétés.
  • Pour modifier le type de composant d’une entrée particulière de la liste Components, cliquez dans sa cellule Component Type, puis choisissez un autre type dans le menu déroulant, ou faites un clic droit sur le type de composant et sélectionnez Change Component Type dans le menu contextuel.

Notez que, grâce à la souplesse des paramètres de l’outil d’importation de bibliothèques, il est possible d’importer un nouveau type de bibliothèque de composants (non catégorisé) avec toute l’infrastructure nécessaire aux futures importations de ce type de bibliothèque. En choisissant une configuration d’importation appropriée (nouveau type de composant, modèle de composant, dossier cible, correspondance des paramètres et types d’unités des valeurs de paramètres), il suffit, lors de l’importation suivante de ce type de bibliothèque, de sélectionner le type de composant précédemment défini. Le type de composant sélectionné détermine alors tous les autres aspects de l’importation.

Exclure de l’importation

Vous pouvez également exclure certains types de composants de l’importation. Pour exclure un type de composant, faites un clic droit sur celui-ci dans la liste Types, puis sélectionnez Exclude from Importer dans le menu contextuel. Si nécessaire, remplacez l’affichage de la colonne Folder Structure par Types ().

Le type de composant exclu apparaît grisé dans la liste Types. Pour afficher les composants exclus dans la grille, cliquez sur Show Excluded Component (n), où n indique le nombre de composants exclus.

Inclure dans l’importation

Si vous avez exclu un type de composant de l’importation à l’aide de la commande Exclude from Importer décrite ci-dessus et que vous souhaitez finalement l’inclure, faites un clic droit sur le type de composant grisé dans la liste Types (ou Folder Structure), puis sélectionnez Include to Importer dans le menu contextuel. Le type de composant réapparaît dans la liste Types, ce qui indique qu’il n’est plus exclu.

Erreurs et avertissements de validation

Les composants qui ne seront pas importés correctement dans l’espace de travail, ou qui ne seront pas importés du tout, sont signalés par des indicateurs d’avertissement ou d’erreur dans l’interface avancée lors du lancement de l’outil d’importation de bibliothèques () ou de l’exécution d’une validation de l’importation (). La validation vérifie également les chemins de dossiers vides dans l’espace de travail, les conflits entre paramètres système et les modèles en double. Une erreur fatale bloque l’importation.

Lors d’une tentative d’importation, le panneau Messages affiche les anomalies détectées et une boîte de dialogue propose d’abandonner l’importation ou de poursuivre avec la configuration actuelle. Dans ce dernier cas, les composants non valides ne sont pas importés, ou le processus d’importation échoue.

En cas d’annulation de l’importation ou d’exécution manuelle de la validation, les composants qui ne satisfont pas aux contrôles d’importation sont associés à des icônes d’erreur ou d’avertissement, accompagnées d’informations complémentaires dans la zone inférieure Details. Les icônes de la colonne d’aperçu Status indiquent les entrées de composants qui ne respectent pas les règles d’importation.

Les contrôles de validation prédéfinis disponibles sont répertoriés ci-dessous.

Les vérifications définissables par l’utilisateur sont configurées dans la zone Import Checks du panneau Properties. Utilisez le menu déroulant Report Mode pour choisir un autre niveau de signalement pour le type de violation associé. Ces vérifications sont répertoriées ci-dessous.

Résolution des erreurs et des avertissements

Les erreurs de paramètres, comme dans l’exemple présenté ici où la valeur Forward Voltage du composant ne peut pas être interprétée comme une tension valide, peuvent être résolues de plusieurs façons :

  • Modifier la valeur du paramètre à l’origine du problème : repérez sa cellule et modifiez-la pour respecter le format requis.

  • Remplacer l’unité du paramètre mappé Type, définie par le modèle de composant appliqué, de Voltage par le type non interprété Text : sélectionnez la bibliothèque source dans l’interface de l’outil d’importation, puis modifiez Forward Voltage Type dans la liste du panneau Propriétés Parameter Mapping (sous l’onglet General).

  • Retirer le composant du processus d’importation : faites un clic droit sur son entrée et choisissez l’option Exclude from Importer.

Une erreur de fichier manquant, comme celle du fichier de fiche technique introuvable illustrée ici, peut être résolue de plusieurs façons :

  • La solution évidente consiste à retrouver le fichier manquant et à le replacer à l’emplacement attendu.
  • Désactiver l’importation des fichiers de fiches techniques : modifiez l’option Migrate dans la section du panneau Propriétés Datasheet (sous l’onglet Advanced).
  • Exclure le composant du processus d’importation de la bibliothèque, comme décrit ci-dessus.

Utilisez le champ Search (en haut à droite) pour rechercher des entrées de composants spécifiques. La recherche filtre la liste des éléments selon les valeurs de paramètres correspondantes pour le type de composant actuellement sélectionné. Sélectionnez All sous Types (Folder Structure) pour que la recherche porte sur tous les composants des bibliothèques sources disponibles.

Importation d’une bibliothèque de schémas

Si vous rencontrez une erreur « modèle introuvable » (telle que Footprint <footprint name> not found in available libraries) lorsque vous tentez d’importer une bibliothèque de schémas, cela signifie que l’outil d’importation de bibliothèques ne parvient pas à localiser les modèles liés aux composants du fichier SCHLIB.

En mode simple, ces erreurs s’affichent dans le Importing Report au format HTML, accessible via le bouton disponible une fois l’importation exécutée. En mode avancé, les erreurs sont signalées par des icônes d’état dans l’interface principale () et par des entrées dans le panneau Messages, lors d’une vérification de validation () ou d’une tentative d’importation de la bibliothèque ().

Les empreintes manquantes sont correctement détectées par le processus de validation, qui propose également une option Choose a Library dans son rapport d’erreurs (dans le menu déroulant Details). Lorsque plusieurs empreintes de composants sont détectées comme manquantes, une boîte de dialogue Apply PcbLib Selection propose d’utiliser le fichier PcbLib spécifié pour cette occurrence ou pour tous les composants dont les empreintes sont manquantes.

Une autre façon de résoudre (ou d’éviter) ce problème consiste à s’assurer que les fichiers de bibliothèques de modèles requis sont accessibles depuis Altium Designer. Les bibliothèques sont installées depuis la page Gestion des données – Bibliothèques basées sur des fichiers de la boîte de dialogue Preferences.

Si vous ne souhaitez pas installer plusieurs bibliothèques de modèles, vous devez les placer dans le chemin de bibliothèque par défaut du logiciel (ou modifier ce chemin) et vérifier que la bibliothèque source des modèles est spécifiée pour les composants de la bibliothèque de schémas :

  • Incluez la bibliothèque de modèles dans le chemin de recherche par défaut du logiciel. Ajoutez la bibliothèque de modèles, par exemple la bibliothèque PCB correspondante, à l’emplacement défini par le chemin de bibliothèque par défaut du système. Pour vérifier cet emplacement, consultez l’entrée Library Path sur la page Système – Emplacements par défaut de la boîte de dialogue Preferences. Si un fichier de bibliothèque a été ajouté ou copié à cet emplacement, vous devrez peut-être redémarrer Altium Designer pour que la modification soit prise en compte.
  • Spécifiez le nom de la bibliothèque de modèles cible pour les composants de la bibliothèque de schémas. Pour que l’outil d’importation de bibliothèques puisse identifier la bibliothèque de modèles liée à un composant de la bibliothèque de schémas, indiquez son nom dans la boîte de dialogue Modèle PCB de la bibliothèque.

Notez qu’il n’est ni nécessaire ni même souhaitable d’importer une bibliothèque PCB en même temps que la bibliothèque de schémas correspondante, car l’importation des modèles requis et la création des liens sont effectuées par l’outil d’importation de bibliothèques lui-même. Le processus d’importation identifie, localise et transfère les modèles appropriés pour chaque composant afin de créer un composant unifié dans l’espace de travail cible.

Détection des doublons

L’outil Library Importer comprend également des mécanismes permettant d’éviter la création de composants en double dans l’espace de travail cible. Lors de la validation, les paramètres d’identification et les choix de pièces des composants de la bibliothèque source sont comparés à ceux des composants de l’espace de travail cible et des bibliothèques sources à importer. Avec les paramètres par défaut de l’outil d’importation, une étape de validation () affiche un message Warning lorsqu’une même entrée de composant Name ou Part Choices est détectée (signalant un éventuel doublon). Le message d’avertissement ou d’erreur affiché indique le type de doublon (paramètre ou choix de pièce), le nom du composant de bibliothèque concerné et l’identifiant du composant avec lequel il fait doublon.

Deux doublons potentiels détectés lors de la validation : le Name du composant (image du haut) ou son Part Choice (image du bas) existe déjà dans les composants de l’espace de travail.
Deux doublons potentiels détectés lors de la validation : le Name du composant (image du haut) ou son Part Choice (image du bas) existe déjà dans les composants de l’espace de travail.

La paire nom-valeur du paramètre utilisée pour détecter les doublons est spécifiée dans la zone Duplicates Detection du panneau Properties, sous l’onglet Advanced. Utilisez le menu déroulant Unique Field (défini sur Name par défaut) pour sélectionner l’un des paramètres disponibles dans la bibliothèque source. Cette sélection est particulièrement utile pour les configurations de bibliothèques d’entreprise qui utilisent un champ d’identification propriétaire lié au système global de l’entreprise.

Doublon détecté lorsque la valeur d’un paramètre spécifié (ERP-REF) est identique pour un composant de bibliothèque locale et un composant de l’espace de travail.
Doublon détecté lorsque la valeur d’un paramètre spécifié (ERP-REF) est identique pour un composant de bibliothèque locale et un composant de l’espace de travail.

Vous pouvez définir un autre type d’indicateur d’état pour les doublons en sélectionnant un autre Report Mode dans la zone Import Checks, sous l’onglet General du panneau Properties.

La détection des doublons s’applique également aux modèles de symboles des composants. Si les composants à importer possèdent des modèles de symboles présentant la même géométrie dans les bibliothèques sources, un seul de ces modèles sera importé.

Cette fonctionnalité est disponible lorsque l’option LibraryMigrator.DuplicatedModelCheck est activée dans la boîte de dialogue Advanced Settings.

Bibliothèques à modèle unique

La détection automatique des doublons est également utilisée pour traiter les bibliothèques sources qui utilisent un modèle de symbole commun à tous les composants. Ces bibliothèques se composent généralement d’un seul type de composant présentant différents styles et valeurs, par exemple des résistances d’un format de boîtier donné, dont chaque symbole correspond à une représentation graphique standard.

Cette utilisation d’un modèle commun unique est détectée par l’outil Library Importer, qui configure alors l’importation pour transférer un seul modèle de symbole applicable à tous les composants importés, plutôt qu’un symbole correspondant, nommé individuellement, pour chaque composant. Le symbole à importer reprend le nom de l’un des symboles à importer, et tous les paramètres des composants restent inchangés.

Le symbole de bibliothèque importé (qui porte le nom générique et dont le champ Description est vide) peut être modifié selon vos besoins. Dans le panneau Components, utilisez l’option Edit du menu contextuel pour lancer l’opération. Au cours du processus, sélectionnez l’option Update items related to <symbol ID> dans la boîte de dialogue Create Revisions for Item afin que les composants importés utilisent la nouvelle révision du symbole.

Fusionner les types de composants

Les types de composants enregistrés dans le système — ou, en pratique, dans l’espace de travail connecté — peuvent être consultés et gérés sur la page Data Management – Component Types de la boîte de dialogue Preferences. Les types sont répertoriés avec les Template de composant et les Folder d’espace de travail qui leur sont associés ; ils comprennent tous les nouveaux types créés lors de l’importation de fichiers de bibliothèque dans l’espace de travail par l’outil Library Importer.

La création de plusieurs nouveaux types de composants se produit généralement lorsqu’une configuration de Library Importer utilise le regroupement par paramètre (la valeur d’un paramètre de composant désigné) pour déterminer le type de chaque composant importé. Par exemple, le paramètre Categories peut avoir la valeur Resistor-0608 pour un ensemble de composants importés et Resistor-0402 pour un autre, et ainsi de suite. Dans ce cas, il serait préférable de tous les regrouper sous le même type de composant Resistors pour une utilisation ultérieure.

Plutôt que de modifier manuellement tous les types de composants dans ces circonstances, la page Component Types de Preferences permet de fusionner les entrées de type sélectionnées en une seule entrée spécifiée. Pour en savoir plus, consultez la section Fusion des types de composants de la page Types de composants.

À la suite d’une telle fusion, lorsque Resistors est choisi comme type de composant importé dans Library Importer, il sera appliqué même si vous sélectionnez à la place l’un des modèles fusionnés (Resistor_0402, etc.).

Importation des modèles uniquement

L’outil Library Importer peut être basculé vers un mode d’importation spécial Models Only qui détecte et traite les modèles de composants disponibles dans une bibliothèque source.

Cette fonctionnalité est disponible lorsque l’option LibraryMigrator.ModelsOnlyMode est activée dans la boîte de dialogue Advanced Settings.

En mode Models Only, le processus d’analyse de l’outil d’importation détecte tous les modèles de symboles, d’empreintes et de simulation disponibles dans une bibliothèque source (IntLib, SchLib, PcbLib, etc.), puis les importe dans l’espace de travail en utilisant les emplacements, les schémas de nommage et les définitions de cycle de vie par défaut du système.

Lorsque l’outil Library Importer est basculé en mode avancé () ou ouvert dans ce mode (File » Library Importer), tous les détails de l’importation de modèles proposée sont disponibles. La zone Import Preview affiche le Folder Structure qui sera utilisé dans l’espace de travail cible ; les paramètres par défaut peuvent être modifiés dans le champ Folder de chaque type de modèle dans le panneau Properties. Les schémas de nommage et la définition de cycle de vie appliqués à chaque modèle peuvent être sélectionnés parmi les types disponibles dans le système (voir le panneau Properties ci-dessous).

Si nécessaire, l’importation des modèles de composants dans l’espace de travail peut être limitée par type, en désactivant (ou en activant) certains types de modèles dans le panneau Properties à l’aide des boutons correspondants.

Une fois l’outil Library Importer configuré, sélectionnez le bouton pour terminer l’importation des modèles de composants répertoriés. Les résultats peuvent être consultés dans le fichier journal d’importation proposé par la boîte de dialogue de progression Library Importer (), ou en affichant les modèles importés dans le panneau Components.

Importation des composants uniquement

Comme pour le mode d’importation Models Only décrit ci-dessus, l’outil Library Importer peut être basculé vers un mode d’importation spécial Components Only qui vous permet d’importer les composants disponibles dans une bibliothèque source sans leurs modèles liés.

Cette fonctionnalité est disponible lorsque l’option LibraryMigrator.ReleaseComponentsWithoutModels est activée dans la boîte de dialogue Advanced Settings.

En mode Components Only, le processus d’analyse de l’outil d’importation détecte tous les composants, paramètres et choix de pièces d’une bibliothèque source, puis importe ces composants dans l’espace de travail en utilisant l’emplacement, le schéma de nommage et la définition de cycle de vie par défaut du système.

Lorsque Library Importer passe en mode avancé () ou est ouvert dans ce mode (File » Library Importer), tous les détails de l’importation de composants proposée sont disponibles. Le dossier utilisé, les schémas de nommage et la définition du cycle de vie peuvent être sélectionnés parmi les types disponibles dans le système (voir le panneau Properties ci-dessous).

Une fois Library Importer configuré, sélectionnez le bouton pour terminer l’importation des composants répertoriés. Seuls des éléments de composant seront créés dans l’espace de travail, sans aucun modèle lié. Les résultats peuvent être consultés dans le fichier journal d’importation, comme le propose la boîte de dialogue de progression Library Importer (), ou en affichant les composants importés dans le panneau Components. 

Panneau Properties

Les paramètres du panneau Properties associé à Library Importer permettent de contrôler de manière avancée la configuration de l’importation pour la bibliothèque sélectionnée (ou le sous-groupe de bibliothèques). Le panneau est accessible depuis le mode avancé de Library Importer en sélectionnant l’option Properties dans le menu du bouton  (en bas à droite de l’espace de conception), en cliquant sur le bouton  en haut à droite de la vue Library Importer, ou en cliquant sur le bouton  à côté de <All Libraries> ou d’une entrée de catégorie spécifique dans la liste Source Libraries.

Les options du panneau sont définies par les paramètres système par défaut ou par ceux spécifiés dans le modèle de composant appliqué, lui-même déterminé par le type de composant détecté dans la bibliothèque, à savoir LED dans l’exemple présenté ici. Ces paramètres sont également modifiables par l’utilisateur, ce qui vous permet d’adapter le processus d’importation selon vos besoins. Ils peuvent être rétablis à l’aide du lien Reset to Default (en haut à droite).

Les sections de l’onglet General du panneau sont les suivantes :

  • General:
    • Component Type – le type de composant détecté par l’outil d’importation pour la bibliothèque sélectionnée et, par association, le modèle appliqué (voir Component Template ci-dessous). Remplacez ce paramètre en modifiant le champ, ce qui créera un nouveau type de composant, ou en sélectionnant un autre type dans le menu déroulant (ou via le bouton ). Il s’agit d’une autre façon de résoudre un problème de composant non catégorisé. Choisissez l’option [LibraryName] pour définir le type sur le nom de la bibliothèque sélectionnée.
    • Component Template – le modèle de composant de l’espace de travail qui sera appliqué aux composants importés et, par association, leur paramètre de type de composant. Remplacez ce paramètre en sélectionnant un autre modèle dans le menu déroulant (ou via le bouton ). Définissez cette option sur [Create new] pour créer automatiquement un modèle à partir des paramètres de la bibliothèque source et des paramètres actuels de Library Importer, ou choisissez [No Template] pour empêcher l’application ou la création d’un modèle.

      Notez que les paramètres Component Type et Component Template sont liés lorsqu’ils sont définis sur un type/modèle disponible. Par exemple, si l’un est défini sur Capacitors, l’autre est automatiquement défini sur Capacitors. Toutefois, si dans ce cas le paramètre Component Template est remplacé par [Create New], un autre modèle Capacitors (dont le nom comporte un suffixe de version/révision approprié) sera créé pour respecter les paramètres actuels. Les modèles de composants existants ne sont pas modifiés par le processus d’importation.
  • Parameter Mapping – la correspondance entre les paramètres de la bibliothèque et ceux du modèle de composant appliqué (ou les paramètres par défaut lorsqu’aucun modèle n’est disponible), ainsi que le type de valeur de chaque paramètre (texte ou type prenant en charge les unités). Utilisez les options du menu déroulant de la colonne Source Library Parameter pour modifier la correspondance, et celles de la colonne Type pour remplacer le paramètre existant déterminé par le modèle ou les valeurs par défaut. Choisissez l’option <Skip> pour ne pas inclure un paramètre. Tout paramètre qui n’a pas été automatiquement associé à un paramètre de la bibliothèque source (défini sur <Skip> par le système) peut être associé manuellement à un paramètre approprié du modèle. Par exemple, le paramètre source ROHS peut être sélectionné pour correspondre au paramètre RoHS Compliant défini par le modèle de l’espace de travail. Les noms des paramètres peuvent être modifiés, et des ensembles de paramètres peuvent être ajoutés, modifiés et supprimés. Les paramètres de base des composants (ID, Name, Description) peuvent être réaffectés, mais sont autrement en lecture seule.

    Pour le paramètre de l’espace de travail ID, le paramètre de la bibliothèque source est défini sur <Auto>. Les identifiants des composants sont ainsi créés automatiquement à partir du Naming Template spécifié dans la section Component du panneau, sous l’onglet Advanced. La correspondance des identifiants peut être modifiée pour utiliser n’importe quel paramètre de la bibliothèque source (unique pour chaque entrée de composant), en choisissant une autre option dans le menu déroulant du paramètre de la bibliothèque source. Notez que les paramètres de base des composants (ID, Name, Description) peuvent être réaffectés, mais sont autrement en lecture seule.
  • Part Choice Mapping – la liste des paramètres de référence fabricant ou de lien fournisseur reconnus par l’outil d’importation, qui serviront à générer les entrées de choix de pièces pour les composants importés. Utilisez les options du menu déroulant pour redéfinir la correspondance, ou ajoutez et supprimez des ensembles de correspondances. Notez que, par défaut, les paramètres de référence fabricant et de lien fournisseur ne sont pas inclus (ils sont ignorés) dans le processus d’importation. Lorsqu’un composant de bibliothèque comporte plusieurs liens fournisseurs, la référence fournisseur principale (Supplier 1 / Supplier Part Number 1) est utilisée pour les entrées du champ de choix de pièces.
  • Import Checks – permet de consulter ou de définir la réponse de l’outil d’importation, sous forme d’erreur ou d’avertissement, aux violations des règles de validation de l’importation. Utilisez le menu déroulant Report Mode pour modifier la réponse et l’icône d’une entrée Violation Type. Notez que si le mode de signalement Fatal Error est sélectionné, le processus d’importation sera bloqué lorsque cette violation sera détectée.

L’onglet Advanced du panneau propose des paramètres pour tous les éléments d’objets de données de l’outil d’importation, tels qu’ils sont définis par les valeurs système par défaut ou le modèle de composant appliqué. Ils comprennent les modèles de composants, les fichiers de fiches techniques et tous les modèles de composants créés. À l’exception de l’option Datasheet (une commande d’activation/désactivation), les paramètres de chaque objet importé comprennent :

  • Folder – le dossier cible de l’espace de travail pour l’objet importé, qui peut être modifié manuellement (par exemple, pour créer un nouveau dossier cible) ou sélectionné à l’aide du bouton Parcourir ().
  • Naming Scheme – la spécification de nommage de l’objet dans l’espace de travail, telle qu’elle est définie par le modèle de composant ou, en l’absence de modèle actif, le schéma défini pour le dossier cible (ou saisi manuellement). Utilisez le menu déroulant pour choisir parmi les schémas de nommage disponibles. Notez qu’une modification du chemin du dossier cible (Folder) peut s’accompagner d’une modification du schéma de nommage appliqué, tel qu’il est défini par le dossier lui-même ou par un modèle de composant appliqué/associé.
  • Revision Naming Scheme – le schéma de nommage utilisé pour les révisions de l’objet dans l’espace de travail, tel qu’il est défini par le modèle appliqué ou sélectionné dans le menu déroulant de l’entrée. Seuls les schémas activés dans le système seront proposés.
  • Lifecycle Definition – le système de cycle de vie utilisé pour l’objet, tel que défini par le modèle appliqué ou sélectionné dans les options du menu déroulant de l’entrée. Seules les définitions activées par le système seront disponibles.
La section de l’objet Component comprend le paramètre Duplicates Detection, comme indiqué ci-dessus.

Exportation et importation de la configuration

Le Library Importer permet d’exporter un fichier texte détaillé qui enregistre la configuration actuelle, notamment tous les paramètres d’importation configurables tels que les chemins cibles, le mappage des paramètres, le schéma de nommage, les définitions des cycles de vie, les types de composants cibles, etc.

Le fichier de configuration de l’outil d’importation est enregistré à l’aide de la commande File » Export » Importer Config au format *.lmcfg et peut être restauré à tout moment via l’option de menu File » Import » Importer Config.

La possibilité de restaurer une configuration est particulièrement utile lorsque la base de données source ou la bibliothèque basée sur des fichiers a été mise à jour et que ces modifications doivent être importées dans le Workspace. Si la configuration a été exportée lors de la première importation de la bibliothèque, la configuration restaurée (importée) rétablira exactement les paramètres utilisés, ce qui garantit un schéma de transfert de données cohérent pour cette bibliothèque (ou ces bibliothèques).

Notez qu’un fichier de configuration de l’outil d’importation exporté (enregistré) contient des références aux fichiers de bibliothèque qui étaient ouverts en tant que bibliothèques sources lors de l’exportation de la configuration. Lorsque ce fichier de configuration est ensuite importé (rechargé), au moins une des bibliothèques référencées dans la configuration doit être disponible, c’est-à-dire qu’elle doit être accessible en tant que bibliothèque source dans le Library Importer.
AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents