Cet article vous explique comment créer un plan de fabrication de faisceau dans Altium Designer à l’aide de l’éditeur Draftsman. Il vous guide depuis l’ajout du document à votre projet et sa configuration jusqu’à l’insertion de vues en lecture seule du schéma de câblage et du plan d’implantation, l’ajout de vues de détail et de composants, puis l’utilisation d’annotations, de cotes et de tableaux pour documenter la conception en vue de sa fabrication. Il explique également comment répercuter les mises à jour du schéma de câblage et du plan d’implantation dans le plan de fabrication, ainsi que la gestion des propriétés, des unités, des paramètres et de la navigation entre les feuilles du document. Pour comprendre comment les données de conception d’un faisceau sont transformées en une documentation de fabrication structurée, poursuivez votre lecture et découvrez l’ensemble du processus.
- Apprenez à créer et à configurer un document de plan de fabrication de faisceau dans Draftsman, notamment les modèles, les paramètres du document, les unités et les paramètres importés du projet.
- Découvrez les types de vues, d’annotations, de cotes et d’outils de dessin supplémentaires que vous pouvez ajouter pour représenter clairement les informations de conception du faisceau.
- Découvrez les tableaux de fabrication disponibles, notamment les nomenclatures, les listes de câblage et les tableaux de connexions, ainsi que la manière dont leurs données sont obtenues et présentées.
Approfondissez avec l'IA :
Une fois le schéma de câblage et le plan d’implantation terminés, des copies en lecture seule de leur contenu peuvent être placées dans le document de plan de fabrication (*.HarDwf) et annotées selon les besoins. Le plan de fabrication d’un faisceau est créé dans l’éditeur Draftsman.
Ajoutez un plan de fabrication au projet de faisceau depuis le panneau Projects en faisant un clic droit sur l’entrée du projet, puis en sélectionnant Add New to Project » Draftsman Document dans le menu contextuel (ou utilisez la commande File » New » Draftsman Document dans les menus principaux). Dans la boîte de dialogue New Document qui s’ouvre, sélectionnez un modèle de plan de fabrication disponible selon vos besoins et vérifiez que les éléments Project et le plan d’implantation du faisceau Document appropriés sont sélectionnés.
Configuration d’un document de plan de fabrication
Les options d’un document de plan de fabrication peuvent être configurées dans le panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception du document. Consultez la page Configuration d’un document Draftsman pour en savoir plus.
Les onglets du panneau Properties lorsqu’aucun objet n’est sélectionné dans le document de plan de fabrication du faisceau
Une fois le document de plan de fabrication créé, toute modification apportée au schéma de câblage ou au plan d’implantation peut être importée dans le plan de fabrication à l’aide de la commande Tools » Import Changes From <LayoutDrawing.LdrDoc> des menus principaux ou du menu contextuel de l’espace de conception. Notez que, malgré la description de la commande dans le menu, celle-ci importe les modifications de both the wiring diagram and the layout drawing.
Les propriétés par défaut des objets du plan de fabrication peuvent être configurées sur la page Draftsman – Defaults de la boîte de dialogue Preferences. Ces propriétés seront appliquées aux objets placés ultérieurement.
Le panneau Bookmarks offre un moyen pratique de parcourir et de gérer un plan de fabrication comportant plusieurs feuilles. Le panneau présente une arborescence développable de la structure complète du document, qui comprend toutes les feuilles du document et les principaux objets de vue qu’elles contiennent.
À l’aide des options Units et Dual_Units du panneau Properties, lorsqu’aucun objet n’est sélectionné dans l’espace de conception, vous pouvez sélectionner les unités de mesure par défaut du document pour les valeurs de cote et les valeurs de longueur affichées dans les tableaux. Si nécessaire, les unités définies au niveau du document peuvent être remplacées dans les propriétés d’objets spécifiques. Les unités prises en charge sont Millimeters, Mils, Inches, Centimètres, Mètres et Feet.
Les paramètres du document de plan d’implantation sont importés dans le document de plan de fabrication du faisceau associé. Ces paramètres sont répertoriés dans l’onglet Parameters du panneau Properties du document (l’affichage des paramètres d’implantation dans la liste peut être activé ou désactivé à l’aide de la case à cocher située à côté de l’icône dans le panneau) et peuvent être utilisés dans des chaînes spéciales. Les valeurs de paramètres calculées, telles que =ItemRevision et =ItemRevisionLevel1, sont également incluses et interprétées dans les sorties générées lors de la publication.
Utilisation des vues
Dans un document de plan de fabrication, vous pouvez placer des vues en lecture seule du schéma de câblage et du plan d’implantation du faisceau inclus dans ce projet.
Vue du schéma de câblage
Une vue du schéma de câblage (Place » Wiring Diagram View) est une représentation graphique composite générée automatiquement à partir du schéma de câblage du projet de conception de faisceau actif.
Exemple de vue du schéma de câblage
Les propriétés d’une vue de schéma de câblage placée peuvent être configurées dans le panneau Properties lorsque la vue est sélectionnée dans l’espace de conception.
Le panneau Properties lorsqu’une vue du schéma de câblage est sélectionnée
Si votre projet de faisceau comprend plusieurs documents de schéma de câblage (en savoir plus), vous pouvez choisir le document de schéma de câblage à partir duquel une vue placée doit être générée et mise à jour. Lorsque la vue du schéma de câblage est sélectionnée, utilisez la liste déroulante Document dans la zone Properties du panneau Properties pour choisir le document de schéma de câblage de cette vue ().
Lorsque Auto Size est activé, la vue du schéma de câblage ajuste automatiquement sa taille pour supprimer les espaces vides sur les bords.
Sélectionnez Justification en cliquant sur la flèche correspondant à l’alignement souhaité ou sur le cercle pour centrer. L’option choisie pour Justification définit le point par rapport auquel la position de la vue est modifiée si sa taille est mise à jour.
Vue du plan d’implantation
Une vue du plan d’implantation (Place » Layout Drawing View) est une représentation graphique composite générée automatiquement à partir du plan d’implantation du projet de conception de faisceau actif.
Exemple de vue du plan d’implantation
Les propriétés d’une vue de plan d’implantation placée peuvent être configurées dans le panneau Properties lorsque la vue est sélectionnée dans l’espace de conception.
Le panneau Properties lorsqu’une vue du plan d’implantation est sélectionnée
Lorsque Auto Size est activé, la vue du plan d’implantation ajuste automatiquement sa taille pour supprimer les espaces vides sur les bords.
Sélectionnez Justification en cliquant sur la flèche correspondant à l’alignement souhaité ou sur le cercle pour centrer. L’option choisie pour Justification définit le point par rapport auquel la position de la vue est modifiée si sa taille est mise à jour.
Vues supplémentaires
Des vues supplémentaires peuvent être utilisées pour compléter votre plan de fabrication : vue de détail du faisceau et vue de composant.
Une vue de détail du faisceau permet d’afficher une zone définie d’un dessin existant sous la forme d’une vue flottante agrandie. Des zones circulaires et rectangulaires sont disponibles pour une vue de détail du faisceau. Pour placer la vue souhaitée, sélectionnez une option (Circle area detail view ou Rectangle area detail view) dans le menu principal Place » Additional Views » Harness Detail View.
Exemple de vue de détail du faisceau avec une zone circulaire appliquée à une vue du schéma de câblage
Exemple de vue de détail du faisceau avec une zone rectangulaire appliquée à une vue du schéma de câblage
La vue de composant (Place » Additional Views » Component View) est une vue de dessin d’un seul composant de la conception de faisceau actuelle.
Exemple de vue de composant
Annotation et cotation du dessin
Une gamme d’outils supplémentaires d’annotation, de cotation et de dessin permet d’ajouter des informations importantes à un plan de fabrication. Ces outils comprennent des systèmes automatisés de notes et de mise en évidence, ainsi que des outils permettant d’indiquer les longueurs, les dimensions et les angles des contours des objets, ou la distance entre des objets désignés.
Exemple de vue de plan d’implantation annotée
Un repère associé à un connecteur ou à un point de connexion et configuré pour afficher l’article de nomenclature indique les numéros de position dans la nomenclature du connecteur ou du point de connexion lui-même, ainsi que de ses pièces associées. Un repère ajouté à la vue physique d’un composant dans une vue de plan d’implantation affiche également les numéros de position dans la nomenclature de toutes les alvéoles affectées à ce composant.
Lorsqu’une cote linéaire est placée entre des points de connexion dans une vue de plan d’implantation, le champ Value (la longueur de la cote) est automatiquement renseigné avec la longueur du faisceau correspondante.
Consultez les pages suivantes pour en savoir plus :
Un document de plan de fabrication permet de placer une nomenclature (BOM), une liste de câblage, une table de connexions et un tableau générique sur le plan. Les données tabulaires sont directement issues des documents du projet et constituent un moyen simple et visuel de communiquer les informations essentielles aux processus de fabrication des faisceaux.
Dans les propriétés de la nomenclature, de la liste de câblage et des tables de connexions, vous pouvez spécifier Length Units et la longueur Value Precision (en remplaçant les valeurs définies au niveau du document). Les options sélectionnées seront appliquées aux valeurs de longueur affichées dans le tableau correspondant.
Pour les composants de câblage du faisceau, la colonne Length d’un tableau de nomenclature présente la longueur totale des fils/câbles correspondant au même article de nomenclature, plutôt que leurs longueurs individuelles.
Les gaines de fils, de câbles et de faisceaux sont des objets définis par leur longueur, dont la valeur est affichée dans le champ Length . Le champ Quantity de ces objets est As Required.
Lorsqu’un objet tableau est copié depuis le document de plan de fabrication, son contenu peut être collé dans une feuille de calcul Microsoft Excel.
Une liste de câblage (Place » Wiring List) est un objet tableau généré automatiquement qui affiche les points de départ et d’arrivée ainsi que les valeurs des paramètres de chaque fil du faisceau.
Exemple de liste de câblage
Les propriétés d’une liste de câblage placée (telles que ses attributs visuels et son contenu) peuvent être configurées dans le panneau Properties lorsque la liste de câblage est sélectionnée dans l’espace de conception.
Les onglets du panneau Properties lorsqu’une liste de câblage est sélectionnée
Les désignateurs des objets de blindage avec connexion sont affichés dans la liste de câblage lorsqu’un fil est connecté à l’objet.
Si le paramètre Include Cut d’un fil a pour valeur No, ce fil ne figurera pas dans la liste de câblage.
Les paramètres des fils (et leurs valeurs) spécifiés dans le schéma de câblage sont repris dans la liste de câblage. Une colonne supplémentaire est ajoutée à la liste de câblage pour chaque paramètre de fil. Ces colonnes supplémentaires sont masquées par défaut. Utilisez les commandes de visibilité de l’onglet Columns du panneau Properties lorsque la liste de câblage est sélectionnée pour afficher ces colonnes dans l’espace de conception (et masquer les colonnes par défaut si nécessaire).
Les cellules de la colonne Color sont divisées pour afficher les couleurs secondaire et tertiaire affectées au fil.
La colonne ColorName comprend les noms des couleurs principale, secondaire et tertiaire.
Des colonnes supplémentaires pour les couleurs secondaire, tertiaire et de bordure peuvent être affichées.
Pour les fils d’un câble, la colonne Length d’une liste de câblage affiche la longueur individuelle de chaque fil.
Pour le connecteur de traversée de cloison (le connecteur comportant le plus grand nombre d’alvéoles), un regroupement automatique est appliqué à la liste de câblage afin de garantir que toutes ses alvéoles sont correctement regroupées dans la colonne From.
Utilisez les boutons et pour déplacer d’une position vers la gauche ou vers la droite, dans la liste de câblage, une colonne visible dont l’entrée est sélectionnée dans l’onglet Columns.
Cliquez sur une cellule de la colonne Order pour faire défiler les options d’ordre de tri des données des colonnes du tableau (désactivé, croissant et décroissant). Le tri peut être appliqué à plusieurs colonnes par ordre de priorité en maintenant la touche Ctrl enfoncée et en cliquant sur les cellules de la colonne Order.
Le connecteur comportant le plus de fils (et toutes ses alvéoles) est automatiquement regroupé dans la colonne From ().
Fractionnement d’une liste de câblage
La liste de câblage d’un faisceau complexe peut comporter un grand nombre d’entrées, ce qui peut rendre difficile son insertion dans un document de dessin sous la forme d’un tableau unique. Plutôt que de modifier l’échelle de la police et du tableau, de créer plusieurs tableaux personnalisés ou d’utiliser un document externe, vous pouvez « fractionner » un tableau de liste de câblage afin que celle-ci soit présentée sur plusieurs « pages ».
Dans le panneau Properties d’une liste de câblage placée, activez l’option Limit Page Height dans la zone Pages pour limiter la hauteur du tableau à la valeur spécifiée (Max Page Height) et, par conséquent, le nombre de lignes affichées dans le tableau.
Javascript ID : Harness_MD_WiringList_LimitPageHeight_AD25_3
L’éditeur détecte que la liste de câblage n’est pas affichée dans son intégralité, comme l’indique l’entrée Page du panneau (par exemple, Page 1 from 2), et le menu déroulant associé vous permet de choisir la page à afficher. Pour ajouter d’autres pages de la liste de câblage, placez une autre liste de câblage et spécifiez la valeur Page suivante dans la zone Pages du panneau Properties .
Puisque chaque page de la liste de câblage est placée en ajoutant un autre tableau de liste de câblage, puis en le configurant en conséquence, les différentes pages peuvent être placées sur n’importe quelle feuille du document de plan de fabrication.
Notez que la propriété Max Page Height spécifie la hauteur de la page first dans le tableau de liste de câblage. Lorsque la deuxième page est sélectionnée (Page 2), la propriété Max Page Height définit la hauteur de la première page exclue (Page 1). La page 2 affiche donc les entrées restantes de la liste de câblage. Commencez par rendre le Max Page Height propriété identique pour chaque page.
Tableau des connexions
Un tableau des connexions (Place » Connection Table) est un objet tableau généré automatiquement qui présente les fils raccordés à chaque point de connexion (broche de connecteur, épissure, etc.) du faisceau.
Exemple de tableau des connexions (pour tous les composants)
Les propriétés d’un tableau des connexions placé (telles que les attributs visuels et les données affichées) peuvent être configurées dans le panneau Properties lorsque le tableau est sélectionné dans l’espace de conception.
Les onglets du panneau Properties lorsqu’un tableau des connexions est sélectionné
Vous pouvez utiliser l’option Component pour afficher dans le tableau les données de tous les composants du projet ou celles d’un composant ou d’une épissure spécifique.
Si la valeur du paramètre Include Cut d’un fil est No, ce fil ne sera pas présenté dans le tableau des connexions.
Les paramètres des fils (et leurs valeurs) spécifiés dans le schéma de câblage sont repris dans le tableau des connexions. Une colonne supplémentaire est ajoutée au tableau pour chaque paramètre de fil. Ces colonnes supplémentaires sont masquées par défaut. Lorsque le tableau des connexions est sélectionné, utilisez les commandes de visibilité de l’onglet Columns du panneau Properties pour afficher ces colonnes dans l’espace de conception (et masquer les colonnes par défaut si nécessaire).
Les cellules de la colonne Color sont divisées pour afficher les couleurs secondaire et tertiaire attribuées au fil.
La colonne ColorName contient les noms des couleurs principale, secondaire et tertiaire.
Des colonnes supplémentaires pour les couleurs secondaire, tertiaire et de bordure peuvent être affichées.
Pour les fils d’un câble, la colonne Length du tableau des connexions affiche la longueur individuelle de chaque fil.
Utilisez les boutons et pour déplacer d’une position vers la gauche ou la droite, dans le tableau des connexions, une colonne visible dont l’entrée est sélectionnée dans l’onglet Columns.
Cliquez sur une cellule de la colonne Order pour parcourir les options d’ordre de tri des données des colonnes du tableau (désactivé, croissant et décroissant). Le tri peut être appliqué à plusieurs colonnes selon un ordre de priorité en maintenant la touche Ctrl enfoncée et en cliquant sur les cellules de la colonne Order.
Utilisez la liste déroulante Display du panneau Properties pour configurer les données affichées dans le tableau :
Wires Only – afficher uniquement les broches auxquelles des fils sont raccordés.
Wires & Parts – afficher les broches auxquelles des fils sont raccordés ainsi que les accessoires d’alvéole ajoutés, tels qu’un bouchon dans le cas d’un connecteur étanche sans fil.
All Cavities – afficher toutes les broches de tous les composants, quels que soient les fils raccordés et les accessoires d’alvéole ajoutés (par exemple, si un composant comporte 10 broches, les 10 broches seront affichées dans le tableau).
No Connect – afficher uniquement les objets « non connecté ».
Fractionnement d’un tableau des connexions
Le tableau des connexions d’une conception de faisceau complexe peut comporter un grand nombre d’entrées, ce qui peut rendre difficile son intégration dans un document de mise en plan sous la forme d’un tableau unique. Plutôt que de modifier la taille de la police et l’échelle du tableau, de créer plusieurs tableaux personnalisés ou d’utiliser un document externe, vous pouvez « fractionner » un tableau des connexions dans un document Harness Draftsman (*.HarDwf) afin de le répartir sur plusieurs « pages ». Dans le panneau Properties d’un tableau des connexions placé, activez l’option Limit Page Height dans la zone Pages pour utiliser cette nouvelle fonctionnalité. La hauteur du tableau des connexions sera alors limitée à la valeur spécifiée (Max Page Height), ce qui limitera le nombre de lignes affichées dans le tableau.
L’éditeur détecte que le tableau des connexions n’est pas affiché dans son intégralité, comme l’indique l’entrée Page du panneau (par exemple, 1 from 2), et le menu déroulant associé vous permet de choisir la page affichée. Pour ajouter d’autres pages du tableau des connexions, placez un autre tableau des connexions (Place » Connection Table) et spécifiez la valeur Page suivante dans la zone Pages du panneau Properties .
La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.