Création du plan d’implantation

En un coup d'œil

Cet article vous guide dans la création d’un plan d’implantation de faisceau dans Altium Designer une fois votre schéma de câblage terminé. Il explique d’abord comment ajouter le document d’implantation, configurer ses principales options et importer les données du schéma de câblage. Il présente également la manière dont les composants apparaissent dans le plan, les propriétés que vous pouvez configurer et comment basculer entre les représentations symboliques et les modèles physiques pour mieux visualiser l’implantation. Pour découvrir concrètement comment transformer les données de conception de votre faisceau en un plan d’implantation physique et comprendre les principales options de configuration, poursuivez votre lecture : cet article vous donnera les repères nécessaires pour réaliser l’implantation de votre faisceau en toute confiance.

- Apprenez à créer et à configurer un document de plan d’implantation de faisceau, notamment les unités, les grilles, les options de page et les modèles.
- Découvrez comment importer les données du schéma de câblage dans le plan d’implantation et comment y répercuter ultérieurement les mises à jour du schéma.
- Comprenez comment les composants sont représentés et configurés dans le plan d’implantation, notamment les vues symboliques et les modèles physiques, ainsi que les propriétés associées.
Approfondissez avec l'IA :

Une fois la conception du faisceau saisie sous la forme d’un schéma de câblage, sa représentation physique peut être créée sous la forme d’un plan d’implantation du faisceau (*.LdrDoc). Ajoutez ce document au projet de faisceau depuis le panneau Projects en faisant un clic droit sur l’entrée du projet, puis en sélectionnant Add New to Project » Harness Wiring Diagram dans le menu contextuel (ou utilisez la commande File » New » Harness Layout Drawing dans les menus principaux).

Configuration d’un document de plan d’implantation de faisceau

Les options d’un document de plan d’implantation peuvent être configurées dans le panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception du document. Les principaux paramètres sont les suivants :

  • Dans la zone General de l’onglet General du panneau, sélectionnez les unités de mesure applicables au document et à ses éléments graphiques, puis définissez les grilles pour faciliter le placement. Altium Designer propose trois types de grilles : une grille visible pour la navigation, une grille d’accrochage pour le placement et une distance d’accrochage pour faciliter la création des connexions.

  • Dans la zone Page Options de l’onglet General du panneau, configurez le format de la feuille et le cartouche du document, ou sélectionnez un modèle de plan d’implantation de faisceau parmi ceux disponibles.

Les onglets General et Parameters du panneau Properties lorsqu’aucun objet n’est sélectionné dans le document de plan d’implantation de faisceau 
Les onglets General et Parameters du panneau Properties lorsqu’aucun objet n’est sélectionné dans le document de plan d’implantation de faisceau

  • La configuration d’un document de plan d’implantation de faisceau est similaire à celle d’un document schématique (*.SchDoc) dans un projet de conception de PCB. Consultez la page Configuration d’un document schématique pour en savoir plus.

  • Utilisez la liste déroulante Length Units pour choisir les unités de longueur du document. Les valeurs Length Value et Offset Length des objets de type toron Length seront affichées dans les unités sélectionnées. Les unités prises en charge sont mm, cm, m, in et ft. Les unités de longueur par défaut des nouveaux documents de plan d’implantation peuvent être définies sur la page Conception de faisceaux – Général de la boîte de dialogue Preferences.

  • Pour en savoir plus sur la création de modèles de documents de plan d’implantation, consultez la page Création de modèles de documents de faisceau.

  • Les propriétés par défaut des objets de plan d’implantation de faisceau peuvent être configurées sur la page Conception de faisceaux – Valeurs par défaut de la boîte de dialogue Preferences. Ces propriétés seront appliquées aux objets placés par la suite.

  • Lors de la création d’un document de plan d’implantation de faisceau, vous pouvez également utiliser des objets texte et des objets de dessin. L’utilisation de ces objets dans un document de plan d’implantation de faisceau est similaire à leur utilisation dans un document schématique (*.SchDoc) d’un projet de conception de PCB. Consultez les pages Utilisation des objets texte dans un schéma et Utilisation des objets de dessin dans un schéma pour en savoir plus sur ces objets.

    • Notez que les liens actifs vers les objets du schéma de câblage du faisceau (par exemple, les fils et les composants) et les objets du plan d’implantation du faisceau (par exemple, les torons et les points de connexion) sont également pris en charge dans les cadres de texte et les notes. Cliquez sur un lien dans le cadre de texte ou la note placé pour localiser l’objet correspondant dans le document associé.

  • Plusieurs contrôles sont disponibles pour détecter les violations logiques, électriques et de dessin dans votre plan d’implantation de faisceau. Consultez la page Validation de la conception du faisceau pour en savoir plus.

  • Un document de plan d’implantation de faisceau peut être enregistré au format ASCII, ce qui peut être utile pour le partage. Utilisez la commande File » Save As et sélectionnez Harness Layout ascii (*.LdrDoc) dans la liste déroulante Save as type de la boîte de dialogue Save As qui s’ouvre. Lors de l’enregistrement d’un plan d’implantation ASCII à l’aide de la commande File » Save, la boîte de dialogue File Format s’ouvre pour vous avertir que le format ASCII est utilisé. Choisissez la version ASCII dans la boîte de dialogue   pour continuer à utiliser ce format.

Importation des données du schéma de câblage

Sélectionnez la commande Design » Import Wiring Diagram dans les menus principaux pour importer les données de conception du schéma de câblage. Les composants seront placés sur la feuille du plan d’implantation aux positions relatives définies dans le schéma de câblage. Les points de connexion associés aux composants seront également placés à côté de chaque composant sur le plan d’implantation.

Document de plan d’implantation de faisceau contenant les données importées du schéma de câblage
Document de plan d’implantation de faisceau contenant les données importées du schéma de câblage

 
 
 
 
 
  • Après l’exécution de la commande, les modifications appliquées sont répertoriées dans le panneau Messages ().

  • Toute modification du schéma de câblage peut être importée dans le plan à l’aide de la même commande Design » Import Wiring Diagram.

Utilisation des composants

Initialement, chaque composant est représenté sur le plan d’implantation par son symbole. Les propriétés d’un composant placé peuvent être configurées dans le panneau Properties lorsque le composant est sélectionné dans l’espace de conception. Le panneau Properties d’un composant comprend les onglets suivants :

 
 
 
 
 
  • General – propriétés générales du composant, telles que le repère et le commentaire, l'emplacement, la représentation du modèle, les paramètres, etc.

  • Pins – liste des broches du composant.

  • Cavities – vue en lecture seule des alvéoles de connecteur affectées au composant. Les affectations d'alvéoles ne peuvent être modifiées que dans le schéma de câblage – en savoir plus.

  • Associated Parts – permet d'affecter au composant des pièces supplémentaires, telles que de la gaine thermorétractable.

Lorsque vous collez des composants de faisceau coupés ou copiés sur un plan d'implantation de faisceau, les repères des composants collés respectent l'option Reset Parts Designators On Paste de la page Schéma – Édition graphique de la boîte de dialogue Preferences. Lorsque des composants sont collés, la partie numérique de leurs repères est réinitialisée à ? si cette option est activée.

Configuration de la représentation d'un composant

À l'aide de l'option Graphical Symbol / Physical Model dans la zone Model du panneau Properties (sous l'onglet General), lorsqu'un composant est sélectionné, vous pouvez basculer entre la représentation par symbole (le symbole du composant) et la projection du modèle 3D (l'empreinte du composant). Utilisez les autres paramètres de cette zone du panneau pour configurer la représentation.

Javascript ID : Harness_LD_HarnessComponent_ModelType_AD25

Un composant représenté par son symbole schématique

Le même composant représenté par la projection de son modèle 3D

Lorsque vous utilisez la représentation Physical Model, utilisez les options Style pour afficher le modèle sous forme de Solid (sans lignes) ou de Wireframe. Utilisez les options de la liste déroulante Side pour sélectionner la vue souhaitée du modèle (des options orthogonales et isométriques sont disponibles). Les images ci-dessous illustrent certains paramètres et les résultats correspondants dans l'espace de conception.

Javascript ID : Harness_LD_HarnessComponent_ModelType_Footprint_Config_AD25

Vous pouvez faire pivoter graphiquement une vue de modèle physique dans l'espace de conception en saisissant avec la souris la poignée de rotation située en bas à droite de la vue du modèle ; le champ Rotation est automatiquement mis à jour (la rotation s'effectue par incréments de 1 degré). Vous pouvez également maintenir la touche Alt enfoncée pour limiter la rotation à des incréments de 45 degrés. Pour vous guider, lorsque vous faites pivoter la vue avec la souris, l'angle actuel s'affiche dans Status Bar.

Si une conception contenant des modèles ayant subi une rotation selon des valeurs personnalisées est ouverte dans une version d'Altium Designer antérieure à la version 26.9, un message d'avertissement de rétrocompatibilité s'affiche. Vous pouvez régénérer les modèles physiques à l'aide de la fonctionnalité précédente, c'est-à-dire les sélections dans les listes déroulantes. 

  • Pour les deux styles Solid et Wireframe, la valeur Zoom définit la taille du cadre de délimitation vert de la vue du modèle dans l'espace de conception, et la vue du modèle s'inscrit toujours dans ce cadre.

  • Pour faciliter l'intégration lors de l'utilisation d'Altium MCAD CoDesigner avec des projets de conception de faisceaux, les modèles 3D utilisés dans les vues physiques des composants de faisceau sont incorporés (au format Parasolid) au document du plan d'implantation. Tout modèle 3D manquant (existant mais non incorporé) sera incorporé après l'enregistrement du document (File » Save). Cette fonctionnalité est en bêta ouverte et est disponible lorsque l'option HarnessDesign.Embed3DModel est activée dans la boîte de dialogue Paramètres avancés.

Adding Multiple Physical Model Views

  • Utilisez la flèche de la liste déroulante pour afficher et modifier les propriétés d'une vue physique ().

  • Vous pouvez ajouter plusieurs vues de modèle physique pour un composant à l'aide de la commande Add Component View du panneau Properties ().

  • Les vues physiques supplémentaires ajoutées à un composant peuvent être déplacées indépendamment dans l'espace de conception par glisser-déposer.

  • Quelle que soit la vue de modèle physique d'un composant sélectionnée dans l'espace de conception, le panneau Properties  affiche les propriétés du composant lui-même.

Définition de l’agencement physique sur un plan d’implantation de faisceau

Toutes les connexions physiques au sein du faisceau sont définies sous forme de torons (même si un toron ne contient qu’un seul fil). Chaque toron doit commencer et se terminer à un point de connexion. Lors de l’importation initiale des données de conception du faisceau (comme décrit ci-dessus), un point de connexion est automatiquement placé à côté de chaque composant et associé à ce composant ainsi qu’à toutes ses broches. Si la structure physique de la conception l’exige, de nouveaux points de connexion peuvent être placés et les objets affectés à un point de connexion peuvent être configurés.

Pour faciliter la compréhension de la connectivité des composants dans le document du plan d’implantation de faisceau, vous pouvez y afficher le graphe de connectivité. Lorsque l’option Connective Graph est activée sur la page System – Navigation de la boîte de dialogue Preferences, utilisez le raccourci Alt+Click sur un composant pour afficher le graphe de connectivité dans l’espace de conception (). Effacez le graphe à l’aide du raccourci Shift+C ou de la commande Clear Filter du menu contextuel de l’espace de conception.

Utilisation des points de connexion

Pour placer un nouveau point de connexion, utilisez la commande Place » Connection Point des menus principaux. Les points de connexion s’affichent dans l’espace de conception comme illustré ci-dessous.

Les propriétés d’un point de connexion placé (son emplacement, sa représentation visuelle, etc.) peuvent être configurées dans le panneau Properties lorsque le point de connexion est sélectionné dans l’espace de conception.

Le panneau Properties lorsqu’un point de connexion est sélectionné
Le panneau Properties lorsqu’un point de connexion est sélectionné

Utilisez la zone Associated Parts du panneau Properties d’un point de connexion sélectionné pour gérer la liste des pièces associées à ce point de connexion, c’est-à-dire les objets physiques que vous souhaitez associer à la représentation graphique affichée. Le modèle 3D d’une pièce associée à un point de connexion peut servir à représenter ce point de connexion dans le document. Lorsqu’un point de connexion est sélectionné, choisissez Physical Model dans la zone Properties du panneau Properties, puis utilisez la liste déroulante Associated Part de la zone Type pour sélectionner la pièce associée souhaitée (). Le modèle sera généré et affiché dans le document. Utilisez les options de la zone Type pour configurer l’affichage du modèle ().

Pour faciliter l’intégration lors de l’utilisation d’Altium MCAD CoDesigner avec des projets de conception de faisceaux, les modèles 3D utilisés dans les vues physiques des points de connexion sont incorporés (au format Parasolid) au document du plan d’implantation. Tous les modèles 3D manquants (existants mais non incorporés) seront incorporés après l’enregistrement du document (File » Save). Cette fonctionnalité est en bêta ouverte et disponible lorsque l’option HarnessDesign.Embed3DModel est activée dans la boîte de dialogue Advanced Settings.

Affectation d’objets aux points de connexion

Les objets affectés à un point de connexion peuvent être configurés selon vos besoins et vos intentions de conception. Un ou plusieurs objets (composants, épissures/dérivations, objets « non connecté » et blindages avec connexion) peuvent être affectés à un point de connexion à l’aide de la boîte de dialogue Add Assigned Objects, accessible en cliquant sur le bouton   dans la zone Assigned Objects  du panneau Properties .

  • Par défaut, l’option Show only unassigned objects est activée dans la boîte de dialogue, et seuls les objets qui ne sont pas actuellement affectés à d’autres points de connexion sont répertoriés. Désactivez cette option pour afficher la liste de tous les objets du plan d’implantation.

  • Si un objet déjà affecté à un autre point de connexion est sélectionné dans la boîte de dialogue, les avertissements et icônes correspondants s’affichent ().

  • Pour éviter qu’une épissure soit affectée à plusieurs points de connexion, elle est automatiquement retirée d’un point de connexion si elle est déjà affectée à un autre.

Lorsqu’un composant est affecté à un point de connexion, une ligne mixte s’affiche dans l’espace de conception entre le composant et le point de connexion, comme illustré ci-dessous. Dans Properties, vous pouvez sélectionner les broches du composant à affecter. Cliquez sur la cellule de la colonne Pins du tableau dans la zone Assigned Objects pour accéder à la liste déroulante et sélectionner les broches souhaitées.

Lorsque vous faites glisser un point de connexion sur un autre (si l’opération est valide) dans le plan d’implantation, les deux sont réunis en un seul objet et leurs listes d’objets affectés sont fusionnées.

Utilisation des torons de faisceau

Pour placer un nouveau toron de faisceau, utilisez la commande Place » Harness Bundle des menus principaux (raccourci : Shift+B).

Après avoir sélectionné la commande, cliquez sur un point de connexion (une croix rouge apparaît au niveau du curseur lorsqu’il se trouve sur le point actif d’un point de connexion) pour placer le point de départ du toron de faisceau. Positionnez le curseur et cliquez pour ancrer une série de sommets définissant la forme du toron de faisceau. Après avoir placé le dernier sommet sur le point actif d’un autre point de connexion, cliquez avec le bouton droit pour terminer le placement.

Par défaut, un toron de faisceau est placé en mode de placement Any Angle. Lors du placement d’un toron de faisceau, appuyez sur Shift+Spacebar pour parcourir les modes de placement. Le mode détermine la manière dont les angles sont créés lors du placement des torons, ainsi que les angles selon lesquels les torons peuvent être placés.  En mode 90 Degree ou 45 Degree (modes véritablement orthogonaux), appuyez sur Spacebar pour alterner entre les sous-modes de début et de fin. Le mode et le sous-mode actuels sont indiqués dans la barre d’état.

Exemple de toron de faisceau placé entre les points de connexion CP1 et CP_P2.
Exemple de toron de faisceau placé entre les points de connexion CP1 et CP_P2.

Une fois le faisceau placé et sélectionné, ses sommets peuvent être déplacés pour modifier l’angle entre deux sections adjacentes.

  • Lorsque des faisceaux sont raccordés à un point de connexion, les épissures qui ne sont pas encore affectées sont automatiquement affectées à ce point de connexion conformément au schéma de câblage.

  • Un point de connexion peut être placé directement sur un faisceau existant. Le faisceau d’origine est alors scindé en deux faisceaux distincts.

  • Lorsqu’un point de connexion qui scinde un faisceau en deux sur un plan d’implantation est supprimé, les deux faisceaux sont automatiquement fusionnés en un seul objet faisceau.

Les propriétés d’un faisceau placé (emplacement, représentation visuelle, etc.) peuvent être configurées dans le panneau Properties lorsque le faisceau est sélectionné dans l’espace de conception.

Le panneau Properties lorsqu’un faisceau est sélectionné
Le panneau Properties lorsqu’un faisceau est sélectionné

Chaque faisceau contient automatiquement les objets (fils et/ou câbles) correspondant à la connectivité définie dans le schéma de câblage. Ces objets sont répertoriés dans la zone Bundle Objects du panneau Properties lorsque le faisceau est sélectionné. Cliquez sur un objet de cette liste pour mettre en surbrillance tous les faisceaux traversés par l’objet sélectionné.

Dans le cas d’une structure physique de faisceau complexe et ramifiée, vous devrez peut-être réaffecter un fil à un autre faisceau. Utilisez la liste déroulante de la zone Bundle Objects Assignment du panneau Properties lorsque le faisceau concerné est sélectionné dans l’espace de conception pour modifier l’affectation du fil à ce faisceau selon vos besoins.

Le champ Length de la zone Properties du panneau permet de définir la longueur du faisceau sélectionné. Les longueurs des fils et des câbles qui traversent les faisceaux sont calculées à partir des valeurs Length de ces faisceaux. Les longueurs calculées des fils et des câbles sont affichées dans la colonne Length Value du tableau de la zone Bundle Objects du panneau.

Ajout d’une vue de segment de fils

La vue de segment de fils affiche les fils présents dans le segment, c’est-à-dire les fils individuels, les paires torsadées et les fils faisant partie de câbles. Elle permet de voir précisément comment les fils s’agencent physiquement à l’intérieur du segment de faisceau. Chaque fil est étiqueté et affiché dans la couleur qui lui a été attribuée, avec une épaisseur correspondant à la valeur de son paramètre Thickness (défini dans le schéma de câblage (*.WirDoc)). Vous pouvez placer une vue d’un segment de faisceau existant dans un plan d’implantation (*.LdrDoc) à l’aide de la commande Add Segment View de la zone Model du panneau Properties . La zone Segment View affiche alors une liste déroulante dans laquelle vous pouvez sélectionner le niveau de Zoom de la vue ajoutée. L’espace de conception effectue un zoom sur la vue, comme illustré dans le diaporama ci-dessous. Pour supprimer une vue de segment, utilisez la commande Delete dans la zone Segment View. Cliquez sur la vue pour la sélectionner, puis déplacez-la à l’emplacement souhaité dans l’espace de conception.

Cliquez sur Add Segment View pour ajouter une nouvelle vue.

La liste déroulante Zoom permet de choisir le niveau de zoom souhaité pour la vue de segment. 

Les propriétés des fils définies dans le schéma de câblage sont transférées à la vue de segment, comme illustré pour W9.

Pour supprimer la vue de segment, cliquez sur Delete.  

Ajout d’un point de rupture

Un point de rupture peut être placé sur un faisceau pour indiquer que celui-ci n’est pas à l’échelle (NTS). Le faisceau affiche un symbole de rupture au milieu de son segment le plus long, comme illustré dans la première image ci-dessous, et les propriétés affichent Drawn Length. Pour placer une rupture, activez l’option Add Break Symbol dans la zone Properties des propriétés du faisceau. Les gaines qui recouvrent un faisceau comportant un point de rupture affichent également la rupture au même endroit. Si la gaine se termine au point de rupture du faisceau, elle est dessinée légèrement plus longue, comme illustré dans la deuxième image.

Un point de rupture placé sur un faisceau

Une gaine placée sur un point de rupture existant

 
  • Si nécessaire, vous pouvez remplacer la longueur calculée d’un fil ou d’un câble. Saisissez la valeur Offset Length souhaitée ou choisissez Manual dans la liste déroulante de la colonne Length Type pour définir manuellement la longueur absolue souhaitée.

  • Pour les fils dont la longueur a été définie dans un outil MCAD, puis importée dans Altium Designer à l’aide de MCAD CoDesigner, l’entrée MCAD CoDesigner apparaît dans l’entrée Length Type. Dans ce cas, la valeur Offset Length ne peut pas être définie, mais vous pouvez remplacer la longueur en sélectionnant Manual dans la liste déroulante (). En savoir plus sur la synchronisation d’un projet de conception de faisceau à l’aide de MCAD CoDesigner.

  • Les unités utilisées pour afficher la valeur Length d’un faisceau et les valeurs Length Value et Offset Length de ses objets dans le panneau Properties lorsque le faisceau est sélectionné sont définies à l’aide de la liste déroulante Length Units de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans le document.

Réaffectation des objets de toron

Vous pouvez réaffecter les objets de toron dans un plan d’implantation lorsqu’un fil peut emprunter plusieurs chemins entre ses connecteurs source et de destination. Par défaut, ce fil est automatiquement affecté au chemin de toron le plus court, mais vous pouvez modifier cette affectation. La commande Assign Objects to Bundle apparaît en bas de la section Bundle Objects du panneau Properties (lorsque le toron est sélectionné dans l’espace de conception), uniquement s’il existe un autre chemin de routage. La boîte de dialogue Assign Objects to Bundle s’ouvre et vous permet de sélectionner les objets (fils/câbles) à déplacer entre les torons appropriés et valides.

Gainers des torons de faisceau

Un objet de gainage de faisceau (Place » Harness Covering) peut être placé sur un toron de faisceau. La longueur du gainage peut être modifiée graphiquement dans l’espace de conception pendant ou après le placement.

Après la sélection d’une commande de placement de gainage de faisceau, un point orange apparaît dans l’espace de conception lorsque le curseur survole un toron de faisceau, indiquant que le gainage peut être placé (un point gris indique qu’il ne peut pas être placé à cet endroit précis). Cliquez à l’endroit où vous souhaitez que le gainage commence, puis déplacez le curseur le long du toron jusqu’au point où vous souhaitez qu’il se termine, puis cliquez à nouveau. Les gainages de faisceau peuvent se chevaucher, comme le montre la vidéo ci-dessous. Vous pouvez également appliquer ou prolonger un gainage de faisceau au-delà d’un point de jonction (un point de connexion du plan d’implantation où deux torons ou plus se rejoignent). Cela évite d’avoir à placer des gainages distincts entre les points de jonction dans une section comprenant plusieurs connecteurs.

Le début d’un gainage correspond au point le plus à gauche et le plus haut de son chemin, et ce chemin comprend uniquement les torons sur lesquels repose le gainage.

Les propriétés d’un gainage de faisceau placé peuvent être configurées dans le panneau Properties lorsque le gainage est sélectionné dans l’espace de conception.

Le panneau Properties lorsqu’un gainage de faisceau est sélectionné
Le panneau Properties lorsqu’un gainage de faisceau est sélectionné

Vous pouvez définir la taille d’un objet de gainage de faisceau par rapport à celle du toron qu’il recouvre (le Line Width du toron) à l’aide de la liste déroulante Size du panneau Properties. Faites défiler les images ci-dessous pour voir des exemples de gainages de différentes tailles sur des torons de faisceau de tailles variées.

 
 
 
 
 
 

Une fois un gainage de faisceau placé dans le plan d’implantation, vous pouvez lui affecter un composant de bibliothèque (ou, si un composant lui est déjà affecté, en sélectionner un autre). Pour ce faire, sélectionnez le gainage de faisceau et cliquez sur le bouton  à droite du champ Design Item ID dans la zone General du panneau Properties. Dans la boîte de dialogue Replace qui s’ouvre, recherchez et sélectionnez le composant souhaité. Le gainage de faisceau placé sera mis à jour avec les paramètres du composant choisi.

Ajout d’étiquettes d’implantation

Des étiquettes physiques peuvent être placées dans le plan d’implantation (Place » Layout Label).

Les propriétés d’une étiquette d’implantation placée (son repère, son texte, sa représentation visuelle, etc.) peuvent être configurées dans le panneau Properties lorsque l’étiquette est sélectionnée dans l’espace de conception.

Le panneau Properties lorsqu’une étiquette d’implantation est sélectionnée
Le panneau Properties lorsqu’une étiquette d’implantation est sélectionnée

Lors de la définition du texte de l’étiquette dans le champ Text, utilisez Ctrl+Enter ou Shift+Enter pour ajouter une nouvelle ligne de texte. Activez Show only first line pour afficher uniquement la première ligne du champ Text dans l’espace de conception. Le texte de l’étiquette d’implantation peut également être aligné selon vos besoins à l’aide des commandes Alignment.

Javascript ID : Harness_LD_LayoutLabel_TextOptions_AD25

Ajout d’étiquettes d’implantation aux torons

Les étiquettes d’implantation suivent automatiquement l’orientation du toron de faisceau auquel elles sont attachées. L’étiquette d’implantation « s’accroche » au toron pour en suivre l’orientation et le chemin. Pendant ou après le placement de l’étiquette d’implantation, appuyez sur Spacebar pour faire pivoter l’étiquette par incréments de 90 degrés, ou modifiez la valeur Rotation dans le panneau Properties .

Si vous ne souhaitez pas que l’étiquette suive l’orientation du toron (c’est-à-dire qu’elle ne soit pas « accrochée »), appuyez sur la touche Alt pendant le placement pour placer l’étiquette à l’endroit souhaité, comme le montre la vidéo ci-dessous.

Lorsque le toron auquel une étiquette est « accrochée » est déplacé, la position de l’étiquette d’implantation est recalculée et suit le toron.

  • Pour afficher le texte de l’étiquette dans la nomenclature, vous pouvez activer la colonne Label Text dans le document ActiveBOM du projet () ou dans le tableau de nomenclature du plan de fabrication (). Notez que la propriété Type de l’étiquette d’implantation doit être définie sur Standard pour qu’elle apparaisse dans la nomenclature ().

  • Une fois une étiquette d’implantation placée dans le plan d’implantation, vous pouvez lui affecter un composant de bibliothèque (ou, si un composant lui est déjà affecté, en sélectionner un autre). Pour ce faire, sélectionnez l’étiquette d’implantation et cliquez sur le bouton  à droite du champ Design Item ID dans la zone General du panneau Properties. Dans la boîte de dialogue Replace qui s’ouvre, recherchez et sélectionnez le composant requis. L’étiquette d’implantation placée sera mise à jour avec les paramètres du composant choisi.

Mise à jour des objets du plan d’implantation à partir des bibliothèques

Les objets suivants peuvent être mis à jour à partir de leur bibliothèque source dans l’espace de travail :

  • Composants de faisceau

  • Pièces associées aux composants de faisceau

  • Pièces associées aux points de connexion

  • Gaines de faisceau

  • Étiquettes d’implantation

Lorsqu’un objet est sélectionné, les informations sur le composant lié de l’espace de travail sont disponibles dans le panneau Properties (par exemple, dans l’onglet Associated Parts pour les pièces associées à un composant de faisceau, ou dans la zone General pour une étiquette d’implantation).

Si une révision plus récente du composant de l’espace de travail est disponible, l’entrée correspondant à l’état de révision l’indique par le texte Out of date. Pour chaque objet, le lien peut être mis à jour vers la dernière révision du composant de l’espace de travail en cliquant sur le bouton .

Exemple d’indication d’une révision obsolète d’un composant de faisceau​
Exemple d’indication d’une révision obsolète d’un composant de faisceau

La fonctionnalité Update from Libraries (Tools » Update from Libraries) peut également être utilisée pour mettre à jour les composants obsolètes liés aux objets énumérés ci-dessus. Notez que, pour qu’un objet soit inclus dans la mise à jour à l’aide de la fonctionnalité Update from Libraries, le composant affecté à cet objet doit comporter un lien vers un symbole schématique.

Annotation des objets du plan d’implantation de faisceau

Utilisez les commandes du menu Tools » Annotation pour annoter les objets suivants dans le document de plan d’implantation de faisceau :

  • Composants de faisceau

  • Points de connexion

  • Torons de faisceau

  • Gaines de faisceau

  • Étiquettes d’implantation

L’annotation des objets dans un document de plan d’implantation de faisceau est similaire à celle des composants dans un document schématique (*.SchDoc) d’un projet de conception de PCB. Utilisez les liens suivants pour en savoir plus sur les commandes d’annotation disponibles pour un document de plan d’implantation de faisceau :

Sélection croisée entre le schéma de câblage et le plan d’implantation

La sélection croisée entre le schéma de câblage et le plan d’implantation d’un projet de faisceau est prise en charge. La commande Cross Probe est accessible depuis le menu principal Tools et le menu contextuel de l’espace de conception.

La sélection croisée peut être effectuée :

  • Entre les composants du schéma de câblage et du plan d’implantation.

  • D’un fil du schéma de câblage vers le ou les torons dans lesquels ce fil passe sur le plan d’implantation.

  • D’un toron du plan d’implantation vers le ou les fils qui traversent ce toron dans le schéma de câblage.

Javascript ID : Harness_CrossProbe_AD25

Localisation croisée d’un composant du schéma de câblage vers le composant correspondant dans le plan d’implantation.

Localisation croisée d’un composant du plan d’implantation vers le composant correspondant dans le schéma de câblage.

Localisation croisée d’un fil du schéma de câblage vers les faisceaux correspondants dans le plan d’implantation.

Localisation croisée d’un faisceau du plan d’implantation vers les fils correspondants dans le schéma de câblage.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents