Configuration d’un document Draftsman
Altium Essentials: Draftsman
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
En un coup d'œil
- Découvrez comment créer un document Draftsman, sélectionner des modèles et lui associer le projet et le PCB source appropriés.
- Découvrez comment Draftsman reste lié aux données du PCB et comment actualiser le document lorsque la conception de la carte évolue.
- Comprenez les principales options du document et les réglages des paramètres qui déterminent l’apparence et le comportement de votre document Draftsman.
Draftsman crée et enregistre les fichiers de dessin de PCB dans un format de fichier dédié (*.PCBDwf).
Créer un document Draftsman
Pour créer un document Draftsman, utilisez la commande File » New » Draftsman Document dans les menus principaux ou faites un clic droit sur l’entrée du projet souhaité dans le panneau Projects, puis choisissez la commande Add New to Project » Draftsman Document dans le menu contextuel. La boîte de dialogue New Document qui s’ouvre vous permet de sélectionner un modèle de document prédéfini ou l’option [Default], qui crée un document A4 vierge.

Créez un document Draftsman vierge ou basé sur un modèle à partir d’un projet et d’un PCB spécifiés.
Pour les modèles de l’espace de travail (répertoriés sous l’entrée de votre espace de travail connecté au format <TemplateName> (v.<Revision>)), la dernière révision de chaque modèle disponible sera utilisée. Cliquez sur le bouton
pour accéder à la page Gestion des données – Modèles de la boîte de dialogue Preferences.
Outre le modèle de document souhaité, vous pouvez sélectionner un Project spécifique (lorsque plusieurs projets sont ouverts dans Altium Designer) ainsi qu’un PCB source Document présent dans le projet choisi. Le nouveau document sera ajouté au projet désigné, dont il utilisera les données et qui deviendra le projet actif.
Les cases à cocher Layers de la boîte de dialogue déterminent les couches de la carte (Signal/Plane, Mask, Paste et/ou Silk, telles que définies par l’empilage des couches) utilisées pour générer les dessins de fabrication dans le document lorsqu’un modèle de document de fabrication est utilisé. Les dessins de fabrication seront créés à raison d’un par feuille, lorsque le paramètre Layer de la vue de fabrication de la carte correspondante est défini sur All (for document template) dans le modèle sélectionné.
Maintenir Draftsman synchronisé avec le PCB
Draftsman extrait les données de conception directement des couches de cuivre, de composants et mécaniques du PCB. Lorsque les données du PCB ont changé, vous pouvez actualiser les données dans Draftsman en faisant un clic droit n’importe où dans le document et en sélectionnant Import Changes From <PCBDocumentName>.PcbDoc dans le menu contextuel, ou en sélectionnant la commande Tools » Import Changes From <PCBDocumentName>.PcbDoc dans les menus principaux.
Options générales du document
Les paramètres de l’ensemble du document Draftsman (qui peut comprendre plusieurs feuilles/pages – en savoir plus) sont définis dans l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Ces paramètres déterminent les données de conception sources du document, le style graphique, le comportement du dessin et les unités utilisées. Les modifications apportées à ces paramètres remplacent les paramètres de propriétés par défaut, qui sont définis par le modèle de document appliqué.
| Grid Size, Show Grid |
Utilisez ces options pour configurer la grille du document. Pour plus d’informations, consultez la section Configurer la grille et les options d’accrochage. |
| Snapping, Snapping Distance |
Utilisez ces options pour configurer la fonction d’accrochage. Pour plus d’informations, consultez la section Configurer la grille et les options d’accrochage. |
| Document Font | Définissez le style de police de base et les éventuels attributs supplémentaires utilisés dans les feuilles du document. Cela définit la police au niveau du document qui est appliquée aux objets de dessin, tels que le titre d’une vue d’assemblage de la carte. Vous pouvez remplacer la police définie au niveau du document pour des objets individuels à l’aide du panneau Properties de ces objets. |
| Sheet Border | Définissez la couleur des lignes et des caractères de la bordure de zones pour les feuilles du document. |
| Sheet Color | Définissez la couleur d’arrière-plan des feuilles du document. |
| Variants Display, Pattern, Not Fitted Text, Not Fitted Font, Font Size (Min/Max) |
Utilisez ces options pour configurer l’affichage, dans les vues d’assemblage de la carte, des composants définis comme non montés pour la variante de conception sélectionnée. Pour plus d’informations, consultez la page Vue d’assemblage de la carte. |
| PCB Document | Définissez la conception de carte utilisée comme source de données pour le document Draftsman. Utilisez le menu déroulant pour choisir parmi les documents PCB disponibles dans le projet actuel. |
| Variants | Utilisez le menu déroulant pour sélectionner une variante de conception de carte qui sera utilisée comme source de données pour le document Draftsman. Pour plus d’informations, consultez la section Prise en charge des variantes de conception. |
| Scale | Définissez la taille des nouvelles vues complètes de la carte placées dans le document actuel (telles que la vue d’assemblage de la carte, la vue de fabrication de la carte ou la vue du plan de perçage). Pour en savoir plus sur le réglage de l’échelle d’une vue placée, consultez la page Utiliser les vues. |
| Dash Pattern | Les définitions des traits et des espacements pour les options de ligne en tirets, en unités de 0,02 mm (en mode métrique). Par exemple, une valeur de motif de 20,10,20 définit une séquence répétée de tirets de 0,4 mm, 0,2 mm et 0,4 mm, avec une longueur de cycle de 1 mm (50 unités). Une option de ligne en tirets personnalisée peut être créée à l’aide du bouton |
| Line Thicknesses | L’épaisseur des options de style de ligne disponibles. Utilisez le bouton |
| Units | Définissez le type d’unité de mesure principal du document. |
| Dual Units | Définissez le type d’unité de mesure secondaire (double cotation) du document. Les unités supplémentaires de double cotation peuvent être activées pour un objet de dessin dans son panneau Properties. |
| Decimal Separator | Sélectionnez le caractère à utiliser comme séparateur décimal dans le menu déroulant. |
| Remove Leading Zero | Activez cette option pour supprimer automatiquement le zéro initial pour les valeurs inférieures à « 1 ». Par exemple, « 0.5 » s’affichera sous la forme « .5 » lorsque cette option est activée. Dimensioning and Tolerancing, ASME Y14.5, indique que, pour les valeurs inférieures à 1, les zéros initiaux doivent être omis lorsque les unités utilisées sont les pouces. |
| Primary Units |
|
| Dual Units |
|
Paramètres du document Draftsman
L’onglet Parameters du panneau Properties, lorsqu’aucun objet n’est sélectionné dans l’espace de conception, présente sous forme de tableau la liste des paramètres disponibles dans le document actif. Les paramètres du projet (y compris ceux de la variante), du système et du PCB, ainsi que tous les paramètres personnalisés ajoutés, figurent dans cette liste.
Utilisez les boutons
et
pour créer ou supprimer vos propres paramètres personnalisés.
Utilisez les cases à cocher au bas de la liste pour choisir les catégories de paramètres affichées dans la liste :
(projet),
(système),
(PCB). Les paramètres du projet, du système et du PCB sont en lecture seule, tandis que les paramètres personnalisés ajoutés sont modifiables et toujours inclus dans la liste.
Les paramètres système et PCB prédéfinis sont présentés ci-dessous.
Paramètres système
Application_BuildNumber |
La version et le numéro de build de l’installation actuelle d’Altium Designer. |
BOMPageNumber |
Utilisé dans le champ Title des propriétés du tableau de nomenclature pour afficher le numéro de la page actuelle du tableau de nomenclature. |
BOMTotalPages |
Utilisé dans le champ Title des propriétés du tableau de nomenclature pour afficher le nombre total de pages du tableau de nomenclature. |
ComponentName |
Utilisé dans le champ Title des propriétés de la vue de composant pour afficher le commentaire du composant pour lequel la vue est créée. |
CurrentDate |
La date actuelle, calculée automatiquement à partir des paramètres de votre système. |
CurrentTime |
L’heure actuelle, calculée automatiquement à partir des paramètres de votre système. |
DocumentFullPathAndName |
Le chemin d’accès complet et le nom du fichier du document Draftsman. Exemple : C:\MyTestDesign\Kame_FMU_asm_rm.PCBDwf. |
DocumentName |
Le nom du fichier du document Draftsman uniquement (sans le chemin d’accès). Exemple : Kame_FMU_asm_rm.PCBDwf. |
DocumentScale |
L’échelle sélectionnée pour le document Draftsman. |
DocumentUnits |
Les unités de mesure sélectionnées pour le document Draftsman. |
FootprintName |
Utilisé dans le champ Title des propriétés de la vue de composant pour afficher le nom de l’empreinte du composant pour lequel la vue est créée. |
HoleName |
Utilisé dans le champ Title des propriétés de la vue de trou lamé ou fraisé pour afficher le nom de la pastille (selon son repère, son emplacement sur le PCB et sa couche) pour laquelle la vue est créée. |
ModifiedDate |
La date de modification du fichier du document Draftsman ; elle est renseignée automatiquement. |
ProjectName |
Le nom réel du projet parent du document Draftsman (extension comprise). Exemple : Sample - Kame_FMU.PrjPcb. |
Revision |
Affiche la valeur spécifiée pour le paramètre par défaut au niveau du document Revision. |
SheetNumber |
Lorsqu’il est placé en tant que chaîne spéciale, affiche le numéro de la feuille actuelle du document Draftsman. |
SheetNumber_OneSheet |
Lorsqu’il est placé en tant que chaîne spéciale, affiche le numéro de la feuille actuelle du document Draftsman. N’affiche aucune valeur si le document Draftsman ne comprend qu’une seule feuille. |
SheetTotal |
Le nombre total de feuilles du document Draftsman. |
VersionControl_PCBDocumentRevNumber |
Le numéro de révision actuel du PCB source du document Draftsman. La gestion de versions doit être utilisée pour que cette chaîne contienne des informations. |
VersionControl_PCBDocumentRevNumberShort |
Un hachage Git court (les huit premiers caractères) et l’état VCS de la révision actuelle du PCB source du document Draftsman. La gestion de versions doit être utilisée pour que cette chaîne contienne des informations. |
VersionControl_PrjFolderRevNumber |
Le numéro de révision actuel du projet, qui est incrémenté chaque fois qu’un commit complet du projet (c’est-à-dire incluant le fichier du projet) est effectué. La gestion de versions doit être utilisée pour que cette chaîne contienne des informations. |
VersionControl_PrjFolderRevNumberShort |
Un hachage Git court (les huit premiers caractères) et l’état VCS du projet. La gestion de versions doit être utilisée pour que cette chaîne contienne des informations. |
VersionControl_RevNumber |
Le numéro de révision actuel du document Draftsman. La gestion de versions doit être utilisée pour que cette chaîne contienne des informations. |
VersionControl_RevNumberShort |
Un hachage Git court (les huit premiers caractères) et l’état VCS de la révision actuelle du document Draftsman. La gestion de versions doit être utilisée pour que cette chaîne contienne des informations. |
ViewLabel |
Utilisé dans le champ Title des propriétés de la vue en coupe de la carte ou de la vue de détail de la carte pour afficher le Label appliqué à la vue. |
ViewLayerName |
Utilisé dans le champ Title des propriétés de la vue de fabrication de la carte pour afficher le Layer pour lequel la vue est créée. |
ViewScale |
Utilisé dans le champ Title des propriétés d’une vue pour afficher le Scale sélectionné pour cette vue. |
ViewSide |
Utilisé dans le champ Title des propriétés de la vue d’assemblage de la carte, de la vue de fabrication de la carte, de la vue de composant ou de la vue isométrique de la carte pour afficher le View Side / Face side pour lequel la vue est créée. |
ViewVariantName |
Utilisé dans le champ Title des propriétés de la vue d’assemblage de la carte ou de la vue isométrique de la carte pour afficher le Variation pour lequel la vue est créée. |
Paramètres du PCB
Arc_Count |
Le nombre d'objets arc dans le PCB source du document Draftsman. |
BoardArea |
La surface du PCB source du document Draftsman, exprimée dans les unités de mesure principales sélectionnées pour le document Draftsman. |
BoardDensity |
La densité du PCB source du document Draftsman. |
BoardHeight |
La hauteur du PCB source du document Draftsman, exprimée dans les unités de mesure principales sélectionnées pour le document Draftsman. |
BoardWidth |
La largeur du PCB source du document Draftsman, exprimée dans les unités de mesure principales sélectionnées pour le document Draftsman. |
BlindVia_Count |
Le nombre de vias borgnes sur le PCB source du document Draftsman. |
BuriedVia_Count |
Le nombre de vias enterrés sur le PCB source du document Draftsman. |
Component_Count |
Le nombre d'objets composant dans le PCB source du document Draftsman. |
ComponentMixed_Count |
Le nombre de composants à pastilles mixtes (CMS et traversantes) sur le PCB source du document Draftsman. |
ComponentsArea |
La surface occupée par les composants du PCB source du document Draftsman, exprimée dans les unités de mesure principales sélectionnées pour le document Draftsman. |
ComponentSMD_Count |
Le nombre de composants à pastilles CMS sur le PCB source du document Draftsman. |
ComponentThru_Count |
Le nombre de composants à pastilles traversantes sur le PCB source du document Draftsman. |
ComputerName |
Le nom système de l'ordinateur sur lequel le document Draftsman a été créé. |
CopperInner_Weight_Max |
Le grammage maximal du cuivre sur les couches internes. |
CopperOuter_Weight_Max |
Le grammage maximal du cuivre sur les couches externes. |
Fill_Count |
Le nombre d'objets de remplissage dans le PCB source du document Draftsman. |
Hole_Count |
Le nombre de trous de pastilles et de vias dans le PCB source du document Draftsman. |
Hole_Size_Min |
Le diamètre minimal des trous sur le PCB source du document Draftsman, exprimé dans les unités de mesure principales sélectionnées pour le document Draftsman. |
Hole_Size_Num |
Le nombre de diamètres de trous distincts sur le PCB source du document Draftsman. |
Item |
Le nom du dernier élément de conception de projet PCB dans lequel les données sources du projet ont été publiées à l'aide de Project Releaser. Exemple : SRC-Sample - Kame_FMU. |
ItemRevision |
La révision du dernier élément de conception de projet PCB dans lequel les données sources du projet ont été publiées à l'aide de Project Releaser. Exemple : 01.A.1. |
ItemRevisionBase |
La partie de niveau de base de la révision du dernier élément de conception de projet PCB dans lequel les données sources du projet ont été publiées à l'aide de Project Releaser. Exemple : 1. |
ItemRevisionLevel1 |
La partie de niveau 1 de la révision du dernier élément de conception de projet PCB dans lequel les données sources du projet ont été publiées à l'aide de Project Releaser. Exemple : A. |
ItemRevisionLevel2 |
La partie de niveau 2 de la révision du dernier élément de conception de projet PCB dans lequel les données sources du projet ont été publiées à l'aide de Project Releaser. Exemple : 01. |
Layer_Count |
Le nombre de couches de cuivre sur le PCB source du document Draftsman. |
MicroVia_Count |
Le nombre de microvias sur le PCB source du document Draftsman. |
Net_Count |
Le nombre de nets dans le PCB source du document Draftsman. |
Pad_Count |
Le nombre d'objets pastille dans le PCB source du document Draftsman. |
Pcb_File_Name |
Le chemin complet et le nom du fichier PCB source du document Draftsman. Exemple : C:\MyTestDesign\Kame_FMU.PcbDoc. |
Pcb_File_Name_No_Path |
Le nom seul du fichier PCB source du document Draftsman (sans le chemin d'accès). Exemple : Kame_FMU.PcbDoc. |
PCBConfigurationName |
Le nom du jeu de données à partir duquel la sortie a été générée, tel que défini dans la vue Release (Project Releaser). |
PadSMD_Count |
Le nombre de pastilles CMS sur le PCB source du document Draftsman. |
PadThru_Count |
Le nombre de pastilles traversantes sur le PCB source du document Draftsman. |
Poly_Count |
Le nombre d'objets de remplissage polygonal dans le PCB source du document Draftsman. |
SlotHole_Count |
Le nombre d'objets pastille comportant des trous oblongs dans le PCB source du document Draftsman. |
SolderMask_Bottom |
Disponibilité du vernis épargne sur la face inférieure. S'il n'existe aucune couche de vernis épargne inférieure, le paramètre prendra la valeur No mask. Si une couche de vernis épargne inférieure existe, mais que sa couleur n'est pas définie, le paramètre prendra la valeur No color. Si une couche de vernis épargne inférieure existe et que sa couleur est définie, le paramètre affichera cette couleur, soit par son nom (Green, Black, Blue, Red, etc.), soit par son code RGBA (par exemple, #FF0065FF). |
SolderMask_Top |
Disponibilité du vernis épargne sur la face supérieure. S'il n'existe aucune couche de vernis épargne supérieure, le paramètre prendra la valeur No mask. Si une couche de vernis épargne supérieure existe, mais que sa couleur n'est pas définie, le paramètre prendra la valeur No color. Si une couche de vernis épargne supérieure existe et que sa couleur est définie, le paramètre affichera cette couleur, soit par son nom (Green, Black, Blue, Red, etc.), soit par son code RGBA (par exemple, #FF0065FF). |
SquareHole_Count |
Le nombre d'objets pastille comportant des trous rectangulaires dans le PCB source du document Draftsman. |
StackedVia_Count |
Le nombre de vias empilés sur le PCB source du document Draftsman. |
String_Count |
Le nombre d'objets texte dans le PCB source du document Draftsman. |
Thru_Via_Count |
Le nombre de vias traversants sur le PCB source du document Draftsman. |
Total_Thickness |
L'épaisseur totale du PCB source du document Draftsman. |
Track_Count |
Le nombre d'objets piste dans le PCB source du document Draftsman. |
VariantName |
Le nom de la variante de conception sélectionnée pour le document Draftsman. |
Via_Count |
Le nombre d'objets via dans le PCB source du document Draftsman. |
Configuration de la grille et des options d'accrochage
Avant de placer des objets dans le document Draftsman, définissez les grilles et configurez les options d'accrochage pour faciliter le placement. Les options de grille et d'accrochage se configurent dans la zone General de l'onglet General du panneau Properties, lorsqu'aucun objet n'est sélectionné dans l'espace de conception.
Dans l'espace de conception, les lignes de grille sont affichées en pointillés, et une ligne sur dix est affichée en trait plein. Définissez la distance entre les lignes de grille à l'aide du champ Grid Size du panneau Properties, lorsqu'aucun objet n'est sélectionné dans le document. Vous pouvez également définir la valeur de la grille à l'aide de la boîte de dialogue Snap Grid (1..1000) , accessible en sélectionnant la commande View » Set Grid Size dans les menus principaux (raccourci : G).
Utilisez l'option Show Grid pour contrôler l'affichage des lignes de grille sur les feuilles du document. Utilisez le bouton de couleur associé pour définir la couleur de la grille dans l’espace de conception.
L’accrochage facilite le placement et le déplacement des objets sur les feuilles d’un document Draftsman. Cette fonction attire une primitive vers des points ou des guides générés par les objets existants ou par la grille définie pour le document. Vous pouvez ainsi aligner rapidement et facilement les différents éléments sur les pages de votre document. L’accrochage peut être activé ou désactivé à l’aide de l’option Snapping du panneau Properties ou de la commande View » Toggle Snapping des menus principaux (raccourci : Shift+E).
Lorsque la fonction d’accrochage est activée, vous pouvez la configurer plus précisément en activant ou en désactivant individuellement les options ci-dessous.
| Snap to Grid | Lorsque cette option est activée, le curseur de prévisualisation s’accroche aux intersections des lignes de la grille lorsque l’éditeur est en mode de placement d’objets. Notez que l’accrochage à la grille ne fonctionne pas lorsque la grille n’est pas affichée (c’est-à-dire lorsque l’option Show_Grid est désactivée). |
| Snap to Vertices | Lorsque cette option est activée, le curseur de prévisualisation s’accroche à un coin (sommet) d’un objet lorsque l’éditeur est en mode de placement d’objets. Un sommet est mis en évidence par un point orange lorsque le curseur de prévisualisation s’y accroche. |
| Snap to Boundaries | Lorsque cette option est activée, le curseur de prévisualisation s’accroche à une ligne du contour d’un objet (ou au prolongement de cette ligne) lorsque l’éditeur est en mode de placement d’objets. Les prolongements du contour des objets sont représentés par une fine ligne en pointillés. |
| Snap to Line centers | Lorsque cette option est activée, le curseur de prévisualisation s’accroche au milieu d’une ligne du contour d’un objet lorsque l’éditeur est en mode de placement d’objets. Le milieu d’une ligne est mis en évidence par un point orange lorsque le curseur de prévisualisation s’y accroche. |
| Snap to Circle centers | Lorsque cette option est activée, le curseur de prévisualisation s’accroche au centre d’un objet circulaire lorsque l’éditeur est en mode de placement d’objets. Le centre d’un cercle est mis en évidence par un point orange lorsque le curseur de prévisualisation s’y accroche. |
| Snap to component references | Lorsque cette option est activée, le curseur de prévisualisation s’accroche aux points de référence des composants. |
| Snap to Visible primitives | Lorsque cette option est activée, le curseur de prévisualisation s’accroche (selon les autres options d’accrochage) aux primitives d’objets visibles dans la vue actuelle de la feuille. Lorsqu’elle est désactivée, le curseur s’accroche à tous les objets présents sur la feuille. ![]() |
Utilisez l’option Snapping Distance pour saisir la distance à laquelle le curseur de prévisualisation s’accrochera aux éléments définis comme cibles d’accrochage. Vous pouvez également utiliser la liste déroulante pour sélectionner une valeur relative à la grille actuelle (par exemple, 0.5x Snap Grid).
Configuration des feuilles (pages) du document
Les documents Draftsman utilisent un format multifeuille, qui leur permet de contenir des pages (feuilles) individuelles dédiées à des types particuliers d’informations de fabrication du projet de carte.
Vous pouvez ajouter des feuilles au document actuel ou en supprimer à l’aide des commandes Add New Sheet et Remove Sheet des menus principaux Tools ou du menu contextuel de l’espace de conception. Une nouvelle feuille est insérée après celle sur laquelle se trouve le curseur au moment de l’exécution de la commande. Sa présentation est conforme au modèle de feuille Draftsman actuellement appliqué à la feuille qui la précède immédiatement.
Les paramètres des pages (feuilles) individuelles d’un document Draftsman peuvent être définis dans l’onglet Page Options du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Ces paramètres déterminent la structure de base de la page (taille, marges, etc.).
Les modifications apportées aux propriétés des options de page peuvent être appliquées à la page actuelle ou à toutes les pages du document. Sélectionnez le bouton
en haut du panneau Properties pour appliquer les propriétés modifiées à la feuille actuelle, ou le bouton
pour appliquer les modifications à toutes les feuilles du document. Le numéro de la page actuelle est affiché dans la liste déroulante Current Page, qui permet également de sélectionner une page.
La section Formatting and Size du panneau permet de choisir la manière dont le format de page est défini.
| Template | Définissez la taille et le format de la page en sélectionnant l’un des modèles de feuille Draftsman disponibles. Pour les modèles de l’espace de travail (répertoriés sous l’entrée de l’espace de travail auquel vous êtes connecté, au format |
| Standard | Définissez la taille de la feuille selon un format de page standard. Utilisez la liste déroulante Sheet Size pour sélectionner des dimensions de page standard. |
| Custom | Définissez la taille de la feuille selon des dimensions personnalisées à l’aide des champs Width et Height. Notez que la valeur maximale pouvant être saisie pour la largeur ou la hauteur est de 20000 mm. |
Les options de la section Margin and Zones du panneau définissent les dimensions du cadre de la feuille et ses divisions en zones.
| Show Zones | Activez cette option pour afficher les divisions en zones dans le cadre. |
| Vertical | Définissez le nombre de divisions (lignes) dans la marge verticale de la feuille. Le type de repérage alphanumérique des zones est défini par les paramètres Origin et Letter Position de cette section du panneau. |
| Horizontal | Définissez le nombre de divisions (colonnes) dans la marge horizontale de la feuille. Le type de repérage alphanumérique des zones est défini par les paramètres Origin et Letter Position de cette section du panneau. |
| Margin | Définissez la distance entre le bord de la page et chacune des quatre lignes du cadre. |
| Origin | Définissez le coin des feuilles du document à partir duquel commencent les repères alphanumériques des zones du pourtour (position de zone A-1 ou 1-A). |
| Letter Position | Définissez l’emplacement des indicateurs de zone alphabétiques sur la ou les feuilles du document : dans les zones périphériques horizontales (colonnes) ou verticales (lignes). Cochez l’option Iterate Columns Across Sheets pour que les indicateurs alphanumériques attribués aux colonnes s’incrémentent séquentiellement sur l’ensemble des feuilles du document (au lieu de recommencer à A ou 1 sur chaque feuille). |
Navigation dans un document Draftsman à l’aide du panneau Bookmarks
Le panneau Bookmarks offre un moyen pratique de parcourir et de gérer les documents Draftsman multifeuilles. Il présente une arborescence développable de la structure complète du document, similaire à celle du panneau Projects, et comprend toutes les feuilles du document ainsi que les principaux objets de vue qu’elles contiennent.

Utilisez le panneau Bookmarks pour parcourir les vues d’un document Draftsman multifeuille.
Le panneau Bookmarks présente une arborescence structurée des feuilles et des objets d’un document Draftsman, dans laquelle chaque entrée de feuille peut être développée ou réduite. Les entrées de feuille de l’arborescence sont automatiquement nommées par Draftsman dans l’ordre décroissant. Chaque entrée de feuille du panneau contient les objets de type vue Draftsman présents sur cette feuille, mais pas les objets de dessin secondaires tels que les cotes, les repères, les formes graphiques, etc.
Le panneau Bookmarks offre des fonctions de navigation active : la feuille ou l’objet de dessin sélectionné dans l’arborescence est mis en évidence dans l’espace de conception. Un objet sélectionné dans l’arborescence est également sélectionné dans la vue de dessin, qui ajuste le zoom pour l’afficher entièrement. La navigation dans l’arborescence est bidirectionnelle : sa sélection change donc également en fonction des feuilles ou des objets sélectionnés dans l’espace de conception.
Le panneau Bookmarks propose d’autres fonctions de gestion des feuilles du document, notamment l’ajout et la suppression de feuilles ainsi que la modification de leur ordre dans la structure du document Draftsman. Les boutons de fonction situés en haut du panneau permettent de gérer l’affichage et la structure des feuilles du document :
-
Définissez le mode d’affichage des pages du document à l’aide des boutons Unique/Continu : le bouton
configure l’espace de conception pour afficher une seule feuille à la fois, tandis que le bouton
active un mode d’affichage continu présentant toutes les feuilles dans une séquence défilante.
-
Cliquez sur le bouton
pour ajouter une nouvelle feuille au document après la feuille actuellement sélectionnée. Le bouton
supprime la feuille actuellement sélectionnée de l’arborescence ou, si un objet de dessin est sélectionné, supprime cet objet de la feuille.
-
Utilisez les boutons
et
pour déplacer la feuille actuellement sélectionnée d’un niveau vers le haut ou vers le bas dans l’arborescence. La feuille et les objets qu’elle contient changent de position en conséquence, et la feuille est renommée pour correspondre à sa nouvelle position dans l’arborescence.
D’autres options sont disponibles dans le menu contextuel accessible par clic droit sur une feuille ou un objet de l’arborescence.
-
Utilisez les options du menu contextuel d’une feuille pour supprimer la feuille sélectionnée, ajouter une nouvelle feuille au document ou accéder à ses propriétés dans le panneau Properties, qui s’ouvre s’il ne l’est pas déjà.
-
Utilisez les options du menu contextuel d’un objet pour supprimer l’objet sélectionné ou accéder à ses propriétés dans le panneau Properties, qui s’ouvre s’il ne l’est pas déjà.
Prise en charge des variantes de conception
Dans Altium Designer, vous pouvez créer des déclinaisons d’une conception de carte (variantes de conception) et transmettre les informations de ces variantes à Draftsman, ce qui permet ensuite d’appliquer une variante de conception à une vue de dessin ou à une table de nomenclature placée. Des paramètres peuvent être ajoutés à chaque variante. Ces paramètres sont généralement utilisés sous forme de chaînes spéciales (interprétées) dans les documents Altium Designer pour indiquer la variante actuellement active.
Dans Draftsman, la variante courante d’un projet au niveau du document se sélectionne à l’aide de la liste déroulante Variants, dans la zone Properties de l’onglet General du panneau Properties, lorsqu’aucun objet n’est sélectionné dans l’espace de conception.
Les vues d’assemblage de la carte, vues isométriques de la carte et vues réalistes de la carte placées reflètent la variante choisie. Pour une vue d’assemblage de la carte, le rendu des composants non montés est appliqué selon les options configurées pour le document (en savoir plus). Pour une vue isométrique de la carte ou une vue réaliste de la carte, les composants non montés ne sont pas affichés dans la vue La variante courante d’une vue peut être sélectionnée dans le panneau Properties lorsque la vue est sélectionnée dans l’espace de conception.
Les chaînes spéciales, telles que =VariantName et les paramètres de variante, peuvent être placées dans le dessin sous forme de chaînes libres.
Pour plus d’informations sur les objets texte, consultez la page Utilisation des annotations.
)
)
)
)
).
)
).
).
)
).