Travailler avec des tableaux

En un coup d'œil

Cet article explique comment placer et configurer des tableaux Draftsman dans Altium Designer, en mettant l’accent sur les tableaux de nomenclature et sur la façon dont leurs données proviennent directement du projet PCB, d’ActiveBOM, des variantes et des vues d’assemblage. Il passe en revue les principaux réglages disponibles dans le panneau Properties, notamment la mise en forme, la sélection de la source de données, les modes d’affichage, le filtrage par variante, la gestion des colonnes et la répartition des nomenclatures sur plusieurs pages pour les conceptions volumineuses. Pour mieux comprendre comment présenter les données de fabrication et d’assemblage avec précision et clarté dans vos documents Draftsman, découvrez les options disponibles et apprenez à les utiliser efficacement afin de mieux maîtriser la documentation de vos PCB.

- Vous découvrirez d’où proviennent les données des tableaux de nomenclature et comment les options Project et Board, les variantes et les vues d’assemblage influencent les informations affichées.
- Vous verrez comment personnaliser l’apparence et la structure d’un tableau de nomenclature, notamment les titres, les polices, les couleurs des lignes, les colonnes, le tri et les alias.
- Vous comprendrez comment fonctionnent les tableaux de nomenclature fractionnés, afin de répartir les nomenclatures volumineuses entre plusieurs objets de tableau et plusieurs pages.
Approfondissez avec l'IA :

Un document Draftsman permet de placer différents tableaux de données sur le dessin et de les configurer selon les besoins. Les données tabulaires proviennent directement du document PCB du projet et offrent un moyen simple et visuel de communiquer les informations essentielles aux processus de fabrication et d’assemblage du PCB.

Le type de tableau à placer peut être sélectionné dans le menu principal Place.

Nomenclature

Une nomenclature Draftsman (Place » Bill Of Materials) est un objet tableau généré automatiquement qui répertorie les éléments physiques à assembler dans une conception de PCB. Les données du tableau de nomenclature proviennent directement du document ActiveBOM du projet ou, si le projet actif ne contient pas de document ActiveBOM, directement des documents sources du projet. Un tableau de nomenclature peut également représenter les éléments constitutifs d’une variante de conception spécifiée ou d’une vue d’assemblage de la carte placée.

Un tableau de nomenclature réparti sur deux objets de nomenclature. Dans l’exemple ci-dessus, le contenu de la nomenclature est filtré pour inclure les éléments de la vue d’assemblage de la face supérieure de la carte.
Un tableau de nomenclature réparti sur deux objets de nomenclature. Dans l’exemple ci-dessus, le contenu de la nomenclature est filtré pour inclure les éléments de la vue d’assemblage de la face supérieure de la carte.

Le style visuel et les données incluses dans un tableau de nomenclature placé peuvent être configurés dans le panneau Properties lorsque le tableau est sélectionné dans l’espace de conception. Les propriétés générales du tableau se configurent dans l’onglet General du panneau ().

Titre

Titre

Le texte du titre qui sera affiché (si l’affichage est activé) avec le tableau. Utilisez le bouton associé pour afficher ou masquer le titre dans le dessin.

Ce champ peut inclure du texte statique et les paramètres souhaités sous forme de chaînes spéciales. Utilisez la syntaxe =<ParameterName> pour inclure un paramètre dans le titre. Les valeurs des paramètres inclus seront affichées dans le titre sur la feuille de dessin. Pour obtenir la liste des paramètres système et PCB disponibles, consultez la page Configuration d’un document Draftsman.

Location Utilisez la liste déroulante pour choisir parmi plusieurs positions relatives du titre. L’option Manual est automatiquement sélectionnée si le titre est déplacé manuellement (par glisser-déposer vers un nouvel emplacement).
Font

Définit la police utilisée pour le titre.

  • Lorsque l’option Use Document Font est activée, la police utilisée pour le titre est celle définie par les options du document (l’entrée Document Font dans la section General de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception).

  • Lorsque l’option Use Document Font est désactivée, utilisez les options proposées pour choisir le type, la taille et la couleur de la police, ainsi que les attributs du texte.

Propriétés

Table Line Style

Utilisez les listes déroulantes pour sélectionner le trait utilisé pour tracer le tableau. Les options disponibles sont définies dans la section Line Styles du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman. Utilisez le bouton de couleur associé pour définir la couleur du trait.

Justification Sélectionnez le point par rapport auquel la position du tableau est modifiée lorsque sa taille est mise à jour.
Even Row Color Sélectionnez la couleur de contraste des lignes paires du tableau.
Non-Even Row Color Sélectionnez la couleur de contraste des lignes impaires du tableau.
Font

Définit la police utilisée pour les données du tableau.

  • Lorsque l’option Use Document Font est activée, la police utilisée est celle définie par les options du document (l’entrée Document Font dans la section General de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception).

  • Lorsque l’option Use Document Font est désactivée, utilisez les options proposées pour choisir le type, la taille et la couleur de la police, ainsi que les attributs du texte.

Le tableau est automatiquement redimensionné pour s’adapter à la taille de police sélectionnée.

Data Source Cette option et la présence éventuelle d’un document ActiveBOM dans le projet déterminent les données incluses dans le tableau :

 

  • Project – lorsque cette option est sélectionnée et que le document ActiveBOM est inclus dans le projet actif, sa configuration et son contenu deviennent la source de données du tableau de nomenclature Draftsman. Utilisez la commande Tools » Import Changes From <PCBDocumentName>.PcbDoc de Draftsman pour prendre en compte les modifications en temps réel du document ActiveBOM.
    Si le document ActiveBOM n’est pas inclus dans le projet actif, les données du tableau de nomenclature Draftsman sont extraites directement des documents sources du projet.

  • Board – lorsque cette option est sélectionnée, les entrées du tableau de nomenclature Draftsman sont limitées aux composants présents sur le PCB physique du projet.

Assembly View Utilisez les options du menu déroulant pour filtrer les entrées de nomenclature et ne conserver que les éléments affichés dans une vue d’assemblage de la carte spécifiée.
View Mode
  • Base – une ligne du tableau est attribuée à chaque type de composant unique et répertorie tous les éléments inclus dans la colonne Designator.

  • Flat – une ligne du tableau est attribuée à chaque composant.

  • Consolidated – si le projet source comprend des variantes, le tableau inclut les entrées de composants de toutes les variantes de conception. La sélection de cette option définit automatiquement l’option Variant sur [No Variations].

Variant

Utilisez le menu déroulant pour sélectionner une variante de conception, si disponible, comme source de données du tableau de nomenclature. Le tableau reflète les entrées non incluses ou dont les paramètres varient, selon l’option Show Components.

Lorsque l’option Document : <VariantName> est sélectionnée pour Variation, la variante spécifiée pour le document est appliquée au tableau. La variante au niveau du document est sélectionnée à l’aide de la liste déroulante Variants dans la section Source de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman.

Show Components

Lorsqu’une variante est sélectionnée, utilisez la liste déroulante pour choisir les entrées de composants à inclure dans la liste :

  • Fitted – afficher uniquement les composants montés dans la variante de conception actuellement sélectionnée.

  • All – afficher tous les composants.

  • Not Fitted – afficher uniquement les composants non montés dans la variante de conception actuellement sélectionnée.

  • Replaced – afficher uniquement les composants pour lesquels des composants de remplacement ont été sélectionnés ou les composants montés dont les valeurs de paramètres diffèrent dans la variante de conception actuellement sélectionnée.

Un tableau de nomenclature dont les options Fitted, Not Fitted ou Replaced sont sélectionnées pour Show Components fonctionne avec les options Base et Flat sélectionnées pour View Mode (et non Consolidated).

Pagesi

BOM Table ID Identifiant numérique d’une instance de tableau de nomenclature. Le tableau complet peut être réparti sur plusieurs objets de tableau de nomenclature (pages), qui conservent le même identifiant.
Limit Page Height Lorsque cette option est cochée, le tableau de nomenclature est divisé en une série de pages virtuelles dont chacune a la hauteur spécifiée dans la propriété Max Page Height.
Max Page Height Définit la hauteur, et donc le nombre de lignes incluses, de chaque page du tableau. Une seule page est incluse dans un objet tableau de nomenclature placé (voir Page ci-dessous), et des objets tableau de nomenclature supplémentaires sont placés pour couvrir toutes les pages.
Page Indique le numéro de page du tableau (1 from 2, 3 from 5, etc.) affiché dans l’objet tableau de nomenclature sélectionné. Utilisez le menu déroulant associé pour spécifier la page souhaitée pour l’objet tableau de nomenclature actuellement sélectionné.
Show Empty Lines Lorsque cette option est cochée, les lignes vides du tableau de nomenclature sont affichées. Elles se trouvent généralement sur la dernière page d’un tableau de nomenclature lorsque la hauteur de page spécifiée dépasse le nombre de lignes de données de nomenclature disponibles.

Utilisez l’onglet Columns du panneau Properties pour gérer les colonnes de données du tableau de nomenclature.

Modifiez les colonnes d’un tableau de nomenclature placé dans l’onglet Columns du panneau Properties.
Modifiez les colonnes d’un tableau de nomenclature placé dans l’onglet Columns du panneau Properties.

  • Les entrées peuvent être modifiées pour spécifier les colonnes incluses (visibles) dans le tableau de nomenclature et l’alignement de leur texte (Align).

  • Utilisez l’entrée Width pour définir la largeur de la colonne en fonction du texte qu’elle contient. Saisissez Auto pour que la largeur s’adapte dynamiquement au texte de cellule le plus large de la colonne.

  • Cliquez dans la colonne Order pour parcourir les options d’ordre de tri des données de la colonne du tableau (désactivé, croissant et décroissant). Le tri peut être appliqué à plusieurs colonnes selon un ordre de priorité, les colonnes triées situées à gauche du tableau étant prioritaires.

  • Les en-têtes du tableau de nomenclature peuvent être modifiés en saisissant un Alias pour le nom du paramètre d’une colonne du tableau. Cela s’applique si le contenu du tableau n’est pas déterminé par un document ActiveBOM (voir Data Source ci-dessus).

  • Utilisez les cases à cocher de filtrage par type de colonne pour remplir la liste des colonnes disponibles avec les types de données de paramètres correspondants : nomenclature (), schéma (), serveur (), PCB (). Désélectionnez tous les types pour ne répertorier que les colonnes visibles dans le tableau de nomenclature.

  • Utilisez les boutons  et  pour déplacer l’entrée sélectionnée d’un rang vers le haut ou vers le bas et, par conséquent, vers la gauche ou vers la droite dans l’ordre des colonnes du tableau de nomenclature. Cette fonction est disponible pour les colonnes définies comme visibles.

  • Cliquez sur le bouton  pour rétablir les entrées par défaut des colonnes du tableau (telles que définies dans les valeurs par défaut de l’objet tableau de nomenclature sur la page Draftsman – Defaults de la boîte de dialogue Preferences).

Tableaux de nomenclature fractionnés

La nomenclature de la plupart des projets de PCB avancés comporte généralement un grand nombre d’entrées, qu’il peut être difficile de présenter dans un tableau tenant sur un document de dessin. Plutôt que de recourir à la mise à l’échelle des polices et du tableau, à plusieurs entrées de tableau personnalisées ou à un document externe, la fonction de fractionnement de la nomenclature permet de présenter un tableau de nomenclature sur plusieurs « pages ».

Pour créer un tableau de nomenclature de plusieurs pages, sélectionnez une nomenclature placée (dont la hauteur dépasse probablement celle de la feuille du document) et cochez la case Limit Page Height dans la section Pages du panneau Properties. Cela limite la hauteur du tableau à la valeur indiquée (Max Page Height, mm) et, par conséquent, le nombre de lignes affichées dans le tableau de nomenclature.

Javascript ID : Draftsman_BOM_LimitPageHeight

Draftsman détecte que la nomenclature n’est pas affichée dans son intégralité, comme l’indique l’entrée Page du panneau (par exemple, Page 1 from 2), et le menu déroulant associé vous permet de choisir la page affichée. Pour ajouter d’autres pages de la nomenclature (ici, BOM Table ID = 0), placez une autre nomenclature et spécifiez le Page suivant dans la section Pages du panneau Properties .

Comme chaque page de la nomenclature est placée en ajoutant un autre tableau de nomenclature puis en le configurant en conséquence, les différentes pages (sections) peuvent être placées sur n’importe quelle feuille d’un document Draftsman. Pour placer un autre ensemble different de pages de nomenclature fractionnée, spécifiez un autre BOM Table ID sur une nomenclature placée, par exemple 1 plutôt que 0.

Notez que la propriété Max Page Height spécifie la hauteur de la page first du tableau de nomenclature. Lorsque la deuxième page est sélectionnée (page 2), la propriété Max Page Height définit la hauteur de la première page exclue (page 1). La page 2 affiche donc les entrées restantes de la nomenclature. Commencez par définir une valeur identique pour la propriété Max Page Height de chaque page.

Tableau de perçage

Un tableau de perçage Draftsman (Place » Drill Table) est un objet tableau généré automatiquement qui contient les symboles et les données de perçage de la carte. Associé à la vue de dessin de perçage de Draftsman, il fournit des informations à la fois tabulaires et graphiques pour le processus de fabrication de la carte. Une ligne de symbole, représentant un type de trou de perçage spécifié, peut inclure diverses informations sur les trous, telles que leur taille, leur métallisation et leur nombre. Les types de trous sont regroupés sous des symboles comme spécifié dans la boîte de dialogue Drill Symbol Configurations.

Un tableau de perçage placé dont les entrées de trous sont regroupées par taille
Un tableau de perçage placé dont les entrées de trous sont regroupées par taille

Lorsque l’extension logicielle GOST 2.701-2008/2.106-1996 est installée dans votre installation d’Altium Designer, les valeurs de la colonne Plated du tableau de perçage sont affichées sous la forme Есть (pour les trous métallisés) et Нет (pour les trous non métallisés). 

Pour plus d’informations sur la gestion des extensions, consultez la page Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Le style visuel et le contenu des données d’un tableau de perçage placé, y compris le symbole utilisé, peuvent être configurés dans le panneau Properties lorsque le tableau est sélectionné dans l’espace de conception. Les propriétés générales du tableau sont configurées dans l’onglet General du panneau ().

Titre

Title

La chaîne de texte du titre qui sera affichée (si l’option est activée) avec le tableau. Utilisez le bouton associé pour afficher ou masquer le titre dans le dessin.

Le champ peut inclure du texte statique et tout paramètre souhaité sous forme de chaînes spéciales. Utilisez la syntaxe =<ParameterName> pour inclure un paramètre dans le titre. Les valeurs des paramètres inclus seront affichées dans le titre sur la feuille de dessin. Pour obtenir la liste des paramètres système et PCB disponibles, consultez la page Configuration d’un document Draftsman.

Location Ouvrez la liste déroulante pour choisir parmi plusieurs positions relatives du titre. L’option Manual est automatiquement sélectionnée si le titre est déplacé manuellement (par glisser-déposer vers un nouvel emplacement).
Font

Définit la police utilisée pour le titre.

  • Lorsque l’option Use Document Font est activée, la police utilisée pour le titre est celle définie dans les options du document (l’entrée Document Font dans le General zone de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception).

  • Lorsque l’option Use Document Font est désactivée, utilisez les options proposées pour choisir le type, la taille et la couleur de police ainsi que les attributs de texte souhaités.

Propriétés

Layer Pairs Sélectionnez les trous de la paire de couches de perçage du PCB à afficher dans la vue de dessin. Utilisez le menu déroulant pour choisir parmi les paires de couches disponibles dans la conception de la carte source, qui peuvent être consultées et modifiées dans l’éditeur de PCB, accessible depuis le Gestionnaire d’empilage des couches. Toutes les conceptions de cartes comportent une paire de couches Top - Bottom, tandis que les autres paires représentent les trous de vias reliant d’autres couches ou y aboutissant, telles que les couches internes ou les plans.

Les options Counterhole Bottom et Counterhole Top sont disponibles uniquement lorsque le document PCB comprend des pastilles pour lesquelles des fonctions de lamage ou de fraisurage sont activées sur les faces correspondantes du PCB (en savoir plus).

Notez que les lamages et fraisurages sont exclus des paires de couches autres que Counterhole Bottom et Counterhole Top. Ils sont également exclus de la paire de couches All Layers.

Pads / Vias Utilisez la liste déroulante pour sélectionner le type de trou de perçage (Pads, Vias ou All) à afficher dans le tableau.
Plated / Non-Plated Utilisez la liste déroulante pour sélectionner le type de métallisation des trous (Plated, Non-Plated ou All) à afficher dans le tableau.
Border Line Style

Utilisez les listes déroulantes pour sélectionner le trait utilisé pour tracer la bordure ou le contour du tableau. Les options disponibles sont définies dans la zone Line Styles du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman. Utilisez le bouton de couleur associé pour spécifier la couleur du trait.

Justification Sélectionnez le point par rapport auquel la position du tableau est modifiée lorsque sa taille est mise à jour.
Even Row Color Sélectionnez la couleur de contraste des lignes paires du tableau.
Non-Even Row Color Sélectionnez la couleur de contraste des lignes impaires du tableau.
Font

Définit la police utilisée pour les données du tableau.

  • Lorsque l’option Use Document Font est activée, la police utilisée est celle définie dans les options du document (l’entrée Document Font dans la zone General de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception).

  • Lorsque l’option Use Document Font est désactivée, utilisez les options proposées pour choisir le type, la taille et la couleur de police ainsi que les attributs de texte souhaités.

Le tableau est automatiquement redimensionné pour s’adapter à la taille de police sélectionnée.

Show Footer Cochez cette case pour activer le pied de tableau, qui indique le nombre total de trous de perçage.
Sélectionnez cette option pour ouvrir la boîte de dialogue Drill Symbol Configurations, qui présente toutes les données de perçage sous forme de tableau et permet de définir le style et la taille de chaque symbole de trou (en savoir plus).

Unités

Primary Units

Sélectionnez le type d’unité de mesure principale à afficher dans le tableau. Utilisez le bouton  associé pour afficher ou masquer les unités de mesure.

Lorsque l’option Document : <Units> est sélectionnée comme Primary Units, les unités principales spécifiées pour le document sont appliquées au tableau. Les unités principales du document sont sélectionnées à l’aide de la liste déroulante Primary Units dans la zone Units de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman.

Dual Units

Sélectionnez le type d’unité de mesure secondaire (double cotation) à afficher dans le tableau. Utilisez le bouton  associé pour afficher ou masquer les valeurs en unités secondaires.

Lorsque l’option Document : <Units> est sélectionnée comme Dual Units, les unités secondaires spécifiées pour le document sont appliquées au tableau. Les unités secondaires du document sont sélectionnées à l’aide de la liste déroulante Dual Units dans la zone Units de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman.

Précision

Primary Units

Utilisez le menu déroulant Value Precision pour définir la précision (jusqu’à cinq chiffres après la virgule, le dernier chiffre étant arrondi) des dimensions de trous exprimées en unités principales dans le tableau.

Lorsque l’option Document : <Precision> est sélectionnée, la précision des valeurs et des tolérances en unités principales spécifiée pour le document est appliquée au tableau. La précision des valeurs et des tolérances en unités principales du document est sélectionnée à l’aide des options Value Precision et Tolerance Precision pour Primary Units dans la zone Units de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman.

Dual Units

Utilisez le menu déroulant Value Precision pour définir la précision (jusqu’à cinq chiffres après la virgule, le dernier chiffre étant arrondi) des dimensions de trous exprimées en unités secondaires, si elles sont activées.

Lorsque l’option Document : <Precision> est sélectionnée, la précision des valeurs et des tolérances en unités secondaires spécifiée pour le document est appliquée à la cote. La précision des valeurs et des tolérances en unités secondaires du document est sélectionnée à l’aide des options Value Precision et Tolerance Precision pour Dual Units dans la zone Units de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman.

Utilisez l’onglet Columns du panneau Properties pour gérer les colonnes de données du tableau de perçage ().

  • Les entrées peuvent être modifiées pour spécifier les colonnes incluses (visibles) dans le tableau de perçage ainsi que leur alignement Horizontal et Vertical.

  • Utilisez l’entrée Width pour définir la largeur de la colonne par rapport au texte qu’elle contient. Saisissez Auto pour que la largeur s’adapte dynamiquement au texte de la cellule la plus large de la colonne.

  • Cliquez dans la colonne Order pour parcourir les options de tri des données des colonnes du tableau (désactivé, croissant et décroissant). Le tri peut être appliqué à plusieurs colonnes selon un ordre de priorité, les colonnes triées situées à gauche dans le tableau étant prioritaires.

  • Les en-têtes du tableau de perçage peuvent être modifiés en saisissant un Caption pour le nom du paramètre d’une colonne du tableau.

  • Utilisez  et  boutons permettant de déplacer l’entrée sélectionnée d’un cran vers le haut ou vers le bas et, par conséquent, vers la gauche ou vers la droite dans l’ordre des colonnes du tableau de perçage. Disponibles pour les colonnes définies comme visibles.

Les styles des symboles du tableau de perçage et le regroupement des types de trous de perçage sous ces symboles sont déterminés par les paramètres de la boîte de dialogue Drill Symbol Configurations, qui s’ouvre en cliquant sur le bouton dans le panneau Properties (dans la zone Properties de l’onglet General) lorsque le tableau est sélectionné dans l’espace de conception.

Il s’agit de la même boîte de dialogue que celle accessible depuis le panneau Properties pour une vue de plan de perçage, mais, dans ce cas, seules les colonnes activées (rendues visibles) pour le tableau de perçage sont affichées. Notez que les deux versions de la boîte de dialogue Drill Symbol Configuration proviennent de la même source et interagissent donc entre elles.

Symbol Graphics Utilisez la liste déroulante pour sélectionner le symbole de représentation des trous souhaité parmi un ensemble de formes et de lettres prédéfinies.
Sync Symbols with PCB Lorsque cette option est activée, les symboles du tableau de perçage sont synchronisés avec ceux du PCB.
Symbol Size Table

Saisissez la taille souhaitée des symboles dans le tableau.

  • Notez que la taille des symboles sera modifiée pour les symboles de perçage actuellement sélectionnés dans la grille en haut de la boîte de dialogue. Pour sélectionner plusieurs symboles de perçage dans la grille, utilisez la méthode Ctrl+Click ou Shift+Click.

  • Notez également que la taille est liée entre la vue de plan de perçage et le tableau de perçage si l’icône de liaison indique un état lié (). Pour définir indépendamment la taille des symboles de perçage, cliquez sur l’icône de liaison afin de dissocier les deux tailles, puis définissez chacune d’elles selon vos besoins.

Symbol Size View Saisissez la taille souhaitée des symboles dans la vue. Pour accéder à ce champ et le modifier, l’icône de liaison doit indiquer un état dissocié (). Cliquez sur l’icône de liaison pour changer l’état de liaison.
Symbol Line Style

Utilisez les listes déroulantes pour sélectionner le trait utilisé pour dessiner la bordure ou le contour des symboles. Les options disponibles sont définies dans la zone Line Styles du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman. Utilisez le bouton de couleur associé pour définir la couleur du trait.

Grouping Les critères choisis regroupent les éléments sélectionnés sous un même symbole. Par exemple, si seul HoleSize est sélectionné, un symbole distinct est attribué à chaque diamètre de trou utilisé dans le PCB. À mesure que d’autres options de regroupement sont sélectionnées, l’attribution des symboles prend en compte ces critères supplémentaires en créant un regroupement plus fin.

Vous pouvez définir les paramètres par défaut de Symbol Size Table, Symbol Size View, Symbol Line Style et Grouping sur la page Draftsman – Valeurs par défaut de la boîte de dialogue Preferences. Sur cette page, sélectionnez Drill Table dans Primitive List et ouvrez l’onglet Drill Symbol dans la zone des propriétés à droite ().

Tableau des lignes de transmission

Les calculs appliqués au routage à impédance contrôlée produisent des structures de pistes visant à respecter une impédance de ligne de transmission cible et, par conséquent, les exigences de la conception de la carte en matière de signaux à haute vitesse et/ou de champs électromagnétiques. Les couches de la carte et leurs propriétés spécifiées ou calculées sont accessibles via le gestionnaire d’empilage des couches, où les couches de routage à impédance contrôlée sont associées à des profils d’impédance configurables. Les matériaux et les dimensions de la carte définis dans chaque profil sont utilisés dans les calculs d’impédance de ligne de transmission, ce qui aboutit à une structure de piste donnée. Cette structure prend en charge aussi bien les pistes simples que les paires différentielles, ainsi que les configurations de couches stripline (internes) ou microruban (en surface).

Pour plus d’informations sur la configuration des profils d’impédance, consultez la page Définition de l’empilage des couches.

La structure et les données associées à chaque définition de ligne de transmission dans l’empilage des couches de la carte constituent des informations importantes pour la fabrication du PCB. Draftsman propose donc un objet dédié de type tableau des lignes de transmission (Place » Transmission Line Table) pour documenter ces informations. Le tableau est alimenté par les données issues du gestionnaire d’empilage des couches et de ses calculs d’impédance de ligne de transmission.

Un tableau des lignes de transmission placé
Un tableau des lignes de transmission placé

Le style visuel et les données d’un tableau des lignes de transmission placé sont configurables dans le panneau Properties lorsque le tableau est sélectionné dans l’espace de conception. Les propriétés générales du tableau sont configurées dans l’onglet General du panneau ().

Titre

Title

Le texte du titre qui sera affiché (si cette option est activée) avec le tableau. Utilisez le bouton associé pour afficher ou masquer le titre dans le dessin.

Ce champ peut contenir du texte statique et les paramètres souhaités sous forme de chaînes spéciales. Utilisez la syntaxe =<ParameterName> pour inclure un paramètre dans le titre. Les valeurs des paramètres inclus seront affichées dans le titre sur la feuille de dessin. Pour obtenir la liste des paramètres système et PCB disponibles, consultez la page Configuration d’un document Draftsman.

Location Utilisez la liste déroulante pour choisir parmi plusieurs positions relatives du titre. L’option Manual est automatiquement sélectionnée si le titre est déplacé manuellement (par glisser-déposer vers un nouvel emplacement).
Font

Définit la police utilisée pour le titre.

  • Lorsque l’option Use Document Font est activée, la police du titre utilisée est celle définie par les options du document (l’entrée Document Font dans la zone General de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception).

  • Lorsque l’option Use Document Font est désactivée, utilisez les options proposées pour choisir la police, la taille, la couleur et les attributs de texte souhaités.

Propriétés

Table Line Style

Utilisez les listes déroulantes pour sélectionner le trait utilisé pour dessiner les lignes du tableau. Les options disponibles sont définies dans la zone Line Styles du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman. Utilisez le bouton de couleur associé pour définir la couleur du trait.

Justification Sélectionnez le point par rapport auquel la position du tableau est modifiée si sa taille est mise à jour.
Even Row Color Sélectionnez la couleur de contraste des lignes paires du tableau.
Non-Even Row Color Sélectionnez la couleur de contraste des lignes impaires du tableau.
Caption Font

Définit la police utilisée pour les données du tableau.

  • Lorsque l’option Use Document Font est activée, la police utilisée est celle définie par les options du document (l’entrée Document Font dans la zone General de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception).

  • Lorsque l’option Use Document Font option est désactivée, utilisez les options proposées pour choisir le type, la taille et la couleur de police, ainsi que les attributs du texte souhaités.

Le tableau se redimensionne automatiquement pour s’adapter à la taille de police sélectionnée.

Rows Font

Définit la police utilisée pour le corps du tableau (le texte des lignes du tableau).

  • Lorsque l’option Use Document Font est activée, la police utilisée est celle définie dans les options du document (l’entrée Document Font dans la zone General de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception).

  • Lorsque l’option Use Document Font est désactivée, utilisez les options proposées pour choisir le type, la taille et la couleur de police, ainsi que les attributs du texte souhaités.

Le tableau se redimensionne automatiquement pour s’adapter à la taille de police sélectionnée.

Unités

Primary Units

Sélectionnez le type d’unité de mesure principale à afficher dans le tableau. Utilisez le bouton  associé pour afficher ou masquer les unités de mesure.

Lorsque l’option Document : <Units> est sélectionnée, les unités principales définies pour le document sont appliquées au tableau. Les unités principales du document sont sélectionnées à l’aide de la liste déroulante Units dans la zone Units de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman.

Primary Precision

Sélectionnez la précision (jusqu’à cinq chiffres après la virgule, avec arrondi du dernier chiffre) des valeurs exprimées dans les unités principales.

Lorsque l’option Document : <Precision> est sélectionnée, la précision des valeurs et des tolérances en unités principales définie pour le document est appliquée au tableau. La précision des valeurs et des tolérances en unités principales du document est sélectionnée à l’aide des options Value Precision et Tolerance Precision pour Primary Units dans la zone Units de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman.

Dual Units

Sélectionnez le type d’unité de mesure secondaire (double cotation) à afficher dans le tableau. Utilisez le bouton  associé pour afficher ou masquer les valeurs en unités secondaires.

Lorsque l’option Document : <Units> est sélectionnée, les unités de double cotation définies pour le document sont appliquées au tableau. Les unités de double cotation du document sont sélectionnées à l’aide de la liste déroulante Dual_Units dans la zone Units de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman.

Dual Precision

Sélectionnez la précision (jusqu’à cinq chiffres après la virgule, avec arrondi du dernier chiffre) des valeurs exprimées dans les unités secondaires, si elles sont activées.

Lorsque l’option Document : <Precision> est sélectionnée, la précision des valeurs et des tolérances en unités de double cotation définie pour le document est appliquée à la cote. La précision des valeurs et des tolérances en unités de double cotation du document est sélectionnée à l’aide des options Value Precision et Tolerance Precision pour Dual Units dans la zone Units de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman.

Utilisez l’onglet Columns du panneau Properties pour gérer les colonnes et les lignes de données de la ligne de transmission ().

  • La zone Columns présente la liste des colonnes incluses dans le tableau. Chaque entrée de colonne peut être modifiée en activant ou désactivant sa visibilité, en renommant son en-tête (Caption), en parcourant ses options d’alignement du texte (Align) ou en définissant une largeur de colonne spécifique ou automatique (Width). L’ordre des entrées de la liste, et donc l’ordre des colonnes dans le tableau placé, peut être modifié en déplaçant une entrée de colonne sélectionnée à l’aide des boutons  et  associés.

  • La zone Rows présente la liste des données des lignes du tableau, triées selon la colonne Impedance Id, qui correspond aux couches nommées de la carte dans l’empilage des couches source. Utilisez la commande de visibilité associée à chaque entrée de ligne pour afficher ou masquer cette ligne dans le tableau.

Tableau

Un document Draftsman permet de placer un tableau générique sur le dessin, puis de le configurer dans le panneau Properties et directement dans les cellules du tableau. La disposition et le contenu du tableau personnalisé peuvent être définis librement selon son utilisation prévue et offrent un moyen souple d’inclure des informations supplémentaires dans tout document Draftsman.

Un tableau placé présentant différentes mises en forme de cellules
Un tableau placé présentant différentes mises en forme de cellules

  • En combinant les options disponibles dans les propriétés du tableau et les commandes du tableau, vous pouvez créer un tableau personnalisé répondant à un large éventail de besoins d’information dans un document Draftsman. Le tableau ci-dessous, par exemple, a été créé pour présenter les informations issues d’un rapport d’empilage de la carte.

    Un tableau personnalisé peut être créé pour contenir une grande variété d’informations sur l’assemblage et la fabrication des PCB.
    Un tableau personnalisé peut être créé pour contenir une grande variété d’informations sur l’assemblage et la fabrication des PCB.

  • Les tableaux peuvent être inclus aussi bien dans les modèles de feuille que dans les modèles de document.

Le lancement de la commande de placement de tableau (Place » Table) ouvre la boîte de dialogue Insert table, dans laquelle vous pouvez spécifier le nombre de lignes et de colonnes du nouveau tableau. Après avoir cliqué sur OK dans la boîte de dialogue Insert table, le nouveau tableau est attaché au curseur et peut être placé à l’emplacement souhaité d’un clic supplémentaire.

Spécifiez le nombre de cellules dans les lignes et les colonnes du tableau. Vous pourrez le modifier ultérieurement à l’aide des commandes Table du menu contextuel d’une cellule.
Spécifiez le nombre de cellules dans les lignes et les colonnes du tableau. Vous pourrez le modifier ultérieurement à l’aide des commandes Table du menu contextuel d’une cellule.

La position d’un tableau placé peut être modifiée graphiquement en sélectionnant l’objet tableau dans l’espace de conception, puis en le faisant glisser vers un nouvel emplacement à l’aide de sa poignée de déplacement, c’est-à-dire l’icône  dans le coin supérieur gauche.

Faites glisser l’icône de déplacement d’un tableau sélectionné pour le repositionner dans l’espace de conception.
Faites glisser l’icône de déplacement d’un tableau sélectionné pour le repositionner dans l’espace de conception.

Un objet tableau est sélectionné lorsque vous cliquez sur une cellule ou sur son titre. Toutefois, la commande Delete s’applique à l’élément précis sur lequel vous cliquez. 

Le contenu d’un tableau est saisi (ou collé) directement dans les cellules. Utilisez Ctrl+Enter pour ajouter une nouvelle ligne dans une cellule.

Les attributs graphiques et textuels du tableau sont définis dans le panneau Properties lorsque le tableau est sélectionné dans l’espace de conception (). L’objet tableau offre un large éventail de fonctions de modification du texte et de la structure, applicables à une ligne ou à une colonne de cellules à l’aide des commandes standard Shift+Click ou Click, Hold&Drag technique.

Titre

Title

Le texte du titre qui sera affiché (si activé) avec le tableau. Utilisez le bouton associé pour afficher ou masquer le titre dans le dessin.

Le champ peut inclure du texte statique et les paramètres souhaités sous forme de chaînes spéciales. Utilisez la syntaxe =<ParameterName> pour inclure un paramètre dans le titre. Les valeurs des paramètres inclus seront affichées dans le titre sur la feuille de dessin. Pour obtenir la liste des paramètres système et PCB disponibles, consultez la page Configuration d’un document Draftsman.

Location Ouvrez la liste déroulante pour choisir parmi plusieurs positions relatives du titre. L’option Manual est automatiquement sélectionnée si le titre est déplacé manuellement (par glisser-déposer vers un nouvel emplacement).
Font

Définit la police utilisée pour le titre.

  • Lorsque l’option Use Document Font est activée, la police du titre utilisée est celle définie dans les options du document (l’entrée Document Font dans la zone General de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception).

  • Lorsque l’option Use Document Font est désactivée, utilisez les options proposées pour choisir le type, la taille et la couleur de police ainsi que les attributs de texte souhaités.

Propriétés

Ligne extérieure

Utilisez les listes déroulantes pour sélectionner la ligne utilisée pour tracer la bordure ou le contour du tableau. Les options disponibles sont définies dans la zone Line Styles du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman. Utilisez le bouton de couleur associé pour définir la couleur de la ligne.

Inner Line Utilisez les listes déroulantes pour sélectionner la ligne utilisée pour tracer les lignes intérieures du tableau qui séparent les cellules. Les options disponibles sont définies dans la zone Line Styles du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Pour plus d’informations, consultez la page Configuration d’un document Draftsman. Utilisez le bouton de couleur associé pour définir la couleur de la ligne.
Column Width

Définit la largeur des cellules sélectionnées et, par conséquent, celle de la colonne qui les contient. Si le tableau entier est sélectionné (en cliquant sur son contour ou son titre), le réglage de largeur sera appliqué à toutes les cellules. Utilisez le bouton de couleur associé pour définir la couleur des cellules actuellement sélectionnées.

Row Height Utilisez ce champ pour ajuster la hauteur d’une ligne sélectionnée dans l’espace de conception. Saisissez la hauteur souhaitée, suivie de l’unité impériale ou métrique.
Cell Padding Vertical Définit l’espacement au-dessous et au-dessus du texte dans les cellules sélectionnées.
Cell Padding Horizontal Définit l’espacement à gauche et à droite du texte dans les cellules sélectionnées.
Font

Définit la police utilisée pour le texte dans les cellules sélectionnées.

  • Lorsque l’option Use Document Font est activée, la police utilisée est celle définie dans les options du document (l’entrée Document Font dans la zone General de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception).

  • Lorsque l’option Use Document Font est désactivée, utilisez les options proposées pour choisir le type, la taille et la couleur de police ainsi que les attributs de texte souhaités.

Le tableau sera automatiquement redimensionné pour s’adapter à la taille de police sélectionnée.

Alignment Utilisez les boutons pour définir l’alignement et le positionnement du texte Horizontal (à gauche, au centre ou à droite) et Vertical (en haut, au milieu ou en bas) dans les cellules sélectionnées.
Justification Sélectionnez le point par rapport auquel la position du tableau est modifiée si sa taille est mise à jour.

Chaînes spéciales dans les cellules du tableau

Un tableau permet d’inclure des paramètres du document Draftsman sous forme de chaînes spéciales. Les paramètres du projet (locaux et côté Workspace), les paramètres système, les paramètres PCB et les paramètres utilisateur seront convertis en leurs valeurs lorsqu’ils sont saisis sous forme de chaînes spéciales dans les cellules du tableau. Les paramètres du document Draftsman sont accessibles dans l’onglet Parameters du panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception. Consultez la page Configuration d’un document Draftsman pour en savoir plus.

La gestion des chaînes de paramètres par le tableau permet également de transférer correctement les données des chaînes spéciales vers et depuis une feuille de calcul à l’aide des méthodes standard de copier-coller.

  • Lorsque vous collez des chaînes spéciales depuis Draftsman dans une feuille de calcul, les cellules cibles de la feuille de calcul sont remplies avec la valeur interprétée de la chaîne.

  • Lorsque vous collez des données de chaînes spéciales depuis une feuille de calcul dans Draftsman, le texte collé est interprété comme une valeur de chaîne spéciale, à condition que cette chaîne corresponde à un paramètre système, de projet ou utilisateur disponible.

    Lorsque vous préparez des entrées de chaînes spéciales dans une feuille de calcul, vous devez faire précéder chaque valeur saisie d’une apostrophe ('), afin que le contenu de la cellule soit traité comme du texte. Par exemple, la chaîne spéciale du paramètre Units doit être saisie sous la forme '=DocumentUnits. Vous pouvez également définir le format de toutes les cellules de la feuille de calcul sur Texte.

Structure du tableau

Faites un clic droit dans une cellule et sélectionnez le menu Table dans le menu contextuel pour accéder aux commandes de configuration des cellules. Celles-ci offrent un ensemble complet de fonctions de manipulation du tableau permettant d’ajouter et de supprimer des colonnes et des lignes, ainsi que de fusionner des cellules.

Les commandes Table accessibles par clic droit offrent diverses fonctions standard de manipulation des tableaux.
Les commandes Table accessibles par clic droit offrent diverses fonctions standard de manipulation des tableaux.

  • La commande Merge Cells n’est disponible que si au moins deux cellules consécutives sont actuellement sélectionnées dans le tableau.

    • Lors de la fusion de cellules contenant du texte, seul le texte de la cellule située le plus à gauche ou le plus en haut (selon le cas) sera conservé dans la cellule fusionnée.

  • La commande Unmerge Cells n’est disponible que si le curseur se trouve dans une cellule fusionnée du tableau ou si la plage de cellules sélectionnée comprend au moins une cellule fusionnée.

    • Notez que si la cellule contient du texte, celui-ci apparaîtra dans la cellule située le plus à gauche ou le plus en haut (selon le cas) après l’annulation de la fusion.

    • Lorsque plusieurs cellules fusionnées sont incluses dans une sélection de cellules, notez que cette commande n’annule la fusion que de la cellule fusionnée située le plus à gauche ou le plus en haut.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents