Sincronizzazione dei dati dal database della supply chain al Workspace
A colpo d'occhio
- Scopri come creare una configurazione di sincronizzazione e collegare le origini dati supportate.
- Impara ad associare i parametri dei fornitori e gli scaglioni di prezzo, utilizzando il codice componente del produttore per collegare le voci dei fornitori ai componenti del Workspace.
- Scopri come eseguire o pianificare la sincronizzazione e dove trovare in Altium Designer i dati risultanti del fornitore di componenti personalizzato.
Attraverso il concetto di Scelte dei componenti, i componenti ospitati in un Workspace Altium 365 o in un Workspace Enterprise Server possono essere associati a componenti effettivamente disponibili presso i fornitori (distributori), in base al componente del produttore specificato. Per impostazione predefinita, questi dati della catena di approvvigionamento provengono dal servizio cloud Altium Parts Provider e includono informazioni in tempo reale sui componenti dei fornitori, come disponibilità a magazzino, prezzi unitari e scaglioni di prezzo.
Per molte organizzazioni, tuttavia, i dati dei fornitori di componenti provengono (e devono provenire) da un sistema aziendale interno che fornisce un insieme proprietario di dati sui fornitori di componenti, eventualmente basato su una gamma rigorosamente approvata di distributori e/o su strutture di prezzo speciali. Questa esigenza viene soddisfatta dall'alternativa Altium Custom Parts Provider che, se configurata per la sincronizzazione tramite Altium Designer, consente di mappare i dati dei fornitori provenienti da un database specificato ai dati della catena di approvvigionamento del Workspace.
Utilizzando la funzionalità Custom Parts Provider Synchronization di Altium Designer, come illustrato di seguito, i dati dei fornitori provenienti da una tabella selezionata all'interno di un database principale vengono mappati per diventare una fonte di dati alternativa per le Scelte dei componenti effettuate in Altium Designer. In pratica, la configurazione di mappatura creata viene utilizzata per sincronizzare il database di origine con i dati dei fornitori del Workspace, secondo una pianificazione oppure semplicemente su richiesta. Di conseguenza, gli aggiornamenti dei dati dei fornitori nel database principale vengono propagati ai dati corrispondenti dei fornitori di componenti nel Workspace connesso.
Questa funzionalità consente alle aziende che gestiscono centralmente i dati dei fornitori di componenti nel database di un sistema aziendale di sfruttare i vantaggi di un Workspace Altium mantenendo la sincronizzazione con il proprio sistema aziendale (PLM, PDM, ERP, ecc.) oppure, semplicemente, con un database condiviso o un file CSV. In modalità di sincronizzazione automatica, un'attività pianificata di Windows esegue l'aggiornamento dei dati dal database al Workspace indipendentemente dal client di progettazione Altium Designer.
-
Per informazioni sull'importazione di librerie di database nel Workspace, vedere Importazione delle librerie esistenti nel Workspace connesso.
-
Per informazioni sul processo correlato di sincronizzazione dei dati dei parametri dei componenti del Workspace con un database di origine, vedere Sincronizzazione dei dati dei componenti tra database e Workspace.
Creazione di una configurazione di sincronizzazione dei fornitori di componenti personalizzati
La sincronizzazione dei dati dei fornitori di componenti dal database al Workspace viene impostata creando e configurando un documento Custom Parts Provider Synchronization Configuration (*.PrtSync) in Altium Designer. L'interfaccia e le funzionalità del documento sono simili a quelle del Sincronizzatore dei componenti. Una volta connessi al Workspace Altium, creare il nuovo documento tramite il comando di menu File » New » Custom Parts Provider Synchronization Configuration.
Aggiungere la fonte di dati principale desiderata alla configurazione di sincronizzazione tramite il pulsante
, oppure trascinando i file di dati compatibili nell'area Data Sources dell'interfaccia. La configurazione supporta le seguenti fonti di dati dei parametri dei componenti:
-
File di database Access (
*.mdb,*.accdb) -
Fogli di calcolo Excel (
*.xlsx) -
File CSV (
*.csv) -
Altre fonti di dati, come interfacce compatibili con OLE DB basate su server (inclusi i database PostgreSQL), tramite una stringa di connessione proprietaria. Per la procedura di connessione ODBC a MySQL, vedere la sezione Configurazione di MySQL di seguito.
Nell'esempio mostrato qui, alla configurazione è stato aggiunto un database che contiene i dati dei fornitori di componenti (per diodi Zener). Il database di origine (SupplierData.mdb) contiene due tabelle, CustomSupplierParts1 e CustomSupplierParts2, delle quali la prima è abilitata per la mappatura e la sincronizzazione.
Procedura di configurazione ODBC per MySQL
La sincronizzazione dei fornitori di componenti personalizzati con un database MySQL viene impostata utilizzando Microsoft OLE DB Provider for ODBC con l'applicazione MySQL Connector/ODB. La procedura di connessione e configurazione è la seguente:
-
Scaricare e installare MySQL Connector, disponibile tramite l'opzione di installazione personalizzata di MySQL Installer 8. Quindi eseguire l'applicazione Windows ODB Data Sources per aggiungere il tipo MySQL ODBC ANSI Driver, specificare l'origine MySQL e il database in MYSQL Connector e confermare l'origine dati ODB appena aggiunta.
-
Creare una nuova configurazione di sincronizzazione dei componenti in Altium Designer (File » New » Custom Parts Provider Synchronization Configuration) e selezionare l'opzione Use Connection String dal menu
.
-
Nella successiva finestra di dialogo Data Link Properties, selezionare l'opzione
Microsoft OLER DB Provider for ODBC Driversnella scheda Provider, fare clic su Next, quindi, nella scheda Connection della finestra di dialogo, immettere i dettagli dell'origine dati definiti in Step 1 sopra. -
Abilitare la tabella del database MySQL desiderata nel pannello Properties di Altium Designer.
-
Selezionare la tabella del database nella gerarchia Data Source e quindi mappare le colonne di dati ai parametri Altium nel pannello Properties, secondo necessità.
Mappatura dei parametri dei dati dei fornitori
La nuova configurazione dei fornitori di componenti personalizzati accede alla tabella del database come fonte di dati parametrici. Quando la tabella viene selezionata nell'albero Data Sources della configurazione, può essere mappata ai parametri standard dei dati dei fornitori utilizzati da Altium Designer e dal Workspace Altium.
I parametri dei dati dei fornitori vengono mappati dal database di origine alla configurazione dei fornitori di componenti nell'area Parameter Mapping del pannello Properties. Utilizzare le opzioni del menu a discesa della voce Column per scegliere un parametro del database di origine che corrisponda correttamente a un parametro dei dati dei fornitori oppure per rimuovere un parametro dalla sincronizzazione (<Skip>). Ogni insieme di dati dei parametri viene aggiunto all'elenco Components Preview man mano che viene mappato. Queste colonne possono essere riordinate trascinandone le intestazioni e abilitate/disabilitate tramite il menu Select Columns (accessibile facendo clic con il pulsante destro del mouse su un'intestazione).
Sono supportati diversi parametri di sistema per i dati dei fornitori, tra cui Manufacturer Name, Manufacturer Part Number, Category, Datasheet, ecc. È inoltre possibile aggiungere e rimuovere parametri personalizzati per i dati dei fornitori utilizzando i pulsanti
e
nell'area Parameter Mapping del pannello Properties.
Gli scaglioni di prezzo dei componenti rappresentano il numero di componenti da ordinare a un fornitore per ottenere un costo unitario ridotto. Le quantità d'ordine richieste sono generalmente organizzate per potenze di dieci – 10 unità, 100 unità, ecc. – e sono supportate dalle voci di scelta dei componenti nei dati dei fornitori di Altium.
Questi dati numerici possono essere mappati dalle voci del database di origine ai dati dei fornitori del Workspace aggiungendo voci Quantity per gli scaglioni di prezzo nella sezione Price Breaks del pannello Properties – con quantità che aumentano progressivamente per potenze di dieci – e quindi mappando tali voci ai campi appropriati del database. Si noti che il parametro di costo convenzionale unit (Price) è incluso nella sezione generale Parameter Mapping.
Sincronizzazione dal database al Workspace
Una volta completata la configurazione della mappatura dei dati dei fornitori, salvare il documento di configurazione del provider di componenti personalizzato (File » Save) ed eseguire una sincronizzazione dei dati dal database di origine al server tramite il pulsante
, oppure impostare una sincronizzazione pianificata La sincronizzazione iniziale caricherà i dati dei fornitori mappati dal database aziendale nel Workspace Altium, mentre i cicli di sincronizzazione successivi aggiorneranno tali dati.
Nell'esempio qui illustrato, i dati dei fornitori relativi ai diodi Zener sincronizzati dal database di origine al Workspace diventano disponibili come dati Custom Parts Provider per tali componenti, oltre ai normali dati dei fornitori di componenti forniti dal servizio cloud Altium Parts Provider.
Un riscontro immediato è visibile nel pannello Manufacturer Part Search quando si seleziona la categoria Custom Parts Provider, che propone soluzioni di approvvigionamento dei componenti tramite il servizio Custom Parts Provider, sincronizzate dal database dei fornitori dell'organizzazione.
Unione dei dati dei fornitori
Se il nome del produttore e il codice componente del produttore di un componente nel database dei fornitori sincronizzato coincidono con il nome del produttore e il codice componente del produttore di un componente fornito da Altium Parts Provider, i dati dei fornitori del Custom Parts Provider configurato vengono uniti a quelli di Altium Parts Provider per presentare tutte le informazioni sui fornitori insieme, ovunque i dati dei fornitori (SPN) siano visualizzati nell'interfaccia utente del software, inclusi il pannello Manufacturer Part Search, ActiveBOM e ogni volta che si aggiungono scelte dei componenti.
Scelte dei componenti dai dati del provider personalizzato
Quando si aggiungono informazioni sulle scelte dei componenti alle voci dei componenti nel pannello Components (clic con il pulsante destro del mouse, Operations » Create/Edit PCL), i dati dei fornitori forniti da Custom Parts Provider appariranno in cima all'elenco nella finestra di dialogo Add Part Choices, come mostrato qui per la voce del diodo Zener 1N4747A. La voce selezionata (evidenziata) verrà aggiunta come scelta del componente per il componente selezionato nel pannello Components.
Come il servizio Altium Parts Provider, anche Custom Parts Provider supporta i dati dei fornitori relativi a più produttori e provenienti da più fornitori, ricavati da più voci distinte nella tabella del database di origine. Si noti inoltre che i dati del provider personalizzato includeranno informazioni sugli scaglioni di prezzo e sui livelli delle scorte sincronizzate dal database di origine.
Oltre al pannello Components qui illustrato, le scelte dei componenti relative ai fornitori possono essere associate a un riferimento di componente nelle seguenti interfacce di Altium Designer:
- Il pannello Explorer.
- Un documento ActiveBOM.
- Il Single Component Editor.
- Il Batch Component Editor.
Sincronizzazione pianificata
Le configurazioni di sincronizzazione dei componenti salvate vengono impostate per l'elaborazione automatizzata dei dati dal database al Workspace tramite la finestra di dialogo Auto Synchronization Schedule, aperta dal pulsante
nell'interfaccia principale.
La sincronizzazione pianificata, in base al profilo di configurazione corrente, può essere impostata a un'ora specifica ogni giorno, a un determinato orario in vari giorni della settimana oppure all'accesso a Windows. È inoltre possibile disabilitare la sincronizzazione quando non si è connessi. Quando si confermano le impostazioni con il pulsante
, la configurazione verrà aggiunta come attività ricorrente in Windows Task Scheduler. Impostare su No automatic synchronization per rimuovere una pianificazione di sincronizzazione esistente.
La sincronizzazione dei dati dal database ai componenti può essere eseguita anche manualmente dalla riga di comando utilizzando l'applicazione ComponentSync.Executor.exe, disponibile nella cartella \System dell'installazione del software. La sintassi del comando è ComponentSync.Executor.exe [configuration file name]. Nell'immagine seguente è stata eseguita la configurazione MyPrtSyncConfig di questo esempio, utilizzando la stringa di comando:
"C:\Program Files\Altium\AD<Solution/Version>\System\ComponentSync.Executor.exe" C:\Users\Public\Documents\PrtSync\MyPrtSyncConfig.PrtSync








).


