Component Templates

A colpo d'occhio

I modelli di componente in un Workspace connesso semplificano la creazione dei componenti in Altium Designer, fornendo impostazioni e parametri riutilizzabili. Questo articolo spiega come organizzare gli elementi Modello di componente, scegliere gli schemi di denominazione e del ciclo di vita e utilizzare la modifica diretta per definire e salvare i modelli nel Workspace. Presenta inoltre i controlli per la visibilità dei parametri, i valori predefiniti, i campi obbligatori e le modifiche consentite al progettista. Continua a leggere per iniziare a creare modelli riutilizzabili che favoriscano definizioni dei componenti più coerenti.

- Scopri come configurare le cartelle del Workspace e gli elementi Modello di componente con schemi di denominazione, revisione e ciclo di vita appropriati.
- Comprendi come i modelli controllano i parametri dei componenti, inclusi i valori obbligatori e i valori predefiniti di sola lettura.
- Scopri come modificare direttamente i modelli e salvarli nuovamente nel Workspace come nuove revisioni.
Approfondisci con l'IA:

Per semplificare la creazione dei componenti, Altium Designer, insieme al tuo Workspace connesso, supporta la creazione e la definizione di Component Templates (elementi modello di componente) in tale Workspace. Proprio come un modello di schema può essere utilizzato per predefinire le informazioni sui fogli schematici che vi fanno riferimento, un modello di componente viene richiamato da un componente della libreria del Workspace e fornisce impostazioni predefinite da utilizzare nella definizione di quel componente.

In particolare, i modelli di componente sono stati sviluppati tenendo ben presenti le informazioni parametriche e consentono di definire, in un'unica posizione, un insieme di parametri che saranno disponibili per il componente che fa riferimento al modello. Tramite il modello, puoi controllare quali parametri rendere visibili, inserire valori predefiniti e persino contrassegnare come obbligatori i parametri richiesti. Al momento del salvataggio del componente vengono eseguiti controlli di convalida per garantire la conformità.

I valori predefiniti specificati per molte delle impostazioni del modello possono essere bloccati in sola lettura oppure resi modificabili dal progettista, in modo selettivo, durante la definizione di un componente.

Un modello di componente costituisce anche la base per la creazione di un componente generico. Per saperne di più, consulta la pagina Creazione di componenti generici.

L'accesso ai modelli di componente dipende dalla licenza del software. Per ulteriori informazioni, consulta il riquadro Note sul lato destro della pagina.

Questi modelli di componente vengono creati direttamente nel Workspace. Una volta creato un modello di componente (e salvati i dati in una sua revisione), è possibile riutilizzarlo per creare uno o più componenti.

Tipo di cartella

Quando crei la cartella in cui memorizzare i modelli di componente, puoi specificarne il tipo. Questo non influisce sul contenuto della cartella: il rilascio di un modello di componente genera sempre un corrispondente elemento modello di componente. Fornisce semplicemente un'indicazione visiva di ciò che è memorizzato nella cartella e può essere utile quando si esplora un Workspace alla ricerca di contenuti specifici. Per destinare una cartella a contenere modelli di componente, imposta Folder Type su Component Templates durante la definizione delle proprietà della cartella nella finestra di dialogo Edit Folder.

Specificare il tipo di cartella, ovvero l'uso a cui è destinata, fornisce un'indicazione visiva del suo contenuto durante l'esplorazione del Workspace.
Specificare il tipo di cartella, ovvero l'uso a cui è destinata, fornisce un'indicazione visiva del suo contenuto durante l'esplorazione del Workspace.

Tipo di contenuto

Quando crei un elemento modello di componente di destinazione in cui memorizzare il modello di componente, assicurati che il relativo Content Type sia impostato su Component Template nella finestra di dialogo Create New Item. Se stai creando l'elemento in una cartella di tipo Component Templates, questo tipo di contenuto sarà disponibile nel menu contestuale accessibile con il pulsante destro del mouse durante la creazione dell'elemento.

Creazione di un modello di componente all'interno di una cartella Component Templates: il Content Type corretto è disponibile nel menu contestuale.
Creazione di un modello di componente all'interno di una cartella Component Templates: il Content Type corretto è disponibile nel menu contestuale.

Salvataggio di un modello di componente

Related page: Creazione e modifica dei contenuti

Finora abbiamo esaminato il supporto per i modelli di componente nel Workspace in termini di tipi di cartella e di contenuto associati. Il salvataggio di un modello di componente effettivamente definito in una revisione di un elemento modello di componente può essere eseguito in modo semplice e rapido.

Grazie al supporto del Workspace per la modifica diretta, è possibile modificare un modello di componente e salvarlo nella revisione iniziale di un elemento modello di componente appena creato. La modifica diretta elimina i vincoli legati alla gestione separata dei dati sorgente sotto controllo di versione. Puoi semplicemente modificare un tipo di contenuto supportato utilizzando un editor temporaneo nel quale viene caricata l'ultima versione dei dati sorgente direttamente dal Workspace. Una volta completata la modifica, l'entità viene salvata (o salvata nuovamente) in una successiva revisione pianificata dell'elemento padre e l'editor temporaneo viene chiuso. Non ci sono file sul disco rigido, non devi chiederti se stai lavorando con i dati sorgente corretti o più recenti e non devi gestire un software separato per il controllo di versione. Il Workspace si occupa di tutto, garantendo un'elevata integrità dei dati e velocizzandone notevolmente la modifica.

Quando crei un elemento modello di componente, puoi modificare e salvare un modello di componente nella revisione iniziale dell'elemento, dopo la sua creazione. A tale scopo, abilita l'opzione Open for editing after creation, nella parte inferiore della finestra di dialogo Create New Item (abilitata per impostazione predefinita). L'elemento verrà creato e si aprirà l'editor temporaneo dei modelli di componente, mostrando un documento .CMPT come documento attivo nella finestra principale di progettazione. Il documento verrà denominato in base all'elemento e alla revisione, nel formato: <Item><Revision>.CMPT (ad es. CMPT-0001-1.CMPT).

 
 
 
 
 

Esempio di modifica della revisione iniziale di un modello di componente, direttamente dal Workspace: l'editor temporaneo dei modelli di componente fornisce il documento con cui definire il modello di componente.
Esempio di modifica della revisione iniziale di un modello di componente, direttamente dal Workspace: l'editor temporaneo dei modelli di componente fornisce il documento con cui definire il modello di componente.

Usa il documento per definire il modello di componente secondo le tue esigenze. Per ulteriori informazioni su questa operazione, consulta Definizione del modello.

Durante la modifica diretta sono disponibili tre controlli pertinenti, accessibili da Quick Access Bar (in alto a sinistra nella finestra principale dell'applicazione) o dalla barra degli strumenti Component Template Standard:

  • – Save Active Document. Usa questo pulsante per salvare localmente le modifiche apportate al documento. Ciò consente di salvare le modifiche correnti, se desideri tornare in un secondo momento per apportare ulteriori modifiche prima del salvataggio definitivo nel Workspace.
  • / – Save to Server. Usa questo pulsante per salvare il modello di componente definito nel Workspace, memorizzandolo nella revisione iniziale (pianificata) dell'elemento modello di componente di destinazione. Verrà visualizzata la finestra di dialogo Edit Revision, in cui puoi modificare nome e descrizione e aggiungere note di rilascio secondo necessità. Il documento e l'editor si chiuderanno dopo il salvataggio. Il documento contenente il modello di componente sorgente, *.CMPT, verrà memorizzato nella revisione dell'elemento.

    Un controllo Save to Server è comodamente disponibile anche a destra della voce del modello di componente, all'interno del pannello Projects stesso.
  • / – Discard Local Changes. Usa questo pulsante se desideri annullare la modifica e scartare tutte le modifiche apportate. Il documento e l'editor si chiuderanno e non verrà rilasciato nulla nell'elemento modello di componente di destinazione.

Questi controlli sono disponibili anche come comandi – Save (scorciatoia: Ctrl+S), Save to Server (scorciatoia: Ctrl+Alt+S) e Discard Local Changes – nel menu principale File e nel menu contestuale della voce del modello di componente nel pannello Projects.

I dati salvati nel Workspace consistono nel modello di componente sorgente, definito nel file del modello di componente (<Item><Revision>.CMPT).

 
 
 
 
 

Esempio di modello di componente definito e salvato nel Workspace.
Esempio di modello di componente definito e salvato nel Workspace.

Ereditarietà di un modello di componente

Questa funzionalità è disponibile quando l'opzione UI.ComponentTemplateInheritance è abilitata nella finestra di dialogo Advanced Settings.

Puoi utilizzare un modello di componente del tipo di componente radice se al sottotipo non è associato alcun modello di componente. Quando si crea una gerarchia di tipi di componente, i sottotipi di componente ereditano il modello di componente assegnato al tipo di componente radice/padre.

L'editor CMPT (modello di componente)

Per accedere all'editor dei modelli di componente in Altium Designer, deve essere installata l'estensione software Component Template Editor. Questa estensione viene installata con Altium Designer per impostazione predefinita. Può essere installata o rimossa manualmente.

Per ulteriori informazioni sulla gestione delle estensioni, consulta la pagina Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Definizione del modello

L'editor dei modelli di componente è essenzialmente suddiviso in due aree principali, illustrate nell'immagine seguente e riepilogate di seguito.

 
 
 
 
 

L'editor dei modelli di componente può essere suddiviso a grandi linee in due aree principali.
L'editor dei modelli di componente può essere suddiviso a grandi linee in due aree principali.

  1. Upper Region – per definire le opzioni a livello di componente (ciclo di vita, denominazione e opzioni delle cartelle) per un componente che fa riferimento al modello.
  2. Lower Region – per definire i parametri da utilizzare per un componente che fa riferimento al modello.

Specifica delle opzioni del componente

La metà superiore dell'editor è dedicata alla definizione dei valori predefiniti per le seguenti proprietà del componente:

  • Lifecycle Definition – scegli la definizione del ciclo di vita da applicare a un componente creato utilizzando il modello. Il campo a discesa elenca tutte le definizioni configurate per il Workspace e consentite per l'utilizzo da parte di un componente.

  • Revision Naming – scegli lo schema di denominazione delle revisioni da applicare a un componente creato utilizzando il modello. Il campo a discesa elenca tutti gli schemi configurati per il Workspace e consentiti per l'utilizzo da parte di un componente.

    Se l'opzione per controllare l'utilizzo delle definizioni del ciclo di vita e degli schemi di denominazione delle revisioni per tipo di contenuto è abilitata per una qualsiasi definizione o schema, e il tipo di contenuto Componente non è impostato per utilizzare una determinata definizione o un determinato schema, tale definizione o schema non sarà disponibile nell'elenco a discesa corrispondente.

  • Component Naming – utilizza questo campo per definire uno schema di denominazione degli elementi predefinito per un componente creato utilizzando il modello, garantendo un ID univoco per il componente risultante nel Workspace. La voce inserita qui verrà utilizzata come modello per assegnare automaticamente un nome al componente (nel relativo campo Id (quando si utilizza l'Editor componenti in modalità Single Component Editing) oppure nel campo Item ID (quando si utilizza l'Editor componenti in modalità Batch Component Editing)). Il software assegnerà automaticamente il successivo ID univoco disponibile, in base a tale schema, dopo aver analizzato l'intero Workspace e gli identificatori dei contenuti esistenti. È disponibile uno schema di denominazione degli elementi predefinito – CMP-{00000} – ma puoi naturalmente creare uno schema personalizzato digitandolo nel campo, assicurandoti che la parte variabile sia racchiusa tra parentesi graffe (ad es. CMP-001-{0000}).

  • Default Folder – per specificare una cartella predefinita nel Workspace di destinazione in cui memorizzare un componente salvato. A tale scopo, fai clic sul pulsante Choose per accedere alla finestra di dialogo Choose Folder (una variante del pannello Explorer), da cui puoi individuare e selezionare una cartella esistente nel Workspace oppure crearne una nuova al momento.

Non è presente alcun campo per impostare il Workspace di destinazione, poiché è preimpostato l'utilizzo dello stesso Workspace in cui risiede la revisione del modello di componente.

L'opzione Allow override di ciascuna proprietà consente di controllare in modo indipendente se l'utente può modificare tale proprietà (abilitata) oppure no (disabilitata) durante la definizione di un componente nell'Editor componenti.

Quando si fa riferimento al modello, le voci specificate in questa sezione vengono utilizzate per precompilare i campi corrispondenti nell'Editor componenti (ove disponibili):

  • Single Component Editing mode – i campi Id e Folder, nell'area Advanced Settings della sezione Component.
  • Batch Component Editing mode – nella scheda Document Options della finestra di dialogo Opzioni documento e, di conseguenza, nei campi Item ID e FolderPath, nell'area Component della sezione delle definizioni dei componenti.

Quando si fa riferimento al modello, le voci vengono utilizzate per precompilare i campi corrispondenti durante la modifica di un componente nell'Editor componenti in modalità Single Component Editing (a sinistra) e Batch Component Editing (a destra).
Quando si fa riferimento al modello, le voci vengono utilizzate per precompilare i campi corrispondenti durante la modifica di un componente nell'Editor componenti in modalità Single Component Editing (a sinistra) e Batch Component Editing (a destra).

Definizione dei parametri

La metà inferiore dell'editor è dedicata alla definizione e alla gestione dei parametri che saranno resi disponibili a un componente che fa riferimento al modello.

 
 
 
 
 

Esempi di parametri definiti in un modello di componente.
Esempi di parametri definiti in un modello di componente.

Parametri di sistema predefiniti

Quando si crea un nuovo modello di componente, vengono inclusi per impostazione predefinita vari parametri di sistema, come illustrato nell'immagine seguente e descritto in dettaglio di seguito.

 
 
 
 
 

Parametri di sistema predefiniti inclusi in un modello di componente appena creato.
Parametri di sistema predefiniti inclusi in un modello di componente appena creato.

  • ComponentType – questo parametro consente di specificare il tipo di componente. Ciò facilita le ricerche mirate tramite la potente funzione di ricerca del Workspace, che consente non solo di cercare per tipo di componente, ma anche di eseguire ricerche più intelligenti grazie al supporto dei parametri dei componenti con riconoscimento delle unità di misura. Quando esplori i componenti del tuo Workspace utilizzando il pannello Componenti, il raggruppamento Categories dei componenti deriva dai parametri ComponentType associati a ciascun componente. Fai clic sul campo Default Value associato, quindi sul pulsante per accedere alla finestra di dialogo Choose component type. Utilizzala per selezionare il tipo di componente desiderato e fai clic su OK: il tipo scelto verrà inserito come valore del parametro ComponentType nella griglia principale dei parametri.

    La finestra di dialogo Choose component type rispecchia l'insieme dei tipi di componente definiti nella pagina Gestione dati – Tipi di componente della finestra di dialogo Preferences. Fai clic sul pulsante nella parte inferiore della finestra di dialogo Choose component type per accedere a questa pagina delle preferenze, da cui puoi personalizzare l'elenco in base alle tue esigenze, aggiungendo nuovi tipi e sottotipi oppure modificando e rimuovendo quelli esistenti.

    Esempio di modello di componente, con il parametro di sistema ComponentType impostato su Diodes.
    Esempio di modello di componente, con il parametro di sistema ComponentType impostato su Diodes.

    Il tipo di dati di questo parametro è impostato su ComponentType e non può essere modificato. Inoltre, il parametro ComponentType non può essere rimosso. Seleziona la cella e utilizza il tasto Delete per cancellare il valore.

  • SCHLIB e PCBLIB – questi due parametri consentono di specificare rispettivamente i modelli predefiniti del simbolo e del footprint. Fai clic sul campo Default Value associato a ciascun parametro, quindi sul pulsante per accedere a una finestra di dialogo in cui scegliere il modello desiderato.

    Nota che stai scegliendo il modello e non una sua revisione specifica. In questo modo, un componente che utilizza il modello di componente userà sempre la revisione più recente del modello scelto.

    Specifica i modelli di simbolo e footprint all'interno del tuo modello di componente.
    Specifica i modelli di simbolo e footprint all'interno del tuo modello di componente.

    I tipi di dati di questi parametri sono impostati rispettivamente su SCHLIB e PCBLIB e non possono essere modificati. Inoltre, i parametri dei modelli non possono essere rimossi. Seleziona la cella e utilizza il tasto Delete per cancellare il valore.

  • Name e Description – questi due parametri consentono di definire rispettivamente il nome e la descrizione del componente. Inserisci le stringhe desiderate nel campo Default Value associato a ciascun parametro.

    Specifica i parametri Name e Description all'interno del tuo modello di componente.
    Specifica i parametri Name e Description all'interno del tuo modello di componente.

    Il tipo di dati per entrambi questi parametri è impostato su Text e non può essere modificato. Inoltre, questi parametri non possono essere rimossi.

È supportata la possibilità di copiare e incollare i parametri di sistema anche tra documenti modello.

Selezionare uno o più parametri in un modello di componente, quindi utilizzare il comando Copy dal menu contestuale della selezione (scorciatoia: Ctrl+C). I parametri copiati possono quindi essere incollati in un altro modello di componente utilizzando il comando Paste dal menu contestuale (scorciatoia: Ctrl+V).

 
 
 
 
 

SCHLIB, Name e Description sono i parametri di sistema selezionati e copiati nel modello di componente Diodes.

Questi parametri sono stati incollati in un altro modello di componente (Zeners) e i relativi valori sono stati applicati ai parametri corrispondenti. 

 

Aggiunta di un nuovo parametro utente

Per aggiungere un nuovo parametro utente all'elenco, fare clic sul pulsante (oppure utilizzare il comando Add dal menu contestuale) – il parametro viene aggiunto in fondo all'elenco corrente.

 
 
 
 
 

Esempio di aggiunta di un nuovo parametro utente al modello.
Esempio di aggiunta di un nuovo parametro utente al modello.

Ogni parametro è presentato nella griglia con le seguenti informazioni:

  • Name – utilizzare questo campo per assegnare un nome al parametro, in genere un nome significativo che ne esprima lo scopo. Al momento dell'aggiunta, ai parametri vengono assegnati nomi predefiniti (Parameter, Parameter 1, Parameter 2 e così via).

  • Type – il tipo di parametro. Inizialmente questa voce è impostata su Text, ma sono supportati diversi tipi di dati con supporto delle unità di misura, oltre al tipo PCBLIB, che agevola la definizione di più footprint, e al tipo HarnessWiring, che agevola la definizione di un componente di cablaggio del cablaggio preassemblato. Sono supportati anche i tipi di parametro definiti dai dizionari disponibili – ulteriori informazioni.

  • Visible – abilitare questa opzione (attiva per impostazione predefinita per un parametro appena aggiunto) affinché la corrispondente opzione Show del parametro sia abilitata quando si modificano uno o più componenti nell'Editor componenti (configurato in modalità Batch Component Editing). Questo, a sua volta, controlla la visualizzazione della colonna corrispondente a quel parametro nell'area inferiore dell'Editor componenti, dove vengono definite le definizioni dei componenti stessi. Questa proprietà non ha alcun effetto quando si definisce un componente utilizzando la modalità Single Component Editing dell'editor.

  • Read Only – abilitare questa opzione per rendere il parametro di sola lettura. Quando si modifica un componente che fa riferimento al modello, il valore del parametro non sarà modificabile.

  • Required – abilitare questa opzione per rendere il parametro un «parametro obbligatorio». Quando si modifica un componente che fa riferimento al modello, è necessario definire un valore per il parametro, altrimenti non sarà possibile salvare il componente. Nell'Editor componenti, quando non è stato inserito alcun valore, un parametro di questo tipo si distingue per la cella del valore con un bordo rosso (in modalità Batch Component Editing) o contenente l'icona (in modalità Single Component Editing).

  • Default Value – utilizzare questo campo per inserire un valore predefinito per il parametro.

    • Se il parametro è contrassegnato come obbligatorio (opzione Required abilitata) ed è stato anche impostato come di sola lettura (opzione Read Only abilitata), MUST inserire un valore predefinito. In caso contrario, quando si modifica un componente che fa riferimento al modello, il parametro verrà segnalato come privo di valore, ma non sarà possibile risolvere il problema perché il parametro non è modificabile in quanto di sola lettura. Non è possibile salvare una nuova revisione di questo modello di componente nel Workspace finché il problema non viene risolto.

    • Quando si modifica una revisione di un componente, un parametro esistente definito dall'utente che ha lo stesso nome di un parametro nel modello di componente collegato verrà sostituito con la versione del modello. Qualsiasi valore esistente per quel parametro verrà mantenuto (e non sovrascritto con il valore predefinito nel modello).

  • Description – aggiungere una descrizione per il parametro, ad esempio una breve nota su ciò che fornisce. Se per un parametro nel modello è definita una descrizione, la colonna Description verrà visualizzata nell'area Parameters dell'Editor componenti nella relativa Single Component Editing.

L'elenco dei parametri supporta anche semplici operazioni di copia e incolla, consentendo di duplicare uno o più parametri utente esistenti. I parametri incollati verranno aggiunti in fondo all'elenco.

Sono supportate le scorciatoie standard per copiare (Ctrl+C) e incollare (Ctrl+V); questi comandi sono disponibili anche nel menu accessibile con il tasto destro del mouse. È possibile selezionare più parametri utente per le operazioni di copia e incolla utilizzando le tecniche standard Ctrl+Click e Shift+Click.
Per eliminare uno o più parametri utente dall'elenco, selezionare ciascun parametro, quindi fare clic sul pulsante oppure utilizzare il comando Remove dal menu contestuale accessibile con il tasto destro del mouse.

Tipi di dati dei parametri dei componenti con riconoscimento delle unità di misura

L'editor dei modelli di componente consente di definire tipi di dati espliciti per i parametri dei componenti definiti all'interno di un modello di componente (*.CMPT). Inoltre, questi tipi di dati riconoscono le unità di misura e supportano diversi prefissi di uso comune. È quindi possibile immettere il valore di un parametro utilizzando vari formati, ad esempio 2.2k, 2k2, 4M, 2.5GHz: il Workspace è dotato delle funzionalità necessarie per riconoscere il valore numerico corrispondente a tali voci.

Questa funzionalità dei modelli di componente facilita le ricerche mirate tramite la funzione di ricerca avanzata del server, che non solo consente di cercare per tipo di componente, ma permette anche di eseguire ricerche più intelligenti, basate su intervalli. Grazie ai parametri dei componenti con riconoscimento delle unità di misura, è possibile definire rapidamente una ricerca, ad esempio per trovare tutti i condensatori con una capacità compresa tra 47uF e 220uF.

I parametri con riconoscimento delle unità di misura vengono utilizzati anche per il filtraggio intelligente durante la ricerca tra i propri componenti tramite il pannello Components.

Utilizzare le seguenti sezioni espandibili per ulteriori informazioni sui parametri con riconoscimento delle unità di misura.

Tipi di dati dei parametri definiti da dizionari

I dizionari sono tipi di parametro personalizzati con diversi valori definiti. I dizionari vengono gestiti dagli amministratori del Workspace nella pagina Settings – Vault – Dictionaries dell'interfaccia browser del Workspace, accessibile dall'editor dei modelli di componente scegliendo l'opzione Add New Dictionary dall'elenco a discesa Type oppure facendo clic sul controllo Manage Dictionaries in alto a destra nell'area Parameters.

  • È possibile accedere alla pagina Settings – Vault – Dictionaries anche dalla pagina Gestione dati – Dizionari della finestra di dialogo Preferences, facendo clic sul controllo Manage Dictionaries, e dalla pagina Gestione dati – Server della finestra di dialogo Preferences, facendo clic sul controllo Properties per il Workspace attivo o uno noto e selezionando la voce Dictionaries dal menu.

  • Quando per un parametro è selezionato un tipo definito da un dizionario, è possibile accedere alla pagina Settings – Vault – Dictionaries anche facendo clic nella cella del parametro nella colonna Type e poi sul pulsante  ().

Accesso alla pagina per la gestione dei dizionari nell'interfaccia browser del Workspace dall'editor dei modelli di componente.
Accesso alla pagina per la gestione dei dizionari nell'interfaccia browser del Workspace dall'editor dei modelli di componente.

Ulteriori informazioni sulla gestione dei dizionari dall'interfaccia browser del Workspace (Altium 365 Workspace, Enterprise Server Workspace).

I dizionari definiti sono disponibili come tipi di parametro nell'elenco a discesa Type.

Selezionare un tipo di parametro definito da un dizionario nell'elenco a discesa Tipo.
Selezionare un tipo di parametro definito da un dizionario nell'elenco a discesa Tipo.

I valori definiti per il tipo selezionato definito nel dizionario sono disponibili nel menu a discesa Default Value. Seleziona il valore desiderato da utilizzare come valore predefinito del parametro oppure seleziona <None>.

Seleziona un valore predefinito tra quelli definiti per il tipo selezionato definito nel dizionario.
Seleziona un valore predefinito tra quelli definiti per il tipo selezionato definito nel dizionario.

  • I valori predefiniti vengono convalidati al momento del salvataggio del modello di componente nel Workspace. Se il valore predefinito diventa incoerente con il dizionario (ad esempio, il valore è stato rimosso dal dizionario e successivamente il modello che lo utilizza è stato aperto per la modifica), tale valore viene evidenziato in rosso nella colonna Default Value e, quando si tenta di salvare nuovamente il modello nel Workspace, viene visualizzato un messaggio di errore nel pannello Messages.

  • Se il valore di un parametro del componente diventa incoerente con il dizionario (ad esempio, il tipo di quel parametro è stato modificato da Text a un tipo definito nel dizionario nel modello di componente e il valore attuale del componente non corrisponde ad alcun valore del tipo selezionato definito nel dizionario), il parametro viene evidenziato durante la modifica del componente nel Component Editor: nella modalità Single Component Editing dell'editor, accanto al valore incoerente del parametro viene visualizzata un'icona con un punto esclamativo, mentre nella modalità Batch Component Editing il valore del parametro viene evidenziato in rosso. Assicurati che tutti i parametri del componente siano coerenti con i valori del modello; in caso contrario, non potrai salvare il componente nella revisione successiva.

  • Se i dizionari sono stati modificati nell'interfaccia browser del Workspace connesso, devi disconnetterti dal Workspace e riconnetterti affinché queste modifiche vengano recepite in Altium Designer. Per ulteriori informazioni, consulta la pagina Accesso al Workspace.

Definizione di più footprint

Il Component Template Editor supporta anche la definizione di più footprint PCB all'interno di un modello di componente. È possibile specificare un numero qualsiasi di collegamenti a modelli di footprint: una funzionalità particolarmente utile per chi desidera creare componenti che fanno riferimento a 3 footprint, soddisfacendo i requisiti IPC per diversi livelli di densità: L (minimo, ovvero con la minima quantità di rame), M (massimo, ovvero con la massima quantità di rame) e N (nominale, ovvero con una quantità intermedia di rame).

Per aggiungere al modello un'ulteriore definizione di modello di footprint, fai clic su per aggiungere un nuovo parametro, quindi scegli la voce PCBLIB dal menu a discesa associato al campo Type.

Trasforma un parametro appena aggiunto in una definizione di modello di footprint impostando il relativo Type su PCBLIB.
Trasforma un parametro appena aggiunto in una definizione di modello di footprint impostando il relativo Type su PCBLIB.

Il nome del parametro cambierà da Parameter a PCBLIB n, dove n è il successivo numero intero disponibile per distinguere i diversi modelli di footprint (ad esempio PCBLIB 1, PCBLIB 2 e così via). Il modello predefinito sarà quello associato alla voce PCBLIB. Quando i footprint vengono importati nel Component Editor durante la definizione di un componente, il modello di footprint predefinito è contrassegnato dall'icona nell'angolo superiore sinistro della finestra di anteprima del modello (in modalità Single Component Editing) e dalla voce PCBLIB (default) nell'area Required Models/Parameters (in modalità Batch Component Editing).

Esempio di componente definito nel Component Editor (modalità Single Component Editing) utilizzando un modello di componente di riferimento. Nel modello sono definiti tre modelli di footprint, che vengono inclusi nella definizione del componente. Nota che la voce PCBLIB del modello viene utilizzata come modello di footprint predefinito (contrassegnato da un'icona nell'angolo superiore sinistro) durante la definizione del componente. Passa il puntatore sull'immagine per vedere lo stesso componente definito con il Component Editor in modalità Batch Component Editing. In questo caso, il footprint predefinito è denominato PCBLIB (default).
Esempio di componente definito nel Component Editor (modalità Single Component Editing) utilizzando un modello di componente di riferimento. Nel modello sono definiti tre modelli di footprint, che vengono inclusi nella definizione del componente. Nota che la voce PCBLIB del modello viene utilizzata come modello di footprint predefinito (contrassegnato da un'icona nell'angolo superiore sinistro) durante la definizione del componente. Passa il puntatore sull'immagine per vedere lo stesso componente definito con il Component Editor in modalità Batch Component Editing. In questo caso, il footprint predefinito è denominato PCBLIB (default).

Importazione ed esportazione dei modelli di componente

Un file di modello di componente esistente (*.CMPT) o un file di libreria di componenti (*.CMPLIB) può essere importato nell'editor dei modelli di componente, mentre il modello di componente in fase di modifica può essere esportato in un file di modello di componente (*.CMPT). Utilizza i comandi File » Import » Component Template, File » Import » Component Library e File » Export del menu principale dell'editor dei componenti per selezionare l'azione desiderata, quindi usa la finestra di dialogo standard di Windows che si apre per raggiungere la posizione desiderata e selezionare un file da importare oppure definire il nome del file da esportare.

Riutilizzo di un modello di componente

È possibile utilizzare una revisione di un modello di componente, o più precisamente farvi riferimento dalla revisione del componente attualmente in fase di modifica, nei modi seguenti.

Un componente può fare riferimento a un solo modello di componente alla volta.

Durante la creazione di un nuovo componente

Quando crei un nuovo componente utilizzando il comando File » New » Component dai menu principali, puoi scegliere il modello nella finestra di dialogo Create new component.

Collegamento rapido di un modello di componente da un elenco di tutti i modelli disponibili durante la creazione di un nuovo componente.
Collegamento rapido di un modello di componente da un elenco di tutti i modelli disponibili durante la creazione di un nuovo componente.

Manualmente dal Component Editor

Il riutilizzo di una revisione di un modello di componente dal Component Editor dipende dalla modalità operativa dell'editor.

In modalità Single Component Editing

Quando modifichi un singolo componente in questa modalità del Component Editor, scegli il modello di componente desiderato dal menu a discesa associato al campo Template, che fa parte del gruppo Advanced Settings nell'area Component dell'editor. Vengono elencati per nome tutti i modelli di componente attualmente disponibili nello stesso Workspace in cui risiede il componente, con le rispettive revisioni più recenti indicate tra parentesi. Scegli il modello desiderato per applicarlo.

Collegamento rapido di un modello di componente da un menu di tutti i modelli disponibili durante la modifica della revisione di un componente con il Component Editor in modalità Single Component Editing.
Collegamento rapido di un modello di componente da un menu di tutti i modelli disponibili durante la modifica della revisione di un componente con il Component Editor in modalità Single Component Editing.

In modalità Batch Component Editing

Esistono due modi per collegare una revisione di un modello di componente alla revisione del componente attualmente in fase di modifica:

  • Dalla scheda Template della finestra di dialogo Opzioni documento (Edit » Document Options). Fai clic sul pulsante Choose a destra del campo Item Revision. Si apre così la finestra di dialogo Choose Item (una variante del pannello Explorer). Utilizza questa finestra di dialogo per individuare e selezionare la revisione del modello di componente desiderato. Dopo aver fatto clic su OK, verrà creato un collegamento tra la revisione del componente e la revisione di destinazione del modello di componente. Il collegamento sarà visibile nella scheda Template della finestra di dialogo Document Options.

    Collegamento manuale di un componente a una revisione di un modello di componente nel Workspace di destinazione.
    Collegamento manuale di un componente a una revisione di un modello di componente nel Workspace di destinazione.

    Il modello di componente utilizzato può essere cambiato in qualsiasi momento: fai clic su Choose e seleziona una revisione di un altro modello di componente.
    Lo stato della revisione dell'elemento del modello di componente collegato è riportato nella scheda Template della finestra di dialogo Document Options. Se è disponibile una revisione più recente dell'elemento collegato, fai clic sul pulsante per utilizzarla.
  • Dal menu Add associato all'area Required Models/Parameters dell'Editor dei componenti. Il sottomenu Templates elenca per nome tutti i modelli di componente attualmente disponibili nello stesso Workspace in cui risiede il componente, con le relative revisioni più recenti indicate tra parentesi. Fai clic su una voce per creare un collegamento alla revisione più recente di quel modello di componente. Anche in questo caso, puoi verificare il collegamento nella scheda Templates della finestra di dialogo Document Options.

    Collegamento rapido di un modello di componente da un menu contenente tutti i modelli disponibili.
    Collegamento rapido di un modello di componente da un menu contenente tutti i modelli disponibili.

Ereditato dalla cartella Components del Workspace

Puoi specificare un modello di componente da utilizzare automaticamente per tutti i componenti (e le relative revisioni) memorizzati in una cartella Components del Workspace.

Un modello di componente predefinito può essere definito solo per una cartella di tipo Components.

Specifica il modello desiderato utilizzando il campo Component Template durante la definizione delle proprietà della cartella, nella finestra di dialogo Edit Folder. L'elenco a discesa associato al campo elenca per nome tutti i modelli di componente attualmente disponibili nello stesso Workspace in cui risiede la cartella Components, con le relative revisioni più recenti indicate tra parentesi. Scegli una voce per creare un collegamento alla revisione più recente di quel modello di componente per ogni componente creato successivamente nella cartella.

Specifica un modello di componente predefinito da applicare a tutti i componenti creati nella cartella Components principale.
Specifica un modello di componente predefinito da applicare a tutti i componenti creati nella cartella Components principale.

Per non utilizzare questa funzionalità, lascia o imposta il campo Component Template su None.

Se viene scelto un modello di componente a livello di cartella, lo stesso modello verrà utilizzato per impostazione predefinita quando vengono creati componenti nelle sottocartelle. Questo consente a tutti i componenti nelle sottocartelle di ereditare rapidamente il modello.

Quando una revisione di un componente viene salvata nel Workspace, la revisione specifica del modello di componente utilizzato viene di fatto fissata, creando un collegamento stabile a tale revisione, a meno che non venga modificato manualmente.

Effetti sui modelli e sui parametri dei componenti quando si utilizza un modello di componente

Quando modifichi una revisione di un componente e colleghi o fai riferimento a una revisione di un modello di componente, nell'Editor dei componenti si verifica quanto segue per quanto riguarda modelli e parametri:

  • I modelli definiti nel modello di componente di riferimento vengono aggiunti all'area Models (modalità Single Component Editing) e all'area Model Links (modalità Batch Component Editing).
  • Un modello di riferimento esistente verrà mantenuto e il componente continuerà a utilizzarlo, a meno che non venga modificato intenzionalmente e manualmente.
  • I parametri definiti nel modello di componente di riferimento vengono aggiunti all'area Parameters (modalità Single Component Editing) e all'area Required Models/Parameters (modalità Batch Component Editing).

    Esempio di parametri dopo il collegamento a una revisione di un modello di componente, utilizzando l'Editor dei componenti in modalità Single Component Editing (a sinistra) e in modalità Batch Component Editing (a destra).
    Esempio di parametri dopo il collegamento a una revisione di un modello di componente, utilizzando l'Editor dei componenti in modalità Single Component Editing (a sinistra) e in modalità Batch Component Editing (a destra).

    Tutti i parametri provenienti dal modello di componente di riferimento sono contraddistinti dall'icona (modalità Single Component Editing) e dall'icona (modalità Batch Component Editing). Inoltre, solo nella modalità di modifica dei componenti in batch, l'opzione Show di ciascun parametro basato sul modello rispecchia lo stato della corrispondente opzione Visible nel modello.
    I parametri basati sul modello non possono essere rimossi.
    Puoi aggiungere ulteriori parametri utente secondo necessità.
  • Solo in modalità Batch Component Editing, i parametri basati sul modello impostati come visibili vengono raggruppati nell'area delle definizioni dei componenti dell'editor, utilizzando Template Parameters come testo dell'intestazione.

    Aspetto di alcuni parametri di esempio basati sul modello nell'area in cui vengono definite le definizioni dei componenti, utilizzando l'Editor dei componenti in modalità Batch Component Editing.
    Aspetto di alcuni parametri di esempio basati sul modello nell'area in cui vengono definite le definizioni dei componenti, utilizzando l'Editor dei componenti in modalità Batch Component Editing.

  • I campi dei valori dei parametri basati sul modello contrassegnati come di sola lettura non saranno modificabili. Per tutti gli altri parametri basati sul modello, non contrassegnati come di sola lettura, puoi modificare i valori secondo necessità.

    Con l'Editor dei componenti in modalità Single Component Editing, un parametro del modello di sola lettura è contraddistinto nell'area Parameters dall'icona .
  • Se un parametro basato sul modello è stato contrassegnato come obbligatorio ma non gli è stato assegnato un valore nel modello, il relativo campo del valore apparirà con un bordo rosso (in modalità Batch Component Editing) oppure con l'icona al suo interno (in modalità Single Component Editing), segnalando che è necessario un valore per questo parametro. Non potrai salvare un componente nel Workspace finché non saranno stati definiti i valori di tutti i parametri obbligatori.

    Con l'Editor dei componenti in modalità Single Component Editing, un parametro obbligatorio del modello è contraddistinto nell'area Parameters dall'icona .

Nuovo salvataggio di un modello di componente

In qualsiasi momento puoi tornare a una qualsiasi revisione di un modello di componente nel Workspace e modificarla direttamente. Fai clic con il pulsante destro del mouse sulla revisione e scegli il comando Edit dal menu contestuale. Si aprirà nuovamente l'editor temporaneo, con il modello contenuto nella revisione aperto per la modifica. Apporta le modifiche necessarie, quindi salva il modello di componente nella revisione successiva dell'elemento.

Facendo clic con il pulsante destro del mouse sulla voce di primo livello del modello di componente, verrà modificata la revisione più recente di quel modello.

Accesso al comando per avviare la modifica diretta di una revisione esistente di un modello di componente.
Accesso al comando per avviare la modifica diretta di una revisione esistente di un modello di componente.

Download dei dati salvati

Scarica i dati memorizzati in una revisione di un modello di componente facendo clic con il pulsante destro del mouse sulla revisione (nel pannello Explorer) e scegliendo il comando Operations » Download dal menu contestuale. Il file del modello di componente verrà scaricato in una sottocartella della directory scelta, denominata utilizzando l'ID della revisione dell'elemento. Il file si trova nella cartella Released al suo interno.

Accedi al comando Download dalla voce di primo livello del modello di componente per scaricare il file del modello di componente memorizzato nella revisione più recente di quel modello.
Fai clic sul pulsante Explore nella finestra di dialogo Download from Server per aprire rapidamente la cartella di download.

Eliminazione reversibile

Quando sei connesso a un Workspace, è disponibile una funzionalità flessibile per rimuovere un modello di componente direttamente da Altium Designer, dal pannello Explorer. Fai clic con il pulsante destro del mouse sulla voce del modello di componente nel pannello e scegli il comando Delete Item dal menu contestuale. Verrà visualizzata la finestra di dialogo Delete Items, in cui confermare l'eliminazione. L'azione è in realtà un'eliminazione reversibile, con la quale il modello di componente viene spostato nell'area Trash del Workspace. L'area Trash è essenzialmente un cestino in cui è possibile spostare qualsiasi contenuto del Workspace tramite un'azione di eliminazione reversibile. È isolata dal resto del Workspace.

Con la funzionalità di eliminazione reversibile, puoi eliminare un modello di componente attualmente in uso.
È possibile eliminare più modelli di componente con un'unica azione. Seleziona tutti i modelli di componente desiderati utilizzando i comandi standard di selezione multipla (Shift+Click, Ctrl+Click), quindi fai clic con il pulsante destro del mouse e scegli il comando Delete Items dal menu contestuale.

Eliminazione reversibile di un modello di componente. Il modello verrà spostato nell'area Trash del Workspace.
Eliminazione reversibile di un modello di componente. Il modello verrà spostato nell'area Trash del Workspace.

Per procedere con l'eliminazione, fai clic sul pulsante . L'elemento verrà rimosso e una finestra di dialogo Deletion Summary confermerà l'avvenuta eliminazione. Eventuali problemi durante l'eliminazione ti verranno segnalati.

Tutti i contenuti eliminati in questo modo sono disponibili nella pagina Trash dell'interfaccia browser del Workspace. Tieni presente che puoi visualizzare solo i contenuti che hai eliminato personalmente in modo non definitivo. Gli amministratori potranno visualizzare tutti i contenuti della pagina Trash, ovvero tutti quelli che sono stati eliminati in modo non definitivo.

Aspetti da considerare per un modello di componente eliminato in modo non definitivo:

  • Il modello di componente non sarà disponibile nel software di progettazione né nell'interfaccia Web.
  • Ovunque fosse utilizzato il modello di componente, verrà indicato che è stato eliminato.
  • Un modello di componente può essere ripristinato o eliminato definitivamente dalla pagina Trash, purché tu disponga dei diritti di modifica. L'eliminazione definitiva è possibile solo se il modello non è utilizzato da un elemento padre.
Tieni presente che, se hai eliminato un modello di componente in modo non definitivo, spostandolo in Trash, puoi creare un nuovo modello di componente con lo stesso nome. Se in seguito ripristini il modello di componente originale e il suo nome è già in uso, verrà aggiunto un suffisso numerico intero per mantenerne univoco il nome all'interno del Workspace.
AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents