Lavorare con i Reuse Blocks e gli Snippet (vecchio pannello Design Reuse)

A colpo d'occhio

Questo articolo spiega come Altium Designer ti aiuta a salvare e riutilizzare sezioni di circuito comuni tramite blocchi di riutilizzo e snippet, evitando di dover ricreare da zero gli elementi di progetto ricorrenti. Illustra cosa comprende ciascuna opzione di riutilizzo, come accedere al pannello Design Reuse e utilizzarlo, e come creare, gestire, rinominare e organizzare i contenuti di progettazione sia nel Workspace sia in locale. Se lavori regolarmente con sezioni ricorrenti di schemi elettrici o PCB, questa guida ti mostra come integrare questi strumenti nel tuo flusso di lavoro e iniziare a usarli in modo efficace. Continua a leggere per rendere il tuo processo di progettazione più rapido e coerente.

- Scopri la differenza tra blocchi di riutilizzo, snippet di schemi elettrici e snippet PCB, e quando utilizzare ciascuno di essi.
- Scopri come utilizzare il pannello Design Reuse per trovare, filtrare, ordinare, cercare e gestire contenuti di progettazione riutilizzabili.
- Segui i passaggi per creare, salvare, rinominare e organizzare blocchi di riutilizzo e snippet sia nel Workspace sia in locale.
Approfondisci con l'IA:

L'interfaccia utente per la funzionalità di riutilizzo dei progetti descritta in questa pagina è la versione precedente del pannello Design Reuse, disponibile quando l'opzione UI.ModernDesignReusePanel è disabilitata nella finestra di dialogo Impostazioni avanzate. Quando questa opzione è abilitata, viene utilizzata una nuova versione del pannello, descritta nelle pagine Lavorare con i blocchi di riutilizzo e Lavorare con gli snippet. Il nuovo pannello Design Reuse è in Open Beta.

Se i tuoi progetti includono spesso 'sezioni' di circuiti comuni, Altium Designer offre un modo semplice e pratico per salvare e riutilizzare sezioni di circuiti del progetto, sia basate su Workspace sia basate su file locali. Queste sezioni possono essere aggiunte a qualsiasi progetto PCB senza dover ricominciare ogni volta da zero. È una funzionalità molto utile per quei frammenti e quelle piccole sezioni di circuiti usati di frequente che desideri riutilizzare. Il sistema consente di salvare qualsiasi selezione di:

  • Circuiti su un singolo foglio schematico (uno snippet di schema).

  • Circuiti in un progetto PCB, inclusi i componenti e le piste (uno snippet PCB).

Quando sei connesso a un Workspace, puoi creare un'unica entità, un blocco di riutilizzo, che può contenere sia i circuiti dello schema sia la loro rappresentazione fisica per il PCB. Quando un blocco di riutilizzo di questo tipo viene posizionato su un foglio schematico, la sua rappresentazione fisica viene posizionata automaticamente nel documento PCB durante il processo ECO.

Il pannello Design Reuse è il centro di controllo per la creazione, la gestione e l'utilizzo di blocchi di riutilizzo e snippet, sia basati su Workspace sia basati su file locali.

Il pannello Design Reuse
Il pannello Design Reuse

È possibile accedere al pannello nei seguenti modi:

  • Fai clic sul pulsante Panels in basso a destra nell'area di progettazione, quindi fai clic su Design Reuse.
  • Seleziona View » Panels » Design Reuse dai menu principali.
  • Seleziona Place » Reuse Block dai menu principali.

Il menu a discesa nella parte superiore del pannello elenca tutte le cartelle disponibili nel Workspace a cui sei connesso che contengono blocchi di riutilizzo e snippet basati su Workspace. Il numero accanto al nome di ciascuna cartella indica quanti blocchi di riutilizzo e snippet sono contenuti nella cartella e nelle relative sottocartelle. Seleziona una cartella nel menu a discesa per visualizzare nella sezione principale del pannello i blocchi di riutilizzo e gli snippet contenuti nella cartella e nelle relative sottocartelle. Seleziona la voce del Workspace a cui sei connesso nel menu a discesa per visualizzare tutti i blocchi di riutilizzo e gli snippet disponibili.

La struttura delle cartelle del Workspace può essere definita all'interno di Altium Designer utilizzando il pannello Explorer.

Utilizza i pulsanti di filtro nel menu a comparsa dell'icona  per mostrare o nascondere nel pannello i contenuti di tipi specifici (Reuse Blocks, Schematic Snippets, PCB Snippets). Utilizza il controllo Sort By per selezionare l'opzione di ordinamento preferita.

Utilizza le opzioni di filtro e ordinamento per configurare la visualizzazione dei contenuti nel pannello
Utilizza le opzioni di filtro e ordinamento per configurare la visualizzazione dei contenuti nel pannello

Per cercare i blocchi di riutilizzo e gli snippet disponibili nella cartella selezionata in base al nome o alla descrizione, inserisci una frase nel campo Search per filtrare l'elenco e limitarlo in base alle tue esigenze specifiche.

Ogni blocco di riutilizzo e snippet viene visualizzato nella sezione principale del pannello mediante un riquadro contenente i seguenti dati:

  • Immagine di anteprima – fai clic sull'immagine per passare dalla visualizzazione normale a quella a grandezza naturale e viceversa. Per un blocco di riutilizzo, utilizza il pulsante  Fai clic e trascina per spostare​ per passare dall'anteprima del documento PCB a quella del documento schematico e viceversa;

  • Icona del tipo –  Fai clic e trascina per spostare​ per un blocco di riutilizzo,  Fai clic e trascina per spostare​ per uno snippet di schema,  Fai clic e trascina per spostare​ per uno snippet PCB;

  • Nome e descrizione (se definita);

  • ID dell'ultima revisione, data di creazione e autore di un blocco di riutilizzo o di uno snippet di schema/PCB del Workspace.

Le informazioni e i controlli relativi a un blocco di riutilizzo o a uno snippet sono visualizzati in un riquadro all'interno del pannello.
Le informazioni e i controlli relativi a un blocco di riutilizzo o a uno snippet sono visualizzati in un riquadro all'interno del pannello.

Creazione di un blocco di riutilizzo

È possibile creare un nuovo blocco di riutilizzo nei seguenti modi:

  1. Seleziona il comando per creare un nuovo blocco di riutilizzo:

    • Dal pannello Design Reuse, facendo clic sul pulsante  nella parte superiore del pannello.

    • Utilizzando il comando File » New » Reuse Block dal menu principale.

    • Dal pannello Explorer, facendo clic sul pulsante  in alto a destra nel pannello quando si esplora una cartella di tipo Design Reuse Blocks.

  2. Nel pannello Projects verrà aperta una struttura temporanea e modificabile del blocco di riutilizzo, simile a un progetto PCB (sotto una voce relativa al Workspace a cui sei attualmente connesso), e nella finestra principale di progettazione verrà aperto l'editor schematico temporaneo, pronto per definire il documento schematico del blocco di riutilizzo. Utilizza i comandi e le tecniche di posizionamento standard per definire il documento schematico del blocco di riutilizzo.

  3. Al termine, utilizza il comando Design » Update PCB Document e il processo ECO per trasferire lo schema acquisito al documento PCB del blocco di riutilizzo, quindi applica le modifiche necessarie a tale documento (definizione delle posizioni dei componenti, sbroglio, ecc.).

    È possibile aggiungere più documenti PCB al blocco di riutilizzo in fase di definizione. A tale scopo, utilizza il comando Add New to Project » PCB dal menu contestuale della voce del blocco di riutilizzo nel pannello Projects.

    Utilizza il comando Rename dal menu contestuale della voce del documento PCB aggiunto nel pannello Projects per assegnargli un nome significativo. Utilizza un comando Design » Update dal menu principale dell'editor schematico per aggiornare il documento PCB desiderato.

    Una volta definiti entrambi i documenti schematico e PCB del blocco di riutilizzo, salva il blocco di riutilizzo nel Workspace utilizzando il comando Save to Server dal menu contestuale della voce del blocco di riutilizzo nel pannello Projects oppure il controllo Save to Server a destra della voce.

    Poiché i blocchi di riutilizzo sono memorizzati nel Workspace connesso, dovrebbero utilizzare componenti di tale Workspace. In questo modo puoi sfruttare appieno i vantaggi del sistema di gestione dei contenuti offerto dal Workspace.

    • Sia il documento schematico sia il documento PCB del blocco di riutilizzo devono contenere almeno un componente per poter essere salvati nel Workspace.

    • Se i documenti schematico e PCB del blocco di riutilizzo non sono sincronizzati (vengono rilevate differenze tra i documenti schematico e PCB), quando si tenta di salvare il blocco di riutilizzo nel Workspace viene visualizzata una finestra di avviso. È possibile annullare il salvataggio per tornare al blocco di riutilizzo e risolvere le differenze oppure procedere con il salvataggio.

  4. Viene visualizzata la finestra di dialogo New Reuse Block, in cui è possibile definire Name, Description e la Folder del Workspace in cui verrà salvato il nuovo blocco di riutilizzo.

    La finestra di dialogo New Reuse Block
    La finestra di dialogo New Reuse Block

  5. Dopo aver fatto clic su OK, il blocco di riutilizzo verrà salvato nel Workspace e la sua struttura temporanea verrà chiusa.

Il blocco di riutilizzo salvato sarà quindi disponibile nel pannello Design Reuse selezionando, nel menu a discesa in alto, la cartella in cui è stato salvato (o la voce relativa al Workspace connesso). Potrebbe essere necessario utilizzare il comando Refresh dal menu del pulsante  affinché il nuovo blocco di riutilizzo venga visualizzato nel pannello.

Rinominare un blocco di riutilizzo

Dopo aver creato un blocco di riutilizzo, è possibile rinominarlo assegnandogli un titolo più adatto. Per rinominare un blocco di riutilizzo, utilizzare il comando Rename , accessibile dal sottomenu  e dal menu contestuale del pannello Design Reuse , visualizzato facendo clic con il pulsante destro del mouse. Nella finestra di dialogo Rename Reuse Block che si apre, inserire il nuovo titolo, quindi fare clic su OK. Il blocco di riutilizzo avrà ora il nome desiderato, come mostrato nelle immagini seguenti.

Creare uno snippet

È possibile creare rapidamente un nuovo snippet schematico o PCB a partire da un circuito esistente su un foglio schematico o in un documento PCB:

  1. Selezionare il circuito desiderato nell'editor schematico o PCB.

  2. Fare clic con il pulsante destro del mouse e scegliere Snippets » Create Snippet from selected objects dal menu contestuale oppure selezionare il comando Tools » Convert » Create Snippet from selected objects dai menu principali.

  3. Viene visualizzata la finestra di dialogo New Schematic Snippet o New PCB Snippet, in cui è possibile definire il nome, la descrizione, la destinazione di salvataggio (un Workspace o una cartella locale) e la cartella in cui verrà salvato il nuovo snippet.

    Quando si salva uno snippet in una cartella locale, fare clic sul pulsante  a destra del campo Path nella finestra di dialogo per accedere alla finestra di dialogo Choose Snippet Folder, che consente di selezionare una cartella locale di snippet esistente in cui salvare lo snippet oppure di creare una nuova sottocartella all'interno di una cartella locale di snippet esistente.

    Per informazioni sull'organizzazione degli snippet locali in cartelle, vedere la sezione Organizzazione degli snippet locali di seguito.
  4. Dopo aver fatto clic su OK, lo snippet verrà salvato.

Lo snippet salvato sarà quindi disponibile nel pannello Design Reuse selezionando, nel menu a discesa in alto, la voce relativa al Workspace connesso (o la cartella in cui è stato salvato).

È possibile creare uno snippet a partire da un insieme di oggetti selezionati. Qui viene mostrata la creazione di uno snippet schematico. Passare il cursore sull'immagine per vedere la creazione di uno snippet PCB.
È possibile creare uno snippet a partire da un insieme di oggetti selezionati. Qui viene mostrata la creazione di uno snippet schematico. Passare il cursore sull'immagine per vedere la creazione di uno snippet PCB.

Potrebbe essere necessario utilizzare il comando Refresh dal menu del pulsante  del pannello affinché il nuovo blocco di riutilizzo venga visualizzato nel pannello.

Per accedere agli snippet locali dal pannello Design Reuse, è necessario abilitare l'opzione Local Snippets nel menu .

È inoltre possibile creare uno snippet nel Workspace a partire da uno snippet locale esistente facendo clic sul pulsante  all'interno del riquadro dello snippet (oppure facendo clic con il pulsante destro del mouse in un punto qualsiasi del riquadro) e selezionando il comando Save to Server dal menu. Nella finestra di dialogo New Schematic Snippet o New PCB Snippet visualizzata, definire Name, Description e la Folder del Workspace in cui verrà salvato lo snippet.

È possibile salvare uno snippet locale nel Workspace connesso utilizzando il comando Save to Server.
È possibile salvare uno snippet locale nel Workspace connesso utilizzando il comando Save to Server.

Gli snippet del Workspace dovrebbero utilizzare componenti provenienti dallo stesso Workspace. In questo modo, è possibile sfruttare appieno il sistema di gestione dei contenuti offerto dal Workspace.

Organizzazione degli snippet locali

Il pannello Design Reuse consente di organizzare gli snippet locali in cartelle, in modo da raggruppare gli snippet correlati e facilitarne la ricerca. Le cartelle degli snippet sono cartelle Windows esistenti che non possono essere create dal pannello Design Reuse. Vengono invece "aperte" o "chiuse" durante l'esplorazione degli snippet locali che contengono. Queste cartelle possono essere create solo direttamente sul disco rigido o in rete, al di fuori di Altium Designer.

Le cartelle degli snippet possono essere aperte e chiuse dalla finestra di dialogo Available Snippets Folders, accessibile facendo clic sul pulsante  in alto a destra nel pannello Design Reuse e selezionando il comando Snippet Folders dal menu. Fare clic su Open Folder per individuare la cartella desiderata sul disco rigido o in rete. La cartella selezionata verrà aggiunta all'elenco nella finestra di dialogo e successivamente comparirà nel menu a discesa nella parte superiore del pannello Design Reuse.

Per rimuovere una cartella degli snippet dall'elenco (in pratica, chiudendola ai fini dell'esplorazione), selezionare la cartella nell'elenco, quindi fare clic su Remove Folder. Utilizzare i pulsanti Move Up e Move Down per modificare l'ordine in cui gli snippet locali verranno presentati nel pannello Design Reuse quando nel menu a discesa del pannello è selezionata la voce Local.

Posizionare blocchi di riutilizzo e snippet

Per posizionare un blocco di riutilizzo o uno snippet in un progetto, fare clic all'interno del relativo riquadro e poi sul pulsante , fare clic sul pulsante all'interno del riquadro oppure fare clic con il pulsante destro del mouse in un punto qualsiasi del riquadro e selezionare uno dei seguenti comandi:

  • Place – selezionare per posizionare il blocco di riutilizzo o lo snippet direttamente nel documento schematico o PCB attivo.
  • Place as Sheet Symbol – quando è attivo un documento schematico, selezionare per posizionare il blocco di riutilizzo o lo snippet schematico come simbolo di foglio sul foglio schematico. Il contenuto del blocco di riutilizzo o dello snippet schematico verrà inserito in un foglio schematico figlio creato automaticamente, a cui farà riferimento il simbolo di foglio posizionato.

Posiziona un blocco di riutilizzo o uno snippet utilizzando il menu del pulsante Place nel relativo riquadro del pannello. Qui viene mostrata la selezione del comando Place, che consente di posizionare il blocco di riutilizzo / snippet di schema sul foglio schematico attivo. Passa il cursore sull'immagine per visualizzare la selezione del comando Place as Sheet Symbol, che consente di posizionare il blocco di riutilizzo / snippet di schema sul foglio figlio a cui fa riferimento il simbolo di foglio posizionato.
Posiziona un blocco di riutilizzo o uno snippet utilizzando il menu del pulsante Place nel relativo riquadro del pannello. Qui viene mostrata la selezione del comando Place, che consente di posizionare il blocco di riutilizzo / snippet di schema sul foglio schematico attivo. Passa il cursore sull'immagine per visualizzare la selezione del comando Place as Sheet Symbol, che consente di posizionare il blocco di riutilizzo / snippet di schema sul foglio figlio a cui fa riferimento il simbolo di foglio posizionato.

Fai clic sul controllo Show more nel riquadro del blocco di riutilizzo per visualizzare la sezione PCB contenente l'elenco dei documenti PCB del blocco di riutilizzo. Seleziona il documento PCB desiderato nell'elenco: il blocco di riutilizzo verrà posizionato con questo documento. Il documento PCB selezionato viene mostrato nell'area di anteprima del riquadro del blocco di riutilizzo quando per l'anteprima è selezionato PCB.

Seleziona un documento PCB da posizionare con il blocco di riutilizzo per visualizzarne l'anteprima.
Seleziona un documento PCB da posizionare con il blocco di riutilizzo per visualizzarne l'anteprima.

Dopo aver posizionato il documento schematico di un blocco di riutilizzo, è possibile posizionare il relativo documento PCB nel documento PCB tramite il processo ECO. Dall'editor degli schemi, utilizza il comando Design » Update PCB Document dei menu principali, quindi convalida ed esegui le modifiche tramite la finestra di dialogo Engineering Change Order. Il documento PCB verrà posizionato nel documento PCB come unione e potrà essere gestito dalla modalità Unions del pannello PCB.

Quando un componente schematico o PCB selezionato fa parte di un blocco di riutilizzo posizionato nel progetto, puoi esaminarne le proprietà facendo clic sul collegamento Reuse Block disponibile nel pannello Properties . Nel pannello verranno visualizzate le proprietà del blocco di riutilizzo a cui appartiene il componente. Per tornare alle proprietà del componente inizialmente selezionato, utilizza il collegamento Component.

Accedi alle proprietà del blocco di riutilizzo da un componente che ne fa parte. Le immagini qui sopra mostrano l'accesso alle proprietà da un componente schematico. Passa il cursore sull'immagine per vedere l'accesso da un componente PCB.
Accedi alle proprietà del blocco di riutilizzo da un componente che ne fa parte. Le immagini qui sopra mostrano l'accesso alle proprietà da un componente schematico. Passa il cursore sull'immagine per vedere l'accesso da un componente PCB.

Per un blocco di riutilizzo, quando si utilizza il comando di posizionamento verrà utilizzato il relativo documento schematico o PCB, a seconda del tipo di documento attivo al momento dell'esecuzione del comando.

Per uno snippet, prima di posizionarlo assicurati che il documento di destinazione corretto sia aperto e attivo. Il comando di posizionamento sarà disponibile solo se lo snippet può essere posizionato correttamente su tale documento, ovvero se il tipo di snippet e il tipo di documento coincidono.

Modifica di blocchi di riutilizzo e snippet

Per modificare un blocco di riutilizzo o uno snippet basato su Workspace, fai clic sul pulsante nel relativo riquadro (oppure fai clic con il pulsante destro del mouse in un punto qualsiasi del riquadro) e seleziona il comando Edit dal menu.

Apri un blocco di riutilizzo o uno snippet basato su Workspace per modificarlo utilizzando il comando Edit nel relativo riquadro del pannello.
Apri un blocco di riutilizzo o uno snippet basato su Workspace per modificarlo utilizzando il comando Edit nel relativo riquadro del pannello.

Si aprirà l'editor temporaneo con il documento contenente il blocco di riutilizzo/snippet sorgente, presente nell'ultima revisione dell'elemento del Workspace, aperto per la modifica. Apporta le modifiche necessarie, quindi salva il documento nella revisione successiva del blocco di riutilizzo/snippet utilizzando il comando File » Save to Server del menu principale oppure il comando Save to Server del menu contestuale della voce del blocco di riutilizzo/snippet nel pannello Projects.

Le proprietà (Nome, Descrizione e Percorso) di uno snippet locale possono essere modificate tramite la finestra di dialogo Snippet Properties, accessibile facendo clic sul pulsante  nel riquadro dello snippet locale (oppure facendo clic con il pulsante destro del mouse in un punto qualsiasi del riquadro) e selezionando il comando Edit Properties dal menu.

Modifica le proprietà di uno snippet locale utilizzando la finestra di dialogo Snippet Properties, accessibile dal pannello Design Reuse.
Modifica le proprietà di uno snippet locale utilizzando la finestra di dialogo Snippet Properties, accessibile dal pannello Design Reuse.

Eliminazione di blocchi di riutilizzo e snippet

Per eliminare un blocco di riutilizzo o uno snippet, fai clic sul pulsante  nel riquadro dello snippet (oppure fai clic con il pulsante destro del mouse in un punto qualsiasi del riquadro) e seleziona il comando Delete dal menu.

  • Per un blocco di riutilizzo o uno snippet basato su Workspace, verrà visualizzata la finestra di dialogo Delete Items in cui confermare l'eliminazione. L'operazione è in realtà un'«eliminazione logica», che sposta il blocco di riutilizzo o lo snippet nell'area Trash del Workspace. L'area Trash è essenzialmente un cestino in cui è possibile spostare qualsiasi contenuto del Workspace tramite un'operazione di eliminazione logica. È isolata dal resto del Workspace. Per un blocco di riutilizzo, puoi anche scegliere di eliminare i contenuti correlati (ad esempio, snippet di schema e PCB).

    Esegui l'eliminazione logica di un blocco di riutilizzo o di uno snippet utilizzando il comando Delete nel relativo riquadro del pannello.
    Esegui l'eliminazione logica di un blocco di riutilizzo o di uno snippet utilizzando il comando Delete nel relativo riquadro del pannello.

  • Per uno snippet locale, verrà visualizzata la finestra di dialogo Confirm per confermare l'eliminazione. L'operazione rimuoverà i file dello snippet dal disco rigido.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents