Lavorare con i fogli schematici gestiti

A colpo d'occhio

Questo articolo spiega come i fogli schematici gestiti in un Workspace connesso ad Altium Designer rendano il riutilizzo dei progetti più affidabile, tracciabile e coerente rispetto al semplice copia e incolla. Illustra che cos'è un foglio schematico gestito, in cosa si differenzia dai fogli dispositivo, come viene archiviato e versionato nel Workspace e quali sono i principali modi per crearlo e salvarlo per utilizzi futuri. Scoprirai inoltre come il tipo di cartella, il tipo di contenuto, la denominazione, il ciclo di vita e la modifica diretta contribuiscano alla creazione di contenuti schematici riutilizzabili su cui il tuo team può fare affidamento. Continua a leggere per scoprire come i fogli gestiti nel Workspace possono aiutarti a riutilizzare con maggiore sicurezza blocchi di progetto collaudati.

- Scopri che cosa sono i fogli schematici gestiti, come favoriscono il riutilizzo e perché l'archiviazione nel Workspace offre controllo delle versioni, tracciabilità e integrità dei contenuti.
- Scopri i diversi modi per creare e salvare fogli schematici gestiti, tra cui la modifica diretta, il salvataggio del foglio corrente e il caricamento di un documento schematico in una revisione.
- Scopri come dettagli di configurazione quali il tipo di cartella, il tipo di contenuto, gli schemi di denominazione e le impostazioni del ciclo di vita aiutino a organizzare e gestire i contenuti schematici riutilizzabili.
Approfondisci con l'IA:

La possibilità di riutilizzare i contenuti di progettazione è un obiettivo comune a tutte le aziende che sviluppano prodotti e può offrire grandi vantaggi. Il riutilizzo non consente solo di risparmiare tempo: poter riutilizzare facilmente una sezione di un progetto precedente significa anche che tutte le attività di qualifica e collaudo di quella parte del progetto sono già state completate. Tuttavia, il riutilizzo dei progetti va ben oltre il semplice copia e incolla: un vero riutilizzo richiede che i contenuti siano protetti dalle modifiche, per garantire che rimangano identici agli originali. Niente modifiche rapide al colore di un componente o piccoli ritocchi al valore di un resistore: lavorare con contenuti riutilizzabili deve essere come lavorare con componenti pronti all'uso; si posiziona il contenuto, lo si collega e funziona esattamente come la volta precedente.

Altium Designer, insieme a un Workspace connesso, consente di creare al suo interno fogli schematici gestiti (elementi di tipo Foglio schematico gestito). Questi fogli possono essere creati:

  • Tramite modifica diretta.

  • Salvando il foglio schematico corrente nel Workspace.

  • Caricando il documento schematico pertinente (*.SchDoc) in una revisione del foglio schematico gestito di destinazione.

Una volta creato un foglio schematico gestito (e salvati i dati in una sua revisione), è possibile riutilizzarlo in futuri progetti di schede.

Che cos'è esattamente un foglio schematico gestito?

Un foglio schematico gestito è un normale foglio schematico di Altium Designer contenente componenti e collegamenti, memorizzato in un Workspace per poter essere riutilizzato in altri progetti. Si modifica come qualsiasi altro foglio schematico. Il concetto di foglio schematico gestito non si limita inoltre a un singolo foglio: è possibile inserire nel progetto un foglio schematico gestito che si trovi al vertice di una struttura ad albero composta da altri fogli schematici gestiti.

I fogli schematici gestiti si differenziano dai fogli dispositivo perché sono memorizzati in un Workspace, mentre i fogli dispositivo sono memorizzati in una cartella su disco rigido. Di conseguenza, i fogli gestiti offrono i vantaggi dei contenuti del Workspace, tra cui archiviazione semplificata, controllo delle versioni obbligatorio e, naturalmente, integrità garantita.

► Consulta le informazioni sui fogli dispositivo gestiti localmente.

La decisione di passare dai fogli dispositivo ai fogli schematici gestiti nasce dal desiderio di passare da contenuti riutilizzabili a contenuti riutilizzabili Workspace, ovvero quando si desidera o si ha la necessità di controllare il rilascio di tali contenuti di progettazione e di fornire un'unica fonte per l'intero team.

Rendendolo un contenuto del Workspace, si ha la certezza che la revisione di un foglio schematico gestito utilizzata in un progetto possa essere facilmente identificata e ricondotta alla sua origine ogni volta che occorre. Inoltre, trattandosi di un contenuto del Workspace, può essere revisionato e aggiornato quando necessario, ed è possibile tracciare tutte le relazioni di utilizzo, sia verso il basso, fino ai componenti presenti sul foglio, sia verso l'alto, fino ai progetti che lo utilizzano. In questo modo si dispone di tutte le informazioni necessarie per decidere se propagare il foglio revisionato ai progetti esistenti o se un determinato progetto debba continuare a utilizzare la revisione precedente.

Tipo di cartella

Quando si crea la cartella in cui memorizzare i fogli schematici gestiti, è possibile specificarne il tipo. Questo non influisce sul contenuto della cartella: il salvataggio di un foglio schematico genera sempre un corrispondente elemento di tipo Foglio schematico gestito. Fornisce semplicemente un'indicazione visiva di ciò che è memorizzato nella cartella e può essere utile quando si esplora un Workspace alla ricerca di contenuti specifici. Per destinare una cartella a contenere fogli schematici gestiti, imposta il relativo Folder Type su Managed Schematic Sheets quando definisci le proprietà della cartella nella finestra di dialogo Modifica cartella.

Specificare il tipo di cartella, ovvero l'uso previsto, fornisce un'indicazione visiva del suo contenuto durante l'esplorazione del Workspace.
Specificare il tipo di cartella, ovvero l'uso previsto, fornisce un'indicazione visiva del suo contenuto durante l'esplorazione del Workspace.

Tipo di contenuto

Quando crei un elemento di tipo Foglio schematico gestito in cui memorizzare il foglio schematico, assicurati che il relativo Content Type sia impostato su Managed Schematic Sheet nella finestra di dialogo Crea nuovo elemento. Se stai creando l'elemento in una cartella di tipo Managed Schematic Sheets, questo tipo di contenuto sarà disponibile nel menu contestuale accessibile con il pulsante destro del mouse durante la creazione dell'elemento.

Creazione di un foglio schematico gestito all'interno di una cartella Managed Schematic Sheets: il Content Type corretto è disponibile nel menu contestuale.
Creazione di un foglio schematico gestito all'interno di una cartella Managed Schematic Sheets: il Content Type corretto è disponibile nel menu contestuale.

Salvataggio di un foglio schematico

Related page: Creazione e modifica dei contenuti

Finora abbiamo illustrato il supporto per i fogli schematici gestiti nel Workspace, in termini di tipi di cartelle e contenuti associati. Il salvataggio di un foglio schematico già definito in una revisione di un elemento Foglio schematico gestito può essere eseguito in un paio di modi, come descritto nelle sezioni seguenti.

Per facilitare il riutilizzo dei fogli gestiti nei progetti, si consiglia vivamente di annotare manualmente il foglio schematico (Tools » Annotation » Annotate Schematics) prima di salvarlo come foglio gestito. Una volta completato un progetto che utilizza fogli gestiti, è possibile rinumerare tutti i fogli e i componenti dell'intero progetto.

► Per ulteriori informazioni, vedere la sezione Annotazione di componenti e fogli riportata di seguito.

Modifica diretta

Grazie al supporto del Workspace per la modifica diretta, è possibile modificare un foglio schematico e salvarlo nella revisione iniziale di un elemento Foglio schematico gestito appena creato. La modifica diretta elimina i vincoli legati alla gestione separata dei dati sorgente sotto controllo di versione. È sufficiente modificare un tipo di contenuto supportato utilizzando un editor temporaneo in cui viene caricata la versione più recente dei dati sorgente direttamente dal Workspace. Al termine della modifica, l'entità viene salvata (o salvata nuovamente) in una successiva revisione pianificata dell'elemento a cui appartiene e l'editor temporaneo viene chiuso. Non ci sono file sul disco rigido, dubbi sul fatto di lavorare con i dati sorgente corretti o più recenti, né la necessità di mantenere un software separato per il controllo di versione. Il Workspace gestisce tutto, garantendo un'elevata integrità dei dati e accelerandone notevolmente la modifica.

Quando si crea un elemento Foglio schematico gestito, è possibile scegliere di modificare e salvare un foglio schematico nella revisione iniziale di tale elemento dopo la creazione. A tale scopo, abilitare l'opzione Open for editing after creation nella parte inferiore della finestra di dialogo Create New Item (abilitata per impostazione predefinita). L'elemento verrà creato e si aprirà l'editor schematico temporaneo, con un documento .SchDoc attivo nella finestra principale di progettazione. Il documento verrà denominato in base alla combinazione elemento-revisione, nel formato: <Item><Revision>.SchDoc (ad esempio SCH-0007-1.SchDoc).

Se il Workspace contiene almeno un modello schematico salvato, verrà visualizzata la finestra di dialogo Select configuration item (Schematic Templates). Utilizzarla per scegliere il modello da applicare al documento schematico.

Esempio di modifica della revisione iniziale di un foglio schematico gestito direttamente dal Workspace: l'editor schematico temporaneo fornisce il documento in cui definire il foglio schematico.
Esempio di modifica della revisione iniziale di un foglio schematico gestito direttamente dal Workspace: l'editor schematico temporaneo fornisce il documento in cui definire il foglio schematico.

Utilizzare il documento per definire il foglio schematico secondo le proprie esigenze. Poiché i fogli schematici gestiti sono archiviati in un Workspace, anche i componenti al loro interno dovrebbero essere archiviati nel Workspace. In questo modo è possibile sfruttare appieno il sistema di gestione dei contenuti offerto dal Workspace, inclusa la possibilità di identificare e individuare tutti i componenti utilizzati nel foglio schematico gestito (gli elementi figli), nonché i progetti in cui è stato utilizzato il foglio schematico gestito (dove utilizzato). Per ulteriori informazioni, vedere Creazione e manutenzione di componenti e librerie.

La possibilità di utilizzare i componenti del Workspace per creare blocchi funzionali più grandi rende il flusso di progettazione sempre più snello e consente di lavorare a un livello di astrazione superiore. Proprio come se prelevasse parti da uno scaffale, il progettista riutilizza questi fogli schematici gestiti, che implementano specifiche funzionalità, come elementi costitutivi di un progetto più ampio. Maggiore è il numero di fogli schematici gestiti di questi circuiti creati e salvati nel Workspace, maggiore è il numero di funzionalità a disposizione del progettista, con un conseguente aumento della produttività nei progetti successivi.

Durante la modifica diretta sono disponibili tre controlli pertinenti, facilmente accessibili da Quick Access Bar (nell'angolo superiore sinistro della finestra principale dell'applicazione) o dalla barra degli strumenti Schematic Standard:

  • – Save Active Document. Utilizza questo pulsante per salvare localmente le modifiche apportate al documento. In questo modo puoi salvare le modifiche correnti e tornare in un secondo momento per apportarne altre, prima di salvare definitivamente nel Workspace.
  • / – Save to Workspace. Utilizza questo pulsante per salvare il foglio schematico definito nel Workspace, memorizzandolo nella revisione iniziale (pianificata) dell'elemento Foglio schematico gestito di destinazione. Verrà visualizzata la finestra di dialogo Modifica revisione, in cui puoi modificare il nome e la descrizione e aggiungere note di rilascio secondo necessità. Il documento e l'editor verranno chiusi dopo il salvataggio. Il documento contenente il foglio schematico sorgente (*.SchDoc) verrà memorizzato nella revisione dell'elemento.

    Un controllo Save to Server è comodamente disponibile anche a destra della voce relativa al foglio schematico, all'interno del pannello Projects stesso.
  • / – Discard Local Changes. Utilizza questo pulsante se desideri annullare la modifica ed eliminare tutte le modifiche apportate. Il documento e l'editor verranno chiusi e non verrà salvato nulla nell'elemento Foglio schematico gestito di destinazione.

Questi controlli sono disponibili anche come comandi – Save (scorciatoia: Ctrl+S), Save to Server (scorciatoia: Ctrl+Alt+S) e Discard Local Changes – nel menu principale File e nel menu contestuale della voce relativa al foglio schematico nel pannello Projects.

I dati salvati nel Workspace comprendono il foglio schematico sorgente, definito nel file Documento schematico (<Item><Revision>.SchDoc), e tutti i file di definizione dei cablaggi associati (*.Harness). Nel pannello Explorer, passa alla scheda della vista Preview per visualizzare una rappresentazione grafica del foglio, insieme a un elenco dei componenti che lo costituiscono (e del modello di foglio schematico gestito, se applicabile).

Fai clic sul collegamento ipertestuale di una revisione di un elemento Componente figlio per individuarla nel pannello Explorer. L'area degli elementi figli offre anche un menu contestuale con comandi per lavorare con la revisione di un elemento Componente figlio.

Torna al pannello Explorer per esplorare la revisione salvata del foglio schematico gestito. Passa alla scheda della vista Preview per visualizzare una rappresentazione grafica e un elenco delle revisioni dei componenti figli.
Torna al pannello Explorer per esplorare la revisione salvata del foglio schematico gestito. Passa alla scheda della vista Preview per visualizzare una rappresentazione grafica e un elenco delle revisioni dei componenti figli.

I componenti figli utilizzati nel foglio possono essere esplorati anche dalla scheda della vista Children. Fai doppio clic su una voce per individuarla oppure fai clic con il pulsante destro del mouse per accedere a una serie di comandi relativi al componente.

Esplora i componenti che costituiscono il foglio schematico gestito tramite la vista Children.
Esplora i componenti che costituiscono il foglio schematico gestito tramite la vista Children.

Salvataggio di un foglio esistente nel Workspace

Sebbene la modifica diretta sia l'approccio preferito per la maggior parte dei contenuti di progettazione che possono essere memorizzati in un Workspace, nel caso di fogli schematici esistenti (o anche di fogli dispositivo) è possibile salvare un foglio direttamente nel Workspace. A tale scopo è necessaria una revisione pianificata di un elemento Foglio schematico gestito esistente, nella quale salvare il foglio. La procedura è la seguente:

  1. Crea un nuovo elemento Foglio schematico gestito con una revisione iniziale pianificata oppure utilizza una revisione pianificata di un altro elemento esistente, secondo necessità.

  2. Apri il foglio schematico o il foglio dispositivo in Altium Designer.

  3. Scegli il comando File » Save as Managed Sheet to Server dai menu principali.

  4. Verrà visualizzata la finestra di dialogo Choose Planned Item Revision. Utilizzala per scegliere la revisione di destinazione dell'elemento Foglio schematico gestito desiderato (che deve trovarsi nello stato Planned), quindi fai clic su OK.

    Se l'elemento Foglio schematico gestito di destinazione non esiste, puoi crearlo al momento tramite la finestra di dialogo Choose Planned Item Revision. In tal caso, assicurati di disabilitare l'opzione Open for editing after creation (nella finestra di dialogo Create New Item), altrimenti entrerai nella modalità di modifica diretta.
  5. Verrà visualizzata la finestra di dialogo Modifica revisione, in cui puoi modificare il nome e la descrizione e aggiungere note di rilascio secondo necessità.

  6. Dopo aver fatto clic su OK, il foglio verrà salvato e memorizzato nella revisione dell'elemento.

Esempio di invio di un foglio dispositivo esistente al Workspace a cui sei attualmente connesso. Il salvataggio deve avvenire in una revisione esistente di un foglio schematico gestito e tale revisione deve trovarsi nello stato Planned.
Esempio di invio di un foglio dispositivo esistente al Workspace a cui sei attualmente connesso. Il salvataggio deve avvenire in una revisione esistente di un foglio schematico gestito e tale revisione deve trovarsi nello stato Planned.

Ricerca e posizionamento di un foglio schematico gestito

Il pannello Design Reuse descritto di seguito è in Open Beta ed è disponibile quando l'opzione UI.ModernDesignReusePanel è abilitata nella finestra di dialogo Impostazioni avanzate. Quando questa opzione è disabilitata, è possibile posizionare un foglio schematico gestito dal pannello Explorer. Per farlo, individua o cerca il foglio schematico gestito che desideri posizionare, fai clic con il pulsante destro del mouse sulla revisione specifica richiesta (in genere la più recente, nel qual caso basta fare clic con il pulsante destro direttamente sulla voce dell'elemento di livello superiore) e scegli il comando Place.

I fogli schematici gestiti memorizzati nel Workspace connesso possono essere esplorati e utilizzati dal pannello Design Reuse quando è impostato per visualizzare le risorse del Workspace ().

Puoi esplorare le cartelle del Workspace per trovare il foglio schematico gestito desiderato. In alternativa, utilizza il campo Search nella parte superiore del pannello Design Reuse per cercare un foglio schematico gestito in base al nome o alla descrizione.

  • Nel pannello Design Reuse viene visualizzata solo la revisione più recente di ciascun foglio schematico gestito.

  • Se l'ultima revisione di un foglio schematico gestito si trova in uno stato del ciclo di vita in cui l'opzione Visible in Vault panels è disabilitata (scopri di più), per impostazione predefinita quel foglio schematico gestito non verrà visualizzato nel pannello. Per visualizzare i fogli schematici gestiti attualmente non visibili, fai clic sul pulsante  in alto a destra nel pannello, quindi abilita l'opzione Show Hidden Revisions nel relativo menu.

Fai clic sul controllo Details nella parte inferiore del pannello per espandere il riquadro Details, che mostra i dettagli dei fogli schematici gestiti selezionati, tra cui:

  • Nome del foglio schematico gestito.

  • Icona dello stato del ciclo di vita e revisione (fai clic sul collegamento per aprire la vista dettagliata della cronologia dell'elemento Foglio schematico gestito con l'ultima revisione selezionata).

  • Descrizione del foglio schematico gestito.

  • Informazioni generali sul foglio schematico gestito.

Utilizzando l'accesso controllato ai contenuti del Workspace, insieme a uno schema del ciclo di vita adeguato, il personale autorizzato (responsabili delle librerie, responsabili senior della progettazione) può approvare e rendere disponibili solo i fogli schematici gestiti da utilizzare nei progetti. In questo modo, il progettista può dedicarsi alla progettazione con la certezza di utilizzare esclusivamente fogli di circuiti riutilizzabili autorizzati.

Prior to Placement

Prima di inserire un foglio schematico gestito in un progetto, occorre tenere presente un paio di aspetti:

  • Il simbolo di foglio di un foglio schematico gestito non può essere inserito in uno schema libero: il foglio di destinazione deve far parte di un progetto.

  • Assicurati che il foglio schematico in cui inserire il simbolo di foglio associato sia aperto in Altium Designer e sia il documento attivo. Se i documenti sono aperti in più finestre, assicurati anche che la finestra contenente il documento schematico attivo sia in primo piano.

Per inserire un foglio schematico gestito in un progetto, posiziona il cursore sulla relativa voce nel pannello Design Reuse, fai clic sul pulsante  (oppure fai clic con il pulsante destro del mouse sulla voce) e seleziona il comando Place dal menu. Un simbolo di foglio che fa riferimento al foglio seguirà il cursore: fai clic nel punto desiderato del foglio schematico per posizionarlo.

Quando posizioni il simbolo di foglio, Altium Designer copia il foglio gestito rappresentato dal simbolo dal Workspace alla cartella del progetto, all'interno di una sottocartella denominata \Managed\Sheets. Qui viene memorizzata una copia di ciascun foglio gestito, ognuna nella propria sottocartella identificata da un identificatore univoco generato dal sistema (GUID).

La sottocartella con nome GUID in cui viene scaricata e memorizzata l'istanza del foglio schematico gestito non deve essere modificata o rinominata in alcun modo.

Annotazione dei componenti e dei fogli

Per garantire l'integrità dei circuiti utilizzati in un foglio schematico gestito, il foglio non può essere modificato durante il normale utilizzo nella progettazione. Ciò significa che il numero del foglio e le assegnazioni dei designatori non possono essere modificati sul foglio stesso. Come si fa, quindi, a numerare tutti i fogli del progetto e ad annotare tutti i componenti?

Queste operazioni sono gestite da due comandi: i fogli vengono numerati utilizzando il comando Tools » Annotation » Annotate Compiled Sheets e i componenti vengono annotati utilizzando il comando Tools » Annotation » Board Level Annotate. Il numero del foglio e le assegnazioni dei designatori vengono memorizzati in un file separato, <ProjectName>*.annotation. 

Gli strumenti di annotazione dei componenti devono conoscere l'ordine in cui elaborare i fogli schematici. Per questo motivo, è preferibile numerare i fogli prima di numerare i componenti.

I principi di annotazione dei componenti e dei fogli sono gli stessi applicati quando si utilizzano fogli dispositivo locali. Per ulteriori informazioni sull'annotazione di progetti che includono fogli schematici gestiti, consulta le seguenti sezioni della pagina Fogli dispositivo:

Modifica di un foglio schematico gestito

Per modificare un foglio schematico gestito, posiziona il cursore sulla relativa voce nel pannello Design Reuse e fai clic sul pulsante  (oppure fai clic con il pulsante destro del mouse sulla voce), quindi seleziona il comando Edit dal menu. Si aprirà l'editor temporaneo con il foglio schematico contenuto nell'ultima revisione dell'elemento Foglio schematico gestito, pronto per la modifica. Apporta le modifiche necessarie, quindi salva il documento nella revisione successiva dell'elemento (File » Save to Server).​​​

Se devi modificare il foglio schematico memorizzato in un elemento Foglio schematico gestito e disponi del foglio aggiornato, puoi caricarlo in quell'elemento utilizzando il pannello Explorer: il nuovo foglio verrà memorizzato nella revisione successiva dell'elemento. Per ulteriori informazioni, consulta la pagina Creazione e modifica dei contenuti.

Altre azioni sui fogli schematici gestiti

Il menu del pulsante  (e il menu contestuale) di una voce relativa a un foglio schematico gestito nel pannello Design Reuse consente inoltre di accedere ai seguenti comandi:

  • Move – consente di modificare la posizione dell'elemento Foglio schematico gestito nella struttura delle cartelle del Workspace. L'esecuzione del comando apre la finestra di dialogo Move Item, in cui selezionare la cartella di destinazione in cui collocare l'elemento. 

  • Share – consente di definire le autorizzazioni di condivisione per il foglio schematico gestito. Dopo aver selezionato il comando, si aprirà la finestra di dialogo Share For Item, in cui puoi configurare la condivisione secondo le necessità. Scopri di più sulla condivisione a livello di elemento.

  • Operations – consente di accedere a un menu a discesa con funzioni aggiuntive per i fogli schematici gestiti, descritte di seguito.

    • Make a Copy – consente di copiare il foglio schematico gestito. Si aprirà un editor temporaneo del foglio schematico gestito, con lo stesso contenuto del foglio schematico gestito originale. Apporta le modifiche necessarie e salva il foglio schematico gestito nel Workspace. 

    • Change Revision State – consente di cambiare lo stato dell'ultima revisione del foglio schematico gestito. Dopo aver selezionato il comando, si apre la finestra di dialogo di modifica dello stato in batch, che consente di cambiare lo stato della revisione del foglio schematico gestito.

    • Download – consente di scaricare i dati memorizzati nel foglio schematico gestito. I dati associati verranno scaricati in una sottocartella della directory scelta, denominata utilizzando l'ID di revisione dell'elemento Foglio schematico gestito. Il file si trova nelle cartelle Released al suo interno.

  • Delete – consente di eliminare il foglio schematico gestito dal Workspace connesso. Dopo aver selezionato il comando, verrà visualizzata la finestra di dialogo Delete Items, in cui confermare l'eliminazione. 

    L'azione è in realtà un'«eliminazione logica», con cui il foglio schematico gestito viene spostato nell'area Trash del Workspace. Scopri di più sull'eliminazione logica.

  • History – consente di accedere a una vista dettagliata del foglio schematico gestito, aperta come nuova scheda in Altium Designer.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents