Lavorare con gli snippet

A colpo d'occhio

Questo articolo spiega come creare, trovare, posizionare, organizzare, modificare e gestire gli snippet in Altium Designer utilizzando il pannello Design Reuse. Descrive sia gli snippet del Workspace sia quelli locali, mostra come acquisire circuiti di schemi elettrici o PCB sotto forma di snippet da riutilizzare e illustra le principali operazioni disponibili per la loro manutenzione, tra cui l'organizzazione delle cartelle, i dettagli relativi alle revisioni e le opzioni di gestione dei contenuti del Workspace. Se vuoi capire meglio come riutilizzare i contenuti di progettazione in modo più efficiente e orientarti con sicurezza tra i comandi disponibili per gli snippet, continua a leggere.

- Scopri come creare snippet di schemi elettrici e PCB a partire da contenuti di progettazione esistenti e salvarli in un Workspace o in una cartella locale.
- Scopri come cercare gli snippet, esaminarne i dettagli e posizionarli nei documenti di destinazione corretti, anche inserendo uno snippet di schema elettrico come simbolo di foglio.
- Comprendi come organizzare le cartelle degli snippet locali e gestire le modifiche e le operazioni sugli snippet, sia locali sia archiviati nel Workspace.
Approfondisci con l'IA:

Il Design Reuse pannello utilizzato per gestire gli snippet e descritto in questa pagina è in Open Beta ed è disponibile quando l'opzione UI.ModernDesignReusePanel è abilitata nella finestra di dialogo Impostazioni avanzate. Quando questa opzione è disabilitata, viene utilizzata la versione precedente del pannello, descritta nella pagina Lavorare con blocchi di riutilizzo e snippet.

La funzionalità snippets consente di salvare qualsiasi selezione di circuiti presente su un singolo foglio schematico o in un progetto PCB, inclusi i componenti e le piste, per poi riutilizzarla in qualsiasi progetto. Il pannello Design Reuse consente di accedere rapidamente a tutti i controlli necessari per utilizzare e gestire la propria raccolta di snippet.

Creazione di uno snippet

È possibile creare un nuovo snippet di schema o PCB a partire da circuiti esistenti su un foglio schematico o in un documento PCB:

  1. Selezionare i circuiti desiderati nell'editor degli schemi o dei PCB.

  2. Selezionare il comando Tools » Convert » Create Snippet from selected objects dai menu principali (nell'editor PCB, è anche possibile fare clic con il pulsante destro del mouse sulla selezione e scegliere Snippets » Create Snippet from selected objects dal menu contestuale).

  3. Verrà visualizzata la finestra di dialogo New Schematic Snippet o New PCB Snippet, in cui è possibile definire Name, Description, la destinazione di salvataggio (Save to – il Workspace connesso o una cartella locale) e la cartella in cui verrà salvato il nuovo snippet (Path).

    Fare clic sul pulsante  a destra del campo Path nella finestra di dialogo per accedere alla finestra di dialogo Choose Folder (quando si salva uno snippet nel Workspace) o Choose Snippet Folder (quando si salva uno snippet in una cartella locale), che consente di selezionare una cartella esistente in cui salvare lo snippet o di crearne una nuova al momento.

    • Nella finestra di dialogo Choose Snippet Folder, fare clic sul pulsante  e utilizzare la finestra di dialogo Folder Properties che si apre per aggiungere una nuova sottocartella alla struttura complessiva delle cartelle degli snippet locali (). Nella finestra di dialogo è possibile specificare un nome per la nuova cartella e stabilire in quale cartella superiore crearla.

    • Per informazioni su come organizzare gli snippet locali in cartelle, consultare la sezione Organizzazione degli snippet locali riportata di seguito.

  4. Fare clic su  nella finestra di dialogo per salvare lo snippet.

Quando si salva uno snippet nel Workspace connesso, si consiglia di utilizzare nello snippet componenti provenienti da tale Workspace. In questo modo è possibile sfruttare appieno il sistema di gestione dei contenuti offerto dal Workspace.

Ricerca e posizionamento di uno snippet

Gli snippet del Workspace e quelli locali sono disponibili per il posizionamento dal pannello Design Reuse.

  • Quando il pannello è impostato per visualizzare le risorse del Workspace (), può essere utilizzato per accedere agli snippet memorizzati nel Workspace connesso.

  • Quando il pannello è impostato per visualizzare le risorse locali (), consente di accedere agli snippet memorizzati nelle cartelle del disco rigido (le cartelle sono configurate come descritto sopra).

È possibile esplorare le cartelle del Workspace o quelle locali per trovare lo snippet desiderato. In alternativa, utilizzare il campo Search nella parte superiore del pannello per cercare uno snippet in base al nome o alla descrizione.

  • Nel pannello Design Reuse viene mostrata solo l'ultima revisione di ciascuno snippet del Workspace.

  • Se l'ultima revisione di uno snippet del Workspace si trova in uno stato del ciclo di vita per il quale l'opzione Visible in Vault panels è disabilitata (ulteriori informazioni), per impostazione predefinita tale snippet non verrà visualizzato nel pannello. Per visualizzare gli snippet attualmente non visibili, fare clic sul pulsante  in alto a destra nel pannello, quindi abilitare l'opzione Show Hidden Revisions nel menu associato.

Fare clic sul controllo Details nella parte inferiore del pannello per espandere il riquadro Details, che mostra i dettagli del blocco di riutilizzo selezionato, tra cui:

  • Nome dello snippet.

  • Icona dello stato del ciclo di vita e revisione (solo per gli snippet del Workspace; fare clic sul collegamento per aprire la vista dettagliata della cronologia dell'elemento Blocco di riutilizzo con l'ultima revisione selezionata).

  • Descrizione dello snippet.

  • Informazioni generali sullo snippet.

  • Immagini di anteprima dello snippet.

Utilizzando l'accesso controllato ai contenuti del Workspace insieme a uno schema del ciclo di vita adeguato, il personale autorizzato (responsabili delle librerie e della progettazione) può approvare e rendere disponibili solo gli snippet del Workspace destinati a essere utilizzati nei progetti. Ciò consente al progettista di lavorare con la certezza di utilizzare solo snippet autorizzati.

Prima di posizionare uno snippet, assicurarsi che il documento di destinazione corretto sia aperto come documento attivo. Il comando di posizionamento sarà disponibile solo se lo snippet può essere posizionato correttamente in tale documento, ovvero se il tipo di snippet e il tipo di documento coincidono.

Per posizionare uno snippet, passare il cursore sulla relativa voce nel pannello Design Reuse, fare clic sul pulsante  (oppure fare clic con il pulsante destro del mouse sulla voce) e selezionare dal menu il comando Place (per uno snippet di schema o PCB) oppure Place as Sheet Symbol (solo per uno snippet di schema). Se si seleziona quest'ultimo comando, lo snippet verrà posizionato sul foglio schematico attivo come simbolo di foglio. Il simbolo di foglio posizionato includerà ingressi di foglio corrispondenti alle porte dello snippet. Il contenuto dello snippet verrà inserito in un foglio schematico secondario creato automaticamente e referenziato dal simbolo di foglio.

Organizzazione degli snippet locali

Gli snippet locali possono essere organizzati in cartelle, raggruppando quelli correlati per facilitarne la ricerca. Le cartelle degli snippet sono cartelle Windows esistenti che non possono essere create dall'interno del pannello Design Reuse. Vengono invece "aperte" o "chiuse" durante l'esplorazione degli snippet locali che contengono. Queste cartelle possono essere create solo direttamente sul disco rigido o in rete, al di fuori di Altium Designer.

Quando il pannello Design Reuse è impostato per visualizzare le risorse locali (fare clic sull'icona più a sinistra nella barra degli indirizzi nella parte superiore del pannello e selezionare la voce Local – l'icona verrà visualizzata come ), le cartelle degli snippet possono essere aperte e chiuse dalla finestra di dialogo Available Snippets Folders, accessibile facendo clic sul pulsante  in alto a destra nel pannello e selezionando il comando Snippet Folders dal menu.

  • Fare clic su  per individuare la cartella desiderata sul disco rigido o in rete. La cartella selezionata verrà aggiunta all'elenco nella finestra di dialogo e successivamente comparirà nel pannello Design Reuse.

  • Per rimuovere una cartella di snippet dall'elenco (chiudendola di fatto ai fini dell'esplorazione), selezionare la cartella nell'elenco della finestra di dialogo Available Snippets Folders, quindi fare clic su .

Modifica di uno snippet

Per modificare uno snippet del Workspace, posiziona il cursore sulla relativa voce nel pannello Design Reuse, fai clic sul pulsante  (oppure fai clic con il pulsante destro del mouse sulla voce) e seleziona il comando Edit dal menu. Si aprirà un editor temporaneo, con lo snippet di documento contenuto nell'ultima revisione dell'elemento Snippet aperto per la modifica. Apporta le modifiche necessarie, quindi salva lo snippet nella revisione successiva dell'elemento (File » Save to Server).

Per modificare il contenuto di uno snippet locale, apri il documento <SCHSnippetName>.SchDoc o <PCBSnippetName>.PcbDoc dalla cartella di Windows in cui è memorizzato lo snippet (utilizzando il comando File » Open dai menu principali di Altium Designer o tramite Windows Explorer), apporta le modifiche necessarie, quindi salva il documento (File » Save).

Le proprietà di uno snippet locale (nome, descrizione e percorso) possono essere modificate tramite la finestra di dialogo Snippet Properties. Per accedere a questa finestra di dialogo, posiziona il cursore sulla relativa voce nel pannello Design Reuse, fai clic sul pulsante  (oppure fai clic con il pulsante destro del mouse sulla voce) e seleziona il comando Edit dal menu contestuale. Utilizza la finestra di dialogo per apportare le modifiche necessarie.

Altre azioni sugli snippet

Il menu del pulsante  (e il menu contestuale accessibile con il pulsante destro del mouse) di una voce snippet nel pannello Design Reuse consente inoltre di accedere ai seguenti comandi:

  • Move (solo per uno snippet del Workspace) – consente di modificare la posizione dell'elemento Snippet nella struttura delle cartelle del Workspace. L'esecuzione del comando apre la finestra di dialogo Move Item, in cui selezionare la cartella di destinazione in cui collocare l'elemento.

  • Share (solo per uno snippet del Workspace) – consente di definire le autorizzazioni di condivisione dello snippet. Dopo aver selezionato il comando, si apre la finestra di dialogo Share For Item, in cui è possibile configurare la condivisione secondo necessità. Scopri di più sulla condivisione a livello di elemento.

  • Operations (solo per uno snippet del Workspace) – consente di accedere a un menu a discesa con funzioni aggiuntive per gli snippet, descritte di seguito.

    • Make a Copy – consente di copiare lo snippet. Si apre un editor temporaneo dello snippet, con lo stesso contenuto dello snippet originale. Apporta le modifiche necessarie e salva lo snippet nel Workspace. 

    • Change Revision State – consente di modificare lo stato di revisione dell'ultima revisione dello snippet. Dopo aver selezionato il comando, si apre la finestra di dialogo per la modifica dello stato in blocco, che consente di modificare lo stato di revisione dello snippet.

    • Download – consente di scaricare i dati memorizzati nello snippet. I dati associati verranno scaricati in una sottocartella della directory scelta, denominata utilizzando l'ID della revisione dell'elemento. Il file si trova nelle cartelle Released al suo interno.

  • Delete – consente di eliminare lo snippet.

    • Per uno snippet del Workspace, viene visualizzata la finestra di dialogo Delete Items, in cui confermare l'eliminazione.

      L'azione è in realtà un'eliminazione logica: lo snippet viene spostato nell'area Trash del Workspace. Scopri di più sull'eliminazione logica.

    • Per uno snippet locale, viene visualizzata la finestra di dialogo Confirm per confermare l'eliminazione. L'azione rimuove i file dello snippet dal disco rigido.

  • History (solo per uno snippet del Workspace) – consente di accedere a una vista dettagliata dello snippet, aperta come nuova scheda all'interno di Altium Designer.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents