Lavorare con i blocchi di riutilizzo

A colpo d'occhio

Questo articolo spiega come utilizzare il pannello Design Reuse di Altium Designer per creare, gestire, cercare, posizionare, modificare e organizzare blocchi di riutilizzo strutturati archiviati in un Workspace connesso. Descrive come i blocchi di riutilizzo possano includere sia dati dello schema elettrico sia dati PCB e come gli elementi PCB vengano trasferiti sulla scheda tramite il processo ECO. Illustra inoltre le principali operazioni disponibili nel pannello, come esplorare le risorse del Workspace, visualizzare i dettagli, selezionare le opzioni di posizionamento, salvare revisioni ed eseguire attività di gestione quali rinomina, spostamento, condivisione, download ed eliminazione. Se cerchi un modo più chiaro ed efficiente per riutilizzare sezioni di progetto collaudate in più progetti, continua a leggere: questo articolo ti mostrerà da dove iniziare e come utilizzare con sicurezza gli strumenti disponibili.

- Scopri come creare blocchi di riutilizzo strutturati, salvarli in un Workspace e riutilizzarli negli schemi elettrici e nei progetti PCB tramite il pannello Design Reuse.
- Scopri come trovare, esaminare e posizionare i blocchi di riutilizzo, con opzioni per il posizionamento diretto, il posizionamento tramite simbolo di foglio e la gestione di più documenti PCB.
- Comprendi le principali operazioni di gestione disponibili per i blocchi di riutilizzo, tra cui modifica, aggiornamento delle revisioni, condivisione, spostamento, download ed eliminazione reversibile.
Approfondisci con l'IA:

Il Design Reuse pannello utilizzato per gestire i blocchi di riutilizzo e descritto in questa pagina è in Open Beta ed è disponibile quando l'opzione UI.ModernDesignReusePanel è abilitata nella finestra di dialogo Advanced Settings. Quando questa opzione è disabilitata, viene utilizzata la versione precedente del pannello, descritta nella pagina Utilizzo dei blocchi di riutilizzo e degli snippet.

Se i tuoi progetti includono spesso 'sezioni' comuni di circuiti nello schema elettrico e nel PCB, Altium Designer offre metodi semplici e pratici per salvare e riutilizzare queste sezioni, evitando di doverle creare da zero ogni volta.

Quando sei connesso a un Workspace, puoi creare un reuse block che può contenere sia i circuiti dello schema elettrico sia la loro rappresentazione fisica per il PCB. Quando un blocco di riutilizzo di questo tipo viene posizionato su un foglio dello schema elettrico, la sua rappresentazione fisica viene posizionata automaticamente nel documento PCB durante il processo ECO.

Il pannello Design Reuse consente di accedere rapidamente a tutti i controlli necessari per utilizzare e gestire i blocchi di riutilizzo.

  • Il pannello offre inoltre la possibilità di accedere ai fogli di schema elettrico gestiti e agli snippet.

  • Oltre ai metodi standard per accedere a un pannello (il menu del pulsante  e il sottomenu View » Panels dei menu principali), è possibile accedere al pannello Design Reuse selezionando il comando Place » Reuse Block dai menu principali nell'editor degli schemi elettrici o dei PCB.

Per utilizzare i blocchi di riutilizzo tramite il pannello Design Reuse, assicurati che il pannello sia configurato per esplorare le risorse del Workspace. A tale scopo, fai clic sull'icona più a sinistra nella barra degli indirizzi nella parte superiore del pannello e seleziona la voce del Workspace connesso. L'icona verrà visualizzata come .

Creazione di un blocco di riutilizzo

È possibile creare un nuovo blocco di riutilizzo come descritto di seguito.

  1. Fai clic sul pulsante  in alto a destra nel pannello Design Reuse. In alternativa, seleziona il comando File » New » Reuse Block dai menu principali.

  2. Nel pannello Projects si aprirà una struttura temporanea modificabile del blocco di riutilizzo, simile a quella di un progetto PCB (sotto una voce relativa al Workspace connesso), e si aprirà l'editor temporaneo degli schemi elettrici, pronto per definire il documento dello schema elettrico del blocco di riutilizzo. Utilizza i comandi e le tecniche di posizionamento standard per definire il documento dello schema elettrico del blocco di riutilizzo.

    Se desideri creare un blocco di riutilizzo contenente solo lo schema elettrico o solo il PCB, puoi rimuovere il documento PCB o dello schema elettrico dalla struttura dello snippet facendo clic con il pulsante destro del mouse rispettivamente sul documento PCB o dello schema elettrico nel pannello Projects e selezionando il comando Remove from Project.

  3. Utilizza il comando Design » Update PCB Document e il processo ECO per trasferire lo schema elettrico acquisito al documento PCB del blocco di riutilizzo, quindi applica le modifiche necessarie a tale documento (definizione delle posizioni dei componenti, sbroglio, ecc.).

    È possibile aggiungere più documenti PCB al blocco di riutilizzo in fase di definizione. A tale scopo, utilizza il comando Add New to Project » PCB dal menu contestuale della voce del blocco di riutilizzo nel pannello Projects.

    Utilizza il comando Rename dal menu contestuale della voce del documento PCB aggiunto nel pannello Projects per assegnargli un nome significativo. Utilizza un comando Design » Update dal menu principale dell'editor degli schemi elettrici per aggiornare il documento PCB desiderato.

  4. Una volta definiti entrambi i documenti, dello schema elettrico e del PCB, del blocco di riutilizzo, salva il blocco nel Workspace utilizzando il comando Save to Server dal menu contestuale della voce del blocco di riutilizzo nel pannello Projects oppure il controllo Save to Server a destra della voce.

    Poiché i blocchi di riutilizzo sono archiviati nel Workspace connesso, si consiglia di utilizzare componenti provenienti da tale Workspace nel blocco di riutilizzo. In questo modo, puoi sfruttare appieno il sistema di gestione dei contenuti offerto dal Workspace.

    • Sia il documento dello schema elettrico sia il documento PCB del blocco di riutilizzo devono contenere almeno un componente per poter essere salvati nel Workspace.

    • Se i documenti dello schema elettrico e del PCB del blocco di riutilizzo non sono sincronizzati (vengono rilevate differenze tra i due documenti), verrà visualizzata una finestra di avviso quando tenti di salvare il blocco di riutilizzo nel Workspace. Puoi annullare il salvataggio per tornare al blocco di riutilizzo e risolvere le differenze oppure procedere con il salvataggio.

  5. Verrà visualizzata la finestra di dialogo Create New Reuse Block, in cui puoi definire Name, Description e la Folder del Workspace in cui verrà salvato il nuovo blocco di riutilizzo.

  6. Dopo aver fatto clic su OK nella finestra di dialogo Create New Reuse Block, il blocco di riutilizzo verrà salvato nel Workspace e la sua struttura temporanea verrà chiusa.

Ricerca e posizionamento di un blocco di riutilizzo

I blocchi di riutilizzo archiviati nel Workspace connesso possono essere esplorati e utilizzati dal pannello Design Reuse quando è impostato per visualizzare le risorse del Workspace (). In questa modalità, il pannello presenta la struttura delle cartelle del Workspace, consentendoti di esplorare le cartelle in cui sono archiviati i blocchi di riutilizzo. Ogni cartella e ogni blocco di riutilizzo sono visualizzati nell'elenco nella parte superiore del pannello con il relativo nome e la relativa descrizione.

Per trovare il blocco di riutilizzo desiderato, puoi navigare tra le cartelle oppure utilizzare il campo Search nella parte superiore del pannello Design Reuse per cercare un blocco di riutilizzo in base al nome o alla descrizione ().

  • Nel pannello Design Reuse viene visualizzata solo la revisione più recente di ciascun blocco di riutilizzo.

  • Se la revisione più recente di un blocco di riutilizzo si trova in uno stato del ciclo di vita in cui l'opzione Visible in Vault panels è disabilitata (scopri di più), per impostazione predefinita tale blocco di riutilizzo non verrà visualizzato nel pannello. Per visualizzare i blocchi di riutilizzo attualmente non visibili, fai clic sul pulsante  in alto a destra nel pannello, quindi abilita l'opzione Show Hidden Revisions nel menu associato.

Fai clic sul controllo Details nella parte inferiore del pannello per espandere il riquadro Details, che visualizza i dettagli del blocco di riutilizzo selezionato, tra cui:

  • Nome del blocco di riutilizzo.

  • Icona dello stato del ciclo di vita e revisione (fai clic sul collegamento per aprire la vista dettagliata della cronologia dell'elemento del blocco di riutilizzo con la revisione più recente selezionata).

  • Descrizione del blocco di riutilizzo.

  • Informazioni generali e parametri del blocco di riutilizzo.

  • Immagini di anteprima dei documenti dello schema elettrico e del PCB del blocco di riutilizzo.

  • Elenco dei progetti () e dei rilasci dei progetti () in cui viene utilizzato il blocco di riutilizzo (l'area Where Used).

Utilizzando l'accesso controllato ai contenuti del Workspace, insieme a uno schema del ciclo di vita adeguato, il personale autorizzato (responsabili delle librerie e responsabili della progettazione) può approvare e rendere disponibili solo i blocchi di riutilizzo destinati all'uso nei progetti. In questo modo, il progettista può lavorare con la certezza di utilizzare solo blocchi di riutilizzo autorizzati.

Per posizionare un blocco di riutilizzo in un progetto, passare il cursore sulla relativa voce nel pannello Design Reuse, fare clic sul pulsante  (oppure fare clic con il pulsante destro del mouse sulla voce) e selezionare uno dei seguenti comandi dal menu:

  • Place – selezionare per posizionare il blocco di riutilizzo direttamente nel documento schematico o PCB attivo. A seconda del tipo di documento attivo quando si esegue il comando, verrà posizionato il documento schematico o PCB del blocco di riutilizzo.

     
  • Place as Sheet Symbol – quando è attivo un documento schematico, selezionare per posizionare il blocco di riutilizzo come simbolo di foglio sul foglio schematico. Il simbolo di foglio posizionato includerà le voci di foglio corrispondenti alle porte del blocco di riutilizzo. Il contenuto del blocco di riutilizzo verrà posizionato su un foglio schematico figlio creato automaticamente e referenziato dal simbolo di foglio. Il simbolo di foglio di un blocco di riutilizzo posizionato avrà un'icona distintiva.

Se il blocco di riutilizzo include più documenti PCB, selezionare il documento PCB desiderato facendo clic sulla relativa scheda sotto l'immagine di anteprima del documento PCB nell'area Preview del riquadro Details prima di posizionare il blocco di riutilizzo (). Quando il blocco di riutilizzo viene posizionato nello schematico, il documento PCB selezionato verrà associato al blocco di riutilizzo e posizionato nel PCB quando quest'ultimo viene aggiornato tramite il processo ECO.

Dopo aver posizionato il documento schematico di un blocco di riutilizzo, il relativo documento PCB può essere posizionato nel documento PCB tramite il processo ECO. Dall'editor schematico, utilizzare il comando Design » Update PCB Document nei menu principali, quindi convalidare ed eseguire le modifiche utilizzando la finestra di dialogo Engineering Change Order.

Modifica di un blocco di riutilizzo

Per modificare un blocco di riutilizzo, passare il cursore sulla relativa voce nel pannello Design Reuse e fare clic sul pulsante  (oppure fare clic con il pulsante destro del mouse sulla voce), quindi selezionare il comando Edit dal menu.

La struttura temporanea del progetto del blocco di riutilizzo, contenente l'ultima revisione dell'elemento blocco di riutilizzo, si aprirà per la modifica. Apportare le modifiche necessarie, quindi salvare il blocco di riutilizzo nella revisione successiva (File » Save to Server).

Altre azioni sui blocchi di riutilizzo

Il menu del pulsante  (e il menu accessibile con il pulsante destro del mouse) di una voce di blocco di riutilizzo nel pannello Design Reuse consente inoltre di accedere ai seguenti comandi:

  • Rename – utilizzare per modificare il nome del blocco di riutilizzo. Dopo aver selezionato il comando, immettere il nuovo nome desiderato nella finestra di dialogo Rename Reuse Block visualizzata, quindi fare clic su OK.

  • Move – utilizzare per modificare la posizione dell'elemento blocco di riutilizzo nella struttura delle cartelle del Workspace. L'esecuzione del comando consente di accedere alla finestra di dialogo Move Item in cui selezionare la cartella di destinazione nella quale posizionare l'elemento.

  • Share – utilizzare per definire le autorizzazioni di condivisione del blocco di riutilizzo. Dopo aver selezionato il comando, si aprirà la finestra di dialogo Share For Item, in cui è possibile configurare la condivisione secondo necessità. Ulteriori informazioni sulla condivisione a livello di elemento.

  • Operations – utilizzare per accedere a un menu a discesa con funzioni aggiuntive per i blocchi di riutilizzo, come descritto di seguito.

    • Make a Copy – utilizzare per copiare il blocco di riutilizzo. Si aprirà una struttura temporanea del progetto del blocco di riutilizzo, con lo stesso contenuto del blocco di riutilizzo originale. Apportare le modifiche necessarie e salvare il blocco di riutilizzo nel Workspace. 

    • Change Revision State – utilizzare per modificare lo stato di revisione dell'ultima revisione del blocco di riutilizzo. Dopo aver selezionato il comando, si apre la finestra di dialogo Batch state change, che consente di modificare lo stato di revisione del blocco di riutilizzo.

    • Download – utilizzare per scaricare i dati memorizzati nel blocco di riutilizzo (i relativi documenti schematici e/o PCB). I dati associati verranno scaricati in una sottocartella della directory scelta, denominata utilizzando l'ID di revisione dell'elemento blocco di riutilizzo. I file si trovano nelle cartelle Released al suo interno.

  • Delete – utilizzare per eliminare il blocco di riutilizzo dal Workspace connesso. Dopo aver selezionato il comando, verrà visualizzata la finestra di dialogo Delete Items in cui confermare l'eliminazione. È inoltre possibile scegliere di eliminare i contenuti correlati del blocco di riutilizzo (ossia i frammenti di schematico e PCB).

    L'azione è in realtà un'«eliminazione reversibile», con cui il blocco di riutilizzo viene spostato nell'area Trash del Workspace. Ulteriori informazioni sull'eliminazione reversibile.

  • History – utilizzare per accedere a una vista dettagliata del blocco di riutilizzo, aperta come nuova scheda in Altium Designer.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents