コンポーネントの一括編集
Workspaceコンポーネントは、Component Editorを使用して定義・編集します。Component Editorには、Single Component EditingとBatch Component Editingの2つのモードがあります。後者は複数のコンポーネントを定義・編集するためのインターフェースですが、必要に応じて単一のコンポーネントの定義・編集にも使用できます。Component EditorがSingle Component Editingモードの場合、エディターのメインメニューからTools » Switch to Batch Editorコマンドを選択すると、一括編集モードに切り替わります。
Componentsパネル または Explorerパネルで編集対象として複数のコンポーネントを選択した場合も、Component Editorが Batch Component Editingモードで開きます。 各コンポーネント定義には、共通のパラメーターセットと、必要なドメインモデルへのリンクが含まれます。一括編集は、たとえばチップ抵抗のセットなど、コンポーネントをひとまとまりとして管理する場合に特に役立ちます。
このドキュメントでは、Component EditorのBatch Component Editingモードでの操作について説明します。
インターフェースの概要
Batch Component EditingモードのComponent Editorインターフェースは、主に4つの領域に分かれています。以下の画像と、その後の説明で各領域を示します。

Batch Component Editingモードに切り替えたComponent Editorは、4つの主要な領域に分かれています。
- 必要なモデル/パラメーター – コンポーネント定義に必要なドメインモデルの種類を指定し、すべてのコンポーネント定義に適用するパラメーターデータのセットを作成する領域です。
- モデルリンク – コンポーネント定義で使用する、保存済みのドメインモデルへのリンクを追加する領域です。
- プレビューウィンドウ – 現在選択されているモデルのプレビューを表示します。シンボルとフットプリントはグラフィカルに表示され、その他のモデルタイプはテキストで表示されます。
- コンポーネント定義 – コンポーネントのフォルダー、名前、タイプ、参照するドメインモデル、パラメーターデータ、部品候補などを定義する領域です。
ドキュメントオプション
コンポーネントの作成先となるWorkspaceフォルダー、およびコンポーネントに適用するライフサイクル定義と命名スキームを指定するコントロールは、Document Optionsダイアログ(Edit » Document Options)にあります。 また、Component Editorからリリースするコンポーネントのデフォルトの命名スキームを定義することで、Workspaceに作成される各コンポーネントに一意のIDを付与できます。

Workspaceの設定は、Document Optionsダイアログで定義します。
-
Target Server – 新しいコンポーネントを1つ以上作成する場合、作成先のWorkspaceは、現在アクティブに接続しているWorkspaceになります。既存のコンポーネントを編集する場合、このフィールドには、それらのコンポーネントが格納されているWorkspaceが表示されます。ドロップダウンの右側にあるServer Adminボタン(コンポーネントがまだリリースされていない場合に使用可能)をクリックすると、PreferencesダイアログのData Management – Serversページが開き、アクティブなWorkspaceや登録済みのWorkspaceを参照・管理できます。
-
Default Folder – 新しいコンポーネントを1つ以上作成する場合、このフィールドで、保存するコンポーネントの格納先となるWorkspace内のデフォルトフォルダーを指定します。Chooseボタンをクリックすると、Explorerパネルと同様のChoose Folderダイアログが開きます。ここでWorkspace内の既存のフォルダーを参照して選択するか、その場で新しいフォルダーを作成できます。ここで指定した値は、新しいコンポーネント定義を追加する際に、FolderPathのデフォルト値として使用されます。既存のコンポーネントのリビジョンを1つ以上編集する場合、このフィールドには既存のフォルダーが表示され、編集できません。この場合、Chooseボタンも使用できません。Show in Explorerボタンをクリックすると、Explorerパネルで指定したデフォルトフォルダーをすばやく表示できます。
-
Lifecycle DefinitionおよびRevision Naming – これらのフィールドで、それぞれに適したデフォルトのスキーム(それぞれ
Component Lifecycleと1-Level Revision Scheme)を設定します。各フィールドのドロップダウンから、親Workspaceで現在定義されている使用可能なスキームを選択して変更できます。 -
Item Naming – このフィールドでは、Component Editorから保存するコンポーネントのデフォルトのアイテム命名スキームを定義し、Workspaceに作成される各コンポーネントアイテムに一意のIDを付与します。ここで指定した値は、新しく追加したコンポーネント定義に自動で名前を付ける際のテンプレートとして使用されます(対応するItem IDフィールド)。ソフトウェアはWorkspace全体と既存のコンテンツの識別子を確認し、このスキームに基づいて、次に使用可能な一意のIDを自動的に割り当てます。
コンポーネントが格納されている(または作成される)親フォルダーに命名スキームが定義されている場合、そのスキームがデフォルトとして入力されます。定義されていない場合は、デフォルトのスキームである
CMP-{00000}が設定されます。もちろん、フィールドに入力して独自のスキームを作成することもできます。パラメーターに基づくコンポーネント名テンプレートも使用できます。このテンプレートでは、Component Editorでコンポーネントに定義されている現在のパラメーター値に基づいて、コンポーネントに正確な名前を付けたり、名前を変更したりできます。命名テンプレートにパラメーターを含めるには、[<ParameterName>]の形式を使用します。1つのテンプレートに複数のパラメーターを使用できるほか、中括弧で指定するイテレーターマクロ(例:{000}、{00A})も追加できます。また、コンポーネント定義のItem IDフィールドに必要なIDを直接入力して、自動的に割り当てられたIDを上書きすることもできます。アイテムの識別方法は、常にユーザーが完全に制御し、最終的に決定できます。
このダイアログでは、定義済みのコンポーネントテンプレートを参照することもできます。ダイアログの Template にあるコントロールを使用して、テンプレートを選択します。タブ。コンポーネントテンプレートは、Component Editorで定義するコンポーネント定義に使用する設定をあらかじめ用意したものです。追加するコンポーネント定義は、関連付けられたコンポーネントテンプレートに従って作成されます。
必須モデル/パラメーター
エディターのこの領域では、コンポーネント定義に必要なドメインモデルを指定するとともに、すべてのコンポーネント定義に適用するパラメーターデータのセットを作成します。

必須モデルとパラメーターを定義します。
-
Models – 最も基本的な要件として、基板設計で使用するコンポーネントには、回路図とPCBの編集ドメインでの表現が必要です。そのため、回路図シンボルとPCBフットプリントのモデルが必要になります。これらはデフォルトで必須モデルとして追加され、削除できません。この領域のAddおよびRemoveコントロールを使用して、必要に応じてほかのモデルタイプを追加または削除します。
-
Parameters – デフォルトでは、
NameとDescriptionの2つのパラメーター項目があります。これらはシステムパラメーターです。必要に応じて、任意の数のパラメーターを追加できます。追加するには、この領域の下部にあるAddコントロールをクリックし、Parameter項目を選択します。新しいパラメーターがリストに追加されます。Parameter Nameフィールド内をクリックして、必要に応じて名前を変更します。パラメーターを削除するには、そのパラメーターを選択してRemoveコントロールをクリックします。システムパラメーターは削除できません。
エディターのこの領域では、Addメニューから次の操作も行えます。
-
Linking to a Component Template – Templatesサブメニューには、コンポーネント自体が格納されているワークスペースで現在利用可能なすべてのコンポーネントテンプレートが表示されます。項目をクリックすると、そのコンポーネントテンプレートの最新リビジョンへのリンクが作成されます。テンプレートのパラメーターがこの領域に取り込まれ、
アイコンで区別されます。
パラメーターリストテンプレート
コンポーネントテンプレートを使用していない場合でも、Component Editorが対応しているカスタマイズ可能なParameter List Templatesを使用して、あらかじめ定義したパラメーターリストを作成できます。これらのシンプルで人が読みやすいファイルに必要なパラメーターのリストを記述しておけば、ワンクリックでエディターに読み込めます。
パラメーターリストテンプレートは、Required Models/Parameters領域の下部にあるAddコントロールをクリックしてアクセスするTemplatesサブメニューにあります。コンデンサー(Capacitor)、抵抗(Resistor)、ダイオード(Diode)、トランジスター(Transistor)に関連するパラメーターセットを含む、定義済みのテンプレートがいくつか用意されています。

この領域のAddコントロールに関連付けられたメニューから、パラメーターテンプレートにアクセスします。使用するテンプレートをクリックすると、そのテンプレートで定義されているパラメーターがこの領域に追加されます。

パラメーターテンプレートを使用すると、コンポーネントで使用するパラメーターセットをすばやく追加できます。パラメーターテンプレートは、コンポーネントライブラリテンプレートファイル(
*.cmplib_template)で定義されます。システムに認識され、Component EditorのTemplatesサブメニューに表示されるようにするには、これらのファイルをAltium Designerのインストール先にあるTemplatesフォルダー(デフォルトのインストールでは\Users\Public\Documents\Altium\AD<Solution/Version>\Templates)に保存する必要があります。テンプレートの定義はシンプルで、角括弧で囲んだテンプレート名(サブメニューに表示される名前)の後に、必要なパラメーターを
<ParameterName>=の形式で列挙します。例えば、あらかじめ定義されている抵抗用テンプレート(resistor.cmplib_template)は、次のように定義されています。[Resistor]
Category=
Manufacturer=
Manufacturer Part Number=1
Mounting Type=
Temperature=
Package Type=
Package Reference=
RoHS=
Temperature Coefficient=
Tolerance=
Weight=
Height=
Value=
Power=
Resistance=
Composition= -
Enabling the use of Datasheets – これを行うには、Datasheet の項目を選択します。詳細については、コンポーネント定義へのデータシートの添付を参照してください。
-
Adding Part Choices – Part Choices サブメニューから By MPN を選択します。定義領域に項目 Part Choice n が追加され、
ManufacturerとPart Numberの2つの列で選択内容を指定できます。また、Workspace が対応しており、カスタムのデータベース部品ソースを設定済みの場合は、メニュー項目 By Internal ID を選択します。 定義領域に項目 Part Choice n が追加され、Part sourceとInternal IDの2つの列で、社内の部品データベースから部品を選択できます。詳細については、部品の選択を参照してください。
モデルリンク
エディターのこの領域では、コンポーネント定義で使用する、保存済みのドメインモデルへのリンクを追加します。Model Links 領域は、どのコンポーネント定義からでもアクセスできるドメインモデルの「入れ物」と考えることができます。割り当ては、各定義に必要なリンクを指定することで行います。

モデルリンクの定義とコンポーネント定義への割り当てを効率化する機能が充実した Model Links 領域。
モデルリンクの操作について詳しくは、以下の折りたたみセクションを参照してください。
モデルリンクの追加
この領域にモデルリンクを効率よく追加する方法は、次の2つです。
-
特定の Workspace フォルダー内からモデルを選択します。異なるモデルを1つ以上選択することも、同じモデルの異なるリビジョンを1つ以上選択することもできます。Model Links 領域の下にある Add コントロールをクリックしてモデルの種類を選択し、Choose Models ダイアログで実際のモデルを選択します。
-
Explorer パネルからモデルを直接ドラッグ&ドロップします。異なるモデルを1つ以上ドラッグすることも、同じモデルの異なるリビジョンを1つ以上ドラッグすることもできます。

Explorer パネルからドラッグ&ドロップして、1つまたは複数のモデルを追加します。
同じモデルの異なるリビジョンへのリンクを含め、任意の数のモデルリンクを追加できます。各リンクは、モデルの特定の名前付きリビジョンを参照します(例:シンボル SYM-001-0023 のリビジョン1 を参照する SYM-001-0023-1)。選択したモデルリンクの右クリックメニューで Show In Explorer コマンドを使用すると、選択したモデル(およびそのリビジョン)にフォーカスした状態で Explorer パネルをすばやく開くことができます。
モデルリンクを変更するには、その Item ID フィールドをクリックし、続いて
ボタンをクリックします。Choose Model ダイアログが表示され、別のモデル、または同じモデルの別のリビジョンを参照して選択できます。モデルリンクを削除するには、対象を選択して Remove コントロールをクリックします。
最新ではないモデル
モデルリンクの Revision Status フィールドは、そのリンクがモデルの最新リビジョンを参照しているか、より新しいリビジョンが利用可能かを示します。コンポーネントエディターが、リンクされたモデルが最新リビジョンではないことを検出すると、Out of date というテキストが太字で表示されます。
モデルの最新リビジョンを使用するようにリンクを更新するには、モデルの項目内を右クリックし、メニューから Update to Latest Revision を選択します。この操作により、次の処理が行われます。
- 最新リビジョンを参照するようにモデルリンクを更新します。
- コンポーネント定義内でそのモデルを使用しているすべての箇所を、モデルの最新リビジョンを使用するように更新します。
リンクされたモデルの直接編集
コンポーネント定義で使用(参照)されているリンク済みのドメインモデルを編集する必要がある場合は、直接編集の方法を使用すると効率的です。
-
エディターの Model Links 領域でモデルの項目を右クリックし、コンテキストメニューから Edit コマンドを選択します。
-
モデルに対応するエディターの一時的なインスタンスで、モデルが開きます。必要に応じてモデルを変更し、Save to Server コマンド(File メインメニューまたは Quick Access Barから実行、ショートカットは
Ctrl+Alt+S)を使用して、Workspace 内の親アイテムの次のリビジョンとして保存します。Create Revision ダイアログが表示され、別の Name や Description を入力したり、Release Notes フィールドに変更内容のメモを入力したりできます。

コンポーネントエディターの Model Links 領域から、モデルを直接編集して保存します。
Create Revision ダイアログで(影響を受けるアイテムを更新するオプションを無効にした状態で)OK をクリックすると、保存処理が実行されます。一時的なモデルエディターが閉じ、すでに開いているコンポーネントエディターに戻ります。モデルリンクと、そのリンクが定義済みコンポーネントに割り当てられているすべての箇所が、この最新リビジョンに自動的に更新されます。
モデルリンクのコピーの作成
参照されている既存のドメインモデルのコピーを作成するには、Model Links リストでモデルを選択し、右クリックしてコンテキストメニューから Make a Copy コマンドを選択します。処理の流れは、Explorer パネルでアイテムリビジョンのコピーを作成する場合と同様です。
-
直接編集セッションが開始され、選択したモデルリンクのアイテムリビジョンに保存されているソースドキュメントのコピーが、対応する一時的なエディターで開きます。
-
エディターで必要な変更を行います。必要に応じて、名前や説明も変更します。
-
Save to Server コマンドを(File メインメニュー、または Quick Access Bar、ショートカット Ctrl+Alt+S から)選択し、ドキュメントをワークスペースに保存します(ショートカット Ctrl+Alt+S)。Create Item ダイアログが表示されます。デフォルトでは、コピーしたモデルには元のモデルと同じリビジョン命名方式とライフサイクル定義方式が適用され、同じフォルダーに作成されます。これらのプロパティは必要に応じて変更できます。また、元のモデルのアイテムリビジョン ID が Ancestor Revision フィールドに入力されていることにも注目してください。
-
アイテムのプロパティを必要に応じて設定したら、OK をクリックします。新しいアイテムとその初期リビジョンが作成され、ドキュメントがリリースされて、一時的なエディターが閉じます。コンポーネントエディターに戻ると、コピーしたアイテムリビジョンが、モデルリンクのリストの末尾に参照リンクとして追加されます。
モデルリンクのグループ化
モデルリンクは、表示されている任意の列見出しを基準にグループ化できます。列のヘッダーをクリックしたまま、Drag a column header here to group by that column と表示されているテキスト上にドラッグ&ドロップします。
たとえば、次の画像は、Revision Status を基準にモデルリンクをグループ化した例です。これにより、モデルリンクはグループ化の基準となる列の異なる値ごとに分けられます。この例では、Revision Status: Out of date と Revision Status: Up to date の2つのグループが作成されます。
並べ替え
モデルリンクは、列のヘッダーをクリックすることで、その列を基準に並べ替えられます。1回クリックすると、列の内容に基づいて昇順に並べ替えられます。もう一度クリックすると、降順に並べ替えられます。
複数の列を基準に並べ替えることもできます。モデルリンクがすでに特定の列を基準に並べ替えられている状態で、別の列で Shift+Click を行うと、その列の内容を基準にさらに並べ替えられます。
列に基づくフィルタリング
Excel のスプレッドシートと同様に、モデルリンクは各列の内容に基づいてさらに絞り込むことができます。 列のヘッダーの右側にある小さな漏斗(フィルター)アイコン(
)をクリックします。その列に存在する各値のチェックボックスを含むメニューが表示されます。必要なチェックボックスをオンにすると、その値を持つモデルリンクだけがリストに表示されます。
より詳細にフィルタリングを制御するには、(Custom...) を選択して Custom Filter ダイアログを表示します。このダイアログでは、データ列に適用するフィルター条件に基づいて表示する情報の行を指定し、要件に合ったカスタムフィルターを設定できます。
列フィルターが適用されると、フィルターアイコンが青色(
)で表示され、その列に基づくフィルタリングが適用されていることを示します。複数のデータ列にフィルタリングを適用できます。各「列フィルター」は、フィルター全体の中で AND 条件として組み合わされます。現在適用されているフィルターを表すテキストが、領域の下部に表示されます。
現在のフィルターをさらにカスタマイズするには、フィルターを表すテキストの右端にある
ボタンをクリックして、Filter Builder ダイアログを開きます。 このダイアログでは、必要に応じて、より高度で複雑なフィルターを作成できます。
コンポーネントの定義
パラメーター一式を指定し、モデルリンクの「セット」を準備したら、必要なコンポーネントの定義に進むことができます。この作業は、ドキュメントの下部領域で行います。

Component Editorを使用して、論理的で直感的な方法でコンポーネントを定義します。
この領域に最初に表示される内容は、編集するコンポーネントによって異なります。
- 新しいコンポーネントを作成し、親フォルダーからコンポーネントテンプレートがis not参照されている場合、エントリにはFolderPathとItem IDが割り当てられますが、それだけです。いわば白紙の状態です。
- 新しいコンポーネントを作成し、親フォルダーからコンポーネントテンプレートがis参照されている場合、エントリにはそのテンプレートが提供する定義情報があらかじめ入力されます。
- 既存の単一コンポーネントのリビジョンを編集する際に、Single Component Editingモードから切り替えた場合、そのリビジョンと、その時点で定義されている情報が表示されます。
- 選択した複数のコンポーネントリビジョンを編集する場合、つまりBatch Component Editingモードに直接アクセスする場合は、それらのリビジョンがすべて表示されます。
各コンポーネント定義は、以下の情報を含む1行のエントリとして表示されます。
-
Component: FolderPath – このフィールドを使用して、対象のWorkspace内の特定のフォルダーにコンポーネントを保存します。グリッドに新しく追加される各コンポーネントについて、ドキュメントオプションダイアログ(Edit » Document Options)のDefault Folderフィールドでデフォルトの保存先が指定されていれば、このフィールドにその保存先を設定できます。デフォルトのパスが指定されているかどうかにかかわらず、対象のWorkspace内でコンポーネントを保存する場所は自由に指定できます。保存先フォルダーを手動で指定するには、コンポーネントのFolderPathフィールド内を1回クリックして
ボタンを表示し、そのボタンをクリックしてChoose Folderダイアログを開きます。既存のフォルダーを参照して選択するか、その場で新しいフォルダーを作成します。
-
Component: Item ID – このフィールドは、Workspaceに保存されるコンポーネントのIDを決定するために使用します。グリッドに新しく追加される各コンポーネントについて、このフィールドには、Document OptionsダイアログのItem Namingフィールドで指定されたデフォルトの命名規則に従って値が入力されます。ソフトウェアはWorkspace全体と既存コンテンツの識別子をスキャンし、その命名規則に基づいて、次に使用可能な一意のIDを自動的に割り当てます。
デフォルトのアイテム命名規則として
CMP-{00000}が用意されていますが、フィールドに入力して独自の命名規則を作成することもできます。その際、可変部分を波括弧で囲んでください(例:CMP-001-{0000})。また、定義のItem IDフィールドに必要なIDを直接入力して、コンポーネントに自動割り当てされたIDを上書きすることもできます。アイテムの識別方法は、常にユーザーが自由に指定し、最終的に決定できます。 -
Component: Name – コンポーネントに付けられた、人が理解しやすい名前を表示します。このシステムパラメーターはWorkspace内の検索で使用でき、インデックス化されるため、アイテムIDを覚えていなくても特定のコンポーネントを見つけるのに役立ちます。
-
Component: Type – このフィールドではコンポーネントの種類を定義できます。これは、Workspaceコンポーネントの絞り込み検索を容易にするための重要な属性であり、Componentsパネルでコンポーネントを参照する際にも頻繁に使用します。このフィールドをクリックしてから
をクリックすると、Choose component typeダイアログが開きます。このダイアログで、現在定義されているすべての種類から必要なコンポーネントの種類を選択し、OKをクリックします。選択した種類が、メインの定義グリッドのType属性の値として入力されます。
-
Component: Description – コンポーネントに追加された説明が反映されます。このシステムパラメーターは、Workspace 内の検索で使用でき、インデックス化されます。
-
Models – これらのフィールドは、ドキュメントの Required Models/Parameters 領域の項目に対応しています。追加された必須モデルごとに1つのフィールドがあります。ただし、フットプリントモデルは例外で、複数定義できます。各フィールドでは、リンクされたモデル(Model Links 領域内)のうち、コンポーネントに使用するモデルを指定します。
-
Template Parameters – これらのフィールドは、参照先のコンポーネントテンプレートのリビジョンからコンポーネントエディターに取り込まれたユーザーパラメーターに対応しています。パラメーターごとに1つのフィールドがあります。コンポーネント定義内でのパラメーターの左から右への順序は、Required Models/Parameters 領域での上から下への順序に対応します。必要に応じて、該当するパラメーターの値を入力または選択してください。たとえば、テンプレートで Read Only と設定されたパラメーターは編集できませんが、それ以外のパラメーターは編集できます。また、テンプレートで Required と設定されたパラメーターには値を指定する必要があります。値を指定しないと、コンポーネント定義を Workspace に保存できません。
-
Parameters – これらのフィールドは、ドキュメントの Required Models/Parameters 領域に入力した追加のユーザーパラメーターに対応しています。追加パラメーターごとに1つのフィールドがあります。コンポーネント定義内でのパラメーターの左から右への順序は、Required Models/Parameters 領域での上から下への順序に対応します。必要に応じてパラメーターの値を入力してください。
-
Release: Current Rev. – この編集不可のフィールドには、Workspace 内のコンポーネントの現在の(最新の)リビジョンが表示されます。
-
Release: Next Rev. – この編集不可のフィールドには、選択したリビジョン命名規則に従って、コンポーネント定義を次回 Workspace に保存する際に作成されるコンポーネントの次のリビジョンが表示されます。
-
Release: Action – このフィールドには、保存処理の一環として、このコンポーネント定義に対してリリースマネージャーが実行するアクションが表示されます。まだ Workspace に保存されていないコンポーネント定義の場合、この項目には
Create Itemが表示されます。すでに Workspace に保存されている定義の場合は、Create Revisionが表示されます。コンポーネントの計画済みリビジョンが対象となっている場合は、Release To Existing Revisionが表示されます。 -
Part Choice n – この項目は、ドキュメントの Required Models/Parameters 領域に追加した部品候補に対応しています。コンポーネント定義内での部品候補の左から右への順序は、Required Models/Parameters 領域での上から下への順序に対応します。追加した部品候補ごとに
ManufacturerとPart Numberの2つのフィールドがあり、これらで候補を指定します。また、カスタムデータベースの部品ソースを設定し、By Internal ID メニュー項目を使用して部品候補を追加した場合、この2つのフィールドはPart sourceとInternal IDになります。これらを使用して、社内の部品データベースから部品候補を指定します。
コンポーネント定義の操作
以下のセクションでは、エディターのこの領域の操作について、便利で時間の節約にもなる機能を含めて詳しく説明します。
既存のコンポーネントへのモデルリンクの割り当て
既存のコンポーネント定義には、次の方法で必要なモデルリンクを割り当てることができます。
-
モデルリンクをコンポーネント定義の該当する列にドラッグ&ドロップします。

Model Links領域から、既存のコンポーネントの対応するモデル列にドラッグ&ドロップして、モデルを割り当てます。 -
モデル列のドロップダウンフィールドを使用すると、専用のモデルリンクポップアップウィンドウを開くことができます。このウィンドウには、割り当てるモデルタイプに対応する既存のモデルリンクがすべて、全データ列を備えたグリッドで表示されます。コンポーネント定義の数が多くてドラッグ&ドロップしにくい場合や、Model Links領域を含むComponent Editorの上部セクションが折りたたまれている場合に、この方法を使うとモデルの検索と割り当てにかかる時間を大幅に短縮できます。また、同じモデルリンクを複数のコンポーネント定義に割り当てることもできます。ポップアップウィンドウを開く前に、各コンポーネントのモデル列を選択するだけです。
必要に応じてウィンドウのサイズを変更してください。ウィンドウ右下の
コントロールをクリックしてドラッグすると、縦横のサイズを同時に変更できます。ウィンドウ左上の列コントロールボタン
をクリックし、表示する必要のない列を無効にします。列ヘッダーをドラッグすると、列の順序を変更できます。
ポップアップの検索フィールドを使用して、必要なモデルをすばやく見つけます。文字を入力し始めると、すべての列のデータに基づいて、一致する箇所が動的にハイライト表示されます。必要なモデルリンクを選択し、Enterを押すかダブルクリックして、そのモデルを割り当てます。

専用のモデルリンク選択ポップアップを使用して、必要なモデルを検索し、見つけて割り当てます。
モデルがリンクされた新しいコンポーネントの作成
コンポーネント定義がまだ存在しない場合は、次の方法で定義を作成し、必要なモデルリンクを自動的に割り当てることができます。
-
Model Links領域からDefinitions領域内の空いている場所にモデルリンクをドラッグ&ドロップすると、そのモデルを使用する新しいコンポーネント定義が追加されます。

Model Links領域からドラッグ&ドロップして、その場でモデルを割り当て、新しいコンポーネントを追加します。 -
ExplorerパネルからDefinition領域にモデルを直接ドラッグ&ドロップします。そのモデルを使用する新しいコンポーネント定義が追加されます。また、そのモデルがModel Links領域に存在しない場合は、モデルのエントリも追加されます。

Explorerパネルからドラッグ&ドロップして、その場でモデルを割り当て、新しいコンポーネントを追加します。モデルリンクがまだ存在しない場合は、Model Links領域に追加されます。
複数のコンポーネントの追加
Component Editorでは、複数の新しいコンポーネントを一度に追加できます。右クリックしてOperations » Add Componentsコマンドを選択します。表示されるAdd Componentsダイアログで追加するコンポーネントの数を入力し、 OK をクリックすると、指定した数の新しいコンポーネント定義が、コンポーネント定義グリッドの現在のリストの末尾に追加されます。グリッドの複数セル編集機能やコピー/貼り付け機能と組み合わせることで、多数のコンポーネント定義を短時間で作成できます。

簡単な2つの手順で、複数の新しいコンポーネント定義を追加します。
基本的なチップ抵抗の生成
メインメニューからEdit » Operations » Generate Basic Chip Resistors コマンドを選択するか、定義領域内の既存の定義がない場所を右クリックして、コンテキストメニューから Operations » Generate Basic Chip Resistors コマンドを選択することで、チップ抵抗のコンポーネント定義をまとめてすばやく作成することもできます。
コマンドを実行すると、指定されたコンポーネントタイプのコンポーネント定義が自動的に生成されます。
このコマンドで生成されたコンポーネント定義は、既存の定義に追加されます。つまり、新しい定義を生成しても、既存の定義が上書きされることはありません。
メーカー部品検索からのコンポーネントの作成
コンポーネントの作成を効率化するため、Altium Designerでは、メーカー部品検索機能を使用して実在する部品を検索し、Component Editorに追加できます。選択した部品の新しいコンポーネント定義エントリだけでなく、その部品のすべてのパラメーター、データシート、および部品に基づく部品選択も取得できます。あとは各ドメインのモデルを整え、コンポーネントタイプと保存先フォルダーを設定して、Workspaceに保存するだけです。
この機能は、Component EditorのDefinitions領域から利用できます。右クリックして、領域のコンテキストメニューからOperations » Create from Part Searchコマンドを選択します。または、メインメニューから Edit » Operations » Create from Part Search コマンドを選択するか、定義領域内をクリックしてキーボードショートカットShift+Ctrl+Mを使用します。
Manufacturer Part Searchダイアログが表示されます。現在有効になっているサプライヤーが提供する実際の製造部品のデータベースから、必要な部品を検索し、エントリを選択してOKボタンをクリックします。

Manufacturer Part Searchダイアログを開き、Component Editorに取り込む部品を検索します。
OKをクリックすると、次の処理が行われます。
-
選択した部品のコンポーネントエントリが、Component Editorの定義領域に作成されます。この定義には、次の設定が適用されます。
- Component Editorで使用される所定のItem Naming体系に従って、次に使用可能な一意のItem IDが割り当てられます。
-
選択したパーツの Manufacturer Part Number パラメーターの値を、そのパーツの
Nameシステムパラメーターの値として割り当てます。 -
選択したパーツの Description パラメーターの値を、そのパーツの
Descriptionシステムパラメーターの値として割り当てます。
- 選択したパーツに定義されているすべてのパラメーター(ダイアログに表示されているもの)が、Required Models/Parameters リストに追加されます。すべて表示されるように設定されます(対応する Show オプションが有効になります)。これは、デフォルトで Definitions 領域に各パラメーターの列が表示されることを意味します。
-
選択したパーツで利用可能な各データシートについても、パラメーターエントリーが追加されます(
ComponentLinknDescriptionとComponentLinknURLのペアの形式)。 -
定義に Part Choice(
Part Choice 1)が追加され、パーツの Manufacturer および Manufacturer Part Number パラメーターの値が、それぞれその選択肢のManufacturerおよびPart Numberフィールドに入力されます。

Manufacturer Part Search ダイアログで選択したパーツに対して生成された定義と、追加されたパラメーターの例。メーカー部品から取り込まれたデータをハイライトで示しています。
コンポーネントタイプの設定
Component Editor では、コンポーネントの定義を設定する際に、コンポーネントのタイプを指定できます。これにより、Workspace の強力な検索機能を使用して、対象を絞り込んだ検索が容易になります。この機能では、コンポーネントタイプで検索できるだけでなく、単位を認識するコンポーネントパラメーターを利用して、よりスマートに検索できます。Components パネルを使用して自分の Workspace ライブラリを参照する際、コンポーネントの Categories グループ分けは、各コンポーネントに定義されたコンポーネントタイプに基づいて行われます。
コンポーネントのタイプは、定義エリアの Component 領域にある Type 属性で指定します。Type フィールドをクリックし、次に
をクリックすると、Choose component type ダイアログが開きます。このダイアログで必要なコンポーネントタイプを選択し、OK をクリックします。選択したタイプが、メインの定義グリッドの Type 属性の値として挿入されます。

コンポーネント定義の Type 属性を Diode に設定する例。
複数のコンポーネント定義の Type フィールドを、一度の操作で設定できます。対象となる各コンポーネント定義の Type フィールドを選択し、そのうちの1つでタイプを選択すると、他のすべてにも適用されます。
単位を認識するコンポーネントパラメーターのデータ型のサポート
Component Editor は、参照するコンポーネントテンプレート内で定義された、単位を認識するコンポーネントパラメーターのデータ型をサポートしています。コンポーネント定義の該当フィールドに、2.2k、2k2、4M、2.5GHz などのさまざまな形式でパラメーター値を直接入力できます。Workspace には、これらの入力が表す数値を認識する機能が備わっています。
コンポーネントテンプレートのこの機能により、Workspace の検索機能を使用して、対象を絞り込んだ検索が容易になります。この機能では、コンポーネントタイプで検索できるだけでなく、範囲検索によってよりスマートに検索できます。単位を認識するコンポーネントパラメーターを活用すれば、たとえば静電容量が 47uF から 220uF の範囲にあるすべてのコンデンサーを見つける検索を、すばやく設定できます。

参照するコンポーネントテンプレートの、単位を認識するデータ型を持つコンポーネントパラメーター。
単位を認識するデータ型を使用するコンポーネントパラメーターに、コンポーネント定義で必要な値を入力する際は、以下の点に注意してください。
-
値は、さまざまな形式で入力できます。
-
数値のみ(例:
10)。データ型に単位がある場合は、自動的に適用されます。単位を持つデータ型では、名前の後ろの括弧内に単位が表示されます。 -
科学表記の数値(例:
1e10、1E6)。 -
数値と単位(例:
10F))。 -
接頭辞付きの数値(例:
10k)。該当する場合は、適切な単位が自動的に追加されます。 -
接頭辞と単位付きの数値(例:
10kF)。 -
一般的なエンジニアリング形式で接頭辞を含む数値(抵抗値の例:
2k2、2K2、10r2、10R2)。値は自動的に適切な形式に正規化されます(例:2K2は2.2kになります)。
-
数値のみ(例:
-
接頭辞や単位は、数値の後にスペースを入れても、入れなくても入力できます(例:
10uFまたは10 uF)。スペースは自動的に削除されます。
サポートされる単位
以下の単位を認識するデータ型がサポートされています。
- ボルト(V)
- アンペア(A)
- オーム
- ファラド(F)
- ヘンリー(H)
- ワット(W)
- ヘルツ(Hz)
- 摂氏(C)
- デシベル(dB)
- パーセント(%)
- メートル(m)
- グラム(g)
- 秒(s)
対応する接頭辞
次の表は、単位対応のパラメーター型に値を入力する際に使用できる接頭辞を示しています。
| 接頭辞 | 名称 | 値(科学表記) | 値(通常表記) |
|---|---|---|---|
| T | テラ | 1 x 1012 | 1,000,000,000,000 |
| G | ギガ | 1 x 109 | 1,000,000,000 |
| M | メガ | 1 x 106 | 1,000,000 |
| k | キロ | 1 x 103 | 1,000 |
| m | ミリ | 1 x 10-3 | 1 / 1,000 |
| u | マイクロ | 1 x 10-6 | 1 / 1,000,000 |
| n | ナノ | 1 x 10-9 | 1 / 1,000,000,000 |
| p | ピコ | 1 x 10-12 | 1 / 1,000,000,000,000 |
| f | フェムト | 1 x 10-15 | 1 / 1,000,000,000,000,000 |
辞書で定義されたコンポーネントパラメーターのデータ型への対応
コンポーネントエディターは、参照先のコンポーネントテンプレートで設定された、辞書定義のコンポーネントパラメーターデータ型に対応しています。値のセルをクリックしてドロップダウンを使用すると、辞書で定義された選択肢からパラメーターの値を選択できます。値のセルをクリックして値を入力し始めると、ドロップダウンが開き、最も近い値がリスト内で強調表示されます。

参照先のコンポーネントテンプレートに含まれる、単位対応のデータ型を持つコンポーネントパラメーター。
Workspaceの管理者の場合は、値フィールドの右側にある
アイコンをクリックすると、WorkspaceのブラウザーインターフェースのSettings – Vault – Dictionariesページが開き、辞書を管理できます。
コンポーネント名テンプレートの使用
コンポーネントエディターでは、Batch Component Editingモードでのみ、パラメーターベースのComponent Name Templatesを使用できます。このようなテンプレートを使用すると、エディター内のコンポーネントで利用可能なパラメーター(システムパラメーターではなく、ユーザー/テンプレートパラメーター)の現在の定義値に基づいて、コンポーネントの名前、つまりItem IDを正確に設定、または変更できます。命名テンプレートにパラメーターを含めるには、[<ParameterName>]の形式を使用します。たとえば、次のように指定できます。
-
CMP-[Value] -
CMP-[Part Number] -
[Part Number]-[Value] -
[Value] -
[Part Number]
テンプレート内で複数のパラメーター宣言を使用することもできます。例:
-
CMP-[Part Number]-[Value] -
CMP-[Manufacturer Part Number]-[Value]-[Tolerance]
さらに、必要に応じて、波括弧で指定するイテレーターマクロ(例:{000}、{00A})を追加することもできます。例:
-
CMP-[Value]-{001} -
CMP-[Part Number]-{00A}
最も基本的な方法としては、使用する命名テンプレートを、Document OptionsダイアログのItem Namingフィールドにデフォルトの命名規則として入力するだけで設定できます。この場合、初期インデックスは常にゼロになります。より細かく制御するには、名前を変更するコンポーネントを選択し、メインメニューからEdit » Operations » Rename Component(Edit » Operations » Rename n Components)コマンドを選択するか、右クリックしてコンテキストメニューからOperations » Rename Component(Operations » Rename n Components)コマンドを選択します。Component Name Templateダイアログが表示されます。このダイアログで、使用するNaming Schemeを指定し、Initial Indexを設定します(テンプレートにイテレーターマクロが追加されている場合)。

命名テンプレートでCompanyPrtTypeおよびValueパラメーターを使用し、コンポーネントエディターで定義中の選択したコンポーネントの名前をすばやく変更する例。
部品候補
コンポーネントエディターでは、コンポーネントに対して1つ以上のPart Choicesを指定できます。これは、実装済み基板上でそのコンポーネントを実現するために使用できる「許可された」メーカー部品です。メーカー(および部品番号)、サプライヤー(および部品番号)、説明、価格、在庫状況からなる実際のサプライチェーン情報は、WorkspaceのローカルPart Catalogと関連する部品ソースから取得されます。
Required Models/Parameters領域から部品候補を追加します。Addコントロールをクリックし、Part ChoicesサブメニューのBy MPNコマンドを使用してください。カスタムデータベース部品ソースを設定している場合は、代わりにBy Internal IDメニュー項目を選択します。使用する部品候補は任意の数だけ追加できます。
定義中のコンポーネントで使用する部品候補を追加すると、定義エリアにPart Choice nという項目が追加され、その候補を指定するための2つの列が表示されます。これらの列は、選択した部品候補の形式によって異なります。
-
By MPN – 表示される2つの列はManufacturerとPart Numberです。
-
By Internal ID – 表示される2つの列はPart sourceとInternal IDです。

定義中のコンポーネントで使用する部品候補(By MPN)を追加します。マウスポインターを合わせると、By Internal IDとして追加された部品候補の例が表示されます。これにより、社内の部品データベースにある部品を関連付けることができます。
基板の製造・実装時に使用する実際の部品について、メーカー名とメーカー部品番号をそれぞれManufacturerフィールドとPart Numberフィールドに入力します。
次の点に注意してください。
-
部品候補を追加しても、コンポーネント定義でその候補を使用する必要はありません。ただし、2つのフィールドのいずれかに値を入力すると、もう一方のフィールドに赤い枠が表示されます。これは、そのコンポーネントをWorkspaceに保存するには、もう一方の値も入力する必要があることを示しています。
-
フィールドに誤った値を入力し、Workspaceが部品を取得できない場合、テキストはグレーの斜体で表示されます。両方の入力が正しくなると、通常の白いテキストで表示されます。なお、値の大文字と小文字は区別されません。
ダイアログを使用したMPN部品候補の追加
部品候補の対応するセルにメーカー名と部品番号の情報を直接入力することもできますが、メーカー部品を検索できるダイアログを使用する方がはるかに簡単です。この機能を使用するには、まずRequired Models/Parameters領域にPart Choice 1項目を追加し、その候補のセル(定義中の対象コンポーネントに対応するセル)のいずれかをクリックします。エディターのPreview領域に
ボタンが表示されます。このボタンをクリックすると、Add Part Choicesダイアログが開きます。このダイアログは、メーカー部品検索パネル と同じ方法で使用できます(UI要素全体の詳細については、このページを参照してください)。

部品候補の選択 – Add Part Choicesダイアログで必要なメーカー部品を検索し、その項目を選択してOKをクリックします。
ダイアログで必要なメーカー部品を検索して選択し、OKボタンをクリックします。メーカー部品のSPNs項目(Supplier Part Numbers)をクリックすると、その部品を取り扱うサプライヤーが表示され、在庫状況や価格などに基づいて、適切な部品候補かどうかを判断できます。選択した部品は、コンポーネントエディターのPart Choice 1項目のセルとPreview領域の両方に反映されます。

Add Part Choicesダイアログを使用して追加され、コンポーネントエディターに反映された部品候補の例。
必要に応じて
ボタンをクリックし、部品候補を追加していきます。対応するPart Choice n項目は自動的に作成されます。
部品候補を削除するには、リストでその候補を選択し、
ボタンをクリックします。
部品候補によって提供される情報の詳細については、 コンポーネントへのサプライチェーン情報の追加 ページを参照してください。
部品候補の自動順位付け
星の機能を使用してパーツ候補にユーザーランクを定義できるほか、Component Editorで定義・編集しているコンポーネントのパーツ候補に、自動でランクを設定することもできます。
-
コンポーネント定義のエントリを1つ以上選択し、選択範囲を右クリックして、右クリックメニューから Set Part Choice Ranks Automatically コマンドを選択すると、選択したコンポーネントのパーツ候補にランクを設定できます。
-
メインメニューから Tools » Set Part Choice Ranks Automatically コマンドを選択すると、すべてのコンポーネントのパーツ候補にランクを設定できます。
パーツ候補は、設定されたランクに従って、コンポーネント定義グリッドとエディターのプレビュー領域で並べ替えられます。すでにランクが設定されているパーツ候補は、既存の順序を維持します。
コンポーネント定義へのデータシートの添付
Component Editorでコンポーネントを定義する際に、1つ以上のデータシートを1つ以上のコンポーネントに添付できます。たとえば、特定のファミリーに属するすべてのコンポーネントに、同じ必要なデータシートをすばやく添付できます。

Component Editorでコンポーネントを編集する際の、各種データシートのリンク。
コンポーネント定義へのデータシートの添付は、一連の手順で行います。以下に概要を示し、その後のセクションで詳しく説明します。
- データシートの使用を有効にする。
- 選択したコンポーネントにデータシートをアップロードする。
- アップロードしたデータシートを他のコンポーネント定義に割り当てる。
データシートの使用を有効にする
エディターでコンポーネント定義にデータシートを添付するには、まずデータシートの使用を有効にする必要があります。これは、エディターのRequired Models/Parameters領域で行います。この領域の下部にあるAddコントロールをクリックし、コンテキストメニューからDatasheetを選択します。

コンポーネントでのデータシートの使用を有効にします。
選択したコンポーネントへのデータシートのアップロード
データシートの使用を有効にしたら、次にデータシートをアップロードします。基本的には、現在選択しているコンポーネントに任意の数のデータシートをアップロードし、その後、すべてのデータシート、または特定のデータシートを、定義中の各コンポーネントに割り当てることができます。DatasheetエンティティをRequired Models/Parameters領域に追加すると、DatasheetエントリがModel Links領域に表示されます。このエントリをクリックすると、選択したコンポーネントに現在割り当てられている(リンクされている)データシートの一覧がプレビュー領域に表示されます。

データシートの「バケット」と、アップロード済みデータシートの一覧。実際には、各データシートは、それぞれに固有のデータシートアイテムにアップロードされます。
エディターでコンポーネント定義を選択した状態で、次のいずれかの方法により、そのコンポーネントにデータシートをアップロードできます。
- Windowsのエクスプローラーから、プレビュー領域またはそのコンポーネント定義のDatasheetsセルにドラッグ&ドロップする。
- 外部WebブラウザーのWebページからデータシートのリンクを、プレビュー領域またはそのコンポーネント定義のDatasheetsセルにドラッグ&ドロップする。
- プレビュー領域内を右クリックし、コンテキストメニューからAdd Fileコマンドを選択する。Openダイアログで必要なデータシートを参照し、開きます。
アップロード後は、次の操作ができます。
- プレビュー領域のエントリをクリックしてデータシートを開く(または、エントリを右クリックし、コンテキストメニューからOpenを選択する)。
- プレビュー領域のエントリを右クリックし、コンテキストメニューからEditを選択して、データシートのキャプションを変更する。表示されるCaptionダイアログで変更できます。データシートのキャプションの変更は、そのコンポーネントにのみ適用されます。
- プレビュー領域のエントリを右クリックし、コンテキストメニューからDeleteを選択して、コンポーネントからデータシートを削除する。
- プレビュー領域のエントリを右クリックし、コンテキストメニューからSave Asを選択して、ファイルをダウンロードする。
アップロードしたデータシートの他のコンポーネント定義への割り当て
データシートを最初に添付(アップロード)する際は、現在選択しているコンポーネントに対して行います。このシステムの便利な点は、アップロードしたすべてのデータシートを、定義中の他のコンポーネントにもリンクできることです。Datasheetsセルの右側にあるコントロールをクリックして、使用可能なデータシートの一覧を開き、対応するチェックボックスを使用して、コンポーネントへのデータシートの添付または削除を行います。

アップロード済みのデータシートを別のコンポーネント定義に添付する例。
コンポーネント名の妥当性チェック
ソフトウェアは、複数のユーザーがWorkspaceに保存するために作成しているコンポーネントのIDを検証し、アイテムIDの重複を防ぎます。ユーザーがコンポーネントアイテムを作成すると、割り当てられたアイテムIDは「ロック」されます。これにより、最初のユーザーがそのコンポーネントをまだWorkspaceに保存していない場合や、保存しない場合でも、別のユーザーはそのIDを使用できません。他のユーザーがコンポーネント定義の一環としてアイテムIDを手動で変更し、既存のアイテム(または作成予定のアイテム)で使用中のIDを指定した場合、そのIDは適用される命名規則に従って、次に使用可能な未使用のIDに変更されます。
コンポーネント定義のコピーの作成
互いに少しだけ異なるコンポーネント定義をすばやく作成できるように、エディターにはコピー機能が用意されています。既存の定義のコピーを作成するには、定義リストでその定義を選択し、メインメニューからEdit » Make a copy of the componentコマンドを選択するか、右クリックしてコンテキストメニューからMake a copy of the componentコマンドを選択します(ショートカット:Ctrl+D)。コピーは定義リストの末尾に追加されます。
コピーは、以下の点で元のコンポーネント定義とまったく同じになります。
- Workspace内の同じフォルダーを保存先とします。これは、元のコンポーネントが存在するフォルダー、または元のコンポーネントがまだ保存されていない場合はその保存先フォルダーです。
- 同じドメインモデルを参照します。
- Name、Description、Type、テンプレートパラメーター、および追加のユーザー定義パラメーターに同じ値を持ちます。
以下の点は異なります。
-
元のコンポーネントに定義されていたデータシートは含まれません。
-
元のコンポーネントに定義されていた部品候補は含まれません。
-
次に使用可能な一意のアイテムIDが割り当てられます。
-
新しいコンポーネントアイテムの初期リビジョンに保存されるように設定されます(Actionが
Create Itemに設定されます)。

コンポーネント定義をコピーする例。コピー後は、必要に応じて、1つ以上のパラメーター値の変更、部品候補の定義、データシートの追加などを行います。
コピー後は、必要に応じて、1つ以上のパラメーター値の変更などを行います。
コンポーネント定義のグループ化
コンポーネント定義は、表示されている任意の列見出しに基づいてグループ化できます。これを行うには、列ヘッダーをクリックしたまま、Drag a column header here to group by that columnと表示されているテキスト上にドラッグ&ドロップします。
たとえば、次の画像は、Case-Metricパラメーターでグループ化されたコンポーネント定義を示しています。この操作により、グループ化する列の異なる値の数だけコンポーネント定義がグループに分けられます。この例では、9つのグループが作成されます。

列の値に基づいてコンポーネント定義をグループ化した例。ここではCase-Metricパラメーターを使用しています。
コンポーネント定義の並べ替え
列ヘッダーをクリックすると、その列を基準にコンポーネント定義を並べ替えられます。1回クリックすると、その列の内容に基づいて昇順に並べ替えられます。もう一度クリックすると、降順に並べ替えられます。
複数の列で並べ替えることもできます。コンポーネント定義を特定の列ですでに並べ替えている状態で、別の列をShift+Clickすると、その列の内容に基づいてさらに並べ替えられます。
列に基づくコンポーネント定義のフィルタリング
Excelスプレッドシートと同様に、各列の内容に基づいてコンポーネント定義をさらに絞り込むことができます。 これを行うには、列ヘッダーの右側にある小さな漏斗(フィルター)アイコン(
)をクリックします。その列に含まれる各値のチェックボックスを備えたメニューが表示されます。必要なチェックボックスをオンにすると、その値を持つコンポーネント定義のみがリストに表示されます。
より詳細に絞り込みを制御するには、(Custom...)を選択してCustom Filterダイアログを表示します。このダイアログでデータ列に適用するフィルター条件に基づいて表示する情報の行を指定し、要件に合ったカスタムフィルターを設定します。
列フィルターが適用されると、フィルターアイコンが青色(
)で表示され、その列に基づく絞り込みが適用されていることを示します。複数のデータ列にフィルターを適用できます。各「列フィルター」は、フィルター全体においてANDで結合された条件になります。現在適用されているフィルターを表すテキストが、領域の下部に表示されます。
現在のフィルターをさらにカスタマイズするには、フィルターを表すテキストの右端にある
ボタンをクリックして、Filter Builderダイアログを開きます。

Filter Builderダイアログを使用して、より高度なフィルターを作成します。
このダイアログでは、必要に応じて、より高度で複雑なフィルターを作成できます。
-
Filter - クリックすると、追加のフィルター条件にアクセスできます。Clear All をクリックすると、すべてのフィルターが解除されます。選択肢は次のとおりです。
- Add Condition - クリックすると、equals、betweenなどのフィルター条件を追加できます。
- Add Group - クリックすると、AND、ORなどのフィルターグループを追加できます。
-
Links - 各リンクをクリックして、フィルターをさらに定義します。
- Id - 各リンクをクリックして、Description、Nameなど、絞り込みに使用する項目を選択します。
- ANDなど - 各リンクをクリックして、ORなどの論理演算子/種類を指定します。
- like - 各リンクをクリックして、equals、is blank、is greater thanなどの演算子を指定します。
- <empty> - 各リンクをクリックして、条件値を追加します。リンクをクリックした後、テキストボックスに必要な値を入力します。
- press the button to add a new condition - クリックすると、条件を追加できます。
データの表示
定義するコンポーネントの種類によっては、パラメーターの数が非常に多くなることがあります。これらがほかのデータ列に加わると、内容が入り組んで一部しか判読できなくなる場合があります。これに対応するため、コンポーネント定義領域には2つの表示モードが用意されています。領域の右下にあるコントロールを使用して、モードを切り替えます。
- Best Fit – このモードでは、各データ列の幅が、その列の最も長いデータに合わせて調整され、さらに少し余白が追加されるため、列内のすべてのデータを表示できます。各列がデータを表示できる幅になるため、列全体が現在の表示領域を超える場合があります。その場合でも読みやすいように、水平スクロールバーが用意されています。
- Auto Width – このモードでは、ソフトウェアが必要に応じて列幅を拡大または縮小し、グリッドの表示領域内にすべてのデータ列を表示しようとします。データ列がそれほど多くない場合は便利ですが、列数が多いと読みづらくなることがあります。

Auto WidthおよびBest Fit表示モードの使用例。
コンポーネント定義 – 編集テクニック
作成するコンポーネントによっては、Component Editorに多数のコンポーネント定義が含まれることがあります。定義間の違いがわずかで、多くの定義に同様のモデル情報やパラメーター情報が必要になる場合もあります。このドキュメントでは、1つまたは複数のコンポーネント定義をすばやく変更できる、さまざまな編集機能がサポートされています。
-
モデルとパラメーターでは、複数セルの編集が可能です。標準のCtrl+ClickおよびShift+Clickのキーボード操作を使用して、列内の複数のデータセルを選択し、操作できます。複数のコンポーネントにモデルを割り当てるには、セル範囲を選択してからドロップダウンをクリックし、モデルリンクのポップアップウィンドウを表示します。ポップアップ内で目的のモデルをダブルクリックすると、選択したすべてのモデルセルにそのモデルが割り当てられます。
パラメーターの場合は、同じ列内で必要なセルを選択し、フォーカスされているセルに必要な値を入力してから、別の場所をクリックするかEnterを押します。選択したすべてのセルに同じ値が設定されます。
-
選択したデータセル間で、Ctrl+X、 Ctrl+C、Ctrl+Vをそれぞれ使用して、データの切り取り、コピー、貼り付けができます(右クリックメニューまたはメインのEditメニューにある対応するコマンドも使用できます)。
-
Deleteキーを使用すると、選択したデータセルの内容を消去できます(右クリックメニューのClear Contentsコマンド、またはメインメニューの Edit » Clear Contents コマンドも使用できます)。
-
選択したコンポーネント定義は、それぞれCtrl+Shift+C、 Ctrl+Shift+X、Ctrl+Shift+Vを使用してコピー、切り取り、貼り付けができます(右クリックメニューまたはメインのEditメニューにある対応するコマンドも使用できます)。
- 選択したコンポーネント定義を完全に削除するには、コンポーネント定義グリッドの下にあるRemove Componentコントロール、右クリックメニューまたはメインのEditメニューにあるRemove <ComponentName> (Remove n Components)コマンド、あるいはCtrl+Delショートカットを使用します。
-
グリッドの内容を更新するには、メインの Editまたは Viewメニュー、あるいはメイングリッド領域の右クリックメニューにあるRefreshコマンドを使用するか、F5キーボードショートカットを使用するか、Component Library Standardツールバーの
ボタンをクリックします。
- 選択したデータセルをWindowsのクリップボードにコピーして、外部の表計算アプリケーションで編集できます。外部のスプレッドシートにあるコンポーネント定義情報を、コンポーネント定義領域に貼り付けることもできます。
保存済みの定義を参照する
Workspaceに保存したコンポーネントは、ComponentsパネルまたはExplorerパネルを使用して、Workspace内で直接参照できます。
すでに保存されていて、現在編集中のコンポーネントについては、定義領域内のエントリを右クリックしてOperations » Show in Explorerコマンドを選択するか、メインメニューから Edit » Operations » Show In Explorer コマンドを選択すると、Component EditorからWorkspace内の該当するComponent Itemに直接移動できます。

保存済みコンポーネントのリビジョンを編集用に開いている場合、Component EditorからExplorerパネル内のそのコンポーネントに直接移動できます。
既存のComponent Itemを対象にする
通常、対象のWorkspace内でのコンポーネントの作成は、保存プロセスの一部として行います。コンポーネント定義を追加し、Item IDを割り当てれば準備は完了です。いわば、その場でコンテンツを作成する方法です。ただし、Workspace内に直接コンポーネントを作成済みである場合や、直接作成してからその既存コンポーネントにリンクしたい場合もあります。また、既存のリリース済みコンポーネント定義に関連付けられている対象のComponent Itemを変更したい場合もあります。
コンポーネント定義の右クリックメニューにあるOperationsサブメニュー(およびメインメニューの Edit » Operations サブメニュー)には、手動で作成したコンポーネントに定義をリンクするためのコマンドが用意されています。
-
Change Link To Target Item — このコマンドを使用するとChoose Target Itemダイアログが開き、Workspace内で必要なコンポーネントを参照して選択できます。
対象のWorkspace内の既存コンポーネントにリンクすると、コンポーネント定義の Item ID はグレー表示になり、編集できなくなります。
-
Clear Link To Target Item (Clear Links To Target Items) — このコマンドを使用すると、Workspace内の既存コンポーネントへのリンクを解除できます。コンポーネント定義のリリース関連フィールドは、新しいItemを作成できる状態に戻ります。
新しい一連のコンポーネントとして再リリースする必要がある場合、リンクの解除が必要になることがあります。たとえば、以前リリースしたコンポーネントをWorkspaceから削除した場合でも、ソースライブラリにはリンクが定義されたまま残ります(ただし、Workspace内のコンポーネントが見つからないため、リンクは無効です)。
コンポーネント定義をすでに保存している場合、この操作によって、その定義と以前リンクされていたコンポーネントの相互の関連付けが実質的に失われます。
対象のWorkspace内の既存コンポーネントへのリンクを解除すると、コンポーネント定義の Item ID が編集可能になります。グリッドの Release 領域にある Action フィールドのエントリは Create Item に変わり、そのコンポーネント定義が現在、対象のWorkspace内のコンポーネントにリンクされていないことを示します。
コンポーネントルールチェックを実行する
Component Editorで定義または編集したWorkspaceライブラリのコンポーネントを、接続先のWorkspaceに保存して設計で使用できるようにする前に、設定された条件に従って、そのコンポーネントが要件を満たしていることを確認する必要があります。Component Editorでは、コンポーネントをWorkspaceに保存しようとしたとき、またはこの機能を手動で実行したときに、検証( Component Rule Check )が実行されます。
リンクされたシミュレーションモデルについて
Related page: シミュレーションモデルの作成
シンボルモデルやフットプリントモデルと同様に、コンポーネントはシミュレーションモデルのリビジョンを参照することもできます。この種類のモデルリンクの追加方法は、シンボルやフットプリントの場合とまったく同じなので、詳細は前のセクションを参照してください。ここでは、コンポーネントレベルのシミュレーションパラメーターの追加と、ピンマッピングの設定について説明します。
コンポーネントレベルのシミュレーションパラメーターの追加
設計内のコンポーネントにシミュレーションモデルを使用する場合、そのモデル固有のパラメーターを次の2つの異なるレベルで指定できます。
- Model-Level Parameter – シミュレーションモデル定義自体(SimModelファイル内)の一部として指定され、その定義とともに、リンクされたシミュレーションモデルのリビジョンに保存されます。
- Component-Level Parameter – コンポーネント定義(ここではComponent Editor内)の一部として指定され、その定義とともに、リンクされたコンポーネントのリビジョンに保存されます。
コンポーネントレベルのパラメーターは、Component EditorのRequired Models/Parameters領域で追加します。パラメーター名は、モデルレベルで定義されているパラメーター名と同じでなければならない点に注意してください。モデルレベルのパラメーターを確認し、コンポーネントレベルで追加できるパラメーターとその名前を調べるには、SIMモデルのリンクを選択し、プレビューウィンドウ下部のView Parametersコントロールをクリックします。

Simulation Model Itemのモデルレベルのパラメーターを表示して、コンポーネントレベルで追加できるパラメーターと、その名前を確認します。
使用可能なモデルレベルのパラメーターを確認したら、それらと同じパラメーターをコンポーネントレベルに追加し、コンポーネント定義で使用できるようにします。これを行うには、Required Models/Parameters領域の下部にあるAddコントロールをクリックし、メニューからParameterを選択します。新しいパラメーター項目がリストに追加されます。必要に応じて名前を変更してください。その際、対応するモデルレベルのパラメーター名と完全に一致させる必要があります。

シミュレーション関連のパラメーターをコンポーネントレベルに追加します。この例のコンポーネントが参照するコンポーネントテンプレートにより、すでに1つのパラメーター (Area Factor) が用意されている点に注目してください。
ピンマッピング
必要なSIMモデルへのリンクを選択したら、回路図上で表現されるコンポーネントのピンが、シミュレーションモデルのピンに正しくマッピングされていることを確認する必要があります。この設定は、Pin Mappingダイアログで行います。このダイアログを開くには、コンポーネント定義のSIMモデル項目を右クリックしてコンテキストメニューからOperations » Edit Pin Mappingを選択するか、SIMモデルのセルを選択してメインメニューから Edit » Operations » Edit Pin Mapping コマンドを選択します。 各回路図ピンについて、ドロップダウンを使用して、対応するModel Pin項目を適切に変更します。デバイスが複数のパートで構成されている場合は、各パートのマッピングを必ず確認してください。









。
。

)に変換するよう提案されます。パラメーターを部品候補にコピーまたは移動することを選択すると、新しい部品候補が作成され、その ManufacturerとPart Numberの値がパラメーターの値に基づいて設定されます。



