PCBフットプリントの作成

作成される基板上でコンポーネントが占有する領域は、コンポーネントのフットプリントによって定義されます。一般的なフットプリントにはパッドとコンポーネントオーバーレイが含まれ、必要に応じてその他の機械的な詳細も含めることができます。以下のフットプリント例では、このコンポーネントが基板の切り欠き部分に張り出すように実装されるため、コンポーネント外形の大部分は(黄色の)オーバーレイではなく、機械レイヤー上(緑の線)で定義されています。

フットプリントは、コンポーネントが占有する空間を定義し、コンポーネントのピン/パッドから基板上の配線への接続点を提供します。 
フットプリントは、コンポーネントが占有する空間を定義し、コンポーネントのピン/パッドから基板上の配線への接続点を提供します。

そのフットプリント上に実装されるコンポーネントは、3D Bodyオブジェクトを使用してモデル化できます。3D Bodyオブジェクトは、以下の画像に示すように、汎用的な MCAD形式のモデルをインポートするためのコンテナとして使用されます。

適切なMCADモデルは、3D Bodyオブジェクトにインポートできます。
適切なMCADモデルは、3D Bodyオブジェクトにインポートできます。

Manufacturer Part Search panelのように、すぐに使えるPCBコンポーネントを提供する豊富なリソースがあったとしても、設計業務のどこかの段階でカスタムPCBコンポーネントを作成する必要が生じる可能性は高いでしょう。PCBコンポーネントのフットプリントは、PCBエディターで利用できるものと同じプリミティブオブジェクト群を使って、PCB Footprintエディターで作成します。フットプリントに加えて、会社のロゴ、製造定義、その他の基板設計時に必要なオブジェクトもPCBコンポーネントとして保存できます。

新しいPCBフットプリントの作成

フットプリントは、接続されたWorkspace内に直接作成できます。手順は次のとおりです。

  1. メインメニューから File » New » Library を選択し、開いた New Library ダイアログで、ダイアログ内の Workspace 領域から Create Library Content » Footprint を選択します。

    New Library ダイアログを使用して新しいWorkspace Footprintを作成します
    New Library ダイアログを使用して新しいWorkspace Footprintを作成します

  2. 開いた Create New Item ダイアログで必要な情報を入力し、 Open for editing after creation オプションが有効になっていることを確認して、 OKをクリックします。Workspace Footprintが作成され、一時的なPCB Footprintエディターが開き、 .PcbLib ドキュメントがアクティブドキュメントとして表示されます。このドキュメントは、Item-Revisionに従って <Item><Revision>.PcbLib の形式(例: PCC-001-0001-1.PcbLib)で命名されます。このドキュメントを使用して、以下で説明するようにフットプリントを定義します。

    Workspace Footprintの初期リビジョンを編集している例。一時的なPCB footprintエディターは、フットプリントを定義するためのドキュメントを提供します。
    Workspace Footprintの初期リビジョンを編集している例。一時的なPCB footprintエディターは、フットプリントを定義するためのドキュメントを提供します。

  3. フットプリントの定義が完了したら、 Projects パネル内のフットプリントの entry 右側にある Save to Server コントロールを使用してWorkspaceに保存します。 Edit Revision ダイアログが表示され、必要に応じてName、Descriptionの変更やリリースノートの追加を行えます。保存後、ドキュメントとエディターは閉じられます。

保存済みのWorkspace Footprintは、Component Editor の Single Component Editing mode または Batch Component Editing modeでコンポーネントを定義する際に使用できます。

Workspace Footprintsは Components panel で参照できます。パネル上部の  ボタンをクリックして Models を選択し、モデルの表示を有効にしてから、 Footprints カテゴリを選択します。

Workspace Footprintを編集するには、Components panel 内のそのエントリを右クリックし、Edit コマンドを選択します。すると再び一時エディターが開き、フットプリントが編集用に開かれます。必要な変更を加えた後、そのドキュメントをWorkspace Footprintの次のリビジョンとして保存します。

編集したフットプリントをWorkspaceに保存する際、フットプリントの現在のライフサイクル状態を保持できます。これは、再保存時に表示される Create Revision ダイアログ内の Preserve lifecycle state (not recommended) オプションで制御できます()。このオプションを有効にすると、新しいフットプリントのリビジョンは自動的に前のリビジョンと同じライフサイクル状態に設定されます。この機能は、Allow to skip lifecycle state change for new revisions の運用権限が割り当てられているユーザーが利用できます(Setting Global Operation Permissions for a Workspace も参照してください)。

また、Component Editor の Single Component Editing mode または Batch Component Editing modeでWorkspace Componentを編集中に、そのWorkspace Componentで使用されているWorkspace Footprintをその場で直接更新することもできます。
  • 設計者の視点では、Workspace Component は、そのコンポーネントをすべての設計ドメインで表現するために必要なすべての情報を、単一のエンティティにまとめたものです。この意味で、これは一種のコンテナ、すなわちすべてのドメインモデルとパラメトリック情報を格納する「バケツ」と考えることができます。各ドメインでの表現という観点では、Workspace Component 自体がWorkspaceドメインモデルを内包しているわけではなく、それらのモデルへのリンクを保持しています。これらのリンクは、コンポーネント定義時に指定されます。
  • PCBフットプリントは、既存の旧世代ライブラリ(SchLib、PcbLib、IntLib、DbLib、SVNDbLib)からコンポーネントをインポートする一環として、Workspace内に作成することもできます。このプロセスのインターフェースである Library Importer は、最初に選択したライブラリをWorkspaceへ取り込むための直感的なフローを提供します。詳細は、 Library Importerをご覧ください。
  • 新しいWorkspace Footprintは、Component Editor in its Single Component Editing mode でWorkspace Componentを定義する際にも作成できます。
  • フットプリントは、file-based PCB footprint library の一部として作成することもできます。

PCBフットプリントの定義

フットプリントは、最終的に基板のどちら側に配置される場合でも、常に上面側に構築されます。使用するツールや設計オブジェクトは、PCBエディターで利用できるものと同じです。表面実装パッドやソルダーマスク定義などのレイヤー固有の属性は、コンポーネント配置時にフットプリントを基板の反対面へ反転すると、自動的に適切な下面側レイヤーへ転送されます。

設計オブジェクトは任意のレイヤーに配置できますが、通常、外形は Top Overlay(シルクスクリーン)レイヤー上に、パッドはマルチレイヤー(スルーホール部品のピン用)またはトップシグナルレイヤー(表面実装部品のピン用)上に作成されます。フットプリントをPCB上に配置すると、フットプリントを構成するすべてのオブジェクトは、それぞれ定義されたレイヤーに割り当てられます。

ジョイスティック部品用フットプリントの2D表示と3D表示。3D画像には、その部品用にインポートされたSTEPモデルが示されています。STEPモデルの下にパッドとコンポーネントオーバーレイが見えている点に注意してください。
ジョイスティック部品用フットプリントの2D表示と3D表示。3D画像には、その部品用にインポートされたSTEPモデルが示されています。STEPモデルの下にパッドとコンポーネントオーバーレイが見えている点に注意してください。

このページに示されているフットプリントは、必要な手順を説明するためのものであり、寸法的に正確ではありません。新しいフットプリントは、必ずメーカーのデータシートと照らし合わせて仕様を確認してください。

コンポーネントフットプリントを手動で作成する際の一般的な手順は次のとおりです。

  1. 設計空間を準備する: スナップオプションを定義し、グリッドとガイドを設定します - 詳細はこちら

  2. フットプリントは、PCB footprint editor 中央の設計空間基準点を中心に作成する必要があります。この基準点は、実際には設計空間の相対原点であり、Place および Move 操作時にコンポーネントフットプリントがカーソルでつかまれる位置となります(Preferences ダイアログの PCB Editor – General ページにある現在の Object Snap Options によります)。J, R ショートカットキーを使うと、この基準点へ直接移動できます。フットプリントの作成を始める前に基準点へ移動するのを忘れていた場合は、Edit » Set Reference サブメニューのコマンドを使って、基準パッドをフットプリント側へ移動できます。
    • Pin 1 - コンポーネント基準点を、コンポーネントフットプリントのピン1に設定します。

    • Center - コンポーネント基準点を、コンポーネントフットプリントの中心に設定します。

    • Location - コンポーネント基準点を、ユーザー定義位置に設定します。

    選択した点は 0,0 に設定され、新しい相対原点となり、すべてのプリミティブの位置はこの点を基準に更新されます。

  3. コンポーネント要件に従って pads (Place » Pad)を配置します。Place Pad コマンドを実行した後、最初のパッドを配置する前に Tab キーを押して Properties panel を開き、パッドの DesignatorSize and ShapeLayer、および(スルーホールパッドの場合は)Hole Size を含む、すべてのパッドプロパティを定義します。Designator は、続けてパッドを配置する際に自動的にインクリメントされます。表面実装パッドの場合は Layer Top Layer に設定します。スルーホールパッドの場合は Layer Multi-Layer に設定します。

    一部のフットプリントでは、不規則な形状のパッドが必要になります。これは Custom Shape のパッドオブジェクトを使用して実現できます。詳細については、 Customizing a Pad Stack ページを参照してください。
    • 新しいコンポーネントフットプリントを作成するうえで最も重要な作業の1つは、コンポーネントをPCBにはんだ付けするために使用するパッドを配置することです。これらは、実際のデバイス上のピンに対応するよう、正確な位置に配置しなければなりません。
    • また、パッドの番号付けにも注意が必要です。というのも、Altium Designer はこのプロパティを使用して、回路図シンボル上のピン番号とのマッピングを行うからです。
  4. パッドを正確に配置するため、この作業専用のグリッドを設定することを検討してください。Ctrl+G ショートカットキーで Cartesian Grid Editor dialog を開き、Q キーでグリッドを Imperial と Metric の間で切り替えます。

  5. マウスで移動しながらパッドを正確に配置するには、キーボードの矢印キーを使って、現在のグリッド刻みでカーソルを移動します。さらに、Shift を押しながら操作すると、グリッドの10倍刻みで移動します。現在の X、Y 位置はステータスバーおよび Heads Up 表示にも表示されます。Heads Up Display には、位置情報に加えて、最後にクリックした位置から現在のカーソル位置までの差分も表示されます。 Shift+H ショートカットを使って Heads Up 表示のオン/オフを切り替えます。あるいは、配置済みパッドをダブルクリックして編集し、Properties panel に必要な X および Y 位置を入力することもできます。

  6. 設計空間内の2点間距離を確認するには、Reports » Measure Distance を使用します(ショートカット Ctrl+M)。ステータスバーの指示に従ってください。

  7. ソルダーマスクやペーストマスクなどのパッド固有属性は、パッド寸法と適用されるマスク設計ルールに基づいて自動計算されます。各パッドに対してマスク設定を手動定義することも可能ですが、そうすると基板設計プロセスの後半でこれらの設定を変更しにくくなります。通常、これは設計ルールでそのパッド群を対象にできない場合にのみ行われます。なお、ルールは基板設計時にPCBエディターで定義します。

  8. Top Overlay レイヤー上にトラック、アーク、その他のプリミティブオブジェクトを配置して、PCBシルクスクリーンに表示されるコンポーネント外形を定義します。配置時にコンポーネントを基板下面へ反転した場合、オーバーレイは自動的に Bottom Overlay レイヤーへ転送されます。

  9. 配置コートヤードなどの追加の機械的詳細を定義するために、機械レイヤー上にトラックやその他のプリミティブオブジェクトを配置します。機械レイヤーは汎用レイヤーです。これらのレイヤーの用途はあらかじめ割り当て、各フットプリントで一貫して使用する必要があります。

  10. PCBに実装される物理コンポーネントの三次元形状を定義するために、3D Body objects を配置します。

    フットプリントに追加された 3D Body オブジェクトは、接続されたWorkspaceにアップロードされた3D モデル を参照することがあります。
  11. Designator および Comment 文字列は、PCB設計空間へ配置する際に自動的にフットプリントの Overlay レイヤーへ追加されます。追加の Designator および Comment 文字列は、機械レイヤー上に .Designator.Comment の特殊文字列を配置することで含めることができます。

    Designator および Comment 文字列を配置する際には、PCBエディターで Layer Pair を定義する必要があります。これにより、これらの文字列がコンポーネント実装面に追従し、コンポーネントが反転されたときには基板の反対面へ切り替わることが保証されます。詳細については、以下の Handling Special Layer-specific Requirements セクションを参照してください。
  12. Properties panel の Library Options モード(設計空間で何も選択されていないときにアクティブ。メインメニューの Tools » Footprint Properties コマンドからアクセス可能)にある Footprint タブで、フットプリントのプロパティ(名前や説明など)を定義します。利用可能なオプションとコントロールの詳細については、以下のセクションを参照してください。

  • すべてのフットプリントでパッド/ビア定義を標準化するには、Pad/Via ライブラリ(*.PvLib)を Pad/Via 配置に使用できます - 詳細はこちら
  • PCB Footprint エディターには、フットプリント作成プロセスを迅速化するためのウィザードも用意されています。
    • IPC Compliant Footprint Wizard – は、IPC 規格 7351 Revision B に真に準拠した PCB フットプリントを生成します - Generic Requirements for Surface Mount Design and Land Pattern Standard – 詳細はこちら
    • file-based PCB footprint library を使用して作業する場合、IPC Compliant Footprints Batch Generator  では IPC Compliant Footprints Batch Generator を使用して、複数の密度レベルで複数のフットプリントをすばやく生成できます - 詳細はこちら
    • Footprint Wizard – さまざまなパッケージタイプから選択し、適切な情報を入力することで、コンポーネントフットプリントを自動作成できます - 詳細はこちら

設計空間の準備

デフォルトでは、グリッドはドットで表示されます。必要に応じて、グリッドを線で表示することもできます。これは、以下の画像に示すように Properties panel の Properties ボタンをクリックして開く Grid Editor dialog で設定します。あるいは、Ctrl+G ショートカットを押してダイアログを開くこともできます。

画像では、細かいグリッドがドットで表示され、粗いグリッドが線で表示されています。
画像では、細かいグリッドがドットで表示され、粗いグリッドが線で表示されています。

Properties Panel

PCB footprint エディターでフットプリントを編集中に、設計空間で現在どの設計オブジェクトも選択されていない場合、Properties panel には Library Options が表示されます。

以下の折りたたみ可能なセクションには、パネルの General タブで利用できるオプションとコントロールに関する情報が含まれています。

以下の折りたたみ可能なセクションには、パネルの Footprint タブで利用可能なオプションとコントロールに関する情報が含まれています。

Footprint パネルの Properties タブを使用してフットプリントプロパティを定義する機能は、PCB.FootprintParameters オプションが Advanced Settings dialog で有効になっている場合に使用できます。このオプションが無効の場合、フットプリントプロパティは、メインメニューから Tools » Footprint Properties コマンドを選択するか、PCB Library パネルの Footprints 領域でフットプリントエントリを選択して Edit ボタンをクリックするか、または PCB Library パネルの Footprints 領域でフットプリントエントリをダブルクリックしてアクセスする PCB Library Footprint ダイアログ()を使用して定義します。

設計オブジェクトが選択されると、パネルにはそのオブジェクトタイプ固有のオプションが表示されます。次の表は、PCB フットプリントのデザインスペース内に配置可能なオブジェクトタイプを一覧表示したものです。リンクをクリックすると、そのオブジェクトのプロパティページにアクセスできます。

3D Body Arc
Arc Keepout Fill
Fill Keepout Pad
Region Region Keepout
Text (String, Text Frame) Track
Track Keepout Via

はんだマスクおよびペーストマスクの拡張

PCB フットプリントエディタで、はんだマスクやペーストマスクが正しく定義されているか確認するには、View Configuration panel を開き、各マスクレイヤーの表示オプション()を有効にします。

各パッドの外周に Top Solder Mask レイヤーの色で表示されるリングは、multi-layer がレイヤー描画順の最上位にあるため、マルチレイヤーパッドの下から拡張量分だけ突出したはんだマスク形状の外縁を表しています。これは最前面に描画されます。Layer Drawing Order Preferences ダイアログの PCB Editor - Display page で設定します)。

下の画像は、各パッドの外周に紫色(Top Solder Mask レイヤーの色)の境界が表示された PCB フットプリントを示しています。

レイヤーをすばやく切り替えて確認するには、Single Layer Mode(Shift+S)を Ctrl+Shift+Wheel roll と組み合わせて使用します。

デフォルトでは、マスクレイヤー上に作成される形状はパッド形状であり、フットプリントが配置される PCB で設定された Solder Mask Expansion および Paste Mask Expansion デザインルールで指定された量だけ拡張または縮小されます。場合によっては、これらの拡張デザインルールをオーバーライドして、パッド属性としてマスク拡張を指定したり、あらかじめ定義された標準マスク形状セットから選択したり、独自のカスタム形状を作成したりする必要があります。そうした場合は、選択したパッドの Properties パネルでペースト/はんだマスクを設定できます - 詳細はこちら。あるいは、必要なマスクレイヤー上に適切なプリミティブ(Region、Track など)を配置することもできます。

PCB ライブラリでは、ルールドリブンのはんだマスク拡張を持つすべてのオブジェクトの拡張値は 0 mil になります。この機能は、PCB.SolderMaskZeroExpansion オプションが Advanced Settings dialog で有効になっている場合に利用できます。このオプションが無効な場合、PCB ライブラリ内のそのようなオブジェクトのはんだマスク拡張値は 4 mil になります。

パラメータサポート

Altium Designer でオブジェクトに適用されるパラメータは、PCB 設計に追加情報を付加するための強力かつ柔軟な手段を提供します。親オブジェクトのプロパティとして適用されるパラメータは、プロジェクト、ドキュメント、テンプレート、設計ドキュメント内の個々のオブジェクトなど、さまざまなレベルに適用できます。

詳細は Parameter object を参照してください。

PCB 空間で利用可能になったパラメータは、Query、Design Rule、Script、Variant のフィルタリングに使用でき、配置済みフットプリント内でカスタム文字列を呼び出すために PCB コンポーネントフットプリントにも適用できます。

Engineering Change Order によるパラメータ

PCB パラメータ機能は、ユーザー定義のコンポーネントパラメータを PCB 空間へ転送して保持できる ECO メカニズムおよび PCB ドキュメントに含まれる機能に基づいています。これは一方向の転送であり、転送されたパラメータは PCB ドメインでは読み取り専用です。

パラメータ転送は、回路図から PCB へ ECO を作成し、 Design » Update PCB Document メニューコマンドを使用して実行されます。

ECO が実行されると( Execute Changes ボタンを使用)、新しいユーザー定義の回路図コンポーネントパラメータは、PCB 設計内の対応するフットプリント参照に転送されます。 

PCB へのパラメータの検出と移行は、プロジェクトのオプション設定(Project » Project Options)によって決まります。Project Options ダイアログで、 Comparator タブの Differences Associated with Parameters セクションおよび ECO Generation タブの Modifications Associated with Parameters セクションで差分検出と変更動作を設定します。

PCB エディタで転送されたパラメータを表示するには、コンポーネントをダブルクリックして Properties パネルを開き、Parameters タブを選択します。 このタブには、選択したコンポーネントフットプリントに割り当てられている現在のユーザーパラメータが一覧表示されます。選択したコンポーネントフットプリントのパラメータは、Components パネルでも使用できます。

情報参照リンク

PCB ドメインは、回路図から定義済みの ComponentLink パラメータを自動的に受け入れます。これらは通常、特定のファイルやインターネット上の場所へのデータ参照リンクを確立するパラメータのペア(Description と link URL)として定義されます。一般的にはメーカーの Web サイトやデータシート URL です。

参照リンクパラメータについては、回路図ライブラリでの Defining Clickable Links to Reference Information および PCB ドキュメントでの Accessing Clickable Links to Reference Information を参照してください。

回路図および PCB の両方の設計空間で、リンクはコンポーネント上にカーソルを合わせた際の右クリックコンテキストメニュー( References サブメニューオプションの下)からアクセスします。これらの特殊パラメータは Properties パネルで追加され、PCB 空間へ転送されるとコンポーネントフットプリントパラメータとして表示されます。 

ソースフットプリント内のパラメータ

PCB に渡されたパラメータは、コンポーネントフットプリントを通じて基板製造や機能に関する追加情報を提供するために使用できます。ソースライブラリレベルで特殊なパラメータ文字列をフットプリントに追加することで、そのカスタム文字列は対象の機械レイヤーまたはオーバーレイ上で解釈されます。

ユーザー定義パラメータを表す特殊文字列は、Properties パネル内の特殊文字列ボタンおよびドロップダウン()を使用して、ソースコンポーネントフットプリントに追加できます。

以下のライブラリフットプリントでは、特殊文字列 .Designator が Mechanical 2 レイヤーに配置されています。

ユーザーパラメータを表す特殊文字列はコンポーネントフットプリントに追加できます。

そのカスタムパラメータが回路図コンポーネントにも適用され、パラメータデータが PCB に転送されると、解釈されたフットプリント文字列は基板ビューと生成出力ファイルの両方に表示されます。この場合、特殊パラメータ文字列には、組み立てを支援するためのカスタムコンポーネント部品識別子が含まれています。

特殊文字列としてユーザーパラメータをコンポーネントフットプリントに適用することで、スイッチやコネクタの機能ラベルなど、他のさまざまなカスタム PCB 要件にも対応できます。たとえば、そのようなコンポーネントタイプのフットプリントでは、「function」パラメータ文字列を Top Overlay に配置できます。

基板レイアウト上で特殊文字列の解釈結果の値を表示するには、View Configuration パネルの View Options タブにある Additional Options 領域で Special Strings オプションを有効にします。特殊文字列は生成出力ファイルでは常に変換されます。
回路図エディタでは、必要に応じて、Preferences ダイアログの Schematic – Graphical Editing ページで Display Names of Special Strings that have No Value Defined オプションを有効にします。

パラメータクエリ

PCB ドメイン内のパラメータ文字列は Altium Designer のクエリ言語からもアクセス可能であり、そのため Find Similar Objects 機能を含むオブジェクトフィルタリング機能で利用できます。

類似オブジェクトの選択を実行するには、コンポーネントを右クリックし、コンテキストメニューから Find Similar Objects を選択して Find Similar Objects ダイアログを開きます。

 Find Similar Objects dialog には、必要に応じてフィルタリングオプションを選択できる Parameters セクションがあります。

 PCB Filter パネルでは、パラメータ固有のクエリワードをフィルタ条件として適用でき、PCB パラメータに基づく Design Rule の作成にも使用できます。

PCB コンポーネントフットプリントパラメータで使用できるクエリワードはいくつかあり、文字列値を数値に変換するための専用関数ワード(たとえば StrToNumber)も含まれます。文字列 Value の変換は単位対応(V、mA、mV、kOhm など)であり、パラメータ値文字列の数値処理によってクエリ結果を決定できます。

クエリで指定できるサポート対象の単位タイプは次のとおりです。

  • % – パーセント
  • A – 電流
  • C – 温度
  • dB – デシベル
  • F – 静電容量
  • G – コンダクタンス
  • H – インダクタンス
  • Hz – 周波数
  • Kg – 質量
  • m – 長さ
  • Ohm – 抵抗
  • Q – 電荷
  • s – 時間
  • V – 電圧
  • W – 電力
  • Z – インピーダンス

PCB コンポーネントフットプリントパラメータを扱うためのパラメータクエリワードが複数用意されています。

上記の Query Helper ダイアログに示されている例では、各コンポーネントの Voltage Rating パラメータを処理し(文字列から数値への変換 – StrToNumber(Unit Value, Unit Type) を使用)、その値が 50V を超えるかどうかを判定しています。これを PCB Filter パネルに適用すると、例の基板レイアウトでは 1 つの高電圧コンポーネント、 C1 ((Voltage Rating 値が 3kV) が抽出されます。

Scientific E 表記もサポートされているため、たとえば 1nF を超えるコンデンサ値をフィルタするクエリは次のようになります。
StrToNumber(ParameterValue('CapacitanceValue'), F) > 1e-9
あるいは、数値変換関数を、返される ParameterValue と比較値の両方に使用することもできます。and
StrToNumber(ParameterValue('CapacitanceValue'), F) > StrToNumber('1nF', F)

ルールとスクリプトPCB パラメータのクエリは、Altium Designer のスクリプトおよびデザインルールにも適用できます。後者では、コンポーネントの配置やレイヤー割り当てを評価するためにフットプリントパラメータを検出するなど、レイアウト検証チェックを実行できます。なお、上記の Query Helper ダイアログに一覧表示されている関数は、スクリプト言語から利用できます。

以下の例では、コンデンサの定格電圧クエリ(上記のフィルタークエリを参照)をコンポーネント配置ルールに適用しています。これを実行すると、高電圧(>50V)デバイスとして検出されたコンポーネントに対して、特定のクリアランス値をチェックします。

回路図空間から転送された特定のフットプリントパラメータで定義されたデザインルールは、カスタムのレイアウト条件を検出するために使用できます。

同様に、カスタム PCB パラメータを使用してコンポーネントのレイヤー互換性をチェックすることもできます。たとえば、あるコンポーネントがウェーブはんだ付けに対応しておらず、そのため Bottom Layer への配置に対応しない場合です。ここでは、カスタムの「WaveSoldering」パラメータ(Yes/No)を処理するオブジェクト一致クエリを Permitted Layers Rule に適用できます。

その後、この(バッチ)ルールが該当コンポーネントパラメータの値をチェックし、コンポーネントが Bottom Layer への配置に適合していない場合には違反を生成します。

バリアント

PCB に転送されたパラメータのうち、設計のバリエーション(Design Variants)に含まれるものは、バリアント選択によって処理されます。

実際には、PCB 空間内のバリアント化されたコンポーネントパラメータは、クエリ文字列によって動的に検出されたり、たとえば特殊文字列を介して基板レイヤー上に表示されたりします。 

ユーザー定義フットプリントパラメータ

この機能は、PCB.FootprintParameters オプションが Advanced Settings dialog で有効になっている場合に利用できます。

フットプリントのユーザー定義パラメータは Altium Designer でサポートされています。PCB フットプリントエディターのデザイン空間で何も選択されていない場合、Properties パネルの Library Options  モードにある Footprint タブの Parameters 領域を使用して、フットプリントパラメータの表示および編集を行えます。

コンポーネントが PCB 上に配置されると、Parameters タブの Component  モードにある Properties  パネルでこれらのパラメータを確認できます。

  • PCB 上に配置されたコンポーネントのフットプリントパラメータは、PCB エディターのメインメニューにある Make PCB Library または Make Integrated Library コマンドによって生成されたライブラリ内のフットプリントへ反映されます。
  • フットプリントパラメータは、Altium Designer の比較エンジン、および生成される Pick and Place 出力と ODB++ 出力でもサポートされています。
Altium MCAD CoDesigner は、設定されたリンクに従って MCAD 内にネイティブ MCAD コンポーネントを配置することをサポートします。場合によっては、異なるモデルを持つ複数のフットプリントが 1 つのコンポーネントにリンクされることがあります(たとえば、PCB に 2 通りの方法で実装できる LED:リードがまっすぐな垂直実装、またはリードを曲げた水平実装)。フットプリントパラメータを使用することで、これらの異なるフットプリントから異なる MCAD モデルを参照できるようになりました。詳細は、Linking Native ECAD and MCAD Design Components を参照してください。

デジグネータ文字列とコメント文字列

デフォルトのデジグネータ文字列とコメント文字列

フットプリントを基板上に配置すると、設計の回路図ビューから抽出された情報に基づいて Designator と Comment が付与されます。Designator 文字列と Comment 文字列のプレースホルダーは、フットプリントが基板上に配置される際に自動的に追加されるため、手動で定義する必要はありません。これらの文字列の位置は、デザイン空間でデジグネータまたはコメント文字列を選択したときの Parameter モードにある Properties パネルの Designator and Comment string Autoposition オプションによって決定されます。Designator 文字列と Comment 文字列のデフォルトの位置およびサイズは、Preferences ダイアログの PCB Editor - Defaults page にあるそれぞれの Primitive で設定します。

追加のデジグネータ文字列とコメント文字列

デジグネータ文字列またはコメント文字列の追加コピーが必要になる場合があります。たとえば、実装業者が各コンポーネント外形の内側にデジグネータを表示した詳細な組立図を求める一方で、自社では最終 PCB 上のコンポーネントオーバーレイで、コンポーネントのすぐ上にデジグネータを配置することを要求する場合です。この追加のデジグネータ要件は、フットプリントに .Designator 特殊文字列を含めることで実現できます。コメント文字列を別のレイヤーまたは位置に指定するための .Comment 特殊文字列も利用できます。

実装業者の要件に対応するため、.Designator 文字列を PCB フットプリントエディターのメカニカルレイヤー上に配置し、このレイヤーを含む印刷出力を設計の組立指示の一部として生成できます。

レイヤー固有の特別な要件への対応

PCB コンポーネントには、グルードットや剥離可能なソルダーマスク定義が必要になるなど、さまざまな特別要件が存在します。これらの特別要件の多くは、コンポーネントが実装される基板面に関連しており、コンポーネントを裏面に反転したときには基板の反対側へも反転する必要があります。

めったに使用されない可能性のある多数の専用レイヤーを用意する代わりに、Altium Designer の PCB エディターでは、レイヤーペアと呼ばれる機能によってこの要件をサポートしています。レイヤーペアとは、ペアとして定義された 2 つのメカニカルレイヤーのことです。コンポーネントが基板の片面からもう一方の面へ反転されるたびに、ペアになっているメカニカルレイヤー上のオブジェクトは、そのペアのもう一方のメカニカルレイヤーへ反転されます。 この方法では、グルードット(またはその他の特別要件)を含めるための適切なメカニカルレイヤーを選択し、利用可能なオブジェクトを使ってその形状を定義します。 そのフットプリントを基板上に配置したら、レイヤーペアリングを設定する必要があります。これにより、そのコンポーネントが反対面に反転されたとき、どのレイヤーへオブジェクトを転送すべきかをソフトウェアに指示します。PCB フットプリントエディターではレイヤーペアを定義できず、これは PCB エディターで行います。

レイヤーペアリングは、コンポーネントを反転する before に定義しておく必要があります。コンポーネントが下側へ移動した後でペアリングを定義すると、メカニカルコンテンツは反転しますが元のレイヤーに残ったままになります。反転前にレイヤーペアを作成し忘れた場合は、ライブラリから更新して基板上に配置されたコンポーネントのインスタンスをリフレッシュできます。

Mechanical Layers の名前は、View Configurations パネル上で右クリックし、Edit Layer を選択することで直接編集できます。

メカニカルレイヤーの使用を管理する一般的な方法として、必要な各メカニカルレイヤー機能に対して専用のレイヤー番号を割り当てる方法があります。この方法では、すべての設計者が同じレイヤー割り当ておよび番号付け方式に従う必要があります。また、同じ割り当て・番号付け方式に従っていない他のソースからコンポーネントを取得した場合に問題が生じることがあります。異なる方式が使われている場合、その機能に割り当てられたメカニカルレイヤーへデザインオブジェクトを現在のメカニカルレイヤーから移動しなければなりません。

この問題は、Layer Type プロパティの導入によって解決されます。コンポーネントがライブラリから PCB エディターへ配置されたとき、あるいはあるライブラリから別のライブラリへコピーされたとき、または IPC Footprint Wizard によって作成されたとき、既存の Layer Type の割り当ては、その Layer Type に割り当てられているメカニカルレイヤー番号に関係なく自動的に一致付けされます。オブジェクトは、その Layer Type に従って正しいレイヤーへ再配置されます。ソフトウェアが Layer Type で一致付けできない場合は、Layer Number による一致付けにフォールバックします。

個別のメカニカルレイヤーおよび Component Layer Pairs の両方について、事前定義されたタイプの一覧から Layer Type を選択できます。以下に示すダイアログは、個々のレイヤーを右クリックして、メニューから Edit Layer または Add Component Layer コマンドを選択することで開けます。

コンポーネント関連のメカニカルレイヤータイプの詳細については、Working with Mechanical Layers ページを参照してください。

PCB フットプリントへの高さ情報の追加

3D 表現の最も基本的なレベルでは、高さ情報を PCB フットプリントに追加できます。これを行うには、Properties パネルを Library Options モード(デザイン空間で何も選択されていないときにアクティブ)で開き、パネルの Footprint タブにある Height フィールドにコンポーネントの推奨高さを入力します。

高さデザインルールは基板設計中に定義できます(PCB Editor で Design » Rules をクリック)。通常は、コンポーネントクラス内、またはルーム定義内における最大コンポーネント高さをチェックします。

高さ情報を定義するより良い方法は、PCB フットプリントに 3D Bodies を追加することです。

配線プリミティブを持つコンポーネントの管理

設計が転送されると、各コンポーネントに指定されたフットプリントが利用可能なライブラリから抽出され、基板上に配置されます。次に、フットプリント内の各パッドには、回路図でそのコンポーネントピンに接続されているネット名が net プロパティとして設定されます。パッドに接触しているすべてのオブジェクトは、そのパッドと同じネットに接続されます。

PCB エディターには包括的なネット管理ツールが含まれています。起動するには、メインメニューから Design » Netlist » Configure Physical Nets を選択して Configure Physical Nets dialog を開きます。オプションメニューを表示するには Menu ボタンをクリックします。New Net Name ヘッダーのドロップダウンをクリックして、未割り当てのプリミティブに割り当てるネットを選択します。

同じピンに接続された複数のパッドを持つフットプリント

以下に示す SOT223 トランジスタのフットプリントには、同じ論理回路図コンポーネントピン、すなわち Pin 2 に接続された複数のパッドがあります。この接続を実現するために、同じデジグネータ「2」を持つ 2 つのパッドが追加されています。 Schematic Editor で Design » Update PCB コマンドを使用して設計情報を PCB に転送すると、その結果の同期処理では PCB エディター上で両方のパッドに接続線が表示されます。つまり、これらは同じネット上にあります。これらの両方を配線できます。

デジグネータ 2 のパッドが 2 つある SOT223 フットプリント。
デジグネータ 2 のパッドが 2 つある SOT223 フットプリント。

シルクスクリーンの準備

露出銅箔や穴にシルクスクリーンが重なることで発生する一般的な Design for Manufacture(DFM)上の問題を解決しやすくするため、PCB フットプリントエディターにはフットプリントのシルクスクリーンを準備する専用機能が用意されています。これらの問題には、次の方法で効果的に対処できます。

  • シルクスクリーンの線分および円弧の自動クリッピング;
  • フィルおよびリージョンの自動クリッピングまたは移動;
  • シルクスクリーン文字列の自動移動。
PCB を設計しているときにもシルクスクリーン準備ツールにアクセスできます。– 詳細はこちら

PCB フットプリントエディターでシルクスクリーン準備ツールにアクセスするには、メインメニューから Tools » Silkscreen Preparation コマンドを使用します。Silkscreen Preparation ダイアログが開きます。

このダイアログを使用して、シルクスクリーンオブジェクトのクリッピング/移動の設定を構成します。利用可能なオプションは次のとおりです。

  • Clip to Exposed Copper – 有効にすると、露出銅箔に対してオブジェクトを自動的にクリップします。
  • Clip to Solder Mask Openings – 有効にすると、ソルダーマスク開口部に対してオブジェクトを自動的にクリップします。
  • Silkscreen Clearance – シルクスクリーンオブジェクトと露出銅箔/ソルダーマスク開口部および穴との間の許容最小値を定義します。
  • Min Remaining Length – クリッピング後に線分/円弧の長さが定義された値未満になった場合、そのオブジェクトはフットプリントから削除されます。なお、この長さはエッジ間の長さではなく頂点間の長さです。– 画像を表示
  • Move Text – 有効にすると、シルクスクリーン文字列と露出銅箔/ソルダーマスク開口部および穴との距離が Silkscreen Clearance 未満である場合、シルクスクリーン文字列をそれらから離れる方向へ移動します。移動量は Max Distance の値によって制限されます。
  • Fill & Region – フィルおよびリージョンと露出銅箔/ソルダーマスク開口部および穴との距離が Silkscreen Clearance 未満である場合に、フィルおよびリージョンに対して実行するアクションを選択します。
    • None – フィルおよびリージョンは変更されません。
    • Clip – フィルおよびリージョンは、Silkscreen Clearance を維持するようにクリップされます。必要に応じてフィルはリージョンに変換されます。
    • Move – フィルおよびリージョンは、露出銅箔/ソルダーマスク開口部および穴から離れる方向へ移動されます。移動量は Max Distance の値によって制限されます。
  • Max Distance – テキスト文字列、コンポーネントデジグネータ、フィル、およびリージョンを移動して Silkscreen Clearance を維持するために許可される最大移動距離を定義します。

OK をクリックすると、ダイアログの設定に従ってシルクスクリーンオブジェクトのクリッピングおよび/または移動を実行します。

あるオブジェクトに対してアクションを実行できない場合(たとえば、Max Distance の制限によりテキスト文字列を移動できない場合)、そのオブジェクトに関するメッセージが Messages パネルに表示されます。

シルクスクリーン準備ツールの動作例を以下に示します。

Javascript

IPC 準拠フットプリントウィザードを使用したフットプリントの作成

IPC Compliant Footprint Wizard は、IPC 規格 7351 の Revision B(Generic Requirements for Surface Mount Design and Land Pattern Standard)に真に準拠した PCB フットプリントを生成します。フットプリント寸法を直接使用するのではなく(Footprint Wizard がそうであるように)、IPC Compliant Footprint Wizard はコンポーネント自体の寸法情報を使用し、その後 IPC が公開したアルゴリズムに従って適切なパッドやその他のフットプリント特性を計算します。

フットプリントを定義するために使用するパッドやトラックの特性を入力する必要はなく、Wizard は実際のコンポーネント寸法を入力値として受け取ります。IPC-7351 規格用に開発された数式に基づき、Wizard はパッドやトラックなどの標準 Altium Designer オブジェクトを使用してフットプリントを生成します。

  • このダイアログは、IPC 規格 7351 の Revision B、すなわち Surface Mount Design and Land Pattern Standard の Generic Requirements に準拠しています。IPC-7351B は 2010 年にリリースされ、2007 年にリリースされた IPC-7351A に取って代わるものです。

  • Altium Designer で IPC Compliant Footprint Wizard にアクセスするには、IPC Footprint Generator ソフトウェア拡張機能がインストールされている必要があります。 この拡張機能はデフォルトで Altium Designer にインストールされています。 手動でインストールまたは削除することもできます。

    拡張機能の管理に関する詳細は、Extending Your Installation ページ(Altium Designer DevelopAltium Designer AgileAltium Designer)を参照してください。

IPC Compliant Footprint Wizard を実行するには、PCB ライブラリドキュメントのメインメニューから Tools » IPC Compliant Footprint Wizard を選択します。

Select Component Type ページで、Select Component Type ページ上にフットプリントを作成したいコンポーネントファミリを選択します。ウィザード右側のプレビュー領域は、現在選択されているコンポーネントを動的に表示するように変化し、生成可能なパッケージの種類も示します。以下の表に、ウィザードでサポートされるコンポーネントタイプとパッケージを示します。

名称 説明 含まれるパッケージ
BGA ボールグリッドアレイ BGA, CGA
BQFP バンパ付きクワッドフラットパック BQFP
CAPAE 電解アルミニウムコンデンサ CAPAE
CFP セラミックデュアルフラットパック - トリミングおよび成形済みガルウィングリード CFP
Chip Array チップアレイ Chip Array
DFN デュアルフラットノーリード DFN
CHIP 2 ピンのチップ部品 コンデンサ、インダクタ、抵抗
CQFP セラミッククワッドフラットパック - トリミングおよび成形済みガルウィングリード CQFP
DPAK トランジスタアウトライン DPAK
LCC リードレスチップキャリア LCC
LGA ランドグリッドアレイ LGA
MELF 2 ピン MELF 部品 ダイオード、抵抗
MOLDED 2 ピンモールド部品 コンデンサ、インダクタ、ダイオード
PLCC プラスチックリード付きチップキャリア、正方形 - J リード PLCC
PQFN プルバッククワッドフラットノーリード PQFN
PQFP プラスチッククワッドフラットパック PQFP, PQFP Exposed Pad
PSON プルバックスモールアウトラインノーリード PSON
QFN クワッドフラットノーリード QFN, LLP
QFN-2ROW 2 列・正方形クワッドフラットノーリード Double Row QFN
SODFL スモールアウトラインダイオード、フラットリード SODFL
SOIC スモールアウトライン集積パッケージ、1.27mm ピッチ - ガルウィングリード SOIC, SOIC Exposed Pad
SOJ スモールアウトラインパッケージ - J リード SOJ
SON スモールアウトラインノンリード SON, SON Exposed Pad
SOP, TSOP スモールアウトラインパッケージ - ガルウィングリード SOP, TSOP, TSSOP
SOT143/343 スモールアウトライントランジスタ SOT143, SOT343
SOT223 スモールアウトライントランジスタ SOT223
SOT23 スモールアウトライントランジスタ 3 リード、5 リード、6 リード
SOT89 スモールアウトライントランジスタ SOT89
SOTFL スモールアウトライントランジスタ、フラットリード 3 リード、5 リード、6 リード
WIRE WOUND 高精度巻線インダクタ、2 ピン インダクタ

ウィザードの後続ページは、選択したコンポーネントタイプに応じて変化します。必要に応じて特定のコンポーネントフットプリントを設定するために、ウィザードの直感的なページに従ってください。IPC Compliant Footprint Wizard を操作する際の注意点を以下に示します。

 
 
 
 
 
  • すべての寸法は、ウィザード内でメートル法(mm)単位で入力します。

  • パッケージ全体の寸法、ピン情報、ヒール間隔、はんだフィレット、および公差を入力し、すぐに確認できます。

    IPC 公差を変更すると、IPC 準拠でない PCB フットプリントが生成される可能性があります。

  • コートヤード、アセンブリ、およびコンポーネント(3D)ボディ情報などの機械寸法を入力できます。

  • Wizard はリエントラントであり、レビューや調整を容易に行えます。

  • フットプリントのプレビューは各段階で表示されます。各コンポーネントタイプについて、Preview 領域は複数の設定に応じて位置やサイズなどを動的に更新します。 Preview 領域では、 または  をクリックして 2D プレビュー画像と 3D プレビュー画像を切り替えることができます。

  • 必要に応じて、モデルを生成する前に 3D STEP モデルのプレビューを確認できます。Generate STEP Model PreviewWizard内の任意のページで、コンポーネント タイプを選択した後に 3D STEP モデルのプレビューを表示するには、Preview領域で確認してください。

  • 大きなサーマル パッド(2.1mm x 1.6 mm 以上)を持つパッケージでは、ペースト マスクは小さなフィルに分割されます。

  • ガルウィング リードを含むパッケージでは、パッドがパッケージ本体の下に入り込まないように、パッドがトリミングされます。

  • 大きな中央サーマル パッドを持つ小型パッケージでは、IPC 規格に従ってパッド間に必要なクリアランスを確保するため、周辺パッドがトリミングされます。

  • パッド トリミングが適用されると、ダイアログ内に警告が表示されます。

  • フットプリントの名前と説明は、Wizard に入力した情報に基づいて自動的に提案されますが、組織の要件に合わせて変更できます。

  • IPC 規格に従い、この Wizard は 3 つのフットプリント バリアント(_L_N_M)をサポートしており、それぞれ異なる基板密度に適合するように調整されています。

  • Finish ボタンはどの段階でも押すことができ、その時点でプレビューされているフットプリントを生成します。Finish 全体を完了する前に Wizard をクリックした場合、選択したコンポーネント タイプに対するシステム デフォルトを使用してフットプリントが作成されます。

  • ファイルベースの PCB フットプリント ライブラリで作業する場合は、IPC Compliant Footprints Batch Generator を使用して、複数の密度レベルで複数のフットプリントをすばやく生成できます。

ファイルベースの PCB フットプリント ライブラリから Wizard にアクセスした場合は、Footprint Destination ページを使用でき、新しく作成するフットプリントの保存先を選択できます – show image:

  • フットプリントを既存の PCB Library ファイルに保存する場合は、 Existing PcbLib File を選択します。ファイルはテキストボックスに直接入力するか、 を使用してダイアログを開き、目的のファイルを検索できます。
  • フットプリントを新しい PCB Library ファイルに保存する場合は、New PcbLib File を選択します。新しい PCB Library ファイルの名前をテキストボックスに入力します。システムは新しいライブラリ ファイル名に拡張子 .PcbLib を付加します。
  • 表示されている PCB Library ファイルにフットプリントを保存するには、Current PcbLib File を選択します。
  • 3D STEP モデルを生成するには、Produce 3D/STEP model を有効にします。
  • 有効な 'MCAD Co-Designer - SOLIDWORKS(R)' ライセンスがある場合、モデルを Parasolid ファイル タイプとして保存することを選択できます。Format の右側にあるドロップダウンをクリックし、Parasolid を選択します。すると External File テキストボックスに表示されるファイルは *.x_t ファイルになります。これは保存されるファイルの名前と場所です。
  • Embedded(デフォルト)または External File のいずれかを選択します。3D STEP モデルを外部ファイルとして保存するには、 External File を選択します。デフォルトのファイル タイプは STEP で、ファイル名は External File テキストボックスに *.step をファイル拡張子として表示されます。必要に応じて、 をクリックし、生成した 3D STEP モデルを保存するフォルダーを参照して選択できます。

フットプリント Wizard を使用したフットプリントの作成

PCB フットプリント エディターには Footprint Wizard が含まれています。この Wizard では、さまざまなパッケージ タイプから選択して適切な情報を入力すると、コンポーネント フットプリントが作成されます。Footprint Wizard では、パッドおよびコンポーネント オーバーレイに必要なサイズを入力することに注意してください。

Footprint Wizardを起動するには、メイン メニューから Tools » Footprint Wizard を選択するか、デザイン スペース内で右クリックして、コンテキスト メニューから Tools » Footprint Wizard コマンドを選択します。

Component patterns ページを使用して、作成するコンポーネントのパターンを指定します。リストから目的のパターンを選択し、ドロップダウンを使用してコンポーネントの単位(Imperial (mil) または Metric (mm))を選択します。使用可能なパターンは次のとおりです。

  • Ball Grid Arrays (BGA)
  • Capacitors
  • Diodes
  • Dual In-line Packages (DIP)
  • Edge Connectors
  • Leadless Chip Carriers (LCC)
  • Pin Grid Arrays (PGA)
  • Quad Packs (QUAD)
  • Resistors
  • Small Outline Packages (SOP)
  • Staggered Ball Grid Arrays (SBGA)
  • Staggered Pin Grid Arrays (SPGA)

以降の Wizard ページは、選択したコンポーネント パターンに応じて変化します。必要なコンポーネント フットプリントを設定するには、Wizard の直感的なページに従って操作してください。

Edge ConnectorsLeadless Chip Carriers (LCC)、または Quad Packs (QUAD) パターンのフットプリントについてパッド命名スタイルを設定する際は、緑色の矢印をクリックして命名順序/方向を変更します – show image

コンポーネント レポートの生成

アクティブな PCB フットプリントのレポートを生成するには、メイン メニューから Reports » Component コマンドを選択します。コマンドを実行すると、レポート(<PCBLibraryDocumentName>.CMP)がソース PCB ライブラリ ドキュメントと同じフォルダーに生成され、メイン デザイン ウィンドウでアクティブ ドキュメントとして自動的に開きます。レポートには、フットプリント寸法、フットプリントを構成するプリミティブ オブジェクトの内訳、およびそれらが存在するレイヤーなどの情報が一覧表示されます。

レポートは、Projects パネルの Documentation\Text Documents サブフォルダーの下に、フリー ドキュメントとして追加されます。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium DevelopAltium Agile TeamsAltium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Content