コンポーネントの一括編集

Workspace コンポーネントは、Component Editor を使用して定義/編集します。Component Editor は Single Component EditingBatch Component Editing の 2 つのモードで動作します。後者は複数のコンポーネントを定義/編集するためのインターフェースを提供しますが、必要に応じて単一のコンポーネントの定義/編集にも使用できます。Component Editor が Single Component Editing モードの場合、エディターのメインメニューから Tools » Switch to Batch Editor コマンドを選択すると、バッチ編集モードにアクセスできます。

  • モードでコンポーネントを定義している場合、そのコンポーネントにまだ Workspace に保存されていないモデルが含まれていると、Batch Component Editing モードへ切り替えることはできません。先にそのコンポーネントを Workspace に保存し、その後で編集してください。そうすると編集モードを切り替えられるようになります。

  • Component Editor の Batch Component Editing モードに現在 1 つのコンポーネント定義しか含まれていない場合は、メインメニューから Tools » Switch to Single Component Editor コマンドを選択することで Single Component Editing モードに切り替えられます。このコンポーネント定義のデータは Single Component Editing モードに反映されます。

Component Editor の Batch Component Editing モードは、Components panel または Explorer panel から複数のコンポーネントを編集対象として選択した場合にも開きます。各コンポーネント定義には、共通のパラメーターセットと必要なドメインモデルへのリンクが含まれます。バッチ編集は、たとえばチップ抵抗のセットのように、コンポーネントをひとまとまりとして管理するのに適しています。

このドキュメントでは、Batch Component Editing モードの Component Editor の操作について説明します。

Single Component Editing モードの Component Editor の操作について詳しくは、Single Component Editing を参照してください。

インターフェースの概要

Batch Component Editing モードでは、Component Editor のインターフェースは基本的に 4 つの主要領域に分かれており、次の図に示され、その後に要約を示します。

Component Editor を Batch Component Editing モードに切り替えると、4 つの主要領域に分けられます。
Component Editor を Batch Component Editing モードに切り替えると、4 つの主要領域に分けられます。

  1. Required Models/Parameters – コンポーネント定義に必要なドメインモデルの種類を定義し、すべてのコンポーネント定義に適用されるパラメトリックデータのセットを作成する領域です。
  2. Model Links – コンポーネント定義で使用するために、保存済みドメインモデルへのリンクを追加する領域です。
  3. Preview Window – 現在選択されているモデルのプレビューを表示します。シンボルおよびフットプリントはグラフィカル表示され、その他のモデルタイプはテキスト表示されます。
  4. Component Definition(s) – フォルダー、名前、タイプ、参照ドメインモデル、パラメトリックデータ、パート選択を含め、コンポーネントを定義する領域です。
Required Models/Parameters 領域と Model Links 領域は、それぞれ左上にある コントロールをクリックすることで水平方向に折りたたむことができます。さらに、右上にある コントロールを使用すると、上側 3 つの領域を折りたたみ、Component Definitions 領域だけを残すことができます。

ドキュメントオプション

コンポーネントの作成先となる Workspace フォルダー、およびそれらのコンポーネントに使用するライフサイクル定義と命名スキームを指定するコントロールは、Document Options ダイアログ(Edit » Document Options)で使用できます。さらに、Component Editor からリリースされるコンポーネント用のデフォルトの Component Naming scheme を定義でき、Workspace 内で生成される各コンポーネントに一意の ID を確保できます。

Workspace 設定は Document Options ダイアログで定義します。
Workspace 設定は Document Options ダイアログで定義します。

  • Target Server – 1 つ以上の新規コンポーネントを作成する場合、対象の Workspace は現在アクティブに接続しているものになります。既存のコンポーネントを編集する場合、このフィールドにはそれらのコンポーネントが存在する Workspace が表示されます。ドロップダウンの右側にある Server Admin ボタン(コンポーネントがまだリリースされていない場合に使用可能)をクリックすると、Preferences ダイアログの Data Management – Servers page にアクセスでき、そこからアクティブおよび既知の Workspace を参照・管理できます。

    複数の Workspace に接続することはできますが、同時にアクティブ接続できる Workspace は 1 つだけです。

  • Default Folder – 1 つ以上の新規コンポーネントを作成する場合、このフィールドを使用して、保存するコンポーネントの格納先となる対象 Workspace 内のデフォルトフォルダーを指定します。Choose ボタンをクリックして Choose Folder ダイアログを開いてください。これは Explorer panel の実装であり、そこから Workspace 内の既存フォルダーを参照して選択したり、その場で新しいフォルダーを作成したりできます。ここでの設定は、新しいコンポーネント定義を追加する際の FolderPath のデフォルトとして使用されます。既存コンポーネントの 1 つ以上のリビジョンを編集している場合、このフィールドには既存のフォルダーが表示され、編集不可になります。この場合、Choose ボタンも使用できません。Show in Explorer ボタンをクリックすると、Explorer panel で指定したデフォルトフォルダーをすばやく参照できます。

  • Lifecycle Definition および Revision Naming – それぞれの場合に適切なデフォルトスキーム(それぞれ Component Lifecycle1-Level Revision Scheme)を設定するために使用します。各フィールドに関連付けられたドロップダウンを使用して、親 Workspace で現在定義されているスキームから別のものを選択できます。

    コンテンツタイプごとにライフサイクル定義およびリビジョン命名スキームの使用を制御するオプションが、いずれかの定義/スキームで有効になっており、かつ Component コンテンツタイプが特定の定義/スキームを使用するよう設定されていない場合、その定義/スキームは該当するドロップダウンリストでは使用できません。

  • Item Naming – このフィールドは、Component Editor から保存されるコンポーネントのデフォルト Item Naming Scheme を定義するために使用され、Workspace 内で生成される各 Component Item に一意の ID を保証します。ここでの設定は、新しく追加されたコンポーネント定義を自動命名する際のテンプレートとして使用されます(関連する Item ID フィールド内)。ソフトウェアは、そのスキームに基づいて、Workspace 全体と既存コンテンツの識別子をスキャンし、次に利用可能な一意 ID を自動的に割り当てます。

    コンポーネントが存在する、または作成される親フォルダーに命名スキームが定義されている場合、それがデフォルトとして事前入力されます。定義されていない場合は、デフォルトスキーム CMP-{00000} が使用されます。もちろん、このフィールドに直接入力して独自のスキームを作成することもできます。パラメーターをベースにした Component Name Templates もサポートされています。これらのテンプレートを使用すると、Component Editor で現在定義されているパラメーター値に基づいて、コンポーネント名を正確に設定、あるいは変更できます。パラメーターは [<ParameterName>] という形式で命名テンプレートに含めます。テンプレートには複数のパラメーターを使用でき、さらに中括弧で指定するイテレーターマクロ(例: {000}{00A})も追加できます。

    また、定義の Item ID フィールドに必要な ID を直接入力することで、コンポーネントに対して自動割り当てされた ID を上書きすることもできます。Item の識別方法については、常に完全な制御権と最終決定権があります。

このダイアログでは、定義済みの Component Template を参照することもできます。ダイアログの Template  タブにあるコントロールを使用してテンプレートを選択してください。Component Template は、Component Editor 内で定義されるコンポーネント定義向けの事前定義設定を提供します。追加するコンポーネント定義は、関連付けられたコンポーネントテンプレートに従って作成されます。

編集中のコンポーネントが Component Template を参照している場合、テンプレート内で指定された Lifecycle DefinitionRevision NamingComponent Naming,Default Folder の各項目が、Document Options ダイアログの Document Options タブにある対応フィールドへ事前入力されます。これらのオプション(Component editor 側)は、テンプレート内で対応する Allow override オプションが有効な場合にのみ編集可能です。さらに、対象 Workspace は、その Component Template のリビジョンが存在する Workspace と同じものを使用するよう固定されます。

Required Models/Parameters

エディターのこの領域では、コンポーネント定義に必要なドメインモデルを指定するとともに、すべてのコンポーネント定義に適用されるパラメトリックデータのセットを作成します。

 
 
 
 
 

必要なモデルとパラメーターを定義します。
必要なモデルとパラメーターを定義します。

  • Models – 最も基本的なレベルでは、基板設計で使用されるコンポーネントは、回路図編集ドメインと PCB 編集ドメインの両方で表現される必要があります。したがって、回路図シンボルモデルと PCB フットプリントモデルが必要です。これらはデフォルトで必須モデルとして追加されており、削除することはできません。その他のモデルタイプが必要な場合は、この領域の Add および Remove コントロールを使用して追加/削除してください。

    モデルタイプを指定しても、そのモデルをコンポーネント定義が has 使用しなければならないわけではなく、そのモデルタイプ用のフィールドがコンポーネント定義に追加されるだけです。
    リストに PCBLIB 項目があることに注目してください。これにより、1 つのコンポーネントに複数の PCB フットプリントモデルを関連付けることができます。さらに、PCBLIB (default) パラメーターを使用して、コンポーネントのデフォルトフットプリントモデルを指定できます。
  • Parameters – デフォルトで 2 つのパラメーター項目 NameDescription が存在します。これらはシステムパラメーターです。必要に応じて、さらに任意の数の追加パラメーターを加えることもできます。これを行うには、領域下部にある Add コントロールをクリックし、Parameter 項目を選択します。新しいパラメーターがリストに追加されます。Parameter Name フィールド内をクリックして、必要に応じて名前を変更してください。パラメーターを削除するには、それを選択して Remove コントロールをクリックします。システムパラメーターは削除できません。
各項目に関連付けられた Show オプションを使用すると、エディター下部の領域、つまりコンポーネント定義自体を定義する領域で、そのモデル/パラメーターに対応する列の表示を切り替えられます。多数のパラメーターが定義され、領域が非常に混雑してきた場合に非常に役立ちます。複数選択と右クリックメニューのオプションを組み合わせて使用することで、複数のモデル/パラメーターの表示状態を切り替えられます。

このエディター領域では、Add メニューを通じて次のことも行えます。

  • Linking to a Component TemplateTemplates サブメニューには、コンポーネント自体が存在するのと同じ Workspace で現在利用可能なすべての Component Templates が一覧表示されます。項目をクリックすると、その Component Template の最新リビジョンへのリンクが作成されます。テンプレートのパラメーターはこの領域に取り込まれ、 アイコンによって区別されます。

  • Enabling the use of Datasheets – これを行うには Datasheet 項目を選択します。詳細については、Attaching Datasheets to Component Definitions を参照してください。

  • Adding Part ChoicesPart Choices サブメニューを使用し、By MPN を選択します。定義領域に Part Choice n という項目が追加され、ManufacturerPart Number の 2 列を使ってその選択を指定できます。あるいは、Workspace がこれをサポートしており、カスタムデータベース部品ソースを構成済みであれば、By Internal ID メニュー項目を選択します。すると定義領域に Part Choice n という項目が追加され、Part sourceInternal ID の 2 列を使って、社内パーツデータベースから部品の選択を指定できます。詳細については、Part Choices を参照してください。

Model Links

エディターのこの領域では、コンポーネント定義で使用するために、保存済みドメインモデルへのリンクを追加します。Model Links 領域は、どのコンポーネント定義からでもアクセスできるドメインモデルの「バケット」と考えることができます。割り当ては、各定義に必要なリンクを指定する形で行います。

特定タイプのモデルへのリンクは、そのモデルタイプが Required Models/Parameters 領域に追加されている場合にのみ追加できます。

Model Links 領域には、モデルリンクの定義とコンポーネント定義への割り当てを効率化する機能が豊富に備わっています。
Model Links 領域には、モデルリンクの定義とコンポーネント定義への割り当てを効率化する機能が豊富に備わっています。

以下の折りたたみ可能なセクションで、モデルリンクの操作について詳しく確認してください。

コンポーネント定義

パラメーターのセットを指定し、モデルリンクの「バケット」を用意したら、必要なコンポーネントの定義に進むことができます。これはドキュメントの下部領域で行います。

Component Editor を使用して、論理的かつ直感的にコンポーネントを定義できます。
Component Editor を使用して、論理的かつ直感的にコンポーネントを定義できます。

この領域に最初に表示される内容は、編集中のコンポーネントによって異なります。

  • 新しいコンポーネントを作成する場合で、親フォルダーから参照される Component Template is not があると、そのエントリには FolderPathItem ID が割り当てられますが、それ以外は何もない、いわば白紙の状態になります。
  • 新しいコンポーネントを作成する場合で、親フォルダーから参照される Component Template is があると、そのエントリにはそのテンプレートによって定義情報が事前入力されます。
  • 既存の単一コンポーネントのリビジョンを編集していて、Single Component Editing モードから切り替えている場合は、そのリビジョンが、その時点で定義されている情報とともに表示されます。
  • 複数のコンポーネントの選択したリビジョンを編集している場合、つまり Batch Component Editing モードに直接アクセスしている場合は、それらすべてのリビジョンが表示されます。
領域の下部にある Add Component コントロールをクリックするか、メインメニューから Edit » Add Component コマンドを選択するか、または領域の右クリックコンテキストメニューにある同名のコマンドを使用して、新しいコンポーネント定義をリストに追加します。

各コンポーネント定義は、次の情報を含む 1 行のエントリとして表示されます。

  • Component: FolderPath – このフィールドは、対象 Workspace 内の特定のフォルダーにコンポーネントを保存するために使用します。グリッドに新しく追加された各コンポーネントについて、このフィールドには、Document Options ダイアログEdit » Document Options)内の Default Folder フィールドで指定されていれば、デフォルトの保存先を設定できます。デフォルトパスが指定されているかどうかにかかわらず、対象 Workspace 内のどこにコンポーネントを保存するかは完全に制御できます。保存先フォルダーを手動で指定するには、コンポーネントの FolderPath フィールド内を 1 回クリックして ボタンを表示し、それをクリックして Choose Folder ダイアログを開きます。既存のフォルダーを参照して選択するか、その場で新しいフォルダーを作成できます。

    コンポーネントのフォルダーパスを慎重に決めておくことで、最初から正しい保存先フォルダーに保存されるようになります。ただし、必要であれば、保存後に Workspace 構造内の任意のフォルダーへ簡単に移動できます。
    このフィールドは、コンポーネントがすでに Workspace に保存されている場合は読み取り専用になります。Clear Link To Target Item コマンド(右クリックの Operations サブメニュー内)を使用すると、Workspace 内の既存 Item へのリンクがクリアされます。コンポーネント定義の各フィールドは新しい Item を作成できる状態に戻り、FolderPath フィールドも編集可能になります。
  • Component: Item ID – このフィールドは、Workspace に保存されるコンポーネントに使用される ID を決定するために使用します。グリッドに新しく追加された各コンポーネントについて、このフィールドは Document Options ダイアログの Item Naming フィールドで指定されたデフォルト命名スキームに従って設定されます。ソフトウェアは Workspace 全体と既存コンテンツの識別子を走査し、そのスキームに基づいて次に利用可能な一意の ID を自動的に割り当てます。

    デフォルトの Item 命名スキームとして CMP-{00000} が用意されていますが、もちろん独自のスキームをフィールドに直接入力して作成することもできます。その際、可変部分は中括弧で囲む必要があります(例: CMP-001-{0000})。また、定義の Item ID フィールドに必要な ID を直接入力して、コンポーネントに自動割り当てされた ID を上書きすることもできます。Item の識別方法については、常に完全な制御権と最終決定権があります。

    パラメーター ベースの Component Name Templates の使用もサポートされています。これらのテンプレートを使用すると、Component Editor 内でコンポーネントに対して現在定義されているパラメーター値に基づいて、コンポーネント名を正確に設定、または言い換えれば変更できます。
    このフィールドは、コンポーネントがすでに Workspace に保存されている場合は読み取り専用になります。Clear Link To Target Item コマンド(右クリックの Operations サブメニュー内)を使用すると、Workspace 内の既存 Item へのリンクがクリアされます。コンポーネント定義の各フィールドは新しい Item を作成できる状態に戻り、Item ID フィールドも編集可能になります。
  • Component: Name – コンポーネントに付けられた人が読んで理解しやすい名前を表します。このシステムパラメーターは Workspace 内での検索時に利用可能でインデックス化されており、Item ID を覚えていなくても特定のコンポーネントを見つける有効な手段となります。

    このフィールドには、参照される Component Template で定義されている Name システムパラメーターのデフォルト値があれば、それが入力されます。

    コンポーネントにパラメーター(値付き)が定義されていれば、そのパラメーターを使って Name を定義できます。パラメーター名は角括弧 [ ] で囲みます。複数のパラメーターを含めることもできます(例: [ParameterName1]_[ParameterName2])–

  • Component: Type – このフィールドではコンポーネントのタイプを定義でき、Workspace 内のコンポーネントに対する対象を絞った 検索 を容易にするための重要な属性です(また、Components パネル でコンポーネントを参照する際にも頻繁に使用します)。このフィールドをクリックし、続けて をクリックして Choose component type ダイアログを開きます。このダイアログで必要なコンポーネントタイプ(現在定義されているすべてのタイプから)を選択し、OK をクリックします。選択したタイプは、メイン定義グリッド内の Type 属性の値として挿入されます。

    このフィールドには、参照される Component Template で定義された ComponentType パラメーターのデフォルト値、または File » New » Component コマンドを使って新しいコンポーネントを作成しようとしたときに表示される Create new component ダイアログで選択したコンポーネントタイプが入力されます。タイプは Preferences レベルで定義されます。Choose component type ダイアログの下部にある ボタンをクリックすると、Preferences ダイアログの Data Management – Component Types ページが開きます。ここで新しいタイプやサブタイプを追加したり、既存のタイプを編集・削除したりして、この一覧をニーズに合わせて調整できます。
  • Component: Description – コンポーネントに追加された説明を表します。このシステムパラメーターは Workspace 内での検索時に利用可能で、インデックス化されます。

    このフィールドには、参照される Component Template で定義されている Description システムパラメーターのデフォルト値があれば、それが入力されます。

    コンポーネントにパラメーター(値付き)が定義されていれば、そのパラメーターを使って Description を定義できます。パラメーター名は角括弧 [ ] で囲みます。複数のパラメーターを含めることもできます(例: [ParameterName1]_[ParameterName2])–

  • Models – これらのフィールドは、ドキュメントの Required Models/Parameters 領域内のエントリに対応します。追加された必須モデルごとに 1 つのフィールドがあり、フットプリントモデルのみ複数定義できます。各フィールドは、コンポーネントに使用するリンク済みモデル(Model Links 領域内)を指定するために使用します。

    それぞれの Required Model エントリについて、関連する Show オプションを有効/無効にすることで、モデル列の表示を切り替えます。複数のモデルタイプの表示状態を切り替えるには、複数選択と右クリックメニューオプションを組み合わせて使用します。
  • Template Parameters – これらのフィールドは、参照される Component Template リビジョンから Component Editor に取り込まれたユーザーパラメーターに対応します。パラメーターごとに 1 つのフィールドがあります。コンポーネント定義内でのパラメーターの左から右への並び順は、Required Models/Parameters 領域での上から下への順序に対応します。必要に応じて、また適用可能な場合にパラメーター値を入力または選択します。たとえば、テンプレートで Read Only としてマークされているパラメーターは編集できませんが、それ以外のパラメーターは編集可能です。また、テンプレートで Required としてマークされている場合は値を設定する必要があり、そうしないとコンポーネント定義を Workspace に保存できません。

  • Parameters – これらのフィールドは、ドキュメントの Required Models/Parameters 領域に入力した追加のユーザーパラメーターに対応します。追加パラメーターごとに 1 つのフィールドがあります。コンポーネント定義内でのパラメーターの左から右への並び順は、Required Models/Parameters 領域での上から下への順序に対応します。必要に応じてパラメーター値を入力します。

    動的(アイテム レベル)パラメーターは、Component Editor を Batch Component Editing モードで使用しているときには表示されませんが、Single Component Editing モードで使用しているときには表示されます。– 詳細はこちら

  • Release: Current Rev. – この編集不可のフィールドには、Workspace 内のコンポーネントの現在の(最新の)リビジョンが表示されます。

  • Release: Next Rev. – この編集不可のフィールドには、選択したリビジョン命名スキームに従って、コンポーネント定義が次回 Workspace に保存される際に作成される次のリビジョンが表示されます。

  • Release: Action – このフィールドには、保存プロセスの一環として、この特定のコンポーネント定義に対してリリースマネージャーが実行するアクションが表示されます。まだ Workspace に保存されていないコンポーネント定義の場合、このエントリには Create Item と表示されます。すでに Workspace に保存されている定義の場合、このエントリには Create Revision と表示されます。コンポーネントの予定リビジョンが対象になっている場合、このエントリには Release To Existing Revision と表示されます。

  • Part Choice n – このエントリは、ドキュメントの Required Models/Parameters 領域に追加した Part Choice に対応します。コンポーネント定義内での Part Choices の左から右への並び順は、Required Models/Parameters 領域での上から下への順序に対応します。追加された Part Choice ごとに ManufacturerPart Number の 2 つのフィールドがあり、これらを使ってその選択肢を指定します。あるいは、カスタムのデータベース パーツ ソースを設定し、By Internal ID メニューエントリを使って Part Choice を追加した場合、2 つのフィールドは Part sourceInternal ID になります。これらを使用して、社内の部品データベースから部品の選択を指定します。

Current Rev.Next Rev.Action の各フィールドは、まとめて Release Status を構成しており、領域下部にある Show Release Status オプションを使用して、その領域内での表示/非表示を切り替えることができます。それぞれの Required Parameter エントリについて、関連する Show オプションを有効/無効にすることで、Template Parameter、Parameter、および Part Choice の各列の表示を切り替えます。複数のパラメーターの表示状態を切り替えるには、複数選択と右クリックメニューオプションを組み合わせて使用します。
Workspace にコンポーネントを保存しようとすると、Component Editor は検証、つまり Component Rule Check を実行します。この機能は、メインメニューから Tools » Component Rule Check コマンドを選択することで、いつでも手動実行することもできます。実行する前に、コンポーネントをローカルに保存(File » Save)しておいてください。詳細については、コンポーネント ルール チェックの実行 を参照してください。

コンポーネント定義の操作

このエディター領域での作業について、便利で時間を節約できる機能や操作を含め、以下のセクションで詳しく説明します。

既存コンポーネントへのモデルリンクの割り当て

既存のコンポーネント定義に対して、必要なモデルリンクは次の方法で割り当てることができます。

  • モデルリンクを、対象となるコンポーネント定義の該当列へドラッグ&ドロップします。

    Model Links 領域から既存コンポーネントの対応するモデル列へドラッグ&ドロップして、モデルを割り当てます。
    Model Links 領域から既存コンポーネントの対応するモデル列へドラッグ&ドロップして、モデルを割り当てます。

  • モデル列のドロップダウンフィールドを使用すると、専用のモデルリンク用ポップアップウィンドウを開けます。このウィンドウには、割り当て対象のモデルタイプに適用可能な既存のすべてのモデルリンクが、すべてのデータ列付きのグリッドとして表示されます。コンポーネント定義の数が多くてドラッグ&ドロップ操作がしにくい場合や、Model Links 領域を含む Component Editor の上部セクションが折りたたまれている場合には、特にモデルの検索と割り当ての時間短縮に役立ちます。また、この方法では同じモデルリンクを複数のコンポーネント定義に割り当てることもできます。ポップアップウィンドウを開く前に、各コンポーネントのモデル列を選択してください。

    必要に応じてウィンドウサイズを変更できます。ウィンドウ右下の コントロールをクリックしてドラッグすると、縦横同時にリサイズできます。ウィンドウ左上の列コントロールボタン をクリックし、表示したくない列を無効にしてください。列は、列ヘッダーをドラッグして並べ替えることもできます。

    ポップアップの検索フィールドを使うと、必要なモデルをすばやく見つけられます。文字を入力し始めると、任意の列のデータに基づいて動的にハイライトされます。必要なモデルリンクを選択し、Enter を押すかダブルクリックしてそのモデルを割り当てます。

    専用のモデルリンク選択ポップアップを使用して、必要なモデルを検索・特定・割り当てできます。
    専用のモデルリンク選択ポップアップを使用して、必要なモデルを検索・特定・割り当てできます。

リンクされたモデルを持つ新規コンポーネントの作成

コンポーネント定義がまだ存在しない場合は、必要なモデルリンクを自動的に割り当てた状態で、次の方法により作成できます。

  • Model Links 領域からモデルリンクを Definitions 領域内の空きスペースへドラッグ&ドロップすると、そのモデルを使用する新しいコンポーネント定義が追加されます。

    Model Links 領域からのドラッグ&ドロップにより、その場でモデルを割り当てて新しいコンポーネントを追加します。
    Model Links 領域からのドラッグ&ドロップにより、その場でモデルを割り当てて新しいコンポーネントを追加します。

  • Explorer パネルからモデルを直接 Definition 領域へドラッグ&ドロップします。そのモデルを使用する新しいコンポーネント定義が追加されます。さらに、そのモデルが Model Links 領域に存在しない場合は、そのためのエントリも追加されます。

    Explorer パネルからのドラッグ&ドロップにより、その場でモデルを割り当てて新しいコンポーネントを追加します。モデルリンクがまだ存在しない場合は、Model Links 領域に追加されます。
    Explorer パネルからのドラッグ&ドロップにより、その場でモデルを割り当てて新しいコンポーネントを追加します。モデルリンクがまだ存在しない場合は、Model Links 領域に追加されます。

複数コンポーネントの追加

Component Editor では、複数の新規コンポーネントを一度に追加できます。右クリックして Operations » Add Components コマンドを選択します。表示される Add Components ダイアログで追加したいコンポーネント数を入力し、 OK  をクリックすると、指定した数の新しいコンポーネント定義が、現在のコンポーネント定義リストの末尾にある定義グリッドへ追加されます。グリッドの複数セル編集機能やコピー&ペースト機能と組み合わせることで、多数のコンポーネント定義を短時間で効率よく作成できます。

このコマンドは、エディターのメイン Edit メニュー(Edit » Operations » Add Components)からも利用できます。
Add Components ダイアログで大きすぎる数値を入力すると、パフォーマンスに影響し、要求の処理中にソフトウェアがかなりの時間応答しなくなる可能性があるので注意してください。

2つの簡単な手順で複数の新しいコンポーネント定義を追加できます。
2つの簡単な手順で複数の新しいコンポーネント定義を追加できます。

基本的なチップ抵抗器の生成

メインメニューから Edit » Operations » Generate Basic Chip Resistors コマンドを選択するか、現在定義されている定義のない場所で定義領域を右クリックし、コンテキストメニューから Operations » Generate Basic Chip Resistors コマンドを選択することで、チップ抵抗器のコンポーネント定義をまとめてすばやく作成することもできます。

このコマンドは、現在どのコンポーネント定義も選択されていない場合にのみ、該当するメニューで使用可能になります。

コマンドを実行すると、指定されたコンポーネントタイプに対するコンポーネント定義が自動的に生成されます。

このコマンドで生成されたコンポーネント定義は、すでに定義済みのものに追加されます。つまり、既存の定義が上書きされることはありません。

Manufacturer Part Search からのコンポーネント作成

コンポーネント作成をさらに効率化するために、Altium Designer は Manufacturer Part Search 機能を使って実在する部品を検索し、その部品を Component Editor に追加する機能をサポートしています。選択した部品に対する新しいコンポーネント定義エントリが作成されるだけでなく、そのすべてのパラメーター、関連するデータシート、さらにそれに基づく Part Choice も取得されるため、あとはいくつかのドメインモデルを整理し、コンポーネントタイプと保存先フォルダーを設定して、Workspace に保存するだけです。

Single Component Editing モードで Component Editor を使用する場合の Manufacturer Part Search 機能とは異なり、Batch Component Editing モードではモデル(存在する場合) は取り込まれない点に注意してください。

Altium Designer でこの機能を利用するには、Component From Supplier Search ソフトウェア拡張機能がインストールされている必要があります。 この拡張機能は、標準で Altium Designer とともにインストールされています。 手動でインストールまたは削除することもできます。

拡張機能の管理の詳細については、 Extending Your Installation ページ(Altium Designer DevelopAltium Designer AgileAltium Designer)を参照してください。

この機能は、Component Editor の Definitions 領域から利用します。右クリックして、その領域のコンテキストメニューから Operations » Create from Part Search コマンドを選択してください。あるいは、メインメニューから Edit » Operations » Create from Part Search コマンドを選択するか、定義領域内をクリックしてキーボードショートカット Shift+Ctrl+M を使用します。

Manufacturer Part Search ダイアログが表示されます。現在有効になっているサプライヤーが提供する実在の製造部品データベースを対象に必要な部品を検索し、エントリを選択してから OK ボタンをクリックします。

このダイアログは Manufacturer Search panel と同じ方法で使用します。詳細は、このリンク先ページを参照してください。
ダイアログ内の検索結果は Manufacturer Part 単位で表示され、関連する SPN エントリには、その部品を供給する有効なベンダーが反映されます。部品を選択すると、そのメーカー部品が新しいコンポーネント定義の作成に使用されます。さらに Part Choice の観点では、特定のベンダー/サプライヤーではなくメーカー部品を基準に作成されるため、単一の Part Choice で、その部品を販売しているサプライヤーに基づくすべての候補(かつ Workspace 経由で利用可能なもの)を取り込めます。パラメーターは、Parameter Import Options に従ってインポートされます。これは Preferences ダイアログの Data Management – Parts Providers page で設定します。

Manufacturer Part Search ダイアログを開き、Component Editor に取り込みたい部品を検索します。
Manufacturer Part Search ダイアログを開き、Component Editor に取り込みたい部品を検索します。

OK をクリックすると、次の処理が行われます。

  • A selected part のコンポーネントエントリが Component Editor の定義領域に作成されます。この定義には次が適用されます。
    • 定義済みの Item Naming スキームに従い、次に利用可能な一意の Item ID が割り当てられます。
    • 選択した部品の Manufacturer Part Number パラメーター値が、その Name システムパラメーターの値として割り当てられます。
    • 選択した部品の Description パラメーター値が、その Description システムパラメーターの値として割り当てられます。
  • 選択した部品に対して定義されているすべてのパラメーター(ダイアログ内で表示されているもの)は、Required Models/Parameters リストに追加されます。すべて表示対象となり(関連する Show オプションが有効化)、既定では Definitions 領域に各パラメーター用の列が表示されます。
  • 選択した部品で利用可能な各データシートについても、パラメトリックエントリが追加されます(ComponentLinknDescriptionComponentLinknURL の組み合わせの形式)。
  • その定義には Part Choice(Part Choice 1)も追加され、部品の Manufacturer および Manufacturer Part Number パラメーターの値が、それぞれその Part Choice の Manufacturer フィールドおよび Part Number フィールドに使用されます。
パラメーターは、Parameter Import Options に従ってインポートされます。これは Preferences ダイアログの Data Management – Parts Providers page で設定します。

Manufacturer Part Search ダイアログで選択した部品について、作成された定義と追加されたパラメーターの例です。Manufacturer Part から取り込まれるデータがわかるようにハイライト表示されています。
Manufacturer Part Search ダイアログで選択した部品について、作成された定義と追加されたパラメーターの例です。Manufacturer Part から取り込まれるデータがわかるようにハイライト表示されています。

コンポーネントタイプの設定

Component Editor は、コンポーネント定義の設定時にコンポーネントタイプを定義する機能をサポートしています。これにより、Workspace の強力な Search facility を通じて、目的に応じた検索が可能になります。この機能ではコンポーネントタイプによる検索だけでなく、単位認識対応のコンポーネントパラメーターを用いた、より賢い検索も行えます。さらに、自身の Workspace ライブラリを Components panel で参照する場合、コンポーネントの Categories グループ分けは、各コンポーネントに定義されたコンポーネントタイプに基づいて行われます。

コンポーネントタイプは、定義領域の Component 領域にある Type 属性で指定します。Type フィールドをクリックし、続けて をクリックして Choose component type ダイアログを開きます。このダイアログで必要なコンポーネントタイプを選択し、OK をクリックすると、選択したタイプがメイン定義グリッド内の Type 属性の値として挿入されます。

Choose component type ダイアログには、既定のコンポーネントタイプ一式が表示されます。これらのタイプは環境設定レベルで定義されています。ダイアログ下部の ボタンをクリックすると、Preferences ダイアログの Data Management – Component Types ページが開きます。ここで、新しいタイプやサブタイプの追加、既存タイプの編集や削除を行い、この一覧を要件に合わせて調整できます。

コンポーネント定義の Type 属性を Diode に設定する例。
コンポーネント定義の Type 属性を Diode に設定する例。

複数のコンポーネント定義に対する Type フィールドは、一度の操作で設定できます。必要な各コンポーネント定義の Type フィールドを選択し、そのうち1つに対してタイプを選択すると、他のすべてにも適用されます。

保存後に、1つまたは複数のコンポーネントのコンポーネントタイプを、その場でまったく別のタイプに変更することも可能です。Components panel または Explorer panel で変更したいコンポーネントを選択し、右クリックしてコンテキストメニューから Operations » Change Component Type コマンドを選択します。すると Choose component type ダイアログが表示され、そこで新しいコンポーネントタイプを選択できます。
このフィールドには、参照されている Component Template で定義された ComponentType パラメーターの既定値、または File » New » Component コマンドを使って新しいコンポーネントを作成しようとした際に表示される Create new component ダイアログで選択したコンポーネントタイプが入力されます。

単位認識対応コンポーネントパラメーターデータ型のサポート

Component Editor は、参照されている Component Template 内で定義された、単位認識対応のコンポーネントパラメーターデータ型をサポートしています。2.2k、2k2、4M、2.5GHz など、さまざまな形式でパラメーター値をコンポーネント定義の該当フィールドへ直接入力でき、Workspace はそれらの入力の背後にある数値を認識するよう設計されています。

この Component Template の機能により、Workspace の Search facility を通じて目的に応じた検索が可能になります。この機能ではコンポーネントタイプによる検索だけでなく、範囲検索も行えます。単位認識対応コンポーネントパラメーターの力を活用すれば、たとえば容量が 47uF ~ 220uF のすべてのコンデンサーを検索するといった条件をすばやく定義できます。

単位認識対応パラメーターは、Components panel を使って自分のコンポーネントを検索する際のスマートフィルタリングにも使用されます。
コンポーネントパラメーターの単位認識対応データ型は、コンポーネントテンプレートを通じてのみ定義できます。

参照されるコンポーネントテンプレート由来で、単位認識対応データ型を持つコンポーネントパラメーター。
参照されるコンポーネントテンプレート由来で、単位認識対応データ型を持つコンポーネントパラメーター。

単位認識対応データ型を使用するコンポーネントパラメーターに値を入力する際、つまりコンポーネント定義に必要な値を入力する際には、次の点を考慮してください。

  • 値はさまざまな形式で入力できます。 
    • 数値のみ(例:10)。データ型に単位がある場合、その単位は自動的に適用されます。単位付きの型では、型名の後ろに括弧付きで単位が表示されます。
    • 科学表記の数値(例:1e101E6)。
    • 数値と単位(例:10F)
    • 接頭辞付きの数値(例:10k)。適切な単位が自動的に追加されます(該当する場合)。
    • 接頭辞と単位を含む数値(例:10kF)。
    • 一般的な工学表記で接頭辞を含む数値(例:抵抗値の場合:2k22K210r210R2)。値は自動的にそれに応じて正規化されます(例:2K22.2k になります)。
  • 数値の後の接頭辞や単位は、スペースあり/なしのどちらでも入力できます(例: 10uF または 10 uF)。スペースは自動的に削除されます。
工学上の略記は大文字小文字を区別しないため、2k2 の入力は 2K2 と同じであり、100R の入力は 100r と同じです。唯一の例外は M(Mega)と m(milli)です。

辞書定義コンポーネントパラメーターデータ型のサポート

Component Editor は、参照されている Component Template 内で設定された、辞書定義コンポーネントパラメーターデータ型をサポートしています。値セルをクリックしてドロップダウンを使うことで、辞書で定義された候補からパラメーター値を選択できます。値セル内をクリックしてそのまま値の入力を始めることもでき、その場合はドロップダウンが開き、最も近い値がリスト内でハイライトされます。

コンポーネントパラメーターの辞書定義データ型は、コンポーネントテンプレートを通じてのみ設定できます。

参照されるコンポーネントテンプレート由来で、単位認識対応データ型を持つコンポーネントパラメーター。
参照されるコンポーネントテンプレート由来で、単位認識対応データ型を持つコンポーネントパラメーター。

Workspace の管理者である場合は、値フィールド右側の  アイコンをクリックすると、Workspace のブラウザーインターフェース内の Settings – Vault – Dictionaries ページが開き、そこで辞書を管理できます。 

  • ​​​​​辞書定義パラメーターの値は、コンポーネントを Workspace に保存する際に検証されます。値が辞書と一致しなくなった場合(たとえば、その値が Workspace から削除された後、その値を使用しているコンポーネントを編集用に開いた場合など)、値フィールドが赤くハイライトされ、その値が適用不可能であることを通知します。値が辞書と整合していない限り、コンポーネントを Workspace に保存することはできません。

  • 接続先 Workspace のブラウザーインターフェースで辞書が変更された場合、それらの変更を Altium Designer に反映するには、Workspace から一度切断して再接続する必要があります。詳細は Accessing Your Workspace ページを参照してください。

コンポーネント名テンプレートの使用

Component Editor は(Batch Component Editing モード時のみ)、パラメータベースの Component Name Templates の使用をサポートしています。こうしたテンプレートを使用すると、エディター内でそのコンポーネントに対して使用可能な、現在定義されているパラメータ値(ユーザー/テンプレートパラメータであり、システムパラメータではありません)に基づいて、コンポーネントの名前、より正確にはその Item ID を正確に命名、あるいは名前変更できます。命名テンプレートにパラメータを含めるには、[<ParameterName>] 形式を使用します。例を挙げると、次のようになります。

  • CMP-[Value]

  • CMP-[Part Number]

  • [Part Number]-[Value]

  • [Value]

  • [Part Number]

テンプレートでは複数のパラメトリック宣言を使用することもできます。たとえば次のようになります。

  • CMP-[Part Number]-[Value]
  • CMP-[Manufacturer Part Number]-[Value]-[Tolerance]

さらに、完全に任意ですが、中括弧で指定するイテレータマクロ(例: {000}{00A})を追加することもできます。たとえば次のようになります。

  • CMP-[Value]-{001}
  • CMP-[Part Number]-{00A}

最も上位のレベルでは、必要な命名テンプレートを、Document Options ダイアログの Item Naming フィールドにデフォルトの命名スキームとして入力できます。この場合、初期インデックスは常に 0 になります。より細かく制御するには、名前を変更するコンポーネントを選択して、メインメニューから Edit » Operations » Rename Component (Edit » Operations » Rename n Components)コマンドを選択するか、右クリックしてコンテキストメニューから Operations » Rename ComponentOperations » Rename n Components)コマンドを選択します。すると Component Name Template ダイアログが表示されます。このダイアログを使用して、必要な Naming Scheme を指定し、Initial Index(テンプレートにイテレータマクロが追加されている場合)を制御します。

なお、このダイアログには最初に Document Options ダイアログで入力したデフォルトの命名スキームが表示されます。このスキームのままにすると、Initial Index は変更できません。後者は、別の命名スキームを使用した場合にのみ変更できます。

命名テンプレート内で CompanyPrtType および Value パラメータを使用し、Component Editor で定義中の選択コンポーネントの名前をすばやく変更する例です。
命名テンプレート内で CompanyPrtType および Value パラメータを使用し、Component Editor で定義中の選択コンポーネントの名前をすばやく変更する例です。

  • 名前変更処理で使用する命名スキームは、その処理にのみ使用されます。ドキュメントに定義されているデフォルトの命名スキームを置き換えるものではありません。後から追加するコンポーネント定義にも同じスキームで名前を付けたい場合は、Document Options  ダイアログの Component Naming フィールドを適宜変更して、ドキュメントレベルでこのスキームを定義してください。
  • 個々のコンポーネント定義の Item ID  は、グリッド内で直接変更することもできます。まず 1 回クリックして Item ID  セルにフォーカスを移し、次にもう 1 回クリックするか F2 を押してインプレース編集を開始します。必要に応じて名前を変更してください。なお、この方法で名前を直接編集する場合、パラメトリック宣言の使用はサポートされていません。

Part Choices

Component Editor を使用して、コンポーネントに対して 1 つ以上の Part Choices を指定できます。これは、実装済み基板上でそのコンポーネントを実現するために使用できる「許可された」製造元部品です。実際のサプライチェーンインテリジェンス(製造元(および部品番号)、サプライヤー(および部品番号)、説明、価格、在庫状況で構成)は、Workspace のローカル Part Catalog と関連する Part Source から取得されます。

各 Workspace には専用の Part Catalog があります。これは、製造元部品とそれに関連付けられたサプライヤー部品の管理および追跡に特化したローカル部品カタログデータベースです。ローカル Part Catalog には、実際の Manufacturer Part を表すアイテムと、それに加えて 1 つ以上の Supplier Part を表すアイテム(サプライヤー/ベンダーによって販売される、それら Manufacturer Part の実体)が保存されます。各 Supplier Part は部品データベース内のアイテムへの参照であり、その参照先は Altium Parts Provider の集約部品データベース(有効化されたサプライヤーと連携し、それらから部品を収集)か、Enterprise Server Workspace の場合はリンクされたローカル部品データベース(ODBC ベース)です。必要なサプライヤーを有効にし、Workspace のブラウザーインターフェースの Part Providers 領域内で Altium Parts Provider の Location/Currency 範囲を設定してください。Altium Designer から Workspace に接続したままでいる間、Preferences ダイアログの Data Management – Parts Providers ページ上の Altium Parts Options 領域は読み取り専用となり、Workspace 用に定義された設定が適用されます。Workspace の Altium Parts Provider part source の管理に関する詳細は、Part Source Configuration (Altium 365 WorkspaceEnterprise Server Workspace)を参照してください。

Required Models/Parameters 領域から part choice を追加するには、Add コントロールをクリックし、Part Choices サブメニューから By MPN コマンドを使用します。あるいは、カスタムデータベース part source を構成している場合は、By Internal ID メニュー項目を選択します。使用する part choice はいくつでも追加できます。

定義中のコンポーネントで使用する part choice を追加すると、定義領域に Part Choice n エントリが追加され、その choice を指定するための 2 つの列が表示されます。これらの列は、選択した part choice のスタイルによって異なります。

  • By MPN – 表示される 2 つの列は ManufacturerPart Number です。

  • By Internal ID – 表示される 2 つの列は Part sourceInternal ID です。

定義中のコンポーネントで使用する part choice(By MPN)を追加しています。ホバーすると、By Internal ID として追加された part choice の例が表示され、社内の内部部品データベース内の部品に接続できます。
定義中のコンポーネントで使用する part choice(By MPN)を追加しています。ホバーすると、By Internal ID として追加された part choice の例が表示され、社内の内部部品データベース内の部品に接続できます。

基板の製造および組み立て時に使用したい実部品の Manufacturer と Manufacturer Part Number を、それぞれ Manufacturer フィールドと Part Number フィールドに入力します。

構成済みのカスタムデータベース part source を使用している場合は、Part source フィールドを使用して part source を選択します。Workspace に定義されているすべてのカスタムデータベース part source が一覧表示されます。必要な部品の ID を Internal ID フィールドに入力します。

Component editor を Batch Component Editing モードで使用していて、コンポーネント内に manufacturer と manufacturer part number のパラメータの組み合わせが検出された場合、Part Choice Migration ダイアログが開き、それらのパラメータを part choices()に変換するよう提案されます。パラメータを part choices にコピーまたは移動することを選択すると、新しい part choices が作成され、その および Part Number の値はパラメータの値によって定義されます。

manufacturer および manufacturer part number として検出されたコンポーネントパラメータは、以下の折りたたみ可能セクションに一覧表示されます。パラメータ名に数値サフィックスがある場合(たとえば、パラメータ名が Manufacturer 1 および Manufacturer Part Number 1 の場合)も、これらのパラメータは検出されます。

注意すべき点がいくつかあります。

  • part choice を追加しても、コンポーネント定義でそれを使用しなければならないわけではありません。ただし、2 つのフィールドのいずれか一方に値を入力すると、もう一方のフィールドに赤い枠が表示され、そのコンポーネントを Workspace に保存する前に値の入力が必要であることを知らせます。

  • フィールド値を誤って入力し、その part を Workspace が取得できない場合、テキストは灰色のイタリック体で表示されます。両方の入力が正しくなると、テキストは通常の白色表示になります。値では大文字と小文字は区別されません。

ダイアログベースでの MPN Part Choice の追加

part choice に関連付けられたセルへ Manufacturer と Part Number の情報を直接入力することもできますが、manufacturer part を検索できるダイアログを使用した方がはるかに簡単です。この機能を利用するには、まず Required Models/Parameters 領域に初期の Part Choice 1 エントリを追加した後、その choice 用セルのいずれか(定義中の対象コンポーネントに関連付けられているセル内)をクリックします。すると、エディターの Preview 領域に ボタンが表示されます。これをクリックすると Add Part Choices ダイアログにアクセスできます。このダイアログは Manufacturer Part Search panel と同様の方法で使用します(UI の全要素の詳細はそのページを参照してください)。

part choice を作成するには、Add Part Choices ダイアログを使用して必要な manufacturer part を検索し、そのエントリを選択して OK をクリックします。
part choice を作成するには、Add Part Choices ダイアログを使用して必要な manufacturer part を検索し、そのエントリを選択して OK をクリックします。

ダイアログ内の検索結果は Manufacturer Part 単位で表示され、それに関連する SPN エントリには、その part を供給する有効化済みベンダーが反映されます。part を選択すると、Part Choices リストに追加されるのは manufacturer part です。特定のベンダー/サプライヤーではなく manufacturer part を使用することで、その part を販売するサプライヤー(かつ、Workspace 経由で利用可能なサプライヤー)に基づくすべての候補を含む単一の Part Choice を得ることができます。

ダイアログを使用して必要な manufacturer part を検索し、part を選択してから OK ボタンをクリックします。manufacturer part の SPNs エントリ(Supplier Part Numbers)をクリックすると、その part を供給可能なサプライヤーを確認でき、在庫状況や価格などに基づいて適切な part choice を選択しているか判断できます。選択した part は Component Editor に戻され、Part Choice 1 エントリのセルと Preview 領域の両方に入力されます。

Add Part Choices ダイアログを使用して追加した part choice の例が、Component Editor に表示された状態です。
Add Part Choices ダイアログを使用して追加した part choice の例が、Component Editor に表示された状態です。

さらに part choice が必要な場合は、 ボタンをクリックして追加を続けてください。関連する Part Choice n エントリが自動的に作成されます。

part choice を削除するには、リスト内でそれを選択し、 ボタンをクリックします。

part choice によって提供される情報の詳細については、Adding Supply Chain Information to a Component ページを参照してください。

Part Choices の自動ランキング

星印機能を使用して part choice にユーザーランクを定義できるだけでなく、Component editor で定義/編集中のコンポーネントに対して、part choices のランキングを自動設定することもできます。

  • 1 つ以上のコンポーネント定義エントリを選択し、その選択を右クリックして、右クリックメニューから Set Part Choice Ranks Automatically コマンドを選択すると、選択したコンポーネントの part choices にランキングを設定できます。

  • メインメニューから Tools » Set Part Choice Ranks Automatically コマンドを選択すると、すべてのコンポーネントの part choices にランキングを設定できます。

part choices は、設定されたランクに従って、コンポーネント定義グリッドおよびエディターのプレビュー領域で並べ替えられます。すでにランク付けされている part choices は、既存の順序を保持します。

コンポーネント定義へのデータシートの添付

Component Editor を通じてコンポーネントを定義する際に、1 つまたは複数のコンポーネントへ 1 つ以上のデータシートを添付できます。これにより、たとえば特定ファミリーに属するすべてのコンポーネントに同じ必要なデータシートをすばやく添付できます。

Component Editor でコンポーネントを編集する観点から見た、さまざまなデータシートのリンク例です。
Component Editor でコンポーネントを編集する観点から見た、さまざまなデータシートのリンク例です。

コンポーネント定義へのデータシート添付は、いくつかの手順から成り、ここでは概要を示し、以降の各セクションで詳しく説明します。

  1. データシートの使用を有効にする。
  2. 選択したコンポーネントへデータシートをアップロードする。
  3. アップロードしたデータシートを他のコンポーネント定義に割り当てる。

コンポーネント命名の検証チェック

ソフトウェアは、複数ユーザーによって作成され Workspace に保存されるコンポーネントの ID を検証し、重複した Item ID の問題を防ぎます。ユーザーが Component Item を作成すると、割り当てられた Item ID は「ロック」され、最初のユーザーがそのコンポーネントを Workspace に保存していない場合、または保存しない場合であっても、他のユーザーはその ID を使用できなくなります。ほかのユーザーがコンポーネント定義の一部として Item ID を手動で変更し、それが既存の Item(または作成予定の Item)ですでに使用されている ID であった場合、その ID は適用される命名スキームに従って、次に使用可能な未使用 ID に変更されます。

コンポーネント Item ID がロックされていても、その時間内に保存が行われなかった場合は、30 分後に自動的に解除されます。

コンポーネント定義のコピー作成

わずかな違いだけを持つコンポーネント定義をすばやく作成できるように、このエディタにはコピー機能があります。既存の定義のコピーを作成するには、定義リストで対象を選択し、メインメニューから Edit » Make a copy of the component コマンドを選択するか、右クリックしてコンテキストメニューから Make a copy of the component コマンドを選択します(ショートカット: Ctrl+D)。コピーは定義リストの末尾に追加されます。

コピーは、次の点において元のコンポーネント定義の完全な複製になります。

  • Workspace 内の同じフォルダを対象とすること。つまり、元のコンポーネントが存在するフォルダ、または(まだ保存されていない場合は)保存先として指定されているフォルダです。
  • 同じドメインモデルを参照すること。
  • NameDescriptionType、テンプレートパラメータ、および追加のユーザー定義パラメータの値が同じであること。

一方、次の点は異なります。

  • 元のコンポーネントに定義されていたデータシートは引き継がれません。

  • 元のコンポーネントに定義されていた部品選択は引き継がれません。

  • 次に利用可能な一意の Item ID が割り当てられます。

  • 新しい Component Item の初期リビジョンに保存されるよう設定されます(ActionCreate Item に設定)。

コンポーネント定義のコピー例です。コピー後、必要に応じて、1 つ以上のパラメータ値の変更、部品選択の定義、必要なデータシートの追加などを行います。
コンポーネント定義のコピー例です。コピー後、必要に応じて、1 つ以上のパラメータ値の変更、部品選択の定義、必要なデータシートの追加などを行います。

コピー後は、必要に応じて変更を加えてください。たとえば、1 つ以上のパラメータの値を変更します。

このコピー機能は、 Copy Component コマンドと Paste Component コマンドを順に使用するのと似ています。既存のコンポーネント定義をより素早くコピーできますが、コピー機能は単一のコンポーネント定義に対してのみ使用できます。一方、Copy/Paste Component コマンドは複数の定義に対して機能します。

コンポーネント定義のグループ化

コンポーネント定義は、表示されている任意の列見出しに基づいてグループ化できます。これを行うには、列ヘッダーをクリックしたまま、Drag a column header here to group by that column と表示されているテキスト上にドラッグ&ドロップします。

たとえば、次の画像では、コンポーネント定義が Case-Metric パラメータでグループ化されています。これにより、グループ化に使用した列の異なる値の数だけコンポーネント定義が分かれます。この例では 9 個のグループが作成されます。

列内の値に基づいてコンポーネント定義をグループ化した例です。この場合は Case-Metric パラメータによるグループ化です。
列内の値に基づいてコンポーネント定義をグループ化した例です。この場合は Case-Metric パラメータによるグループ化です。

列ヘッダーを入れ子にすることで、グループ階層を作成できます。グループ化された列領域内では、ドラッグ&ドロップで必要に応じてグループ化の「並び順」を再定義できます。

コンポーネント定義の並べ替え

コンポーネント定義は、特定の列ヘッダーをクリックすることで並べ替えできます。1 回クリックすると、その列の内容に基づいて昇順で並べ替えます。もう 1 回クリックすると降順で並べ替えます。

複数列による並べ替えも可能です。すでに特定の列でコンポーネント定義が並べ替えられている状態で、別の列に対して Shift+Click すると、その列の内容による「サブソート」が行われます。

列の並べ替えを解除するには、そのヘッダー上で Ctrl+Click します。

列ベースでのコンポーネント定義のフィルタリング

Excel のスプレッドシートと同様に、コンポーネント定義は各列の内容でさらにフィルタリングできます。 これを行うには、列ヘッダーの右側にある小さな漏斗(フィルタ)アイコン()をクリックします。すると、その列に存在する各値ごとのチェックボックスを含むメニューが表示されます。必要なチェックボックスを有効にすると、その値を持つコンポーネント定義だけにリストを絞り込めます。

あるいは、より詳細にフィルタを制御するには (Custom...) を選択します。すると Custom Filter ダイアログが表示されます。このダイアログでは、データ列に適用するフィルタ条件に基づいて表示したい情報行を指定し、要件に合ったカスタムフィルタを設定できます。

標準の列フィルタリングとカスタマイズされた列フィルタリングを選択して適用できます。
標準の列フィルタリングとカスタマイズされた列フィルタリングを選択して適用できます。

列フィルタが適用されると、フィルタアイコンは青色()で表示され、その列に基づくフィルタが適用中であることを示します。フィルタリングは複数のデータ列に適用できます。各「列フィルタ」は、全体フィルタ内で AND 条件として扱われます。現在有効なフィルタの文字列表現は、その領域の下部に表示されます。

列フィルタリングの動作例。
列フィルタリングの動作例。

列のフィルタをクリアするには、フィルタのドロップダウンから (All) エントリを選択します。フィルタを完全にクリアするには、フィルタの文字列表現の左側にある ボタンをクリックします。フィルタを無効にするには、文字列表現の左側にあるチェックボックスをオフにします。再度有効にするには、そのチェックボックスをオンにします。
編集セッション中は、直前まで使用していたフィルタの履歴を利用できます。現在のフィルタの文字列表現の右側にある ボタンをクリックすると履歴が表示されます。この履歴リストは、一時的な Component Editor を閉じるとクリアされます。

現在のフィルタをさらにカスタマイズするには、フィルタの文字列表現のいちばん右にある ボタンをクリックして Filter Builder ダイアログを開きます。

Filter Builder ダイアログを使用して、より高度なフィルタを作成します。
Filter Builder ダイアログを使用して、より高度なフィルタを作成します。

必要に応じて、このダイアログを使用して、より高度で複雑なフィルタを作成できます。

  • Filter - クリックして追加のフィルタ条件にアクセスします。Clear All をクリックすると、すべてのフィルタをクリアします。選択肢は次のとおりです。
    • Add Condition - クリックして、equalsbetween などのフィルタ条件を追加します。
    • Add Group - クリックして、ANDOR などのフィルタグループを追加します。
  • Links - 各種リンクをクリックして、フィルタをさらに定義します。
    • Id - 各種リンクをクリックして、たとえば DescriptionName など、フィルタ対象とする項目を選択します。
    • AND など。- 各種リンクをクリックして、たとえば OR などの論理演算子/種別を指定します。
    • like - 各種リンクをクリックして、equalsis blankis greater than などの演算子を指定します。
    • <empty> - 各種リンクをクリックして条件値を追加します。リンクをクリックした後、テキストボックスに目的の値を入力します。
  • press the button to add a new condition - クリックして追加の条件を加えます。
よく使用するフィルタは保存して再利用できます。これは Filter Builder ダイアログで ボタンをクリックし、現在のフィルタを Filters ファイル(*.flt)に保存することで行います。以前に保存したフィルタを再読み込みするには ボタンをクリックします。

データの表示

定義しているコンポーネントの種類によっては、かなり多くのパラメータが存在する場合があり、それらが他のデータ列に加わることで、部分的にしか判読できない内容が入り乱れた状態になることがあります。これに対応するため、コンポーネント定義領域には 2 種類の表示モードが用意されています。領域右下のコントロールを使ってモードを切り替えます。

このコントロールには、現在有効なモードではなく、クリックしたときに有効になるモードが表示されます。
  • Best Fit – このモードでは、各データ列は、その列内の最大データ項目に合わせて、さらに少し余白を加えた幅に自動調整され、すべてのデータを表示できるようになります。各列がデータ表示に合わせてサイズ変更されるため、列全体が現在表示可能な領域を超える場合があります。これに対応するため、読みやすさを保てるよう水平スクロールバーが用意されています。
  • Auto Width – このモードでは、ソフトウェアはグリッドの表示可能領域内にすべてのデータ列を収めようとし、必要に応じて拡張または圧縮します。データ列がそれほど多くない場合には問題なく機能しますが、列数が多いと可読性が低下することがあります。

Auto Width と Best Fit の表示モードの使用例。
Auto WidthBest Fit の表示モードの使用例。

データ表示をさらに補助するために、モデル列とパラメータ列の表示を個別に切り替えることができます。これは、エディタの Required Models/Parameters 領域にあるそれぞれの Show オプションを使用して行います。
また、データ列の幅を手動で調整して表示を微調整することもできます。列ヘッダーの右端をクリックしてドラッグしてください。

コンポーネント定義 – 編集テクニック

作成しているコンポーネントによっては、Component Editor にかなり多くのコンポーネント定義が含まれることがあります。場合によっては、これらの定義の違いはごくわずかで、多くが似たモデル情報やパラメトリック情報を必要とします。このドキュメントでは、1 つまたは複数のコンポーネント定義にすばやく変更を反映できる各種編集機能をサポートしています。

  • モデルおよびパラメータに対しては複数セル編集が実装されています。列内の複数のデータセルは、標準的な Ctrl+Click および Shift+Click のキーボード操作を使って選択できます。複数のコンポーネントにモデルを割り当てるには、セル範囲を選択し、ドロップダウンをクリックしてモデルリンクのポップアップウィンドウを表示します。ポップアップで必要なモデルをダブルクリックすると、そのモデルが選択したすべてのモデルセルに割り当てられます。

    パラメータの場合は、同じ列内の必要なセルを選択し、フォーカスのあるセルに必要な値を入力してから、ほかの場所をクリックするか Enter を押します。選択範囲内のすべてのセルに同じ値が設定されます。

    この機能は FolderPath に対しても使用できます。該当するコンポーネント定義の FolderPath 列内のエントリを選択し、フォーカスのあるエントリの ボタンをクリックして、Choose Folder ダイアログで対象フォルダを選択します。選択したすべての定義の FolderPath がこのフォルダを指すように変更されます。
  • 選択したデータセル間では、それぞれ Ctrl+X、 Ctrl+CCtrl+V を使用して切り取り、コピー、貼り付けができます(または右クリックメニューやメイン Edit メニューの対応コマンドを使用します)。

    対象セルがクリップボードのデータと互換性がない場合、貼り付けは実行されません(たとえば、パラメトリックデータをモデルリンク欄に貼り付ける場合など)。

  • 選択したデータセルの内容は、Delete キー(または右クリックメニューの Clear Contents コマンド、あるいはメインメニューの Edit » Clear Contents コマンド)を使ってクリアできます。

    Component Library ドキュメントが Component Template を参照している場合は、次の点に注意してください。

    • テンプレート内でパラメータが Read Only としてマークされている場合、そのパラメータに対応するセルの内容をクリアすることはできません。
    • テンプレート内でパラメータが Required としてマークされている場合、そのパラメータに対応するセルの内容をクリアすると、値が必要であることを示すために、そのセルが赤い枠線で強調表示されます。
  • 選択したコンポーネント定義は、それぞれ Ctrl+Shift+C、 Ctrl+Shift+XCtrl+Shift+V を使用してコピー、切り取り、貼り付けできます(または右クリックメニューやメイン Edit メニューの対応コマンドを使用します)。

    • 単一のコンポーネント定義をすばやく複製するには、 Make a copy of the component command を使用します。

    • クリップボード上のコンポーネント定義は、Component Editor のメイングリッド領域に 2 通りの方法で貼り付けることができます。

      • 現在の定義リストの末尾に貼り付ける場合 - 現在どの定義も選択されていないことを確認してから、コマンドを実行します。
      • 現在の定義を上書きする場合 - 上書きしたい定義の上で右クリックし、コマンドを実行します。確認ダイアログが表示されるので、Yes をクリックして続行します。既存のセルデータは、貼り付ける定義のデータで上書きされます。上書きが機能するのは、フォーカスされている定義に対してのみである点に注意してください。クリップボードに複数の定義がある場合、最初の 1 つだけがフォーカスされた定義の「上」に貼り付けられ、残りは定義リストの末尾に貼り付けられます。
  • 選択したコンポーネント定義は、コンポーネント定義グリッドの下にある Remove Component コントロール、右クリックメニューまたはメイン Edit メニューの Remove <ComponentName> (Remove n Components)コマンド、あるいは Ctrl+Del ショートカットを使用して完全に削除できます。
  • グリッドの内容は、メイン Edit または View メニュー、あるいはメイングリッド領域の右クリックメニューの Refresh コマンド、F5 キーボードショートカット、または Component Library Standard ツールバー上の ボタンをクリックすることで更新できます。
  • 選択したデータセルは Windows クリップボードにコピーして、外部のスプレッドシートアプリケーションで編集できます。また、外部スプレッドシート内のコンポーネント定義情報をコンポーネント定義領域に貼り戻すこともできます。
Component Editor の上部領域は、エディタ右上にある小さな矢印 をクリックすることで折りたたむこともでき、表示領域全体をコンポーネント定義の編集に使えるようになります。

保存済み定義の参照

Workspace に保存した後は、Components panel または Explorer panel を使用して、Workspace 内のコンポーネントを直接参照できます。

すでに保存済みで現在編集中のコンポーネントについては、Component Editor から定義領域内のエントリを右クリックして Operations » Show in Explorer コマンドを選択するか、メインメニューから Edit » Operations » Show In Explorer コマンドを選択することで、Workspace 内のその Component Item に直接ジャンプできます。

そのコンポーネントのリビジョンを編集用に開いているときは、Component Editor から直接、すでに保存されているコンポーネントへ Explorer パネル内でジャンプできます。
そのコンポーネントのリビジョンを編集用に開いているときは、Component Editor から直接、すでに保存されているコンポーネントへ Explorer パネル内でジャンプできます。

既存の Component Item を対象にする

多くの場合、対象 Workspace へのコンポーネント作成は保存処理の一部として行うのが一般的です。コンポーネント定義を追加し、Item ID を割り当てれば、そのまま進められます。いわば「その場で」コンテンツを作成する形です。ただし、Workspace 内で直接コンポーネントを作成して(あるいは作成しておいて)、それら既存コンポーネントにリンクしたい場合もあります。または、既存のリリース済みコンポーネント定義に関連付けられている対象 Component Item を変更したい場合もあります。

コンポーネント定義に関連付けられた右クリックの Operations サブメニュー(およびメインメニューの Edit » Operations サブメニュー)には、手動で作成したコンポーネントへのリンクをサポートするためのコマンドがいくつか含まれています。

  • Change Link To Target Item – このコマンドを使用して Choose Target Item ダイアログを開き、Workspace 内で必要なコンポーネントを参照して選択できます。

    選択したコンポーネント定義がすでにコンポーネントにリンクされている場合、ダイアログにはそのコンポーネントがあらかじめ選択された状態で表示されます。定義がまだリンクされていない場合は、その定義に対して設定されている対象フォルダが表示されます。

    対象 Workspace 内の既存コンポーネントにリンクされると、そのコンポーネント定義の Item ID  はグレー表示(編集不可)になります。

    このコマンドは、コンポーネント定義が選択されている場合にのみ、該当メニューで使用可能になる点に注意してください。複数のコンポーネント定義が選択されている場合、このコマンドはフォーカスされている定義に対して動作します。フォーカスされた定義は、選択セルの点線枠で識別されます。
  • Clear Link To Target Item (Clear Links To Target Items) – このコマンドを使用して、Workspace 内の既存コンポーネントへのリンクを解除します。コンポーネント定義のリリース関連フィールドは、新しい Item を作成する準備ができた状態に戻ります。

    リンクを解除する必要が生じるのは、新しい一式のコンポーネントとして再度リリースする必要がある場合です。たとえば、以前にリリースした後で Workspace からそのコンポーネントを削除した場合でも、ソースライブラリにはリンク定義が残っています(ただし、Workspace 側のコンポーネントが存在しないため無効です)。

    すでにコンポーネント定義を保存している場合、この手順により、その定義と以前リンクされていたコンポーネントは相互の関連情報を失うことになります。

    対象 Workspace 内の既存コンポーネントへのリンクが解除されると、そのコンポーネント定義の Item ID  は編集可能になります。グリッドの 領域にある Action  フィールドのエントリは Create Item に変わり、そのコンポーネント定義が現在、対象 Workspace 内のコンポーネントにリンクされていないことを示します。

コンポーネントルールチェックの実行

Component Editor で定義または編集した Workspace Library コンポーネントを、接続されている Workspace に保存して設計で利用可能にする前に、そのコンポーネントが設定済みの要件を満たしていることを確認するのは重要です。Component Editor では、コンポーネントを Workspace に保存しようとしたとき、またはこの機能を手動で実行したときに、検証(Component Rule Check)が実行されます。

コンポーネント検証の詳細については、Validating a Component ページを参照してください。

リンクされたシミュレーションモデルについて

Related page: シミュレーションモデルの作成

シンボルモデルやフットプリントモデルと同様に、コンポーネントはシミュレーションモデルのリビジョンを参照することもできます。このタイプのモデルリンクの追加方法は、シンボルやフットプリントの場合とまったく同じですので、その点については前のセクションを参照してください。ここでは、コンポーネントレベルのシミュレーションパラメータの追加と、ピンマッピングの設定について説明します。

コンポーネントレベルのシミュレーションパラメータの追加

設計内のコンポーネントでシミュレーションモデルを使用する場合、そのモデル固有のパラメータは 2 つの異なるレベルで指定できます。

  • Model-Level Parameter – シミュレーションモデル定義自体(SimModel ファイル内)の一部として指定し、その定義とともにリンクされたシミュレーションモデルのリビジョンに保存する。
  • Component-Level Parameter – コンポーネント定義の一部として(ここでは Component Editor 内で)指定し、その定義とともにリンクされたコンポーネントのリビジョンに保存する。
コンポーネントレベルのパラメータは、複数のモデル間で共有されるパラメータや、設計者が回路図上でそのようなパラメータを表示または編集できるようにしたい場合(たとえば値、周波数など)に使用されます。

パラメータは、Component Editor の Required Models/Parameters 領域でコンポーネント レベルに追加されます。ここで重要なのは、パラメータ名をモデル レベルで定義されているパラメータ名と同一にする必要があるという点です。モデル レベルのパラメータ、つまりコンポーネント レベルで追加可能なパラメータ(およびその名前)を確認するには、SIM モデルのリンクを選択し、プレビュー ウィンドウの下部にある View Parameters コントロールをクリックします。

Simulation Model Item のモデル レベル パラメータを確認し、コンポーネント レベルで追加できるパラメータと、その正確な名前を把握します。
Simulation Model Item のモデル レベル パラメータを確認し、コンポーネント レベルで追加できるパラメータと、その正確な名前を把握します。

利用可能なモデル レベル パラメータが確認できたら、それらと同じパラメータをコンポーネント レベルに追加して、あらゆるコンポーネント定義で使用できるようにします。そのためには、Required Models/Parameters 領域の下部にある Add コントロールをクリックし、メニューから Parameter を選択します。新しいパラメータ エントリがリストに追加されます。必要に応じて名前を変更しますが、対応するモデル レベルのパラメータ名と完全に一致させるようにしてください。

シミュレーション関連のパラメータをコンポーネント レベルで追加します。この例のコンポーネントが参照している Component Template により、Area Factor という 1 つのパラメータはすでに使用可能になっている点に注意してください。
シミュレーション関連のパラメータをコンポーネント レベルで追加します。この例のコンポーネントが参照している Component Template により、Area Factor という 1 つのパラメータはすでに使用可能になっている点に注意してください。

保存済みコンポーネントのインスタンスを設計に配置すると、シミュレーション パラメータは、モデル レベルでの同じパラメータの値とは異なる値をコンポーネント レベルで持たせることができます。ネットリスト生成時には、コンポーネント レベルのパラメータが優先されます。
一部の組み込み SPICE3f5 モデルでは、コンポーネント レベルでパラメータ値を入力すると、リンクされたモデル ファイル(*.mdl)で定義されている関連パラメータが上書きされます。たとえば半導体コンデンサでは、コンポーネント レベルの Width パラメータに値を指定すると、関連するモデル ファイル内の DEFW パラメータに指定された値は上書きされます。サブサーキット モデルに対してコンポーネント レベルでパラメータが指定されている場合、その値はリンクされたサブサーキット ファイル(*.ckt)で定義されている値より優先されます。

ピン マッピング

必要な SIM モデルへのリンクを選択したら、次に、回路図ドメインで表現されるコンポーネントのピンが、シミュレーション モデルのピンに正しくマッピングされていることを確認する必要があります。これは Pin Mapping ダイアログで行います。このダイアログは、コンポーネント定義の SIM モデル エントリを右クリックしてコンテキスト メニューから Operations » Edit Pin Mapping を選択するか、SIM モデルのセルを選択してメイン メニューから Edit » Operations » Edit Pin Mapping コマンドを選択することで開けます。各回路図ピンについて、使用可能なドロップダウンを使って対応する Model Pin エントリを適切に変更してください。デバイスがマルチパートの場合は、各パートのマッピングを必ず確認してください。

回路図ピンからモデル ピンへのマッピングが正しいことを確認します。
回路図ピンからモデル ピンへのマッピングが正しいことを確認します。

マルチパート コンポーネントの場合、パートをシミュレーション対象から除外する機能も Pin Mapping ダイアログで設定します。
組み込みの SPICE3f5 およびサポートされている PSpice モデルについては、モデル内の各ピンの機能は、SPICE 3f5 ユーザー マニュアルのそのモデルの general form セクションに記載されています。サブサーキット モデルでは、通常、メーカーがモデルの各ピンにコメントを挿入し、そのピンの機能を説明しています。コメントが見当たらない場合、モデルのピン配列は通常、物理デバイスそのもののピン配列に従います。この場合は、デバイスのデータシートを参照してください。
AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium DevelopAltium Agile TeamsAltium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Content