コンポーネントの一括編集

Workspace コンポーネントは、2 つのモード(Single Component Editing および Batch Component Editing)で動作する Component Editor を使用して定義/編集します。後者は複数コンポーネントの定義/編集用インターフェースを提供しますが、必要に応じて単一コンポーネントの定義/編集にも使用できます。Component Editor が Single Component Editing モードのときは、エディターのメインメニューから Tools » Switch to Batch Editor コマンドを選択することで、バッチ編集モードにアクセスできます。

  • モードでコンポーネントを定義している際、そのコンポーネントにまだ Workspace に保存されていないモデルがある場合、Batch Component Editing モードへ切り替えることはできません。まずコンポーネントを Workspace に保存してから編集してください。そうすると、編集モードを切り替えられるようになります。

  • Component Editor の Batch Component Editing モードに現在 1 つのコンポーネント定義しか含まれていない場合は、メインメニューから Tools » Switch to Single Component Editor コマンドを選択することで Single Component Editing モードに切り替えられます。このコンポーネント定義のデータは Single Component Editing モードに反映されます。

Component Editor の Batch Component Editing モードは、Components panel または Explorer panel から複数のコンポーネントを選択して編集する場合にも開きます。各コンポーネント定義には、共通のパラメーターセットと必要なドメインモデルへのリンクが含まれます。たとえばチップ抵抗のセットのように、コンポーネントをひとまとめで管理したい場合に、バッチ編集は特に有効です。

このドキュメントでは、Component Editor の Batch Component Editing モードでの作業について説明します。

Component Editor の Single Component Editing モードでの作業の詳細については、Single Component Editing を参照してください。

インターフェースの概要

Batch Component Editing モードの Component Editor インターフェースは、基本的に 4 つの主要領域に分かれており、以下の図で示し、その後に概要を説明します。

Component Editor を Batch Component Editing モードに切り替えると、4 つの主要領域に分けることができます。
Component Editor を Batch Component Editing モードに切り替えると、4 つの主要領域に分けることができます。

  1. Required Models/Parameters – ここでは、コンポーネント定義に必要なドメインモデルの種類を定義し、さらにすべてのコンポーネント定義に適用されるパラメトリックデータのセットを作成します。
  2. Model Links – ここでは、コンポーネント定義で使用するために保存済みドメインモデルへのリンクを追加します。
  3. Preview Window – 現在選択されているモデルのプレビューを表示します。シンボルおよびフットプリントはグラフィカルに、それ以外のモデルタイプはテキストで表示されます。
  4. Component Definition(s) – ここでコンポーネントを定義します。内容には、フォルダー、名前、タイプ、参照するドメインモデル、パラメトリックデータ、部品候補が含まれます。
The Required Models/Parameters and Model Links regions can be horizontally collapsed by clicking the control at the respective top-left. In addition, the top three regions can be collapsed, leaving just the Component Definitions region by using the control at the top-right.

ドキュメントオプション

コンポーネントの作成先となる Workspace フォルダー、およびそれらのコンポーネントに使用するライフサイクル定義と命名スキームを指定するためのコントロールは、Document Options ダイアログ(Edit » Document Options)で利用できます。さらに、Component Editor からリリースされるコンポーネント用のデフォルトの Component Naming スキームを定義して、Workspace 内の各生成コンポーネントに一意の ID を割り当てることもできます。

Workspace 設定は Document Options ダイアログで定義します。
Workspace 設定は Document Options ダイアログで定義します。

  • Target Server – 1 つまたは複数の新規コンポーネントを作成する場合、対象 Workspace は現在アクティブに接続しているものになります。既存コンポーネントを編集している場合、このフィールドにはそれらのコンポーネントが存在する Workspace が表示されます。ドロップダウンの右にある Server Admin ボタン(コンポーネントがまだリリースされていない場合に使用可能)をクリックすると、Preferences ダイアログの Data Management – Servers page が開き、そこからアクティブおよび既知の Workspace を参照・管理できます。

    複数の Workspace に接続していても、同時にアクティブ接続できる Workspace は 1 つだけです。

  • Default Folder – 1 つまたは複数の新規コンポーネントを作成する場合、このフィールドを使って、保存したコンポーネントの格納先となる対象 Workspace 内のデフォルトフォルダーを指定します。Choose ボタンをクリックして Choose Folder ダイアログを開いてください。これは Explorer panel の派生版で、Workspace 内の既存フォルダーを参照して選択することも、その場で新しいフォルダーを作成することもできます。ここで指定した内容は、新しいコンポーネント定義を追加する際の FolderPath のデフォルトとして使用されます。1 つまたは複数の既存コンポーネントのリビジョンを編集している場合、このフィールドには既存のフォルダーが表示され、編集はできません。この場合、Choose ボタンも使用できません。Show in Explorer ボタンをクリックすると、Explorer panel 内で指定されたデフォルトフォルダーをすばやく参照できます。

  • Lifecycle Definition および Revision Naming – これらのフィールドを使用して、それぞれに適切なデフォルトスキーム(Component Lifecycle および 1-Level Revision Scheme)を設定します。各フィールドに関連付けられたドロップダウンを使うと、親 Workspace に現在定義されている任意のスキームから別のものを選択できます。

    コンテンツタイプごとにライフサイクル定義とリビジョン命名スキームの使用を制御するオプションが、いずれかの定義/スキームに対して有効になっており、かつ Component コンテンツタイプに特定の定義/スキームが設定されていない場合、その定義/スキームは該当するドロップダウンリストには表示されません。

  • Item Naming – このフィールドは、Component Editor から保存されるコンポーネントのデフォルト Item Naming Scheme を定義するために使用され、Workspace 内の各 Component Item に一意の ID が付与されるようにします。ここでの入力内容は、新しく追加されたコンポーネント定義を自動命名するためのテンプレートとして使用されます(関連する Item ID フィールド内)。ソフトウェアは Workspace 全体と既存コンテンツの識別子をスキャンしたうえで、そのスキームに基づく次に利用可能な一意 ID を自動的に割り当てます。

    コンポーネントが存在する(または作成される)親フォルダーに命名スキームが定義されている場合、それがデフォルトとしてあらかじめ入力されます。定義されていない場合は、デフォルトスキームの CMP-{00000} が使用されます。もちろん、このフィールドに直接入力して独自のスキームを作成することもできます。パラメーターベースの Component Name Templates もサポートされています。これらのテンプレートを使用すると、Component Editor 内でそのコンポーネントに対して現在定義されているパラメーター値に基づいて、コンポーネント名を正確に設定、または再設定できます。テンプレートにパラメーターを含めるには、[<ParameterName>] 形式を使用します。テンプレートには複数のパラメーターを使用でき、さらに中かっこで指定するイテレーターマクロ(例: {000}, {00A})を追加することもできます。

    または、定義の Item ID フィールドに必要な ID を直接入力することで、コンポーネントに自動割り当てされた ID を上書きすることもできます。Item の識別方法については、常に完全な制御権と最終決定権があります。

このダイアログでは、定義済みの Component Template を参照することもできます。ダイアログの Template  タブで利用できるコントロールを使用してテンプレートを選択してください。Component Template は、Component Editor 内で定義されるコンポーネント定義に使用する事前定義済み設定を提供します。追加するコンポーネント定義はすべて、関連付けられた component template に従って作成されます。

編集中のコンポーネントが Component Template を参照している場合、テンプレート内で指定された Lifecycle DefinitionRevision NamingComponent Naming,Default Folder の各エントリが、Document Options ダイアログの Document Options タブにある対応するフィールドへ事前入力されます。これらのオプション(Component editor 側)は、テンプレート内で対応する Allow override オプションが有効になっている場合にのみ編集可能です。さらに、対象 Workspace は、Component Template のリビジョンが存在する Workspace と同じものを使用するよう固定されます。

Required Models/Parameters

エディターのこの領域では、コンポーネント定義に必要なドメインモデルを指定するとともに、すべてのコンポーネント定義に適用されるパラメトリックデータのセットを作成します。

 
 
 
 
 

必要なモデルとパラメーターを定義します。
必要なモデルとパラメーターを定義します。

  • Models – 最も基本的なレベルでは、基板設計で使用されるコンポーネントには、回路図編集ドメインおよび PCB 編集ドメインでの表現が必要です。そのため、回路図シンボルモデルと PCB フットプリントモデルが必要になります。これらはデフォルトで必須モデルとして追加されており、削除することはできません。必要に応じて、この領域の Add および Remove コントロールを使用して他のモデルタイプを追加/削除してください。

    モデルタイプを指定しても、そのモデルをコンポーネント定義がhas使用しなければならないという意味ではありません。これは、そのモデルタイプ用のフィールドをコンポーネント定義に追加するだけです。
    リストには PCBLIB エントリがあることに注意してください。これにより、1 つのコンポーネントに複数の PCB フットプリントモデルを関連付けることができます。さらに、PCBLIB (default) パラメーターを使用して、コンポーネントのデフォルトフットプリントモデルを指定できます。
  • Parameters – デフォルトで 2 つのパラメーターエントリ、Name および Description が存在します。これらはシステムパラメーターです。必要に応じて、追加のパラメーターを任意の数だけ追加することもできます。追加するには、領域下部の Add コントロールをクリックし、Parameter エントリを選択します。新しいパラメーターがリストに追加されます。Parameter Name フィールド内をクリックすると、必要に応じて名前を変更できます。パラメーターを削除するには、そのパラメーターを選択して Remove コントロールをクリックします。システムパラメーターは削除できません。
各エントリに関連付けられた Show オプションを使用すると、エディター下部の領域、つまりコンポーネント定義自体を定義する場所において、そのモデル/パラメーターに対応する列の表示を切り替えられます。多数のパラメーターが定義されていて、領域がかなり混み合ってきた場合に非常に役立ちます。複数のモデル/パラメーターの表示状態を切り替えるには、複数選択と右クリックメニューのオプションを組み合わせて使用してください。

エディターのこの領域では、Add メニューを通じて、次のことも行えます。

  • Linking to a Component TemplateTemplates サブメニューには、そのコンポーネント自体が存在するのと同じ Workspace で現在利用可能なすべての Component Templates が表示されます。エントリをクリックすると、その Component Template の最新リビジョンへのリンクが作成されます。テンプレートのパラメーターはこの領域に取り込まれ、 アイコンによって区別されます。

  • Enabling the use of Datasheets – これを行うには Datasheet エントリを選択します。詳細は Attaching Datasheets to Component Definitions を参照してください。

  • Adding Part ChoicesPart Choices サブメニューを使用し、By MPN を選択します。定義領域に Part Choice n というエントリが追加され、ManufacturerPart Number の 2 列を使って選択内容を指定できます。あるいは、Workspace がこれをサポートしており、カスタムデータベース部品ソースを構成済みであれば、By Internal ID メニュー項目を選択してください。定義領域に Part Choice n というエントリが追加され、Part sourceInternal ID の 2 列を使って、社内の部品データベースから部品候補を指定できます。詳細は Part Choices を参照してください。

Model Links

エディターのこの領域では、コンポーネント定義で使用するために、保存済みドメインモデルへのリンクを追加します。Model Links 領域は、任意のコンポーネント定義からアクセスできるドメインモデルの「バケット」と考えることができます。割り当ては、各定義にどのリンクが必要かを指定する形で行います。

特定タイプのモデルへのリンクは、そのモデルタイプが Required Models/Parameters 領域に追加されている場合にのみ追加できます。

Model Links 領域には、モデルリンクの定義とコンポーネント定義への割り当てを効率化する機能が数多く用意されています。
Model Links 領域には、モデルリンクの定義とコンポーネント定義への割り当てを効率化する機能が数多く用意されています。

以下の折りたたみ可能なセクションで、モデルリンクの操作方法を確認してください。

コンポーネント定義

パラメータのセットを指定し、モデルリンクの「バケット」が準備できたら、必要なコンポーネントの定義に進むことができます。これはドキュメントの下部領域で実行します。

Component Editor を使用して、論理的かつ直感的にコンポーネントを定義します。
Component Editor を使用して、論理的かつ直感的にコンポーネントを定義します。

この領域に最初に表示される内容は、編集中のコンポーネントに応じて異なります。

  • 新しいコンポーネントを作成する場合で、親フォルダから参照される Component Template is not がないときは、そのエントリには FolderPathItem ID が割り当てられるだけで、それ以外はありません。いわば白紙の状態です。
  • 新しいコンポーネントを作成する場合で、親フォルダから参照される Component Template is があるときは、そのテンプレートによって事前入力された定義情報がエントリに設定されます。
  • 既存の単一コンポーネントのリビジョンを編集していて、Single Component Editing モードから切り替えた場合は、そのリビジョンが、その時点で定義されている情報とともに表示されます。
  • 複数のコンポーネントリビジョンを選択して編集している場合、つまり Batch Component Editing モードに直接アクセスしている場合は、それらすべてのリビジョンが表示されます。
領域の下部にある Add Component コントロールをクリックするか、メインメニューから Edit » Add Component コマンドを選択するか、領域の右クリックコンテキストメニューにある同名のコマンドを使用して、新しいコンポーネント定義をリストに追加します。

各コンポーネント定義は、次の情報を含む 1 行のエントリとして表示されます。

 
 
 
 
 
  • Component: FolderPath – このフィールドは、コンポーネントを対象 Workspace 内の特定フォルダに保存するために使用します。グリッドに新たに追加される各コンポーネントについて、このフィールドには Document Options dialogEdit » Document Options)の Default Folder フィールドで指定されたデフォルトの保存先を設定できます。デフォルトパスが指定されているかどうかにかかわらず、対象 Workspace 内のどこにコンポーネントを保存するかは完全に制御できます。保存先フォルダを手動で指定するには、コンポーネントの FolderPath フィールド内を 1 回クリックして ボタンを表示し、それをクリックして Choose Folder ダイアログを開きます。既存のフォルダを参照して選択することも、その場で新しいフォルダを作成することもできます。

    コンポーネントのフォルダパスを慎重に決めておくことで、最初から正しい保存先フォルダに保存できます。ただし、必要であれば保存後に Workspace 構造内の任意のフォルダへ簡単に移動できます。
    コンポーネントがすでに Workspace に保存されている場合、このフィールドは読み取り専用になります。Clear Link To Target Item コマンド(右クリックの Operations サブメニュー内)を使用すると、Workspace 内の既存 Item へのリンクがクリアされます。コンポーネント定義の各フィールドは、新しい Item を作成できる状態に戻り、FolderPath フィールドが再び編集可能になります。
  • Component: Item ID – このフィールドは、保存されたコンポーネントに Workspace 内で使用される ID を決定するために使用されます。グリッドに新たに追加される各コンポーネントについて、このフィールドは Document Options ダイアログの Item Naming フィールドで指定されたデフォルト命名スキームに従って設定されます。ソフトウェアは Workspace 全体と既存コンテンツの識別子を走査し、そのスキームに基づいて次に利用可能な一意の ID を自動的に割り当てます。

    デフォルトの Item 命名スキーム CMP-{00000} が用意されていますが、もちろんフィールド内に直接入力して独自のスキームを作成することもできます。その際、可変部分は中括弧で囲む必要があります(例: CMP-001-{0000})。また、定義の Item ID フィールドに必要な ID を直接入力して、コンポーネントの自動割り当て ID を上書きすることもできます。Item の識別方法については、常に最終的な決定権があります。

    パラメータベースの Component Name Templates の使用もサポートされています。このようなテンプレートを使用すると、Component Editor でそのコンポーネントに対して現在定義されているパラメータ値に基づいて、コンポーネントに正確な名前を付ける、あるいは名前を変更できます。
    コンポーネントがすでに Workspace に保存されている場合、このフィールドは読み取り専用になります。Clear Link To Target Item コマンド(右クリックの Operations サブメニュー内)を使用すると、Workspace 内の既存 Item へのリンクがクリアされます。コンポーネント定義の各フィールドは、新しい Item を作成できる状態に戻り、Item ID フィールドが再び編集可能になります。
  • Component: Name – コンポーネントに付与される、人が読みやすい名前を表します。このシステムパラメータは Workspace 内での検索時に使用可能でインデックス化されており、Item ID を覚えていなくても特定のコンポーネントを見つけるための有効な手段になります。

    このフィールドには、参照されている Component Template で定義された Name システムパラメータのデフォルト値があれば、それが設定されます。
  • Component: Type – このフィールドはコンポーネントのタイプを定義するためのもので、対象を絞った Workspace components の検索 を容易にするための重要な属性です(また、Components panel からコンポーネントを参照するときにも多用します)。このフィールドをクリックし、次に をクリックして Choose component type ダイアログを開きます。このダイアログを使用して、必要なコンポーネントタイプを(現在定義されているすべてのタイプの中から)選択し、OK をクリックします。選択したタイプは、メイン定義グリッド内の Type 属性の値として挿入されます。

    このフィールドには、参照されている Component Template で定義された ComponentType パラメータのデフォルト値、または File » New » Component コマンドを使用して新しいコンポーネントを作成しようとしたときに表示される Create new component ダイアログで選択したコンポーネントタイプが設定されます。タイプは環境設定レベルで定義されます。Choose component type ダイアログの下部にある ボタンをクリックすると、Preferences ダイアログの Data Management – Component Types ページにアクセスできます。ここで新しいタイプやサブタイプの追加、既存タイプの編集や削除を行い、この一覧を要件に合わせて調整できます。
  • Component: Description – コンポーネントに追加された説明を表します。このシステムパラメータは Workspace 内での検索時に使用可能でインデックス化されます。

    このフィールドには、参照されている Component Template で定義された Description システムパラメータのデフォルト値があれば、それが設定されます。
  • Models – これらのフィールドは、ドキュメントの Required Models/Parameters 領域のエントリに対応します。追加された必須モデルごとに 1 つのフィールドがあり、フットプリントモデルのみ複数定義できます。各フィールドは、そのコンポーネントに使用するリンク済みモデル(Model Links 領域内)を指定するために使用されます。

    それぞれの Required Model エントリに対する関連 Show オプションを有効/無効にして、モデル列の表示を切り替えます。複数のモデルタイプの表示状態を切り替えるには、複数選択と右クリックメニューのオプションを組み合わせて使用します。
  • Template Parameters – これらのフィールドは、参照されている Component Template リビジョンから Component Editor に取り込まれたユーザーパラメータに対応します。パラメータごとに 1 つのフィールドがあります。コンポーネント定義内でのパラメータの左から右への順序は、Required Models/Parameters 領域での上から下への順序に対応します。必要に応じて、また適用可能な場合にパラメータ値を入力または選択します。たとえば、テンプレートで Read Only としてマークされたパラメータは編集できませんが、他のパラメータは編集可能です。また、テンプレートで Required としてマークされている場合は値を指定しなければならず、指定しないとコンポーネント定義を Workspace に保存できません。

  • Parameters – これらのフィールドは、ドキュメントの Required Models/Parameters 領域に入力した追加ユーザーパラメータに対応します。追加パラメータごとに 1 つのフィールドがあります。コンポーネント定義内でのパラメータの左から右への順序は、Required Models/Parameters 領域での上から下への順序に対応します。必要に応じてパラメータ値を入力します。

    動的(アイテムレベル)パラメータは、Component Editor を Batch Component Editing モードで使用しているときには表示されませんが、Single Component Editing モードで使用しているときには表示されます。詳細はこちら

  • Release: Current Rev. – この編集不可フィールドは、Workspace 内のコンポーネントの現在(最新)のリビジョンを示します。

  • Release: Next Rev. – この編集不可フィールドは、選択したリビジョン命名スキームに従って、次回このコンポーネント定義を Workspace に保存したときに作成される次のリビジョンを示します。

  • Release: Action – このフィールドは、保存プロセスの一部として、この特定のコンポーネント定義に対してリリースマネージャが実行するアクションを示します。まだ Workspace に保存されていないコンポーネント定義の場合、このエントリには Create Item と表示されます。すでに Workspace に保存されている定義の場合、このエントリには Create Revision と表示されます。コンポーネントの計画済みリビジョンが対象になっている場合、このエントリには Release To Existing Revision と表示されます。

  • Part Choice n – このエントリは、ドキュメントの Required Models/Parameters 領域に追加した Part Choice に対応します。コンポーネント定義内での Part Choices の左から右への順序は、Required Models/Parameters 領域での上から下への順序に対応します。追加された Part Choice ごとに 2 つのフィールドがあり、ManufacturerPart Number を使用してその選択を指定します。または、カスタムのデータベース部品ソースを設定していて、By Internal ID メニューエントリを使用して Part Choice を追加した場合、2 つのフィールドは Part sourceInternal ID になります。これらを使用して、社内部品データベースから部品の選択を指定します。

Current Rev.Next Rev.Action の各フィールド – これらをまとめて Release Status と呼びます – は、領域下部にある Show Release Status オプションを使用して、その領域での表示/非表示を切り替えられます。Template Parameter、Parameter、および Part Choice の各列は、それぞれの Required Parameter エントリに対する関連 Show オプションを有効/無効にすることで表示を切り替えられます。複数選択と右クリックメニューのオプションを組み合わせることで、複数パラメーターの表示状態を切り替えることもできます。
コンポーネントを Workspace に保存しようとすると、Component Editor は検証 – Component Rule Check – を実行します。この機能は、メインメニューから Tools » Component Rule Check コマンドを選択することで、いつでも手動実行することもできます。実行前に、コンポーネントをローカルに保存しておいてください(File » Save)。詳細は Running a Component Rule Check を参照してください。

コンポーネント定義の操作

以下のセクションでは、このエディター領域の使い方に加えて、便利で時間を節約できる機能について説明します。

既存コンポーネントへのモデルリンクの割り当て

既存のコンポーネント定義に対して、必要なモデルリンクは次の方法で割り当てることができます。

  • モデルリンクを、コンポーネント定義の該当列にドラッグ&ドロップします。

    Model Links 領域から、そのコンポーネントの対応するモデル列へドラッグ&ドロップして、既存コンポーネントにモデルを割り当てます。
    Model Links 領域から、そのコンポーネントの対応するモデル列へドラッグ&ドロップして、既存コンポーネントにモデルを割り当てます。

  • モデル列のドロップダウンフィールドを使うと、専用のモデルリンク ポップアップウィンドウを開けます。ここには、割り当て対象のモデルタイプに適用可能な既存のすべてのモデルリンクが、すべてのデータ列とともにグリッド表示されます。コンポーネント定義の数が多くてドラッグ&ドロップが使いにくい場合や、Model Links 領域を含む Component Editor 上部が折りたたまれている場合でも、モデルの検索と割り当てをすばやく行えるため、大きな時間節約になります。また、この方法を使えば、同じモデルリンクを複数のコンポーネント定義に割り当てることもできます。ポップアップウィンドウを開く前に、各コンポーネントのモデル列を選択しておくだけです。

    ウィンドウは必要に応じてサイズ変更できます。ウィンドウ右下の コントロールをクリックしてドラッグすると、縦横を同時にリサイズできます。ウィンドウ左上の列コントロールボタン をクリックし、表示したくない列を無効にしてください。列は列ヘッダーをドラッグすることで並べ替えできます。

    ポップアップの検索フィールドを使うと、必要なモデルをすばやく見つけられます。文字を入力し始めると、任意の列のデータに基づいた動的ハイライトが適用されます。必要なモデルリンクを選択し、Enter を押すかダブルクリックしてそのモデルを割り当てます。

    専用のモデルリンク選択ポップアップを使って、必要なモデルを検索、特定、割り当てできます。
    専用のモデルリンク選択ポップアップを使って、必要なモデルを検索、特定、割り当てできます。

リンクされたモデルを持つ新規コンポーネントの作成

まだコンポーネント定義が存在しない場合は、次の方法で新しい定義を作成し、必要なモデルリンクも自動的に割り当てることができます。

  • Model Links 領域からモデルリンクを Definitions 領域内の空きスペースへドラッグ&ドロップして、そのモデルを使用する新しいコンポーネント定義を追加します。

    Model Links 領域からのドラッグ&ドロップを使って、その場でモデルを割り当て、新しいコンポーネントを追加します。
    Model Links 領域からのドラッグ&ドロップを使って、その場でモデルを割り当て、新しいコンポーネントを追加します。

  • Explorer パネルからモデルを直接 Definition 領域へドラッグ&ドロップします。そのモデルを使用する新しいコンポーネント定義が追加されます。さらに、そのモデルが Model Links 領域に存在しない場合は、そのエントリも追加されます。

    Explorer パネルからのドラッグ&ドロップを使って、その場でモデルを割り当て、新しいコンポーネントを追加します。モデルリンクがまだ存在しない場合は、Model Links 領域にも追加されます。
    Explorer パネルからのドラッグ&ドロップを使って、その場でモデルを割り当て、新しいコンポーネントを追加します。モデルリンクがまだ存在しない場合は、Model Links 領域にも追加されます。

複数コンポーネントの追加

Component Editor では、複数の新規コンポーネントを一度に追加できます。右クリックして Operations » Add Components コマンドを選択します。続いて表示される Add Components ダイアログで、追加したいコンポーネント数を入力し、 OK  をクリックします。指定した数の新しいコンポーネント定義が、現在のコンポーネント定義リストの末尾に、コンポーネント定義グリッドとして追加されます。グリッドの複数セル編集機能やコピー/貼り付け機能と組み合わせることで、多数のコンポーネント定義を短時間で素早く構築できます。

このコマンドは、エディターのメイン Edit メニュー(Edit » Operations » Add Components)からも実行できます。
Add Components ダイアログで大きすぎる数値を入力すると、処理中にソフトウェアのパフォーマンスに影響し、かなり長時間応答しなくなる可能性があるので注意してください。

2 つの簡単な手順で、複数の新しいコンポーネント定義を追加できます。
2 つの簡単な手順で、複数の新しいコンポーネント定義を追加できます。

基本的なチップ抵抗器の生成

また、メインメニューから Edit » Operations » Generate Basic Chip Resistors コマンドを選択するか、現在定義済みの定義がない場所で定義領域を右クリックし、コンテキストメニューから Operations » Generate Basic Chip Resistors コマンドを選択することで、チップ抵抗器のコンポーネント定義をまとめてすばやく作成することもできます。

このコマンドは、現在コンポーネント定義が選択されていない場合にのみ、該当メニューで使用可能になります。

コマンドを起動すると、指定されたコンポーネントタイプのコンポーネント定義が自動生成されます。

このコマンドの実行によって生成されたコンポーネント定義は、すでに定義されているものに追加されます。つまり、既存の定義が新しく生成された定義によって上書きされることはありません。

Manufacturer Part Search からのコンポーネント作成

コンポーネント作成をより効率化するために、Altium Designer は Manufacturer Part Search 機能を通じて実在の部品を検索し、その部品を Component Editor に追加する機能をサポートしています。選択した部品の新しいコンポーネント定義エントリが作成されるだけでなく、そのすべてのパラメーター、利用可能なデータシート、その部品に基づく Part Choice も取得されます。あとはドメインモデルを整理し、コンポーネントタイプと保存先フォルダーを設定して、Workspace に保存するだけです。

なお、Component Editor を Single Component Editing モードで使用する際の Manufacturer Part Search 機能とは異なり、Batch Component Editing モードではモデル(存在する場合)も取り込まれません。

Altium Designer でこの機能を利用するには、Component From Supplier Search ソフトウェア拡張機能がインストールされている必要があります。 この拡張機能は既定で Altium Designer とともにインストールされます。 手動でインストールまたは削除することもできます。

拡張機能の管理について詳しくは、 Extending Your Installation ページ(Altium Designer DevelopAltium Designer AgileAltium Designer)を参照してください。

この機能は Component Editor の Definitions 領域から利用します。右クリックして、その領域のコンテキストメニューから Operations » Create from Part Search コマンドを選択します。あるいは、メインメニューから Edit » Operations » Create from Part Search コマンドを選択するか、定義領域内をクリックしてキーボードショートカット Shift+Ctrl+M を使用します。

Manufacturer Part Search ダイアログが表示されます。現在有効な Supplier が提供する実在の製造部品データベース全体から必要な部品(または複数の部品)を検索し、エントリを選択してから OK ボタンをクリックします。

このダイアログの使い方は Manufacturer Search panel と同じです。詳細は、このリンク先ページを参照してください。
ダイアログ内の検索結果は Manufacturer Part 単位で表示され、関連する SPN エントリは、その部品を供給する有効なベンダーを反映しています。部品を選択すると、その manufacturer part が新しいコンポーネント定義の作成に使用されます。また、Part Choice の観点では、特定のベンダー/サプライヤーではなく manufacturer part に基づいて作成することで、その部品を販売しているサプライヤーに基づくすべての候補(かつ、Workspace を通じて利用可能なもの)を持つ単一の Part Choice が得られます。パラメーターは、Preferences ダイアログの Data Management – Parts Providers page で設定された Parameter Import Options に従って取り込まれます。

Manufacturer Part Search ダイアログを開き、Component Editor に取り込みたい部品を検索します。
Manufacturer Part Search ダイアログを開き、Component Editor に取り込みたい部品を検索します。

OK をクリックすると、次の処理が行われます:

  • 選択した部品のコンポーネントエントリが Component Editor の定義領域に作成されます。この定義は次のようになります:
    • Component Editor で使用されている定義済みの Item Naming スキームに従って、次に利用可能な一意の Item ID が割り当てられます。
    • 選択した部品の Manufacturer Part Number パラメーター値が、その Name システムパラメーターの値として割り当てられます。
    • 選択した部品の Description パラメーター値が、その Description システムパラメーターの値として割り当てられます。
  • 選択した部品に対して定義されているすべてのパラメーター(ダイアログ内で表示されているもの)が Required Models/Parameters リストに追加されます。すべて表示状態になります(関連する Show オプションが有効)。つまり、既定では Definitions 領域に各パラメーター用の列が表示されます。
  • 選択した部品で利用可能な各データシートについても、パラメトリックエントリが追加されます(ComponentLinknDescriptionComponentLinknURL の組み合わせの形式)。
  • 定義には Part Choice(Part Choice 1)も追加され、その部品の Manufacturer および Manufacturer Part Number パラメーター値が、それぞれその選択の Manufacturer および Part Number フィールドに使用されます。
パラメーターは、Preferences ダイアログの Data Management – Parts Providers page で設定された Parameter Import Options に従って取り込まれます。

Manufacturer Part Search ダイアログで選択した部品に対して生成された定義と、追加されたパラメーターの例です。Manufacturer Part から取り込まれるデータを示すためにハイライトが使用されています。
Manufacturer Part Search ダイアログで選択した部品に対して生成された定義と、追加されたパラメーターの例です。Manufacturer Part から取り込まれるデータを示すためにハイライトが使用されています。

コンポーネントタイプの設定

Component Editor は、コンポーネント定義の設定時にコンポーネントタイプを定義する機能をサポートしています。これにより、Workspace の強力な Search facility を使った対象を絞った検索が容易になります。この機能ではコンポーネントタイプによる検索だけでなく、単位を認識する対応コンポーネントパラメーターによる、より高度な検索も可能です。Components panel を使用して自分の Workspace ライブラリを参照する場合、コンポーネントの Categories グループ化は、各コンポーネントに定義されたコンポーネントタイプに基づきます。

コンポーネントタイプは、定義領域の Component 領域にある Type 属性で指定します。Type フィールドをクリックし、次に をクリックして Choose component type ダイアログを開きます。このダイアログで必要なコンポーネントタイプを選択し、OK をクリックすると、選択したタイプがメイン定義グリッドの Type 属性の値として挿入されます。

Choose component typeダイアログには、既定のコンポーネントタイプ一式が表示されます。これらのタイプは、環境設定レベルで定義されています。ダイアログ下部の ボタンをクリックすると、Preferencesダイアログの Data Management – Component Types ページにアクセスできます。ここで、この一覧をニーズに合わせて調整でき、新しいタイプやサブタイプの追加、既存タイプの編集や削除が可能です。

Type 属性を Diode に設定するコンポーネント定義の例。
Type 属性を Diode に設定するコンポーネント定義の例。

複数のコンポーネント定義の Type フィールドは、1 回の操作で設定できます。必要な各コンポーネント定義の Type フィールドを選択し、そのうち 1 つに対してタイプを選ぶと、他のすべてにも適用されます。

保存後でも、1 つまたは複数のコンポーネントのコンポーネントタイプを、その場でまったく別のタイプに変更することも可能です。Components panel または Explorer panel で変更したいコンポーネントを選択し、右クリックしてコンテキストメニューから Operations » Change Component Type コマンドを選択します。新しいコンポーネントタイプを選択できる Choose component type ダイアログが表示されます。
このフィールドには、参照されている Component Template で定義された ComponentType パラメータの既定値、または File » New » Component コマンドを使用して新しいコンポーネントを作成しようとした際に表示される Create new component ダイアログで選択したコンポーネントタイプが設定されます。

単位認識対応コンポーネントパラメータデータ型のサポート

Component Editor は、参照先の Component Template 内で定義された、単位認識対応のコンポーネントパラメータデータ型をサポートしています。2.2k、2k2、4M、2.5GHz など、さまざまな形式で、コンポーネント定義の該当フィールドにパラメータ値を直接入力できます。Workspace には、これらの入力の背後にある数値を認識するための機能が備わっています。

このコンポーネントテンプレートの機能により、Workspace の Search facility を使ったターゲット検索が容易になります。この機能では、コンポーネントタイプで検索できるだけでなく、範囲検索による高度な検索も可能です。単位認識対応コンポーネントパラメータの力を活用することで、たとえば静電容量が 47uF から 220uF の間にあるすべてのコンデンサを見つける検索をすばやく定義できます。

単位認識対応パラメータは、Components panel を使って独自コンポーネントを検索する際のスマートフィルタリングにも使用されます。
コンポーネントパラメータの単位認識対応データ型は、コンポーネントテンプレートを通じてのみ定義できます。

参照されているコンポーネントテンプレート由来で、単位認識対応データ型を持つコンポーネントパラメータ。
参照されているコンポーネントテンプレート由来で、単位認識対応データ型を持つコンポーネントパラメータ。

単位認識対応データ型を使用するコンポーネントパラメータに値を入力する際、つまりコンポーネント定義に必要な値として入力する際には、次の点を考慮してください。

  • 値はさまざまな形式で入力できます。
    • 数値のみ(例: 10)。データ型に単位がある場合、その単位は自動的に適用されます。単位を持つ型には、名前の後ろに括弧付きで単位が表示されます。
    • 科学表記の数値(例: 1e101E6)。
    • 数値と単位(例: 10F)
    • プレフィックス付き数値(例: 10k)。適切な単位は自動的に追加されます(該当する場合)。
    • プレフィックスと単位付き数値(例: 10kF)。
    • 一般的な工学表記でのプレフィックス付き数値(例: 抵抗値の場合: 2k22K210r210R2)。値はそれに応じて自動的に正規化されます(例: 2K22.2k になります)。
  • 数値の後のプレフィックスや単位は、スペースありでもなしでも入力できます(例: 10uF、または 10 uF)。スペースは自動的に削除されます。
工学略語は大文字小文字を区別しないため、2k2 の入力は 2K2 の入力と同じであり、100R の入力も 100r の入力と同じです。唯一の例外は、M(Mega)と m(milli)です。

辞書定義コンポーネントパラメータデータ型のサポート

Component Editor は、参照先の Component Template 内で設定された、辞書定義のコンポーネントパラメータデータ型をサポートしています。値セルをクリックしてドロップダウンを使うことで、辞書で定義された選択肢からパラメータ値を選択できます。値セルをクリックして入力を始めることもでき、その場合ドロップダウンが開き、最も近い値が一覧内で強調表示されます。

コンポーネントパラメータの辞書定義データ型は、コンポーネントテンプレートを通じてのみ設定できます。

参照されているコンポーネントテンプレート由来で、単位認識対応データ型を持つコンポーネントパラメータ。
参照されているコンポーネントテンプレート由来で、単位認識対応データ型を持つコンポーネントパラメータ。

Workspace の管理者である場合は、値フィールド右側の アイコンをクリックして、Workspace のブラウザインターフェイス内にある Settings – Vault – Dictionaries ページを開き、辞書を管理できます。

  • ​​​​​辞書定義パラメータの値は、コンポーネントを Workspace に保存する際に検証されます。値が辞書と不整合になった場合(たとえば、その値が Workspace から削除された後、その値を使用しているコンポーネントを編集のために開いた場合など)、値フィールドが赤く強調表示され、その値が適用不可であることを知らせます。値が辞書と整合するまで、コンポーネントを Workspace に保存することはできません。

  • 接続先 Workspace のブラウザインターフェイスで辞書が変更された場合、その変更を Altium Designer に反映するには、Workspace から一度切断して再接続する必要があります。詳細は Accessing Your Workspace ページを参照してください。

コンポーネント名テンプレートの使用

Component Editor では(Batch Component Editing モードのみ)、パラメータベースの Component Name Templates の使用をサポートしています。こうしたテンプレートを使用すると、エディタ内でそのコンポーネントに利用可能な現在定義済みのパラメータ値(ユーザー/テンプレートパラメータ。システムパラメータは除く)に基づいて、コンポーネントの Item ID を正確に命名、あるいは再命名できます。命名テンプレートにパラメータを含めるには、[<ParameterName>] の形式を使用します。例としては次のようなものがあります。

  • CMP-[Value]

  • CMP-[Part Number]

  • [Part Number]-[Value]

  • [Value]

  • [Part Number]

テンプレート内で複数のパラメトリック宣言を使用することもできます。たとえば次のとおりです。

  • CMP-[Part Number]-[Value]
  • CMP-[Manufacturer Part Number]-[Value]-[Tolerance]

さらに、完全に任意ですが、中括弧で指定するイテレータマクロ(例: {000}{00A})を追加することもできます。たとえば次のとおりです。

  • CMP-[Value]-{001}
  • CMP-[Part Number]-{00A}

最上位レベルでは、必要な命名テンプレートを Document Options ダイアログの Item Naming フィールドに既定の命名スキームとして入力するだけで済みます。この場合、初期インデックスは常に 0 です。より詳細に制御するには、名前を変更するコンポーネントを選択し、メインメニューから Edit » Operations » Rename ComponentEdit » Operations » Rename n Components)コマンドを選択するか、右クリックしてコンテキストメニューから Operations » Rename ComponentOperations » Rename n Components)コマンドを選択します。すると Component Name Template ダイアログが表示されます。このダイアログを使用して、必要な Naming Scheme を指定し、Initial Index を制御します(テンプレートにイテレータマクロを追加している場合)。

ダイアログには最初に、Document Options ダイアログで入力した既定の命名スキームが表示されます。このスキームのままにした場合、Initial Index を変更することはできません。後者は、別の命名スキームを使用した場合にのみ変更できます。

命名テンプレート内で CompanyPrtType および Value パラメータを使用し、Component Editor で定義中の選択コンポーネントをすばやくリネームする例。
命名テンプレート内で CompanyPrtType および Value パラメータを使用し、Component Editor で定義中の選択コンポーネントをすばやくリネームする例。

  • リネーム処理で使用される命名スキームは、その処理に対してのみ使用されます。ドキュメントに定義されている既定の命名スキームを置き換えるものではありません。後から追加するコンポーネント定義にも同じスキームで名前を付けたい場合は、Component Naming フィールドを Document Options ダイアログで適切に変更し、ドキュメントレベルでこのスキームを定義してください。
  • 個々のコンポーネント定義の Item ID  は、グリッド上で直接変更することもできます。まず 1 回クリックして Item ID  セルにフォーカスを当て、さらにもう 1 回クリックするか F2 を押してインプレース編集に入ります。必要に応じて名前を変更してください。この方法で名前を直接編集する場合、パラメトリック宣言の使用はサポートされません。

Part Choices

Component Editor では、コンポーネントに対して 1 つ以上の Part Choices を指定できます。これは、組み立て済み基板上でそのコンポーネントを実装するために使用可能な「許可された」メーカー部品です。実際のサプライチェーンインテリジェンス、すなわちメーカー(および部品番号)、サプライヤー(および部品番号)、説明、価格、在庫状況は、Workspace のローカル Part Catalog と関連する Part Source から取得されます。

各 Workspace には専用の Part Catalog があります。これは、メーカー部品と、それに関連するサプライヤー部品を管理・追跡するためのローカル部品カタログデータベースです。ローカル Part Catalog には、実際の Manufacturer Part を表すアイテムと、それに関連付けられた 1 つ以上の Supplier Part を表すアイテムが保存されます。これらの Supplier Part は、部品データベース内のアイテムへの参照であり、Altium Parts Provider の集約部品データベース(有効化されたサプライヤーから部品を取得して統合するもの)または Enterprise Server Workspace の場合はリンクされたローカル部品データベース(ODBC ベース)のいずれかです。Workspace のブラウザインターフェイスの Part Providers 領域で、Altium Parts Provider に対して必要なサプライヤーを有効にし、地域/通貨の範囲を決定します。Altium Designer から Workspace に接続している間は、Preferences ダイアログの Data Management – Parts Providers page にある Altium Parts Options 領域は読み取り専用となり、Workspace で定義された設定を反映します。Workspace 用の Altium Parts Provider part source の管理について詳しくは、Part Source ConfigurationAltium 365 WorkspaceEnterprise Server Workspace)を参照してください。

Required Models/Parameters 領域から part choice を追加します。Add コントロールをクリックし、Part Choices サブメニューから By MPN コマンドを使用します。あるいは、カスタムデータベース部品ソースを設定している場合は、By Internal ID メニュー項目を選択します。使用する part choice はいくつでも追加できます。

定義中のコンポーネントで使用する part choice を追加すると、定義領域に Part Choice n エントリが追加され、その choice を指定するための 2 つの列が表示されます。これらの列は、選択した part choice のスタイルによって異なります。

  • By MPN – 表示される 2 つの列は ManufacturerPart Number です。

  • By Internal ID – 表示される 2 つの列は Part sourceInternal ID です。

定義中のコンポーネントで使用する part choice(By MPN)の追加。ホバーすると、追加された By Internal ID part choice の例が表示され、社内の内部部品データベースの部品を関連付けることができます。
定義中のコンポーネントで使用する part choice(By MPN)の追加。ホバーすると、追加された By Internal ID part choice の例が表示され、社内の内部部品データベースの部品を関連付けることができます。

Manufacturer および Part Number フィールドに、それぞれメーカー名とメーカー部品番号を入力してください。これは、基板の製造および組み立て時に使用したい実部品に対応します。

設定済みのカスタムデータベース部品ソースを使用している場合は、Part source フィールドで part source を選択します。Workspace に定義されているすべてのカスタムデータベース部品ソースが一覧表示されます。必要な部品の ID を Internal ID フィールドに入力してください。

Component editor を Batch Component Editing モードで開いた際、コンポーネント内にメーカーおよびメーカー部品番号のパラメータの組が検出されると、Part Choice Migration ダイアログが開き、それらのパラメータを part choices()に変換することが提案されます。パラメータを part choices にコピーまたは移動することを選択すると、新しい part choices が作成され、その Part Number の値はパラメータの値に基づいて定義されます。

メーカー名およびメーカー部品番号として検出されたコンポーネントパラメータは、以下の折りたたみ可能なセクションに一覧表示されます。パラメータ名に数値サフィックスが付いている場合(たとえば、パラメータ名が Manufacturer 1 および Manufacturer Part Number 1 の場合)も、これらのパラメータは検出されます。

知っておくべき点がいくつかあります。

  • part choice を追加しても、コンポーネント定義でそれを必ず使用しなければならないわけではありません。ただし、2 つのフィールドのいずれか一方に値を入力すると、もう一方のフィールドに赤い枠が表示され、そのコンポーネントを Workspace に保存する前に値の入力が必要であることを知らせます。

  • フィールド値を誤って入力し、Workspace がその部品を取得できない場合、テキストはグレーの斜体で表示されます。両方の入力が正しくなると、通常の白色テキストで表示されます。値では大文字小文字は区別されません。

ダイアログによる MPN Part Choices の追加

part choice に関連付けられたセルへ Manufacturer と Part Number の情報を直接入力することもできますが、メーカー部品を検索できるダイアログを使うほうがはるかに簡単です。この機能を利用するには、最初の Part Choice 1 エントリを Required Models/Parameters 領域に追加した後、その choice 用セルのいずれか 1 つ(定義対象コンポーネントに関連するもの)をクリックします。すると、エディタの Preview 領域に ボタンが表示されます。これをクリックすると Add Part Choices ダイアログが開きます。このダイアログは Manufacturer Part Search panel と同じように使用します(完全な UI 要素の詳細はそのページを参照してください)。

part choice の作成 - Add Part Choices ダイアログを使用して必要なメーカー部品を検索し、そのエントリを選択して OK をクリックします。
part choice の作成 - Add Part Choices ダイアログを使用して必要なメーカー部品を検索し、そのエントリを選択して OK をクリックします。

ダイアログ内の検索結果は Manufacturer Part 単位で表示され、関連付けられた SPN エントリには、その部品を供給する有効化済みベンダーが反映されます。部品を選択すると、Part Choices リストに追加されるのはメーカー部品です。特定のベンダー/サプライヤーではなくメーカー部品を使用することで、その部品を扱うサプライヤーに基づくすべてのソリューションを含む単一の Part Choice を得られます(かつ、それらは Workspace を通じて利用可能です)。

ダイアログを使用して必要なメーカー部品を検索し、部品を選択してから OK ボタンをクリックします。メーカー部品の SPNs エントリ(Supplier Part Numbers)をクリックすると、その部品の利用可能なサプライヤーを確認でき、在庫状況、価格などに基づいて適切な part choice かどうかを判断できます。選択した部品は Component Editor に戻され、Part Choice 1 エントリのセルと Preview 領域の両方に入力されます。

Add Part Choices ダイアログを使用して追加された example part choice が、Component Editor に戻って表示された例。
Add Part Choices ダイアログを使用して追加された example part choice が、Component Editor に戻って表示された例。

必要に応じてさらに part choice を追加するには、 ボタンをクリックします。対応する Part Choice n エントリは自動的に作成されます。

part choice を削除するには、リスト内でそれを選択してから ボタンをクリックします。

part choice によって提供される情報の詳細については、Adding Supply Chain Information to a Component ページを参照してください。

Part Choices の自動ランキング

星印機能を使って part choice にユーザーランクを定義できることに加え、Component editor で定義/編集しているコンポーネントについて、part choices のランキングを自動設定することもできます。

  • 1 つ以上のコンポーネント定義エントリを選択し、その選択を右クリックして、右クリックメニューから Set Part Choice Ranks Automatically コマンドを選ぶと、選択したコンポーネントの part choices のランキングを設定できます。

  • メインメニューから Tools » Set Part Choice Ranks Automatically コマンドを選択すると、すべてのコンポーネントの part choices のランキングを設定できます。

部品の選択肢は、設定されたランクに従って、 component definitions grid とエディターのプレビュー領域で並べ替えられます。すでにランク付けされている部品の選択肢は、既存の順序が維持されます。

コンポーネント定義へのデータシートの添付

Component Editor でコンポーネントを定義する際に、1 つ以上のデータシートを 1 つ以上のコンポーネントに添付できます。これにより、たとえば特定のファミリーに属するすべてのコンポーネントに、同じ必要なデータシートをすばやく添付できます。

Component Editor でコンポーネントを編集する観点から見た、各種データシートのリンク例。
Component Editor でコンポーネントを編集する観点から見た、各種データシートのリンク例。

コンポーネント定義にデータシートを添付するには、以下に要約し、後続のセクションで詳述する一連の手順を実行します。

  1. データシートの使用を有効にする。
  2. 選択したコンポーネントにデータシートをアップロードする。
  3. アップロードしたデータシートを他のコンポーネント定義に割り当てる。

コンポーネント命名の検証チェック

ソフトウェアは、複数のユーザーが Workspace へ保存するために作成しているコンポーネントの ID を検証し、重複した Item ID の問題を防ぎます。ユーザーが Component Item を作成すると、割り当てられた Item ID は「ロック」されるため、最初のユーザーがそのコンポーネントを Workspace に保存していなくても、または保存しなくても、他のユーザーはその ID を使用できません。他のユーザーがコンポーネント定義の一部として Item ID を手動で変更し、それが既存の Item(または作成予定の Item)で現在使用されているものと重複する場合、その ID は適用される命名スキームに従って、次に利用可能な未使用 ID に変更されます。

ロックされた Component Item ID は、その時間内に保存が行われなかった場合、30 分後に自動的に解放されます。

コンポーネント定義のコピー作成

わずかに異なるコンポーネント定義をすばやく作成できるようにするため、エディターにはコピー機能が用意されています。既存の定義のコピーを作成するには、定義一覧でそれを選択し、メインメニューから Edit » Make a copy of the component コマンドを選択するか、右クリックしてコンテキストメニューから Make a copy of the component コマンドを選択します(ショートカット: Ctrl+D)。コピーは定義一覧の一番下に追加されます。

コピーは、以下の点で元のコンポーネント定義と完全に同一です。

  • Workspace 内の同じフォルダーを対象にする。つまり、元のコンポーネントが存在するフォルダー、または(まだ保存されていない場合は)保存先として対象となるフォルダーです。
  • 同じドメインモデルを参照する。
  • NameDescriptionType、テンプレートパラメーター、および追加のユーザー定義パラメーターについて同じ値を持つ。

以下の点は異なります。

  • 元のコンポーネントに定義されていたデータシートを持たない。

  • 元のコンポーネントに定義されていた部品選択肢を持たない。

  • 次に利用可能な一意の Item ID を持つ。

  • 新しい Component Item の初期リビジョンに保存されるよう設定されている(ActionCreate Item に設定)。

コンポーネント定義をコピーする例。コピー後は必要に応じて、たとえば 1 つ以上のパラメーター値の変更、部品選択肢の定義、必要なデータシートの追加などを行います。
コンポーネント定義をコピーする例。コピー後は必要に応じて、たとえば 1 つ以上のパラメーター値の変更、部品選択肢の定義、必要なデータシートの追加などを行います。

コピー後は必要に応じて変更を行います。たとえば 1 つ以上のパラメーター値を変更します。

コピー機能は、 Copy Component コマンドと Paste Component コマンドを順に使用するのと似ています。既存のコンポーネント定義をより素早くコピーする手段ではありますが、コピーは単一のコンポーネント定義に対してのみ実行できるのに対し、Copy/Paste Component コマンドは複数の定義に対して機能します。

コンポーネント定義のグループ化

コンポーネント定義は、表示されている任意の列見出しに基づいてグループ化できます。これを行うには、列ヘッダーをクリックしたまま、Drag a column header here to group by that column と表示されているテキスト上にドラッグ&ドロップします。

たとえば次の画像は、コンポーネント定義が Case-Metric パラメーターでグループ化されていることを示しています。これにより、コンポーネント定義はグループ化列内の異なる値の数だけグループに分かれ、この場合は 9 つのグループが作成されます。

列内の値に基づいてコンポーネント定義をグループ化する例。この場合は Case-Metric パラメーターによるものです。
列内の値に基づいてコンポーネント定義をグループ化する例。この場合は Case-Metric パラメーターによるものです。

列ヘッダーをネストすることで、グループ階層を作成できます。グループ化列領域内では、ドラッグ&ドロップを使用して必要に応じてグループ化の「並び順」を再定義できます。

コンポーネント定義の並べ替え

コンポーネント定義は、特定の列のヘッダーをクリックすることで並べ替えられます。1 回クリックすると昇順(その列の内容に基づく)で並べ替えられ、もう 1 回クリックすると降順になります。

複数列で並べ替えることもできます。コンポーネント定義がすでに特定の列で並べ替えられている状態で、別の列に対して Shift+Click すると、その列の内容で「サブソート」されます。

列の並べ替えを解除するには、そのヘッダーで Ctrl+Click します。

列ベースのコンポーネント定義フィルタリング

Excel スプレッドシートと同様に、コンポーネント定義は各列の内容に基づいてさらにフィルタリングできます。 これを行うには、列ヘッダーの右側にある小さな漏斗(フィルター)アイコン()をクリックします。すると、その列に存在する各値に対応するチェックボックスを含むメニューが表示されます。必要なチェックボックスを有効にすると、その値を持つコンポーネント定義だけに一覧が絞り込まれます。

あるいは、より高度なフィルタリング制御のために (Custom...) を選択すると、Custom Filter ダイアログが表示されます。このダイアログを使用して、データ列に適用するフィルター条件に基づき、表示したい情報の行を指定して、要件に合うカスタムフィルターを設定できます。

標準またはカスタムの列フィルタリングを適用します。
標準またはカスタムの列フィルタリングを適用します。

列フィルターが適用されると、フィルターアイコンは青色()で表示され、その列に基づくフィルタリングが適用されていることを示します。フィルタリングは複数のデータ列に適用できます。各「列フィルター」は、全体のフィルターにおける AND 条件になります。現在有効なフィルタリングのテキスト表現が、領域の下部に表示されます。

列フィルタリングの動作例。
列フィルタリングの動作例。

列のフィルタリングをクリアするには、フィルタリング用ドロップダウンから (All) エントリを選択します。フィルタリングを完全にクリアするには、フィルターのテキスト表現の左側にある ボタンをクリックします。フィルターを無効にするには、テキスト表現の左側にあるチェックボックスをオフにします。再度有効にするには、そのチェックボックスをオンにします。
編集セッション中は、直前に使用したフィルターの履歴を利用できます。現在のフィルターのテキスト表現の右側にある ボタンをクリックすると履歴が表示されます。履歴リストは、一時的な Component Editor を閉じるとクリアされます。

現在のフィルターをさらにカスタマイズするには、フィルターのテキスト表現の右端にある ボタンをクリックして Filter Builder ダイアログを開きます。

Filter Builder ダイアログを使用して、より高度なフィルタリングを作成します。
Filter Builder ダイアログを使用して、より高度なフィルタリングを作成します。

このダイアログを使用すると、必要に応じて、より高度で複雑なフィルターを作成できます。

  • Filter - クリックして追加のフィルター条件にアクセスします。Clear All をクリックすると、すべてのフィルターをクリアします。選択肢は次のとおりです。
    • Add Condition - クリックして、equalsbetween などのフィルター条件を追加します。
    • Add Group - クリックして、ANDOR などのフィルターグループを追加します。
  • Links - 各種リンクをクリックして、フィルターをさらに定義します。
    • Id - 各種リンクをクリックして、たとえば DescriptionName など、フィルタリングに使用する目的の項目を選択します。
    • AND など。 - 各種リンクをクリックして、たとえば OR などの論理演算子/タイプを指定します。
    • like - 各種リンクをクリックして、equalsis blankis greater than などの演算子を指定します。
    • <empty> - 各種リンクをクリックして条件値を追加します。リンクをクリックした後、テキストボックスに目的の値を入力します。
  • press the button to add a new condition - クリックして追加の条件を加えます。
よく使うフィルターは保存して再利用できます。これは Filter Builder ダイアログで、 ボタンをクリックして現在のフィルターを Filters ファイル(*.flt)として保存することで行います。以前保存したフィルターを再読み込みするには、 ボタンをクリックします。

データの表示

定義しているコンポーネントの種類によっては、かなり多くのパラメーターが存在する場合があり、それらが他のデータ列に加わることで、部分的にしか判読できない内容が複雑に入り組んだ状態になることがあります。これに対応するため、コンポーネント定義領域には 2 つの表示モードが用意されています。領域右下のコントロールを使用してモードを切り替えます。

このコントロールは、クリックしたときに有効になるモードを表示するのであって、現在有効なモードを表示するものではありません。
  • Best Fit – このモードでは、各データ列は、その列内で最も大きいデータ項目に合わせて、少し余白を加えたうえで、すべてのデータを表示できるサイズに調整されます。各列は自身のデータを表示するようにサイズ調整されるため、列全体が現在表示可能な領域を超えて広がることがあります。これを補うため、読みやすさを確保する水平スクロールバーが用意されています。
  • Auto Width – このモードでは、ソフトウェアは必要に応じて拡張または圧縮しながら、グリッドの表示可能領域内にすべてのデータ列を収めようとします。データ列がそれほど多くない場合にはうまく機能しますが、列数が多い場合は可読性が低下することがあります。

Auto Width および Best Fit 表示モードの使用例。
Auto Width および Best Fit 表示モードの使用例。

データ表示をさらに補助するため、モデル列とパラメーター列の表示を個別に切り替えることができます。これは、エディターの Required Models/Parameters 領域で利用可能な、それぞれの Show オプションを使用して行います。
データ表示を微調整するために、データ列の幅を手動で調整することもできます。列ヘッダーの右端をクリックしてドラッグしてください。

コンポーネント定義 – 編集テクニック

作成するコンポーネントによっては、Component Editor にかなり多くのコンポーネント定義が含まれることがあります。場合によっては、これらの定義の違いがごくわずかであり、多くが似たモデル情報やパラメトリック情報を必要とすることがあります。このドキュメントでは、1 つ以上のコンポーネント定義に対してすばやく変更を加えられるようにする、さまざまな編集機能をサポートしています。

  • モデルとパラメーターでは、複数セル編集が実装されています。列内の複数のデータセルは、標準的な Ctrl+Click および Shift+Click のキーボード操作を使用して選択できます。複数のコンポーネントにモデルを割り当てるには、対象セル範囲を選択してからドロップダウンをクリックし、モデルリンクのポップアップウィンドウを表示します。ポップアップ内で目的のモデルをダブルクリックすると、そのモデルが選択したすべてのモデルセルに割り当てられます。

    パラメーターについては、同じ列内で必要なセルを選択し、フォーカスされているセルに必要な値を入力してから、他の場所をクリックするか Enter を押します。選択範囲内のすべてのセルに同じ値が設定されます。

    この機能は FolderPath に対しても使用できます。該当するコンポーネント定義の FolderPath 列のエントリを選択し、フォーカスされているエントリの ボタンをクリックして、Choose Folder ダイアログで必要なターゲットフォルダーを選択します。選択されたすべての定義の FolderPath は、このフォルダーを指すように変更されます。
  • 選択したデータセル間で、Ctrl+X、 Ctrl+CCtrl+V を使用して、それぞれデータの切り取り、コピー、貼り付けを行えます(または、右クリックメニューやメインの Edit メニューにある対応するコマンドを使用します)。

    貼り付け先のセルがクリップボードのデータと互換性がない場合、貼り付けは実行されません(たとえば、パラメトリックデータをモデルリンクフィールドに貼り付ける場合など)。

  • 選択したデータセルの内容は、Delete キー(または右クリックメニューの Clear Contents コマンド、あるいはメインメニューの Edit » Clear Contents コマンド)を使用して消去できます。

    コンポーネントライブラリドキュメントが Component Template を参照している場合は、次の点に注意してください。

    • テンプレート内でパラメーターが Read Only としてマークされている場合、そのパラメーターに対応するセルの内容を消去することはできません。
    • テンプレート内でパラメーターが Required としてマークされている場合、そのパラメーターに対応するセルの内容を消去すると、そのセルは赤い枠線で強調表示され、値が必須であることを示します。
  • 選択したコンポーネント定義は、Ctrl+Shift+C、 Ctrl+Shift+XCtrl+Shift+V を使用して、それぞれコピー、切り取り、貼り付けできます(または、右クリックメニューやメインの Edit メニューにある対応するコマンドを使用します)。

    • 単一のコンポーネント定義をすばやく複製するには、 Make a copy of the component command を使用します。

    • クリップボード内のコンポーネント定義は、Component Editor のメイングリッド領域に 2 通りの方法で貼り付けできます。

      • 現在の定義リストの末尾に貼り付ける - 現在どの定義も選択されていないことを確認してから、コマンドを実行します。
      • 現在の定義を上書きする - 上書きする定義を右クリックしてコマンドを実行します。確認を求めるダイアログが表示されるので、Yes をクリックして続行します。既存の定義済みセルデータは、貼り付けた定義のデータで上書きされます。上書きはフォーカスされている定義に対してのみ機能する点に注意してください。クリップボードに複数の定義がある場合、最初の 1 つだけがフォーカスされている定義に「上書き」貼り付けされ、残りは定義リストの末尾に貼り付けられます。
  • 選択したコンポーネント定義は、コンポーネント定義グリッドの下にある Remove Component コントロール、右クリックメニューまたはメインの Edit メニューにある Remove <ComponentName> (Remove n Components)コマンド、または Ctrl+Del ショートカットを使用して完全に削除できます。
  • グリッドの内容は、メインの Edit または View メニュー、あるいはメイングリッド領域の右クリックメニューにある Refresh コマンド、F5 キーボードショートカット、または Component Library Standard ツールバーの ボタンをクリックして更新できます。
  • 選択したデータセルを Windows クリップボードにコピーして、外部のスプレッドシートアプリケーションで加工することもできます。外部のスプレッドシートにあるコンポーネント定義情報を、コンポーネント定義領域に貼り戻すことも可能です。
また、エディター右上の小さな矢印 をクリックすると、Component Editor の上部領域を折りたたむことができ、表示領域全体をコンポーネント定義の編集に使用できます。

保存済み定義の参照

Workspace に保存した後は、Components panel または Explorer panel を使用して、Workspace 内でコンポーネントを直接参照できます。

すでに保存され、現在編集中のコンポーネントについては、定義領域内のそのエントリを右クリックして Operations » Show in Explorer コマンドを選択するか、メインメニューから Edit » Operations » Show In Explorer コマンドを選択することで、Component Editor から Workspace 内のその Component Item に直接移動できます。

そのコンポーネントのリビジョンを編集用に開いているときに、Component Editor から直接 Explorer パネル内の保存済みコンポーネントへ移動します。
そのコンポーネントのリビジョンを編集用に開いているときに、Component Editor から直接 Explorer パネル内の保存済みコンポーネントへ移動します。

既存の Component Item を対象にする

通常は、対象 Workspace におけるコンポーネントの作成は保存プロセスの一部として行うのが一般的です。コンポーネント定義を追加し、Item ID を割り当てれば、そのまま進められます。いわばその場でコンテンツを作成する形です。ただし、Workspace 内で直接コンポーネントを作成済み(または作成したい)で、それら既存のコンポーネントにリンクしたい場合もあります。あるいは、既存のリリース済みコンポーネント定義に関連付けられている対象の Component Item を変更したいこともあります。

コンポーネント定義に関連付けられた右クリックの Operations サブメニュー(およびメインメニューの Edit » Operations サブメニュー)には、定義を手動作成されたコンポーネントにリンクするためのコマンドがいくつか用意されています。

  • Change Link To Target Item – このコマンドを使用すると Choose Target Item ダイアログにアクセスでき、そこで Workspace 内の必要なコンポーネントを参照して選択できます。

    選択したコンポーネント定義がすでにコンポーネントにリンクされている場合、ダイアログにはそのコンポーネントがあらかじめ選択された状態で表示されます。定義がまだリンクされていない場合、ダイアログにはその定義に対して定義されているターゲットフォルダーが表示されます。

    対象 Workspace 内の既存コンポーネントにリンクされると、そのコンポーネント定義の Item ID  はグレー表示され(編集不可になります)。

    このコマンドは、コンポーネント定義が選択されている場合にのみ、それぞれのメニューで使用可能になります。複数のコンポーネント定義が選択されている場合、このコマンドはフォーカスされている定義に対して動作します。フォーカスされている定義は、選択セルの周囲の点線枠で区別されます。
  • Clear Link To Target Item (Clear Links To Target Items) – このコマンドを使用すると、Workspace 内の既存コンポーネントへのリンクを解除できます。コンポーネント定義のリリース関連フィールドは、新しい Item を作成できる状態に戻ります。

    リンクを解除する必要が生じるのは、新しい一式のコンポーネントに対して再度リリースする必要がある場合です。たとえば、以前にリリースした後で Workspace からそのコンポーネントを削除した場合、ソースライブラリにはリンク定義が残ったままになります(ただし、Workspace 内のコンポーネントが見つからないため無効です)。

    すでにコンポーネント定義を保存している場合、この手順により、その定義と以前リンクされていたコンポーネントは互いの関連情報を失うことになります。

    対象 Workspace 内の既存コンポーネントへのリンクが解除されると、そのコンポーネント定義の Item ID  は編集可能になります。グリッドの Release  領域にある Action  フィールドのエントリは Create Item に変わり、そのコンポーネント定義が現在、対象 Workspace 内のコンポーネントにリンクされていないことを示します。

コンポーネントルールチェックの実行

Component Editor で定義または編集した Workspace Library コンポーネントを、接続中の Workspace に保存して設計で使用可能にする前に、そのコンポーネントが構成済み設定に従った要件を満たしていることを確認することが重要です。コンポーネントを Workspace に保存しようとしたとき、またはこの機能を手動で実行したときに、Component Editor は検証( Component Rule Check )を実行します。

コンポーネント検証の詳細については、Validating a Component ページを参照してください。

リンクされたシミュレーションモデルについて

Related page: シミュレーションモデルの作成

シンボルモデルやフットプリントモデルと同様に、コンポーネントはシミュレーションモデルのリビジョンを参照することもできます。この種類のモデルリンクの追加方法は、シンボルやフットプリントの場合とまったく同じなので、その情報については前のセクションを参照してください。ここでは、コンポーネントレベルのシミュレーションパラメーターの追加と、ピンマッピングの設定について説明します。

コンポーネントレベルのシミュレーションパラメーターの追加

設計内のコンポーネントにシミュレーションモデルを使用する場合、そのモデル固有のパラメーターは 2 つの異なるレベルで指定できます。

  • Model-Level Parameter – シミュレーションモデル定義自体の一部として指定されるもの(SimModel ファイル内)で、リンクされたシミュレーションモデルのリビジョンにその定義とともに保存されます。
  • Component-Level Parameter – コンポーネント定義の一部として指定されるもの(ここでは Component Editor 内)で、リンクされたコンポーネントのリビジョンにその定義とともに保存されます。
コンポーネントレベルのパラメーターは、複数のモデル間で共有されるパラメーターや、設計者がそのようなパラメーターを回路図上で表示または編集可能にしたい場合(例: 値、周波数など)に使用されます。

パラメーターは、Component Editor の Required Models/Parameters 領域でコンポーネントレベルに追加されます。重要なのは、パラメーター名がモデルレベルで定義されているパラメーター名と同一でなければならない点です。モデルレベルのパラメーター、ひいてはコンポーネントレベルで追加可能なパラメーター(およびその名前)を確認するには、SIM モデルリンクを選択し、プレビューウィンドウ下部にある View Parameters コントロールをクリックします。

Simulation Model Item のモデルレベルパラメーターを表示して、どのパラメーターをコンポーネントレベルに追加できるか、またそれらの名前を確認してください。
Simulation Model Item のモデルレベルパラメーターを表示して、どのパラメーターをコンポーネントレベルに追加できるか、またそれらの名前を確認してください。

利用可能なモデルレベルパラメーターを把握したら、それらと同じパラメーターをコンポーネントレベルに追加して、任意のコンポーネント定義で利用できるようにします。これを行うには、Required Models/Parameters 領域の下部にある Add コントロールをクリックし、メニューから Parameter を選択します。新しいパラメーターエントリがリストに追加されます。必要に応じて名前を変更しますが、対応するモデルレベルパラメーター名と完全に一致させるようにしてください。

シミュレーション関連パラメーターをコンポーネントレベルに追加します。この例のコンポーネントが参照している Component Template により、すでに 1 つのパラメーター Area Factor が利用可能になっている点に注目してください。
シミュレーション関連パラメーターをコンポーネントレベルに追加します。この例のコンポーネントが参照している Component Template により、すでに 1 つのパラメーター Area Factor が利用可能になっている点に注目してください。

保存済みコンポーネントのインスタンスを設計内に配置すると、シミュレーションパラメーターは、モデルレベルの同じパラメーターとは異なる値をコンポーネントレベルで持つことができます。ネットリスト生成時には、コンポーネントレベルのパラメーターが優先されます。
一部の組み込み SPICE3f5 モデルでは、コンポーネントレベルでパラメーター値を入力すると、リンクされたモデルファイル(*.mdl)で定義されている関連パラメーターが上書きされます。たとえば半導体コンデンサーでは、コンポーネントレベルの Width パラメーターに値を指定すると、関連するモデルファイル内の DEFW パラメーターに指定されている値は上書きされます。 サブサーキットモデルに対してコンポーネントレベルでパラメーターが指定されている場合、その値はリンクされたサブサーキットファイル(*.ckt)で定義されている値を上書きします。

ピンマッピング

必要な SIM モデルへのリンクを選択したら、回路図ドメインで表されるコンポーネントのピンが、シミュレーションモデルのピンに正しくマッピングされていることを確認する必要があります。これは Pin Mapping ダイアログで行います。このダイアログは、コンポーネント定義の SIM モデルエントリを右クリックしてコンテキストメニューから Operations » Edit Pin Mapping を選択するか、SIM モデルのセルを選択してメインメニューから Edit » Operations » Edit Pin Mapping コマンドを選択することで開けます。各回路図ピンについて、利用可能なドロップダウンを使用して、関連する Model Pin エントリを適切に変更します。デバイスがマルチパートの場合は、各パートのマッピングを必ず確認してください。

回路図ピンからモデルピンへの正しいマッピングを確保します。
回路図ピンからモデルピンへの正しいマッピングを確保します。

マルチパートコンポーネントでは、シミュレーションからパートを除外する機能も Pin Mapping ダイアログで設定します。
組み込みの SPICE3f5 およびサポートされている PSpice モデルについては、各モデルのピン機能は SPICE 3f5 ユーザーマニュアルのそのモデルの general form セクションに記載されています。サブサーキットモデルについては、通常、メーカーがモデルの各ピンに対してその機能を説明するコメントを挿入しています。コメントが見当たらない場合、通常そのモデルのピン配置は物理デバイス自体のピン配置に対応しています。その場合はデバイスのデータシートを参照してください。
AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium DevelopAltium Agile TeamsAltium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Content