コンポーネントテンプレート

コンポーネント作成の効率化を支援するために、Altium Designer では connected Workspace と連携して、その Workspace 内で Component Templates (Component Template Items)を作成および定義できます。回路図テンプレートを使って、それを参照する回路図シート上の情報をあらかじめ定義できるのと同様に、コンポーネントテンプレートは Workspace library component から参照され、そのコンポーネントを定義する際に使用する事前定義済み設定を提供します。

特に、コンポーネントテンプレートはパラメトリック情報を強く意識して開発されており、参照先コンポーネントで利用可能となるパラメータの「ひとまとめ」を 1 か所で定義できます。テンプレートを通じて、それらのパラメータのうちどれを表示するかを制御し、デフォルト値を入力し、さらに必須のパラメータを必須項目としてマークすることもできます。コンポーネント保存時には、準拠を確実にするための検証チェックが実行されます。

テンプレート設定の多くについて指定したデフォルト値は、読み取り専用として固定することも、コンポーネント定義時に設計者が選択的に上書きできるようにすることもできます。

コンポーネントテンプレートは、汎用コンポーネントを作成する際の基盤にもなります。詳細は、Creating Generic Components ページを参照してください。

コンポーネントテンプレートへのアクセス可否は、ソフトウェアライセンスによって異なります。詳細は、ページ右側の Note ボックスを参照してください。

このようなコンポーネントテンプレートは、Workspace 内から直接作成します。コンポーネントテンプレートを作成し、そのリビジョンにデータを保存した後は、1 つ以上のコンポーネント作成時に再利用できます。

Folder Type

コンポーネントテンプレートを保存するフォルダを作成する際、そのフォルダのタイプを指定できます。これはフォルダの内容自体には影響しません。コンポーネントテンプレートをリリースすると、常に対応する Component Template Item が作成されます。これは単に、そのフォルダに何が保存されているかを視覚的に示す「手がかり」を提供するもので、特定のコンテンツを探して Workspace を参照する際に役立ちます。フォルダをコンポーネントテンプレートの格納先として指定するには、Edit Folder dialog でフォルダプロパティを定義する際に、その Folder Type を Component Templates に設定します。

フォルダタイプ、つまりその想定用途を指定することで、Workspace を参照する際にそのフォルダの内容を視覚的に把握できます。
フォルダタイプ、つまりその想定用途を指定することで、Workspace を参照する際にそのフォルダの内容を視覚的に把握できます。

Content Type

コンポーネントテンプレートを保存する対象の Component Template Item を作成する際は、Create New Item dialog でその Content Type が Component Template に設定されていることを確認してください。Component Templates タイプのフォルダ内で Item を作成する場合、このコンテンツタイプは Item 作成時の右クリックコンテキストメニューから利用できます。

Component Templates フォルダ内でコンポーネントテンプレートを作成する場合、正しい Content Type がコンテキストメニューで利用できます。
Component Templates フォルダ内でコンポーネントテンプレートを作成する場合、正しい Content Type がコンテキストメニューで利用できます。

Saving a Component Template

Related page: Creating & Editing Content

ここまでは、関連するフォルダタイプおよびコンテンツタイプという観点から、Workspace におけるコンポーネントテンプレートのサポートについて説明してきました。実際に定義したコンポーネントテンプレートを、そのような Component Template Item のリビジョンに保存することも、効率的な方法で行えます。

コンポーネントテンプレートは、Workspace のダイレクト編集機能により、新規作成された Component Template Item の初期リビジョンで編集して保存できます。ダイレクト編集を使えば、別個のバージョン管理されたソースデータに縛られることがありません。Workspace 自体から最新ソースを直接読み込んだ一時エディタを使って、サポート対象のコンテンツタイプをそのまま編集できます。そして編集が完了すると、そのエンティティは親 Item の次の予定リビジョンに保存(または再保存)され、一時エディタは閉じられます。ハードドライブ上にファイルは存在せず、正しい最新ソースで作業しているか悩む必要もなく、別途バージョン管理ソフトウェアを維持する必要もありません。Workspace がこれらをすべて高い整合性で処理し、データ変更を大幅に迅速化します。

Component Template Item を作成する際、その Item の作成後に、コンポーネントテンプレートを編集して初期リビジョンに保存するオプションがあります。これを行うには、Create New Item dialog の下部にある Open for editing after creation オプションを有効にします(既定で有効)。Item が作成されると、一時的な Component Template Editor が開き、メイン設計ウィンドウのアクティブドキュメントとして .CMPT ドキュメントが表示されます。このドキュメントは Item-Revision に従って、次の形式で命名されます: <Item><Revision>.CMPT(例: CMPT-0001-1.CMPT)。

 
 
 
 
 

Workspace から直接コンポーネントテンプレートの初期リビジョンを編集している例。定義用ドキュメントは一時的な Component Template Editor によって提供されます。
Workspace から直接コンポーネントテンプレートの初期リビジョンを編集している例。定義用ドキュメントは一時的な Component Template Editor によって提供されます。

必要に応じてこのドキュメントを使用してコンポーネントテンプレートを定義してください。詳細は Defining the Template を参照してください。

ダイレクト編集時には、主に 3 つの関連コントロールがあり、Quick Access Bar(メインアプリケーションウィンドウ左上)または Component Template Standard ツールバーから簡単に利用できます。

  • – Save Active Document。このボタンは、ドキュメントに加えた変更をローカルに保存するために使用します。これにより、最終的に Workspace に保存する前に、後でさらに変更を加えるために現在の作業内容を保存しておけます。
  • / – Save to Server。このボタンは、定義したコンポーネントテンプレートを Workspace に保存し、対象 Component Template Item の初期(予定)リビジョン内に格納するために使用します。Edit Revision ダイアログが表示され、必要に応じて Name、Description を変更し、リリースノートを追加できます。保存後、ドキュメントとエディタは閉じられます。ソースコンポーネントテンプレートを含むドキュメント *.CMPT は、その Item のリビジョン内に保存されます。

    Save to Server コントロールは、Projects panel 内のコンポーネントテンプレートのエントリ右側にも便利に用意されています。
  • / – Discard Local Changes。編集を中止し、加えた変更を破棄したい場合にこのボタンを使用します。ドキュメントとエディタは閉じられ、対象の Component Template Item には何もリリースされません。

これらのコントロールは、コマンドとしても利用できます。Save(ショートカット: Ctrl+S)、Save to Server(ショートカット: Ctrl+Alt+S)、および Discard Local Changes で、メインの File メニュー、および Projects パネル内のコンポーネントテンプレートエントリの右クリックメニューから実行できます。

Workspace に保存されるデータは、Component Template ファイル(<Item><Revision>.CMPT)で定義されたソースコンポーネントテンプレートです。

 
 
 
 
 

定義済みコンポーネントテンプレートを Workspace に保存した例。
定義済みコンポーネントテンプレートを Workspace に保存した例。

コンポーネントテンプレートの継承

この機能は、Advanced Settings dialog で UI.ComponentTemplateInheritance オプションが有効な場合に利用できます。

サブタイプにリンクされたコンポーネントテンプレートがない場合は、ルートコンポーネントタイプのコンポーネントテンプレートを使用できます。コンポーネントタイプの階層を構築すると、コンポーネントのサブタイプはルート/親コンポーネントタイプに割り当てられたコンポーネントテンプレートを継承します。

CMPT(Component Template)Editor

Altium Designer で Component Template editor にアクセスするには、Component Template Editor ソフトウェア拡張機能がインストールされている必要があります。 この拡張機能は既定で Altium Designer とともにインストールされます。 手動でインストールまたは削除することも可能です。

拡張機能の管理の詳細については、Extending Your Installation ページを参照してください(Altium Designer Develop、Altium Designer Agile、Altium Designer)。

テンプレートの定義

Component Template Editor は基本的に 2 つの主要な領域に分かれており、以下の図で示し、その後に概要を説明します。

 
 
 
 
 

Component Template Editor は大まかに 2 つの主要領域に分けられます。
Component Template Editor は大まかに 2 つの主要領域に分けられます。

  1. Upper Region – テンプレートを参照するコンポーネントのコンポーネントレベルオプション(ライフサイクル、命名、フォルダオプション)を定義するための領域です。
  2. Lower Region – テンプレートを参照するコンポーネントで使用するパラメータを定義するための領域です。

コンポーネントオプションの指定

エディタ上半分は、次のコンポーネントプロパティのデフォルト値を定義するために使用します。

  • Lifecycle Definition – テンプレートを使用して作成されるコンポーネントに適用するライフサイクル定義を選択します。ドロップダウンフィールドには、Workspace に定義され、かつコンポーネントで使用が許可されているすべての定義が一覧表示されます。

  • Revision Naming – テンプレートを使用して作成されるコンポーネントに適用するリビジョン命名スキームを選択します。ドロップダウンフィールドには、Workspace に定義され、かつコンポーネントで使用が許可されているすべてのスキームが一覧表示されます。

    コンテンツタイプごとにライフサイクル定義およびリビジョン命名スキームの使用を制御するオプションが、いずれかの定義/スキームで有効になっており、かつ Component コンテンツタイプが特定の定義/スキームを使用するよう設定されていない場合、その定義/スキームは該当ドロップダウンリストに表示されません。

  • Component Naming – このフィールドは、テンプレートを使用して作成されるコンポーネントの既定の Item Naming Scheme を定義し、結果として生成されるコンポーネントの Workspace 内での一意 ID を保証するために使用します。ここに入力した内容は、コンポーネントの自動命名テンプレートとして使用されます(Component Editor を Single Component Editing モードで使用する場合は関連する Id フィールド、Batch Component Editing モードで使用する場合は Item ID フィールド)。ソフトウェアは Workspace 全体と既存コンテンツの識別子をスキャンしたうえで、そのスキームに基づく次に利用可能な一意 ID を自動的に割り当てます。既定の Item 命名スキーム CMP-{00000} が用意されていますが、もちろんフィールドに直接入力して独自スキームを作成することもできます。その際、可変部分は必ず中括弧で囲んでください(例: CMP-001-{0000})。

  • Default Folder – 保存したコンポーネントの格納先となる、対象 Workspace 内の既定フォルダを指定します。これを行うには、Choose ボタンをクリックして Choose Folder ダイアログ(Explorer panel の一形態)を開き、Workspace 内の既存フォルダを参照して選択するか、その場で新規作成します。

対象 Workspace を設定するフィールドはありません。これは、コンポーネントテンプレートのリビジョンが存在するのと同じ Workspace を使用するよう固定されているためです。

各プロパティの Allow override オプションを使うと、コンポーネントを Component editor で定義する際に、そのプロパティをユーザーが変更可能にするか(有効)、変更不可にするか(無効)を個別に制御できます。

テンプレートが参照されると、この領域で指定した内容は、Component Editor 内の該当フィールドに事前入力されます(利用可能な場合)。

  • Single Component Editing mode – Component 領域の Advanced Settings エリアにある Id フィールドおよび Folder フィールド。
  • Batch Component Editing mode – Document Options dialog の Document Options タブ、および結果としてコンポーネント定義領域の Component エリアにある Item ID フィールドと FolderPath フィールド。

テンプレートが参照されると、Component Editor の Single Component Editing モード(左)および Batch Component Editing モード(右)でコンポーネントを編集する際、該当フィールドに事前入力されます。
テンプレートが参照されると、Component Editor の Single Component Editing モード(左)および Batch Component Editing モード(右)でコンポーネントを編集する際、該当フィールドに事前入力されます。

パラメータの定義

エディタ下半分は、参照先コンポーネントで利用可能となるパラメータの定義と管理に使用します。

 
 
 
 
 

コンポーネントテンプレートで定義されたパラメータの例。
コンポーネントテンプレートで定義されたパラメータの例。

デフォルトのシステムパラメータ

新しいコンポーネントテンプレートを作成すると、さまざまなシステムパラメータが既定で含まれます。以下の図に示し、その後に詳細を説明します。

 
 
 
 
 

新規作成されたコンポーネントテンプレートに含まれる既定のシステムレベルパラメータ。
新規作成されたコンポーネントテンプレートに含まれる既定のシステムレベルパラメータ。

  • ComponentType – このパラメータではコンポーネントのタイプを指定できます。これにより、Workspace の強力な Search facility を使った対象検索が容易になります。この機能では、コンポーネントタイプで検索できるだけでなく、サポートされている unit-aware component parameters により、より高度な検索も可能です。Components panel を使用して自分の Workspace コンポーネントを参照する場合、コンポーネントの Categories グループ化は、各コンポーネントに関連付けられた ComponentType パラメータに基づいて決まります。関連する Default Value フィールドをクリックし、次に ボタンをクリックして Choose component type ダイアログを開きます。ここで必要なコンポーネントタイプを選択し、OK をクリックしてください。選択したタイプが、メインのパラメータグリッド内の ComponentType パラメータ値として挿入されます。

    Choose component type ダイアログには、Preferences ダイアログの Data Management – Component Types page で定義されたコンポーネントタイプのセットが反映されます。この設定ページを開くには、Choose component type ダイアログの下部にある ボタンをクリックします。ここから、新しいタイプやサブタイプを追加したり、既存のタイプを編集・削除したりして、この一覧を必要に合わせて調整できます。

    ComponentType システムパラメータが Diodes に設定された Component Template の例。
    ComponentType システムパラメータが Diodes に設定された Component Template の例。

    このパラメータのデータ型は ComponentType に設定されており、変更できません。また、ComponentType パラメータはコピーや削除ができません。値をクリアするにはセルを選択し、Delete キーを使用します。

  • SCHLIBPCBLIB と Default Value – これら 2 つのパラメータでは、それぞれデフォルトのシンボルモデルとフットプリントモデルを指定できます。各パラメータに関連付けられた Default Value フィールドをクリックし、次に ボタンをクリックすると、必要なモデルを選択するためのダイアログが開きます。

    ここで選択するのはモデルであり、そのモデルの特定リビジョンではないことに注意してください。これにより、このテンプレートを使用するコンポーネントは、常に選択したモデルの最新リビジョンを使用します。

    テンプレートの一部としてシンボルモデルとフットプリント モデルを指定します。
    テンプレートの一部としてシンボルモデルとフットプリント モデルを指定します。

    これらのパラメータのデータ型は、それぞれ SCHLIB および PCBLIB に設定されており、変更できません。また、モデルパラメータはコピーや削除ができません。 値をクリアするにはセルを選択し、Delete キーを使用します。

  • NameDescription と Default Value – これら 2 つのパラメータでは、それぞれコンポーネントの名前と説明を定義できます。各パラメータに関連付けられた Default Value フィールドに必要な文字列を入力します。

    テンプレートの一部として Name および Description パラメータを指定します。
    テンプレートの一部として Name および Description パラメータを指定します。

    これら両方のパラメータのデータ型は Text に設定されており、変更できません。また、これらのパラメータはコピーや削除ができません。

新しいユーザーパラメータの追加

一覧に新しいユーザーパラメータを追加するには、 ボタンをクリックするか、右クリックのコンテキストメニューから Add コマンドを使用します。追加されたパラメータは現在の一覧の末尾に追加されます。

 
 
 
 
 

テンプレートに新しいユーザーパラメータを追加した例。
テンプレートに新しいユーザーパラメータを追加した例。

各パラメータは、グリッド一覧に次の情報とともに表示されます。

  • Name – このフィールドは、通常その用途が分かる意味のある名前を付けるために使用します。最初に追加されたとき、パラメータにはデフォルト名(Parameter、Parameter 1、Parameter 2 など)が付けられます。

  • Type – パラメータの型です。この項目は最初は Text が既定値ですが、さまざまな 単位対応データ型 がサポートされています。また、PCBLIB 型(複数フットプリントの定義 を容易にする)、および HarnessWiring 型(ハーネス配線コンポーネント の定義を容易にする)もサポートされます。 使用可能なディクショナリで定義されたパラメータ型もサポートされます – 詳細はこちら。

  • Visible – このオプションを有効にすると(新しく追加されたパラメータでは既定で有効)、Component Editor で 1 つ以上のコンポーネントを編集する際(Batch Component Editing モードで構成)に、そのパラメータに対応する Show オプションが有効になります。これにより、コンポーネント定義自体を定義する Component Editor の下部領域に、そのパラメータに対応する列が表示されるかどうかが制御されます。このプロパティは、エディタの Single Component Editing モードを使用してコンポーネントを定義する場合には影響しません。

  • Read Only – このオプションを有効にすると、パラメータは読み取り専用になります。テンプレートを参照するコンポーネントを編集するとき、このパラメータの値は編集できなくなります。

  • Required – このオプションを有効にすると、パラメータは「必須パラメータ」になります。テンプレートを参照するコンポーネントを編集するとき、このパラメータには値が定義されていなければならず、そうでない場合はコンポーネントを保存できません。Component Editor では、このようなパラメータは、値が未入力のときに値セルが赤い枠線で表示される(Batch Component Editing モード)か、 アイコンが表示される(Single Component Editing モード)ことで識別されます。

  • Default Value – このフィールドは、パラメータのデフォルト値を入力するために使用します。

    • パラメータが必須(Required オプション有効)で、かつ読み取り専用(Read Only オプション有効)にも設定されている場合は、デフォルト値を MUST 入力する必要があります。そうしないと、テンプレートを参照するコンポーネントの編集中に、そのパラメータは値がないものとして扱われますが、読み取り専用のため編集できず、この状態を解消できません。これが解消されるまで、この Component Template の新しいリビジョンは Workspace に保存できません。

    • コンポーネントのリビジョンを編集する際、リンクされた Component Template 内のパラメータと同じ名前を持つ既存のユーザー定義パラメータは、テンプレート側のバージョンに置き換えられます。そのパラメータに既に存在する値は保持されます(テンプレート内のデフォルト値で上書きされることはありません)。

  • Description – パラメータの説明を追加します。たとえば、そのパラメータが何を提供するかを簡潔に記したメモなどです。テンプレート内のパラメータに説明が定義されている場合、Component Editor の Parameters 領域にある Description 列は、その Single Component Editing に応じて表示されます。

パラメータ一覧では、シンプルなコピー&ペースト操作もサポートされています。これにより、既存の 1 つまたは複数のユーザーパラメータを複製できます。貼り付けられたパラメータは一覧の末尾に追加されます。

標準のコピー(Ctrl+C)および貼り付け(Ctrl+V)ショートカットがサポートされており、これらのコマンドは右クリックメニューからも利用できます。複数のユーザーパラメータは、標準的な Ctrl+Click および Shift+Click の操作で選択してコピー&ペーストできます。
一覧から 1 つまたは複数のユーザーパラメータを削除するには、各パラメータを選択し、 ボタンをクリックするか、右クリックのコンテキストメニューから Remove コマンドを使用します。

単位対応コンポーネントパラメータのデータ型

Component Template Editor では、Component Template 内で定義されるコンポーネントパラメータ(*.CMPT)に対して明示的なデータ型を定義できます。さらに、これらのデータ型は単位対応であり、一般的な単位プレフィックスも幅広くサポートされています。そのため、パラメータ値は 2.2k、2k2、4M、2.5GHz など、さまざまな形式で入力でき、Workspace はそれらの入力値の背後にある数値を正しく認識します。

Component Template のこの機能により、サーバーの Advanced Search facility を使った対象を絞った検索が可能になります。この機能では、コンポーネントタイプで検索できるだけでなく、範囲検索を使ってよりスマートに検索できます。単位対応コンポーネントパラメータの力を利用すれば、たとえば静電容量が 47uF から 220uF の間にあるすべてのコンデンサを見つける検索をすばやく定義できます。

単位対応パラメータは、Components panel を使用して自分のコンポーネントを検索する際のスマートフィルタリングにも使用されます。

以下の折りたたみ可能なセクションで、単位対応パラメータの詳細を確認してください。

ディクショナリ定義パラメータデータ型

ディクショナリは、複数の定義済み値を持つカスタムパラメータ型です。ディクショナリは Workspace 管理者によって管理され、Workspace のブラウザインターフェース内の Settings – Vault – Dictionaries ページで設定されます。このページには、Component Template editor から Type ドロップダウンで Add New Dictionary オプションを選択するか、Parameters 領域の右上にある Manage Dictionaries コントロールをクリックしてアクセスできます。

  • Settings – Vault – Dictionariesページには、PreferencesダイアログのData Management – DictionariesページでManage Dictionariesコントロールをクリックしてアクセスすることもできます。また、PreferencesダイアログのData Management – Serversページで、アクティブな、または既知のWorkspaceに対するPropertiesコントロールをクリックし、メニューからDictionariesエントリを選択してアクセスすることもできます。

  • 辞書で定義されたタイプがパラメータに選択されている場合は、Type列のそのパラメータのセル内をクリックしてからボタン()をクリックすることでも、Settings – Vault – Dictionariesページにアクセスできます。

Component Template Editorから、Workspaceのブラウザインターフェースで辞書を管理するためのページにアクセスします。
Component Template Editorから、Workspaceのブラウザインターフェースで辞書を管理するためのページにアクセスします。

Workspaceのブラウザインターフェースでの辞書管理の詳細については、(Altium 365 Workspace、Enterprise Server Workspace)を参照してください。

定義済みの辞書は、Typeドロップダウンでパラメータタイプとして使用できます。


Typeドロップダウンで、辞書定義されたパラメータタイプを選択します。選択した辞書定義タイプに対して定義されている値が、Default Valueドロップダウンで使用可能になります。必要な値を選択してパラメータのデフォルトとして使用するか、<None>を選択します。


選択した辞書定義タイプに対して定義されている値の中からデフォルト値を選択します。デフォルト値は、コンポーネントテンプレートをWorkspaceへ保存する際に検証されます。デフォルト値が辞書と不整合になった場合(たとえば、その値が辞書から削除され、その値を使用しているテンプレートを編集のために開いた場合)、このデフォルト値はDefault Value列で赤くハイライト表示され、テンプレートをWorkspaceへ保存しようとするとMessagesパネルにエラーメッセージが表示されます。

  • コンポーネントパラメータの値が辞書と不整合になった場合(たとえば、コンポーネントテンプレート内でそのパラメータのタイプがTextから辞書定義タイプに切り替えられ、現在のコンポーネント値が選択した辞書定義タイプのいずれの値とも一致しない場合)、Component Editorでコンポーネントを編集するとこのパラメータは強調表示されます。エディタのSingle Component Editingモードでは、不整合なパラメータ値の横に感嘆符アイコンが表示され、Batch Component Editingモードではそのパラメータ値が赤くハイライト表示されます。すべてのコンポーネントパラメータがテンプレート値と整合していることを確認してください。そうでない場合、コンポーネントを次のリビジョンとして保存できません。

  • 接続先Workspaceのブラウザインターフェースで辞書が変更された場合、それらの変更をAltium Designerに反映するには、Workspaceから切断して再接続する必要があります。詳細はAccessing Your Workspaceページを参照してください。

  • 複数フットプリントの定義

    Component Template Editorでは、コンポーネントテンプレートの一部として複数のPCBフットプリントを定義することもサポートされています。フットプリントモデルリンクはいくつでも指定でき、異なる密度レベルに対するIPC要件を満たす3つのフットプリントを参照するコンポーネントを作成したいユーザーにとって便利な機能です。すなわち、L(最小、または最小銅量)、M(最大、または最大銅量)、およびN(公称、または中間銅量)です。

    テンプレートに追加のフットプリントモデル定義を追加するには、をクリックして新しいパラメータを追加し、Typeフィールドに関連付けられたドロップダウンメニューでPCBLIBエントリを選択します。

    新しく追加したパラメータのTypeをPCBLIBに設定して、フットプリントモデル定義に変更します。
    新しく追加したパラメータのTypeをPCBLIBに設定して、フットプリントモデル定義に変更します。

    パラメータ名はParameterからPCBLIB nに変わります。ここでnは複数のフットプリントモデルを区別するための次に使用可能な整数です(例:PCBLIB 1、PCBLIB 2など)。デフォルトモデルはPCBLIBエントリに関連付けられたものになります。フットプリントがコンポーネント定義時にComponent Editorへ取り込まれると、デフォルトのFootprintモデルは、Single Component Editingモードではモデルプレビューウィンドウの左上にあるアイコンで、Batch Component EditingモードではRequired Models/Parameters領域のPCBLIB (default)エントリで識別されます。

    参照されたComponent Templateを使用してComponent Editorで定義されたコンポーネントの例(Single Component Editingモード)。テンプレートには3つのフットプリントモデルが定義されており、それらがコンポーネント定義に取り込まれます。コンポーネント定義時に、テンプレート内のPCBLIBモデルエントリがデフォルトのフットプリントモデルとして使用されていることに注目してください(左上のアイコンで区別されます)。画像にカーソルを合わせると、Component EditorのBatch Component Editingモードで同じコンポーネントを定義している状態を確認できます。この場合、デフォルトフットプリントはPCBLIB (default)と呼ばれます。
    参照されたComponent Templateを使用してComponent Editorで定義されたコンポーネントの例(Single Component Editingモード)。テンプレートには3つのフットプリントモデルが定義されており、それらがコンポーネント定義に取り込まれます。コンポーネント定義時に、テンプレート内のPCBLIBモデルエントリがデフォルトのフットプリントモデルとして使用されていることに注目してください(左上のアイコンで区別されます)。画像にカーソルを合わせると、Component EditorのBatch Component Editingモードで同じコンポーネントを定義している状態を確認できます。この場合、デフォルトフットプリントはPCBLIB (default)と呼ばれます。

    Component Templateのインポートとエクスポート

    既存のコンポーネントテンプレートファイル(*.CMPT)またはコンポーネントライブラリファイル(*.CMPLIB)をcomponent template editorにインポートでき、編集中のコンポーネントテンプレートはコンポーネントテンプレートファイル(*.CMPT)へエクスポートできます。目的の操作を選択するには、component editorのメインメニューにあるFile » Import » Component Template、File » Import » Component Library、File » Exportコマンドを使用し、開いた標準Windowsダイアログで必要な場所を参照してインポートするファイルを選択するか、エクスポートするファイル名を指定します。

    Component Templateの再利用

    コンポーネントテンプレートのあるリビジョンを使用する、正確には現在編集中のコンポーネントのリビジョンからそのリビジョンを参照するには、以下の方法があります。

    コンポーネントが一度に参照できるComponent Templateは1つだけです。

    新しいコンポーネント作成時

    メインメニューからFile » New » Componentコマンドを使用して新しいコンポーネントを作成するとき、Create new componentダイアログでテンプレートを選択できます。

    新しいコンポーネント作成時に、使用可能なすべてのテンプレート一覧からすばやくコンポーネントテンプレートをリンクします。
    新しいコンポーネント作成時に、使用可能なすべてのテンプレート一覧からすばやくコンポーネントテンプレートをリンクします。

    Component Editor内から手動で

    Component Editorからコンポーネントテンプレートのリビジョンを再利用する方法は、Editorの動作モードによって異なります。

    Single Component Editingモードの場合

    Component Editorのこのモードで単一のコンポーネントを編集している場合は、EditorのComponent領域にあるAdvanced Settingsグループの一部であるTemplateフィールドに関連付けられたドロップダウンメニューから、必要なComponent Templateを選択します。コンポーネント自体が存在するのと同じWorkspaceで現在利用可能なすべてのcomponent templateが、名前と最新リビジョン(括弧内)付きで一覧表示されます。必要なテンプレートを選択して適用します。

    Component EditorのSingle Component Editingモードでコンポーネントのリビジョンを編集しているときに、使用可能なすべてのテンプレートのメニューからすばやくコンポーネントテンプレートをリンクします。
    Component EditorのSingle Component Editingモードでコンポーネントのリビジョンを編集しているときに、使用可能なすべてのテンプレートのメニューからすばやくコンポーネントテンプレートをリンクします。

    Batch Component Editingモードの場合

    現在編集中のコンポーネントリビジョンにComponent Templateのリビジョンを「接続」する方法は2つあります。

    • Edit » Document Options()のTemplateタブからDocument Options dialogを開きます。Item Revisionフィールドの右にあるChooseボタンをクリックします。これにより、Choose Itemダイアログ(Explorer panelの一形態)にアクセスできます。このダイアログを使用して、必要なcomponent templateのリビジョンを参照して選択します。OKをクリックすると、コンポーネントのリビジョンと対象のcomponent templateリビジョンの間にリンクが作成されます。このリンクの証拠は、Document OptionsダイアログのTemplateタブに戻ると確認できます。

      対象Workspace内で、コンポーネントをコンポーネントテンプレートのリビジョンに手動でリンクします。
      対象Workspace内で、コンポーネントをコンポーネントテンプレートのリビジョンに手動でリンクします。

      使用するcomponent templateはいつでも変更できます。Chooseをクリックして、別のcomponent templateのリビジョンを選択してください。
      リンクされたComponent Template Item Revisionのステータスは、Document OptionsダイアログのTemplateタブに反映されます。リンクされたItemの新しいリビジョンが利用可能な場合は、ボタンをクリックしてその最新リビジョンを使用します。
    • Component EditorのRequired Models/Parameters領域に関連付けられたAddメニューから行う方法です。Templatesサブメニューには、コンポーネント自体が存在するのと同じWorkspaceで現在利用可能なすべてのcomponent templateが、名前と最新リビジョン(括弧内)付きで一覧表示されます。エントリをクリックすると、そのcomponent templateの最新リビジョンへのリンクが作成されます。ここでも、リンクの確認はDocument OptionsダイアログのTemplatesタブで行えます。

      使用可能なすべてのテンプレートのメニューからすばやくコンポーネントテンプレートをリンクします。
      使用可能なすべてのテンプレートのメニューからすばやくコンポーネントテンプレートをリンクします。

    Components Workspace Folderから継承

    Workspace内のComponentsフォルダに保存されるすべてのコンポーネント(およびそのリビジョン)に対して、自動的に使用するcomponent templateを指定できます。

    デフォルトのcomponent templateは、Componentsタイプのフォルダに対してのみ定義できます。

    Edit Folder dialogでフォルダのプロパティを定義するときに、Component Templateフィールドを使用して必要なテンプレートを指定します。このフィールドに関連付けられたドロップダウンには、Componentsフォルダ自体が存在するのと同じWorkspaceで現在利用可能なすべてのcomponent templateが、名前と最新リビジョン(括弧内)付きで一覧表示されます。エントリを選択すると、そのフォルダ内で以後作成される各コンポーネントについて、そのcomponent templateの最新リビジョンへのリンクが作成されます。

    親Componentsフォルダ内で作成されるすべてのコンポーネントに適用するデフォルトのcomponent templateを指定します。
    親Componentsフォルダ内で作成されるすべてのコンポーネントに適用するデフォルトのcomponent templateを指定します。

    この機能を使用しない場合は、Component TemplateフィールドをNoneのままにするか、それに設定してください。

    フォルダレベルでComponent Templateを選択した場合、子サブフォルダ内でコンポーネントを作成するときにも、デフォルトで同じテンプレートが使用されます。これにより、子フォルダ内のすべてのコンポーネントにテンプレート継承をすばやく適用できます。

    コンポーネントのリビジョンがWorkspaceに保存されると、使用されたComponent Templateの特定のリビジョンは実質的に固定されます。つまり、手動で変更しない限り、そのリビジョンへの強いリンクが作成されます。

    Component Template使用時のコンポーネントモデルとパラメータへの影響

    コンポーネントのリビジョンを編集していて、component templateのリビジョンがリンクまたは参照されている場合、モデルとパラメータに関してComponent Editor内では次のようになります。

    • 参照されているテンプレート内で定義されたモデルは、Models領域(Single Component Editingモード)およびModel Links領域(Batch Component Editingモード)に追加されます。
    • 既存の参照モデルは保持され、意図的に手動で変更しない限り、コンポーネントはそのモデルを使い続けます。
    • 参照されているテンプレート内で定義されたパラメータは、Parameters領域(Single Component Editingモード)およびRequired Models/Parameters領域(Batch Component Editingモード)に追加されます。

      component templateのリビジョンにリンクした後のパラメータ例。Component EditorのSingle Component Editingモード(左)およびBatch Component Editingモード(右)を使用した場合。
      component templateのリビジョンにリンクした後のパラメータ例。Component EditorのSingle Component Editingモード(左)およびBatch Component Editingモード(右)を使用した場合。

      参照されたcomponent templateに由来するすべてのパラメータは、アイコン(Single Component Editingモード)およびアイコン(Batch Component Editingモード)によって区別されます。さらに、Batch Component Editingモードに限り、各テンプレートベースのパラメータに対するShowオプションは、テンプレート内の対応するVisibleオプションの状態に従います。
      テンプレートベースのパラメータは削除できません。
      必要に応じて、追加のユーザーパラメータを自由に追加できます。
    • Batch Component Editingモードのみでは、表示するよう設定されたテンプレートベースのパラメータはエディタのコンポーネント定義エリアでまとめてグループ化され、ヘッダーテキストとしてTemplate Parametersが使用されます。

      Component EditorのBatch Component Editingモードを使用した場合に、コンポーネント定義自体を行うエリアに表示されるテンプレートベースのパラメータ例。
      Component EditorのBatch Component Editingモードを使用した場合に、コンポーネント定義自体を行うエリアに表示されるテンプレートベースのパラメータ例。

    • 読み取り専用としてマークされたテンプレートベースのパラメータの値フィールドは編集できません。読み取り専用に設定されていないその他のテンプレートベースのパラメータについては、必要に応じて自由に値を変更できます。

      Component EditorがSingle Component Editingモードのとき、読み取り専用テンプレートパラメータはParameters領域でアイコンにより区別されます。
    • テンプレートベースのパラメータが必須としてマークされているにもかかわらず、テンプレート内で値が与えられていない場合、その値フィールドは赤い枠で表示される(Batch Component Editingモード)か、アイコンを含んで表示されます(Single Component Editingモード)。これにより、そのパラメータに値が必要であることが示されます。すべての必須パラメータに値が定義されるまで、コンポーネントをWorkspaceに保存することはできません。

      Component EditorがSingle Component Editingモードのとき、必須テンプレートパラメータはParameters領域でアイコンにより区別されます。

    Component Templateの再保存

    いつでも、Workspace内のcomponent templateの任意のリビジョンに戻って直接編集できます。そのリビジョンを右クリックし、コンテキストメニューからEditコマンドを選択します。すると再び一時エディタが開き、そのリビジョンに含まれるテンプレートを編集できます。必要に応じて変更を加えた後、component templateをそのItemの次のリビジョンとして保存します。

    component template自体の最上位エントリを右クリックすると、そのテンプレートの最新リビジョンが編集されます。

    既存のcomponent templateリビジョンを直接編集するためのコマンドにアクセスします。
    既存のcomponent templateリビジョンを直接編集するためのコマンドにアクセスします。

    保存済みデータのダウンロード

    component templateのリビジョンに保存されているデータをダウンロードするには、(Explorerパネル内で)そのリビジョンを右クリックし、コンテキストメニューからOperations » Downloadコマンドを選択します。component templateファイルは、選択したディレクトリ配下の、Item Revision IDを名前とするサブフォルダにダウンロードされます。ファイルはその中のReleasedフォルダにあります。

    component template自体の最上位エントリからDownloadコマンドにアクセスすると、そのテンプレートの最新リビジョンに保存されているcomponent templateファイルをダウンロードできます。
    Download from ServerダイアログでExploreボタンをクリックすると、ダウンロードフォルダをすばやく開いて確認できます。

    ソフト削除

    Workspaceに接続している場合、Altium Designer内のExplorer panelから直接component templateを削除するための柔軟な機能を利用できます。パネル内のcomponent templateエントリを右クリックし、コンテキストメニューからDelete Itemコマンドを選択します。削除を確認するためのDelete Itemsダイアログが表示されます。この操作は実際には「ソフト削除」であり、component templateはWorkspaceのTrashエリアへ移動されます。Trashは実質的にごみ箱で、Workspace内のあらゆるコンテンツを(ソフト削除操作によって)移動できます。これはWorkspaceの他の部分から分離されています。

    ソフト削除機能では、現在使用中のcomponent templateでも削除できます。
    複数のcomponent templateを1回の操作で削除できます。標準の複数選択操作(Shift+Click、Ctrl+Click)を使用して必要なcomponent templateをすべて選択し、右クリックしてコンテキストメニューからDelete Itemsコマンドを選択します。

    component templateのソフト削除。テンプレートはWorkspaceのTrashエリアへ移動されます。
    component templateのソフト削除。テンプレートはWorkspaceのTrashエリアへ移動されます。

    削除を実行するには、ボタンをクリックします。アイテムは削除され、Deletion Summaryダイアログで削除成功が確認されます。削除に問題があった場合は、その旨が通知されます。

    この方法で削除されたすべてのコンテンツは、WorkspaceのブラウザインターフェースにあるTrashページで確認できます。なお、表示できるのは自分自身がソフト削除したコンテンツのみです。管理者はTrashページの全コンテンツ、つまりソフト削除されたすべてのコンテンツを確認できます。

    ソフト削除されたcomponent templateに関して考慮すべき点:

    • component templateは、設計ソフトウェアからもWebインターフェース内からも利用できなくなります。
    • component templateが使用されていたあらゆる場所で、そのcomponent templateが削除されたことが反映されます。
    • 編集権限があれば、component templateはTrashページから復元することも、完全に削除することもできます。完全削除は、親Itemで使用されていない場合にのみ可能です。
    component templateをソフト削除してTrashへ移動した場合でも、同じ名前の新しいcomponent templateを再度作成できます。その後、元のcomponent templateを復元しようとして元の名前がすでに使われていた場合は、Workspace内で名前の一意性を保つために整数の接尾辞が付加されます。
    AI-LocalizedAI で翻訳
    問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
    機能の提供状況

    ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

    実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

    従来のドキュメント

    Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

    Content