コンポーネントテンプレート

Altium Designerは、接続されたWorkspaceと連携し、そのWorkspace内でのComponent Templates (コンポーネントテンプレートアイテム)の作成と定義をサポートすることで、コンポーネントの作成を効率化します。回路図テンプレートを使用して、それを参照する回路図シート上の情報をあらかじめ定義できるのと同様に、コンポーネントテンプレートはWorkspaceライブラリコンポーネントから参照され、そのコンポーネントを定義する際に使用する設定をあらかじめ提供します。

特に、コンポーネントテンプレートはパラメータ情報を重視して開発されており、参照元のコンポーネントで使用できるパラメータの「セット」を1か所で定義できます。テンプレートを通じて、どのパラメータを表示するかを制御し、デフォルト値を入力し、必要なパラメータを必須に指定することもできます。コンポーネントの保存時には検証チェックが行われ、要件への準拠が確認されます。

テンプレートの多くの設定に指定されたデフォルト値は、読み取り専用として固定することも、コンポーネントの定義時に設計者が上書きできるよう、選択的に許可することもできます。

コンポーネントテンプレートは、汎用コンポーネントを作成するための基盤でもあります。詳細については、 汎用コンポーネントの作成 ページを参照してください。

コンポーネントテンプレートへのアクセスは、ソフトウェアライセンスによって異なります。詳細については、ページ右側のNoteボックスを参照してください。

これらのコンポーネントテンプレートは、Workspace内から直接作成します。コンポーネントテンプレートを作成し、そのリビジョンにデータを保存すると、1つまたは複数のコンポーネントの作成に再利用できます。

フォルダータイプ

コンポーネントテンプレートを格納するフォルダーを作成する際には、フォルダーのタイプを指定できます。これはフォルダーの内容には影響しません。コンポーネントテンプレートをリリースすると、常に対応するコンポーネントテンプレートアイテムが生成されます。フォルダータイプは、フォルダーに何が格納されているかを視覚的に示す「手がかり」であり、Workspace内で特定のコンテンツを探す際に役立ちます。フォルダーをコンポーネントテンプレートの格納先として指定するには、フォルダーの編集ダイアログでフォルダープロパティを定義する際に、Folder TypeをComponent Templatesに設定します。

フォルダータイプ、つまり用途を指定すると、Workspaceを参照する際に、そのフォルダーの内容を視覚的に把握できます。
フォルダータイプ、つまり用途を指定すると、Workspaceを参照する際に、そのフォルダーの内容を視覚的に把握できます。

コンテンツタイプ

コンポーネントテンプレートを格納するコンポーネントテンプレートアイテムを作成する際は、新規アイテムの作成ダイアログで、Content TypeがComponent Templateに設定されていることを確認してください。Component Templatesタイプのフォルダー内にアイテムを作成する場合、このコンテンツタイプは、アイテム作成時の右クリックコンテキストメニューから選択できます。

Component Templatesフォルダー内でのコンポーネントテンプレートの作成 – 適切なContent Typeをコンテキストメニューから選択できます。
Component Templatesフォルダー内でのコンポーネントテンプレートの作成 – 適切なContent Typeをコンテキストメニューから選択できます。

コンポーネントテンプレートの保存

Related page: コンテンツの作成と編集

ここまでは、関連するフォルダータイプとコンテンツタイプの観点から、Workspaceでのコンポーネントテンプレートのサポートについて説明してきました。実際に定義したコンポーネントテンプレートは、こうしたコンポーネントテンプレートアイテムのリビジョンに、効率的な手順で保存できます。

Workspaceがサポートする直接編集機能により、コンポーネントテンプレートを編集し、新しく作成したコンポーネントテンプレートアイテムの初期リビジョンに保存できます。直接編集を使用すれば、ソースデータを別途バージョン管理する必要がなくなります。Workspace自体から最新のソースを直接読み込んだ一時エディターを使用するだけで、サポートされているコンテンツタイプを編集できます。編集が完了すると、そのデータは親アイテムの次の予定リビジョンに保存(または再保存)され、一時エディターは閉じられます。ハードドライブ上にファイルを置く必要も、正しいソースや最新のソースで作業しているかを気にする必要も、別のバージョン管理ソフトウェアを維持する必要もありません。Workspaceが高い整合性を保ちながらすべてを処理し、データの変更を大幅に効率化します。

コンポーネントテンプレートアイテムを作成する際、作成後にそのアイテムの初期リビジョンでコンポーネントテンプレートを編集して保存できます。これを行うには、新規アイテムの作成ダイアログの下部にあるOpen for editing after creationオプションを有効にします(デフォルトで有効になっています)。アイテムが作成され、一時的なコンポーネントテンプレートエディターが開き、メイン設計ウィンドウに.CMPTドキュメントがアクティブドキュメントとして表示されます。このドキュメントには、アイテムとリビジョンに基づき、 <Item><Revision>.CMPTという形式の名前が付けられます(例:CMPT-0001-1.CMPT)。

 
 
 
 
 

Workspaceからコンポーネントテンプレートの初期リビジョンを直接編集する例。一時的なコンポーネントテンプレートエディターに、コンポーネントテンプレートを定義するためのドキュメントが表示されます。
Workspaceからコンポーネントテンプレートの初期リビジョンを直接編集する例。一時的なコンポーネントテンプレートエディターに、コンポーネントテンプレートを定義するためのドキュメントが表示されます。

このドキュメントを使用して、必要に応じてコンポーネントテンプレートを定義します。詳細については、テンプレートの定義を参照してください。

直接編集時には、関連する3つのコントロールをQuick Access Bar(メインアプリケーションウィンドウの左上)またはComponent Template Standardツールバーから使用できます。

  • – Save Active Document。このボタンを使用すると、ドキュメントに加えた変更をローカルに保存できます。Workspaceに最終的に保存する前に、後でさらに変更を加えたい場合に、現在の変更内容を保存しておけます。
  • / – Save to Server。このボタンを使用すると、定義したコンポーネントテンプレートをWorkspaceに保存し、対象のコンポーネントテンプレートアイテムの初期(計画済み)リビジョンに格納できます。Edit Revisionダイアログが表示され、必要に応じて名前と説明を変更し、リリースノートを追加できます。保存後、ドキュメントとエディターは閉じます。ソースコンポーネントテンプレートを含むドキュメント*.CMPTは、アイテムのリビジョンに保存されます。

    Projectsパネル内のコンポーネントテンプレートの エントリの右側にも、Save to Serverコントロールが用意されています。
  • / – Discard Local Changes。編集をキャンセルし、加えた変更をすべて破棄する場合は、このボタンを使用します。ドキュメントとエディターが閉じ、対象のコンポーネントテンプレートアイテムには何もリリースされません。

これらのコントロールは、メインのFileメニューおよびProjectsパネル内のコンポーネントテンプレートのエントリを右クリックしたときのメニューから、Save(ショートカット:Ctrl+S)、Save to Server(ショートカット:Ctrl+Alt+S)、Discard Local Changes の各コマンドとしても使用できます。

Workspaceに保存されるデータは、コンポーネントテンプレートファイル(<Item><Revision>.CMPT)で定義されたソースコンポーネントテンプレートです。

 
 
 
 
 

定義したコンポーネントテンプレートをWorkspaceに保存した例。
定義したコンポーネントテンプレートをWorkspaceに保存した例。

コンポーネントテンプレートの継承

この機能は、詳細設定ダイアログでUI.ComponentTemplateInheritanceオプションが有効になっている場合に使用できます。

サブタイプにコンポーネントテンプレートがリンクされていない場合、ルートのコンポーネントタイプのコンポーネントテンプレートを使用できます。コンポーネントタイプの階層を構築すると、コンポーネントのサブタイプは、ルートまたは親のコンポーネントタイプに割り当てられたコンポーネントテンプレートを継承します。

CMPT(コンポーネントテンプレート)エディター

Altium Designerでコンポーネントテンプレートエディターを使用するには、Component Template Editor ソフトウェア拡張機能をインストールする必要があります。 この拡張機能は、デフォルトでAltium Designerとともにインストールされます。 手動でインストールまたは削除することもできます。

拡張機能の管理について詳しくは、 Extending Your Installation ページ(Altium Designer Develop、Altium Designer Agile、Altium Designer)を参照してください。

テンプレートの定義

コンポーネントテンプレートエディターは、基本的に2つの主要な領域に分かれています。次の画像にそれらを示し、その下に概要を説明します。

 
 
 
 
 

コンポーネントテンプレートエディターは、大きく2つの主要な領域に分かれています。
コンポーネントテンプレートエディターは、大きく2つの主要な領域に分かれています。

  1. Upper Region – テンプレートを参照するコンポーネントについて、コンポーネントレベルのオプション(ライフサイクル、命名、フォルダーのオプション)を定義します。
  2. Lower Region – テンプレートを参照するコンポーネントで使用するパラメーターを定義します。

コンポーネントオプションの指定

エディターの上半分では、次のコンポーネントプロパティのデフォルト値を定義します。

  • Lifecycle Definition – テンプレートを使用して作成するコンポーネントに適用するライフサイクル定義を選択します。ドロップダウンフィールドには、Workspaceで定義され、コンポーネントでの使用が許可されているすべての定義が表示されます。

  • Revision Naming – テンプレートを使用して作成するコンポーネントに適用するリビジョン命名スキームを選択します。ドロップダウンフィールドには、Workspaceで定義され、コンポーネントでの使用が許可されているすべてのスキームが表示されます。

    いずれかの定義/スキームで、コンテンツタイプごとにライフサイクル定義とリビジョン命名スキームの使用を制御するオプションが有効になっており、コンポーネントのコンテンツタイプが特定の定義/スキームを使用するように設定されていない場合、その定義/スキームは該当するドロップダウンリストに表示されません。

  • Component Naming – このフィールドを使用して、テンプレートから作成するコンポーネントのデフォルトのアイテム命名スキームを定義し、Workspace内で作成されるコンポーネントに一意のIDが割り当てられるようにします。ここで入力した内容は、コンポーネントの名前を自動的に付けるためのテンプレートとして使用されます(コンポーネントエディターをSingle Component Editingモードで使用する場合は関連するIdフィールド、Batch Component Editingモードで使用する場合はItem IDフィールド)。ソフトウェアはWorkspace全体と既存コンテンツの識別子をスキャンし、そのスキームに基づいて次に使用可能な一意のIDを自動的に割り当てます。デフォルトのアイテム命名スキーム(CMP-{00000})が用意されていますが、フィールドに入力して独自のスキームを作成することもできます。その際は、可変部分を波括弧で囲んでください(例:CMP-001-{0000})。

  • Default Folder – 保存したコンポーネントを格納する、対象Workspace内のデフォルトフォルダーを指定します。ChooseボタンをクリックしてChoose Folderダイアログ(Explorerパネルの一形態)を開き、Workspace内の既存フォルダーを参照して選択するか、その場で新しいフォルダーを作成します。

対象のWorkspaceを設定するフィールドはありません。コンポーネントテンプレートのリビジョンが保存されているWorkspaceと同じWorkspaceを使用するように固定されているためです。

各プロパティのAllow overrideオプションを使用すると、コンポーネントエディターでコンポーネントを定義する際に、ユーザーがそのプロパティを変更できるか(有効)、変更できないか(無効)を個別に制御できます。

テンプレートが参照されると、この領域で指定した内容が、コンポーネントエディター内の該当するフィールドにあらかじめ入力されます(フィールドが存在する場合)。

  • Single Component Editing mode – Component領域のAdvanced SettingsエリアにあるIdフィールドとFolderフィールド。
  • Batch Component Editing mode – ドキュメントオプションダイアログのDocument Optionsタブ、および、それに応じてコンポーネント定義領域のComponentエリアにあるItem IDフィールドとFolderPathフィールド。

テンプレートが参照されると、コンポーネントエディターのSingle Component Editingモード(左)およびBatch Component Editingモード(右)でコンポーネントを編集する際に、該当するフィールドに指定した内容があらかじめ入力されます。
テンプレートが参照されると、コンポーネントエディターのSingle Component Editingモード(左)およびBatch Component Editingモード(右)でコンポーネントを編集する際に、該当するフィールドに指定した内容があらかじめ入力されます。

パラメーターの定義

エディターの下半分は、テンプレートを参照するコンポーネントで使用できるパラメーターの定義と管理に使用します。

 
 
 
 
 

コンポーネントテンプレートで定義したパラメーターの例。
コンポーネントテンプレートで定義したパラメーターの例。

デフォルトのシステムパラメーター

新しいコンポーネントテンプレートを作成すると、さまざまなシステムパラメーターがデフォルトで含まれます。以下の画像に示し、その後で詳しく説明します。

 
 
 
 
 

新しく作成したコンポーネントテンプレートに含まれるデフォルトのシステムレベルのパラメーター。
新しく作成したコンポーネントテンプレートに含まれるデフォルトのシステムレベルのパラメーター。

  • ComponentType – このパラメーターでは、コンポーネントのタイプを指定できます。これにより、Workspaceの強力な検索機能を使用して、対象を絞り込んだ検索が容易になります。この機能では、コンポーネントタイプによる検索だけでなく、サポートされている単位を認識するコンポーネントパラメーターを使用した、より高度な検索も可能です。Componentsパネルで自分のWorkspaceのコンポーネントを参照する場合、コンポーネントのCategoriesグループ分けは、各コンポーネントに関連付けられたComponentTypeパラメーターに基づきます。関連するDefault Valueフィールドをクリックし、続いてボタンをクリックしてChoose component typeダイアログを開きます。このダイアログで必要なコンポーネントタイプを選択し、OKをクリックします。選択したタイプが、メインのパラメーターグリッドのComponentTypeパラメーターの値として入力されます。

    Choose component typeダイアログには、PreferencesダイアログのData Management – Component Typesページ で定義されたコンポーネントタイプが表示されます。Choose component typeダイアログの下部にあるボタンをクリックすると、この設定ページを開くことができます。ここでは、新しいタイプやサブタイプの追加、既存タイプの編集や削除により、ニーズに合わせて一覧を調整できます。

    ComponentTypeシステムパラメーターをDiodesに設定したコンポーネントテンプレートの例。
    ComponentTypeシステムパラメーターをDiodesに設定したコンポーネントテンプレートの例。

     
     
     
     
     

    このパラメーターのデータ型はComponentTypeに設定されており、変更できません。また、ComponentTypeパラメーターはコピーも削除もできません。セルを選択し、Delete キーを使用して値をクリアします。

  • SCHLIBとPCBLIB – これら2つのパラメーターでは、それぞれデフォルトのシンボルモデルとフットプリントモデルを指定できます。各パラメーターに対応するDefault Valueフィールドをクリックし、ボタンをクリックすると、必要なモデルを選択するダイアログが開きます。

    選択するのはモデルであり、そのモデルの特定のリビジョンではないことに注意してください。これにより、テンプレートを使用するコンポーネントは、選択したモデルの最新リビジョンを常に使用します。

    テンプレートの一部としてシンボルモデルとフットプリントモデルを指定します。
    テンプレートの一部としてシンボルモデルとフットプリントモデルを指定します。

     
     
     
     
     

    これらのパラメーターのデータ型は、それぞれSCHLIBとPCBLIBに設定されており、変更できません。また、モデルパラメーターはコピーも削除もできません。 セルを選択し、Delete キーを使用して値をクリアします。

  • NameとDescription – これら2つのパラメーターでは、それぞれコンポーネントの名前と説明を定義できます。各パラメーターに対応するDefault Valueフィールドに、必要な文字列を入力します。

    テンプレートの一部としてNameパラメーターとDescriptionパラメーターを指定します。
    テンプレートの一部としてNameパラメーターとDescriptionパラメーターを指定します。

     
     
     
     
     

    これら2つのパラメーターのデータ型は、どちらもTextに設定されており、変更できません。また、これらのパラメーターはコピーも削除もできません。

新しいユーザーパラメーターの追加

リストに新しいユーザーパラメーターを追加するには、ボタンをクリックします(または、右クリックのコンテキストメニューからAddコマンドを使用します)。パラメーターは現在のリストの末尾に追加されます。

 
 
 
 
 

テンプレートに新しいユーザーパラメーターを追加する例。
テンプレートに新しいユーザーパラメーターを追加する例。

各パラメーターは、グリッドの一覧に次の情報とともに表示されます。

  • Name – このフィールドを使用してパラメーターに名前を付けます。通常は、その目的が伝わる意味のある名前を指定します。追加直後のパラメーターには、デフォルトの名前(Parameter、Parameter 1、Parameter 2など)が付けられます。

  • Type – パラメーターの型です。初期値はTextですが、さまざまな単位を認識するデータ型に加え、複数のフットプリントの定義を可能にするPCBLIB型、およびハーネス配線コンポーネントの定義を可能にするHarnessWiring型もサポートされています。 利用可能な辞書で定義されたパラメーター型もサポートされています。詳細はこちら。

  • Visible – このオプションを有効にすると(新しく追加したパラメーターではデフォルトで有効)、コンポーネントエディター(Batch Component Editingモードに設定)で1つ以上のコンポーネントを編集する際に、そのパラメーターに対応するShowオプションが有効になります。これにより、コンポーネント定義を設定するコンポーネントエディター下部の領域で、そのパラメーターに対応する列の表示が制御されます。このプロパティは、エディターのSingle Component Editingモードでコンポーネントを定義する場合には影響しません。

  • Read Only – このオプションを有効にすると、パラメーターが読み取り専用になります。テンプレートを参照するコンポーネントを編集する際、そのパラメーターの値は編集できなくなります。

  • Required – このオプションを有効にすると、パラメーターが「必須パラメーター」になります。テンプレートを参照するコンポーネントを編集する際、このパラメーターに値が定義されていないと、コンポーネントを保存できません。コンポーネントエディターでは、値が未入力の場合、このようなパラメーターは値セルの赤い枠線(Batch Component Editingモード)またはセル内のアイコン(Single Component Editingモード)で識別されます。

  • Default Value – このフィールドを使用して、パラメーターのデフォルト値を入力します。

    • パラメーターが必須に指定され(Requiredオプションが有効)、かつ読み取り専用に設定されている(Read Onlyオプションが有効)場合は、デフォルト値をMUST入力する必要があります。入力しないと、テンプレートを参照するコンポーネントを編集する際に、そのパラメーターに値がないことが示されますが、読み取り専用で編集できないため、この状態を解消できません。この問題が解決されるまで、このコンポーネントテンプレートの新しいリビジョンをWorkspaceに保存することはできません。

    • コンポーネントのリビジョンを編集する際、リンクされたコンポーネントテンプレート内のパラメーターと同じ名前を持つ既存のユーザー定義パラメーターは、テンプレートのものに置き換えられます。 そのパラメーターの既存の値は保持されます(テンプレートのデフォルト値で上書きされることはありません)。

  • Description – パラメーターの説明を追加します。たとえば、その役割についての簡潔なメモを記載できます。テンプレート内のパラメーターに説明が定義されている場合、コンポーネントエディターのSingle Component Editingでは、それに応じて Parameters 領域に Description 列が表示されます。

パラメーターリストは、簡単なコピー&ペースト操作にも対応しており、既存のユーザーパラメーターを1つまたは複数複製できます。貼り付けたパラメーターは、リストの末尾に追加されます。

標準のコピー(Ctrl+C)と貼り付け(Ctrl+V)のショートカットに対応しています。これらのコマンドは右クリックメニューからも使用できます。標準の Ctrl+Click および Shift+Click の操作で複数のユーザーパラメーターを選択し、コピー&ペーストできます。
リストから1つまたは複数のユーザーパラメーターを削除するには、各パラメーターを選択し、 ボタンをクリックするか、右クリックのコンテキストメニューから Remove コマンドを使用します。

単位対応のコンポーネントパラメーターのデータ型

コンポーネントテンプレートエディターでは、コンポーネントテンプレート(*.CMPT)内で定義するコンポーネントパラメーターに、明示的なデータ型を設定できます。また、これらのデータ型は単位に対応しており、一般的なさまざまな単位接頭辞を使用できます。そのため、パラメーターの値を2.2k、2k2、4M、2.5GHzなどのさまざまな形式で入力できます。Workspaceには、これらの入力が表す数値を認識する機能が備わっています。

このコンポーネントテンプレートの機能により、サーバーの高度な検索機能を使った、対象を絞り込んだ検索が容易になります。この機能では、コンポーネントの種類による検索だけでなく、範囲検索による、よりスマートな検索も可能です。単位対応のコンポーネントパラメーターを活用すると、たとえば静電容量が47uFから220uFの間にあるすべてのコンデンサーを検索する条件をすばやく設定できます。

単位対応パラメーターは、Componentsパネルを使用して自分のコンポーネントを検索する際のスマートなフィルタリングにも使用されます。

単位対応パラメーターの詳細については、以下の折りたたみセクションを参照してください。

辞書で定義されたパラメーターのデータ型

辞書は、複数の値が定義されたカスタムパラメーター型です。辞書は、Workspace管理者がWorkspaceのブラウザーインターフェースのSettings – Vault – Dictionariesページで管理します。このページには、Component Template EditorでTypeドロップダウンから Add New Dictionaryオプションを選択するか、Parameters領域の右上にあるManage Dictionariesコントロールをクリックしてアクセスできます。

  • Settings – Vault – Dictionariesページには、Preferencesダイアログのデータ管理 – 辞書ページでManage Dictionariesコントロールをクリックしてアクセスすることもできます。また、Preferencesダイアログのデータ管理 – サーバーページで、アクティブなWorkspaceまたは既知のWorkspaceの Propertiesコントロールをクリックし、メニューからDictionaries項目を選択してアクセスすることもできます。

  • パラメーターに辞書で定義された型を選択している場合は、Type列にあるそのパラメーターのセル内をクリックし、続いて ボタン()をクリックすることでも、Settings – Vault – Dictionariesページにアクセスできます。

Component Template Editorから、Workspaceのブラウザーインターフェースにある辞書管理ページにアクセスします。
Component Template Editorから、Workspaceのブラウザーインターフェースにある辞書管理ページにアクセスします。

Workspaceのブラウザーインターフェースでの辞書の管理について詳しくは、こちらをご覧ください (Altium 365 Workspace、Enterprise Server Workspace)。

定義済みの辞書は、Typeドロップダウンでパラメーター型として選択できます。

Typeドロップダウンで、辞書で定義されたパラメーター型を選択します。
Typeドロップダウンで、辞書で定義されたパラメーター型を選択します。

選択した辞書定義型に定義されている値は、Default Valueドロップダウンで選択できます。パラメーターのデフォルト値として使用する値を選択するか、<None>を選択します。

選択した辞書定義型に定義されている値から、デフォルト値を選択します。
選択した辞書定義型に定義されている値から、デフォルト値を選択します。

  • デフォルト値は、コンポーネントテンプレートをWorkspaceに保存するときに検証されます。デフォルト値が辞書と整合しなくなった場合(たとえば、辞書から値が削除された後、その値を使用しているテンプレートを編集のために開いた場合)、そのデフォルト値はDefault Value列で赤く強調表示されます。また、テンプレートをWorkspaceに保存しようとすると、Messagesパネルにエラーメッセージが表示されます。

  • コンポーネントパラメーターの値が辞書と整合しなくなった場合(たとえば、コンポーネントテンプレートでそのパラメーターの型をTextから辞書定義型に変更し、コンポーネントの現在の値が、選択した辞書定義型のどの値とも一致しない場合)、Component Editorでコンポーネントを編集すると、そのパラメーターが強調表示されます。エディターの単一コンポーネント編集モードでは、整合しないパラメーター値の横に感嘆符アイコンが表示され、一括コンポーネント編集モードでは、パラメーター値が赤く強調表示されます。すべてのコンポーネントパラメーターがテンプレートの値と整合していることを確認してください。 整合していない場合、コンポーネントを次のリビジョンとして保存できません。

  • 接続先Workspaceのブラウザーインターフェースで辞書が変更された場合、その変更をAltium Designerに反映するには、Workspaceとの接続をいったん解除してから再接続する必要があります。詳しくは、 Workspaceへのアクセスページを参照してください。

複数のフットプリントの定義

Component Template Editorでは、コンポーネントテンプレートの一部として複数のPCBフットプリントを定義することもできます。フットプリントモデルへのリンクは任意の数だけ指定できます。この機能は、異なる密度レベルに関するIPC要件を満たす3つのフットプリントを参照するコンポーネントを作成する場合に便利です。これらの密度レベルは、L(最小、または最小銅箔)、M(最大、または最大銅箔)、N(標準、または中間銅箔)です。

テンプレートにフットプリントモデル定義を追加するには、をクリックして新しいパラメーターを追加し、Typeフィールドに関連付けられたドロップダウンメニューからPCBLIB項目を選択します。

新しく追加したパラメーターのTypeをPCBLIBに設定して、フットプリントモデル定義に変更します。
新しく追加したパラメーターのTypeをPCBLIBに設定して、フットプリントモデル定義に変更します。

パラメーター名はParameterからPCBLIB nに変わります。ここで、nは複数のフットプリントモデルを区別するために使用できる次の整数です(例:PCBLIB 1、PCBLIB 2など)。PCBLIB項目に関連付けられたモデルがデフォルトモデルになります。コンポーネントを定義する際にフットプリントをComponent Editorに取り込むと、デフォルトのフットプリントモデルは、モデルのプレビューウィンドウの左上にあるアイコン(Single Component Editingモードの場合)、またはRequired Models/Parameters領域のPCBLIB (default)項目(Batch Component Editingモードの場合)で識別できます。

参照するコンポーネントテンプレートを使用して、コンポーネントエディター(Single Component Editing モード)で定義したコンポーネントの例です。テンプレートには3つのフットプリントモデルが定義されており、これらがコンポーネント定義に取り込まれます。コンポーネントを定義する際、テンプレート内の PCBLIB モデルエントリーがデフォルトのフットプリントモデルとして使用される点に注目してください(左上のアイコンで識別できます)。画像にマウスポインターを合わせると、同じコンポーネントをコンポーネントエディターの Batch Component Editing モードで定義した例が表示されます。この場合、デフォルトのフットプリントは PCBLIB (default) と呼ばれます。
参照するコンポーネントテンプレートを使用して、コンポーネントエディター(Single Component Editing モード)で定義したコンポーネントの例です。テンプレートには3つのフットプリントモデルが定義されており、これらがコンポーネント定義に取り込まれます。コンポーネントを定義する際、テンプレート内の PCBLIB モデルエントリーがデフォルトのフットプリントモデルとして使用される点に注目してください(左上のアイコンで識別できます)。画像にマウスポインターを合わせると、同じコンポーネントをコンポーネントエディターの Batch Component Editing モードで定義した例が表示されます。この場合、デフォルトのフットプリントは PCBLIB (default) と呼ばれます。

コンポーネントテンプレートのインポートとエクスポート

既存のコンポーネントテンプレートファイル(*.CMPT)またはコンポーネントライブラリファイル(*.CMPLIB)をコンポーネントテンプレートエディターにインポートできます。また、編集中のコンポーネントテンプレートをコンポーネントテンプレートファイル(*.CMPT)にエクスポートできます。コンポーネントエディターのメインメニューにある File » Import » Component Template、 File » Import » Component Library および File » Export コマンドで必要な操作を選択し、表示される標準のWindowsダイアログで目的の場所を参照して、インポートするファイルを選択するか、エクスポートするファイルの名前を指定します。

コンポーネントテンプレートの再利用

コンポーネントテンプレートのリビジョンを使用する、より正確には、現在編集中のコンポーネントのリビジョンから参照するには、次の方法があります。

コンポーネントが一度に参照できるコンポーネントテンプレートは1つだけです。

新規コンポーネントの作成時

メインメニューの File » New » Component コマンドを使用して新規コンポーネントを作成する際、Create new component ダイアログでテンプレートを選択できます。

新規コンポーネントの作成時に、使用可能なすべてのテンプレートの一覧からコンポーネントテンプレートをすばやくリンクします。
新規コンポーネントの作成時に、使用可能なすべてのテンプレートの一覧からコンポーネントテンプレートをすばやくリンクします。

コンポーネントエディター内での手動設定

コンポーネントエディターでコンポーネントテンプレートのリビジョンを再利用する方法は、エディターの動作モードによって異なります。

単一コンポーネント編集モードの場合

コンポーネントエディターのこのモードで単一のコンポーネントを編集する場合、エディターの Component 領域にある Advanced Settings グループの Template フィールドに関連付けられたドロップダウンメニューから、必要なコンポーネントテンプレートを選択します。コンポーネント自体が存在するWorkspaceで現在使用可能なすべてのコンポーネントテンプレートが名前で一覧表示され、最新のリビジョンが括弧内に表示されます。必要なテンプレートを選択すると適用されます。

コンポーネントエディターの Single Component Editing モードでコンポーネントのリビジョンを編集する際、使用可能なすべてのテンプレートのメニューからコンポーネントテンプレートをすばやくリンクします。
コンポーネントエディターの Single Component Editing モードでコンポーネントのリビジョンを編集する際、使用可能なすべてのテンプレートのメニューからコンポーネントテンプレートをすばやくリンクします。

一括コンポーネント編集モードの場合

現在編集中のコンポーネントのリビジョンに、コンポーネントテンプレートのリビジョンをリンクするには、次の2つの方法があります。

  • ドキュメントオプションダイアログ(Edit » Document Options)の Template タブから設定します。Item Revision フィールドの右側にある Choose ボタンをクリックします。これにより、Choose Item ダイアログ(Explorerパネルの別形式)が開きます。このダイアログで必要なコンポーネントテンプレートを参照し、そのリビジョンを選択します。OK をクリックすると、コンポーネントのリビジョンと、コンポーネントテンプレートの対象リビジョンとの間にリンクが作成されます。このリンクは、Document Options ダイアログの Template タブに戻って確認できます。

    対象のWorkspace内で、コンポーネントをコンポーネントテンプレートのリビジョンに手動でリンクします。
    対象のWorkspace内で、コンポーネントをコンポーネントテンプレートのリビジョンに手動でリンクします。

    使用するコンポーネントテンプレートはいつでも変更できます。Choose をクリックして、別のコンポーネントテンプレートのリビジョンを選択してください。
    リンクされたコンポーネントテンプレートのアイテムリビジョンのステータスは、Document Options ダイアログの Template タブに表示されます。リンクされたアイテムに新しいリビジョンがある場合は、 ボタンをクリックして最新のリビジョンを使用します。
  • コンポーネントエディターの Required Models/Parameters 領域に関連付けられた Add メニューから設定します。Templates サブメニューには、コンポーネント自体が存在するWorkspaceで現在使用可能なすべてのコンポーネントテンプレートが名前で一覧表示され、最新のリビジョンが括弧内に表示されます。エントリーをクリックすると、そのコンポーネントテンプレートの最新リビジョンへのリンクが作成されます。この場合も、Document Options ダイアログの Templates タブでリンクを確認できます。

    使用可能なすべてのテンプレートのメニューからコンポーネントテンプレートをすばやくリンクします。
    使用可能なすべてのテンプレートのメニューからコンポーネントテンプレートをすばやくリンクします。

WorkspaceのComponentsフォルダーからの継承

Workspace内のComponentsフォルダーに保存されるすべてのコンポーネント(およびそのリビジョン)に対して、自動的に使用するコンポーネントテンプレートを指定できます。

デフォルトのコンポーネントテンプレートを定義できるのは、種類が Components のフォルダーのみです。

フォルダー編集ダイアログでフォルダーのプロパティを定義する際、Component Template フィールドを使用して必要なテンプレートを指定します。このフィールドのドロップダウンには、Componentsフォルダー自体が存在するWorkspaceで現在使用可能なすべてのコンポーネントテンプレートが名前で一覧表示され、最新のリビジョンが括弧内に表示されます。エントリーを選択すると、そのフォルダー内で以後作成される各コンポーネントに対して、そのコンポーネントテンプレートの最新リビジョンへのリンクが作成されます。

親のComponentsフォルダー内で作成されるすべてのコンポーネントに適用する、デフォルトのコンポーネントテンプレートを指定します。
親のComponentsフォルダー内で作成されるすべてのコンポーネントに適用する、デフォルトのコンポーネントテンプレートを指定します。

この機能を使用しない場合は、Component Template フィールドを None のままにするか、その値に設定してください。

フォルダーレベルでコンポーネントテンプレートを選択すると、その下の子サブフォルダーでコンポーネントを作成する際にも、デフォルトで同じテンプレートが使用されます。これにより、子フォルダー内のすべてのコンポーネントにテンプレートを簡単に継承できます。

コンポーネントのリビジョンをWorkspaceに保存すると、使用したコンポーネントテンプレートの特定のリビジョンが実質的に固定されます。つまり、手動で変更しない限り、そのリビジョンへの強固なリンクが作成されます。

コンポーネントテンプレートの使用がコンポーネントのモデルとパラメーターに与える影響

コンポーネントのリビジョンを編集する際に、コンポーネントテンプレートのリビジョンをリンクまたは参照すると、コンポーネントエディター内のモデルとパラメーターに対して次の処理が行われます。

  • 参照するテンプレート内で定義されたモデルが、Models 領域(Single Component Editing モード)および Model Links 領域(Batch Component Editing モード)に追加されます。
  • 既存の参照モデルは保持され、意図的に手動で変更しない限り、コンポーネントはそのモデルを引き続き使用します。
  • 参照するテンプレート内で定義されたパラメーターが、Parameters 領域(Single Component Editing モード)および Required Models/Parameters 領域(Batch Component Editing モード)に追加されます。

    コンポーネントエディターの Single Component Editing モード(左)および Batch Component Editing モード(右)で、コンポーネントテンプレートのリビジョンにリンクした後のパラメーターの例です。
    コンポーネントエディターの Single Component Editing モード(左)および Batch Component Editing モード(右)で、コンポーネントテンプレートのリビジョンにリンクした後のパラメーターの例です。

    参照するコンポーネントテンプレートに由来するすべてのパラメーターは、 アイコン(Single Component Editing モード)および アイコン(Batch Component Editing モード)で識別できます。また、一括コンポーネント編集モードに限り、テンプレートに基づく各パラメーターの Show オプションは、テンプレート内の対応する Visible オプションの状態に従います。
    テンプレートに基づくパラメーターは削除できません。
    必要に応じて、追加のユーザーパラメーターを自由に追加できます。
  • Batch Component Editing モードに限り、表示するように設定されたテンプレート由来のパラメーターは、エディターのコンポーネント定義領域内でまとめて表示され、見出しには Template Parameters が使用されます。

    コンポーネントエディターを Batch Component Editing モードで使用した場合の、コンポーネント定義を行う領域に表示されるテンプレートベースのパラメーターの例。
    コンポーネントエディターを Batch Component Editing モードで使用した場合の、コンポーネント定義を行う領域に表示されるテンプレートベースのパラメーターの例。

  • 読み取り専用に設定されたテンプレートベースのパラメーターの値フィールドは、編集できません。読み取り専用に設定されていないその他のテンプレートベースのパラメーターについては、必要に応じて自由に値を変更できます。

    コンポーネントエディターが Single Component Editing モードの場合、読み取り専用のテンプレートパラメーターは、Parameters 領域に表示される アイコンで識別できます。
  • テンプレートベースのパラメーターが必須に設定されているにもかかわらず、テンプレート内で値が指定されていない場合、その値フィールドには赤い枠線(Batch Component Editing モードの場合)または アイコン(Single Component Editing モードの場合)が表示され、このパラメーターに値が必要であることを知らせます。すべての必須パラメーターに値を設定するまで、コンポーネントを Workspace に保存することはできません。

    コンポーネントエディターが Single Component Editing モードの場合、必須のテンプレートパラメーターは、Parameters 領域に表示される アイコンで識別できます。

コンポーネントテンプレートの再保存

いつでも Workspace 内のコンポーネントテンプレートの任意のリビジョンに戻り、直接編集できます。リビジョンを右クリックし、コンテキストメニューから Edit コマンドを選択します。一時エディターが再び開き、そのリビジョンに含まれるテンプレートを編集できるようになります。必要な変更を加えた後、コンポーネントテンプレートをアイテムの次のリビジョンとして保存します。

コンポーネントテンプレート自体の最上位エントリを右クリックすると、そのテンプレートの最新リビジョンを編集できます。

コンポーネントテンプレートの既存のリビジョンを直接編集するためのコマンドへのアクセス。
コンポーネントテンプレートの既存のリビジョンを直接編集するためのコマンドへのアクセス。

保存済みデータのダウンロード

コンポーネントテンプレートのリビジョンに保存されているデータをダウンロードするには、Explorer パネルでそのリビジョンを右クリックし、コンテキストメニューから Operations » Download コマンドを選択します。コンポーネントテンプレートファイルは、選択したディレクトリ内に作成される、アイテムリビジョン ID を名前とするサブフォルダーにダウンロードされます。ファイルは、その中の Released フォルダーにあります。

コンポーネントテンプレート自体の最上位エントリから Download コマンドを実行すると、そのテンプレートの最新リビジョンに保存されているコンポーネントテンプレートファイルをダウンロードできます。
Download from Server ダイアログの Explore ボタンをクリックすると、ダウンロード先のフォルダーをすぐに開くことができます。

論理削除

Workspace に接続している場合、Altium Designer の Explorer パネルからコンポーネントテンプレートを直接削除できる柔軟な機能を利用できます。パネル内のコンポーネントテンプレートのエントリを右クリックし、コンテキストメニューから Delete Item コマンドを選択します。削除を確認するための Delete Items ダイアログが表示されます。この操作は実際には「論理削除」であり、コンポーネントテンプレートは Workspace の Trash 領域に移動されます。Trash は、Workspace 内のあらゆるコンテンツを論理削除操作によって移動できる、いわばごみ箱です。Workspace の他の領域からは隔離されています。

論理削除機能では、現在使用されているコンポーネントテンプレートも削除できます。
複数のコンポーネントテンプレートを一度に削除できます。標準の複数選択操作(Shift+Click、Ctrl+Click)で対象のコンポーネントテンプレートをすべて選択し、右クリックしてコンテキストメニューから Delete Items コマンドを選択します。

コンポーネントテンプレートの論理削除。テンプレートは Workspace の Trash 領域に移動されます。
コンポーネントテンプレートの論理削除。テンプレートは Workspace の Trash 領域に移動されます。

削除を実行するには、 ボタンをクリックします。アイテムが削除され、Deletion Summary ダイアログで削除の成功が確認されます。削除に問題があった場合は、その旨が通知されます。

この方法で削除されたすべてのコンテンツは、Workspace のブラウザーインターフェースの Trash ページで確認できます。ただし、表示できるのは自分自身が論理削除したコンテンツのみです。管理者は、Trash ページのすべてのコンテンツ、つまり論理削除されたすべてのコンテンツを確認できます。

論理削除されたコンポーネントテンプレートに関する注意事項:

  • コンポーネントテンプレートは、設計ソフトウェアからも Web インターフェースからも利用できなくなります。
  • コンポーネントテンプレートが使用されていたすべての場所で、そのコンポーネントテンプレートが削除されたことが示されます。
  • 編集権限があれば、Trash ページからコンポーネントテンプレートを復元するか、完全に削除できます。完全に削除できるのは、親アイテムで使用されていない場合のみです。
コンポーネントテンプレートを論理削除して Trash に移動した場合、その後、同じ名前で新しいコンポーネントテンプレートを作成できます。その後で元のコンポーネントテンプレートを復元する際に、元の名前がすでに使用されている場合は、Workspace 内で名前が一意になるように整数の接尾辞が付加されます。
AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents