コンポーネントテンプレート

概略

接続されたWorkspaceのコンポーネントテンプレートは、再利用可能な設定やパラメーターを提供し、Altium Designerでのコンポーネント作成を効率化します。この記事では、コンポーネントテンプレートアイテムの整理方法、命名スキームとライフサイクルスキームの選択方法、ダイレクト編集を使用してテンプレートを定義し、Workspaceに保存する方法を説明します。また、パラメーターの表示、デフォルト値、必須フィールド、設計者による上書きの設定についても紹介します。再利用可能なテンプレートを作成して、より一貫性のあるコンポーネント定義を実現しましょう。

- 適切な命名スキーム、リビジョンスキーム、ライフサイクルスキームを使用して、Workspaceフォルダーとコンポーネントテンプレートアイテムを設定する方法を学びます。
- 必須の値や読み取り専用のデフォルト値など、テンプレートによるコンポーネントパラメーターの制御方法を理解します。
- テンプレートを直接編集し、新しいリビジョンとしてWorkspaceに保存する方法を確認します。
AIでさらに深掘り:

コンポーネントの作成を効率化するため、Altium Designerは接続されたWorkspaceと連携して、そのWorkspace内でのComponent Templates (コンポーネントテンプレートアイテム)の作成と定義をサポートしています。回路図テンプレートを使用して、それを参照する回路図シートの情報を事前定義できるのと同様に、コンポーネントテンプレートはWorkspaceライブラリコンポーネントから参照され、そのコンポーネントを定義する際に使用する設定を事前に提供します。

特に、コンポーネントテンプレートはパラメーター情報を重視して開発されており、参照元のコンポーネントで利用できるパラメーター群を1か所で定義できます。テンプレートを通じて、表示するパラメーターの制御、デフォルト値の入力、さらには必要なパラメーターの必須指定も行えます。コンポーネントの保存時には検証チェックが実行され、これらの要件に準拠していることが確認されます。

テンプレートの多くの設定では、指定したデフォルト値を読み取り専用に固定することも、コンポーネントを定義する設計者が上書きできるように個別に設定することもできます。

コンポーネントテンプレートは、汎用コンポーネントを作成するための基盤にもなります。詳細は、 汎用コンポーネントの作成 ページを参照してください。

コンポーネントテンプレートへのアクセス可否は、ソフトウェアのライセンスによって異なります。詳細は、ページ右側のNoteボックスを参照してください。

これらのコンポーネントテンプレートは、Workspace内から直接作成します。コンポーネントテンプレートを作成し、そのリビジョンにデータを保存すると、1つ以上のコンポーネントの作成に再利用できます。

フォルダーの種類

コンポーネントテンプレートを保存するフォルダーを作成する際は、フォルダーの種類を指定できます。これはフォルダーの内容には影響しません。コンポーネントテンプレートをリリースすると、常に対応するコンポーネントテンプレートアイテムが作成されます。フォルダーの種類は、保存されている内容を視覚的に示す「手がかり」にすぎませんが、Workspace内で特定のコンテンツを探す際に役立ちます。フォルダーをコンポーネントテンプレートの保存先として指定するには、[Edit Folder]ダイアログでフォルダーのプロパティを定義する際に、Folder TypeをComponent Templatesに設定します。

フォルダーの種類、つまり用途を指定すると、Workspaceを参照する際に、そのフォルダーの内容を視覚的に把握できます。
フォルダーの種類、つまり用途を指定すると、Workspaceを参照する際に、そのフォルダーの内容を視覚的に把握できます。

コンテンツの種類

コンポーネントテンプレートを保存するコンポーネントテンプレートアイテムを作成する際は、[Create New Item]ダイアログで、Content TypeがComponent Templateに設定されていることを確認してください。Component Templatesタイプのフォルダー内にアイテムを作成する場合は、アイテム作成時の右クリックコンテキストメニューから、このコンテンツの種類を選択できます。

Component Templatesフォルダー内でのコンポーネントテンプレートの作成。適切なContent Typeをコンテキストメニューから選択できます。
Component Templatesフォルダー内でのコンポーネントテンプレートの作成。適切なContent Typeをコンテキストメニューから選択できます。

コンポーネントテンプレートの保存

Related page: コンテンツの作成と編集

ここまでは、関連するフォルダーとコンテンツの種類という観点から、Workspaceでのコンポーネントテンプレートのサポートについて説明しました。実際に定義したコンポーネントテンプレートは、このようなコンポーネントテンプレートアイテムのリビジョンに、効率的な手順で保存できます。

Workspaceの直接編集機能により、コンポーネントテンプレートを編集し、新しく作成したコンポーネントテンプレートアイテムの初期リビジョンに保存できます。直接編集を使用すると、ソースデータを別途バージョン管理する必要がなくなります。Workspace自体から最新のソースを直接読み込んだ一時エディターを使用して、対応する種類のコンテンツを編集するだけです。編集が完了すると、対象は親アイテムの次の計画済みリビジョンに保存(または再保存)され、一時エディターが閉じられます。ハードドライブにファイルを置く必要も、正しいソースや最新のソースで作業しているかを気にする必要も、別のバージョン管理ソフトウェアを維持する必要もありません。Workspaceがすべてを高い整合性を保って処理し、データの変更を大幅に迅速化します。

コンポーネントテンプレートアイテムを作成する際は、作成後にそのアイテムの初期リビジョンでコンポーネントテンプレートを編集して保存することができます。これを行うには、新規アイテムの作成ダイアログの下部にあるオプションOpen for editing after creationを有効にします(デフォルトで有効)。アイテムが作成され、一時的なコンポーネントテンプレートエディターが開き、メイン設計ウィンドウに.CMPTドキュメントがアクティブドキュメントとして表示されます。このドキュメントには、アイテムとリビジョンに基づいて、 <Item><Revision>.CMPTという形式で名前が付けられます(例:CMPT-0001-1.CMPT)。

 
 
 
 
 

Workspaceから直接、コンポーネントテンプレートの初期リビジョンを編集する例。一時的なコンポーネントテンプレートエディターには、コンポーネントテンプレートを定義するためのドキュメントが表示されます。
Workspaceから直接、コンポーネントテンプレートの初期リビジョンを編集する例。一時的なコンポーネントテンプレートエディターには、コンポーネントテンプレートを定義するためのドキュメントが表示されます。

このドキュメントを使用して、必要に応じてコンポーネントテンプレートを定義します。詳細については、テンプレートの定義を参照してください。

直接編集時に使用する3つのコントロールは、Quick Access Bar(メインアプリケーションウィンドウの左上)またはComponent Template Standardツールバーから簡単に利用できます。

  • – Save Active Document。このボタンを使用すると、ドキュメントに加えた変更をローカルに保存できます。Workspaceに最終的に保存する前に、後からさらに変更を加えたい場合に、現在の変更内容を保存しておくことができます。
  • / – Save to Server。このボタンを使用すると、定義したコンポーネントテンプレートをWorkspaceに保存し、対象のコンポーネントテンプレートアイテムの初期(計画済み)リビジョンに格納できます。Edit Revisionダイアログが表示され、必要に応じて名前や説明を変更したり、リリースノートを追加したりできます。保存後、ドキュメントとエディターは閉じます。ソースコンポーネントテンプレートを含むドキュメント*.CMPTは、アイテムのリビジョンに格納されます。

    Projectsパネル内のコンポーネントテンプレートのエントリの右側にも、便利なSave to Serverコントロールが用意されています。
  • / – Discard Local Changes。編集をキャンセルし、加えた変更を破棄するには、このボタンを使用します。ドキュメントとエディターが閉じ、対象のコンポーネントテンプレートアイテムには何もリリースされません。

これらのコントロールは、メインのFileメニュー、およびProjectsパネル内のコンポーネントテンプレートのエントリの右クリックメニューから、コマンドとしても利用できます。コマンドは、Save(ショートカット:Ctrl+S)、Save to Server(ショートカット:Ctrl+Alt+S)、Discard Local Changesです。

Workspaceに保存されるデータは、コンポーネントテンプレートファイル(<Item><Revision>.CMPT)で定義されたソースコンポーネントテンプレートです。

 
 
 
 
 

定義したコンポーネントテンプレートをWorkspaceに保存した例。
定義したコンポーネントテンプレートをWorkspaceに保存した例。

コンポーネントテンプレートの継承

この機能は、詳細設定ダイアログでUI.ComponentTemplateInheritanceオプションが有効になっている場合に利用できます。

サブタイプにコンポーネントテンプレートがリンクされていない場合は、ルートのコンポーネントタイプのコンポーネントテンプレートを使用できます。コンポーネントタイプの階層を構築すると、コンポーネントのサブタイプは、ルートまたは親のコンポーネントタイプに割り当てられたコンポーネントテンプレートを継承します。

CMPT(コンポーネントテンプレート)エディター

Altium Designerでコンポーネントテンプレートエディターにアクセスするには、Component Template Editorソフトウェア拡張機能がインストールされている必要があります。この拡張機能は、デフォルトでAltium Designerとともにインストールされます。手動でインストールまたは削除することもできます。

拡張機能の管理の詳細については、Extending Your Installationページ(Altium Designer Develop、Altium Designer Agile、Altium Designer)を参照してください。

テンプレートの定義

コンポーネントテンプレートエディターは、基本的に2つの主要な領域に分かれています。次の図にそれらを示し、その後で概要を説明します。

 
 
 
 
 

コンポーネントテンプレートエディターは、大きく2つの主要な領域に分かれています。
コンポーネントテンプレートエディターは、大きく2つの主要な領域に分かれています。

  1. Upper Region – テンプレートを参照するコンポーネントの、コンポーネントレベルのオプション(ライフサイクル、命名、フォルダーのオプション)を定義します。
  2. Lower Region – テンプレートを参照するコンポーネントで使用するパラメーターを定義します。

コンポーネントオプションの指定

エディターの上半分では、次のコンポーネントプロパティのデフォルト値を定義します。

  • Lifecycle Definition – テンプレートを使用して作成するコンポーネントに適用するライフサイクル定義を選択します。ドロップダウンフィールドには、Workspaceで定義され、コンポーネントでの使用が許可されているすべての定義が表示されます。

  • Revision Naming – テンプレートを使用して作成するコンポーネントに適用するリビジョン命名スキームを選択します。ドロップダウンフィールドには、Workspaceで定義され、コンポーネントでの使用が許可されているすべてのスキームが表示されます。

    コンテンツタイプごとにライフサイクル定義とリビジョン命名スキームの使用を制御するオプションが有効になっている定義/スキームについて、Componentコンテンツタイプでその定義/スキームを使用するように設定されていない場合、その定義/スキームは該当するドロップダウンリストに表示されません。

  • Component Naming – このフィールドを使用して、テンプレートから作成されるコンポーネントのデフォルトのアイテム命名スキームを定義し、Workspace内でコンポーネントに一意のIDが付与されるようにします。ここに入力した内容は、コンポーネントを自動命名するためのテンプレートとして使用されます(Component EditorをSingle Component Editingモードで使用する場合は関連するIdフィールド、Batch Component Editingモードで使用する場合はItem IDフィールド)。ソフトウェアはWorkspace全体と既存コンテンツの識別子をスキャンし、そのスキームに基づいて次に使用可能な一意のIDを自動的に割り当てます。デフォルトのアイテム命名スキームとしてCMP-{00000}が用意されていますが、フィールドに入力して独自のスキームを作成することもできます。その際は、可変部分を波かっこで囲んでください(例:CMP-001-{0000})。

  • Default Folder – 保存したコンポーネントを格納する、対象Workspace内のデフォルトフォルダーを指定します。ChooseボタンをクリックしてChoose Folderダイアログ(Explorerパネルの一形態)を開き、Workspace内の既存フォルダーを参照して選択するか、その場で新しいフォルダーを作成します。

対象Workspaceを設定するフィールドはありません。コンポーネントテンプレートのリビジョンが存在するWorkspaceと同じWorkspaceを使用するように固定されているためです。

各プロパティのAllow overrideオプションを使用すると、Component Editorでコンポーネントを定義する際に、ユーザーがそのプロパティを変更できるか(有効)、できないか(無効)を個別に制御できます。

テンプレートが参照されると、この領域で指定した内容が、Component Editor内の該当するフィールドに事前入力されます(該当フィールドが存在する場合)。

  • Single Component Editing mode – Component領域のAdvanced SettingsエリアにあるIdおよびFolderフィールド。
  • Batch Component Editing mode – Document OptionsダイアログのDocument Optionsタブ、およびそれに対応する、コンポーネント定義領域のComponentエリアにあるItem IDおよびFolderPathフィールド。

テンプレートが参照されると、Component EditorのSingle Component Editingモード(左)およびBatch Component Editingモード(右)でコンポーネントを編集する際に、該当するフィールドに内容が事前入力されます。
テンプレートが参照されると、Component EditorのSingle Component Editingモード(左)およびBatch Component Editingモード(右)でコンポーネントを編集する際に、該当するフィールドに内容が事前入力されます。

パラメーターの定義

エディターの下半分では、テンプレートを参照するコンポーネントで利用可能になるパラメーターを定義および管理します。

 
 
 
 
 

コンポーネントテンプレートで定義されたパラメーターの例。
コンポーネントテンプレートで定義されたパラメーターの例。

デフォルトのシステムパラメーター

新しいコンポーネントテンプレートを作成すると、各種システムパラメーターがデフォルトで含まれます。以下の画像に示し、その後で詳しく説明します。

 
 
 
 
 

新規作成したコンポーネントテンプレートに含まれるデフォルトのシステムレベルのパラメーター。
新規作成したコンポーネントテンプレートに含まれるデフォルトのシステムレベルのパラメーター。

  • ComponentType – このパラメーターでは、コンポーネントのタイプを指定できます。これにより、Workspaceの強力な検索機能を使って、対象を絞り込んだ検索が容易になります。この機能では、コンポーネントタイプによる検索だけでなく、サポートされている単位を認識するコンポーネントパラメーターを使用した、よりスマートな検索も可能です。Componentsパネルで自分のWorkspaceのコンポーネントを参照する場合、コンポーネントのCategoriesグループ分けは、各コンポーネントに関連付けられたComponentTypeパラメーターに基づきます。関連するDefault Valueフィールドをクリックしてから、ボタンをクリックし、Choose component typeダイアログを開きます。このダイアログで必要なコンポーネントタイプを選択し、OKをクリックすると、メインのパラメーターグリッドに戻り、選択したタイプがComponentTypeパラメーターの値として挿入されます。

    Choose component typeダイアログには、PreferencesダイアログのData Management – Component Typesページ で定義されたコンポーネントタイプが反映されます。Choose component typeダイアログの下部にあるボタンをクリックすると、この設定ページにアクセスできます。ここで、新しいタイプやサブタイプの追加、既存タイプの編集や削除を行い、ニーズに合わせてリストをカスタマイズできます。

    ComponentTypeシステムパラメーターをDiodesに設定したコンポーネントテンプレートの例。
    ComponentTypeシステムパラメーターをDiodesに設定したコンポーネントテンプレートの例。

    このパラメーターのデータ型はComponentTypeに設定されており、変更できません。また、ComponentTypeパラメーターは削除できません。値をクリアするには、セルを選択してDelete キーを使用します。

  • SCHLIBおよびPCBLIB – これら2つのパラメーターでは、それぞれデフォルトのシンボルモデルとフットプリントモデルを指定できます。各パラメーターに関連するDefault Valueフィールドをクリックしてから、ボタンをクリックすると、必要なモデルを選択するためのダイアログが開きます。

    選択するのはモデルであり、そのモデルの特定のリビジョンではない点に注意してください。これにより、テンプレートを使用するコンポーネントでは、選択したモデルの最新リビジョンが常に使用されます。

    テンプレートの一部としてシンボルモデルとフットプリントモデルを指定します。
    テンプレートの一部としてシンボルモデルとフットプリントモデルを指定します。

    これらのパラメーターのデータ型は、それぞれSCHLIBおよびPCBLIBに設定されており、変更できません。また、モデルパラメーターは削除できません。 値をクリアするには、セルを選択してDeleteキーを使用します。

  • NameおよびDescription – これら2つのパラメーターでは、それぞれコンポーネントの名前と説明を定義できます。各パラメーターに関連するDefault Valueフィールドに必要な文字列を入力します。

    テンプレートの一部としてNameおよびDescriptionパラメーターを指定します。
    テンプレートの一部としてNameおよびDescriptionパラメーターを指定します。

    これら両方のパラメーターのデータ型は Text に設定されており、変更できません。また、これらのパラメーターは削除できません。

システムパラメーターのコピー&ペーストがサポートされており、テンプレートドキュメント間で貼り付けることができます。

コンポーネントテンプレートで1つ以上のパラメーターを選択し、選択項目の右クリックメニューから Copy コマンドを使用します(ショートカット:Ctrl+C)。コピーしたパラメーターは、右クリックメニューの Paste コマンドを使用して、別のコンポーネントテンプレートに貼り付けることができます(ショートカット:Ctrl+V)。

 
 
 
 
 

SCHLIB、Name、Description のシステムパラメーターを、Diodes コンポーネントテンプレートで選択してコピーしました。

これらのパラメーターを別のコンポーネントテンプレート(Zeners)に貼り付け、その値を対応するパラメーターに適用しました。 

 

新しいユーザーパラメーターの追加

リストに新しいユーザーパラメーターを追加するには、 ボタンをクリックします(または、右クリックのコンテキストメニューから Add コマンドを使用します)。パラメーターは現在のリストの末尾に追加されます。

 
 
 
 
 

テンプレートに新しいユーザーパラメーターを追加する例。
テンプレートに新しいユーザーパラメーターを追加する例。

各パラメーターは、グリッド内のリストに以下の情報とともに表示されます。

  • Name – このフィールドでパラメーターに名前を付けます。通常は、その用途が伝わるわかりやすい名前にします。追加直後のパラメーターには、デフォルトの名前(Parameter、Parameter 1、Parameter 2 など)が付けられます。

  • Type – パラメーターの型です。初期値は Text ですが、さまざまな単位対応のデータ型のほか、複数のフットプリントの定義を容易にする PCBLIB 型や、ハーネス配線コンポーネントの定義を容易にする HarnessWiring もサポートされています。 利用可能な辞書で定義されたパラメーターの型もサポートされています。詳細はこちら。

  • Visible – このオプションを有効にすると(新しく追加したパラメーターではデフォルトで有効)、Component Editor(Batch Component Editing モードに設定)で1つ以上のコンポーネントを編集する際に、そのパラメーターに対応する Show オプションが有効になります。これにより、コンポーネント定義自体を設定する Component Editor の下部領域で、そのパラメーターに対応する列の表示が制御されます。エディターの Single Component Editing モードでコンポーネントを定義する場合、このプロパティは影響しません。

  • Read Only – このオプションを有効にすると、パラメーターが読み取り専用になります。テンプレートを参照するコンポーネントを編集する際、このパラメーターの値は編集できなくなります。

  • Required – このオプションを有効にすると、パラメーターが「必須パラメーター」になります。テンプレートを参照するコンポーネントを編集する際は、このパラメーターに値を設定する必要があります。設定しないと、コンポーネントを保存できません。Component Editor では、このようなパラメーターに値が入力されていない場合、値のセルが赤い枠で表示されるか(Batch Component Editing モード)、 アイコンが表示されます(Single Component Editing モード)。

  • Default Value – このフィールドにパラメーターのデフォルト値を入力します。

    • パラメーターを必須に設定し(Required オプションを有効化)、さらに読み取り専用にも設定した場合(Read Only オプションを有効化)、デフォルト値の入力がMUST。入力しないと、テンプレートを参照するコンポーネントの編集時に、そのパラメーターに値がないことが示されますが、読み取り専用で編集できないため、この問題を解決できません。この問題が解決されるまで、このコンポーネントテンプレートの新しいリビジョンを Workspace に保存することはできません。

    • コンポーネントのリビジョンを編集する際、リンクされたコンポーネントテンプレート内のパラメーターと同じ名前を持つ既存のユーザー定義パラメーターは、テンプレート側のパラメーターに置き換えられます。そのパラメーターに既存の値がある場合は保持されます(テンプレートのデフォルト値で上書きされません)。

  • Description – パラメーターの説明を入力します。たとえば、その役割についての簡潔なメモなどを追加できます。テンプレート内のパラメーターに説明が定義されている場合、Component Editor の Single Component Editing では、それに応じて Parameters 領域に Description 列が表示されます。

パラメーターリストでは通常のコピーと貼り付けもサポートされており、1つ以上の既存のユーザーパラメーターを複製できます。貼り付けたパラメーターは、リストの末尾に追加されます。

標準のコピー(Ctrl+C)と貼り付け(Ctrl+V)のショートカットがサポートされており、これらのコマンドは右クリックメニューからも使用できます。標準のCtrl+ClickおよびShift+Clickの操作方法で複数のユーザーパラメーターを選択し、コピーして貼り付けることができます。
リストから1つ以上のユーザーパラメーターを削除するには、対象のパラメーターを選択し、ボタンをクリックするか、右クリックのコンテキストメニューからRemoveコマンドを使用します。

単位対応のコンポーネントパラメーターデータ型

コンポーネントテンプレートエディターでは、コンポーネントテンプレート(*.CMPT)内で定義するコンポーネントパラメーターに対して、データ型を明示的に指定できます。また、これらのデータ型は単位に対応しており、一般的な各種の単位接頭辞もサポートしています。そのため、2.2k、2k2、4M、2.5GHzなど、さまざまな形式でパラメーターの値を入力できます。Workspaceには、これらの入力が表す数値を認識する機能が備わっています。

コンポーネントテンプレートのこの機能により、サーバーの高度な検索機能を使用して、目的を絞った検索ができます。この機能では、コンポーネントの種類で検索できるだけでなく、範囲検索による、よりスマートな検索も可能です。単位対応のコンポーネントパラメーターを活用すれば、たとえば静電容量が47uF~220uFのすべてのコンデンサーを探す検索条件をすばやく設定できます。

単位対応パラメーターは、Componentsパネルで自身のコンポーネントを検索する際のスマートなフィルタリングにも使用されます。

単位対応パラメーターの詳細については、以下の折りたたみセクションをご覧ください。

辞書で定義されたパラメーターデータ型

辞書は、複数の値が定義されたカスタムパラメーター型です。辞書は、Workspace管理者がWorkspaceのブラウザーインターフェースのSettings – Vault – Dictionariesページで管理します。このページには、コンポーネントテンプレートエディターでTypeドロップダウンから Add New Dictionaryオプションを選択するか、Parameters領域の右上にあるManage Dictionariesコントロールをクリックしてアクセスできます。

  • Settings – Vault – Dictionariesページには、Preferencesダイアログのデータ管理 – 辞書ページでManage Dictionariesコントロールをクリックしてアクセスすることもできます。また、Preferencesダイアログのデータ管理 – サーバーページで、アクティブなWorkspaceまたは既知のWorkspaceのPropertiesコントロールをクリックし、メニューからDictionaries項目を選択してアクセスすることもできます。

  • パラメーターに辞書定義型を選択している場合は、Type列のパラメーターのセル内をクリックし、続いて ボタン()をクリックすることでも、Settings – Vault – Dictionariesページにアクセスできます。

コンポーネントテンプレートエディターから、Workspaceのブラウザーインターフェースで辞書を管理するページにアクセスします。
コンポーネントテンプレートエディターから、Workspaceのブラウザーインターフェースで辞書を管理するページにアクセスします。

Workspaceのブラウザーインターフェースでの辞書の管理について詳しくは、こちらをご覧ください(Altium 365 Workspace、Enterprise Server Workspace)。

定義済みの辞書は、Typeドロップダウンでパラメーター型として選択できます。

「型」ドロップダウンで、辞書で定義されたパラメーター型を選択します。
「型」ドロップダウンで、辞書で定義されたパラメーター型を選択します。

選択した辞書定義型に定義されている値は、Default Valueドロップダウンで選択できます。パラメーターのデフォルトとして使用する値を選択するか、<None>を選択します。

選択した辞書定義型に定義されている値からデフォルト値を選択します。
選択した辞書定義型に定義されている値からデフォルト値を選択します。

  • デフォルト値は、コンポーネントテンプレートをWorkspaceに保存する際に検証されます。デフォルト値と辞書の間に 不整合が生じた場合(例えば、辞書から値が削除された後に、その値を使用するテンプレートを編集用に開いた場合)、Default Value列でそのデフォルト値が赤くハイライトされ、テンプレートをWorkspaceに 保存しようとすると、Messagesパネルにエラーメッセージが表示されます。

  • コンポーネントパラメーターの 値と辞書の間に不整合が生じた場合(例えば、コンポーネントテンプレートでそのパラメーターの型がTextから辞書定義型に変更され、現在のコンポーネントの値が、選択した辞書定義型のどの 値とも一致しない場合)、Component Editorでコンポーネントを編集する際に、このパラメーターがハイライトされます。エディターの単一コンポーネント編集モードで編集する場合は、不整合のあるパラメーター値の横に感嘆符アイコンが表示され、一括コンポーネント編集モードで 編集する場合は、パラメーター値が赤くハイライトされます。すべてのコンポーネントパラメーターがテンプレートの値と整合していることを確認してください。 整合していない場合、コンポーネントを次のリビジョンとして保存できません。

  • 接続先Workspaceのブラウザーインターフェースで辞書が変更された場合、その変更をAltium Designerに反映するには、Workspaceから切断して再接続する必要があります。詳細は、 Workspaceへのアクセスページを参照してください。

複数のフットプリントの定義

Component Template Editorでは、コンポーネントテンプレートの一部として複数のPCBフットプリントを定義することもできます。フットプリントモデルのリンクは任意の数だけ指定できます。この機能は、密度レベルごとのIPC要件を満たす3つのフットプリント、すなわちL(最小、または最小銅箔)、M(最大、または最大銅箔)、N(標準、または中間銅箔)を参照するコンポーネントを作成したい場合に便利です。

テンプレートにフットプリントモデルの定義を追加するには、をクリックして新しいパラメーターを追加し、TypeフィールドのドロップダウンメニューからPCBLIBを選択します。

新しく追加したパラメーターのTypeをPCBLIBに設定すると、フットプリントモデルの定義になります。
新しく追加したパラメーターのTypeをPCBLIBに設定すると、フットプリントモデルの定義になります。

パラメーター名はParameterからPCBLIB nに変わります。ここで、nは、複数のフットプリントモデルを区別するための、次に使用可能な整数です(例:PCBLIB 1、PCBLIB 2など)。PCBLIBエントリに関連付けられたモデルがデフォルトモデルになります。コンポーネントを定義する際にフットプリントがComponent Editorに取り込まれると、デフォルトのフットプリントモデルは、モデルプレビューウィンドウの左上にあるアイコン(Single Component Editingモードの場合)、およびRequired Models/Parameters領域のPCBLIB (default)エントリ(Batch Component Editingモードの場合)で識別できます。

参照先のコンポーネントテンプレートを使用して、Component Editor(Single Component Editingモード)で定義されたコンポーネントの例です。テンプレートには3つのフットプリントモデルが定義されており、これらがコンポーネント定義に取り込まれます。コンポーネントの定義時には、テンプレートのPCBLIBモデルエントリがデフォルトのフットプリントモデルとして使用されます(左上のアイコンで識別できます)。画像にカーソルを合わせると、Component EditorのBatch Component Editingモードで同じコンポーネントを定義している状態を確認できます。この場合、デフォルトのフットプリントはPCBLIB (default)と呼ばれます。
参照先のコンポーネントテンプレートを使用して、Component Editor(Single Component Editingモード)で定義されたコンポーネントの例です。テンプレートには3つのフットプリントモデルが定義されており、これらがコンポーネント定義に取り込まれます。コンポーネントの定義時には、テンプレートのPCBLIBモデルエントリがデフォルトのフットプリントモデルとして使用されます(左上のアイコンで識別できます)。画像にカーソルを合わせると、Component EditorのBatch Component Editingモードで同じコンポーネントを定義している状態を確認できます。この場合、デフォルトのフットプリントはPCBLIB (default)と呼ばれます。

コンポーネントテンプレートのインポートとエクスポート

既存のコンポーネントテンプレートファイル(*.CMPT)またはコンポーネントライブラリファイル(*.CMPLIB)をコンポーネントテンプレートエディターにインポートできます。また、編集中のコンポーネントテンプレートをコンポーネントテンプレートファイル(*.CMPT)にエクスポートできます。コンポーネントエディターのメインメニューにある File » Import » Component Template、 File » Import » Component Library、 File » Export コマンドを使用して目的の操作を選択し、 表示される標準のWindowsダイアログで目的の場所に移動して、インポートするファイルを選択するか、エクスポートするファイルの名前を指定します。

コンポーネントテンプレートの再利用

コンポーネントテンプレートのリビジョンを使用する、より正確には、現在編集中のコンポーネントのリビジョンから参照するには、以下の方法があります。

コンポーネントが一度に参照できるコンポーネントテンプレートは1つだけです。

新しいコンポーネントを作成する場合

メインメニューのFile » New » Componentコマンドを使用して新しいコンポーネントを作成する場合、Create new componentダイアログでテンプレートを選択できます。

新しいコンポーネントを作成する際に、使用可能なすべてのテンプレートの一覧からコンポーネントテンプレートをすばやくリンクできます。
新しいコンポーネントを作成する際に、使用可能なすべてのテンプレートの一覧からコンポーネントテンプレートをすばやくリンクできます。

Component Editor内から手動で設定する場合

Component Editorからコンポーネントテンプレートのリビジョンを再利用する方法は、エディターの動作モードによって異なります。

単一コンポーネント編集モードの場合

Component Editorのこのモードで単一のコンポーネントを編集する場合は、エディターのComponent領域にあるAdvanced SettingsグループのTemplateフィールドに関連付けられたドロップダウンメニューから、必要なコンポーネントテンプレートを選択します。コンポーネント自体が存在するWorkspaceと同じWorkspace内で現在使用可能なすべてのコンポーネントテンプレートが名前で一覧表示され、最新のリビジョンが括弧内に表示されます。必要なテンプレートを選択すると適用されます。

Component EditorのSingle Component Editingモードでコンポーネントのリビジョンを編集する際に、使用可能なすべてのテンプレートのメニューからコンポーネントテンプレートをすばやくリンクできます。
Component EditorのSingle Component Editingモードでコンポーネントのリビジョンを編集する際に、使用可能なすべてのテンプレートのメニューからコンポーネントテンプレートをすばやくリンクできます。

一括コンポーネント編集モードの場合

現在編集中のコンポーネントリビジョンにコンポーネントテンプレートのリビジョンを関連付けるには、次の2つの方法があります。

  • Document Optionsダイアログ(Edit » Document Options)のTemplateタブから設定します。Item Revisionフィールドの右側にあるChooseボタンをクリックします。これにより、Choose Itemダイアログ(Explorerパネルの一形態)が開きます。このダイアログで必要なコンポーネントテンプレートのリビジョンを探して選択します。OKをクリックすると、コンポーネントのリビジョンと、対象のコンポーネントテンプレートのリビジョンの間にリンクが作成されます。このリンクは、Document OptionsダイアログのTemplateタブに戻ると確認できます。

    対象のWorkspace内で、コンポーネントをコンポーネントテンプレートのリビジョンに手動でリンクします。
    対象のWorkspace内で、コンポーネントをコンポーネントテンプレートのリビジョンに手動でリンクします。

    使用するコンポーネントテンプレートはいつでも変更できます。Chooseをクリックし、別のコンポーネントテンプレートのリビジョンを選択してください。
    リンクされたコンポーネントテンプレートのアイテムリビジョンのステータスは、Document OptionsダイアログのTemplateタブに表示されます。リンクされたアイテムに新しいリビジョンがある場合は、ボタンをクリックすると、その最新リビジョンを使用できます。
  • コンポーネントエディターのRequired Models/Parameters領域にあるAddメニューから。Templatesサブメニューには、コンポーネント自体が存在するWorkspaceで現在利用可能なすべてのコンポーネントテンプレートが名前で一覧表示され、最新リビジョンが括弧内に示されます。エントリをクリックすると、そのコンポーネントテンプレートの最新リビジョンへのリンクが作成されます。この場合も、リンクはDocument OptionsダイアログのTemplatesタブで確認できます。

    利用可能なすべてのテンプレートのメニューから、コンポーネントテンプレートをすばやくリンクします。
    利用可能なすべてのテンプレートのメニューから、コンポーネントテンプレートをすばやくリンクします。

WorkspaceのComponentsフォルダーからの継承

Workspace内のComponentsフォルダーに保存されるすべてのコンポーネント(およびそのリビジョン)に対して、自動的に使用するコンポーネントテンプレートを指定できます。

デフォルトのコンポーネントテンプレートを定義できるのは、種類がComponentsのフォルダーのみです。

フォルダーの編集ダイアログでフォルダーのプロパティを定義する際に、Component Templateフィールドを使用して必要なテンプレートを指定します。このフィールドのドロップダウンには、Componentsフォルダー自体が存在するWorkspaceで現在利用可能なすべてのコンポーネントテンプレートが名前で一覧表示され、最新リビジョンが括弧内に示されます。エントリを選択すると、それ以降にそのフォルダー内で作成される各コンポーネントに対して、そのコンポーネントテンプレートの最新リビジョンへのリンクが作成されます。

親のComponentsフォルダー内で作成されるすべてのコンポーネントに適用する、デフォルトのコンポーネントテンプレートを指定します。
親のComponentsフォルダー内で作成されるすべてのコンポーネントに適用する、デフォルトのコンポーネントテンプレートを指定します。

この機能を使用しない場合は、Component TemplateフィールドをNoneのままにするか、その値に設定してください。

フォルダーレベルでコンポーネントテンプレートを選択すると、その配下の子サブフォルダーでコンポーネントを作成する際にも、デフォルトで同じテンプレートが使用されます。これにより、子フォルダー内のすべてのコンポーネントにテンプレートをすばやく継承できます。

コンポーネントのリビジョンをWorkspaceに保存すると、使用したコンポーネントテンプレートの特定のリビジョンが実質的に固定され、そのリビジョンへの強いリンクが作成されます。このリンクは、手動で変更しない限り維持されます。

コンポーネントテンプレート使用時のコンポーネントモデルとパラメーターへの影響

コンポーネントのリビジョンを編集する際に、コンポーネントテンプレートのリビジョンをリンクまたは参照すると、コンポーネントエディター内のモデルとパラメーターに対して次の処理が行われます。

  • 参照先のテンプレートで定義されているモデルが、Models領域(Single Component Editingモード)およびModel Links領域(Batch Component Editingモード)に追加されます。
  • 既存の参照モデルは保持され、意図的に手動で変更しない限り、コンポーネントはそのモデルを引き続き使用します。
  • 参照先のテンプレートで定義されているパラメーターが、Parameters領域(Single Component Editingモード)およびRequired Models/Parameters領域(Batch Component Editingモード)に追加されます。

    コンポーネントエディターをSingle Component Editingモード(左)およびBatch Component Editingモード(右)で使用し、コンポーネントテンプレートのリビジョンにリンクした後のパラメーターの例。
    コンポーネントエディターをSingle Component Editingモード(左)およびBatch Component Editingモード(右)で使用し、コンポーネントテンプレートのリビジョンにリンクした後のパラメーターの例。

    参照先のコンポーネントテンプレートに由来するすべてのパラメーターは、アイコン(Single Component Editingモード)およびアイコン(Batch Component Editingモード)で区別されます。また、コンポーネントの一括編集モードでのみ、テンプレートに基づく各パラメーターのShowオプションが、テンプレート内の対応するVisibleオプションの状態に従います。
    テンプレートに基づくパラメーターは削除できません。
    必要に応じて、ユーザーパラメーターを自由に追加できます。
  • Batch Component Editingモードでのみ、表示するように設定されたテンプレートベースのパラメーターが、エディターのコンポーネント定義領域にまとめられ、Template Parametersがヘッダーテキストとして使用されます。

    コンポーネントエディターをBatch Component Editingモードで使用したときに、コンポーネント定義を行う領域に表示される、テンプレートベースのパラメーターの例。
    コンポーネントエディターをBatch Component Editingモードで使用したときに、コンポーネント定義を行う領域に表示される、テンプレートベースのパラメーターの例。

  • 読み取り専用に設定されたテンプレートベースのパラメーターは、値フィールドを編集できません。読み取り専用に設定されていないその他のテンプレートベースのパラメーターは、必要に応じて値を自由に変更できます。

    コンポーネントエディターがSingle Component Editingモードの場合、読み取り専用のテンプレートパラメーターは、Parameters領域でアイコンによって区別されます。
  • テンプレートベースのパラメーターが必須に設定されていても、テンプレート内で値が指定されていない場合、その値フィールドは赤い枠線で表示されるか(Batch Component Editingモード)、アイコンが表示され(Single Component Editingモード)、このパラメーターに値が必要であることを知らせます。すべての必須パラメーターに値を定義するまで、コンポーネントをWorkspaceに保存することはできません。

    コンポーネントエディターがSingle Component Editingモードの場合、必須のテンプレートパラメーターは、Parameters領域でアイコンによって区別されます。

コンポーネントテンプレートの再保存

いつでもWorkspace内のコンポーネントテンプレートの任意のリビジョンに戻り、直接編集できます。リビジョンを右クリックし、コンテキストメニューからEditコマンドを選択します。再び一時エディターが開き、そのリビジョンに含まれるテンプレートを編集できる状態になります。必要な変更を加えてから、コンポーネントテンプレートをアイテムの次のリビジョンとして保存します。

コンポーネントテンプレート自体の最上位エントリを右クリックすると、そのテンプレートの最新リビジョンを編集できます。

コンポーネントテンプレートの既存のリビジョンを直接編集するためのコマンドにアクセスします。
コンポーネントテンプレートの既存のリビジョンを直接編集するためのコマンドにアクセスします。

保存済みデータのダウンロード

コンポーネントテンプレートのリビジョンに保存されているデータをダウンロードするには、(Explorerパネルで)そのリビジョンを右クリックし、コンテキストメニューからOperations » Downloadコマンドを選択します。コンポーネントテンプレートファイルは、選択したディレクトリ配下に、アイテムリビジョンIDを名前とするサブフォルダーを作成してダウンロードされます。ファイルは、その中のReleasedフォルダーにあります。

コンポーネントテンプレート自体の最上位エントリからDownloadコマンドを実行すると、そのテンプレートの最新リビジョンに保存されているコンポーネントテンプレートファイルをダウンロードできます。
Download from ServerダイアログのExploreボタンをクリックすると、ダウンロードフォルダーをすばやく開くことができます。

論理削除

Workspaceに接続している場合、Altium Designer内のExplorerパネルから直接コンポーネントテンプレートを削除できる、柔軟な機能を利用できます。パネル内のコンポーネントテンプレートのエントリを右クリックし、コンテキストメニューからDelete Itemコマンドを選択します。削除を確認するためのDelete Itemsダイアログが表示されます。この操作は実際には「論理削除」であり、コンポーネントテンプレートはWorkspaceのTrash領域に移動されます。Trashは実質的にはごみ箱で、Workspace内のあらゆるコンテンツを(論理削除操作によって)移動できます。この領域はWorkspaceの他の領域から隔離されています。

論理削除機能を使用すると、現在使用中のコンポーネントテンプレートも削除できます。
複数のコンポーネントテンプレートを1回の操作で削除できます。標準の複数選択操作(Shift+Click、Ctrl+Click)を使用して対象のコンポーネントテンプレートをすべて選択し、右クリックしてコンテキストメニューからDelete Itemsコマンドを選択します。

コンポーネントテンプレートの論理削除。テンプレートはWorkspaceのTrash領域に移動されます。
コンポーネントテンプレートの論理削除。テンプレートはWorkspaceのTrash領域に移動されます。

削除を実行するには、 ボタンをクリックします。アイテムが削除され、Deletion Summary ダイアログに削除が完了したことが表示されます。削除中に問題が発生した場合は、その旨が通知されます。

この方法で削除したコンテンツはすべて、Workspaceのブラウザーインターフェースの Trash ページで確認できます。ただし、表示できるのは自分で論理削除したコンテンツのみです。管理者は Trash ページのすべてのコンテンツ、つまり論理削除されたすべてのコンテンツを表示できます。

論理削除されたコンポーネントテンプレートに関する注意事項:

  • コンポーネントテンプレートは、設計ソフトウェアやWebインターフェースから利用できなくなります。
  • そのコンポーネントテンプレートが使用されていたすべての場所に、テンプレートが削除されたことが反映されます。
  • 編集権限があれば、Trash ページからコンポーネントテンプレートを復元したり、完全に削除したりできます。完全に削除できるのは、親アイテムで使用されていない場合のみです。
コンポーネントテンプレートを論理削除して Trash に移動した場合は、同じ名前の新しいコンポーネントテンプレートを作成できます。その後、元のコンポーネントテンプレートを復元する際に、元の名前がすでに使用されている場合は、Workspace内で名前が一意になるように整数の接尾辞が付加されます。
AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents