部品とそのライブラリの作成と管理
概略
- 回路図シンボル、PCBフットプリント、その他のモデルが、実際の部品をどのように表現するかを理解します。
- ライブラリの選択肢を比較し、コンポーネントデータの共有、モデルの再利用、サプライチェーン情報、ライフサイクルの追跡といったWorkspaceの機能を確認します。
- コンポーネントエディターとコンポーネントテンプレートを使って、Workspaceコンポーネントの作成を始める方法を学びます。
電子設計は、相互に接続されたコンポーネントの集合です。製品開発の醍醐味は、技術的な課題を解決する優れた方法を考え出し、コンポーネントを接続して独自の設計を作り上げることにあります。
しかし、作業の大部分を占め、多くの設計者にとって面倒に感じられるのが、コンポーネントの作成です。刺激的な作業ではないかもしれませんが、コンポーネントは企業にとって貴重な資産となるため、実際の部品を正確に表現していることが不可欠です。
購入して基板にはんだ付けする部品や、ワイヤーハーネスに使用する部品は実物の部品ですが、電子設計で使用するには、使用先の各設計領域でその部品をモデル化する必要があります。
実施する設計の種類に応じて、コンポーネントには 回路図用のシンボル、 回路シミュレーター用のシミュレーションモデル、 シグナルインテグリティ解析用のIBISモデル、 PCBレイアウト用のパターンまたはフットプリント、 および可視化、3Dクリアランスチェック、メカニカルCAD領域へのエクスポート用の3Dモデルを含めることができます。
コンポーネント管理
コンポーネントデータの効果的な管理は、 電子設計に不可欠です。設計で使用するコンポーネントの管理は、Altiumの設計ソフトウェアにおいて、常に 基本的な要素となってきました。長年にわたるソフトウェアの進化とともに、コンポーネント管理の手法も大きく発展してきました。回路図モデルとPCBモデルのシンプルな個別ライブラリから、データベースライブラリを経て、 Workspaceコンポーネントへと進化しています。Workspaceコンポーネントは、設計コンポーネントの情報をより広範な製品開発の場に提供するとともに、 設計プロセス全体を通じて卓越したコラボレーションを実現する、先進的で使いやすい機能を備えています。
| Workspaceライブラリ | コンポーネントは、接続されたWorkspaceに保存されます。これにより、設計チーム全体が、最新かつ標準化されたコンポーネントデータを単一の情報源から入手できます。パラメトリック検索とファセット検索の機能により、必要な部品を効率よくすばやく見つけて配置できます。これらのコンポーネントは、実際に製造される部品や、設計時にアクセス可能なサプライチェーンデータと密接に結び付いており、製品の実装・製造時における調達コストと所要時間を大幅に改善できます。 |
|
| データベースライブラリ | 設計コンポーネントを社内のデータベースと緊密に連携させたい場合は、データベースライブラリをご検討ください。各レコードが1つのコンポーネントに対応し、必要なモデルとコンポーネントのパラメトリックデータを参照します。配置時にモデルへのリンクとパラメーターがシンボルに追加され、Altium Designerのコンポーネントになります。 | |
| SVNデータベースライブラリ | SVNデータベースライブラリは、データベースライブラリのモデルを拡張したもので、ソースのシンボルとモデルがバージョン管理される点が異なります。ソースライブラリの作成、追加、保守は、Subversionベースのリポジトリ内で行われます。リポジトリおよび外部データベースへのリンクは、SVNデータベースライブラリファイル(*.SVNDbLib)内で定義します。 |
|
| データベースリンク | この方法では、データベースリンクファイル(*.DbLink)によって、回路図コンポーネントとデータベース内の対応するレコードとのリンクを定義します。レコードの照合にはキーフィールドによるリンクを使用し、単一のキーフィールド(部品番号など)、または複数のキーフィールド(Where句で定義)を指定できます。 |
|
| 統合ライブラリ | コンポーネントを事前にパッケージ化・検証し、1つのファイルにまとめたい場合は、ソースの回路図/PCB/シミュレーションモデルをコンパイルして、統合ライブラリ(*.IntLib)を生成します。 |
|
| 回路図ライブラリ | 回路図ライブラリ(*.SchLib)は、コンポーネントシンボルを格納するモデルライブラリとして使用できます。また、各シンボルにモデルへのリンクとパラメトリックデータを追加すると、コンポーネントライブラリになります。 |
|
| PCBライブラリ | PCBフットプリントモデルを保存するためのライブラリ(*.PcbLib)です。必要に応じて、各フットプリントに3Dモデルを追加できます。3Dモデルは、3Dボディオブジェクトから作成するか、STEPモデルを3Dボディオブジェクトにインポートして作成します。 |
Workspaceライブラリ
コンポーネントは、Workspaceに保存されます。Workspaceは、設計チーム全体がアクセスでき、すべての設計データを安全に一元管理できる場所です。Workspaceで管理されるコンポーネントの利用には、数多くの利点があります。主な利点は次のとおりです。
-
Single source of component data – チーム全体がWorkspaceにアクセスできるため、エンジニアは安全な単一の場所から最新かつ標準化されたコンポーネントを入手し、リアルタイムのサプライチェーンデータを取得できるほか、パラメトリック検索とファセット検索を使用して、必要なコンポーネントを的確に見つけることができます。
-
Design-time choice of physical components – 各コンポーネントについて、基板の実装時にそのコンポーネントとして使用できるメーカー部品を選択できます。
-
Real-time supply-chain information – Altium Parts Provider の集約部品データベースからフィードバックされる情報です(このデータベース自体も、 有効化されたサプライヤーと連携し、 部品情報を収集します)。これにより、選択した部品の現在の価格と在庫状況を、その部品を販売するすべてのベンダーについて設計者が把握できます(対象はWorkspaceのローカル部品カタログで定義されます)。この情報は、コンポーネントをWorkspaceに保存した後も含め、いつでもコンポーネントに追加できます。コンポーネントを直接編集する必要がないため、すでにそのコンポーネントを使用している設計に影響を与えることなく 追加でき、その後、 部品表の一部として使用できます。
-
Concurrent editing of the library – Workspaceライブラリは、実質的にはこのWorkspaceで管理されるコンポーネントアイテムの集合であるため、 複数のユーザーが、ほかのユーザーの作業完了を待つことなく、Workspaceライブラリのコンポーネントの編集や新規作成をそれぞれ独立して行えます。
-
Component Models Reuse – コンポーネントは、回路図シンボル、PCBフットプリント、ハーネス配線、シミュレーションモデルなど、すべてのパラメトリック情報と各設計領域のモデルを格納する「入れ物」と考えることができます。コンポーネントには各設計領域のモデルそのものではなく、同じくWorkspace内にある関連モデルアイテムへのリンクが含まれるため、1つのモデルを複数のコンポーネントで使用できます。モデルが変更されると、そのモデルを使用しているすべてのコンポーネントの更新が提案されるため、古いモデルを使用するコンポーネントが残るのを防げます。
-
Direct Component Editing – コンポーネントを編集する必要がある場合は、Workspace内から直接、編集用に開くことができます。コンポーネントエディターの一時的なインスタンスを使用して、参照先の各設計領域のモデルの変更も含め、コンポーネントのあらゆる要素を編集できます。 ファイルベースのドキュメントを扱う必要はありません。
-
Use of Component Templates – パラメーターとコンポーネントの分類体系に基づくテンプレートを適用できます。これにより、適切な命名、リビジョン、ライフサイクルの各体系を自動的に適用するとともに、新しいコンポーネントの種類ごとに、BOMの要件に準拠した正しいパラメーターセットが自動的に設定されます。
-
Component Lifecycle Validation – コンポーネントが「生産終了」「廃止」「使用中止」の状態にある場合、そのコンポーネントを使用した基板を製造する前に警告が表示されます。
-
Where-used Component Traceability – コンポーネントの使用先をすべて追跡できます。部品が廃止された場合は、その部品がどの設計に使用されているかを調べ、 更新が必要な設計を特定できます。シンボルやフットプリントに誤りがある場合は、そのシンボルやフットプリントを使用するすべてのコンポーネントを確認して、 修正できます。
-
Requests of new components – エンジニアは、 新しいコンポーネント(または不足しているコンポーネント)の作成を専任のライブラリ管理者に依頼できます。依頼した本人や社内のほかのエンジニアが、そのコンポーネントを設計で使用できるようになると、通知を受け取れます。
新しいWorkspaceライブラリコンポーネントの作成
基板に実装される、またはワイヤーハーネスの製造に使用される実際の部品は、回路図の作成時には回路図シンボルとして、基板設計時にはPCBフットプリントとして表現されます(オプションで、可視化、3Dクリアランスチェック、メカニカルCADへのエクスポート用の3Dモデルを含めることもできます)。設計コンポーネントには、回路シミュレーター用のシミュレーションモデルや、シグナルインテグリティ解析用のIBISモデルを含めることもできます。設計コンポーネントをより広範な製品開発プロセスで利用できるように、1つ以上の部品候補を追加できます。
設計プロジェクトで使用するコンポーネントは、社内のWorkspaceライブラリに作成して格納できます。コンポーネントの配置には、Altium Designerの高度なコンポーネント検索エンジンを使用するComponentsパネルを使用します。
新しいWorkspaceライブラリコンポーネントは、コンポーネントエディターで作成します。コンポーネントのすべてのデータ(ドメインモデル、パラメーター、部品候補など)を手動で定義するか、Manufacturer Part Searchパネルから取得したデータを使用できます。
新しいWorkspaceライブラリコンポーネントを作成するには:
-
コンポーネント作成コマンドを選択します。次の方法でアクセスできます。
-
メインメニューからFile » New » Componentコマンドを選択します。
-
メインメニューからFile » New » Libraryを選択し、開いたNew LibraryダイアログのWorkspace領域でCreate Library Content » Componentを選択します。
-
コンポーネントパネルで、コンポーネント一覧領域を右クリックし、コンテキストメニューからCreateコマンドを選択します。
-
-
開いたCreate new componentダイアログで、コンポーネントタイプを選択します。選択したコンポーネントタイプにコンポーネントテンプレートがリンクされている場合、そのデータを使用してコンポーネントが事前定義されます。
-
OKをクリックすると、単一コンポーネント編集モードのコンポーネントエディターが開きます。このモードでは、単一のコンポーネントを定義・編集するためのシンプルなインターフェースが提供されます。
-
コンポーネントエディターで詳細情報を追加し、コンポーネントを定義します。
- コンポーネントエディターのComponent領域で、コンポーネントのNameとDescriptionを定義します。これらの情報は、設計プロジェクトで必要なコンポーネントを使用する際に、検索するうえで不可欠です。
-
Advanced Settingsコントロールをクリックして、Workspaceに保存されるコンポーネントに使用するIdや、保存先Workspace内のFolderなど、その他のコンポーネント情報を定義または変更します。
-
コンポーネントエディターのParameters領域で、標準パラメーター、Webページ(メーカーのWebサイトなど)へのURLリンク、データシート(任意の形式)へのリンクなど、追加のコンポーネント情報を定義します。
-
コンポーネントエディターのPart Choices領域で、コンポーネントの部品候補を1つ以上指定します。これは、組み立てられた基板上でそのコンポーネントとして使用できる「許可された」メーカー部品です。
-
コンポーネントエディターのModels領域で、そのコンポーネントが使用する、保存済み(またはその場で作成した)のドメインモデルへのリンクを追加します。コンポーネントには、1つの回路図シンボルと複数のPCBフットプリントおよびシミュレーションモデル、または1つのハーネス配線モデルを含めることができます。コンポーネントには少なくとも1つのモデルが必要です。
-
定義したコンポーネントを検証し、Preferencesダイアログのデータ管理 – コンポーネントルールチェックページの設定に従って、要件を満たしていることを確認します。コンポーネントをローカルに保存(File » Save)してから、メインメニューでTools » Component Rule Checkコマンドを選択します。検出された違反は、Messagesパネルに一覧表示されます。
-
コンポーネントの定義が完了したら、メインメニューからFile » Save to Serverコマンドを選択して、コンポーネントをWorkspaceに保存します。Edit Revisionダイアログが表示され、必要に応じて名前と説明を変更し、リリースノートを追加できます。保存後、エディターは閉じます。
新しいコンポーネントは、コンポーネントパネルで検索して使用できるようになります。
注記
-
Workspace内の既存のコンポーネントに似た新しいコンポーネントを作成するには、そのコンポーネントのコピーを作成できます。Componentsパネルで目的のコンポーネントを探し、右クリックしてOperations » Make a copyコマンドを選択します。選択したコンポーネントのデータがあらかじめ設定された状態で、コンポーネントエディターが開きます。
-
部品は、 Manufacturer Part Search機能から提供されるデータを使用して定義できます。Nameフィールドに入力を開始し、一致するメーカー部品を選択するか、定義中の部品に部品候補を追加すると、 Use Component Dataダイアログ が開きます。このダイアログでは、現在作成/編集中の部品に適用するデータ(名前、説明、パラメーター、モデル、データシート)を選択できます。

部品データは、メーカー部品検索から取得できます。ここでは、Nameフィールドに部品名を入力し、ポップアップリストから一致する項目を選択して、この機能にアクセスする例を示しています。 -
Componentエディターは、複数の部品を定義/編集するためのインターフェースを備えた 部品一括編集モードでも動作します。 Componentエディターが Single Component Editing モードの場合、エディターのメインメニューから Tools » Switch to Batch Editor コマンドを選択すると、一括編集モードに切り替わります。
-
既存のファイルベースライブラリやデータベースライブラリ(SchLib、PcbLib、IntLib、DbLib、SVNDbLib)を Workspaceにすばやくインポートするには、 Library Importer を使用できます。Library Importerは、選択したライブラリを自動的に解析し、現在接続しているWorkspaceにインポートするワンクリックソリューションを提供します。
-
新しい部品は、 Projectsパネルで接続中のWorkspaceの項目を右クリックし、メニューから Create Component コマンドを選択して作成することもできます。
-
Workspace部品を編集するには、Componentsパネルで部品の項目を右クリックし、コンテキストメニューからEditコマンドを選択します。Componentエディターが Single Component Editing モードで開き、部品定義を編集できるようになります。必要な変更を加えた後、部品定義をWorkspace部品の次のリビジョンとして保存します。
-
同様に、Componentsパネルで複数の部品を選択し、コンテキストメニューからEditコマンドを選択できます。選択した部品が同じ部品テンプレートを参照している場合、単一のComponentエディターが 部品一括編集モードで開きます。それ以外の場合は、同じ部品テンプレートを共有する部品グループごとに、個別のComponentエディターが開きます。
-
編集用に開いたWorkspace部品は、ProjectsパネルのWorkspace Components項目の下に表示されます。
Workspace Component項目の右クリックコンテキストメニューから、グループ内の部品を開く、閉じる、ローカルに保存する、接続中のWorkspaceに保存する、または変更を破棄する(変更せずに閉じる)操作を実行できます
。Close Allコマンドを使用するときに、グループ内の複数の部品が変更されている場合は、編集用に開いたWorkspaceエンティティに対する操作に応じた選択肢を備えた保存確認ダイアログが表示されます(
)。
-
閲覧専用権限を持つユーザーがWorkspace部品を編集用に開こうとすると、Componentエディターが開き、部品の詳細を確認できますが、変更をWorkspaceに保存することはできません。この場合、Projectsパネル内の該当するWorkspace部品の項目には、Local Edits Onlyラベルが表示されます(
)。
-
編集した部品をWorkspaceライブラリに保存する際、部品の現在のライフサイクル状態を維持できます。 この設定は、再保存時に表示されるEdit RevisionダイアログのPreserve lifecycle state (not recommended)オプションで行います(画像を表示)。このオプションを有効にすると、新しい部品リビジョンには、前のリビジョンのライフサイクル状態が自動的に設定されます。 この機能は、Allow to skip lifecycle state change for new revisions操作権限が割り当てられているユーザーが利用できます(詳しくは、Workspaceのグローバル操作権限の設定を参照)。
データベースライブラリ
Altium Designerでは、Database Libraryを作成して使用することで、社内データベースから直接部品を配置できます。配置はComponentsパネルから行います。このパネルは、データベースライブラリをインストールすると、データベースを参照するブラウザーとして機能します。
配置後は、配置した部品と、それに対応するデータベース内のリンクされたレコードとの間で、設計パラメーター情報を同期できます。グラフィカルシンボル、モデル参照、パラメーターを含め、部品全体を更新できます。また、データベースのパラメーター情報を最終的な部品表(BOM)に含め、部品調達に利用することもできます。
データベースライブラリについてお読みください。
ファイルベースライブラリ
部品をローカルのファイルシステムに保持する必要がある場合は、ファイルベースライブラリに部品をまとめることができます。
Altium Designerのファイルベースライブラリは、モデルまたは部品を任意にまとめたものです。モデルや部品をどのようにライブラリに整理するかは自由です。デバイスのサプライヤー別にライブラリを構成することも、機能別に部品をまとめることもできます。たとえば、社内で使用するすべてのマイクロコントローラーを1つのライブラリにまとめることができます。
回路図部品シンボルは、回路図ライブラリ(*.SchLib)で作成します。これらのライブラリ内の部品は、個別のフットプリントライブラリ(*.PcbLib)やモデルファイルで定義されたフットプリントおよびその他のモデルを参照します。設計者は、これらの個別の部品ライブラリから部品を配置することも、シンボルライブラリ、フットプリントライブラリ、モデルファイルを統合ライブラリ(*.IntLib)にコンパイルすることもできます。
ファイルベースの部品ライブラリについてお読みください。
モデル
設計者の観点では、部品とは、あらゆる設計領域でその部品を表現するために必要な情報を、単一のエンティティにまとめたものです。この意味で、部品はコンテナーと考えることができます。
各部品は、リンクされたモデルと部品のパラメーターデータの集合です。各設計領域で必要となる詳細情報は、モデルに含まれています。
次の種類のモデルを使用できます。
| 回路図シンボル | シンボルは、回路図シート上で部品を表します。シンボルは標準の描画オブジェクトを使用して作成し、ピンによって電気的特性が付加されます。 |
| SPICEモデル | SPICEシミュレーターを使用して、接続された部品の動作をシミュレーションします。SPICEモデルは通常、デバイスのサプライヤーから入手します。 |
| シグナルインテグリティモデル | デバイスや回路のスイッチング速度が向上するにつれて、PCB上の配線も回路の一部として扱う必要が生じています。IBISモデルはピンの動作を記述し、Altium Designerのシグナルインテグリティシミュレーターによる配線の解析を可能にします。 |
| PCBフットプリント | 各部品には、PCB上で実装および接続する場所を定義する必要があります。フットプリントは、そのPCB上の領域を定義するモデルです。PCBフットプリントは標準オブジェクトの組み合わせで作成され、パッドによって接続が提供されます。 |
| 3Dモデル | 今日の電子製品は、小型で高密度に実装され、独特な形状をしており、筐体に収まるようにPCBが折り曲げられていることもあります。このような製品を設計するには、PCBを3Dでモデル化し、完成した基板の可視化、3Dクリアランスチェック、部品実装済み基板のメカニカルCAD環境への転送ができる必要があります。そのためには、各部品の3Dモデルが必要です。 |
Workspaceでのシンボル、フットプリントモデル、シミュレーションモデル、3Dモデルの作成と管理についてご覧ください。
Componentsパネル
Altium DesignerのComponentsパネルからは、Workspace、 データベース、ファイルベースのライブラリに含まれる部品など、利用可能なすべての部品に直接アクセスできます。
このパネルは、Workspaceと、開いている、またはインストールされているライブラリファイルから部品を取得します。選択した部品の詳細情報(パラメーター、モデル、部品候補、サプライヤーデータなど)の表示や部品の比較に加え、Workspaceの部品については、目的の部品パラメーターを指定できるフィルターベースのパラメトリック検索機能も提供します。状況に応じた動的フィルターを使用するこのパネルの検索機能により、接続先の社内Workspaceから必要な部品をすばやく正確に見つけることができます。
Componentsパネルについてご覧ください。
Manufacturer Part Searchパネル
Manufacturer Part Searchパネルを使用して、実際に製造されている部品を 検索することもできます。このパネルでは、Componentsパネルと同じ基本的な検索エンジン機能と表示形式を使用します。選択したメーカー部品を、接続先のWorkspaceで 新しい部品を作成するためのベースとして使用したり、そのパラメーターやデータシートを配置済みの部品に追加したりできます。
部品エントリー内の
アイコンは、その部品にモデル(回路図シンボル、PCBフットプリント、 シミュレーションモデル)が割り当てられていることを示します。このメーカー部品をベースに新しい部品を作成すると、そのモデルも取得されます。また、 この部品をローカルにダウンロードしたり、回路図に直接配置したりすることもできます。
Manufacturer Part Searchパネルについてご覧ください。








