パッド/ビアテンプレートとライブラリ
概略
- ライブラリを一から作成する方法や、既存のPCB上のパッドやビアから作成する方法を学びます。
- パッドおよびビアのテンプレートを追加、削除、編集する方法を確認します。
- 穴寸法、マスク、パッドおよびビアのスタック、サーマルリリーフの設定オプションを詳しく見ていきます。
パッドとビアは、トラックオブジェクトとともに、あらゆる回路基板設計の基本要素です。 PCB設計におけるパッドとビアの設計再利用性と管理機能を向上させるため、Altium Designerはパッドおよびビアのテンプレートライブラリをサポートしています。
パッドとビアのテンプレートをライブラリにまとめるという概念は、PCBフットプリントライブラリと似ていますが、より基本的なものです。パッド・ビアテンプレートライブラリには、実際のパッドやビアではなく、パッドやビアのインスタンスを配置する際に適用される、あらかじめ設定された定義が保存されます。保存済みのパッド・ビアテンプレートライブラリを読み込むと、任意のPCB設計やPCBフットプリントに、定義済みのパッドやビアのインスタンスを配置できます。
パッド・ビアテンプレートライブラリも、Altium Designerで作成できる設計ドキュメントの一種で、ファイル拡張子は*.PvLibです。パッド・ビアテンプレートライブラリはプロジェクトドキュメントとして追加でき、その場合、 そのプロジェクトではPCB Pad Via Templatesパネルを通じて、いつでもテンプレートを利用できます。テンプレートライブラリをパネルにインストールして、開いているすべてのプロジェクトで使用できるようにすることもできます。テンプレートを使用可能にする方法の詳細は、 パッド・ビアテンプレートの操作ページを参照してください。
パッドおよびビアのテンプレートは、PvLibファイルを開いて作成・編集します。PvLibに含まれるパッドおよびビアのテンプレートはPad Via Libraryパネルに一覧表示され、選択したパッドまたはビアのテンプレートが、以下のようにパッド/ビアテンプレートエディターに表示されます。
|
パッドとビアのテンプレートは、どちらもPvLibファイルを開いて編集します。エディターのオプションは、編集中のオブジェクトの種類に応じて変わります。ここではパッドテンプレートエディターを示しています。 パッドとビアのテンプレートは、どちらもPvLibファイルを開いて編集します。エディターのオプションは、編集中のオブジェクトの種類に応じて変わります。 ここではビアテンプレートエディターを示しています。 |
パッド・ビアテンプレートライブラリの作成
新しいパッド/ビアテンプレートライブラリは、次の方法で作成できます。
-
メインメニューからFile » New » Library コマンドを選択し、開いたNew LibraryダイアログのFile 領域でPad Via Libraryオプションを選択して、Createをクリックします。 新しいパッド・ビアテンプレートライブラリには、デフォルトで
PvLib1.PvLibという名前が付けられます。この段階では、ファイルはまだハードドライブに保存されておらず、 コンピューターのメモリ内にのみ存在します。未保存のため、初めて保存する際には Save Asダイアログが開き、PreferencesダイアログのSystem – Default Locationsページで定義されているDefault Locationへの保存が提案されます。 -
Projectsパネルでプロジェクトを右クリックし、コンテキストメニューからAdd New to Project » Pad Via Libraryを選択して、現在のプロジェクトに新しいパッド・ビアテンプレートライブラリを追加することもできます。ファイルは、プロジェクト構造の
Libraries/Pad Via Library Documentsフォルダーに表示されます。ファイルを保存する際のデフォルトの保存先は、プロジェクトフォルダーになります。 -
PCBパネルのPad & Via Templatesモードで、開いているPCBのパッドとビアからパッド・ビアテンプレートライブラリを作成できます。Windowsの標準的な選択操作で、ライブラリに保存するパッド/ビアテンプレートを選択し、Save as Libraryボタンをクリックします。新しいPvLibが編集可能な状態で開きますが、まだハードドライブには保存されていません。必要な名前を付けて、適切な場所にファイルを保存してください。パッド・ビアテンプレートライブラリをテンプレートエディターで初めて開いたとき、Pad Via Libraryパネルにパッドテンプレートが1つだけ(デフォルトのテンプレート)表示される場合があります。その場合は、ファイルを保存して閉じ、再度開いて、Pad Via Libraryパネルのテンプレート一覧を更新してください。
Pad Via Libraryパネル
Pad Via Libraryパネルから、アクティブなパッド・ビアライブラリに含まれるテンプレートにアクセスできます。パッド/ビアテンプレートエディターで使用できるPad Via Libraryパネルには、現在のパッド・ビアテンプレートライブラリに含まれるパッドおよびビアのテンプレートが一覧表示されます。この編集セッションで使用する単位は、パネル上部のDisplay Unitsドロップダウンメニューから選択します。
パネルへのアクセス
パッド/ビアテンプレートエディターで、設計スペース内のアクティブドキュメントとして*.PvLibドキュメントを開いた状態で、次の方法でパネルにアクセスできます。
- 設計スペースの右下にあるPanels ボタンをクリックし、Pad Via Libraryを選択します。
- メインメニューから View » Panels » Pad Via Libraryをクリックします。
パッドまたはビアテンプレートの作成
新しいパッドまたはビアテンプレートを作成するには、パネル内を右クリックし、コンテキストメニューからAdd Pad templateまたはAdd Via templateを選択します。ライブラリからテンプレートを削除するには、Deleteを使用します。

このパネルから、現在のパッド・ビアライブラリに含まれるテンプレートにアクセスできます。新しいテンプレートを追加するには、右クリックします。
パッド/ビアテンプレートエディター
Pad Template Editorは、パッドまたはビアテンプレートの基本的な設定オプションを構成するために使用します。このテンプレートは、PCBまたはPCBフットプリントドキュメント内のパッドやビアに適用できます。これらのオプションにはパッド/ビア構成の主要なプロパティが含まれます。一方、位置、向き、レイヤーなど、ドキュメント固有のプロパティは、パッドやビアを設計ドキュメントに配置するときに定義します。

テンプレートエディターでは、Pad Via Libraryパネルで現在選択されているパッドまたはビアテンプレートを設定します。
パッド/ビア設定オプションの大部分は、Altium Designerでおなじみの標準的なパッドおよびビアの設定(サイズ、穴、マスクなど)です。パッドテンプレートエディターとビアテンプレートエディターは、共通のインターフェース設計と多くのオプションを共有しています。以下ではテンプレートエディターの各領域について説明し、パッドまたはビアに固有のオプションにはその旨を記載します。
全般
-
Name – デフォルトでは、IPC-7251/7351 Padstack naming conventions(詳細はこちら)に従い、パッド/ビアの属性に基づいて名前が自動的に付けられます。必要に応じて手動で名前を指定でき、
ボタンをクリックするとその名前を削除できます。手動で名前を付けたテンプレートを基板設計で使用した後、そのテンプレートとテンプレートライブラリとのリンクを解除すると(プロパティが編集可能になると)、手動で付けた名前は自動生成された名前に置き換えられます。
- Description – 説明(任意)。
- Pad Type(パッドのみ) – 表面実装またはスルーホール。
穴情報
- Hole Size – 名前内ではh<Value>で表され、穴の直径を指定します。
- Tolerance – 名前内ではTolで表されます。必要に応じて穴のプラス側とマイナス側の公差を入力します。該当しない場合は、N/Aを入力します。
- Hole Type(パッドのみ)– 丸形、正方形、またはスロット。
- Length(パッドのみ)– 正方形の穴またはスロットの長さ。名前では、穴サイズの後に _<Value> を付加して示されます。
- Rotation(パッドのみ)– 正方形の穴またはスロットの回転角度。
- Plated(パッドのみ)– めっきあり、またはめっきなし(めっきなしは名前内の n で示されます)。
ペーストマスク(パッドのみ)
- Manual Expansion – チェックボックスをオンにすると、パッドをPCB設計に配置した際にデザインルールの値を上書きする拡張量を手動で指定できます。この値は、パッドテンプレート名内の p<Value> で示されます。
- Expansion – ペーストマスクの開口部を拡張(正の値)または縮小(負の値)する量。絶対値(mil/mm)またはパッド面積に対する割合で指定できます。絶対値を指定すると、フィールドの右側に割合が表示され、割合を指定すると絶対値が表示されます。フィールドの左側にある Use Paste チェックボックスをオフにすると、そのパッドテンプレートでペーストマスクを使用しなくなります。
ソルダーマスク
- Manual Expansion – 名前内の m<Value> で示されます。ここで、m<Value> はソルダーマスクの開口部全体のサイズです。上面と下面の拡張量がリンクされていない場合、名前の要素は m<Value>mx<Value> になります。
- Top/Bottom – 拡張量。Solder mask from the hole edge オプションが有効でない限り、パッド/ビアの端から測定されます。
-
– 上面と下面の値がリンクされています(同じ値)。クリックすると、上面と下面に異なる値を指定できます。
- Tented – 有効にすると、ソルダーマスクの開口部を閉じます(開口部のサイズがゼロに設定されます)。
- Solder mask from the hole edge – 有効にすると、パッド/ビアの端ではなく、穴の端を基準に拡張量を指定します。
ビアの種類とフィーチャー(ビアのみ)
- IPC 4761 Via Type – ドロップダウンで、IPC 4761規格に準拠したビアの種類 Design Guide for Protection of Printed Board Via Structures を選択します。
-
Grid – IPC 4761 Via Type ドロップダウンで
None以外のビアの種類を選択すると表示されます。基板の Side を選択し、選択したビアの種類で使用可能なフィーチャーの Material を入力します。
サイズと形状
- Offset From Hole Center (X/Y)(パッドのみ)– パッドの中心からのパッド穴のオフセット量。名前内の o<Xvalue>_<Yvalue> で示されます。
-
Mode – パッド/ビアスタックの種類。選択肢は
Simple、Top-Middle-Bottom、Full Stackです(パッドの場合、このオプションは Pad Type がスルーホールの場合にのみ使用できます)。そのモードで使用可能な各レイヤー上で、パッド/ビアに異なるサイズと形状を設定できます。下面レイヤーに異なるサイズ/形状を指定すると、名前の要素 x<Xvalue_Yvalue> が追加されます。中間レイヤーに異なるサイズ/形状を指定すると、名前の要素 z<Xvalue_Yvalue> が追加されます。 -
Attributes on Layer – パッド/ビアの標準属性。
-
Shape(パッドのみ)– c<SizeValue>(円形)、X/Y寸法が同じか異なるかに応じて s<SizeValue>(正方形)または r<xSizeValue_ySizeValue>(長方形)、s<SizeValue>c<Value>(八角形)、s<Sizevalue>r<Radius%Value> または r<xSizeValue_ySizeValue>r<Radius%Value>(角丸長方形)で示されます。
-
X & Y Size(パッドのみ)– X/Y平面上のパッドの寸法。
-
Corner Radius(パッドのみ)– パッドのコーナー半径の絶対値。値はパッドの短辺の半分以下である必要があります。値の後に
%記号を付けると、パッドの短辺の半分に対する割合として半径を指定できます。100%を指定すると、パッドの短辺が完全に丸くなります。このオプションは、パッドの Shape に Rounded Rectangle が選択されている場合にのみ使用できます。 -
Diameter(ビアのみ)– ビアの直径(ビアは円形のみ)。
-
-
Thermal Relief – このパッドと、同じネットに属する周囲のポリゴンとの間のサーマルリリーフ設定。From Rule チェックボックスをオフにすると、これらのローカル設定を編集して使用できます。
- From Rule – このオプションが有効な場合、ローカル設定は適用されません。オフにすると、ローカル設定を指定して使用できます。
- Connect Style – サーマルリリーフのスタイル。
- Air Gap – パッドの端から周囲のポリゴンまでの距離。
- Conductors – パッドと周囲のポリゴンを接続する導体の数。
- Width – パッドと周囲のポリゴンを接続する導体の幅。
- Angle – リリーフ導体の角度パターン。
- Layer – このパッドスタック/ビアスタック内のレイヤー。使用可能なレイヤーは、現在の Mode 設定によって異なります。Mode がフルスタックの場合、右クリックでレイヤーの追加、削除、またはリセットを実行できます。



