Altium Designer Documentation

Properties for Schematic Component

Modified by Phil Loughhead on Mar 14, 2018


The Properties for Schematic Component dialog.

SUMMARY

This dialog allows designers to edit the properties of a schematic component. 

ACCESS

The Component Properties dialog can be accessed prior to entering placement mode from the PCB Editor - Defaults page of the Preferences dialog (DXP» Preferences). This allows you to change the default properties for the object, which will be applied when placing subsequent Objects.

During placement, the dialog can be accessed by pressing the Tab key.

After placement, the dialog can be accessed in the following ways:

  • Double-clicking on the placed component
  • Right-clicking the component and selecting Properties from the context menu
  • Selecting the Edit » Change command, then click an existing object

This dialog is also used to configure the component settings in the Schematic Library Editor, including the default Designator, Comment, Description and Component Type. To learn more about creating a schematic component, refer to the page, Creating the Schematic Symbol.

OPTIONS/CONTROLS

Properties

  • Designator - This field shows the part designator, which identifies each part in your schematic project. If you do not enter a designator before you place a part, then its designator will be the pre-assigned default (i.e., U?). To enter a designator before you place a part, press the Tab key while the component is floating under the cursor. If you enter a designator at this time, then the designator will increment automatically (U1, U2 etc) as further parts are placed. If the component is a multi-part device it will automatically be assigned a part suffix, for example, U3A, U3B, and so on. The suffix will automatically increment if the designator is assigned before you place the part.
    • Visible - Enable this option to display the designator text field of the current schematic component.
    • Locked - Enable this option to prevent this component from being re-annotated.
       
  • Comment - Use the Comment field to enter a description of the component, such as 74LS04, or 10K. This field maps to the Comment field of the PCB component when the schematic and PCB are synchronized. As well as typing a string in the Comment field, you can also select one of the parameters from the Comment drop down list. This list includes all the Parameters currently available in the Parameters list of this dialog. When one of the =Value parameters is used as the Comment, this parameter can be used to map a component’s simulation Value into the Comment field of a schematic component and its linked PCB component.
    • Visible - Enable this option to display the comment field of the current schematic component.
       
  • First Part - Click on one of these buttons to assign the current part ID to an existing part of a multi-part device. The field indicates which part this particular instance is, and a multi-part device will be assigned a part suffix, for example U3A, U3B etc. Click << to the first part of a multi-part device.
  • Prev Part - Click on one of these buttons to assign the current part ID to an existing part of a multi-part device. The field indicates which part this particular instance is, and a multi-part device will be assigned a part suffix, for example U3A, U3B etc. Click < to the previous part of a multi-part device.
  • Next Part - Click on one of these buttons to assign the current part ID to an existing part of a multi-part device. The field indicates which part this particular instance is, and a multi-part device will be assigned a part suffix, for example U3A, U3B etc. Click > to the next part of a multi-part device.
  • Last Part - Click on one of these buttons to assign the current part ID to an existing part of a multi-part device. The field indicates which part this particular instance is, and a multi-part device will be assigned a part suffix, for example U3A, U3B etc. Click >> to the last part of a multi-part device.
    • Locked - Enable this option to lock the sub part of a component from being re-annotated with a different part ID.
       
  • Description This field shows the component description, which can be used to describe this component. Edit this field to update the description if required.
     
  • Unique Id - The Unique ID (UID) is an system generated value that uniquely identifies this current component. It is used for linking to an associated PCB component on a PCB document. Enter a new UID value or click the Reset button to generate a new UID if you wish to force the Schematic component to be linked to a different PCB component. You will need to run the Component Links dialog to update the linkage on the corresponding PCB document.
    • Reset - Assign a new Unique ID (UID) to the schematic component. You will need to run the Component Links dialog from the PCB's Project menus to update the linkage to a corresponding PCB component. You can also globally reset UIDs of components and sheet symbols at Tools » Reset Component Unique IDs from the menus.
       
  • Type Select one of the following component types from the drop-down list:
    • Standard - These components possess standard electrical properties, are always synchronized, and are the type most commonly used on a schematic sheet.
    • Mechanical - These components are not checked for electrical properties/errors or synchronized. This type is used to include additional mechanical objects, such as a mounting screw or a heatsink. They are included in the BOM.
    • Graphical - These components are not checked for electrical properties/errors or synchronized. This type is used for tasks such as adding a company logo to a document. They are not included in the BOM.
    • Tie Net (in BOM) - These components short two or more different nets and these components will appear in the BOM and are maintained during synchronization.
    • Tie Net - These components short two or more different nets and these components will NOT appear in the BOM and are maintained during synchronization.
    • Standard (No BOM) - These components possess standard electrical properties, and are synchronized BUT are not included in any BOM file produced from the file.
    • Jumper - These components are used to represent a wire link, typically used on a single-sided board. On the schematic, Jumper-type components do not need to be wired in, they are only included to ensure that the Jumpers get included in the BOM. On the PCB, set the jumper pads to share the same non-zero JumperID value; the software recognizes this state, adds a symbolic link between the jumper pads to represent the wire link, and factors the link into design rule checks.

Link to Library Component

  • Design Item ID  - The component placed from a schematic or integrated library will have its Design Item ID set to the symbol reference (library reference) and the integrated library or Schematic library name in the Library Name field and the Table Name field will be disabled.

    If the component is placed from a database library, then the design item ID will be the unique part number and represents a record within the table of a database and the parent database library filename in the Library Name field and specific database table in which the component resides in the Table Name field.

    The Design Item IDLibrary Name and Table Name fields within the Library Link section are also available in the SCH Inspector panel.

  • Choose - Click this button to invoke the Browse Libraries dialog to search through libraries (Schematic Libraries, Integrated Libraries or database libraries) and choose the appropriate component.
     
  • Library Name -   If the component is placed from a schematic or integrated library, then the Design Item ID will be set to the symbol reference (library reference) and thus the Library Name represents the name of the library.However if the component is placed from a database library then the design item ID will be the unique part number and represents a record within the table of a database and the parent database library filename in the Library Name field and specific database table in which the component resides in the Table Name field.Press the Validate button to ensure the library link of the component is valid.

    The Design Item IDLibrary Name and Table Name fields within the Library Link section are also available in the SCH Inspector panel.

  • Table Name - This field represents the table of physical components within a database library. All those physical components that have the same logical symbols come from the same table within the database library.
  • Validate Link - Press this button to verify that the correct library is being used as a reference for this design item / component. A dialog will appear displaying the path and the library for the first match of the design component in this library.

Graphical

  • Location X, Y - These fields show the current X and Y coordinates (in 0.1 inch units) of the top-left corner of the component relative to the bottom-left corner of the schematic sheet. Enter a number in these fields to change the position of the component.
  • Orientation  - Select an option from the drop-down list to set the orientation of the part on the schematic. The available rotations are: 0, 90, 180 or 270 degrees.
  • Locked - If this option is checked, the component is protected from being edited graphically. Lock a component whose position or size is critical. If you try to edit a design object that is locked, you will be informed that this object is locked and asked if you wish to proceed with the action.
    If this option is unchecked, the design object can be freely edited without confirmation.

    If the Protect Locked Objects option is enabled in the Schematic - Graphical Editing page of the Preferences dialog and the Locked option for this design object is enabled as well, then this object cannot be edited.

  • Mode  - The Schematic editor supports up to three "Modes," or drawing styles, for each part - Normal, DeMorgan and IEEE. Use this option to select an alternative mode. Each mode is defined in the Library Editor; however, only the Normal mode must be defined. If the drawing style does not change when you change this option, it means that only the normal mode has been created.
  • Locked Pins - Enable this option to prevent the pins of this schematic component from being edited. Only the component itself can be edited. If you wish to edit a pin, disable this option.
  • Mirrored - Enable this option and the schematic component will be mirrored along the X axis.
  • Show All Pins On Sheet (Even if Hidden) - Enable this option to display all pins including the hidden pins of a component on the current schematic document. Note, power pins are often defined as Hidden. Once a pin is defined as hidden, you must enable this Show All Pins On Sheet option to be able to see them or disable the Hide option in the Pin Properties dialog to show this particular pin.
  • Local Colors - Enable the local color option and the schematic component's fill, line, and pin colors are overridden with the colors from the FillLines, and Pins color boxes respectively. Disable this option to use the predefined colors from the library.

Parameters

This section lists out all parameters of the schematic component. The designer can add, remove, edit, or add rule parameters with the  Add, Remove, Edit, and Add as Rule buttons.

Models

This table lists the models (including simulation, PCB, EDIF Macro and Signal Integrity) that link to this schematic component. Select a model and click Edit to configure symbol-to-model links. Multiple models can be linked, the first enabled model of each type is used. The model location is typically not defined at the component level and the model is searched in the currently open and installed libraries.

  • Add - Click this button to add a new model (including simulation, PCB and Signal Integrity) that links to this schematic component. Multiple models can be linked, the first enabled model of each type is used. The model location is typically not defined at the component level, the model is searched for in the currently Installed Libraries, then down the project search path (Project » Project Options).
  • Remove - Click this button to delete a selected model (including simulation, PCB and Signal Integrity) from the table. This model's link to the schematic component is also removed.
  • Edit - Click this button to edit the selected model from the table to configure the symbol-to-model links. This model is linked to the current schematic component and the model location is typically not defined at the component level, the model is searched for in the currently Installed Libraries, then down the project search path (Project » Project Options).
  • Edit Pins - Click this button to directly edit the properties of pins of the current schematic component.
  • Configure - This button becomes available when a configurable component (such as a touch sensor component) is being edited. Click this button to open the configuration dialog for that component. Controls in the configuration dialog can vary between configurable components.
Parameter names cannot contain spaces unless they are a special string. If a string starts with ".", the entire string is treated as a 'special' string. To include more than one string in a 'special' string, use apostrophe ( ' ) to enclose each string. Example:  '.PcbDoc' '.PcbName'. You can now also use spaces or special characters inside 'special' strings. Example: '.PcbDoc #1'
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

アルティウムでは、学生の方や教育機関を対象とした特別価格ライセンスを提供しています。アカデミックライセンスの詳細については、こちらをクリック してください。.

また、下記のフォームに入力して無償評価版をリクエストしていただくことも可能です。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。