部品とそのライブラリの作成と管理
電子設計は、相互に接続されたコンポーネントの集合です。製品開発の醍醐味は、技術的な課題を解決する優れた方法を考案し、コンポーネントを接続して独自の設計を作り上げることにあります。
しかし、作業の大部分を占め、多くの設計者にとってより手間に感じられるのが、コンポーネントの作成です。華やかな作業ではないかもしれませんが、コンポーネントは企業にとって貴重な資産となるため、実際の部品を正確に表現していることが不可欠です。
購入して基板にはんだ付けしたり、ワイヤーハーネスに使用したりする部品は実物の部品ですが、設計で使用するには、それぞれの電子設計領域でその部品をモデル化する必要があります。
実施する設計の種類に応じて、コンポーネントには、 回路図用のシンボル、 回路シミュレーター用のシミュレーションモデル、 シグナルインテグリティ解析用のIBISモデル、 PCBレイアウト用のパターンまたはフットプリント、 さらに可視化、3Dクリアランスチェック、機械CAD領域へのエクスポート用の3Dモデルを含めることができます。
コンポーネント管理
コンポーネントデータの効果的な管理は、 電子設計に不可欠です。設計で使用するコンポーネントの管理は、Altiumの設計ソフトウェアにおいて、常に 基本的な要素の一つでした。長年にわたるソフトウェアの進化とともに、コンポーネント管理手法も大きく発展してきました。回路図モデルとPCBモデルを個別に格納するシンプルなライブラリから、データベースライブラリを経て、 Workspaceコンポーネント へと進化しています。Workspaceコンポーネントは、設計コンポーネントの情報をより広い製品開発の領域で利用できるようにするとともに、設計プロセス全体を通じて優れたコラボレーションを実現する、先進的で使いやすい機能を提供します。
| Workspaceライブラリ | 接続されたWorkspaceに保存されるコンポーネントです。設計チーム全体に、最新かつ標準化されたコンポーネントデータの一元的な情報源を提供します。パラメトリック検索とファセット検索により、必要な部品を効率よく素早く見つけて配置できます。これらのコンポーネントは、実際に製造される部品や、設計時にアクセスできるサプライチェーンデータと密接に結び付いているため、製品の製造時における調達コストと調達時間を大幅に改善できます。 |
|
| データベースライブラリ | 設計コンポーネントを社内データベースと密接に連携させたい場合は、データベースライブラリをご検討ください。各レコードが一つのコンポーネントに相当し、必要なモデルとコンポーネントのパラメトリックデータを参照します。配置時にモデルへのリンクとパラメーターがシンボルに追加され、Altium Designerのコンポーネントになります。 | |
| SVNデータベースライブラリ | SVNデータベースライブラリは、データベースライブラリモデルを拡張したもので、ソースシンボルとモデルがバージョン管理される点が異なります。ソースライブラリの作成、追加、保守は、Subversionベースのリポジトリ内で行われます。リポジトリおよび外部データベースへのリンクは、SVNデータベースライブラリファイル(*.SVNDbLib)内で定義されます。 |
|
| データベースリンク | この方法では、データベースリンクファイル(*.DbLink)によって、回路図コンポーネントとデータベース内の対応するレコードとのリンクを定義します。レコードの照合はキーフィールドのリンクによって行われます。単一のキーフィールド(部品番号など)を使用することも、Where句を定義して複数のキーフィールドを使用することもできます。 |
|
| 統合ライブラリ | コンポーネントを事前にパッケージ化し、検証したうえで一つのファイルにまとめたい場合は、ソースの回路図モデル、PCBモデル、シミュレーションモデルをコンパイルして、統合ライブラリ(*.IntLib)を生成します。 |
|
| 回路図ライブラリ | 回路図ライブラリ(*.SchLib)は、コンポーネントシンボルを格納するモデルライブラリとして使用できます。また、各シンボルにモデルへのリンクとパラメトリックデータを追加すると、コンポーネントライブラリになります。 |
|
| PCBライブラリ | PCBフットプリントモデルを格納するライブラリ(*.PcbLib)です。必要に応じて、各フットプリントに3Dモデルを追加できます。3Dモデルは、3Dボディオブジェクトから作成するか、STEPモデルを3Dボディオブジェクトにインポートして作成します。 |
Workspaceライブラリ
コンポーネントは、Workspaceに保存されます。Workspaceは、設計データを一元管理する安全な場所であり、設計チーム全体からアクセスできます。Workspaceでホストされるコンポーネントを使用することには、多くの利点があります。その一部を以下に示します。
-
Single source of component data – チーム全体がアクセスできるWorkspaceを使用することで、エンジニアは一つの安全な場所から最新かつ標準化されたコンポーネントを入手し、リアルタイムのサプライチェーンデータを取得できます。また、パラメトリック検索とファセット検索を使用して、必要なコンポーネントを的確に見つけられます。
-
Design-time choice of physical components – 各コンポーネントについて、基板の組み立て時にそのコンポーネントとして使用できるメーカー部品を選択できます。
-
Real-time supply-chain information – Altium Parts Provider の集約部品データベースから情報がフィードバックされます。このデータベース自体も、有効化されたサプライヤーと連携し、部品情報を収集します。これにより、選択した部品の現在の価格と入手可能性、およびそれらの部品を販売するすべてのベンダーの情報(Workspaceのローカル部品カタログで定義されているもの)を設計者が把握できます。この情報は、コンポーネントをWorkspaceに保存した後も含め、いつでもコンポーネントに追加できます。コンポーネントを直接編集する必要がないため、すでにそのコンポーネントを使用している設計に影響を与えることなく、 部品表の一部として利用できます。
-
Concurrent editing of the library – Workspaceライブラリは、基本的にそのWorkspaceでホストされるコンポーネントアイテムの集合です。そのため、 複数のユーザーが、他のユーザーの作業完了を待つことなく、それぞれ独立してWorkspaceライブラリのコンポーネントを編集したり、新しく作成したりできます。
-
Component Models Reuse – コンポーネントは、回路図シンボル、PCBフットプリント、ハーネス配線モデル、シミュレーションモデルを含む、すべてのパラメトリック情報と領域別モデルを格納する「入れ物」と考えることができます。コンポーネントには領域別モデルそのものではなく、同じくWorkspace内にある関連モデルアイテムへのリンクが含まれるため、一つの領域別モデルを複数のコンポーネントで使用できます。モデルが変更されると、そのモデルを使用しているすべてのコンポーネントの更新が推奨されるため、古いモデルを使用するコンポーネントが残るのを防げます。
-
Direct Component Editing – コンポーネントを編集する必要がある場合は、Workspace内から直接開いて編集できます。コンポーネントエディターの一時的なインスタンスを使用して、参照先の領域別モデルの変更を含む、コンポーネントのあらゆる項目を編集できます。 ファイルベースのドキュメントを扱う必要はありません。
-
Use of Component Templates – パラメーターとコンポーネント分類に基づくテンプレートを適用することで、新しいコンポーネントタイプには、BOMの要件に適合した正しいパラメーターセットが自動的に設定されます。 さらに、適切な命名、リビジョン、ライフサイクルの各スキームの適用も自動化できます。
-
Component Lifecycle Validation – コンポーネントが「生産終了」「廃止」「使用中止」の状態にある場合、そのコンポーネントを使用した基板を製造する前に警告が表示されます。
-
Where-used Component Traceability – コンポーネントの使用先をすべて追跡できます。部品が廃止された場合は、どの設計で使用されていたかを調べ、 更新が必要な設計を特定できます。シンボルやフットプリントに誤りがある場合は、それらを使用しているすべてのコンポーネントを確認し、 修正できます。
-
Requests of new components – エンジニアは、 新しいコンポーネントや不足しているコンポーネントの作成を専任のライブラリ管理者に依頼できます。そのコンポーネントが依頼者や社内の他のエンジニアの設計で使用可能になると、通知を受け取れます。
新しいWorkspaceライブラリコンポーネントの作成
基板に実装される、またはワイヤーハーネスの製造に使用される実際の部品は、回路図設計では回路図シンボルとして、基板設計ではPCBフットプリントとして表現されます。必要に応じて、可視化、3Dクリアランスチェック、およびメカニカルCADへのエクスポート用の3Dモデルも含めることができます。設計コンポーネントには、回路シミュレーター用のシミュレーションモデルや、シグナルインテグリティ解析用のIBISモデルも含めることができます。製品開発のより幅広い領域で設計コンポーネントを表現できるように、1つ以上の部品候補を追加することもできます。
設計プロジェクト用のコンポーネントは、作成して自社のWorkspaceライブラリに保存できます。コンポーネントの配置には、Altium Designerの高度なコンポーネント検索エンジンを使用するComponentsパネルを使用します。
新しいWorkspaceライブラリコンポーネントは、コンポーネントエディターを使用して作成します。ここでは、すべてのコンポーネントデータ(ドメインモデル、パラメーター、部品候補など)を手動で定義するか、Manufacturer Part Searchパネルから取得したデータを使用できます。
新しいWorkspaceライブラリコンポーネントを作成するには、次の手順に従います。
-
コンポーネント作成コマンドを選択します。次のいずれかの方法でアクセスできます。
-
メインメニューからFile » New » Componentコマンドを選択します。
-
メインメニューからFile » New » Libraryを選択し、開いたNew Libraryダイアログで、Workspace領域からCreate Library Content » Componentを選択します。
-
コンポーネントパネルで、コンポーネント一覧の領域を右クリックし、コンテキストメニューからCreateコマンドを選択します。
-
-
開いたCreate new componentダイアログで、コンポーネントタイプを選択します。選択したコンポーネントタイプにコンポーネントテンプレートがリンクされている場合、そのテンプレートのデータを使用してコンポーネントが事前定義されます。
-
OKをクリックすると、単一コンポーネント編集モードのコンポーネントエディターが開きます。このモードでは、単一のコンポーネントを定義・編集するための効率的なインターフェースが提供されます。
-
コンポーネントエディターで詳細情報を追加し、コンポーネントを定義します。
- コンポーネントエディターのComponent領域で、コンポーネントのNameとDescriptionを定義します。これらの情報は、設計プロジェクトで必要なコンポーネントを使用する際に、検索するための重要な情報となります。
-
Advanced Settingsコントロールをクリックし、Workspaceに保存されるコンポーネントに使用するIdや、保存先Workspace内のFolderなど、その他のコンポーネント情報を定義または変更します。
-
コンポーネントエディターのParameters領域で、標準パラメーター、Webページ(メーカーのWebサイトなど)へのURLリンク、およびデータシート(任意の形式)へのリンクなど、コンポーネントの詳細情報を定義します。
-
コンポーネントエディターのPart Choices領域で、コンポーネントの部品候補を1つ以上指定します。これは、組み立て済み基板上でそのコンポーネントを実装するために使用できる「許可された」メーカー部品です。
-
コンポーネントエディターのModels領域で、コンポーネントが使用する、保存済み(またはその場で作成した)ドメインモデルへのリンクを追加します。コンポーネントには、1つの回路図シンボルと複数のPCBフットプリントおよびシミュレーションモデル、または1つのハーネス配線モデルを含めることができます。コンポーネントには、少なくとも1つのモデルが必要です。
-
定義したコンポーネントを検証し、Preferencesダイアログのデータ管理 – コンポーネントルールチェックページの設定に従って、要件を満たしていることを確認します。コンポーネントをローカルに保存(File » Save)してから、メインメニューでTools » Component Rule Checkコマンドを選択します。検出された違反は、Messagesパネルに一覧表示されます。
-
コンポーネントの定義が完了したら、メインメニューからFile » Save to Serverコマンドを選択し、コンポーネントをWorkspaceに保存します。Edit Revisionダイアログが表示され、名前と説明を変更したり、必要に応じてリリースノートを追加したりできます。保存後、エディターは閉じます。
新しいコンポーネントは、コンポーネントパネルで参照して使用できるようになります。
注記
-
Workspace内の既存のコンポーネントに似た新しいコンポーネントを作成するには、そのコンポーネントのコピーを作成できます。Componentsパネルで目的のコンポーネントを探し、右クリックしてOperations » Make a copyコマンドを選択します。選択したコンポーネントのデータが事前設定された状態で、コンポーネントエディターが開きます。
-
コンポーネントは、Manufacturer Part Search機能から提供されるデータを使用して定義できます。Nameフィールドに入力を開始し、一致するメーカー部品を選択するか、定義中のコンポーネントに部品候補を追加すると、 Use Component Dataダイアログ が開きます。このダイアログでは、現在作成または編集中のコンポーネントに適用するデータ(名前、説明、パラメーター、モデル、データシート)を選択できます。

コンポーネントデータは、メーカー部品検索から取得できます。ここでは、Nameフィールドにコンポーネント名を入力し、ポップアップリストから一致する項目を選択して、この機能にアクセスする例を示しています。 -
コンポーネントエディターは、複数のコンポーネントを定義・編集するためのインターフェースを備えた コンポーネント一括編集モードでも使用できます。コンポーネントエディターが Single Component Editing モードのときは、エディターのメインメニューから Tools » Switch to Batch Editor コマンドを選択すると、一括編集モードに切り替えられます。
-
既存のファイルベースライブラリやデータベースライブラリ(SchLib、PcbLib、IntLib、DbLib、SVNDbLib)をWorkspaceにすばやくインポートするには、 Library Importer を使用できます。Library Importerは、選択したライブラリを自動的に解析し、現在接続しているWorkspaceにインポートする、ワンクリックのソリューションを提供します。
-
新しいコンポーネントは、 Projectsパネルで接続中のWorkspaceの項目を右クリックし、メニューから Create Component コマンドを選択することでも作成できます。
-
Workspaceコンポーネントを編集するには、Componentsパネルでコンポーネントの項目を右クリックし、コンテキストメニューからEditコマンドを選択します。コンポーネントエディターが Single Component Editing モードで開き、コンポーネント定義を編集できるようになります。必要な変更を加えてから、コンポーネント定義をWorkspaceコンポーネントの次のリビジョンとして保存します。
-
同様に、Componentsパネルで複数のコンポーネントを選択し、コンテキストメニューからEditコマンドを選択できます。選択したコンポーネントが同じコンポーネントテンプレートを参照している場合、コンポーネントエディターのインスタンスが1つだけ コンポーネント一括編集モードで開きます。それ以外の場合は、同じコンポーネントテンプレートを共有するコンポーネントのグループごとに、個別のコンポーネントエディターのインスタンスが開きます。
-
編集用に開いたWorkspaceコンポーネントは、ProjectsパネルのWorkspace Components項目の下に表示されます。
Workspace Component項目の右クリックコンテキストメニューから、グループ内のコンポーネントを開く、閉じる、ローカルに保存する、接続中のWorkspaceに保存する、または変更を破棄する(変更せずに閉じる)操作を実行できます
。Close Allコマンドを使用した際、グループ内の複数のコンポーネントが変更されている場合は、保存を確認するダイアログが表示されます。このダイアログには、編集用に開いたWorkspaceエンティティの操作に応じた選択肢が用意されています(
)。
-
閲覧のみの権限を持つユーザーがWorkspaceコンポーネントを編集用に開こうとすると、コンポーネントエディターが開き、コンポーネントの詳細を確認できますが、変更内容をWorkspaceに保存することはできません。この場合、Projectsパネル内の該当するWorkspaceコンポーネントの項目には、Local Edits Onlyラベルが表示されます(
)。
-
編集したコンポーネントをWorkspaceライブラリに保存する際、コンポーネントの現在のライフサイクル状態を保持できます。再保存時に表示されるEdit RevisionダイアログのPreserve lifecycle state (not recommended)オプションで設定できます(画像を表示)。このオプションを有効にすると、新しいコンポーネントリビジョンのライフサイクル状態は、前のリビジョンと同じ状態に自動的に設定されます。この機能は、Allow to skip lifecycle state change for new revisions操作権限が割り当てられているユーザーが利用できます(詳細はWorkspaceのグローバル操作権限の設定を参照)。
データベースライブラリ
Altium Designerでは、Database Libraryを作成して使用することで、企業のデータベースからコンポーネントを直接配置できます。配置はComponentsパネルから行います。このパネルは、データベースライブラリをインストールすると、データベースを閲覧するためのブラウザーとして機能します。
配置後は、配置したコンポーネントと、データベース内の対応するリンク済みレコードとの間で、設計パラメーター情報を同期できます。グラフィカルシンボル、モデル参照、パラメーターを含む、コンポーネント全体の更新も可能です。また、データベースのパラメーター情報を最終的な部品表(BOM)に含めて、部品調達に利用することもできます。
データベースライブラリについて参照してください。
ファイルベースライブラリ
コンポーネントをローカルのファイルシステムに保存しておく必要がある場合は、ファイルベースライブラリにまとめて管理できます。
Altium Designerのファイルベースライブラリは、モデルまたはコンポーネントを任意にまとめたものです。モデルやコンポーネントをどのようにライブラリに整理するかは自由です。デバイスのサプライヤー別にライブラリを構成することも、機能別にコンポーネントをまとめることもできます。たとえば、社内で使用するすべてのマイクロコントローラーを1つのライブラリにまとめられます。
回路図コンポーネントのシンボルは、回路図ライブラリ(*.SchLib)で作成します。これらのライブラリ内のコンポーネントは、別のフットプリントライブラリ(*.PcbLib)やモデルファイルで定義されたフットプリントおよびその他のモデルを参照します。設計者は、これらの個別のコンポーネントライブラリからコンポーネントを配置することも、シンボルライブラリ、フットプリントライブラリ、モデルファイルを統合ライブラリ(*.IntLib)にコンパイルすることもできます。
ファイルベースのコンポーネントライブラリについて参照してください。
モデル
設計者の観点では、コンポーネントとは、すべての設計領域にわたってそのコンポーネントを表現するために必要な情報を、1つのエンティティにまとめたものです。この意味で、コンポーネントはコンテナーと考えることができます。
各コンポーネントは、リンクされたモデルとコンポーネントのパラメーターデータの集合です。各設計領域で必要となる詳細情報は、モデルに含まれています。
次の種類のモデルを使用できます。
| 回路図シンボル | シンボルは、回路図シート上でコンポーネントを表します。シンボルは標準の描画オブジェクトを使用して作成し、ピンによって電気的特性を付加します。 |
| SPICEモデル | SPICEシミュレーターを使用して、接続されたコンポーネントの動作をシミュレーションします。SPICEモデルは通常、デバイスのサプライヤーから入手します。 |
| シグナルインテグリティモデル | デバイスや回路のスイッチング速度が向上するにつれ、PCBの配線も回路の一部として機能するようになっています。IBISモデルはピンの動作を記述し、Altium Designerのシグナルインテグリティシミュレーターによる配線の解析を可能にします。 |
| PCBフットプリント | 各コンポーネントには、PCB上で実装および接続する場所を定義する必要があります。フットプリントは、そのPCB上の領域を定義するモデルです。PCBフットプリントは標準オブジェクトの組み合わせで作成し、パッドによって電気的な接続を提供します。 |
| 3Dモデル | 今日の電子製品は、小型で部品が高密度に配置され、独特な形状を持ち、筐体に収めるためにPCBを折り曲げていることもあります。このような製品を設計するには、PCBを3Dでモデル化できる必要があります。これにより、完成した基板の可視化、3Dクリアランスチェック、部品実装済み基板の機械系CAD環境への転送が可能になります。そのためには、各部品の3Dモデルが必要です。 |
Workspaceでのシンボル、フットプリントモデル、シミュレーションモデル、3Dモデルの作成と管理についてご覧ください。
Componentsパネル
Componentsパネルでは、Altium Designerで利用可能なすべての部品に直接アクセスできます。これには、Workspace、 データベース、およびファイルベースのライブラリの部品が含まれます。
このパネルは、Workspaceと、開いている、またはインストールされているライブラリファイルから部品を取得します。選択した部品の詳細情報(パラメーター、モデル、部品候補、サプライヤーデータなど)の表示や部品の比較に加え、Workspaceの部品については、目的の部品パラメーターを指定できるフィルターベースのパラメトリック検索機能を提供します。状況に応じて動的に変化するフィルターを使用するこの検索機能により、接続された自社のWorkspaceから、必要な部品をすばやく正確に見つけることができます。
Componentsパネルについてご覧ください。
Manufacturer Part Searchパネル
Manufacturer Part Searchパネルを使用して、 実際に製造されている部品を検索することもできます。このパネルは、Componentsパネルと同じ基本的な検索エンジン機能と表示形式を使用します。選択した メーカー部品 を基に、 接続されたWorkspaceで新しい部品を作成したり、そのパラメーターやデータシートを配置済みの部品に追加したりできます。
部品エントリーの
アイコンは、その部品にモデル(回路図シンボル、PCBフットプリント、 シミュレーションモデル)が割り当てられていることを示します。このメーカー部品を基に新しい部品を作成すると、そのモデルも取得されます。また、 この部品をローカルにダウンロードしたり、回路図に直接配置したりすることもできます。
Manufacturer Part Searchパネルについてご覧ください。








