Altium Designer Documentation

Testpoint Setup

Modified by Rob Evans on Oct 31, 2018

   The two varations of the Testpoint Setup dialog

Summary

The Assembly/Fabrication Testpoint Setup dialog is used to configure testpoint reports. The banner of this dialog will change (either Assembly or Fabrication) depending on whether it was accessed to configure options for an Assembly or a Fabrication Testpoint report.

Testpoints are assigned manually or can be detected automatically by running the Testpoint Manager

Access

Testpoint output can be generated in one of two ways:

  • By using an Assembly or Fabrication Test Point Report output generator in an OutputJob Configuration file (*.OutJob). Output is generated when the configured output generator is run.
  • Directly from within the active PCB document using File » Fabrication Outputs » Test Point Report or File » Assembly Outputs » Test Point Report. Output will be generated immediately upon clicking OK in the dialog.
The settings defined in the Testpoint Setup dialog when generating output directly from the PCB are distinct and separate to those defined for the same output type in an Output Job Configuration file. In the former, the settings are stored in the project file; for the latter, they are stored in the Output Job Configuration file.

Options/Controls

Report Formats

  • Text - check for standard text format in the report.
  • CSV - check for standard comma separated value format, which can be imported into a spreadsheet application, such as Excel, for further processing.
  • IPC-D-356A - check for an IPC netlist file which carries blind and buried via information as well as differentiating between through-hole vias and free pads. When imported into a CAM document along with image and drill data, it facilitates the recovery of original net names used in the PCB design, making the PCB easier to understand and manage within the CAM Editor.

Test Point Layers 

These selections allow you to specify a scope for the report:

  • Top layer - check to include valid testpoints assigned on the top of the board.
  • Bottom layer - check to include valid testpoints assigned on the bottom of the board.

Units

  • Imperial - check to output coordinates in inches.
  • Metric - check to output coordinates in millimeters.

Coordinate Positions

  • Reference to absolute origin - select to use the absolute origin as the reference point for testpoint coordinates.
  • Reference to relative origin - select to use the relative origin as the reference point for testpoint coordinates.

IPC-D-356A Options 

This region of the dialog becomes available only when the IPC format option is enabled.
  • Adjacency Information - check to include a list of nets that could possibly be shorted, then enter the adjacency criteria in the text box.
  • Board Outline - check to permit the description of outlines and other segment type data that are not connected to a specific net.  Use the drop down to select the desired information.
  • Conductor Traces - Refer to IPC-D-356A spec for more detail.

Generated Files

All generated testpoint files are named first by type (Fabrication or Assembly), then by filename. For example: Fabrication Testpoint Report for BoardFileName. The following file extensions are used, depending on which of the Report Formats is enabled: .txt, .CSV, .IPC (note that this is an ASCII file).

Location of Generated Files

The output path for generated files depends on how the output was generated:

  • From an OutputJob file - the generated files are stored in a folder within the project folder. The naming and folder structure is defined in the Output Container that the Testpoint output is targeting.
  • Directly from the PCB - the output path is specified in the Project Options - Options dialog. By default, the output path is set to a sub-folder under the folder that contains the Project file and has the name: Project Outputs for ProjectName. The output path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options tab, then the Testpoint files will be written to a further sub-folder named Testpoint Output.

Automatically Opening the Generated Output

When generating Testpoint output, you can specify that the output be opened automatically in a new CAM document. The way in which this is accomplished depends on how you are generating the output:

  • From an OutputJob file - enable the IPC-D-356A Output auto-load option in the Output Job Options dialog (Tools » Output Job Options from the OutputJob Editor).
  • Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Project Options dialog (Project » Project Options).
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。