패드 및 비아 작업하기
개요
- Pad와 비아의 구조, 용도, PCB 설계에 사용되는 주요 비아 유형을 비롯해 둘 사이의 실질적인 차이를 알아봅니다.
- Altium Designer 워크플로에서 Pad와 비아를 배치, 이동, 변환하고 할당하는 방법을 살펴봅니다.
- 템플릿 사용과 Properties 패널의 주요 편집 옵션을 포함해 Pad 및 비아 속성을 관리하는 방법을 전반적으로 알아봅니다.
Pad 및 비아 개요
Pad는 컴포넌트 핀의 기계적 고정과 전기적 연결에 사용됩니다
Pad는 기본 설계 객체입니다. Pad는 컴포넌트를 보드에 고정하고 컴포넌트 핀과 보드의 라우팅을 연결하는 접점을 만드는 데 사용됩니다. Pad는 표면 실장 소자용 Pad처럼 싱글 레이어에 존재할 수도 있고, Z 평면(수직)에 배럴 형태의 몸체가 있고 각 (수평) 구리 레이어에 평평한 영역이 있는 3차원 스루홀 Pad일 수도 있습니다. Pad의 배럴 형태 몸체는 제조 과정에서 보드에 구멍을 뚫고 관통 도금을 수행할 때 형성됩니다. X 및 Y 평면에서 Pad는 원형, 직사각형, 팔각형, 둥근 직사각형, 모서리가 모따기된 직사각형 또는 Custom 형상일 수 있습니다. Pad는 설계에서 개별 프리 Pad로 사용할 수 있지만, 일반적으로는 PCB 라이브러리 Editor에서 다른 기본 객체와 함께 컴포넌트 풋프린트를 구성하는 데 사용됩니다.

상단 레이어(빨간색)에서 하단 레이어(파란색)까지 이어져 연결되며, 내부 전원 플레인 하나(녹색)에도 연결되는 비아입니다.
비아는 기본 설계 객체입니다. 비아는 PCB의 둘 이상의 전기적 레이어 사이에 수직 전기 연결을 형성하는 데 사용됩니다. 비아는 3차원 객체이며, Z 평면(수직)에 배럴 형태의 몸체가 있고 각 (수평) 구리 레이어에 평평한 링이 있습니다. 비아의 배럴 형태 몸체는 제조 과정에서 보드에 구멍을 뚫고 관통 도금을 수행할 때 형성됩니다. 비아는 원형 Pad와 마찬가지로 X 및 Y 평면에서 원형입니다. 비아와 Pad의 주요 차이점은 비아가 보드의 모든 레이어(상단부터 하단까지)를 관통할 수 있을 뿐 아니라, 표면 레이어에서 내부 레이어까지 또는 두 내부 레이어 사이에 걸쳐 형성될 수도 있다는 점입니다.
Pad 및 비아 직접 배치
Pad와 비아는 PCB Editor와 PCB 풋프린트 Editor 모두에서 배치할 수 있습니다. 비아는 일반적으로 인터랙티브 라우팅 또는 자동 라우팅 과정에서 자동으로 배치되지만, 필요한 경우 수동으로 배치할 수도 있습니다. 수동으로 배치한 비아를 '프리' 비아라고 합니다. Pad (Place » Pad) 또는 비아 (Place » Via) 배치 명령을 실행하면 커서가 십자 모양으로 바뀌고 배치 모드로 전환됩니다.
- 커서를 원하는 위치에 놓고 클릭하거나 Enter 키를 눌러 Pad/비아를 배치합니다.
- 계속해서 Pad/비아를 배치하거나, 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 배치 모드를 종료합니다.
배치 중에 Alt 키를 누르면 최초 이동 방향에 따라 이동 방향이 수평 또는 수직 축으로 제한됩니다.
그래픽 편집
Pad와 비아는 위치를 제외한 속성을 그래픽 방식으로 수정할 수 없습니다.
- 프리 Pad와 연결된 트랙을 함께 이동하려면 Pad를 클릭한 상태로 드래그합니다. Pad를 이동하는 동안 연결된 라우팅은 Pad에 연결된 상태를 유지합니다. Pad가 컴포넌트에 속한 경우에는 이동하지 않습니다.
- PCB 또는 PCB Library Editor에서 연결된 트랙을 이동하지 않고 자유 Pad를 이동하려면 Edit » Move » Move 명령을 선택한 다음, Pad를 클릭한 상태로 이동합니다.
Properties 패널을 통한 비그래픽 편집
이 편집 방법은 Properties Panel의 해당 모드를 사용하여 Pad/비아 객체의 속성을 수정합니다.
Pad 속성
Net 정보
이 영역에는 Pad가 속한 Net에 대한 정보와, 해당 Net이 멤버인 경우 Differential Pair 및/또는 xSignal에 대한 정보가 표시됩니다. 해당하는 경우 클래스 정보도 표시됩니다. Delay 및 Length 값도 제공됩니다.
Net 정보에 대한 자세한 내용은 PCB 배치 및 편집 기법 페이지를 참조하세요.
속성
-
Component – 이 필드는 선택한 Pad가 PCB 컴포넌트의 구성 요소인 경우에만 PCB Editor에 표시되며, 상위 PCB 컴포넌트의 Designator를 표시합니다. 클릭 가능한 Component 링크를 선택하면 상위 컴포넌트에 대한 Properties 패널의 컴포넌트 모드가 열립니다.
-
Designator – 이 필드는 현재 Pad Designator를 표시합니다. Pad가 컴포넌트의 일부인 경우, Designator는 일반적으로 해당 컴포넌트의 핀 번호로 설정됩니다. 자유 Pad에는 Designator를 지정하거나 이 필드를 비워 둘 수 있습니다. Designator가 숫자로 시작하거나 끝나는 경우, 여러 Pad를 순서대로 배치하면 해당 숫자가 자동으로 증가합니다. Pad Designator를 변경하려면 이 필드의 값을 편집합니다.
-
Layer – Pad가 할당될 레이어를 선택합니다. 스루홀 Pad를 정의하려면 Multi-Layer을 선택합니다.
-
Net – Pad의 Net을 선택하는 데 사용합니다. 활성 보드 설계의 모든 Net이 드롭다운 목록에 표시됩니다. Pad가 어떤 Net에도 연결되지 않도록 지정하려면 No Net을 선택합니다. Design Rule 검사기는 프리미티브의 Net 속성을 사용하여 PCB 객체가 올바르게 배치되었는지 판단합니다. 또는 Assign Net 아이콘을 클릭하여 설계 공간에서 객체를 선택할 수 있습니다. 해당 객체의 Net이 선택한 Pad에 할당됩니다.
-
Electrical Type – 이 필드는 Pad의 현재 전기적 상태를 표시합니다. 이 상태는 컴포넌트 Pad에만 적용되며, 해당 Pad의 전송선 특성을 설정합니다. Pad는 Load, Source 또는 Terminator로 지정할 수 있습니다. Net에 데이지 체인 라우팅 토폴로지 중 하나가 필요한 경우 Source 및 Terminator 설정을 사용합니다. 전기적 유형을 변경하려면 필드를 클릭하고 드롭다운 목록에서 선택합니다.
-
Propagation Delay – 이 필드는 신호의 선두가 송신 측에서 수신 측으로 이동하는 데 걸리는 시간인 전파 지연을 표시합니다.
-
Pin Package Length – 핀 패키지 길이는 PCB Panel에 표시되는 Signal Length 계산에 자동으로 포함됩니다. 선택한 Net의 핀에 대한 Pin/Pkg Length 값을 확인하거나 편집하려면 PCB Panel을 Nets 모드로 설정합니다.
-
Jumper – PCB에서 점퍼 연결을 사용하는 경우, 이 필드는 Pad에 점퍼 연결 식별 번호(범위: 1~1000)를 제공합니다. 점퍼 연결은 와이어를 사용하여 PCB의 Pad를 물리적으로 연결하며, 보드의 트랙이나 전기적 객체를 사용하지 않습니다. Jumper 값은 어떤 Pad를 '연결된' 것으로 처리할지 소프트웨어에 알려 줍니다. 점퍼 연결은 컴포넌트 풋프린트 내부의 Pad 사이에서만 생성할 수 있습니다. 사용되는 Pad는 동일한 Jumper 값을 사용해야 하며 동일한 Net에 속해야 합니다. 점퍼 연결은 PCB Editor에서 곡선 형태의 연결선으로 표시됩니다. 스크롤 화살표를 사용하거나 원하는 점퍼 연결 식별 번호를 직접 입력합니다.
-
Template – Pad의 현재 템플릿을 표시합니다. 다른 템플릿을 선택하려면 드롭다운을 사용합니다. 연결된 Library가 있으면 해당 라이브러리가 표시됩니다. 연결된 Pad/비아 템플릿 라이브러리에서 템플릿의 연결을 해제하려면
버튼을 클릭합니다.
-
(X/Y)
-
X (첫 번째 필드) – 이 필드는 현재 원점을 기준으로 Pad 중심의 현재 X 위치를 표시합니다. 현재 원점을 기준으로 Pad 위치를 변경하려면 이 필드의 값을 편집합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위가 아닌 단위로 값을 입력할 때는 단위를 포함해야 합니다. Default 단위(미터법 또는 야드파운드법)는 Board 모드의 Properties Panel에 있는 Other 영역의 Units 설정에 따라 결정되며, 단위를 지정하지 않은 경우 사용됩니다. 이 모드는 설계 공간에서 아무 객체도 선택하지 않았을 때 접근할 수 있습니다.
-
Y (두 번째 필드) – 이 필드는 현재 원점을 기준으로 Pad 중심의 현재 Y 위치를 표시합니다. 현재 원점을 기준으로 Pad 위치를 변경하려면 이 필드의 값을 편집합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위가 아닌 단위로 값을 입력할 때는 단위를 포함해야 합니다. Default 단위(미터법 또는 야드파운드법)는 Board 모드의 Properties Panel에 있는 Other 영역의 Units 설정에 따라 결정되며, 단위를 지정하지 않은 경우 사용됩니다. 이 모드는 설계 공간에서 아무 객체도 선택하지 않았을 때 접근할 수 있습니다.
-
-
Rotation – 패드의 회전 각도(도 단위)로, 0도(3 o'clock 수평 방향)에서 반시계 방향으로 측정됩니다. 이 필드를 사용하여 패드의 회전을 변경합니다. 최소 각도 분해능은 0.001°입니다.
Pad Stack
-
Simple / Top-Middle-Bottom / Full Stack – 스루홀 패드에 사용할 패드 스택 모드를 선택합니다(즉, 패드의 Layer으로 Multi-Layer가 선택된 경우). 다른 레이어에는 Simple 모드의 옵션이 적용됩니다.
-
Simple – 단순한 레이어 구성의 패드를 선택합니다. 이 패드의 모든 신호 구리 레이어에 공통으로 적용되는 패드 형상 속성을 정의할 수 있습니다.
-
Top-Middle-Bottom – 상단-중간-하단 레이어 구성의 패드를 선택합니다. 이 패드의 상단, 중간 및 하단 신호 구리 레이어에 대해 X 및 Y 크기와 형상 속성을 정의할 수 있습니다.
-
Full Stack – 전체 스택 레이어 구성의 패드를 선택합니다. 이 패드의 모든 신호 구리 레이어에 대해 X 및 Y 크기와 형상 속성을 정의할 수 있습니다.
-
-
Copper – 접이식 영역을 펼치거나 그리드를 사용하여 신호 구리 레이어의 패드 속성을 정의합니다. 사용 가능한 구리 레이어는 패드가 배치된 레이어와 선택한 패드 스택 모드에 따라 달라집니다.
- Shape – 패드 형상을 선택합니다. 표준 패드 형상(Round, Rectangular, Octagonal, Rounded Rectangle, Chamfered Rectangle 및 Donut)은 X 및 Y 설정을 변경하여 비대칭 패드 형상으로 만들 수 있습니다. 비표준 형상의 패드를 정의하려면 Custom Shape를 선택합니다(자세히 알아보기).
-
Edit Shape – 클릭하여 설계 공간에서 사용자 지정 형상 패드의 영역을 대화식으로 편집합니다. 이 버튼은 Shape으로 Custom Shape 이 선택된 경우에만 사용할 수 있습니다.
-
(X/Y) – 패드의 X(수평) 및 Y(수직) 크기를 정의합니다. X 및 Y 크기는 각각 독립적으로 설정하여 비대칭 패드 형상을 정의할 수 있습니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력합니다. Default 단위(미터법 또는 야드파운드법)는 Board 모드의 Properties 패널에 있는 Other 영역의 Units 설정에 따라 결정되며(설계 공간에서 아무 객체도 선택하지 않았을 때 접근 가능), 단위를 지정하지 않으면 이 단위가 사용됩니다. 이 옵션은 Shape으로 Rounded Rectangle 또는 Chamfered Rectangle 이 선택된 경우에만 사용할 수 있습니다.
-
Corner Radius – 패드 모서리의 반경/모따기 크기를 절대값으로 입력합니다. 값은 패드의 가장 짧은 변 길이의 절반 이하여야 합니다. 계산된 백분율 값(패드의 가장 짧은 변 길이의 절반에 대한 백분율)이 필드 오른쪽에 표시됩니다. 값 뒤에
%기호를 입력하면 반경/모따기 크기를 패드의 가장 짧은 변 길이의 절반에 대한 백분율로 정의할 수 있습니다.100%는 가장 짧은 변을 완전히 둥글게 만듭니다(이 경우 계산된 절대값이 필드 오른쪽에 표시됨). 이 옵션은 해당 구리 레이어에서 패드의 Shape으로 Rounded Rectangle 또는 Chamfered Rectangle 가 선택된 경우에만 사용할 수 있습니다. -
Upper Left, Upper Right, Lower Left, Lower Right – 패드 형상의 모서리에 라운딩/모따기를 적용합니다. 이 옵션은 해당 구리 레이어에서 패드의 Shape으로 Rounded Rectangle 또는 Chamfered Rectangle 가 선택된 경우에만 사용할 수 있습니다.
-
Outer Diameter – 패드의 외경을 입력합니다. 이 옵션은 해당 구리 레이어에서 패드의 Shape으로 Donut 이 선택된 경우에만 사용할 수 있습니다.
-
Width – 패드의 너비를 입력합니다. 이 옵션은 해당 구리 레이어에서 패드의 Shape으로 Donut 이 선택된 경우에만 사용할 수 있습니다.
-
Thermal Relief – 활성화하면 패드의 열 릴리프를 사용자 지정하여 적용되는 Polygon Connect Style 규칙을 재정의할 수 있습니다. 선택한 후 링크를 클릭하면 Polygon Connect Style 대화 상자가 열리며, 여기서 필요에 따라 열 릴리프 옵션을 변경할 수 있습니다. Edit Points 버튼을 클릭하면 열 릴리프 스포크의 연결 지점을 수동으로 정의할 수 있습니다. Custom 열 릴리프 정의에 대해 자세히 알아보세요.
-
Center Offset (X/Y) (SMD 패드에만 해당, 즉 패드의 Layer으로 Multi-Layer 이외의 레이어가 선택된 경우) – 패드 랜딩 영역을 중심에서 이동시킬 오프셋 값을 입력합니다.
-
Hole – 접이식 영역을 펼치거나 그리드를 사용하여 패드 홀 속성을 정의합니다. 홀 옵션은 스루홀 패드에만 사용할 수 있습니다(즉, 패드의 Layer으로 Multi-Layer가 선택된 경우).
-
Shape – 원하는 홀 모양을 선택합니다.
- Round – 패드의 홀 모양을 원형으로 지정합니다. 홀 종류별로, 그리고 도금 홀과 비도금 홀별로 별도의 드릴 파일(NC Drill Excellon 형식 2)이 생성됩니다. 이러한 유형에 대해 최대 6개의 서로 다른 드릴 파일이 생성됩니다.
- Rectangular – 이 패드에 직사각형(펀칭) 홀을 지정합니다. 직사각형 홀은 도금하거나 도금하지 않을 수 있습니다. 홀 종류별로, 그리고 도금 홀과 비도금 홀별로 별도의 드릴 파일(NC Drill Excellon 형식 2)이 생성됩니다. 이러한 유형에 대해 최대 6개의 서로 다른 드릴 파일이 생성됩니다.
- Slot – 이 패드에 끝이 둥근 슬롯 홀을 지정합니다. 슬롯 홀은 도금하거나 도금하지 않을 수 있습니다. 홀 종류별로, 그리고 도금 홀과 비도금 홀별로 별도의 드릴 파일(NC Drill Excellon 형식 2)이 생성됩니다. 이러한 유형에 대해 최대 6개의 서로 다른 드릴 파일이 생성됩니다.
- Size – 이 필드는 패드의 현재 홀 크기를 표시합니다. 이 값은 제작 중 패드에 형성할 원형 홀의 지름(또는 직사각형 홀이나 슬롯의 너비)을 mil 또는 mm 단위로 지정합니다. SMD 패드나 에지 커넥터의 경우 이 값을 0으로 설정해야 합니다. 홀 크기는 0~1000mil로 설정할 수 있으며, 패드보다 크게 설정하여 구리가 없는 기계적 홀을 정의할 수도 있습니다. 단, Rectangular 또는 Slot 홀의 Length보다 클 수는 없습니다. 패드의 홀 크기를 변경하려면 이 필드의 값을 편집합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위로 값을 입력할 때는 단위를 함께 입력해야 합니다. Default 단위(미터법 또는 야드파운드법)는 Board 모드의 Properties 패널에 있는 Other 영역의 Units 설정에 따라 결정되며(설계 공간에서 아무 객체도 선택하지 않은 상태에서 접근), 단위를 지정하지 않으면 이 단위가 사용됩니다.
-
Tolerance – 홀 공차 속성을 설정하면 보드의 끼워맞춤과 한계를 결정하는 데 도움이 됩니다. 홀의 최소(-) 및 최대(+) 공차를 지정합니다.
-
Length – 홀의 Shape이 Rectangular 또는 Slot으로 설정되어 있을 때 패드 내 홀의 길이를 표시합니다. 이 값은 제작 중 패드에 NC 라우팅으로 가공할 길이를 mm 또는 mil 단위로 지정합니다. 홀 크기는 0~1000mil로 설정할 수 있으며, 패드보다 크게 설정하여 구리가 없는 기계적 홀을 정의할 수도 있습니다. 단, Rectangular 또는 Slot 홀의 Size보다 작을 수는 없습니다(필요한 X-Y 형태를 얻으려면 Rotation 설정을 사용하십시오). 길이를 변경하려면 이 필드의 값을 편집합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위로 값을 입력할 때는 단위를 함께 입력해야 합니다. Default 단위(미터법 또는 야드파운드법)는 Board 모드의 Properties 패널에 있는 Other 영역의 Units 설정에 따라 결정되며(설계 공간에서 아무 객체도 선택하지 않은 상태에서 접근), 단위를 지정하지 않으면 이 단위가 사용됩니다. 홀의 Shape이 Round으로 설정되어 있으면 이 옵션을 사용할 수 없습니다.
- Rotation – 패드에 대한 현재 홀의 반시계 방향 회전 각도를 도 단위로 표시합니다. 회전을 변경하려면 이 필드를 편집합니다. 최소 각도 분해능은 0.001°입니다. 이 옵션은 홀의 Shape으로 Rectangular 또는 Slot이 선택된 경우에만 사용할 수 있습니다.
- Copper Offset (X/Y) – 패드 랜딩 영역을 패드 홀의 중심에서 오프셋할 값을 입력합니다.
- Plated – 이 옵션은 패드의 홀이 도금 홀인지 여부를 결정합니다. 이 필드를 선택하면 패드가 도금 홀 패드로 설정됩니다. 설계에 도금 패드와 비도금 패드가 모두 있는 경우, NC 드릴 파일에서 비도금 홀은 도금 홀과 다른 공구를 사용하도록 설정됩니다.
-
Shape – 원하는 홀 모양을 선택합니다.
-
Paste – 접을 수 있는 영역을 펼치거나 그리드를 사용하여 페이스트 마스크 레이어의 패드 속성을 정의합니다. 사용 가능한 페이스트 마스크 레이어는 패드가 배치된 레이어에 따라 달라집니다.
-
Shape – 페이스트 마스크 레이어의 모양을 선택합니다.
-
Rule Expansion – 패드의 페이스트 마스크 확장값이 해당 Paste Mask Expansion 설계 규칙에 정의된 값을 따르도록 선택합니다.
-
Manual Expansion – 패드의 페이스트 마스크 확장값을 직접 지정하려면 선택합니다.
-
Round, Rectangular, Octagonal, Rounded Rectangle, Chamfered Rectangle 및 Donut – 표준 페이스트 마스크 모양을 정의하려면 선택합니다. X 및 Y 설정을 변경하여 이러한 모양을 비대칭 모양으로 조정할 수 있습니다.
- Donut 모양의 경우 D 은 도넛의 외경을, W은 너비를 나타냅니다.
-
Custom Shape – 비표준 페이스트 마스크 모양을 정의하려면 선택합니다.
-
-
Edit – 클릭하면 설계 공간에서 페이스트 마스크 레이어의 사용자 지정 모양을 대화형으로 편집할 수 있습니다. 이 버튼은 Shape으로 Custom Shape이 선택된 경우에만 사용할 수 있습니다..
-
Paste Expansion – 원하는 Paste Mask Expansion 값을 입력합니다. 이 값은 절대값(mil/mm) 또는 Pad 면적의 백분율로 정의할 수 있습니다. 절대값을 입력할 때 현재 기본 단위와 다른 단위를 사용한다면 단위도 함께 입력합니다. Default 단위는 Board 모드의 Properties Panel에 있는 Other Region의 Units 설정에 따라 결정되며(설계 공간에서 선택된 객체가 없을 때 접근 가능), 단위를 지정하지 않으면 이 단위가 사용됩니다. 이 옵션은 Shape 에 Manual Expansion 이 선택되어 있고 Paste 마스크 사용이 Enabled인 경우에만 사용할 수 있습니다.
-
(X/Y) – Paste 마스크 형상의 X(가로) 및 Y(세로) 크기를 정의합니다. X와 Y 크기를 개별적으로 설정하여 비대칭 형상을 정의할 수 있습니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있으며, 현재 기본 단위와 다른 단위를 사용한다면 단위도 함께 입력합니다. Default 단위(미터법 또는 야드파운드법)는 Board 모드의 Properties Panel에 있는 Other Region의 Units 설정에 따라 결정되며(설계 공간에서 선택된 객체가 없을 때 접근 가능), 단위를 지정하지 않으면 이 단위가 사용됩니다. 이 옵션은 Shape에 Round, Rectangular, Octagonal, Rounded Rectangle 또는 Chamfered Rectangle이 선택된 경우에만 사용할 수 있습니다.
-
Corner Radius – Paste 마스크 형상의 모서리 반경/모따기 크기를 절대값으로 입력합니다. 이 값은 Paste 마스크 형상의 가장 짧은 변 길이의 절반 이하여야 합니다. 계산된 백분율 값(Paste 마스크 형상의 가장 짧은 변 길이의 절반에 대한 백분율)은 필드 오른쪽에 표시됩니다. 값 뒤에
%심볼을 입력하면 반경/모따기 크기를 Paste 마스크 형상의 가장 짧은 변 길이의 절반에 대한 백분율로 정의할 수 있으며,100%이면 가장 짧은 변이 완전히 둥글게 처리됩니다(이 경우 계산된 절대값이 필드 오른쪽에 표시됩니다). 이 옵션은 해당 Paste 마스크 레이어에서 Pad의 Shape 에 Rounded Rectangle 또는 Chamfered Rectangle 가 선택된 경우에만 사용할 수 있습니다. -
Upper Left, Upper Right, Lower Left, Lower Right – Paste 마스크 형상의 모서리를 둥글게 처리하거나 모따기할 수 있도록 활성화합니다. 이 옵션은 해당 Paste 마스크 레이어에서 Pad의 Shape 에 Rounded Rectangle 또는 Chamfered Rectangle 가 선택된 경우에만 사용할 수 있습니다.
-
Offset (X/Y) – Pad 중심에서 Paste 마스크 형상을 이동시킬 오프셋 값을 입력합니다.
-
Outer Diameter – Pad의 외경을 입력합니다. 이 옵션은 해당 Paste 마스크 레이어에서 Pad의 Shape 에 Donut 이 선택된 경우에만 사용할 수 있습니다.
-
Width – Pad의 너비를 입력합니다. 이 옵션은 해당 Paste 마스크 레이어에서 Pad의 Shape 에 Donut 이 선택된 경우에만 사용할 수 있습니다.
-
Enabled – 이 옵션을 사용하여 Pad의 Paste 마스크 형상 사용을 활성화/비활성화합니다. 이 옵션은 Shape 에 Rule Expansion 이외의 옵션이 선택된 경우에만 사용할 수 있습니다.
-
-
Solder – 접을 수 있는 Region을 펼치거나 Grid를 사용하여 솔더 마스크 레이어의 Pad 속성을 정의합니다. 사용 가능한 솔더 마스크 레이어는 Pad가 배치된 레이어에 따라 달라집니다.
-
Shape – 솔더 마스크 레이어의 형상을 선택합니다.
-
Rule Expansion – Pad의 Solder Mask Expansion이 해당 Solder Mask Expansion Design Rule에 정의된 값을 따르도록 선택합니다.
-
Manual Expansion – Pad의 Solder Mask Expansion 값을 지정하려면 선택합니다.
- Round, Rectangular, Octagonal, Rounded Rectangle, Chamfered Rectangle 및 Donut – 표준 솔더 마스크 형상을 정의하려면 선택합니다. X 및 Y 설정을 변경하여 이러한 형상을 비대칭 형상으로 조정할 수 있습니다.
-
Custom Shape – 비표준 솔더 마스크 형상을 정의하려면 선택합니다.
-
-
Edit – 클릭하면 설계 공간에서 솔더 마스크 레이어의 사용자 지정 형상을 대화형으로 편집할 수 있습니다. 이 버튼은 Shape 에 Custom Shape 이 선택된 경우에만 사용할 수 있습니다.
-
Solder Expansion – 원하는 Paste Mask Expansion 값을 입력합니다. 이 값은 절대값(mil/mm) 또는 Pad 면적의 백분율로 정의할 수 있습니다. 절대값을 입력할 때 현재 기본 단위와 다른 단위를 사용한다면 단위도 함께 입력합니다. Default 단위는 Board 모드의 Properties Panel에 있는 Other Region의 Units 설정에 따라 결정되며(설계 공간에서 선택된 객체가 없을 때 접근 가능), 단위를 지정하지 않으면 이 단위가 사용됩니다. 이 옵션은 Shape 에 Manual Expansion 이 선택되어 있고 Tented 옵션이 비활성화된 경우에만 사용할 수 있습니다.
-
From Hole Edge – 활성화하면 솔더 마스크 개구부가 홀 형상을 따릅니다. 따라서 마스크는 Pad의 형상 및 크기와 무관하며, 홀의 크기와 형상을 기준으로 크기가 조정됩니다. 예를 들어 정사각형 홀이 있는 Pad는 홀 치수와 지정된 Expansion 값에 맞는 정사각형 마스크 개구부를 생성합니다. 또한 Pad의 Expansion 마스크 개구부 크기는 홀 크기가 변경되면 그에 따라 변경됩니다. 이 옵션은 스루홀 Pad(즉, Pad의 Layer에 Multi-Layer이 선택된 경우)에만 사용할 수 있으며, Shape 에 Manual Expansion 이 선택되어 있어야 합니다. 및 Tented 옵션이 비활성화됩니다.
-
(X/Y) – 솔더 마스크 형상의 X(가로) 및 Y(세로) 크기를 정의합니다. X와 Y 크기는 독립적으로 설정하여 비대칭 형상을 정의할 수 있습니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위로 값을 입력할 때는 단위를 함께 입력하세요. Default 단위(미터법 또는 야드파운드법)는 Board 모드의 Properties 패널에 있는 Other 영역의 Units 설정에 따라 결정되며, 단위를 지정하지 않으면 이 단위가 사용됩니다. 이 모드는 설계 공간에서 선택된 객체가 없을 때 접근할 수 있습니다. 이 옵션은 Shape으로 Round, Rectangular, Octagonal, Rounded Rectangle 또는 Chamfered Rectangle을 선택한 경우에만 사용할 수 있습니다.
-
Corner Radius – 솔더 마스크 형상의 모서리 반경/모따기 크기를 절대값으로 입력합니다. 값은 솔더 마스크 형상의 가장 짧은 변 길이의 절반 이하여야 합니다. 계산된 백분율 값(솔더 마스크 형상의 가장 짧은 변 길이의 절반에 대한 백분율)이 필드 오른쪽에 표시됩니다. 값 뒤에
%기호를 입력하면 반경/모따기 크기를 솔더 마스크 형상의 가장 짧은 변 길이의 절반에 대한 백분율로 정의할 수 있습니다.100%는 가장 짧은 변을 완전히 둥글게 만듭니다(이 경우 계산된 절대값이 필드 오른쪽에 표시됩니다). 이 옵션은 해당 솔더 마스크 레이어에서 패드의 Shape 으로 Rounded Rectangle 또는 Chamfered Rectangle 을 선택한 경우에만 사용할 수 있습니다. -
Upper Left, Upper Right, Lower Left, Lower Right – 솔더 마스크 형상의 모서리를 둥글게 하거나 모따기할 수 있도록 설정합니다. 이 옵션은 해당 솔더 마스크 레이어에서 패드의 Shape 으로 Rounded Rectangle 또는 Chamfered Rectangle 를 선택한 경우에만 사용할 수 있습니다.
-
Offset (X/Y) – 솔더 마스크 형상을 패드 중심에서 오프셋할 값을 입력합니다.
-
Outer Diameter – 패드의 외경을 입력합니다. 이 옵션은 해당 솔더 마스크 레이어에서 패드의 Shape 으로 Donut 을 선택한 경우에만 사용할 수 있습니다.
-
Width – 패드의 너비를 입력합니다. 이 옵션은 해당 솔더 마스크 레이어에서 패드의 Shape 으로 Donut 를 선택한 경우에만 사용할 수 있습니다.
-
Tented – 솔더 마스크 확장 설계 규칙의 솔더 마스크 설정을 재정의하려면 선택합니다. 이렇게 하면 이 패드의 상단/하단 레이어에 솔더 마스크 개구부가 생기지 않아 텐팅 처리됩니다. 이 옵션을 비활성화하면 패드에 솔더 마스크 확장 규칙 또는 특정 확장 값이 적용됩니다. 이 옵션은 Shape으로 Rule Expansion 이외의 옵션을 선택한 경우에만 사용할 수 있습니다.
-
/
– Shape으로 Manual Expansion 를 선택한 경우, 버튼을
으로 설정하면 Bottom Solder Mask 영역(따라서 해당 영역의 Solder Expansion 옵션)에 접근할 수 있습니다. 버튼이
상태이면 하단 레이어의 솔더 마스크 확장 값은 상단 레이어의 값과 동일해집니다.
-
Pad 기능
Top Side / Bottom Side – 보드 상단/하단 면의 패드 카운터홀에 원하는 옵션을 선택합니다. 사용 가능한 옵션: None, Counterbore, Countersink. 이 옵션은 원형 스루홀 패드에만 사용할 수 있습니다 (즉, 패드의 Layer 으로 Multi-Layer을 선택하고 패드의 홀 형상으로 Round를 선택한 경우).
적층판의 카운터홀은 나사 머리가 들어갈 공간을 제공합니다. 카운터싱크 홀과 카운터보어 홀은 서로 다른 유형의 나사에 사용할 수 있는 두 가지 카운터홀입니다. 이번 릴리스에서는 카운터보어 또는 카운터싱크 홀을 선택하는 기능이 도입되었습니다. 카운터싱크와 카운터보어 나사의 주요 차이점은 홀의 크기와 형상입니다. 카운터보어 홀은 와셔를 추가할 수 있도록 더 넓고 단면이 더 사각형에 가깝습니다. 카운터싱크 홀은 접시머리 나사 아랫면의 경사진 형상에 맞는 원뿔형 홀을 만듭니다. 카운터싱크는 적층판에 가공한 원뿔형 홀입니다. 일반적으로 나사의 테이퍼진 머리가 적층판 상단과 같은 높이로 놓이도록 하는 데 사용됩니다. 반면 카운터보어는 바닥이 평평한 홀을 만들며 측면은 수직으로 가공됩니다. 일반적으로 육각 머리 캡이나 나사를 끼우는 데 사용됩니다. 패드당 카운터싱크 또는 카운터보어 홀은 하나만 허용됩니다.
2D에서는 패드 주위에 점선이 나타나 활성 레이어의 카운터홀 윤곽을 표시합니다. 카운터홀은 2D, 3D 및 Draftsman에서 지원됩니다.
테스트포인트
Fabrication/Assembly – 이 옵션을 사용하면 제작 및/또는 조립 테스트에서 테스트포인트 위치로 사용할 패드(스루홀 또는 SMD)를 지정할 수 있습니다. 이 패드를 상단 레이어 테스트포인트로 정의하려면 Top을 활성화합니다. 이 패드를 하단 레이어 테스트포인트로 정의하려면 Bottom을 활성화합니다.
비아 속성
Net 정보
이 영역은 비아가 속한 네트에 대한 정보를 제공하며, 해당 네트가 Differential Pair 및/또는 xSignal의 구성원인 경우 이에 대한 정보도 제공합니다. 해당되는 경우 클래스 정보가 표시됩니다. Delay, Length, Max Current 및 Resistance 값도 제공됩니다.
네트 정보에 대한 자세한 내용은 PCB 배치 및 편집 기법 페이지를 참조하세요.
정의
-
Component – 이 필드는 선택한 비아가 PCB 컴포넌트의 구성 요소인 경우에만 PCB 편집기에 표시되며, 상위 PCB 컴포넌트의 참조 지정자를 표시합니다. 클릭 가능한 Component 링크를 선택하면 상위 컴포넌트에 대한 Properties 패널의 컴포넌트 모드가 열립니다.
-
Net – 비아의 네트를 선택하는 데 사용합니다. 활성 보드 설계의 모든 네트가 드롭다운 목록에 표시됩니다. 비아가 어떤 네트에도 연결되지 않도록 지정하려면 No Net 을 선택합니다. Net 프리미티브의 속성은 Design Rule 검사기가 PCB 객체가 적법하게 배치되었는지 판단하는 데 사용됩니다. 또는 Assign Net 아이콘을 클릭하여 설계 공간에서 객체를 선택할 수 있습니다. 해당 객체의 Net이 선택한 비아에 할당됩니다.
-
Name – 하나 이상의 비아를 선택하면 드롭다운을 클릭하여 비아 이름을 표시할 수 있습니다. 이 목록에는 Layer Stack에 정의된 모든 비아 스팬이 나열됩니다. 보드에 사용되는 모든 비아는 Layer Stack에 정의된 비아 스팬 중 하나여야 합니다.
-
Propagational Delay – 이 필드에는 전파 지연이 표시됩니다. 전파 지연은 Signal의 선두가 송신기에서 수신기까지 이동하는 데 걸리는 시간입니다.
-
Template – 비아의 현재 템플릿을 표시합니다. 드롭다운을 사용하여 다른 템플릿을 선택할 수 있습니다. 연결된 Library이 있으면 해당 라이브러리가 표시됩니다.
-
Library – 현재 라이브러리에 포함된 비아 템플릿을 표시합니다. Pad 비아 라이브러리(*.PvLib)에서 비아를 배치하면 이 필드에 해당 라이브러리의 이름이 포함됩니다. 배치 후에는
아이콘이 활성화되며, 이는 배치된 비아의 속성이 라이브러리에 정의되어 있어 더 이상 편집할 수 없음을 나타냅니다.
아이콘이 활성화되어 있지 않으면 내용을 계속 편집할 수 있습니다.
-
(X/Y)
- X (첫 번째 필드) – 현재 원점을 기준으로 비아 중심의 현재 X 위치를 표시합니다. 현재 원점을 기준으로 비아의 위치를 변경하려면 이 필드의 값을 편집합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력하십시오. Default 단위(미터법 또는 야드파운드법)는 Board 모드의 Properties Panel 내 Other Region에 있는 Units 설정에 따라 결정되며(설계 공간에서 아무 객체도 선택하지 않았을 때 접근 가능), 단위를 지정하지 않으면 이 단위가 사용됩니다.
- Y (두 번째 필드) – 이 필드는 현재 원점을 기준으로 비아 중심의 현재 Y 위치를 표시합니다. 현재 원점을 기준으로 비아의 위치를 변경하려면 이 필드의 값을 편집합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력하십시오. Default 단위(미터법 또는 야드파운드법)는 Board 모드의 Properties Panel 내 Other Region에 있는 Units 설정에 따라 결정되며(설계 공간에서 아무 객체도 선택하지 않았을 때 접근 가능), 단위를 지정하지 않으면 이 단위가 사용됩니다.
비아 스택
-
Simple – 단순 비아를 선택하려면 이 옵션을 선택합니다.
- Diameter – 필요한 비아 직경을 입력합니다. 비아 직경은 모든 레이어에서 동일합니다.
- Relief – 적용되는 폴리곤 연결 스타일 Rule을 재정의하여 비아의 써멀 릴리프를 사용자 지정하려면 활성화합니다.
-
Thermal Relief – Relief 옵션을 활성화한 후 링크를 클릭하여 Polygon Connect Style 대화상자를 열면 필요에 따라 써멀 릴리프 옵션을 변경할 수 있습니다. 써멀 릴리프 스포크의 연결 지점을 수동으로 정의하려면 Edit Points 버튼을 클릭합니다.
-
Top-Middle-Bottom – 상단 레이어, 모든 내부 Signal 레이어 및 하단 레이어에 서로 다른 직경을 지정하려면 선택합니다.
- Displayed Layer(s) – 표시된 레이어를 클릭하여 해당 레이어의 비아를 구성합니다. 선택한 레이어는 강조 표시됩니다.
- Diameter – 드롭다운을 클릭한 다음 선택한 레이어에 필요한 비아 직경을 입력합니다.
- Relief – 적용되는 폴리곤 연결 스타일 Rule을 재정의하여 비아의 써멀 릴리프를 사용자 지정하려면 활성화합니다.
-
Thermal Relief – Relief 옵션을 활성화한 후 링크를 클릭하여 Polygon Connect Style 대화상자를 열면 필요에 따라 써멀 릴리프 옵션을 변경할 수 있습니다. 써멀 릴리프 스포크의 연결 지점을 수동으로 정의하려면 Edit Points 버튼을 클릭합니다.
-
Full Stack – 전체 스택 비아 객체를 선택하려면 이 옵션을 선택합니다.
- Displayed Layer(s) – 표시된 레이어를 클릭하여 해당 레이어의 비아를 구성합니다. 선택한 레이어는 강조 표시됩니다.
- Diameter – 드롭다운을 클릭한 다음 선택한 레이어에 필요한 비아 직경을 입력합니다.
- Relief – 적용되는 폴리곤 연결 스타일 Rule을 재정의하여 비아의 써멀 릴리프를 사용자 지정하려면 활성화합니다.
-
Thermal Relief – Relief 옵션을 활성화한 후 링크를 클릭하여 Polygon Connect Style 대화상자를 열면 필요에 따라 써멀 릴리프 옵션을 변경할 수 있습니다. 써멀 릴리프 스포크의 연결 지점을 수동으로 정의하려면 Edit Points 버튼을 클릭합니다.
-
Hole Size – 이 필드는 비아의 현재 홀 크기를 표시합니다. 이 값은 제조 중 비아에 드릴 가공할 홀(원형, 정사각형 또는 슬롯형)의 직경을 mil 또는 mm 단위로 지정합니다. 홀 크기는 0~1000mil로 설정할 수 있으며, 비아보다 크게 설정하여 구리가 없는 기계적 홀을 정의할 수도 있습니다. 비아 홀 크기를 변경하려면 이 필드의 값을 편집합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력하십시오. Default 단위(미터법 또는 야드파운드법)는 Board 모드의 Properties Panel 내 Other Region에 있는 Units 설정에 따라 결정되며(설계 공간에서 아무 객체도 선택하지 않았을 때 접근 가능), 단위를 지정하지 않으면 이 단위가 사용됩니다.
-
Tolerance – 홀 공차 속성을 설정하면 보드의 끼워맞춤과 한계를 결정하는 데 도움이 됩니다. 홀의 최소(-) 및 최대(+) 공차를 지정합니다. Altium Designer에는 기본 홀 공차 값이 없습니다.
Solder Mask Expansion
-
Rule – 비아의 솔더 마스크 확장값이 해당 Solder Mask Expansion 설계 규칙에 정의된 값을 따르도록 선택합니다.
-
Top
- Tented – 솔더 마스크 확장 설계 규칙의 모든 솔더 마스크 설정을 재정의하려면 선택합니다. 그러면 이 비아의 상단 레이어에 솔더 마스크 개구부가 생성되지 않아 텐팅 처리됩니다. 이 옵션을 비활성화하면 이 비아에는 솔더 마스크 확장 규칙이나 특정 확장값이 적용됩니다.
-
Bottom
- Tented – 솔더 마스크 확장 설계 규칙의 모든 솔더 마스크 설정을 재정의하려면 선택합니다. 그러면 이 비아의 하단 레이어에 솔더 마스크 개구부가 생성되지 않아 텐팅 처리됩니다. 이 옵션을 비활성화하면 이 비아에는 솔더 마스크 확장 규칙이나 특정 확장값이 적용됩니다.
-
Top
-
Manual – 해당 설계 규칙을 재정의하고 비아의 솔더 마스크 확장값을 지정하려면 선택합니다.
-
Top – 상단 레이어의 솔더 마스크 확장값을 입력합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력하십시오. 기본 단위(미터법 또는 야드파운드법)는 Board 모드(설계 공간에서 아무 객체도 선택하지 않았을 때 접근 가능)의 Properties 패널에 있는 Other 영역의 Units 설정에 따라 결정되며, 단위를 지정하지 않으면 이 기본 단위가 사용됩니다. 이 필드는 Tented이 활성화되어 있지 않은 경우에만 사용할 수 있습니다.
- Tented – 솔더 마스크 확장 설계 규칙의 모든 솔더 마스크 설정을 재정의하려면 선택합니다. 그러면 이 비아의 상단 레이어에 솔더 마스크 개구부가 생성되지 않아 텐팅 처리됩니다. 이 옵션을 비활성화하면 이 비아에는 솔더 마스크 확장 규칙이나 특정 확장값이 적용됩니다.
-
Bottom – 하단 레이어의 솔더 마스크 확장값을 입력합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력하십시오. 기본 단위(미터법 또는 야드파운드법)는 Board 모드(설계 공간에서 아무 객체도 선택하지 않았을 때 접근 가능)의 Properties 패널에 있는 Other 영역의 Units 설정에 따라 결정되며, 단위를 지정하지 않으면 이 기본 단위가 사용됩니다. 이 필드는 이 영역 오른쪽의
아이콘이
상태로 설정되어 있고 Tented 옵션이 활성화되어 있지 않은 경우에만 사용할 수 있습니다. 아이콘이
상태이고 Tented 옵션이 활성화되어 있지 않으면 하단 레이어의 솔더 마스크 확장값은 상단 레이어와 동일하게 설정됩니다.
- Tented – 솔더 마스크 확장 설계 규칙의 모든 솔더 마스크 설정을 재정의하려면 선택합니다. 그러면 이 비아의 하단 레이어에 솔더 마스크 개구부가 생성되지 않아 텐팅 처리됩니다. 이 옵션을 비활성화하면 이 비아에는 솔더 마스크 확장 규칙이나 특정 확장값이 적용됩니다.
- From Hole Edge – 활성화하면 솔더 마스크 개구부가 홀 크기를 따릅니다. 따라서 마스크는 비아 크기와 무관하며 홀 크기를 기준으로 크기가 조정됩니다. 또한 홀 크기가 변경되면 비아의 확장 마스크 개구부 크기도 이에 따라 변경됩니다.
-
Top – 상단 레이어의 솔더 마스크 확장값을 입력합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력하십시오. 기본 단위(미터법 또는 야드파운드법)는 Board 모드(설계 공간에서 아무 객체도 선택하지 않았을 때 접근 가능)의 Properties 패널에 있는 Other 영역의 Units 설정에 따라 결정되며, 단위를 지정하지 않으면 이 기본 단위가 사용됩니다. 이 필드는 Tented이 활성화되어 있지 않은 경우에만 사용할 수 있습니다.
비아 유형 및 기능
- IPC 4761 Via Type – 드롭다운을 사용하여 IPC 4761 표준 Design Guide for Protection of Printed Board Via Structures에 따른 비아 유형을 선택합니다.
-
Grid – IPC 4761 Via Type 드롭다운에서
None이외의 비아 유형을 선택하면 표시됩니다. 보드의 Side을 선택하고 선택한 비아 유형에 따라 사용할 수 있는 기능의 Material을 입력합니다.
테스트포인트
Fabrication/Assembly – 이 옵션을 사용하면 제작 및/또는 조립 테스트에서 테스트포인트 위치로 사용할 비아를 지정할 수 있습니다. 이 비아를 상단 레이어 테스트포인트로 정의하려면 Top을 활성화합니다. 이 비아를 하단 레이어 테스트포인트로 정의하려면 Bottom을 활성화합니다.
Pad 및 비아의 서멀 릴리프
Properties 패널의 Pad Stack / Via Stack 영역에 있는 Thermal Relief 필드에는 현재 적용된 서멀 릴리프 구성이 요약되어 표시됩니다. 예를 들어 Relief, 15mil, 10mil, 4, 90는 다음을 의미합니다.
- 서멀 릴리프 연결이 적용됩니다.
- 에어 갭의 폭은 15mil입니다.
- 서멀 릴리프 도체의 폭은 10mil입니다.
- 서멀 릴리프 도체의 회전 각도는 90도입니다.
Thermal Relief 필드의 체크박스를 비활성화하면 패드와 비아의 폴리곤 서멀 릴리프는 rules-driven 상태가 됩니다. 즉, 이러한 릴리프는 해당 Polygon Connect Style 설계 규칙에 의해 정의됩니다. 개별 패드의 경우 필요한 레이어에 연결된 Thermal Relief 옵션을 활성화하여 서멀 릴리프 구성을 사용자 지정할 수 있습니다. 이 경우 서멀 릴리프는 custom으로 간주됩니다. Custom 서멀 릴리프 정의에 대해 자세히 알아보십시오.
솔더 및 Paste 마스크 확장
솔더 마스크는 Solder Mask 레이어의 각 Pad/비아 위치에 자동으로 생성됩니다. 솔더 마스크는 네거티브 방식으로 정의됩니다. 즉, 배치된 객체가 Solder Mask 레이어의 개구부를 정의합니다. 페이스트 마스크는 Paste Mask 레이어의 각 Pad 위치에 자동으로 생성됩니다. 마스크 레이어에 생성되는 형상은 Pad/비아 형상을 기준으로 하며, PCB Editor에서 설정한 Solder Mask Expansion 및 Paste Mask Expansion 설계 규칙이나 Properties 패널에서 지정한 값만큼 확장 또는 축소됩니다.
Pad 또는 비아를 편집하면 Properties 패널의 Pad Stack 및 Solder Mask Expansion 영역에서 각각 솔더 마스크와 페이스트 마스크의 Expansion 설정을 확인할 수 있습니다. 이러한 설정은 개별 Pad/비아의 Expansion 요구 사항을 제어할 수 있도록 제공되지만, 일반적으로 사용할 필요는 없습니다. 대개 PCB Editor에서 적절한 설계 규칙을 정의하여 페이스트 마스크와 솔더 마스크 요구 사항을 제어하는 것이 더 쉽습니다. 설계 규칙을 사용할 때는 하나의 규칙으로 보드의 모든 컴포넌트에 대한 Expansion을 설정한 다음, 필요에 따라 보드에 사용된 특정 풋프린트 유형의 모든 인스턴스나 특정 컴포넌트의 특정 Pad 등 개별 상황을 대상으로 하는 다른 규칙을 추가할 수 있습니다.
설계 규칙에서 마스크 Expansion을 설정하려면:
-
Properties 패널(Pad용)의 Pad Stack 영역에서 Shape 항목에 Rule Expansion 옵션이 선택되어 있는지, 그리고/또는 Properties 패널(비아용)의 Solder Mask Expansion 영역에서 Rule 옵션이 선택되어 있는지 확인합니다.
-
PCB Editor의 기본 메뉴에서 Design » Rules을 선택하고 PCB Rules and Constraints Editor 대화 상자에서 Mask 범주의 설계 규칙을 확인합니다. 풋프린트가 PCB에 배치되면 이 규칙이 적용됩니다.
Expansion 설계 규칙을 재정의하고 마스크 Expansion을 Pad/비아 속성으로 지정하려면, Properties 패널(Pad용)의 Pad Stack 영역에서 Shape 항목에 Manual Expansion을 선택하고/하거나 Properties 패널(비아용)의 Solder Mask Expansion 영역에서 Manual 를 선택한 다음 필요한 값을 입력합니다.
Pad 및 비아 텐팅
Solder Mask Expansion에 적절한 값을 지정하면 Pad와 비아를 부분적으로 또는 완전히 텐팅할 수 있습니다. 이 Expansion 제약 조건은 Properties 패널에서 객체별로 정의하거나 적절한 Solder Mask Expansion 설계 규칙을 정의하여 설정할 수 있습니다. Expansion 값을 적절하게 설정하면 다음과 같은 결과를 얻을 수 있습니다.
- Pad/비아를 부분적으로 텐팅하려면(랜드 영역만 덮기), 마스크 개구부가 Pad/비아 홀의 가장자리까지 줄어들도록 Expansion을 음수 값으로 설정합니다.
- Pad/비아를 완전히 텐팅하려면(랜드와 홀 모두 덮기), Expansion을 Pad/비아 반지름 이상의 절댓값을 갖는 음수 값으로 설정합니다.
- 단일 레이어의 모든 Pad/비아를 텐팅하려면 적절한 Expansion 값을 설정하고, Solder Mask Expansion 규칙의 적용 범위(Full Query)가 해당 레이어의 모든 Pad/비아를 대상으로 하는지 확인합니다.
- 다양한 비아 크기가 정의된 설계에서 모든 Pad/비아를 완전히 텐팅하려면, Expansion을 가장 큰 Pad/비아 반지름 이상의 절댓값을 갖는 음수 값으로 설정합니다. 개별 Pad/비아를 텐팅할 때는 해당 설계 규칙에 정의된 Expansion을 따르거나, 규칙을 재정의하여 해당 Pad/비아에 지정한 Expansion을 직접 적용하는 옵션을 사용할 수 있습니다.
테스트포인트
Related page: 보드에 테스트포인트 지정하기
소프트웨어는 테스트포인트를 완벽하게 지원하며, Pad(스루홀 또는 SMD)와 비아를 제작 및/또는 조립 테스트의 테스트포인트 위치로 지정할 수 있습니다. Pad/비아를 테스트포인트로 지정하려면 관련 테스트포인트 속성, 즉 제작용 또는 조립용 테스트포인트 여부와 테스트포인트로 사용할 보드 면을 설정합니다. 이 속성은 Properties 패널의 Testpoint 영역에서 확인할 수 있습니다.
절차를 간소화하고 테스트포인트 속성을 수동으로 설정할 필요를 줄이기 위해, 소프트웨어는 정의된 설계 규칙을 기반으로 Testpoint Manager(Tools » Testpoint Manager)를 사용하여 테스트포인트를 자동으로 지정하는 방법을 제공합니다. 각 경우에 자동 지정 기능은 Pad/비아의 관련 테스트포인트 속성을 설정합니다.
Pad 세부 사항
Pad Designator
각 Pad에는 최대 20자의 영숫자로 구성된 Designator(일반적으로 컴포넌트 핀 번호를 나타냄)를 지정해야 합니다. 첫 번째 Pad의 Designator가 숫자로 끝나면 배치 중에 Pad Designator가 자동으로 1씩 증가합니다. 배치하기 전에 Properties 패널에서 첫 번째 Pad의 Designator를 변경합니다.
1A, 1B 등의 알파벳 증가나 1 이외의 숫자 증가 간격을 적용하려면, Paste Special 대화 상자(Edit » Paste Special)의 Paste Array 버튼을 눌러 여는 Setup Paste Array 대화 상자를 사용합니다.
Paste Array 기능
Pad를 클립보드에 복사하기 전에 Designator를 설정하면, Setup Paste Array 대화 상자를 사용하여 Pad 배치 중에 지정 순서를 자동으로 적용할 수 있습니다. Setup Paste Array 대화 상자의 Text Increment 필드를 사용하면 다음과 같은 Pad Designator 순서로 배치할 수 있습니다.
- 숫자(1, 3, 5)
- 알파벳(A, B, C)
- 영숫자 조합(A1 A2, 1A 1B, A1 B1 또는 1A 2A 등)
숫자로 증가시키려면 Text Increment 필드를 원하는 증가량으로 설정합니다. 알파벳으로 증가시키려면 Text Increment 필드를 원하는 이동 간격에 해당하는 순서의 알파벳 문자로 설정합니다. 예를 들어 첫 번째 Pad의 Designator가 1A인 경우, 필드를 A(알파벳의 첫 번째 문자)로 설정하면 Designator가 1씩 증가합니다. 필드를 C(알파벳의 세 번째 문자)으로 설정하면 Designator는 1A, 1D(A에서 세 글자 뒤), 1G 등의 순서가 됩니다.
점퍼 연결
점퍼 연결은 PCB에서 프리미티브로 물리적으로 배선되지 않은 컴포넌트 Pad 사이의 전기적 연결을 정의합니다. 이는 하나의 물리적 레이어에서 트랙을 가로질러 연결하기 위해 와이어를 사용하는 단면 보드에서 특히 유용합니다.
컴포넌트 내의 Pad에는 Properties 패널에서 Jumper 값을 지정할 수 있습니다. 동일한 점퍼와 전기적 Net을 공유하는 Pad는 물리적으로 연결되어 있지 않더라도 서로 유효하게 연결되어 있음을 시스템에 알립니다.
점퍼 연결은 PCB Editor에서 곡선 연결선으로 표시됩니다. 설계 Rule 검사기는 점퍼 연결을 미라우팅 Net으로 보고하지 않습니다.
비아 세부 정보
비아 속성 정의
각 비아 유형의 레이어 간 연결 범위(Z 평면) 요구 사항은 Layer Stack Manager의 Via Types 탭에서 정의되지만, 비아의 크기 속성은 다음과 같은 방식으로 정의됩니다.
-
배치된 비아를 Properties 패널에서 수동으로 편집하거나
-
비아를 수동으로 배치할 때(Place » Via) PCB 기본 프리미티브를 사용하거나
-
대화형 라우팅, ActiveRouting 또는 자동 라우팅 중에 비아를 배치하는 경우 라우팅 Via Style 설계 Rule을 사용합니다.
라우팅 Via Style Design Rule 구성
Main page: PCB 설계 Rule 정의, 적용 범위 설정 및 관리
대화형 라우팅, ActiveRouting 또는 자동 라우팅 중에 배치되는 비아의 크기 속성은 해당 라우팅 Via Style 설계 Rule에 따라 제어됩니다. 설계 Rule에서 비아를 대상으로 지정할 수 있도록 Rule 적용 범위(Where the Object Matches)에 사용할 수 있는 비아 관련 쿼리 키워드가 제공됩니다. 자세한 내용은 아래에 설명되어 있습니다.
라우팅 중에 레이어를 변경하면 소프트웨어는 레이어 변경의 시작 레이어와 종료 레이어를 확인하고 Layer Stack Manager에서 허용된 비아 유형을 선택합니다. 그런 다음 적용 가능한 라우팅 Via Style 설계 Rule 중 우선순위가 가장 높은 Rule을 식별하고, 해당 Rule의 Constraints 섹션에 있는 비아 크기 설정을 배치할 비아에 적용합니다.
예를 들어 TopLayer에서 S2로, 그리고 S2에서 S3로 레이어를 전환할 때는 µVia가 필요하고, 그 밖의 모든 레이어 전환에는 드릴 가공된 스루홀 비아가 필요한 DRAM_DATA Net 그룹이 있을 수 있습니다. 이 스루홀 비아 역시 다른 Net에 필요한 비아와 다를 수 있습니다. 이러한 경우에는 해당 DRAM_DATA Net을 대상으로 하는 라우팅 Via Style 설계 Rule 두 개를 생성하면 됩니다. 적합한 µVia 설계 Rule의 예가 아래에 나와 있습니다. 이미지 위에 커서를 올리면 스루홀 설계 Rule이 표시됩니다.

특정 비아 유형에 적용되도록 설계 Rule의 적용 범위를 설정할 수 있습니다.
라우팅 Via Style 설계 Rule의 적용 범위를 쉽게 설정할 수 있도록 다음과 같은 비아 관련 쿼리 키워드가 제공됩니다.
| Via Type Query | Returns |
|---|---|
| IsVia | 비아 유형에 관계없이 모든 비아 객체. |
| IsThruVia | 최상위 레이어에서 최하위 레이어까지 연결하는 모든 비아. |
| IsBlindVia | 표면 레이어에서 시작하여 내부 레이어에서 끝나는 비아 중 µVia가 아닌 모든 비아. |
| IsBuriedVia | 내부 레이어에서 시작하여 다른 내부 레이어에서 끝나는 비아 중 µVia가 아닌 모든 비아. |
| IsMicroVia | µVia 옵션이 활성화되어 있고 인접한 레이어를 연결하는 모든 비아. |
| IsSkipVia | µVia 옵션이 활성화되어 있고 2개 레이어에 걸쳐 연결하는 모든 비아. |
대화형 라우팅 중 비아 배치
대화형 라우팅 중에 레이어를 변경하면 소프트웨어가 비아를 자동으로 삽입합니다. 선택되는 비아는 다음에 따라 결정됩니다.
- 레이어 변경 시 연결할 레이어 범위에 사용할 수 있는 비아 유형.
- 해당 레이어 변경에 선택된 비아 유형에 적용되는 라우팅 Via Style 설계 Rule.
L1에서 L4로 레이어를 변경하는 동안 적층 µVia가 배치되는 모습입니다. Properties 패널의 Interactive Routing 모드에는 배치될 비아 유형이 표시됩니다. 6을 누르면 사용 가능한 비아 스택이 순환 선택되고, 8을 누르면 사용 가능한 비아 스택 목록이 표시됩니다.
대화형 라우팅 중 배치되는 비아 제어
-
라우팅 레이어를 변경하면 소프트웨어가 해당 레이어 연결 범위에 가장 적합한 비아 유형을 자동으로 선택합니다.
-
사용할 수 있는 비아 유형 또는 조합(비아 스택)이 여러 개인 경우 6 단축키를 누르면 해당 레이어 변경에 사용할 수 있는 모든 비아 스택을 대화형으로 순환 선택할 수 있으며, 8 단축키를 누르면 목록이 표시됩니다. 비아 스택은 µVia 사용, Skip µVia 사용, 블라인드 비아 사용, 스루홀 비아 사용 순서로 제시됩니다. 레이어 변경 범위가 한 레이어를 초과하고 적합한 비아 유형이 정의되어 있으면 적층 비아를 배치할 수 있습니다. 위 이미지와 같이 제안된 비아 유형은 상태 표시줄과 헤드업 디스플레이에 [µVia 1:2, µVia 2:3, µVia 3:4] 등의 형식으로 자세히 표시됩니다.
-
마지막으로 사용한 비아 스택은 다음에 라우팅할 Net의 기본값으로 유지됩니다. 기본 비아 스택은 현재 편집 세션 동안에만 유지됩니다.
-
비아 크기 속성은 적용 가능한 라우팅 Via Style 설계 Rule에 의해 지정됩니다. 적합한 라우팅 Via Style 설계 Rule을 정의하는 방법은 위에서 설명했습니다.
-
레이어를 변경하는 동안 비아 크기를 대화형으로 변경하려면 4 단축키를 누릅니다. 그러면 비아 크기 모드가
Rule Minimum,Rule Preferred,Rule Maximum,User Choice순으로 순환 선택됩니다. 현재 비아 크기 모드는 위 이미지와 같이 헤드업 디스플레이와 상태 표시줄에 표시됩니다. User Choice를 선택한 경우 Shift+V을 눌러 Choose Via Sizes 대화 상자를 열고 원하는 비아 크기를 선택합니다. 대화 상자에 표시되는 사용 가능한 비아 크기 목록은 설계에서 이미 사용된 비아 목록을 기반으로 합니다. 이 비아들은 PCB 패널의 Pad 및 비아 템플릿 모드에서 확인할 수 있습니다.적용 가능한 라우팅 Via Style 설계 Rule에서 Template preferred 모드를 사용하는 경우 4 단축키를 누르면 활성화된 비아 템플릿이 순환 선택됩니다.
-
위와 같이 제안된 비아 유형의 측면도가 Properties 패널에 표시됩니다.
-
비아를 배치하고 동일한 레이어에서 라우팅을 계속하려면 2 단축키를 누릅니다.
-
비아를 배치하고 이 연결의 라우팅을 일시 중단하려면 숫자 키패드에서 / 단축키를 누릅니다.
-
라우팅 중인 Net을 내부 전원 평면에 연결해야 하는 경우 숫자 키패드의 / 키를 눌러 적절한 전원 평면에 연결되는 비아를 배치합니다. 이 기능은 Any Angle 모드를 제외한 모든 Track 배치 모드에서 작동합니다.
-
라우팅 중 Shift+F1을 누르면 해당 명령에서 사용할 수 있는 모든 단축키 메뉴가 표시됩니다.
적층 비아 작업
-
연속적인 연결을 형성하는 적층 비아는 하나의 비아처럼 다룰 수 있습니다. 적층 비아에서 click and drag하면 연결된 라우팅과 함께 모든 비아를 이동할 수 있습니다.
-
한 번 클릭하면 적층 구조의 맨 위 비아가 선택됩니다. 마우스를 움직이지 않고 계속 한 번씩 클릭하면 적층 구조의 다른 비아가 차례로 선택됩니다.
-
Ctrl+Click and drag하면 선택한 비아만 연결된 라우팅과 함께 이동합니다.
-
적층 구조의 모든 비아를 선택하려면 한 번 클릭하여 비아 하나를 선택한 다음, Tab을 눌러 해당 적층 구조의 모든 비아가 포함되도록 선택 범위를 확장합니다.
비아 표시 설정
비아 작업에 도움이 되는 여러 표시 기능을 사용할 수 있습니다.
비아 색상
비아 색상은 View Configuration 패널에서 설정합니다. 비아의 구리 링은 Layers 섹션의 현재 Multi-Layer 설정에 따라 표시됩니다. 비아 홀 색상은 System Colors 섹션의 Via Holes 설정에 따라 표시됩니다. 원하는 설정의
을 전환하여 홀 표시를 비활성화할 수도 있습니다.

첫 번째 이미지에는 관통 비아가 표시되어 있습니다. 두 번째 이미지의 비아는 블라인드 비아이며, 홀은 시작 및 끝 레이어의 색상으로 표시됩니다.
비아와 솔더 마스크
PCB 편집기에서는 기본적으로 Multi-Layer를 항상 최상위 레이어로 표시합니다. 이 때문에 솔더 마스크 레이어의 내용을 정확히 확인하기 어려울 수 있습니다. 특히 패드나 비아에 음수 마스크 확장값을 사용하면 솔더 마스크 레이어의 내용이 멀티레이어 객체 아래에 가려집니다. Preferences 대화 상자의 PCB Editor – Display 페이지에서 레이어 그리기 순서를 변경하면 이 문제를 해결할 수 있습니다. 현재 레이어가 최상위 레이어로 그려지도록 설정합니다.
현재 레이어가 맨 위에 표시되도록 레이어 그리기 순서를 변경한 후 Top Solder를 현재 레이어로 설정하면, 아래 이미지와 같이 마스크 개구부가 정확하게 표시됩니다. 녹색 화살표는 왼쪽 비아의 솔더 마스크 개구부 크기, 가운데 마스크 개구부가 축소된 패드, 오른쪽 개구부가 확장된 패드를 보여줍니다.

솔더 마스크 개구부를 확인할 수 있도록 표시 설정을 구성합니다.
적층 비아 표시
적층 비아가 있는 경우, 표시되는 숫자는 적층 구조에 있는 모든 비아의 시작 및 끝 레이어를 나타냅니다. 아래 이미지 위에 커서를 올리면 비아가 3D로 표시됩니다. 이미지 오른쪽에는 비아 세 개가 적층되어 있습니다.
비아가 걸쳐 있는 레이어를 비아에 표시할 수 있습니다. 커서를 올리면 비아가 3D로 표시됩니다.
기타 비아 표시 설정
비아에 비아 Net 이름과 비아가 걸쳐 있는 레이어 번호를 표시하려면, View Configuration 패널의 View Options 탭에 있는 Additional Options 영역에서 Via Nets 및 Via Span 옵션을 각각 활성화합니다.
Pad 및 비아 홀 탐색
PCB 패널의 Hole Size Editor 모드에서는 세 개의 주요 영역이 위에서부터 다음 내용을 표시하도록 변경됩니다.
- 홀 유형과 상태에 대한 일반 필터링 및 현재 보드에 정의된 레이어 드릴 쌍을 표시하는 하위 섹션.
- Unique Holes 크기와 형상에 따라 그룹으로 정렬된 항목.
- 각 홀 객체 그룹을 구성하는 개별 Pads/Vias.

패널의 각 섹션에는 홀 유형, 스타일 및 상태에 누적 적용된 필터링 결과가 표시됩니다.
패널의 Unique Holes 영역에서 해당 열의 셀에 값을 입력하여 홀 그룹을 일괄 편집할 수 있습니다. Hole Size 열에 숫자 값을 입력하면 패드와 비아의 현재 홀 크기를 변경할 수 있습니다.

동일한 홀 스타일 6개로 구성된 선택 그룹의 홀 크기 편집.
해당되는 경우 홀의 Hole Length, Hole Type 및 Plated 항목도 변경할 수 있습니다.

동일한 홀 스타일 6개로 구성된 선택 그룹의 홀 유형 변경.
선택한 홀 그룹에 속하는 개별 패드/비아 객체는 PCB 패널 하단의 Pad/Via 섹션에 나열됩니다. 목록에서 객체를 마우스 오른쪽 버튼으로 클릭한 후 Properties을 선택하거나 항목을 직접 두 번 클릭하면, 해당 프리미티브에 대한 Properties 패널의 관련 모드가 열리며 속성을 확인하고 편집할 수 있습니다.
PCB의 현재 드릴 심볼 데이터로 PCB 패널의 Hole Size Editor 모드를 업데이트하려면, 이 모드에서 패널 영역을 마우스 오른쪽 버튼으로 클릭하고 Refresh 명령을 선택합니다.
백 드릴링 지원
PCB 패널의 Hole Size Editor 모드를 사용하여 백 드릴링 대상 패드와 비아를 확인할 수도 있습니다. 백 드릴 레이어 쌍은 Layer Pairs 목록에 표시되며, [BD] 텍스트가 추가되어 구분됩니다.
백 드릴 홀 크기를 선택하면 객체의 Kind이 Backdrill로 표시됩니다. 이 기능을 사용하여 백 드릴링된 홀을 빠르게 찾아 확인할 수 있습니다. 백 드릴 설정은 패널에서 편집할 수 없습니다.
백 드릴 보고서
모든 백 드릴 작업에 대한 보고서를 생성하려면 Unique Holes 목록을 마우스 오른쪽 버튼으로 클릭한 후 컨텍스트 메뉴에서 Backdrill Report을 선택합니다.
보고서에는 위치, 드릴 크기 및 드릴 깊이를 포함하여 각 백 드릴 작업의 세부 정보가 표시됩니다.
카운터홀 지원
PCB 패널의 Hole Size Editor 모드를 사용하여 카운터홀 기능이 활성화된 패드를 확인할 수도 있습니다. PCB 설계에 한쪽 또는 양쪽의 카운터홀(카운터보어/카운터싱크) 기능이 활성화된 패드 객체가 있으면, 관련 Counterholes Top 및/또는 Counterholes Bottom 그룹이 Layer Pairs 목록에 표시됩니다. Counterhole Depth 및 Counterhole Angle 열은 Unique Holes에 표시할 수 있습니다. Panel의 Region. 카운터홀 설정은 Panel에서 편집할 수 없습니다.

설계의 카운터홀 정보는 PCB Panel의 Hole Size Editor 모드에 표시됩니다.









