3D PDF 파일 준비하기

개요

Altium Designer의 PDF3D Export 기능을 사용하여 PCB 설계의 인터랙티브 3D 뷰를 제조업체, 조립업체 및 고객과 공유하세요. 이 문서에서는 3D PDF를 생성하고, 포함할 설계 콘텐츠와 표시 방식을 구성하고, Adobe Acrobat Reader에서 Export한 보드를 살펴보는 방법을 설명합니다. 계속 읽고 공유 대상이 확인해야 할 내용에 맞춘 3D PDF를 준비해 보세요.

- PDF3D Export 기능에 접근하고 형상, 색 구성표, 초기 뷰를 설정하는 방법과 필요에 따라 저장된 키 프레임 뷰를 사용하는 방법을 알아보세요.
- 포함된 설계 콘텐츠가 파일 크기와 보기 성능에 어떤 영향을 미치는지 이해해 보세요.
- Acrobat Reader의 3D 도구 모음과 모델 트리를 활용하여 보드를 탐색하고, 부품과 네트를 강조 표시하고, 표시 여부를 제어하는 방법을 알아보세요.
AI로 더 깊이 알아보기:

Altium Designer 사용자는 오랫동안 완전히 렌더링된 3D로 PCB 설계를 대화형으로 볼 수 있는 기능을 활용해 왔습니다. 이 기능을 통해 보드 설계의 실제 구조와 컴포넌트, 관련 기구 부품을 고유한 시각으로 파악할 수 있습니다.

이러한 3D 기능을 제작 및 조립 업체는 물론 고객처럼 직접적인 설계 팀 외부에 있는 사람들에게도 제공하면 상당한 이점이 있습니다. Altium Designer의 3D PDF 내보내기 기능을 사용하면 이를 실현할 수 있습니다. 널리 사용되는 Adobe® Acrobat® Reader의 최신 버전이 있으면 누구나 이 대화형 3D 형식을 이용할 수 있습니다.

Adobe Reader에서 내보낸 3D 설계를 대화형으로 확인하세요. 확대/축소하고 회전하며, 표시할 설계 요소를 선택할 수 있습니다.
Adobe Reader에서 내보낸 3D 설계를 대화형으로 확인하세요. 확대/축소하고 회전하며, 표시할 설계 요소를 선택할 수 있습니다.

특정 각도에서 바라본 보드 3D 설계의 고정 뷰와 달리, 내보낸 3D PDF 형식은 개념적으로 Altium Designer의 대화형 3D Layout Mode와 동일합니다. 따라서 내보낸 3D PDF는 동일한 회전, 확대/축소 및 화면 이동 기능과 각 컴포넌트 및 Net에 대한 북마크를 제공하며, 미리 정의된 여러 색상 구성표 중 하나를 적용할 수 있습니다.

Altium Designer에서 3D PDF 내보내기 기능을 사용하려면 PDF3D Exporter 소프트웨어 확장이 설치되어 있어야 합니다. 이 확장은 기본적으로 Altium Designer와 함께 설치됩니다. 수동으로 설치하거나 제거할 수도 있습니다.

확장 관리에 대한 자세한 내용은 Extending Your Installation 페이지(Altium Designer Develop, Altium Designer Agile, Altium Designer)를 참조하세요.

Acrobat Reader의 3D

Acrobat Reader 버전 7부터 고급 3D 보기 기능이 도입되면서 PDF 파일에서 대화형 3D 보기가 가능해졌습니다. 이후 Acrobat Reader 버전에서 기능이 지속적으로 개선되었으며, Altium Designer의 3D PDF 내보내기가 제공하는 높은 수준의 세부 표현과 Configuration 옵션은 버전 9 이상과 호환됩니다.

이 새로운 3D 기능은 업계에서 개발한 컴퓨터 그래픽 파일 형식인 Universal 3D(U3D)를 기반으로 합니다. 이 형식은 유럽 컴퓨터 제조업체 협회(ECMA)에 의해 표준 ECMA-363 - 범용 3D 파일 형식으로 표준화되었습니다. U3D는 PDF 형식에서 기본적으로 지원되며, PDF 파일에 간단히 포함하고 압축하여 Acrobat Reader에서 대화형 3D 보기를 제공할 수 있습니다.

그 결과, 전용 3D 보기 소프트웨어가 필요 없고 파일 크기가 비교적 작으며 여러 플랫폼에서 사용할 수 있는 3D 파일 형식이 구현됩니다. Altium Designer에서 내보낸 3D PDF 파일에는 모든 트랙, 패드, 비아, 폴리곤 등을 비롯해 모든 컴포넌트와 전체 보드 레이어 등 Altium Designer 자체 3D 뷰에서 볼 수 있는 데이터 대부분이 포함됩니다.

PDF 생성

3D PDF 파일을 내보내려면 설계 공간에서 원하는 PCB 설계 문서를 열고 메인 메뉴에서 File » Export » PDF3D 명령을 선택하세요. 현재 PCB Editor 보기 모드가 2D인지 3D인지에 관계없이 3D PDF 파일은 3D 형식으로 생성됩니다.

특정 각도에서 바라본 보드 3D 설계의 고정 뷰와 달리, 새로운 3D PDF 내보내기는 개념적으로 Altium Designer 자체의 대화형 3D 뷰와 동일합니다.

따라서 내보낸 3D PDF는 동일한 회전, 확대/축소 및 화면 이동 기능을 제공하며, 활성 View Configuration에 정의된 색상 구성표 중 어느 것이든 적용할 수 있습니다. 현재 Configuration과 내보낼 PDF에 사용할 수 있는 렌더링 색상을 확인하거나 편집하려면 보드를 3D 보기로 전환하고(키보드 단축키: 3) View Configuration Panel을 여세요. 렌더링 색상은 Panel의 View Options 탭에 있는 3D Settings 섹션에서 확인할 수 있습니다.

Ctrl+D 키보드 단축키를 사용하면 View Configuration Panel의 View Options 탭에 빠르게 접근할 수 있습니다.

현재 PCB Editor 보기 모드가 2D인지 3D인지에 관계없이 3D PDF 파일은 3D 형식으로 생성됩니다.

Export 옵션

3D PDF 내보내기를 시작하고(File » Export » PDF3D) 표준 Windows 기반 Export File 대화 상자에서 타겟 파일 이름과 위치를 지정하면, Export 3D 대화 상자가 열립니다. 여기에서 PDF의 렌더링, 동작 및 포함할 설계 내용을 정의할 수 있습니다.

Export 3D 대화 상자에서는 내보낸 PDF의 표시 방식과 동작을 설정할 수 있습니다.
Export 3D 대화 상자에서는 내보낸 PDF의 표시 방식과 동작을 설정할 수 있습니다.

Export 3D 대화 상자에서 필요에 따라 Export 옵션을 설정한 다음 Export 버튼을 클릭하여 3D PDF 파일을 생성합니다.

3D 파일은 형식 자체의 데이터 압축 기능을 사용하더라도 크기가 클 수 있으므로, 타겟 사용자에게 어떤 수준의 설계 콘텐츠가 중요한지 고려해야 합니다. 예를 들어, 보드 설계의 기구적 측면을 검토하는 사용자에게는 구리 레이어의 콘텐츠(트랙, 패드 등)가 필요하지 않을 수 있습니다.

  • Acrobat Reader에서는 사용자가 필요에 따라 모델 요소의 표시 여부를 그룹별로 또는 개별적으로 전환할 수 있습니다. 아래 내용을 참조하십시오.

  • Export 3D 대화 상자에서 Use 3D Movie views 옵션을 선택하면 PCB 문서에 정의된 키 프레임을 3D PDF Export에 포함할 수 있습니다. 3D PDF 문서로 Export된 키 프레임은 Acrobat Reader에서 선택 가능한 보기로 제공됩니다.

포함할 3D 콘텐츠를 선택할 때는 열람자 PC의 3D 렌더링 성능도 고려하는 것이 좋습니다. 생성된 3D PDF 파일의 크기가 적당하더라도 타겟 컴퓨터의 CPU와 그래픽 시스템으로는 복잡한 다중 레이어 설계를 원활하게 렌더링하기 어려울 수 있습니다.

위 옵션은 Acrobat Reader에서 PDF를 열 때 적용되는 초기 설정을 정의하며, Reader의 3D 도구 모음에서 원하는 대로 쉽게 변경할 수 있습니다. 3D PDF Export 옵션에서 도구 모음을 비활성화하면 사용자가 보기를 변경할 수 없다는 점에 유의하십시오.

3D PDF 보기

예상할 수 있듯이 Acrobat Reader에서 3D PDF를 보는 방법은 매우 간단합니다. 명령과 메뉴는 익숙한 2D 기능을 자연스럽게 확장한 형태로 제공됩니다.

플로팅 3D 도구 모음에서 기능을 선택한 후 간단한 마우스 드래그와 스크롤 휠 조작으로 3D 객체를 이동, 확대/축소 및 회전할 수 있습니다.

Acrobat의 3D 도구 모음은 3D 탐색과 조명/보기 설정을 위한 컨트롤을 제공합니다.
Acrobat의 3D 도구 모음은 3D 탐색과 조명/보기 설정을 위한 컨트롤을 제공합니다.

Reader에서 특히 유용한 기능은 Model Tree 탐색 창입니다. 이 창이 아직 열려 있지 않다면 버튼으로 열 수 있습니다. 이 창에서 3D PDF의 모든 객체를 탐색하고, 관심 있는 객체를 선택하여 강조 표시하며, 표시 여부를 전환할 수 있습니다.


모델 트리 탐색 창은 특히 유용합니다.
특정 컴포넌트와 Net의 표시를 제어할 수 있습니다.

Model Tree 탐색 창은 3D 설계의 모든 측면을 매우 세밀하게 검토할 수 있는 강력한 수단을 제공합니다. 컴포넌트의 배치와 레이아웃을 면밀히 살펴보거나 보드 내부 구조를 자세히 검사할 때 탐색 트리를 사용하여 해당 객체를 찾아 표시할 수 있습니다.

컴포넌트와 보드 오버레이의 선택을 해제한 상태로 표시된 설계입니다. Acrobat Reader에서 가능한 3D 제어 수준을 보여줍니다.
컴포넌트와 보드 오버레이의 선택을 해제한 상태로 표시된 설계입니다. Acrobat Reader에서 가능한 3D 제어 수준을 보여줍니다.

Model Tree 창에서 개별 객체를 선택하면 창 상단에 정의된 색상(이 예에서는 빨간색)으로 보기 창에 강조 표시됩니다. 따라서 특정 컴포넌트나 Net을 쉽게 찾을 수 있으며, 위치를 찾기 위해 객체의 표시 여부를 전환할 필요가 없습니다. 마찬가지로 3D 보기 창에서 객체를 선택하면 Model Tree 창에서 해당 Entry가 강조 표시됩니다.

Acrobat Reader의 다양한 컨트롤, 기능 및 설정 사용에 대한 자세한 내용은 관련 Adobe 도움말을 참조하십시오. PDF에서 3D 모델 표시.

Altium Designer의 기본 설계 메타데이터도 Export된 3D PDF 문서에 포함됩니다. 이 데이터에는 설계 소스 파일, 작성자, Altium Designer 버전, 생성/수정 날짜 등이 포함됩니다. Adobe Reader의 Document Properties 대화 상자에 있는 Description 탭에서 이 정보를 확인할 수 있습니다. – File » Properties.

3D PDF OutJob Export

프로젝트 OutJob에 3D PDF 파일 Export를 포함하려면 Documentation Outputs Entry 아래의 Add New Documentation Output를 클릭하고 PDF3D을 선택한 다음 원하는 문서 소스를 선택합니다. Export할 특정 PCB 문서를 선택하거나, OutJob을 범용으로 재사용할 수 있도록 [PCB Document]을 선택합니다.

Output 작업 Configuration 파일에 PDF3D Output 생성기를 추가하는 모습입니다.Output 작업 Configuration 파일에 PDF3D Output 생성기를 추가하는 모습입니다.

Output 생성기의 Entry를 선택하고 마우스 오른쪽 버튼을 클릭한 다음 컨텍스트 메뉴에서 Configure을 선택하면 3D PDF 생성 설정을 미리 구성할 수 있습니다. 그러면 앞서 설명한 Export 3D Configuration 대화 상자가 열립니다.

Output 작업이 실행되거나 수동으로 시작되면 OutJob의 Output Containers 섹션에 정의된 대로 3D PDF 파일이 Export됩니다. 파일은 설정된 워크스페이스와 경로 또는 Preferences 대화 상자의 데이터 관리 – 게시 대상 페이지에 정의된 로컬/원격 게시 타겟으로 Export됩니다.

설정된 OutJob에서 지정된 PDF Output 컨테이너로 3D PDF 파일을 생성하는 모습입니다.
설정된 OutJob에서 지정된 PDF Output 컨테이너로 3D PDF 파일을 생성하는 모습입니다.

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents