회로도 시트에 번호 매기기
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
개요
- 시트 번호 지정 도구에 접근하는 위치, SheetNumber, DocumentNumber, SheetTotal을 편집하는 방법, 자동 번호 지정을 활성화하거나 비활성화해야 하는 경우를 알아보세요.
- 논리적 회로도 시트의 번호 지정과 컴파일된 시트 인스턴스의 어노테이션 간 차이점, 그리고 각각의 정보가 저장되고 표시되는 방식을 이해하세요.
- =SheetNumber와 같은 특수 문자열을 표제란, 인쇄 출력, 프로젝트 데이터에 사용하여 지정한 번호를 반영하는 방법을 알아보세요.
프로젝트에서 Schematic 시트에 번호를 지정하면 시트 식별 번호를 관리하고 각 Schematic 문서에 파라미터로 저장할 수 있습니다. 그런 다음 특수 문자열 기능(=SheetNumber, =DocumentNumber, =SheetTotal)을 사용하여 이러한 값을 시트에 텍스트 개체로 표시할 수 있습니다(예: 시트의 타이틀 블록). 이 번호 지정은 컴포넌트 지정자가 아닌 Schematic 시트 지정자(번호)를 변경하므로, 일반적인 설계 어노테이션 개념과 관련이 있습니다.
시트 번호 지정
시트 번호 지정 기능에 액세스하려면 주 메뉴에서 Tools » Annotation » Number Schematic Sheets을 클릭하여 Sheet Numbering For Project 대화상자를 엽니다.

Sheet Numbering For Project 대화상자를 사용하여 프로젝트의 Schematic 시트에 번호를 지정하고 정리할 수 있습니다.
Sheet Numbering For Project 대화상자의 옵션 및 컨트롤
이 대화상자의 옵션과 컨트롤 대부분은 직관적이므로 추가 설명이 필요하지 않습니다. 설명이 필요한 항목은 아래에 나와 있습니다.
| SheetNumber DocumentNumber |
이 필드는 Grid에서 직접 편집할 수 있습니다. 한 번 클릭하여 셀에 포커스를 맞춘 다음 다시 클릭하여 편집 모드로 전환합니다. 마우스 오른쪽 버튼 클릭 메뉴의 명령을 사용하여 값을 복사/붙여넣기하거나 선택한 여러 셀을 편집할 수 있습니다. 여러 셀을 편집하려면 필요한 셀을 선택한 다음 셀 하나를 마우스 오른쪽 버튼으로 클릭하고 Edit 명령을 선택합니다. 새 값을 입력한 다음 Enter 키를 누르면 선택한 각 셀에 해당 값이 적용됩니다. |
| SheetTotal | 문서의 SheetTotal 문서 수준 파라미터의 현재 값입니다. 이 필드는 Update Sheet Count 버튼을 클릭하면 업데이트됩니다. |
| Automatic Sheet Numbering (Project Option) | 프로젝트의 Schematic 시트에 자동 번호 지정을 적용하려면 이 옵션을 활성화합니다. 이 옵션을 사용하면 시트 식별 번호를 관리하고 각 Schematic 문서에 파라미터로 저장할 수 있습니다. 이 옵션은 Project Options - Options 대화상자에서도 활성화할 수 있습니다. |
| Auto Sheet Number Auto Document Number |
선택한 번호 지정 체계/방식에 따라 시트/문서에 번호를 지정하려면 클릭합니다. 버튼의 드롭다운 화살표를 클릭하면 사용 가능한 번호 지정 옵션에 액세스할 수 있습니다.
|
| Update the Sheet Count | 현재 프로젝트의 총 시트 수를 집계하고 결과를 SheetTotal 열에 입력하려면 클릭합니다. 시트 수는 앞의 컨트롤에서 선택한 번호 지정 체계와 관계없이 프로젝트에 포함된 전체 시트의 수입니다. 이 필드에 액세스하려면 Automatic Sheet Numbering (Project Option) 옵션을 비활성화해야 합니다. |
Schematic 시트 번호 지정 및 Device Sheets
Device Sheets가 읽기 전용 상태(기본 상태)인 경우 시트 번호 또는 문서 번호를 설정할 수 없습니다. Sheet Numbering For Project 대화상자에서는 아래 이미지와 같이 업데이트할 수 없음을 나타내기 위해 교차 해칭으로 표시됩니다. Device Sheets를 편집 가능 상태로 설정하면 교차 해칭이 제거되고 일반적인 방식으로 번호를 지정할 수 있습니다.
자동 시트 번호 지정
자동 시트 번호 지정 기능은 Project Options 대화상자의 Options 탭에 있는 Automatic Sheet Numbering 옵션과 Sheet Numbering For Project 대화상자의 Automatic Sheet Numbering (Project Option) 옵션을 사용하여 활성화/비활성화할 수 있습니다. 자동 시트 번호 지정을 적용하려면 두 대화상자 중 하나에서만 옵션을 활성화하면 됩니다. 두 대화상자 모두에서 옵션을 비활성화하면 시트에 수동으로 번호를 지정할 수 있습니다.
위에서 언급한 옵션 중 하나가 활성화되어 있으면 Projects Panel에서 Schematic 시트에 자동 시트 번호 지정을 직접 적용할 수 있습니다. 번호를 변경하려면 Panel에서 Schematic 시트를 끌어다 놓습니다. 시트 번호는 Schematic 시트 이름 왼쪽에 표시됩니다.
컴파일된 시트 어노테이션
컴파일된 시트 어노테이션을 사용하면 시트 번호 지정 기능으로 논리적 시트의 번호 지정 방식을 제어하는 것과 유사하게, 컴파일된 시트(시트의 물리적 인스턴스)의 번호 지정 방식을 제어할 수 있습니다.
예를 들어, Input channel.SchDoc이라는 Schematic 문서가 포함된 설계를 생각해 보겠습니다. 해당 시트의 회로가 설계 내에서 8번 사용되므로, 설계를 컴파일하면 Input channel.SchDoc이 8번 인스턴스화됩니다(즉, 실제 PCB에 있는 회로의 각 인스턴스마다 한 번씩). 시트 번호 지정은 설계의 논리적 구조 내에서 Input channel.SchDoc 시트에 번호를 지정하는 데 사용됩니다. 컴파일된 시트 어노테이션은 설계의 물리적(컴파일된) 뷰에서 해당 시트의 개별 인스턴스에 번호를 지정하는 작업입니다.
컴파일된 시트 어노테이션은 Annotate Compiled Sheets 대화상자에서 수행하며, 주 메뉴에서 Tools » Annotation » Annotate Compiled Sheets 명령을 선택하여 이 대화상자에 액세스할 수 있습니다.
이 대화상자에는 현재 프로젝트의 컴파일된 모든 시트가 나열됩니다. Sheet Number 필드에 직접 입력하여 컴파일된 시트에 사용자 지정 이름을 만들 수 있습니다. 영숫자 또는 영숫자 이외의 문자를 자유롭게 조합한 다음 OK 을 클릭하여 사용자 지정 어노테이션을 적용합니다.
버튼 옆의 아래쪽 화살표를 클릭하여 표시되는 옵션을 선택한 후 Annotate Sheet 버튼을 클릭하여 시트에 어노테이션을 적용합니다. (필드에 대한 설명이 필요하면 시트 번호 지정 섹션을 참조하십시오.) 선택 사항에 맞게 SheetNumber 항목이 업데이트됩니다.
대화상자에서 업데이트한 시트 번호는 Projects Panel의 Settings\Annotation Documents 하위 폴더에 있는 프로젝트의 *.Annotation 파일에 저장됩니다. 따라서 프로젝트 편집 세션이 바뀌어도 어노테이션 정보와 설정이 유지됩니다.
보드 수준 어노테이션에서 컴파일된 시트 어노테이션 사용
컴파일된 시트에 Annotate Compiled Sheets 대화 상자를 통해 어노테이션을 지정하면, 보드 레벨 어노테이션 옵션 대화 상자의 명명 규칙에 $SheetNumber 키워드를 사용할 수 있습니다. 프로젝트의 컴파일된 시트에 아직 어노테이션을 지정하지 않은 경우, 기본적으로 Sheet Numbering For Project 대화 상자에 정의된 시트 번호가 사용됩니다.
프로젝트에서 컴파일된 시트 어노테이션 사용하기
컴파일된 시트에 어노테이션을 지정한 후에는 프로젝트에 SheetNumber 특수 문자열을 배치하여 이 정보를 참조할 수 있습니다.
-
특수 문자열은 항상 표시되며, 값이 null이면 파라미터 이름이 표시됩니다.
-
컴파일된 시트 어노테이션 값을 사용하려면 값이
=SheetNumber인 특수 문자열을 배치하세요. 파라미터 속성 값, 텍스트 문자열, Net 레이블 등에 특수 문자열을 사용할 수 있습니다. -
대화 상자에서 할당된 시트 번호는 =SheetNumber 특수 문자열을 사용하여 컴파일된(Physical) 시트의 인쇄 출력물에서 참조할 수 있습니다. 그러면 설계의 모든 인쇄 출력물에 해당 값이 반영됩니다.

