회로도 편집기 및 회로도 라이브러리 편집기 바로 가기
개요
- 키보드 조합과 마우스 동작을 포함한 Altium Designer 단축키 표기 방식에 대한 명확한 개요.
- 편집, 선택, 이동, 정렬, 탐색, 보기 등 일반적인 Schematic 작업에 사용하는 단축키를 범주별로 정리한 목록.
- Schematic 및 Schematic Library 편집기에서 Grid 제어, 텍스트 검색, 주요 Panel 열기에 빠르게 활용할 수 있는 참고 자료.
다음 섹션에서는 Schematic 편집기 및/또는 Schematic 심볼 편집기 전용 단축키를 소개합니다. 단축키 접근 및 편집, 일반적인 Altium 환경 단축키, 액셀러레이터 키를 포함한 단축키 관련 일반 정보는 Altium Designer 단축키를 참조하세요.
단축키 목록을 볼 때 다음 사항에 유의하세요.
- 단축키에서 더하기(+) 기호는 표시된 순서대로 키보드의 여러 키를 누른 상태로 유지한다는 의미입니다. 예를 들어, Shift+F1는 Shift 키를 누른 상태에서 F1 키를 누르는 것을 의미합니다. 마찬가지로 Shift+Ctrl+PgUp는 Shift 키를 누른 상태에서 Ctrl 키도 함께 누른 채 PgUp 키를 누르는 것을 의미합니다.
- 표준 마우스 버튼을 사용하는 경우, Click 는 마우스 왼쪽 버튼을 한 번 클릭하는 것을, Double-Click는 마우스 왼쪽 버튼을 두 번 클릭하는 것을, Right-Click는 마우스 오른쪽 버튼을 한 번 클릭하는 것을 의미합니다.
표준 단축키
다음은 Schematic 편집기 및/또는 Schematic 심볼 편집기의 표준 단축키입니다. 일반적으로 사용할 수 있으며, 대화형 작업을 수행 중이지 않아도 사용할 수 있습니다.
General Editing |
|
| Double-Click | 현재 커서 아래에 있는 객체의 속성을 수정합니다. |
| Right-Click | 설계 공간 또는 현재 커서 아래에 있는 객체의 컨텍스트 메뉴를 엽니다. 대화형 명령을 실행 중인 경우 현재 작업을 종료합니다. |
| F2 | 선택한 텍스트 객체를 제자리에서 편집합니다(직접 편집). |
| Ctrl+C | 선택 항목 복사 |
| Ctrl+X | 선택 항목 잘라내기 |
| Ctrl+V | 선택 항목 Paste |
| Ctrl+R | 선택한 객체를 복사하여 설계 공간의 필요한 위치에 반복해서 붙여넣습니다(러버 스탬핑). |
| Shift+Ctrl+V | 스마트 Paste 대화 상자를 엽니다. |
| Delete | 선택 항목 삭제 |
| Ctrl+Z | 실행 취소 |
| Ctrl+Y | 다시 실행 |
Selecting |
|
| Shift+F | 유사 객체 찾기 기능을 실행합니다(기준 템플릿으로 사용할 객체를 클릭). |
| Click | 현재 커서 아래에 있는 객체를 선택하거나 선택 해제합니다. |
| Shift+Click | 다른 객체의 선택 상태에 영향을 주지 않고 현재 커서 아래에 있는 객체의 선택 상태를 변경합니다. |
| Shift+Ctrl+X | 교차 선택 모드를 켜거나 끕니다. |
| Shift+Ctrl+Y | 교차 선택 모드의 Reposition selected component in PCB 옵션을 켜거나 끕니다. |
| Ctrl+A | 현재 문서의 모든 객체를 선택합니다. |
| Alt+Click | Net 객체 위에서 사용하면 해당 객체를 선택하고, 활성 설계 프로젝트의 모든 시트에서 해당 Net에 연결된 모든 객체를 강조 표시합니다. |
| Click (객체가 없는 곳에서), Hold&Drag (왼쪽에서 오른쪽으로) | 선택 영역 안에 완전히 포함된 모든 객체를 선택합니다. |
| Click (객체가 없는 곳에서), Hold&Drag (오른쪽에서 왼쪽으로) | 선택 영역 안에 완전히 포함되거나 선택 영역의 경계에 닿는 모든 객체를 선택합니다. |
| Ctrl+n (n = 1 ~ 8) | 현재 선택 항목을 메모리 위치 n에 저장합니다. |
| Alt+n (n = 1 ~ 8) | 메모리 위치 n에서 선택 항목을 불러옵니다. |
| Shift+n (n = 1 ~ 8) | 현재 선택 항목을 메모리 위치 n에 이미 저장된 선택 항목에 추가합니다. |
| Alt+Shift+n (n = 1 ~ 8) | 메모리 위치 n에서 선택 항목을 불러와 설계 공간의 현재 선택 항목에 추가합니다. |
| Shift+Ctrl+n (n = 1 ~ 8) | 메모리 위치 n에 저장된 선택 항목을 기준으로 필터링을 적용합니다. |
Moving |
|
| Click (객체 위에서), Hold&Drag | 현재 커서 아래에 있는 단일 객체를 이동합니다(해당 객체가 선택된 객체 그룹에 속하는 경우 해당 그룹을 이동). Always Drag 옵션이 활성화되어 있으면(Preferences 대화 상자의 Schematic - Graphical Editing 페이지에서 설정), 이 단축키를 사용하여 전기적 객체를 이동할 때 다른 전기적 객체와의 연결이 유지됩니다. |
| Ctrl+Click, Hold&Drag | 현재 커서 아래에 있는 단일 객체를 이동합니다(해당 객체가 선택된 객체 그룹에 속하는 경우 해당 그룹을 이동). Always Drag 옵션이 비활성화되어 있으면(Preferences 대화 상자의 Schematic - Graphical Editing 페이지에서 설정), 이 단축키를 사용하여 전기적 객체를 이동할 때 다른 전기적 객체와의 연결이 유지됩니다. |
| Left Arrow | 현재 문서의 설계 공간에서 커서를 Snap Grid 1단위씩 왼쪽으로 이동합니다. |
| Shift+Left Arrow | 현재 문서의 설계 공간에서 커서를 Snap Grid 10단위씩 왼쪽으로 이동합니다. |
| Right Arrow | 현재 문서의 설계 공간에서 커서를 Snap Grid 1단위씩 오른쪽으로 이동합니다. |
| Shift+Right Arrow | 현재 문서의 설계 공간에서 커서를 Snap Grid 10단위씩 오른쪽으로 이동합니다. |
| Up Arrow | 현재 문서의 설계 공간에서 커서를 Snap Grid 1단위씩 위로 이동합니다. |
| Shift+Up Arrow | 현재 문서의 설계 공간에서 커서를 Snap Grid 10단위씩 위로 이동합니다. |
| Down Arrow | 현재 문서의 설계 공간에서 커서를 Snap Grid 1단위씩 아래로 이동합니다. |
| Shift+Down Arrow | 현재 문서의 설계 공간에서 커서를 Snap Grid 10단위씩 아래로 이동합니다. |
| Ctrl+Left Arrow | 현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 Snap Grid 1단위씩 왼쪽으로 이동합니다. |
| Shift+Ctrl+Left Arrow | 현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 Snap Grid 10단위씩 왼쪽으로 이동합니다. |
| Ctrl+Right Arrow | 현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 Snap Grid 1단위씩 오른쪽으로 이동합니다. |
| Shift+Ctrl+Right Arrow | 현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 Snap Grid 10단위씩 오른쪽으로 이동합니다. |
| Ctrl+Up Arrow | 현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 Snap Grid 1단위씩 위로 이동합니다. |
| Shift+Ctrl+Up Arrow | 현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 Snap Grid 10단위씩 위로 이동합니다. |
| Ctrl+Down Arrow | 현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 Snap Grid 1단위씩 아래로 이동합니다. |
| Shift+Ctrl+Down Arrow | 현재 문서의 설계 공간에서 현재 선택 항목(선택된 하나 이상의 설계 객체)을 Snap Grid 10단위씩 아래로 이동합니다. |
Aligning |
|
| Shift+Ctrl+L | 선택한 객체의 왼쪽 가장자리를 기준으로 정렬합니다. |
| Shift+Ctrl+R | 선택한 객체의 오른쪽 가장자리를 기준으로 정렬합니다. |
| Shift+Ctrl+H | 선택한 객체의 가로 간격을 동일하게 맞춥니다. |
| Shift+Ctrl+T | 선택한 객체의 위쪽 가장자리를 기준으로 정렬합니다. |
| Shift+Ctrl+B | 선택한 객체의 아래쪽 가장자리를 기준으로 정렬합니다. |
| Shift+Ctrl+V | 선택한 객체의 세로 간격을 동일하게 맞춥니다. |
| Shift+Ctrl+D | 선택한 객체를 현재 Snap Grid에서 가장 가까운 지점으로 이동합니다. |
| Spacebar | 선택 항목을 시계 반대 방향으로 90° 회전합니다. |
| Shift+Spacebar | 선택 항목을 시계 방향으로 90° 회전합니다. |
Viewing the Schematic |
|
| Ctrl+PgDn | 현재 문서의 모든 설계 객체를 표시합니다. |
| PgUp | 현재 커서 위치를 기준으로 확대합니다. 다음 방법 중 하나로 마우스를 사용하여 문서의 특정 영역을 확대할 수도 있습니다(지원 여부 및 마우스 버튼 할당 방식에 따라 다름).
|
| PgDn | 현재 커서 위치를 기준으로 축소합니다. 다음 방법 중 하나를 사용하여 문서의 특정 영역을 마우스로 축소할 수 있습니다(사용 가능 여부 및 마우스 버튼에 할당된 기능에 따라 다름).
|
| Mouse Wheel | 설계 공간 내에서 세로로 스크롤합니다. 이는 기본 설정이며, Preferences 대화 상자의 System - Mouse Wheel Configuration 페이지에서 변경할 수 있습니다. |
| Shift+Mouse Wheel | 설계 공간 내에서 가로로 스크롤합니다. 이는 기본 설정이며, Preferences 대화 상자의 System - Mouse Wheel Configuration 페이지에서 변경할 수 있습니다. |
| Shift+Ctrl+Mouse Wheel | 다중 채널 설계의 채널을 순환합니다. 마우스 휠을 위/아래로 굴리면 기본 설계 창 하단에 있는 다음/이전 컴파일된 채널 탭이 활성 탭이 됩니다. 이는 기본 설정이며, Preferences 대화 상자의 System - Mouse Wheel Configuration 페이지에서 변경할 수 있습니다. |
| Home | 명령을 실행하기 전에 커서가 가리키던 위치가 창 중앙에 오도록 기본 설계 창의 보기를 다시 그립니다. |
| End | 현재 문서를 다시 그리는 방식으로 화면을 새로 고쳐, 원치 않는 화면 갱신 잔상을 제거합니다. |
| Alt+End | 현재 문서의 현재 레이어를 다시 그려, 원치 않는 화면 갱신 잔상을 제거합니다. |
| Alt+F5 | 현재 문서의 Editor 표시를 최대화 상태와 최대화되지 않은 상태 간에 전환합니다. |
| F5 | Net Color Override 기능의 시각적 표시를 켜거나 끕니다. |
| Shift+C | 활성 문서에 현재 적용된 필터를 해제합니다. |
| Right-Click, Hold&Drag | 슬라이더(화면 이동) 손 모양 커서를 표시한 다음 드래그하여 설계 공간의 보기를 이동합니다. |
Grids |
|
| G | 미리 정의된 Snap Grid 설정을 순방향으로 순환합니다. |
| Shift+G | 미리 정의된 Snap Grid 설정을 역방향으로 순환합니다. |
| Shift+Ctrl+G | 현재 문서에서 표시되는 Grid를 켜거나 끕니다. |
| Ctrl+Shift | Grid를 일시적으로 비활성화합니다. |
| Shift+E | 커서의 전기적 Grid를 켜거나 끕니다. |
Finding Text |
|
| Ctrl+F | 텍스트를 찾습니다. |
| Ctrl+H | 텍스트를 찾아 바꿉니다. |
| F3 | 검색한 텍스트의 다음 항목을 찾습니다. |
Quick Panel Access |
|
| F11 | Properties Panel의 표시 여부를 전환합니다. |
| F12 | 상황에 따라 SCH Filter Panel 또는 SCHLIB Filter Panel의 표시 여부를 전환합니다. |
| Shift+F12 | 상황에 따라 List Panel(SCH List 또는 SCHLIB List Panel)의 표시 여부를 전환합니다. |
Commenting |
|
| Alt+Ctrl+C | 활성 Schematic 문서의 지점, 개체 또는 영역에 새 Comment 스레드를 추가합니다. Comment 기능을 사용하려면 먼저 관리형 프로젝트를 열고(체크아웃) 해당 프로젝트의 소스 Schematic 문서 중 하나에서 작업하고 있어야 합니다. |
Miscellaneous |
|
| Ctrl+Double-Click |
|
| Ctrl+L | 보드 레벨 어노테이션 대화 상자를 사용하여 Board Level Annotation 작업을 수행합니다. |
| Ctrl+W | 와이어 배치 모드로 들어갑니다. |
| Ctrl+Home | 현재 문서의 절대 원점 좌표(0,0)로 커서를 이동합니다. |
| Ctrl+Q |
|
| Ctrl+M | 현재 문서에서 임의의 두 지점 사이의 거리를 측정하고 표시합니다. |
| F9 | Simulation Dashboard Panel을 통해 현재 정의된 해석 및 관련 설정을 사용하여 활성 설계의 시뮬레이션을 실행합니다. 해당 설계의 시뮬레이션을 처음 수행하는 경우 기본 해석인 Operating Point, DC Sweep, Transient Analysis, AC Analysis이 각각의 기본 설정으로 실행됩니다. 이 경우 먼저 Simulation Dashboard Panel에서 시뮬레이션을 설정하는 것이 좋습니다. 이 단축키에 연결된 Run Simulation 명령은 Mixed Simulation 시스템 확장이 설치되어 있어야 사용할 수 있습니다. 이 확장을 설치하면 Schematic Editor에 Simulate 메뉴가 추가됩니다. 자세한 내용은 Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer)를 참조하십시오. |
| |
소스 문서에 머무른 상태에서 현재 Schematic 문서에서 선택한 개체를 PCB 문서의 해당 개체와 크로스 프로빙합니다(Continuous Mode). |
| |
현재 Schematic 문서에서 선택한 개체를 PCB 문서의 해당 개체와 크로스 프로빙하고 타겟 문서를 활성 문서로 전환합니다(Jump To Mode). |
대화형 단축키
다음 단축키는 새 설계 개체 배치 또는 기존 개체 이동과 같은 대화형 프로세스가 시작되면 사용할 수 있습니다. 사용 가능한 단축키는 대화형 명령과 해당 명령의 대상인 설계 개체에 따라 달라집니다.
| F1 | 사용 가능한 단축키 목록을 제공하고(이 대화 상자에서 단축키를 실행할 수는 없음), 현재 실행 중인 명령의 문서에 접근할 수 있는 Graphical Editing Hot key List 대화 상자를 엽니다. |
| Shift+F1 | 현재 실행 중인 대화형 명령의 현 단계에서 사용할 수 있는 모든 단축키가 나열된 메뉴를 엽니다. |
| Enter | 객체를 배치하거나 이동할 때 마우스의 Click 처럼 작동합니다. |
| PgUp | 확대합니다. |
| PgDn | 축소합니다. |
| End | 화면을 새로 고칩니다. |
| Home | 배치하거나 이동 중인 객체가 연결된 커서가 설계 창 중앙에 오도록 화면을 변경합니다. |
| Left Arrow | 현재 문서 워크스페이스에서 배치하거나 이동 중인 객체가 연결된 커서를 Snap Grid 1단위씩 왼쪽으로 이동합니다. |
| Shift+Left Arrow | 현재 문서 워크스페이스에서 배치하거나 이동 중인 객체가 연결된 커서를 Snap Grid 10단위씩 왼쪽으로 이동합니다. |
| Right Arrow | 현재 문서 워크스페이스에서 배치하거나 이동 중인 객체가 연결된 커서를 Snap Grid 1단위씩 오른쪽으로 이동합니다. |
| Shift+Right Arrow | 현재 문서 워크스페이스에서 배치하거나 이동 중인 객체가 연결된 커서를 Snap Grid 10단위씩 오른쪽으로 이동합니다. |
| Up Arrow | 현재 문서 워크스페이스에서 배치하거나 이동 중인 객체가 연결된 커서를 Snap Grid 1단위씩 위로 이동합니다. |
| Shift+Up Arrow | 현재 문서 워크스페이스에서 배치하거나 이동 중인 객체가 연결된 커서를 Snap Grid 10단위씩 위로 이동합니다. |
| Down Arrow | 현재 문서 워크스페이스에서 배치하거나 이동 중인 객체가 연결된 커서를 Snap Grid 1단위씩 아래로 이동합니다. |
| Shift+Down Arrow | 현재 문서 워크스페이스에서 배치하거나 이동 중인 객체가 연결된 커서를 Snap Grid 10단위씩 아래로 이동합니다. |
| Tab | 대화형 작업을 일시 중지하고 Properties Panel의 관련 모드에 액세스하여 배치하거나 이동 중인 객체의 속성을 즉시 변경할 수 있습니다. Properties Panel이나 다른 대화 상자에서 Tab 을 계속 사용하면 Panel의 필드를 순서대로 이동합니다. |
| X | 배치하거나 이동 중인 객체를 X축을 기준으로 Mirror합니다. |
| Y | 배치하거나 이동 중인 객체를 Y축을 기준으로 Mirror합니다. |
| Alt | 최초 이동 방향에 따라 이동 방향을 수평축 또는 수직축으로 제한합니다. |
| Shift | 객체를 배치하거나 이동하면서 자동 패닝할 때 사용하면 더 빠르게 패닝할 수 있습니다. |
| Esc (또는 Right-Click) |
현재 프로세스, 즉 실행 중인 대화형 명령의 한 단계 또는 명령 자체를 종료합니다. |
| Spacebar |
|
| Shift+Spacebar |
|
| Ctrl+Spacebar | 전기적 객체를 드래그할 때 연결된 와이어, 버스 또는 Signal 하네스의 배선 모드를 변경합니다. |
| Insert |
|
| Click&Hold+Insert | 배치된 와이어, 선, 버스 또는 Signal 하네스의 선택된 세그먼트나 배치된 폴리곤의 가장자리에서 사용하여 해당 지점에 꼭짓점을 추가합니다. |
| Click&Hold+Delete | 배치된 와이어, 선, 버스, Signal 하네스 또는 폴리곤의 꼭짓점에서 사용하여 해당 꼭짓점을 제거합니다. |
| Backspace 또는 Delete | 와이어, 선, 버스, Signal 하네스 또는 폴리곤을 배치하는 동안 마지막으로 배치한 꼭짓점을 제거합니다. |
| + (숫자 키패드에서) | 현재 배치하거나 이동 중인 IEEE 심볼의 크기를 확대합니다. |
| - (숫자 키패드에서) | 현재 배치하거나 이동 중인 IEEE 심볼의 크기를 축소합니다. |
| S | 현재 선택하여 이동 중인 시트 Entry를 Parent 시트 심볼의 정반대 쪽으로 옮깁니다. |
| V | 선택한 시트 Entry를 두 개 이상 이동할 때 순서를 반대로 바꿉니다. |
| T |
팝업 메뉴 단축키
다음 단축키를 사용하면 설계 공간 내에서 직접 특정 명령 팝업 메뉴에 액세스할 수 있습니다. 이 중 일부는 Editor의 기본 메뉴에 있는 하위 메뉴이므로 익숙할 수 있습니다. 각 기본 메뉴에도 설계 공간 내에서 빠르게 액세스할 수 있는 팝업 키가 지정되어 있습니다. 자세한 내용은 액셀러레이터 키를 참조하세요.
| A | Align 하위 메뉴(기본 Edit 메뉴에 있음). |
| B | Toolbars 하위 메뉴 (기본 보기 메뉴에 있음). |
| J | Jump 하위 메뉴 (기본 Edit 메뉴에 있음). |
| K | Panels 하위 메뉴 (기본 보기 메뉴에 있음). |
| M | Move 하위 메뉴 (기본 Edit 메뉴에 있음). |
| O | 옵션 및 환경설정에 빠르게 액세스할 수 있는 팝업 메뉴입니다. |
| S | Select 하위 메뉴 (기본 Edit 메뉴에 있음). |
| X | DeSelect 하위 메뉴 (기본 Edit 메뉴에 있음). |
| Y | 필터링 명령이 있는 팝업 메뉴입니다. |
| Z | 확대/축소 명령이 있는 팝업 메뉴입니다. |