Harness Design
W skrócie
- Dowiesz się, jakie możliwości projektowania wiązek oferuje Altium Designer — od połączeń między pinami po dokumentację produkcyjną.
- Poznasz strukturę projektu wiązki, obejmującą schematy połączeń, rysunki rozmieszczenia, dane BOM, dokumenty Draftsman i zadania generowania plików wyjściowych.
- Dowiesz się, jak korzystać z projektów wiązek samodzielnie lub w ramach projektu wielopłytkowego, w tym jak je dodawać i nimi zarządzać.
Funkcjonalność projektowania wiązek przewodów umożliwia inżynierom różnych specjalności (zaangażowanym w proces projektowania produktu) pracę w Altium Designer. Zapewnia kompleksową obsługę projektowania wiązek w tym samym środowisku co projektowanie PCB i systemów, eliminując dotychczasową silną zależność od oprogramowania innych firm.
Funkcjonalność projektowania wiązek przewodów umożliwia utworzenie kompletnego projektu wiązki — od pojedynczych połączeń między pinami po dokumentację produkcyjną. Projekt wiązki można utworzyć jako samodzielny projekt lub jako część projektu wielopłytkowego. W tym drugim przypadku logiczne połączenia między płytkami PCB w projekcie wielopłytkowym określają połączenia w obrębie wiązki.
Struktura projektu wiązki przewodów
Nowy projekt wiązki przewodów (*.PrjHar) można utworzyć w taki sam sposób jak projekt PCB lub projekt wielopłytkowy. Wybierz polecenie File » New » Project z menu głównego, aby otworzyć okno dialogowe Create Project. Wybierz pozycję <Empty> lub dostępny szablon projektu pod pozycją Harness w obszarze Project Type okna dialogowego.
Projekt wiązki przewodów obsługuje następujące dokumenty:
-
Schemat połączeń wiązki (
*.WirDoc) — umieszcza się na nim poszczególne przewody i kable, aby utworzyć wymagane połączenia fizyczne w obrębie wiązki. -
Rysunek rozmieszczenia wiązki (
*.LdrDoc) — przewody i kable są rozmieszczane tak, aby odwzorować fizyczną konstrukcję wiązki. -
ActiveBOM (
*.BomDoc) — zawiera następujące elementy:-
Złącza i powiązane z nimi części
-
Części powiązane z połączeniami splatanymi
-
Części powiązane z punktami połączeń
-
Gniazda styków
-
Etykiety rozmieszczenia
-
Osłony wiązki
-
Przewody i kable wraz z ich długościami
-
-
Dokument Draftsman (
*.HarDwf) — importuje się do niego widoki schematu połączeń, rysunku rozmieszczenia i BOM przeznaczone tylko do odczytu, a następnie dodaje wszelkie dodatkowe informacje wymagane do produkcji wiązki. -
Plik Output Job (
*.OutJob) — za pomocą pliku Output Job można wstępnie skonfigurować zestaw wymaganych danych wyjściowych projektu wiązki. Każde wyjście ma własne ustawienia i format, na przykład zapis do pliku lub wydruk na drukarce. Ten sam plik Output Job skonfigurowany dla projektu wiązki można następnie wykorzystać ponownie w innych projektach, oszczędzając czas i nakład pracy potrzebne do przygotowania danych wyjściowych dla każdego nowego projektu.Dane wyjściowe obsługiwane w projekcie wiązki przewodów
Documentation Outputs
-
Wydruki schematu połączeń wiązki
-
Wydruki rysunku rozmieszczenia wiązki
-
Draftsman
Dowiedz się więcej o przygotowywaniu danych do druku
Report Outputs
-
Zestawienie materiałowe
-
Porównanie BOM
-
Dane produkcyjne
-
Eksport komentarzy
Dowiedz się więcej o przygotowywaniu raportów
Validation Outputs
-
Kontrole BOM
-
Stany komponentów
-
Zgodność konfiguracji
Dowiedz się więcej o przygotowywaniu raportów walidacji
PostProcess Outputs
-
Kopiowanie plików
Dowiedz się więcej o przygotowywaniu danych wyjściowych przetwarzania końcowego
-
Dodawanie projektu wiązki przewodów do projektu wielopłytkowego
Projekt wiązki przewodów może (ale nie musi) być częścią projektu wielopłytkowego. W tym celu otwórz projekt wielopłytkowy z dokumentem schematu zawierającym co najmniej jeden obiekt połączenia wiązki. Upewnij się, że definicja wiązki jest kompletna: przypisano elementy złączy wiązki, określono połączenia złączy wiązki ↔ pinów PCB oraz połączenia złączy wiązki ↔ złączy wiązki.
Dodaj projekt wiązki do projektu wielopłytkowego, klikając prawym przyciskiem myszy pozycję projektu wielopłytkowego w panelu Projects, wybierając Add Existing to Project, a następnie odszukując i wybierając lokalny plik *.PrjHar. Projekt wiązki pojawi się w panelu Projects w strukturze projektu wielopłytkowego.

Dodaj utworzony projekt wiązki do powiązanego projektu wielopłytkowego.
Tworzenie projektu wiązki – przykładowy przewodnik
Poniższe rozwijane sekcje zawierają instrukcje krok po kroku dotyczące tworzenia od podstaw prostego projektu wiązki składającego się z trzech elementów.
Tworzenie projektu wiązki
-
Wybierz polecenie File » New » Project z menu głównego.
-
Otworzy się okno dialogowe Create Project. W tym oknie:
-
Na liście Locations wybierz pozycję odpowiadającą Twojemu obszarowi roboczemu (lub pozycję Local Projects, jeśli nie korzystasz z obszaru roboczego).
-
Na liście Project Type wybierz pozycję <Empty> w kategorii Harness.
-
Wprowadź odpowiednią nazwę w polu Project Name, np.
Harness_Project. -
W razie potrzeby ustaw pozostałe opcje po prawej stronie okna dialogowego (np. folder zapisu).
-
-
Kliknij przycisk
w prawym dolnym rogu okna dialogowego, aby je zamknąć i utworzyć projekt.
Pozycja nowego projektu, Harness_Project.PrjPCB, pojawi się w panelu Projects.
Definiowanie schematu połączeń przewodów
Main page: Definiowanie schematu połączeń przewodów
-
Kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects, a następnie wybierz polecenie Add New to Project » Harness Wiring Diagram z menu kontekstowego. W obszarze projektowania otworzy się pusty arkusz schematu połączeń przewodów o nazwie
Harness Wiring Diagram1.WirDoc, a pozycja tego dokumentu pojawi się jako powiązana z projektem w panelu Projects pod pozycją Source Documents. -
Aby zapisać nowy dokument schematu połączeń przewodów lokalnie, wybierz polecenie Save As z menu otwieranego prawym przyciskiem myszy dla pozycji dokumentu w panelu Projects. Otworzy się okno dialogowe Save As, gotowe do zapisania dokumentu w tej samej lokalizacji co plik projektu. Wpisz nazwę
Harness Wiring Diagramw polu File name i kliknij przycisk Save. -
Ponieważ do projektu dodano nowy dokument, plik projektu uległ zmianie. Kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects, a następnie wybierz Save z menu kontekstowego, aby zapisać projekt lokalnie.
-
Umieść komponenty złączy na schemacie okablowania. Zwykle korzysta się z komponentów z własnych bibliotek, dostępnych z poziomu panelu Components. W tym przykładzie zostaną użyte bezpośrednio modele dostarczone wraz z częściami producentów.
-
Otwórz panel Manufacturer Part Search. W tym celu kliknij przycisk
w prawym dolnym rogu obszaru projektowego i wybierz z menu Manufacturer Part Search.
-
W polu Search u góry panelu wpisz
SLW-107-0-1-G-Si naciśnijEnter. Wyniki wyszukiwania zostaną wyświetlone w panelu. W tym przykładzie potrzebna jest część z modelem symbolu schematowego. Części z modelami są oznaczone na liście ikoną
.
-
Zaznacz znalezioną część, kliknij ją prawym przyciskiem myszy i wybierz polecenie Place z menu kontekstowego. Kursor automatycznie przesunie się w obręb schematu okablowania i przyjmie postać krzyżyka z dołączonym symbolem złącza. Tryb umieszczania komponentów jest teraz aktywny. Gdy poruszysz kursorem, złącze będzie się przemieszczać wraz z nim.
Do not place the connector yet!
-
Gdy złącze jest nadal dołączone do kursora, naciśnij klawisz
Tab, aby otworzyć panel Properties. Pole Designator, jako najczęściej używane, zostanie automatycznie wyróżnione w panelu i będzie gotowe do edycji. -
Wpisz
P1w polu Designator i upewnij się, że widoczność pola Comment jest włączona (oznaczona jako
-
Pozostaw wartości domyślne we wszystkich pozostałych polach, a następnie kliknij przycisk pauzy w obszarze projektowym , aby wrócić do umieszczania komponentów.
-
Użyj
Spacebar, aby obrócić komponent o 90 stopni, oraz klawiszyXiY, aby odbić go odpowiednio w poziomie i w pionie. -
Przesuń kursor z dołączonym symbolem złącza, aby ustawić złącze w prawej górnej części arkusza. Gdy komponent znajdzie się w odpowiednim miejscu, kliknij, aby umieścić go w dokumencie.
-
Przesuń kursor — kopia złącza została umieszczona w dokumencie, a tryb umieszczania komponentów jest nadal aktywny z symbolem złącza dołączonym do kursora. Ta funkcja umożliwia umieszczanie wielu egzemplarzy tego samego komponentu.
-
Możesz teraz umieścić drugie złącze. Jest ono takie samo jak poprzednie, więc nie trzeba edytować jego atrybutów przed umieszczeniem. Podczas umieszczania wielu egzemplarzy tego samego komponentu Altium Designer automatycznie zwiększa numer w oznaczeniu komponentu. W tym przypadku następne złącze automatycznie otrzyma oznaczenie P2.
-
Umieść drugie i trzecie złącze zgodnie z ilustracją poniżej.
-
Po umieszczeniu wszystkich złączy zakończ tryb umieszczania komponentów, klikając prawym przyciskiem myszy lub naciskając klawisz
Esc. Kursor ponownie przyjmie postać standardowej strzałki.
-
-
Piny komponentów łączy się za pomocą fizycznych przewodów.
-
Wybierz polecenie Place » Harness Wire z menu głównego.
-
Kliknij punkt połączenia pinu P1-1 (gdy kursor znajduje się nad punktem połączenia pinu, pojawia się przy nim czerwony krzyżyk), aby umieścić punkt początkowy przewodu, a następnie kliknij punkt połączenia pinu P2-1, aby umieścić punkt końcowy przewodu.
-
W podobny sposób połącz pozostałe piny P1 i P2 (P1-2 ↔ P2-2, P1-3 ↔ P2-3 itd.).
-
Po umieszczeniu przewodów kliknij prawym przyciskiem myszy, aby zakończyć polecenie.
-
-
Do umieszczonych przewodów należy podłączyć dodatkowe przewody. W takich przypadkach należy najpierw umieścić połączenie splatane lub odgałęzienie. W tym przykładzie zostaną użyte połączenia splatane.
-
Wybierz polecenie Place » Splice z menu głównego.
-
Naciśnij klawisz
Tab, aby otworzyć panel Properties i edytować właściwości połączenia splatanego. -
Wpisz
SPL1w polu Designator panelu Properties. -
Kliknij przycisk pauzy w obszarze projektowym , aby wrócić do umieszczania połączeń splatanych.
-
Umieść pięć połączeń splatanych na wcześniej umieszczonych przewodach, jak pokazano na ilustracji poniżej. Każde połączenie splatane podzieli przewód na dwie części.
-
Po umieszczeniu połączeń splatanych kliknij prawym przyciskiem myszy, aby zakończyć polecenie.
-
-
Umieść dodatkowe przewody (Place » Harness Wire) między umieszczonymi połączeniami splatanymi a pinami P3, jak pokazano na ilustracji poniżej.
-
Umieść dodatkowe niepodłączone przewody przy pinach P3-6 i P3-7 i oznacz je jako niepodłączone.
-
Wybierz polecenie Place » Harness Wire z menu głównego.
-
Kliknij punkt połączenia pinu P3-6, aby umieścić punkt początkowy przewodu, a następnie kliknij punkt w obszarze projektowym z dala od innych obiektów, na lewo od pinu, aby umieścić punkt końcowy przewodu, jak pokazano poniżej.
-
Kliknij prawym przyciskiem myszy, aby zakończyć umieszczanie przewodu. Zwróć uwagę, że niepodłączony koniec przewodu jest oznaczony wypełnionym kwadratem.
-
Kliknij punkt połączenia pinu P3-7, aby umieścić punkt początkowy przewodu, a następnie kliknij punkt w obszarze projektowym z dala od innych obiektów, na lewo od pinu, aby umieścić punkt końcowy przewodu, jak pokazano poniżej.
-
Kliknij prawym przyciskiem myszy, aby zakończyć umieszczanie przewodu.
-
Ponieważ przewód nie powinien pozostawać niepodłączony, na niepodłączonych końcach przewodów należy umieścić znaczniki braku połączenia. Wybierz polecenie Place » No Connect z menu głównego.
-
Podczas umieszczania naciśnij
Spacebaraby ustawić położenie nazwy obiektu braku połączenia. -
Umieść obiekt braku połączenia (
Nc1iNc2) na każdym niepodłączonym końcu przewodu.
-
-
Skonfiguruj wyświetlanie przewodu między pinem P1-1 a połączeniem SPL1. Kliknij dwukrotnie przewód w obszarze projektowania, aby otworzyć panel Properties.
-
Ustaw Designator przewodu na
W1-A. -
Wyłącz widoczność komentarza przewodu, klikając ikonę widoczności po prawej stronie pola Comment (ikona powinna wyglądać tak:
-
Ustaw czerwony kolor przewodu, klikając próbkę koloru w kolumnie Wartość dla parametru Color w sekcji Parameters i wybierając kolor w wyświetlonym oknie podręcznym.
-
-
Skonfiguruj wyświetlanie pozostałych umieszczonych przewodów, jak pokazano na poniższej ilustracji.
-
Zapisz dokument schematu połączeń lokalnie, klikając prawym przyciskiem myszy jego pozycję w panelu Projects i wybierając Save z menu kontekstowego.
-
Zamknij dokument schematu połączeń, klikając prawym przyciskiem myszy jego pozycję w panelu Projects i wybierając Close z menu kontekstowego.
Tworzenie rysunku rozmieszczenia
Main page: Tworzenie rysunku rozmieszczenia
-
Kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects, a następnie wybierz polecenie Add New to Project » Harness Layout Drawing z menu kontekstowego.
W obszarze projektowania otworzy się pusty arkusz rysunku rozmieszczenia o nazwie
Harness Layout Drawing1.LdrDoc, a w panelu Projects, pod pozycją Source Documents, pojawi się pozycja tego dokumentu powiązana z projektem. -
Aby zapisać nowy dokument rysunku rozmieszczenia lokalnie, wybierz polecenie Save As z menu dostępnego po kliknięciu prawym przyciskiem myszy pozycji dokumentu w panelu Projects. Otworzy się okno dialogowe Save As, umożliwiające zapisanie dokumentu w tej samej lokalizacji co plik projektu. Wpisz nazwę
Harness Layout Drawingw polu File name i kliknij przycisk Save. -
Ponieważ do projektu dodano nowy dokument, plik projektu uległ zmianie. Kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects, a następnie wybierz Save z menu kontekstowego, aby zapisać projekt lokalnie.
-
Wybierz polecenie Design » Import Wiring Diagram z menu głównego, aby zaimportować dane projektowe ze schematu połączeń. Złącza zostaną wstawione do arkusza rysunku rozmieszczenia z zachowaniem ich względnego położenia określonego na schemacie połączeń. Punkty połączeń powiązane ze złączami również zostaną umieszczone obok każdego złącza na rysunku rozmieszczenia.
-
Dla punktu połączenia powiązanego ze złączem P3 powinny być wybrane tylko piny 1–5. Zaznacz punkt połączenia CP_P3 i usuń zaznaczenie pinów 6 i 7 na liście rozwijanej Pins pozycji P3 w sekcji Assigned Objects panelu Properties.
-
Połączenia fizyczne są definiowane jako wiązki przewodów. Każda wiązka musi zaczynać się i kończyć w punkcie połączenia. Najpierw umieść wiązkę rozpoczynającą się w CP_P1 i kończącą się w CP_P2.
-
Wybierz polecenie Place » Harness Bundle z menu głównego.
-
Kliknij punkt połączenia (gdy kursor znajduje się nad punktem połączenia pinu, pojawia się przy nim czerwony krzyżyk), aby umieścić punkt początkowy wiązki, a następnie kliknij inny punkt połączenia, aby umieścić punkt końcowy wiązki.
-
Kliknij prawym przyciskiem myszy, aby zakończyć polecenie i zatwierdzić umieszczenie wiązki.
-
-
Zaznacz umieszczoną wiązkę w obszarze projektowania, aby zobaczyć jej właściwości w panelu Properties. Zawartość wiązki można zobaczyć na liście Bundle Objects. Zwróć uwagę, że wiązka zawiera przewody W6 i W7, ponieważ są to jedyne dwa przewody bezpośrednio łączące P1 i P2.
-
Aby przewody między pinami 1–5 złączy P1 i P2 zostały uwzględnione w wiązce, połączenia umieszczone na schemacie połączeń muszą zostać uwzględnione na rysunku rozmieszczenia. Umieść punkt połączenia (CP1) na wiązce, używając polecenia Place » Connection Point z menu głównego. Spowoduje to podział pierwotnej wiązki na dwie oddzielne wiązki.
-
Umieść wiązkę między punktami połączeń CP1 i CP_P3.
-
Zaznacz CP1 i sprawdź, czy przypisano do niego każde połączenie (SPL1, SPL2, SPL3, SPL4 i SPL5).
-
Każda wiązka będzie teraz automatycznie zawierać właściwe przewody. Na przykład zaznacz wiązkę między punktami połączeń CP_P1 i CP1, aby sprawdzić, czy zawiera teraz przewody W1-A, W2-A, W3-A, W4-A, W5-A, W6 i W7.
-
Po zaznaczeniu wiązki między punktami połączeń CP_P1 i CP1 w obszarze projektowania skonfiguruj jej właściwości w panelu Properties w następujący sposób:
-
Ustaw Designator wiązki na
B1. -
Wyłącz widoczność komentarza wiązki, klikając ikonę widoczności po prawej stronie pola Comment (ikona powinna wyglądać tak:
-
Ustaw Length wiązki na
50mm.
-
-
W podobny sposób skonfiguruj właściwości pozostałych dwóch wiązek.
-
Dla wiązki między punktami połączeniowymi CP1 i CP_P2 ustaw Designator na
B2, wyłącz widoczność Comment i ustaw Length na65mm. -
Dla wiązki między punktami połączeniowymi CP1 i CP_P3 ustaw Designator na
B3, wyłącz widoczność Comment i ustaw Length na50mm.
Po zastosowaniu zmian rysunek rozmieszczenia będzie wyglądał jak poniżej.
-
-
Symbol punktu połączeniowego można zmienić, aby poprawić jego wygląd. Po zaznaczeniu punktu połączeniowego CP1 zmień Style na Insulator w sekcji Properties panelu Properties.
-
Pojedyncze przewody można przedstawić na rysunku rozmieszczenia jako wiązki zawierające jeden przewód.
-
Umieść dwa punkty połączeniowe (CP2 i CP3) obok złącza P3.
-
Zaznacz CP2 i kliknij przycisk
w sekcji Assigned Objects panelu Properties.
-
W otwartym oknie dialogowym Add Assigned Objects wyłącz Show only unassigned objects, wybierz pozycję odpowiadającą złączu P3 i kliknij
.
-
W panelu Properties wybierz pin 6 złącza P3.
-
Zaznacz CP3 i kliknij przycisk
w sekcji Assigned Objects panelu Properties.
-
W otwartym oknie dialogowym Add Assigned Objects wyłącz Show only unassigned objects, wybierz pozycję odpowiadającą złączu P3 i kliknij
.
-
W panelu Properties wybierz pin 7 złącza P3.
-
Umieść dwa dodatkowe punkty połączeniowe (CP4 i CP5).
-
Zaznacz CP4 i kliknij przycisk
w sekcji Assigned Objects panelu Properties.
-
W otwartym oknie dialogowym Add Assigned Objects wybierz pozycję odpowiadającą obiektowi braku połączenia Nc1 i kliknij
.
-
Zaznacz CP5 i kliknij przycisk
w sekcji Assigned Objects panelu Properties.
-
W otwartym oknie dialogowym Add Assigned Objects wybierz pozycję odpowiadającą obiektowi braku połączenia Nc2 i kliknij
.
-
Umieść wiązkę między CP2 i CP4 oraz kolejną wiązkę między CP3 i CP5. Pierwsza wiązka będzie automatycznie zawierać przewód W13, a druga — przewód W14.
-
Skonfiguruj właściwości umieszczonych wiązek — ustaw ich wartości Designator na
B4iB5, wyłącz widoczność ich Comment i ustaw ich Length na30mm. -
Wygląd wiązek i punktów połączeniowych można zmienić, aby lepiej odzwierciedlał ich rzeczywisty wygląd.
-
-
Umieść etykiety fizyczne za pomocą polecenia Place » Layout Label z menu głównego. Właściwości etykiety można skonfigurować w panelu Properties po zaznaczeniu etykiety w obszarze projektowym. Umieść etykiety na wiązkach przewodów, ustaw ich wartości Designator na
L1,L2iL3, ustaw ich wartości Text naLabel A,Label BiLabel Coraz wyłącz widoczność ich wartości Comment. -
Zmień sposób przedstawienia złączy na rysunku rozmieszczenia z symbolu graficznego na model fizyczny.
-
Kliknij dwukrotnie złącze P1 w obszarze projektowym, aby otworzyć panel Properties.
-
W sekcji Model panelu ustaw opcję Type na Physical Model i rozwiń sekcję dodaną do listy Views poniżej.
-
Ustaw Side widoku na Front, a Rotation na 180 Degrees.
-
W obszarze projektowym użyj
Click, Hold&Dragna widoku komponentu, oznaczniku i komentarzu, aby odpowiednio zmienić ich położenie.
-
-
Podobnie skonfiguruj sposób przedstawienia złączy P2 i P3.
-
Zapisz dokument rysunku rozmieszczenia lokalnie, klikając prawym przyciskiem myszy jego pozycję w panelu Projects i wybierając Save z menu kontekstowego.
Weryfikacja projektu wiązki
Main page: Weryfikacja projektu wiązki
Przed kontynuowaniem zweryfikuj projekt wiązki, aby upewnić się, że dokumenty schematu połączeń i rysunku rozmieszczenia nie zawierają naruszeń reguł projektowych.
-
Kliknij prawym przyciskiem myszy pozycję projektu wiązki w panelu Projects i wybierz polecenie Project Options z menu kontekstowego. Otworzy się okno dialogowe Project Options.
-
Wybierz kartę Error Reporting w oknie dialogowym Project Options. Karta ta zawiera listę dostępnych kontroli. Ustawienia Report Mode określają poziomy ważności odpowiadających im naruszeń.
-
W tym przykładowym projekcie wyłącz kontrolę Unspecified connector cavities - no part choice for active pins (w kategorii Violations Associated with Wiring Diagram). W tym celu kliknij w kolumnie Report Mode dla tej kontroli i wybierz No Report.
-
Kliknij OK w oknie dialogowym Project Options, aby zapisać zmianę i zamknąć okno.
-
Kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects, a następnie wybierz polecenie Validate Harness Project <ProjectName> z menu kontekstowego.
-
Otwórz panel Messages, klikając przycisk
w prawym dolnym rogu obszaru projektowego i wybierając Messages z wyświetlonego menu. Upewnij się, że panel zawiera tylko jeden komunikat: Compile successful, no errors found. -
Jeśli w panelu Messages znajdują się ostrzeżenia lub błędy, usuń przyczyny naruszeń i ponownie przeprowadź weryfikację, aby upewnić się, że w projekcie nie pozostały żadne nierozwiązane naruszenia. Kliknij dwukrotnie komunikat o naruszeniu w panelu Messages, aby przejść do obiektu, którego ono dotyczy.
-
Kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects, a następnie wybierz Save z menu kontekstowego, aby zapisać zmiany w opcjach projektu.
-
Zamknij dokument rysunku rozmieszczenia, klikając prawym przyciskiem myszy jego pozycję w panelu Projects i wybierając Close z menu kontekstowego.
Tworzenie rysunku produkcyjnego
Main page: Tworzenie rysunku produkcyjnego
-
Zanim będzie można umieścić widok rysunku na rysunku produkcyjnym projektu, należy dodać do projektu dokument ActiveBOM. Kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects, a następnie wybierz polecenie Add New to Project » ActiveBOM z menu kontekstowego.
-
W otwartym dokumencie ActiveBOM kliknij przycisk
u góry, aby nadać numery wierszom.
-
Zapisz dokument ActiveBOM lokalnie, wybierając polecenie Save As z menu kontekstowego pozycji dokumentu w panelu Projects. Otworzy się okno dialogowe Save As, umożliwiające zapisanie dokumentu w tej samej lokalizacji co plik projektu. Pozostaw domyślną nazwę i lokalizację i kliknij Save.
-
Zamknij dokument ActiveBOM, klikając prawym przyciskiem myszy jego pozycję w panelu Projects i wybierając Close z menu kontekstowego.
-
Kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects i wybierz polecenie Add New to Project » Draftsman Document z menu kontekstowego.
-
W otwartym oknie dialogowym New Document wybierz szablon [Default] z listy Templates i upewnij się, że na listach rozwijanych Project i Document wybrano właściwy projekt i dokument rysunku rozmieszczenia (
Harness_Project.PrjHariHarness Layout Drawing.LdrDoc).
-
Kliknij OK w oknie dialogowym. Otworzy się nowy, pusty dokument Draftsman, a jego pozycja pojawi się w projekcie w panelu Projects pod pozycją Source Documents.
-
Zapisz dokument Draftsman lokalnie, wybierając polecenie Save As z menu kontekstowego pozycji dokumentu w panelu Projects. Otworzy się okno dialogowe Save As, umożliwiające zapisanie dokumentu w tej samej lokalizacji co plik projektu. Wpisz
Harness Manufacturing Drawingw polu File name i kliknij Save. -
Kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects, a następnie wybierz polecenie Save z menu kontekstowego, aby zapisać zmiany w strukturze projektu.
-
Jeśli panel Properties nie jest widoczny, kliknij przycisk
w prawym dolnym rogu obszaru projektowego i wybierz Properties z otwartego menu. Panel wyświetla właściwości zaznaczonego obiektu, a jeśli żaden obiekt nie jest zaznaczony — właściwości dokumentu Draftsman.
-
Na karcie Page Options panelu wybierz A3 z listy rozwijanej Sheet_Size, gdy dla Formatting and Size aktywny jest tryb Standard.
-
Wybierz polecenie Place » Wiring Diagram View z menu głównego.
-
Kursor zmieni się w krzyżyk, a widok będzie podążać za kursorem. Przesuń kursor, aby ustawić widok w lewym górnym rogu rysunku. Gdy położenie widoku będzie odpowiednie, kliknij, aby umieścić go na rysunku. W razie potrzeby położenie można później zmienić, używając
Click, Hold&Dragna widoku. -
Kliknij dwukrotnie umieszczony widok schematu połączeń, aby otworzyć jego właściwości w panelu Properties. W panelu:
-
Wyłącz widoczność tytułu widoku, klikając ikonę widoczności po prawej stronie pola Title w sekcji Title (ikona powinna mieć postać
-
Wyłącz opcję Show Border w sekcji Properties.
-
-
Wybierz polecenie Place » Layout Drawing View z menu głównego.
-
Przesuń kursor, aby ustawić widok w prawym górnym rogu rysunku, i kliknij, aby go umieścić.
-
Kliknij dwukrotnie umieszczony widok rysunku rozmieszczenia, aby otworzyć jego właściwości w panelu Properties. W panelu:
-
Wyłącz widoczność tytułu widoku, klikając ikonę widoczności po prawej stronie pola Title w sekcji Title (ikona powinna mieć postać
-
Wyłącz opcję Show Border w sekcji Properties.
-
-
Wybierz polecenie Place » Bill of Materials z menu głównego i umieść tabelę BOM w wolnym miejscu na arkuszu.
-
Wybierz polecenie Place » Wiring List z menu głównego i umieść tabelę listy przewodów w wolnym miejscu na arkuszu. Kliknij dwukrotnie listę przewodów, aby otworzyć jej właściwości w panelu Properties, i upewnij się, że opcja Length Units w sekcji Units panelu jest ustawiona na Document: mm.
-
Na rysunku produkcyjnym można umieścić odnośniki odpowiadające numerom pozycji BOM. Aby to zrobić:
-
Wybierz polecenie Place » Annotations » Callout z menu głównego.
-
Najedź kursorem na złącze w widoku rysunku rozmieszczenia, tak aby krawędź lub punkt tego złącza zostały podświetlone.
-
Kliknij, aby określić położenie grotu odnośnika.
-
Odsuń kursor od złącza i kliknij, aby umieścić tekst źródłowy odnośnika (domyślnie numer pozycji BOM).
-
Kliknij prawym przyciskiem myszy, aby zakończyć umieszczanie odnośnika. Tryb umieszczania odnośników pozostanie aktywny.
-
Umieść odnośniki dla dwóch pozostałych złączy w widoku, jak pokazano poniżej.
-
Kliknij prawym przyciskiem myszy, aby wyjść z trybu umieszczania odnośników.
-
-
Umieść tabelę połączeń dla każdego złącza:
-
Wybierz polecenie Place » Connection Table z menu głównego.
-
Umieść tabelę obok złącza w widoku rysunku rozmieszczenia.
-
Kliknij dwukrotnie tabelę połączeń, aby otworzyć jej właściwości w panelu Properties.
-
Z listy rozwijanej Component na karcie General panelu wybierz złącze, obok którego umieszczono tabelę, i upewnij się, że opcja Length Units jest ustawiona na Document: mm.
-
Powtórz powyższe kroki, aby umieścić tabele połączeń dla dwóch pozostałych złączy.
-
-
Umieść wymiary w widoku rysunku rozmieszczenia zgodnie z poniższą ilustracją.
-
Aby umieścić wymiar liniowy, wybierz polecenie Place » Linear Dimension z menu głównego. Kliknij raz, aby określić pierwszy punkt odniesienia, ponownie, aby określić drugi punkt odniesienia, a następnie po raz trzeci, aby umieścić tekst wymiaru i powiązane z nim pomocnicze linie wymiarowe. Umieść kolejny wymiar liniowy lub kliknij prawym przyciskiem myszy, aby zakończyć tryb wstawiania wymiarów.
-
Aby umieścić wymiar kątowy, wybierz polecenie Place » Angular Dimension z menu głównego. Kliknij raz, aby określić pierwszą linię odniesienia, ponownie, aby określić drugą linię odniesienia, a następnie po raz trzeci, aby ustawić położenie tekstu wymiaru i styl linii wymiarowych kąta. Umieść kolejny wymiar kątowy lub kliknij prawym przyciskiem myszy, aby zakończyć tryb wstawiania wymiarów.
-
Różne właściwości umieszczonego wymiaru można modyfikować w panelu Properties po zaznaczeniu wymiaru w obszarze projektowym. Obejmują one czcionkę, konfigurację tekstu i strzałek, wartość (z możliwością ręcznego nadpisania) oraz tolerancje.
-
-
Zapisz dokument rysunku produkcyjnego lokalnie, klikając prawym przyciskiem myszy jego pozycję w panelu Projects i wybierając Save z menu kontekstowego.
-
Jeśli projekt wiązki przewodów został utworzony w połączonym obszarze roboczym, kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects, wybierz polecenie Save to Server z menu kontekstowego i kliknij OK w otwartym oknie dialogowym Save to Server.
).
























































