Preparing Reports

W skrócie

Altium Designer umożliwia generowanie raportów służących do dokumentowania komponentów, śledzenia zmian w projekcie i przygotowywania danych produkcyjnych. W tym artykule przedstawiono dostępne typy raportów, wyjaśniono, jak konfigurować i eksportować raporty za pomocą narzędzia Report Manager, oraz wskazano, gdzie generować i zapisywać pliki wynikowe. Czytaj dalej, aby wybrać potrzebne raporty i uporządkować pliki wynikowe projektu.

- Poznaj typy raportów, w tym zestawienie materiałów (BOM), porównanie zestawień BOM, dane produkcyjne wiązek przewodów, odwołania krzyżowe komponentów, komentarze i historię projektu.
- Dowiedz się, jak konfigurować obsługiwane raporty, wyświetlać ich podgląd, drukować je i eksportować do różnych formatów plików.
- Dowiedz się, jak dodawać raporty do plików Output Job lub generować je bezpośrednio oraz jak zarządzać folderami wyjściowymi, aby uniknąć nadpisywania raportów.
Zagłęb się w temat dzięki AI:

Dla projektu można przygotować i wygenerować szereg raportów dotyczących całego projektu lub określonego dokumentu projektu , w tym:

  • Zestawienie materiałowe – ten dokument raportu zawiera przejrzystą listę wszystkich komponentów wymaganych do zbudowania produktu – w tym nieobsadzonej płytki, która jest w istocie podstawowym „komponentem”, na którym montowane są wszystkie pozostałe części. Zestawienie materiałowe (BOM) wskazuje, co należy zakupić, aby zbudować produkt zgodnie z projektem. Umożliwia również obliczenie kosztów na podstawie wymaganej liczby zmontowanych płytek w danej serii produkcyjnej.

    Dane prezentowane w oknie dialogowym Report Manager – służącym do konfigurowania raportu zestawienia materiałowego – mogą pochodzić z jednego z dwóch źródeł. Jeśli z projektem powiązany jest dokument ActiveBOM (*.BomDoc), zostanie on użyty jako źródło danych. W przeciwnym razie dane zostaną pobrane ze źródłowych dokumentów schematów projektu.

  • Porównanie BOM – raport zawierający informacje o tym, które komponenty zostały zmienione (np. dodane, usunięte lub zastąpione) podczas wydawania projektu z przestrzeni roboczej.

  • Manufacturing Data – pojedynczy skoroszyt programu Excel zawierający dane przeznaczone dla producentów wiązek przewodów. Wygenerowany skoroszyt zawiera cztery oddzielne arkusze:

    • Bill of Materials – przydatny do szybkiego przygotowywania wycen.

    • Wiring List – do wykorzystania w maszynach do obróbki przewodów.

    • Labels – zestawienie fizycznych etykiet do wydrukowania dla pęków przewodów wiązki, przeznaczone do drukarek Zebra lub innych drukarek.

    • Coverings – zestawienie osłon nakładanych na pęki przewodów wiązki.

     

    Zaleca się używanie dokumentu ActiveBOM projektu wiązki przewodów jako źródła danych wyjściowych do produkcji.

    Więcej informacji na temat projektowania wiązek przewodów można znaleźć na stronie Projektowanie wiązek przewodów.

  • Raport odsyłaczy komponentów – tworzy listę komponentów na podstawie arkuszy schematu, na których znajdują się one w projekcie.

    Raporty zestawienia materiałowego i odsyłaczy komponentów można konfigurować w szerokim zakresie dzięki dedykowanemu, zaawansowanemu mechanizmowi generowania raportów, którego interfejsem jest okno dialogowe Report Manager. Po zdefiniowaniu i odpowiednim uporządkowaniu zawartości wymaganego raportu można go wygenerować – wydrukować lub wyeksportować do jednego z kilku formatów plików: CSV (rozdzielany przecinkami) (*.csv), arkusz programu Microsoft Excel (*.xls;*.xlsx;*.xlt;*.xltx), Portable Document Format (*.pdf), tekst rozdzielany tabulatorami (*.txt), strona internetowa (*.htm;*.html), arkusz kalkulacyjny XML (*.xml). Wyeksportowany plik można zapisać w dowolnej wskazanej lokalizacji. Po utworzeniu można go również otworzyć w odpowiedniej aplikacji i/lub dodać do projektu. Użyj polecenia Report z menu okna dialogowego Report Manager, aby otworzyć okno dialogowe Report Preview z już załadowanym raportem. Za pomocą dostępnych w oknie elementów sterujących dostosuj widok raportu. Kliknij przycisk Print , aby otworzyć okno dialogowe Print , w którym można określić, co zostanie wydrukowane i do jakiej drukarki zostanie wysłane zadanie. Podgląd raportu można również wyeksportować do różnych formatów plików.

  • Eksportuj komentarze – tworzy plik PDF z wyeksportowanymi komentarzami do dokumentów projektu.

  • Historia projektu – tworzy plik PDF z wyeksportowaną historią projektu. Skonfiguruj dane wyjściowe w oknie dialogowym Project History Report Configuration, w którym można ustawić Period określający zakres eksportowanego raportu: całą historię projektu lub zakres od/do określonego (bądź najnowszego) wydania projektu.

  • Raport hierarchii projektu – tworzy listę dokumentów źródłowych użytych w projekcie. Ten typ danych wyjściowych nie ma opcji konfiguracji; raport ASCII jest zapisywany we wskazanym folderze wyjściowym.

  • Raport sieci z jednym wyprowadzeniem – tworzy raport zawierający listę sieci, które mają tylko jedno połączenie. Ten typ danych wyjściowych nie ma opcji konfiguracji; raport ASCII jest zapisywany we wskazanym folderze wyjściowym. Raport zawierający listę wszystkich źródłowych dokumentów schematów projektu z uwzględnieniem ich hierarchii w projekcie. Plik jest generowany bezpośrednio w formacie <ActiveDocumentName>.REP.

Raporty można dodawać do aktywnego pliku Output Job z menu elementu sterującego [Add New Report Output] w sekcji Report Outputs pliku lub z podmenu Edit » Add Report Outputs menu głównych.

Chociaż pliki OutputJob usprawniają przygotowywanie danych wyjściowych projektów i ich późniejsze generowanie z wykorzystaniem procesu wydawania projektu zapewniającego wysoką integralność danych, raporty dla aktywnego projektu można również generować bezpośrednio za pomocą polecenia z głównego menu Reports  edytora schematów lub z podmenu Reports » Project Reports edytora PCB.
  • Ponieważ okno dialogowe Report Manager oferuje tak szerokie możliwości konfiguracji, można go również użyć do wygenerowania raportu w dowolnym wymaganym formacie, na przykład pliku pick and place, w którym dane muszą mieć określoną strukturę dostosowaną do konkretnego automatu montażowego.
  • Wszystkie pliki wyjściowe zostaną zapisane w folderze wyjściowym określonym w polu Output Path na karcie Options okna dialogowego Options for Project. Domyślnie ścieżka wyjściowa wskazuje podfolder folderu zawierającego plik projektu o nazwie Project Outputs for <ProjectName>. Ścieżkę wyjściową można zmienić zgodnie z potrzebami. W panelu Projects wygenerowane pliki będą widoczne w podfolderach Generated\Text Documents (.csv, .txt, .rep) lub Generated\Documents (.xls, .pdf, .htm, .xml). Pamiętaj, że jeśli z tego samego aktywnego dokumentu zostanie wygenerowany raport w innym formacie, poprzednio wygenerowany plik raportu zostanie nadpisany (jeśli ma tę samą nazwę pliku).
  • Jeśli opcja Use separate folder for each output type jest włączona (również na karcie Options ), dane wyjściowe zostaną zapisane w dodatkowym podfolderze o nazwie Reports (np. Project Outputs for <ProjectName>\Reports). W panelu Projects dane wyjściowe będą widoczne w podfolderach Generated (Reports)\Text Documents (.csv, .txt, .rep) lub Generated (Reports)\Documents (.xls, .pdf, .htm, .xml). Pozwala to generować wiele raportów z tego samego aktywnego dokumentu bez nadpisywania plików.
AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.