Support for Panelization

W skrócie

Edytor CAMtastic w Altium Designer oferuje więcej niż tylko weryfikację danych wyjściowych — udostępnia narzędzia do panelizacji płytek z uwzględnieniem wymagań produkcyjnych i montażowych. W tym artykule wyjaśniamy, jak ustawić wymiary panelu, odstępy między płytkami i liczbę powtórzeń, wyświetlić podgląd rozmieszczenia oraz korzystać z kodów przesunięcia, aby efektywnie zarządzać danymi powtarzających się płytek. Omawiamy również dodawanie, usuwanie i modyfikowanie obiektów w macierzach Step & Repeat. Czytaj dalej, aby zyskać większą kontrolę nad procesem panelizacji.

- Dowiedz się, jak rozmiar panelu, odstępy i opcja Calculate określają liczbę płytek mieszczących się w panelu.
- Poznaj metody ustalania odstępów Offset i Gap oraz sprawdź podgląd rozmieszczenia przed jego zastosowaniem.
- Odkryj, jak funkcja Step & Repeat ogranicza powielanie danych i jak aktualizować macierze po panelizacji.
Zagłęb się w temat dzięki AI:

Tradycyjnie projektanci używali narzędzi CAM wyłącznie do weryfikacji, przeglądając wizualnie pliki wynikowe Gerber i pliki wierceń przed przekazaniem ich do producenta płytek. Doświadczeni projektanci zdają sobie sprawę ze znaczenia prac wykonywanych po zakończeniu projektowania, które pozwalają niezawodnie uzyskać działające płytki. Prace te wymagają precyzyjnej i otwartej komunikacji z zakładami produkcji i montażu.

Edytor CAM w Altium Designer zapewnia projektantom wszystko, czego potrzebują do takiej komunikacji — nie tylko niezawodne narzędzia weryfikacyjne, lecz także pełny zestaw narzędzi CAM dostępnych dla producentów płytek i zakładów montażowych. Obejmuje on narzędzia do panelizacji płytki i definiowania krawędzi frezowania.

Wielu projektantów płytek może się zastanawiać, dlaczego uwzględniono te narzędzia. Odpowiadamy: trudno nam jednoznacznie określić, gdzie kończy się rola projektanta. Niektórym wystarczy sprawdzenie projektu i pozostawienie producentowi kwestii optymalnego wykorzystania powierzchni paneli, o ile otrzymają to, co zamówili. Inni mogą chcieć bardziej zaangażować się w ten proces. Możesz na przykład potrzebować paneli najlepiej dostosowanych nie tylko do wymagań producenta płytek, ale także zakładu montażowego.

Panelizacja

Okno dialogowe Panelization Okno dialogowe Panelization

Panel jest tworzony automatycznie, a użytkownik określa jego rozmiar oraz sposób rozmieszczenia na nim wielu kopii danych płytki. Można również wskazać sposób przechowywania danych. Zdecydowanie zalecamy używanie jednego z dostępnych kodów przesunięcia, ponieważ pozwalają one zachować niewielki rozmiar plików i ułatwiają zarządzanie nimi. Informacje o obrazie i wierceniach zostaną zdefiniowane w panelu tylko raz, a po nich pojawi się zestaw instrukcji powielania.

Narzędzia pozycjonowania

Panelizacja przebiega zgodnie z ogólnym schematem edycji w edytorze CAM. Aby rozpocząć, można wybrać polecenie Tools » Panelize PCB, następnie zaznaczyć obiekty, które mają znaleźć się w panelu (lub użyć skrótów klawiaturowych E, S, L, aby zaznaczyć wszystko), a potem wykonać polecenie, klikając prawym przyciskiem myszy lub używając skrótu klawiaturowego Shift+9. Ta sekwencja spowoduje otwarcie okna dialogowego Panelization.

Okno dialogowe Panelization Okno dialogowe Panelization

Wyświetlone początkowo okno dialogowe Panelization zawiera informacje obliczone na podstawie wymiarów płytki poddawanej panelizacji (określonych przez zaznaczone obiekty). W górnej części okna, w polach Image Size , podane są wymiary zaznaczonych obiektów w poziomie i w pionie. Poniżej wyświetlane są wartości Panel Size, Spacing i Parts Count.

Wszystkie te pola działają dynamicznie. Jeśli opcja Calculate jest włączona, wyświetlana jest maksymalna liczba kolumn i wierszy, które zmieszczą się przy podanych wymiarach panelu i odstępach. Liczbę kolumn lub wierszy w panelu można zwiększyć, umieszczając płytki bliżej siebie lub zmniejszając margines przy krawędziach panelu. Więcej płytek można też zmieścić, zwiększając rozmiar panelu.

Wyłączenie opcji Calculate pozwala odwrócić ten sposób działania: można teraz wprowadzić liczbę kolumn i wierszy, które mają zmieścić się w panelu, a wynikowy rozmiar panelu zostanie wyświetlony na podstawie wartości wprowadzonych w polach Parts Count i Spacing . Ponieważ wynikowe wymiary panelu będą miały niezaokrąglone wartości, metoda ta będzie prawdopodobnie używana jedynie do określenia minimalnych wymaganych wymiarów panelu. Następnie warto ponownie włączyć opcję Calculate i wprowadzić rozmiar panelu obsługiwany przez producenta płytek i zakład montażowy.

Układ płytek można wyśrodkować w panelu lub umieścić w jego lewym dolnym rogu.

Kliknięcie przycisku Show Preview otworzy w oknie dialogowym podgląd, w którym można zobaczyć rozmieszczenie paneli na arkuszu. Zmiany odstępów między panelami będą na bieżąco uwzględniane w podglądzie, co pozwala uzyskać wymagane odstępy przed przejściem dalej.

Po ustawieniu wszystkich opcji zgodnie z wymaganiami kliknięcie OK spowoduje wykonanie panelizacji, a układ paneli pojawi się w głównym obszarze roboczym projektu. Układ zaczyna się od pierwotnie zaznaczonych obiektów i jest rozmieszczany w górę oraz w lewo.

  • Odstępy w układzie paneli można precyzyjnie określić na jeden z dwóch sposobów:
    • Offset — ta metoda pozwala określić odstępy między wierszami i kolumnami względem rozmiaru obrazu (czyli zaznaczonych obiektów). Podając wartość w polu Offset , należy dodać wymagany odstęp do wartości w polu Image Size i wprowadzić uzyskaną sumę jako przesunięcie. Na przykład, jeśli rozmiar obrazu wynosi 0,5 cala, a wymagany odstęp to 200 milsów, w odpowiednim polu Offset należy wprowadzić 0,7.
    • Gap — ta metoda pozwala bezpośrednio określić odstępy między wierszami i kolumnami, a zatem nie zależy od rozmiaru obrazu. Na przykład, jeśli wymagany odstęp wynosi 200 milsów, w odpowiednim polu Gap należy wprowadzić 0,2.
  • Użyj opcji Calculate , aby określić optymalną liczbę płytek na podstawie podanych wartości Panel Size i Spacing.
  • Włączenie opcji Use Step & Repeat umożliwi użycie osadzonych kodów Step and Repeat w celu zmniejszenia rozmiaru plików zawierających wielokrotnie te same informacje. Gdy opcja ta jest używana, w obszarze roboczym projektu w całości wyświetlany jest tylko oryginalny panel, a wszystkie pozostałe przewidywane kopie są przedstawiane jako puste ramki.
  • Każde użycie polecenia panelizacji powoduje dodanie nowej warstwy do listy warstw w panelu CAMtastic . Jest to warstwa vent_border, której w oknie dialogowym Layers Table (Tables » Layers) przypisywany jest typ Temporary. Ten obrys należy zachować, jeśli na późniejszym etapie chcesz szybko dodać do panelu wypełnienie technologiczne.

Kroki we właściwym kierunku

To logiczne, że umieszczenie ośmiu pełnych kopii płytki na jednym panelu spowoduje co najmniej ośmiokrotne zwiększenie rozmiaru pliku wynikowego. Dzieje się tak zawsze, gdy dane są exploded, czyli w całości zapisywane ponownie w pliku opisu dla każdej nowej lokalizacji. Zazwyczaj główne obciążenie związane z takim plikiem nie wynika z jego rozmiaru, lecz z faktu, że każde odświeżenie ekranu trwa osiem razy dłużej.

CAM Editor oferuje dwa rodzaje kodów przesunięcia, które pomagają zapobiegać nadmiernemu rozrostowi plików podczas panelizacji: tradycyjne polecenia Step & Repeat oraz ODB++ Steps.

Step & Repeat

Gdy opcja Use Step & Repeat jest włączona w oknie dialogowym Panelization, wcześniej zaznaczone dane są przenoszone do lewego dolnego rogu panelu. Wszystkie pozostałe sekcje panelu wyglądają podobnie jak w podglądzie: są pustymi prostokątami pokazującymi pionowe i poziome wymiary kopiowanych danych. Prostokąty te pojawiają się na każdej warstwie zawierającej informacje Step & Repeat.

Ponieważ dane przechowywane w każdym powtórzeniu są ustalane w momencie panelizacji, użycie kodów Step & Repeat najlepiej odłożyć do chwili uzyskania całkowitej pewności, że oryginalne dane nie będą już zmieniane. Jest to oczywiście idealny scenariusz, ponieważ panelizację zazwyczaj wykonuje się po zakończeniu weryfikacji. Co jednak zrobić, jeśli po panelizacji płytki okaże się, że trzeba wprowadzić drobne poprawki?

Możliwa jest edycja danych Step & Repeat , choć nie jest to łatwe. Do danych widocznych w lewej dolnej sekcji panelu można dodawać nowe błyski, linie lub tekst. Te dodatkowe obiekty można następnie dodać do pozostałych (powielonych) sekcji panelu za pomocą polecenia Edit » Step/Repeat » Add Objects. Po uruchomieniu polecenia kursor zmieni się w kwadrat i przejdziesz do trybu dodawania obiektów. Procedura obejmuje następującą sekwencję czynności:

  1. Kliknij obiekty, które mają zostać dodane, aby je zaznaczyć. Kliknięcie poza obiektem umożliwia przeciągnięcie obszaru zaznaczenia w celu objęcia nim wielu obiektów. Kolejne zaznaczenia sumują się.
  2. Po zaznaczeniu wszystkich wymaganych obiektów kliknij prawym przyciskiem myszy.
  3. Teraz wybierz konkretną macierz Step & Repeat, do której chcesz dodać zaznaczone obiekty. Wystarczy umieścić kursor nad dowolnym obiektem należącym do zaznaczenia macierzy w jej oryginalnej ramce (lewej dolnej) i kliknąć. Rozmiar ramek w macierzy zostanie zmieniony tak, aby pomieściły zarówno dodane, jak i oryginalne obiekty. Widoczne obiekty będą znajdować się wyłącznie w oryginalnej (lewej dolnej) ramce macierzy — wszystkie pozostałe ramki pozostaną puste.
  4. Kontynuuj wybieranie obiektów do dodania do innych macierzy Step & Repeat albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć.

Dodanie obiektów może spowodować nakładanie się ramek w macierzy. Odległość (lub odstęp) między ramkami można zmienić w oknie dialogowym Modify Step_Repeat. Aby to zrobić, wybierz polecenie Edit » Step/Repeat » Modify z menu głównego. Po uruchomieniu polecenia kursor zmieni się w kwadrat i przejdziesz do trybu modyfikacji macierzy. Modyfikacja macierzy obejmuje następującą sekwencję czynności:

  1. Wybierz konkretną macierz Step & Repeat do zmodyfikowania. Wystarczy umieścić kursor nad dowolnym obiektem należącym do zaznaczenia macierzy w jej oryginalnej ramce (lewej dolnej) i kliknąć — pojawi się okno dialogowe Modify Step_Repeat. W tym oknie możesz zmienić liczbę wierszy i kolumn macierzy, a także odstępy, korzystając z jednej z dwóch metod:

    • Distance — ta metoda umożliwia określenie odległości między wierszami i kolumnami w odniesieniu do rozmiaru obrazu (tj. zaznaczonych obiektów). Określając wartość w polu Distance , należy dodać wymagany odstęp do wartości w polu Image Size i wprowadzić tę sumę jako odległość. Na przykład, jeśli rozmiar obrazu wynosi 0,5 cala, a wymagany odstęp to 200 milsów, w odpowiednim polu Distance należy wpisać 0.7.
    • Gap — ta metoda umożliwia bezpośrednie określenie odstępu między wierszami i kolumnami, niezależnie od rozmiaru obrazu. Na przykład, jeśli wymagany odstęp wynosi 200 milsów, w odpowiednim polu Gap należy wpisać 0.2.
    Kliknij przycisk Show Preview, aby rozwinąć okno dialogowe i wyświetlić okno podglądu macierzy, w którym można sprawdzić, jak macierz będzie wyglądała po modyfikacji. Podgląd będzie aktualizowany w miarę zmieniania ustawień macierzy.
  2. Po wprowadzeniu wymaganych modyfikacji kliknij OK — macierz Step & Repeat zostanie zmieniona zgodnie z określonymi modyfikacjami.
  3. Kontynuuj wybieranie i modyfikowanie kolejnych macierzy Step & Repeat albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć.

Usuwanie jest nieco bardziej złożone i wymaga usunięcia obiektów z powielonych (niewidocznych) sekcji panelu za pomocą polecenia Edit » Step/Repeat » Remove Objects, a następnie usunięcia tych samych obiektów z widocznej sekcji panelu za pomocą polecenia Edit » Clear. Po uruchomieniu polecenia Edit » Step/Repeat » Remove Objects kursor zmieni się w kwadrat i przejdziesz do trybu usuwania obiektów. Usuwanie obejmuje następującą sekwencję czynności:

  1. Zaznacz obiekty do usunięcia w oryginalnej ramce (lewej dolnej) docelowej macierzy Step & Repeat. Można to zrobić, umieszczając kursor nad istniejącym obiektem, który ma zostać zaznaczony, i klikając. Można też kliknąć poza obiektem i przeciągnąć obszar zaznaczenia, aby objąć nim wiele obiektów. Kolejne zaznaczenia sumują się.
  2. Po zaznaczeniu wszystkich wymaganych obiektów kliknij prawym przyciskiem myszy. Obiekty zostaną usunięte z macierzy, a rozmiar jej ramek zostanie dostosowany do pozostałych obiektów.
  3. Kontynuuj wybieranie obiektów do usunięcia z innych macierzy Step & Repeat albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć.
Usunięcie wszystkich obiektów z oryginalnej ramki macierzy spowoduje w praktyce usunięcie całej macierzy.

Ponieważ tę samą grupę obiektów trzeba zaznaczyć dwukrotnie dla dwóch różnych poleceń, ryzyko błędu jest duże. Edytor CAM umożliwia jednak przywrócenie poprzedniego zaznaczenia. Dodatkowym utrudnieniem jest to, że pola Step & Repeat w macierzy pozostają puste i nie dostarczają żadnych wskazówek co do ich zawartości, dopóki dane nie zostaną rozbite na obiekty podstawowe za pomocą polecenia Edit » Step/Repeat » Explode. Po uruchomieniu polecenia kursor zmieni się w kwadrat i pojawi się monit o wybranie konkretnej macierzy Step & Repeat do rozbicia. Wystarczy umieścić kursor nad dowolnym obiektem należącym do zaznaczenia macierzy w jej oryginalnej ramce (lewej dolnej) i kliknąć. Wszystkie ramki macierzy zostaną wypełnione danymi skopiowanymi z oryginału, a obramowania ramek zostaną usunięte. Kontynuuj rozbijanie innych macierzy Step & Repeat albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć.

Podczas rozbijania danych rozmiar pliku może znacznie wzrosnąć, zależnie od ilości powielanych informacji.

Kroki ODB++

ODB++ rozwiązują problemy występujące w kodach Step & Repeat. Każdy utworzony krok staje się nową kolumną odpowiadającą bieżącym wierszom warstw. Im więcej kroków dodasz, tym większa będzie macierz, w której można przechowywać dane. Jeden krok można wstawić jednokrotnie lub wielokrotnie w obrębie innego kroku — dokładnie tak dzieje się podczas panelizacji z włączoną opcją Create ODB++ Step. Podczas korzystania z opcji Create ODB++ Step oprócz domyślnego kroku obszaru projektowego (cam_work) tworzone są dwa nowe kroki:

  • jeden dla danych wybranych do panelizacji (campcb)
  • jeden dla samego panelu (campanel).
    Zawartość każdego kroku można wyświetlić, klikając dwukrotnie jego nazwę na karcie Steps panelu CAM.
    Krok zawierający wybrane dane jest automatycznie wstawiany jako podkrok kroku panelu i wyświetlany w formacie:
    [n]: NazwaKroku (Wiersze, Kolumny),
    gdzie [n] to kolejny dostępny numer przypisany do wstawionego kroku, począwszy od 1, a wartości Rows i Columns są pobierane z sekcji Parts Count okna dialogowego Panelization.

Podczas wyświetlania zawartości kroku panelu w obszarze projektowym wstawiony krok (z danymi) będzie widoczny jako puste białe prostokąty w układzie wiersze × kolumny. W przeciwieństwie do szyku Step & Repeat dane obiektów nie są widoczne w żadnym z elementów szyku. Dla każdego wystąpienia wstawionego kroku wyświetlany jest biały krzyżyk wskazujący miejsce, w którym zostanie wstawiona zawartość danych po rozwinięciu szyku kroków.

Przed zakończeniem pracy należy kliknąć prawym przyciskiem myszy krok panelu i wybrać Refresh Inserts. Dzięki temu wstawione do panelu kroki będą odzwierciedlać bieżący stan danych źródłowych, a wszelkie zmiany wprowadzone po panelizacji zostaną uwzględnione w gotowym panelu.

Aby otworzyć okno dialogowe Steps Table, w którym można wyświetlić informacje o krokach ODB++ dla bieżącego dokumentu, wybierz polecenie Tables » Steps z menu głównego. Po kliknięciu OK  w oknie dialogowym Steps Table karta Steps  w panelu CAMtastic  zostanie odświeżona. Na tej karcie można dodawać i modyfikować kroki, klikając prawym przyciskiem myszy i wybierając odpowiednie polecenie z menu kontekstowego. Okno dialogowe Steps Table pojawia się automatycznie podczas importowania plików ODB++ do edytora CAMtastic.

Dodatkowe strategie panelizacji

Automatyczne narzędzia pomagają zmaksymalizować liczbę identycznych płytek w panelu, ale co zrobić, gdy wymagania dotyczące panelu są bardziej złożone? Jak dodać do panelu kupony kontrolne wiercenia lub otwory technologiczne? Co zrobić, jeśli chcesz zastosować układ z odwróceniem, tworząc panel, który po odwróceniu wygląda tak samo, co umożliwia montaż elementów po obu stronach przez dwukrotne przepuszczenie panelu przez ten sam automat montażowy pick-and-place? A jeśli chcesz zoptymalizować wykorzystanie powierzchni panelu, rozmieszczając w nim różne płytki?

Wszystkie te wymagania można spełnić, używając kroków ODB++ w CAM Editor. Punktem wyjścia jest procedura automatycznej panelizacji, ponieważ tylko ona umożliwia utworzenie obrysu panelu za pomocą opcji Create ODB++ Step zamiast opcji Use Step & Repeat.

Wstawianie kroków

Okna dialogowe  Enter Value i Add Insert to ODB StepOkna dialogowe Enter Value i Add Insert to ODB Step

Obok szyku płytek w panelu można wstawiać dodatkowe kroki. Producent płytek może na przykład umieścić kupon kontrolny wiercenia na jednej z odłamywanych listew technologicznych, aby wizualnie porównać zamierzone rozmiary otworów z otworami w wyprodukowanych płytkach. Otwory technologiczne, służące do mocowania panelu podczas wiercenia i frezowania jego warstw, mogą być potrzebne w innych miejscach panelu, poza poszczególnymi płytkami.

Najpierw należy utworzyć nowy krok. Służy do tego polecenie Add Step, dostępne w menu kontekstowym na karcie Steps panelu CAM. Nowy krok zawiera te same warstwy, ale wszystkie są początkowo puste. Za pomocą tego samego menu kontekstowego można kopiować lub przenosić dane między krokami. Można też umieszczać nowe obiekty na istniejących warstwach, gdy nowy krok jest aktywny — obiekty te będą istnieć tylko w tym kroku.

Aby na przykład utworzyć kupon kontrolny wiercenia, można utworzyć nowy krok, a następnie na warstwie wiercenia umieścić w jednym rzędzie po jednym otworze wykonanym każdym z narzędzi używanych w projekcie. Na górnej warstwie opisowej można dodać tekst lub inne oznaczenia identyfikujące poszczególne średnice wierteł.

Należy również narysować zamkniętą polilinię wokół danych na warstwie oznaczonej w tabeli Layers jako typ Border, wybierając Tables » Layers z menu głównego. Posłuży ona do wygenerowania profile dla ODB++, czyli pliku umożliwiającego wstawianie kroków wewnątrz innych kroków bez naruszania ich granic przez wzory wypełnienia technologicznego.

Dla każdego kuponu lub obiektu, który chcesz dodać do panelu, możesz utworzyć osobny krok. Każdy z nich można wstawić w dokładnie określonym miejscu w nadrzędnym kroku panelu, takim jak campanel, gdy krok panelu jest aktywny. W tym celu użyj polecenia Add Insert z menu kontekstowego. Jeśli podczas tworzenia panelu zastosowano wzór wypełnienia technologicznego, należy go usunąć, a następnie zastosować ponownie. Dzięki temu wzór wypełnienia będzie uwzględniał granicę profilu każdego kroku.

Układ z odwróceniem (step-and-turn)


Panelizacja z odwróceniem to technika usprawniająca pracę zakładu montażowego. Zwykle płytki z elementami po obu stronach wymagają dwóch automatów montażowych pick-and-place: jednego do elementów na górnej stronie panelu, a drugiego do elementów na dolnej stronie. Jeśli jednak górna i dolna strona panelu po odwróceniu są identyczne, panel można dwukrotnie przepuścić przez ten sam automat montażowy.

Należy rozróżniać górną stronę płytki i górną stronę panelu, ponieważ technika ta wymaga, aby płytki po prawej stronie panelu były takie same jak te po lewej, lecz odwrócone. Wymaga ona również symetrycznego układu typów warstw. Połowa górnej strony panelu będzie zawierać obrazy górnej strony płytki, a druga połowa — lustrzane obrazy dolnej strony płytki.

Aby uzyskać taki układ w CAM Editor, należy najpierw skopiować wszystkie dane płytki do nowego kroku. Można użyć funkcji Swap Layers Data, wybierając Edit » Layers » Swap Layers Data z menu głównego, aby określić, gdzie zostaną umieszczone dane odwróconych warstw. W rezultacie górna warstwa będzie zawierać obrazy zarówno górnej, jak i dolnej warstwy, ale obrazy te pozostaną w osobnych krokach.

Jeśli panel nie został jeszcze utworzony na podstawie pierwotnego projektu, można zrobić to teraz, pamiętając o parzystej liczbie kolumn lub wierszy wyśrodkowanych w panelu. Kliknij znak plus obok wygenerowanego kroku campanel, a następnie kliknij prawym przyciskiem myszy wstawiony krok, aby go zmodyfikować. Zmień liczbę wierszy lub kolumn tak, aby połowa płytek zniknęła. Następnie wstaw nowo utworzony krok i poddaj go panelizacji w identyczny sposób, ale użyj obliczonego punktu bazowego, który umieści nowy szyk w miejscu wcześniej usuniętych kroków. Upewnij się, że opcja Mirror jest włączona dla tego kroku.

Okno dialogowe  Modify Insert in ODB StepOkno dialogowe Modify Insert in ODB Step

Różne płytki w tym samym panelu

Odwracanie płytek w panelu to w rzeczywistości bardzo wąskie zastosowanie możliwości kroków ODB. Płytki można odwracać, ponieważ ta sama warstwa może zawierać różne dane w każdym ze swoich kroków, które następnie można umieścić obok siebie w tym samym obszarze projektowym. Ta swoboda nasuwa pytanie: dlaczego panel musi zawierać szyk jednakowych płytek? Odpowiedź brzmi: w CAM Editor nie ma takiego ograniczenia.

Powody umieszczania różnych płytek w tym samym panelu są różne. Producentowi zależy na maksymalnym wykorzystaniu powierzchni panelu, ale im większa płytka, tym trudniej to osiągnąć. Małe płytki, nawet pochodzące z innego źródła, mogą wypełnić dostępne miejsce i obniżyć koszty produkcji. Z drugiej strony jeden produkt może składać się z kilku płytek, które projektant wolałby wyprodukować razem w jednym panelu.

Oczywiście istnieją pewne ograniczenia. W jednym panelu można umieszczać tylko płytki o takim samym układzie warstw sygnałowych i wewnętrznych warstw płaszczyzn. Wymagają one również zgodnych zestawów warstw wierceń.

Domyślnie CAM Editor tworzy nowe warstwy podczas wczytywania nowych obrazów lub plików wierceń. Ta metoda nie sprawdzi się przy umieszczaniu różnych płytek w jednym panelu, ponieważ dane różnych płytek muszą znajdować się na tej samej warstwie, ale w różnych krokach. W tym celu na stronie CAM Editor - Import/Export okna dialogowego Preferences dostępna jest opcja umożliwiająca importowanie dodatkowych plików Gerber/wierceń do istniejących warstw.

Po włączeniu tej opcji przy każdym imporcie dodatkowych plików Gerber, wierceń lub danych IPC, gdy takie warstwy zostały już zaimportowane, będzie wyświetlane okno dialogowe mapowania.

Okno dialogowe Map Layers to Import to Existing LayersOkno dialogowe Map Layers to Import to Existing Layers

Okno dialogowe Maps Layers to Import to Existing Layers zawiera nowe pliki po lewej stronie, a istniejące warstwy po prawej. Na podstawie rozszerzeń oraz Layer Types Detection Template, do którego można uzyskać dostęp, wybierając Tables » Layer Type Detection z menu głównego, edytor CAM zaproponuje dopasowania, ale można je dostosować do własnych potrzeb. Dla plików, których nie chcesz mapować do istniejących warstw, można wybrać utworzenie nowej warstwy lub całkowite wykluczenie z importu.

Przed rozpoczęciem mapowania należy utworzyć nowy krok ODB i ustawić go jako bieżący. W przeciwnym razie wszystkie dane warstw zostaną nałożone na siebie bez możliwości oddzielenia danych poszczególnych płytek.

Wypełnienie technologiczne

Okna dialogowe Venting i Edit Pattern - Venting Okna dialogowe Venting i Edit Pattern - Venting

W nieużywanych obszarach panelu można dodać wzór wypełnienia technologicznego, który pomaga równomiernie rozprowadzać środek trawiący na całym panelu. Funkcja automatycznej panelizacji edytora CAM wypełni całą przestrzeń między krawędzią panelu a instancjami płytek wybranym wzorem wypełnienia.

Wzór ten może być rastrowy, wektorowy, jednolity lub oparty na kształtach. Można wybrać standardowe kształty o rozmiarach zdefiniowanych przez użytkownika albo użyć istniejącego kodu D jako podstawy wzoru wypełnienia. Wzór zostanie zastosowany wyłącznie do warstw sygnałowych i warstw płaszczyzn (zdefiniowanych w kolumnie Layers Table in the Types ).

Jeśli wypełnienie technologiczne zostało utworzone podczas początkowej panelizacji danych, a następnie dodano kroki ODB++, takie jak kupony testowe, otwory technologiczne czy nawet odwrócone lub alternatywne płytki, najlepiej odświeżyć wzór wypełnienia. W tym celu należy usunąć wypełnienie, a następnie dodać je ponownie. Odpowiednie polecenia pojawią się po kliknięciu prawym przyciskiem myszy wpisu kroku panelu (campanel), znajdującego się na karcie Steps panelu CAM. Pamiętaj, aby ustawić krok panelu jako bieżący — tylko wtedy te polecenia będą aktywne.

Aby dodać wzór wypełnienia technologicznego do bieżącego panelu PCB, wybierz polecenie Tools » Venting z menu głównego. Sposób użycia tego polecenia zależy od tego, czy podczas panelizacji PCB zachowano warstwę vent_border.

  • With a vent_border layer present – po uruchomieniu polecenia pojawi się okno dialogowe Venting . Domyślnie wszystkie warstwy sygnałowe i warstwy płaszczyzn będą zaznaczone do wypełnienia. Aby odznaczyć warstwę, wystarczy kliknąć jej wpis.

    Po lewej stronie okna dialogowego wyświetlany jest aktualnie zdefiniowany wzór wypełnienia, który zostanie zastosowany. Kliknij przycisk Edit Pattern, aby otworzyć okno dialogowe Edit Pattern - Venting, w którym można zdefiniować żądany wzór wypełnienia.

    Po zdefiniowaniu wzoru wypełnienia i wybraniu warstw zgodnie z potrzebami kliknięcie OK spowoduje zastosowanie wzoru na panelu we wszystkich obszarach poza vent_border.

  • With no vent_border layer present – bez warstwy vent_border obrys panelu nadal będzie istnieć, ale poszczególne płytki PCB na panelu nie będą miały granic umożliwiających obliczenie obszaru wypełnienia. Dlatego konieczne będzie dodanie obrysów do każdej płytki PCB na panelu, co w praktyce oznacza utworzenie własnej warstwy vent_border. Jednym z najszybszych sposobów jest dodanie nowej warstwy i narysowanie granic wokół każdej płytki PCB na panelu za pomocą polecenia polilinii.

    Po uruchomieniu polecenia kursor zmieni się w mały kwadrat i pojawi się monit o zaznaczenie obrysów panelu oraz płytek PCB. Wystarczy przeciągnąć ramkę zaznaczenia wokół całego panelu. Zaznaczone zostaną wszystkie obrysy płytek PCB oraz obrys panelu. Kliknij prawym przyciskiem myszy — pojawi się okno dialogowe Venting. Zdefiniuj wzór wypełnienia i wybierz warstwy zgodnie z potrzebami, a następnie kliknij OK. Wzór wypełnienia zostanie zastosowany na panelu w obszarze między obrysem panelu a obrysami płytek PCB.

  • Użyj okna dialogowego Edit Pattern - Venting, aby zdefiniować żądany wzór wypełnienia. Jeśli Fill Type ma wartość Polygon (Raster), wszystkie pozostałe ustawienia w tym oknie będą nieaktywne. Obszar wewnątrz obrysu panelu zostanie wypełniony jednolitym wielokątem.
  • Jeśli Fill Type ma wartość Vector, można wybrać jednolity obraz lub kształt/kod D. Można wybrać kształt i podać jego rozmiar na potrzeby wypełnienia albo wskazać istniejącą aperturę. Jeśli wybrano Shape/Dcode, można określić odstępy w osiach X i Y między użytymi kształtami.
  • Użycie wzoru wielokątnego spowoduje dodanie dwóch nowych kodów D do listy apertur. Będą one widoczne jako wpisy Poex i Poin.
  • Jeśli we wzorach wektorowych użyjesz kształtów i rozmiarów, które nie odpowiadają istniejącym aperturom, zostaną one dodane do listy apertur z kolejnym dostępnym kodem D.

Kreator kliszy

Aby rozmieścić wybrane warstwy Gerber w obrębie jednej kliszy, co umożliwia wyprowadzenie warstw Gerber na kliszę dla bieżącego dokumentu, użyj polecenia Tools » Film Wizard z menu głównego.

Najpierw upewnij się, że włączone są tylko te warstwy Gerber, które chcesz uwzględnić w panelu.

Po uruchomieniu polecenia pojawi się okno dialogowe Film Wizard. Użyj go, aby określić rozmiar kliszy i układ warstw na niej. Możesz wybrać jedną z predefiniowanych konfiguracji rozmiaru i układu z pola rozwijanego Film Description lub wprowadzić własną.

Sekcja Individual Film Size okna dialogowego pokazuje powierzchnię kliszy dostępną dla każdego obrazu w układzie, na podstawie określonych ustawień rozmiaru i układu.

Kliknięcie przycisku Neg/Mirror otworzy okno dialogowe Film Wizard - Select Layers. Użyj go, aby wybrać warstwy, które mają zostać odbite lustrzanie lub przedstawione na kliszy w negatywie.

Po zdefiniowaniu opcji kliszy kliknięcie OK w oknie dialogowym Film Wizard spowoduje utworzenie warstw kliszy. Pojawi się okno dialogowe z pytaniem, czy usunąć stare obiekty. Jeśli wybierzesz Yes, panel kliszy zostanie utworzony, a oryginalne warstwy zostaną usunięte. Jeśli wybierzesz No, panel kliszy zostanie utworzony, a wszystkie oryginalne warstwy pozostaną, ale zostaną wyłączone.

  • Na kliszy zazwyczaj umieszcza się tylko warstwy sygnałowe i warstwy płaszczyzn. W większości przypadków warstwy płaszczyzn przedstawia się w negatywie.
  • Jeśli określono własne ustawienia rozmiaru kliszy/liczby elementów w macierzy, przycisk Add Description stanie się dostępny. Kliknięcie tego przycisku spowoduje dodanie definicji do kreatora. Przy następnym użyciu polecenia będzie ona dostępna na liście rozwijanej Film Description.
  • Upewnij się, że rozmiar pojedynczej kliszy jest co najmniej równy rzeczywistym wymiarom obrazu. W przeciwnym razie będzie można kontynuować, ale pojawi się okno dialogowe z ostrzeżeniem. Wyniki panelizacji mogą być niezadowalające.
  • Usunięcie oryginalnych warstw jest operacją, której nie można cofnąć.
  • Utworzone warstwy kliszy są dodawane do listy warstw w panelu CAMtastic  i otrzymują nazwy film1, film2, film3 itd.
  • Liczba warstw kliszy jest obliczana przez podzielenie liczby włączonych warstw (które mają zostać umieszczone na kliszy) przez liczbę elementów w macierzy XY na pojedynczej kliszy. Na przykład przy 10 włączonych warstwach i macierzy 1x2 zostanie utworzonych 5 warstw kliszy.
  • Włączone warstwy są rozmieszczane na warstwach kliszy zgodnie z kolejnością na liście warstw. Zatem przy 10 warstwach i macierzy 1x2 pierwsze dwie warstwy zostaną umieszczone na warstwie film1, kolejne dwie na warstwie film2 itd. W przypadku większych macierzy warstwy są rozmieszczane przeciwnie do ruchu wskazówek zegara, począwszy od lewego górnego rogu.

Krawędzie płytek

Sposób oddzielania płytek od panelu jest istotny zarówno dla producentów płytek, jak i zakładów montażowych. Na przykład zakład montażowy może preferować pozostawienie paneli w całości do czasu obsadzenia płytek komponentami. Wymaga to, aby panele były wystarczająco sztywne, by zachować spójność podczas montażu, a jednocześnie miały perforację umożliwiającą późniejsze łatwe wyłamanie płytek z panelu.

Nacinanie rowków V

Jednym z możliwych rozwiązań jest nacinanie rowków V pomiędzy poszczególnymi płytkami, zarówno od górnej, jak i dolnej strony panelu, z pozostawieniem cienkiego mostka materiału. Wszystkie szczegóły tego procesu, takie jak kąt ostrza i grubość mostka oraz ewentualne zastosowanie nacinania przerywanego (odcinków bez rowka, zwiększających sztywność panelu), należy przekazać operatorowi maszyny nacinającej.

Obecnie maszyny nacinające wymagają programowania. Często odbywa się to na podstawie formularzy niezwiązanych z CAD, w których wskazuje się punkty i linie w układzie panelu. Niektóre firmy świadczące usługi nacinania potrafią jednak wyodrębnić informacje o otworach i liniach z plików Gerber. W takim przypadku można zaprojektować linie nacinania w CAM Editor dokładnie według potrzeb. Niezależnie od metody umieszczenie linii nacinania na górnej warstwie opisowej zapewni operatorowi maszyny wskazówki wizualne, które wykorzysta wraz z wyodrębnionymi danymi i przekazanymi instrukcjami.

Frezowanie NC

Tradycyjna metoda obróbki krawędzi płytek polega jednak na użyciu frezów. Gładkie krawędzie można uzyskać przez zagłębienie frezu w płytkę w określonych miejscach, przesunięcie go wzdłuż wyznaczonej ścieżki, a następnie wycofanie.


Podczas przygotowywania danych do frezowania należy uwzględnić kilka istotnych kwestii. Należą do nich rozmiar i kształt narzędzia oraz ścieżka frezowania wraz z punktami zagłębienia i wycofania.

Aby wygenerować i przejrzeć te instrukcje, należy przełączyć CAM Editor w tryb frezowania NC, dostępny z menu View lub panelu CAM. W tym trybie można tworzyć nowe narzędzia w tabeli narzędzi na podstawie wybranych błysków w projekcie, wybierając polecenie Tables » NC Tools z menu głównego. Po uruchomieniu polecenia pojawi się okno dialogowe Tool Table. Domyślnie tabela zawiera listę narzędzi na podstawie zaimportowanego pliku wierceń NC. Jeśli taki plik nie został zaimportowany, tabela będzie pusta. Tabela umożliwia dodawanie i edytowanie definicji narzędzi. Można zdefiniować do 99 narzędzi, każde z unikatowym kodem D, począwszy od D9500. Przyciski Save  i Open  służą odpowiednio do zapisania bieżącej definicji tabeli narzędzi i wczytania wcześniej zapisanej definicji. Dane narzędzi są przechowywane w pliku ustawień tabeli frezowania (Mill/Rout Table Settings, *.mts). Po zatrzymaniu wskaźnika myszy nad poszczególnymi kolumnami tabeli pojawi się podpowiedź z dodatkowymi informacjami o danej pozycji.

Następnie można użyć poleceń dostępnych w menu Rout, aby zdefiniować ścieżki frezowania z użyciem tych lub innych istniejących frezów.

Użyj poniższych poleceń z menu View » Display Symbols, aby włączać i wyłączać wyświetlanie elementów związanych ze ścieżkami frezowania:

  • Drill – włącza i wyłącza wyświetlanie symboli otworów w bieżącym dokumencie. Symbole te stanowią pomoc wizualną ułatwiającą lokalizowanie punktów wiercenia. Symbol otworu ma postać białego krzyżyka wskazującego środek punktu wiercenia.
  • Direction Arrows – włącza i wyłącza wyświetlanie strzałek kierunku ścieżek frezowania.
  • Centerline Path – włącza i wyłącza wyświetlanie oryginalnej linii środkowej ścieżki frezowania, czyli ścieżki bez przesunięcia wynikającego z kompensacji frezu. Efekt działania tego polecenia jest widoczny tylko wtedy, gdy tryb Fill  jest WYŁĄCZONY.
  • Plunge – włącza i wyłącza wyświetlanie symboli punktów zagłębienia dla ścieżek frezowania w bieżącym dokumencie. Punkt zagłębienia to początkowy punkt wejścia frezu w materiał podczas frezowania ścieżki w projekcie.
  • Retract – włącza i wyłącza wyświetlanie symboli punktów wycofania dla ścieżek frezowania w bieżącym dokumencie. Punkt wycofania to punkt wyjścia frezu z materiału po zakończeniu frezowania ścieżki w projekcie.

Aby ponownie narysować wybraną ścieżkę frezowania i dokładnie prześledzić ruch narzędzia podczas rzeczywistej produkcji płytki, wybierz polecenie View » Redraw a Rout Path z menu głównego. Po uruchomieniu polecenia kursor zmieni się w mały kwadrat i pojawi się monit o wybranie frezowanego obiektu. Umieść kursor w dowolnym miejscu nad obiektem poddanym frezowaniu i kliknij. Najpierw zostanie ponownie narysowany odcinek zagłębienia narzędzia. Klikaj dalej, aby odtwarzać ścieżkę frezowania segment po segmencie aż do punktu wycofania. Jest to dokładna ścieżka, po której będzie poruszać się frez podczas produkcji płytki. Dla ułatwienia można włączyć tylko warstwę frezowania, a wszystkie pozostałe warstwy WYŁĄCZYĆ.

Tworzenie ścieżek frezowania

Aby utworzyć ścieżki frezowania na podstawie zaznaczonych ścieżek w bieżącym dokumencie, wybierz polecenie Rout » Create Rout Path(s) z menu głównego. 

Najpierw upewnij się, że zdefiniowano narzędzia wiertarskie. Jeśli wcześniej wczytano plik wierceń NC, narzędzia dla projektu zostały załadowane automatycznie i będą widoczne w oknie dialogowym Tool Table (Tables » NC Tools). Jeśli nie zdefiniowano jeszcze żadnych narzędzi, przy próbie uruchomienia polecenia pojawi się okno dialogowe z odpowiednim ostrzeżeniem. Konieczne będzie zdefiniowanie narzędzi przez zaimportowanie pliku wierceń lub ręczne wprowadzenie danych.

Po zdefiniowaniu wymaganych narzędzi uruchomienie polecenia spowoduje otwarcie okna dialogowego Select Mill/Drill Tool okna dialogowego. Okno zawiera listę rozwijaną wszystkich narzędzi wiertarskich aktualnie zdefiniowanych w projekcie. Wybierz narzędzie, którego chcesz użyć do frezowania, i kliknij OK. Kursor zmieni się w mały kwadrat i pojawi się monit o wybranie obiektów do frezowania. Wystarczy umieścić kursor nad poszczególnymi obiektami i kliknąć, aby dodać je do zaznaczenia, lub użyć jednego z wielu dostępnych narzędzi zaznaczania. Po zaznaczeniu wszystkich wymaganych obiektów kliknij prawym przyciskiem myszy.

Dla wybranych obiektów zostaną utworzone ścieżki frezowania, a warstwa frezowania zostanie utworzona i dodana do listy warstw w panelu CAMtastic . Pojawi się okno dialogowe Create Rout Path(s), w którym można zmienić narzędzie używane do frezowania oraz jego odsunięcie. Można również odwrócić kierunek ścieżek frezowania — punkty zagłębiania staną się punktami wycofania i odwrotnie. Zmiany te są wirtualne i zostaną zastosowane na stałe dopiero po kliknięciu przycisku OK .

  • Frezowanie jest zwykle związane ze ścieżkami. Często zaznaczenie obejmuje również pola lutownicze, które znajdują się na ścieżkach frezowania. Użyj opcji w oknie dialogowym Rout Pads Options (Rout » Rout Pads Options), aby określić sposób postępowania z takimi polami. Domyślnie okrągłe pola lutownicze są przekształcane w punkty wiercenia.
  • Każdy z połączonych ze sobą odcinków linii ma własny punkt zagłębiania i wycofania. Aby uzyskać jeden punkt zagłębiania i jeden punkt wycofania, należy najpierw scalić poszczególne odcinki. Z kolei dodatkowe punkty zagłębiania i wycofania można dodać do ścieżki frezowania, dzieląc ją na odcinki.
  • Warstwa frezowania będzie zawierać wszystkie ścieżki frezowania i, jeśli włączono odpowiednią opcję, wyświetlać szereg symboli związanych z frezowaniem. Symbole te oznaczają punkty zagłębiania i wycofania, a także kierunek każdej ścieżki.
  • W ścieżce frezowania nie można używać następujących apertur: Custom, Diamond, Donut, Target i Thermal.
  • Uważaj, aby nie frezować ścieżek i pól lutowniczych na warstwach sygnałowych ani warstwach płaszczyzn.
  • Podczas tworzenia ścieżki frezowania punkty zagłębiania i wycofania zostaną wstawione w domyślnych miejscach. Można je zmienić na dowolnym etapie, podobnie jak narzędzie, odsunięcie i kierunek frezowania, używając odpowiedniego polecenia Modify Rout Path(s).

Modyfikowanie ścieżek frezowania

Aby zmodyfikować wybrane ścieżki frezowania w bieżącym dokumencie, wybierz polecenie Rout » Modify Rout Path(s) z menu głównego.

Najpierw upewnij się, że warstwa frezowania jest jedyną włączoną warstwą i jest widoczna w obszarze projektowania.

Po uruchomieniu polecenia kursor zmieni się w mały kwadrat i pojawi się monit o wybranie ścieżek frezowania do zmodyfikowania. Wystarczy umieścić kursor nad poszczególnymi obiektami i kliknąć, aby dodać je do zaznaczenia, lub użyć jednego z wielu dostępnych narzędzi zaznaczania. Po zaznaczeniu wszystkich wymaganych obiektów kliknij prawym przyciskiem myszy.

Pojawi się okno dialogowe Modify Rout Path(s), w którym można zmienić narzędzie używane do frezowania oraz jego odsunięcie. Można również odwrócić kierunek ścieżek frezowania — punkty zagłębiania staną się punktami wycofania i odwrotnie. Zmiany te są wirtualne i zostaną zastosowane na stałe dopiero po kliknięciu przycisku OK .

  • Warstwa frezowania zawiera wszystkie ścieżki frezowania i, jeśli włączono odpowiednią opcję, wyświetla szereg symboli związanych z frezowaniem. Symbole te oznaczają punkty zagłębiania i wycofania, a także kierunek każdej ścieżki.
  • Podczas modyfikowania pojedynczej ścieżki frezowania w oknie dialogowym Modify Rout Path(s) dostępne stają się przyciski Plunge  i Retract . Użyj tych przycisków, aby odpowiednio zmienić położenie punktów zagłębiania i wycofania.

Opcje frezowania pól lutowniczych

W oknie dialogowym Rout Pads Options można zdefiniować opcje określające sposób postępowania z polami lutowniczymi znajdującymi się na ścieżce frezowania. Aby otworzyć to okno, wybierz polecenie Rout » Rout Pads Options z menu głównego. Skonfiguruj dostępne opcje zgodnie z potrzebami.

Domyślnie okrągłe pola lutownicze są przekształcane w punkty wiercenia.

Automatyczne frezowanie obrysu

Ścieżki frezowania można definiować ręcznie, ale w miarę możliwości należy korzystać z narzędzi automatycznych. Połączenie segmentów obrysu płytki w jedną zamkniętą polilinię wymaga znacznie mniej pracy niż próba ręcznego, precyzyjnego wyznaczenia ścieżki frezowania, zwłaszcza gdy obrys płytki zawiera łuki.

Najpierw upewnij się, że obrys PCB stanowi jedną zamkniętą granicę. W tym celu może być konieczne użycie polecenia Join.

Użyj polecenia Auto-Rout PCB Border z menu Rout, aby utworzyć ścieżkę frezowania wokół całej płytki na podstawie obrysu PCB. Po uruchomieniu polecenia kursor zmieni się w mały kwadrat i pojawi się monit o wybranie narożnika obrysu, w którym mają zostać umieszczone punkty zagłębiania i wycofania ścieżki. Wystarczy umieścić kursor nad obrysem i kliknąć — wybrany zostanie narożnik najbliższy miejscu kliknięcia. Jeśli na tym etapie nie można wybrać żadnego wierzchołka obrysu PCB, upewnij się, że obrys jest zamkniętą polilinią.

Następnie pojawi się monit o wybranie kierunku frezowania. Aby ułatwić wybór, wyświetlona zostanie linia pomocnicza względem wybranego narożnika obrysu. Przesuń kursor w kierunku, w którym chcesz frezować, i kliknij — pojawi się okno dialogowe Auto Rout PCB. W tym oknie wybierz narzędzie do frezowania obrysu, a także określ przedłużenia w punktach zagłębiania i wycofania.

Po zdefiniowaniu opcji frezowania zgodnie z potrzebami kliknij OK. Ścieżka frezowania zostanie utworzona i dodana do warstwy frezowania.

Okno dialogowe Auto Rout PCB Okno dialogowe Auto Rout PCB

Wierzchołek wybrany jako początek ścieżki frezowania powinien znajdować się w lewym dolnym rogu projektu. W przeciwnym razie linie przedłużeń, jeśli zdecydujesz się ich użyć, mogą wcinać się w płytkę. Postępując zgodnie z instrukcjami na pasku stanu, możesz kliknąć drugie miejsce na obrysie, określając w ten sposób kierunek ścieżki frezowania. Kliknięcie prawym przyciskiem myszy w celu zakończenia spowoduje otwarcie okna dialogowego Auto Rout PCB, w którym można wybrać narzędzie wiertarskie oraz wartości przedłużeń dla punktów zagłębiania i wycofania.

Jeśli dla wybranego narzędzia nie zdefiniowano wartości odsunięcia kompensacyjnego frezu (w tabeli narzędzi), może ona zostać wygenerowana automatycznie. Zostanie utworzona nowa warstwa (*.rte) zawierająca ścieżkę frezowania obrysu PCB.
Następnie możesz dodać mostki wzdłuż ścieżki frezowania. W tych miejscach narzędzie wycofuje się z panelu, przesuwa wzdłuż ścieżki o określoną odległość, a następnie ponownie się zagłębia. Umieszczanie mostków frezarskich jest analogiczne do pozostawiania przerw w nacięciach: w określonych miejscach płytki pozostają w pełni połączone z panelem, gotowe do późniejszego wyłamania.

  • Podczas ustawiania kursora w żądanym miejscu wzdłuż ścieżki frezowania, w którym ma zostać wstawiony mostek, należy kliknąć bezpośrednio na ścieżce frezowania. W trybie wypełnienia ścieżka frezowania może składać się z właściwej ścieżki frezowania oraz ścieżki odsuniętej. W rezultacie środek wypełnionej ścieżki może nie pokrywać się z właściwą ścieżką frezowania, a kliknięcie w tym miejscu nie spowoduje wstawienia mostka. W takim przypadku zaleca się przełączenie do trybu konturu (Shift+F). Wyświetlone zostaną ścieżka frezowania oraz ewentualna ścieżka odsunięta (kompensacyjna) — pierwsza jako linia ciągła, a druga jako linia kropkowana.
  • Punkt kierunkowy należy ustawić w pobliżu krawędzi obrysu.
  • Jeśli narzędzie wybrane do frezowania nie ma zdefiniowanej kompensacji promienia frezu, pojawi się okno dialogowe z pytaniem, czy przypisać wartość domyślną. Wartość domyślna będzie równa rozmiarowi samego narzędzia.
  • Aby użyć tego polecenia, należy zdefiniować co najmniej jedno narzędzie wiertnicze. Jeśli nie zdefiniowano żadnych narzędzi, uruchomienie tego polecenia spowoduje wyświetlenie okna dialogowego z odpowiednim ostrzeżeniem, a następnie przekierowanie do okna dialogowego Tool Table (Tables » NC Tools), w którym można wczytać dane wiercenia z pliku lub ręcznie wprowadzić definicje narzędzi.
  • Warstwa frezowania zostanie utworzona (jeśli jeszcze nie istnieje) na podstawie nazwy warstwy, z której pobrano obrys PCB.

Narzędzia do ręcznego frezowania

Okręgi można tworzyć jako obiekty o kierunku zgodnym z ruchem wskazówek zegara lub przeciwnym, określając ich promień. Punkt zagłębienia będzie znajdował się w środku okręgu, a narzędzie zostanie wycofane po wyfrezowaniu całego okręgu. Tworzenie szczelin jest mniej zautomatyzowane: aby szczelina była kompletna, należy rozpocząć w punkcie zagłębienia i powrócić do niego przed umieszczeniem punktu wycofania narzędzia kliknięciem prawym przyciskiem myszy. Frezowanie tekstu przypomina frezowanie szczelin, ale wykorzystuje wstępnie zdefiniowane ścieżki dla każdej litery (łącznie z punktami zagłębienia i wycofania narzędzia); wystarczy podać tekst i określić wysokość liter.

Instrukcje frezowania nie muszą oczywiście dotyczyć wyłącznie operacji po panelizacji. Wszelkie obiekty frezowania zdefiniowane wewnątrz płytki, takie jak szczeliny wewnętrzne, zostaną uwzględnione wraz z pozostałymi danymi podczas panelizacji.

Aby ręcznie umieścić ścieżki frezowania w bieżącym dokumencie, wybierz polecenie Rout » Manual Rout z menu głównego. Polecenie to opiera się na wstawianiu polilinii. Polilinie są przydatne, gdy trzeba zamknąć linię lub wstawić łuki jako jej fragmenty — żadnej z tych operacji nie można wykonać za pomocą standardowych linii. 

Po uruchomieniu polecenia pojawi się okno dialogowe Select Mill/Drill Tool. Z listy dostępnych narzędzi wybierz narzędzie, którego chcesz użyć do frezowania. Po kliknięciu OK przejdziesz do trybu wstawiania polilinii, a przy kursorze pojawi się wypełnione koło odpowiadające rozmiarowi wybranego narzędzia. Wstawianie odbywa się w następującej kolejności:

  1. Ustaw kursor w żądanym miejscu w obszarze roboczym i kliknij, aby ustalić początek polilinii.
  2. Przesuń kursor i kliknij ponownie, aby umieścić kolejny wierzchołek polilinii.
  3. Kontynuuj umieszczanie kolejnych wierzchołków, klikając za każdym razem, aż polilinia uzyska żądany kształt.
  4. Kliknij prawym przyciskiem myszy, aby otworzyć menu podręczne z poleceniami dostępnymi w trybie wstawiania polilinii. Menu zawiera następujące polecenia:

    • End - kończy wstawianie bieżącej polilinii bez jej zamykania.
    • Close - zamyka polilinię, rysując linię od ostatniego umieszczonego punktu do punktu początkowego, i kończy jej wstawianie.
    • Change to Line - zmienia tryb wstawiania na linie proste.
    • Change to Arc - zmienia tryb wstawiania na łuki.
    • Draw Arc Clockwise - rysuje łuk od poprzedniego wierzchołka zgodnie z ruchem wskazówek zegara.
    • Draw Arc C-Clockwise - rysuje łuk od poprzedniego wierzchołka przeciwnie do ruchu wskazówek zegara.
    • Undo Polyline Changes - usuwa bieżącą polilinię, pozostawiając aktywny tryb wstawiania polilinii.
    • Snap Change - włącza lub wyłącza tryb przyciągania podczas wstawiania polilinii.
    • Cancel Action - usuwa bieżącą polilinię i kończy tryb wstawiania polilinii.
  5. Po zakończeniu lub zamknięciu polilinii albo cofnięciu zmian tryb wstawiania pozostaje aktywny. Kontynuuj wstawianie kolejnych polilinii lub naciśnij Esc , aby zakończyć tryb wstawiania polilinii. Możesz też kliknąć prawym przyciskiem myszy i wybrać Cancel Action z menu podręcznego.

  • Polilinia musi mieć co najmniej dwa różne wierzchołki, aby można było zakończyć jej wstawianie.
  • Polilinia musi mieć co najmniej trzy różne wierzchołki, aby można było ją zamknąć.
  • Polilinie będą rysowane na bieżącej warstwie. Bieżąca warstwa jest wyświetlana w panelu CAMtastic u góry listy warstw. Dwukrotne kliknięcie dowolnej warstwy na liście spowoduje ustawienie jej jako bieżącej.
  • Aby frezować ręcznie, należy wcześniej zdefiniować narzędzia. W przeciwnym razie pojawi się okno dialogowe z odpowiednim ostrzeżeniem, a następnie nastąpi przekierowanie do okna dialogowego Tool Table (Tables » NC Tools), w którym można dodać definicje narzędzi.
  • Najszybszym sposobem wygenerowania narzędzi jest wygenerowanie plików NC Drill z dokumentu projektu PCB. Pliki te są importowane do edytora CAMtastic, a definicje narzędzi dodawane do okna dialogowego Tool Table.

Dodawanie mostka do wybranej ścieżki frezowania

Aby dodać mostek wzdłuż wybranej ścieżki frezowania w bieżącym dokumencie, wybierz polecenie Rout » Add Tabs z menu głównego. Po uruchomieniu polecenia pojawi się okno dialogowe Enter Value. Wprowadź w nim rozmiar mostka w aktualnie wybranych jednostkach obszaru roboczego (calach lub mm). Po kliknięciu OK nastąpi powrót do głównego okna projektu, kursor zmieni się w mały kwadrat i pojawi się monit o wybranie położenia mostka. Ustaw kursor w żądanym miejscu wzdłuż ścieżki frezowania, w którym chcesz wstawić mostek, i kliknij.

Mostek zostanie wstawiony, dzieląc ścieżkę frezowania na dwa segmenty. Każdemu z nich zostaną przypisane osobne punkty zagłębienia i wycofania narzędzia.

Kontynuuj dodawanie kolejnych mostków wzdłuż ścieżek frezowania albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć.

Podczas ustawiania kursora w żądanym miejscu wzdłuż ścieżki frezowania, w którym ma zostać wstawiony mostek, należy kliknąć bezpośrednio na ścieżce frezowania. W trybie Fill  ścieżka frezowania może składać się z właściwej ścieżki frezowania oraz ścieżki odsuniętej. W rezultacie środek wypełnionej ścieżki może nie pokrywać się z właściwą ścieżką frezowania, a kliknięcie w tym miejscu nie spowoduje wstawienia mostka. W takim przypadku zaleca się przełączenie do trybu Outline  (Shift+F). Wyświetlone zostaną ścieżka frezowania oraz ewentualna ścieżka odsunięta (kompensacyjna) — pierwsza jako linia ciągła, a druga jako linia kropkowana.

Przekształcanie linii w łuk

Aby przekształcić linie w łuk na określonej ścieżce frezowania w bieżącym dokumencie, wybierz polecenie Rout » Convert Lines to Arc z menu głównego. Po uruchomieniu polecenia przejdziesz do trybu przekształcania, w którym należy wykonać następujące czynności:

  1. Wybierz punkt początkowy łuku. Ustaw kursor nad wierzchołkiem ścieżki frezowania i kliknij, aby ustalić ten punkt.
  2. Wybierz punkt końcowy łuku. Ponownie umieść kursor nad innym wierzchołkiem ścieżki frezowania i kliknij, aby ustalić ten drugi punkt. Podczas przesuwania kursora pojawi się linia pomocnicza.
  3. Wybierz punkt pośredni łuku. Umieść kursor nad trzecim wierzchołkiem ścieżki frezowania i kliknij — linie zostaną zastąpione łukiem, którego rozmiar zależy od długości linii pomocniczej łączącej punkt początkowy i końcowy oraz odległości wybranego punktu pośredniego od tej linii.
  4. Kontynuuj przekształcanie kolejnych linii w łuki w innych ścieżkach frezowania albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć.
  • Jeśli ścieżka frezowania składa się z odcinków, przed użyciem tego polecenia należy je połączyć.
  • Aby polecenie zadziałało, ścieżka frezowania, w której ma zostać umieszczony łuk, musi zawierać co najmniej trzy wierzchołki — na przykład polilinia tworząca kąt prosty, w której punktami początkowym i końcowym są końce polilinii, a punktem pośrednim łuku jest jej narożnik.

Przekształcanie linii w okrąg

Aby przekształcić ścieżkę frezowania tworzącą zamknięty obrys w okrąg w bieżącym dokumencie, wybierz polecenie Rout » Convert Lines to Circle z menu głównego. Po uruchomieniu polecenia pojawi się monit o wybranie zamkniętego obrysu. Wystarczy umieścić kursor nad fragmentem obrysu ścieżki frezowania, którą chcesz przekształcić w okrąg, i kliknąć — ścieżka zostanie zastąpiona okręgiem, którego środek znajduje się w środku prostokąta opisanego na zamkniętym obrysie, a promień jest równy poziomej odległości od tego środka do krawędzi prostokąta.

Kontynuuj przekształcanie kolejnych ścieżek frezowania o zamkniętym obrysie w okręgi albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć.

Jeśli ścieżka frezowania jest zamkniętym obrysem złożonym z odcinków, przed użyciem tego polecenia należy je połączyć.

Frezowanie obszaru wewnątrz obrysu

Inne automatyczne narzędzie, Frezowanie obszaru wewnątrz obrysu, wykrywa granicę w podobny sposób (również wymagana jest zamknięta polilinia), ale następnie tworzy zygzakowatą ścieżkę, która umożliwia wyfrezowanie całego obszaru zamiast wycięcia go wzdłuż obrysu i pozostawienia do wypadnięcia z płytki lub panelu. Wybierz polecenie Rout » Mill Boundary z menu głównego, aby utworzyć ścieżki frezowania obszarów wewnątrz zamkniętych obrysów w bieżącym dokumencie. Po uruchomieniu polecenia kursor zmieni się w mały kwadrat i pojawi się monit o wybranie obiektów zamkniętych obrysów, dla których chcesz utworzyć ścieżki frezowania. Wystarczy kolejno umieszczać kursor nad każdym zamkniętym obrysem i klikać. Po wybraniu wszystkich wymaganych obrysów kliknij prawym przyciskiem myszy.

Pojawi się okno dialogowe Milling. W tym oknie określ warstwę, na której mają zostać umieszczone ścieżki frezowania. Możesz wybrać warstwę bieżącą, nową lub jedną z istniejących warstw dokumentu. W polu Select Tool wybierz, którego z dostępnych narzędzi wiertarskich chcesz użyć do frezowania ścieżek. Opcja Delete Old Objects umożliwia zachowanie oryginalnych obiektów obrysu do porównania.

  • Jeśli obrys składa się z oddzielnie umieszczonych odcinków, przed użyciem tego polecenia należy je połączyć.
  • Jeśli zdecydujesz się dodać ścieżki frezowania na nowej warstwie, zostanie użyty następny dostępny numer warstwy na liście warstw (np. layer29).

Przełącz widok z wypełnienia na obrys (Shift+F), aby zobaczyć rzeczywisty przebieg wyznaczonej ścieżki frezowania. Frezowanie współbieżne występuje wtedy, gdy kierunek ruchu wzdłuż ścieżki frezowania jest zgodny z kierunkiem ruchu wklęsłej strony zęba narzędzia; frezowanie w przeciwnym kierunku nazywa się przeciwbieżnym.

Frezowanie obszaru jest szczególnie przydatne, gdy narzędziu frezującemu przypisano parametr osi Z mniejszy niż grubość panelu. Pozwala to utworzyć zagłębienie w płytce, które może być potrzebne na przykład przy montażu specjalnych komponentów.

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents