Udostępnianie projektu
Ponieważ istotą współpracy jest wspólna praca wielu osób nad osiągnięciem jednego celu, jej kluczowym elementem jest możliwość udzielania dostępu do wspólnego zasobu i zarządzania tym dostępem — w tym przypadku chodzi o projekt i powiązane z nim dane. Przestrzeń robocza zapewnia tę możliwość dzięki kontrolowanemu, opartemu na uprawnieniach udostępnianiu projektu — w jego bieżącym stanie roboczym (WIP) lub w postaci utrwalonej migawki z danego momentu.
Należy pamiętać, że nowo utworzony projekt lub projekt udostępniony w przestrzeni roboczej jest domyślnie udostępniany następującym osobom i rolom:
-
Właścicielowi projektu, którym jest zazwyczaj projektant, który go utworzył (lub udostępnił w przestrzeni roboczej): z pełnymi uprawnieniami dostępu (odczyt/zapis).
-
Roli Administrators: z pełnymi uprawnieniami dostępu (odczyt/zapis).
Z poziomu Altium Designer obsługiwane są następujące poziomy udostępniania:
-
Sharing of a live design — sam projekt w toku (WIP), który można udostępniać:
- Innym członkom zespołu w przestrzeni roboczej — do edycji i/lub przeglądania. Zaproszony członek zespołu może przeglądać projekt w Altium Designer lub w przestrzeni roboczej zespołu. Edycja odbywa się wyłącznie w Altium Designer. Zaproszony członek zespołu musi być zarejestrowany w AltiumLive i mieć aktywną subskrypcję licencji Altium Designer.
- Osobom spoza zespołu w przestrzeni roboczej — do przeglądania lub edycji, za pośrednictwem zaproszenia e-mail. Ta funkcja jest dostępna tylko po połączeniu z przestrzenią roboczą Altium 365. Ten typ udostępniania umożliwia zaproszonym interesariuszom przeglądanie lub edytowanie (zależnie od uprawnień) aktualnego projektu w toku bez uzyskiwania dostępu do całej przestrzeni roboczej lub wszystkich danych projektowych. Zaproszona osoba musi być zarejestrowana w AltiumLive i może uzyskać dostęp do udostępnionego projektu ze swojej przestrzeni osobistej w Altium 365 (lub z przestrzeni roboczej swojej organizacji, jeśli jest dostępna) albo otworzyć go w Altium Designer.
Jeśli zaproszonemu interesariuszowi przyznano wyłącznie dostęp do przeglądania, może on przeglądać projekt i dodawać do niego komentarze w Altium Designer lub za pośrednictwem interfejsu swojej przestrzeni roboczej Altium 365. Gdy osoby z uprawnieniami do edycji wprowadzają i zatwierdzają zmiany w projekcie, osoby zewnętrzne mogą na bieżąco je oglądać. Aby przeglądać udostępniony projekt w interfejsie przeglądarkowym z dowolnego miejsca, wystarczy zarejestrować się w AltiumLive.
Jeśli zaproszonemu interesariuszowi przyznano uprawnienia do edycji projektu, może go otwierać i edytować w Altium Designer — to idealne rozwiązanie dla zewnętrznych wykonawców.
-
Sharing of a design 'snapshot' — statyczna migawka projektu z określonego momentu, udostępniana:
-
Za pomocą łącza — dostępna dla każdego w przeglądarce. Dostęp do udostępnionego projektu na tym poziomie nie wymaga ani aktywnej subskrypcji licencji Altium Designer, ani rejestracji w AltiumLive. Odbiorca udostępnionego łącza otwiera samodzielną przeglądarkę Altium 365, aby przeglądać projekt (bez możliwości komentowania). Przeglądanie nie wymaga rejestracji w AltiumLive, a łącze jest dostępne przez 48 godzin.
-
Określonym osobom — dostępna dla wskazanych osób za pośrednictwem zaproszenia e-mail. Dostęp do udostępnionego projektu na tym poziomie wymaga rejestracji w AltiumLive, ale nie wymaga aktywnej subskrypcji licencji Altium Designer. Odbiorca uzyskuje dostęp do migawki projektu z zaproszenia e-mail za pośrednictwem przeglądarki internetowej w interfejsie przestrzeni roboczej platformy Altium 365. Przeglądanie wymaga rejestracji w AltiumLive, ale migawka jest dostępna bezterminowo. Dostępne jest również komentowanie projektu.
Należy pamiętać, że udostępniona w ten sposób migawka projektu jest zasadniczo przeznaczona tylko do odczytu. Można ją pobrać lub przeglądać w przestrzeni roboczej Altium 365, ale w przeciwieństwie do udostępnionego projektu WIP nie można jej otworzyć do przeglądania ani edycji w Altium Designer.
-
Dostęp do opcji udostępniania
Opcje udostępniania projektu z poziomu Altium Designer znajdują się w oknie dialogowym Share, do którego można uzyskać dostęp w następujący sposób:
-
Dla aktywnego projektu — klikając przycisk
w prawym górnym rogu głównego okna aplikacji lub wybierając polecenie Project » Share z menu głównego.
- Dla projektu zaznaczonego w panelu Projects — klikając prawym przyciskiem myszy wpis projektu, a następnie wybierając polecenie Share z menu kontekstowego.
- Podczas komentowania dokumentu projektowego — publikując komentarz ze wzmianką o użytkowniku, który nie ma dostępu do bieżącego projektu.

Dostęp do okna dialogowego Share — centrum zarządzania udostępnianiem projektu z poziomu Altium Designer.
Przygotowanie do udostępniania
Aby móc udostępniać aktualny projekt WIP za pośrednictwem przestrzeni roboczej Altium 365:
- Musisz zalogować się na swoje konto Altium (używając danych logowania AltiumLive).
- Musisz mieć aktywną (ważną) subskrypcję Altium dla swojej licencji Altium Designer.
- Musisz mieć połączenie ze swoją przestrzenią roboczą Altium 365.
- Projekt musi być zarejestrowany w przestrzeni roboczej (udostępniony w niej).
- Musisz mieć uprawnienia do udostępniania projektu.
Aby móc udostępniać projekt w toku (WIP) za pośrednictwem przestrzeni roboczej Enterprise Server:
- Musisz mieć aktywną (ważną) licencję Altium Designer.
- Musisz mieć połączenie ze swoją przestrzenią roboczą.
- Projekt musi być zarejestrowany w przestrzeni roboczej (udostępniony w niej).
Aby móc udostępniać migawkę projektu za pośrednictwem przestrzeni roboczej:
- Musisz mieć połączenie ze swoją przestrzenią roboczą Altium.
- Projekt musi być zarejestrowany w przestrzeni roboczej (udostępniony w niej).
- Odbiorca udostępnionego łącza do migawki potrzebuje jedynie standardowej przeglądarki.
-
Odbiorca migawki udostępnionej bezpośrednio jemu musi:
- mieć konto w AltiumLive i być do niego zalogowany.
- mieć połączenie ze swoją przestrzenią osobistą Altium 365.
Okno dialogowe Share zawiera wskazówki, które pomogą Ci odpowiednio przygotować wybrany projekt do udostępnienia. Poniżej przedstawiono przykłady dotyczące udostępniania za pośrednictwem przestrzeni roboczej Altium 365 (podczas pracy z przestrzenią roboczą Enterprise Server wyświetlane są podobne okna dialogowe z odpowiednimi wskazówkami):
- Jeśli nie jesteś zalogowany na swoim koncie Altium, w oknie dialogowym pojawi się łącze umożliwiające zalogowanie (otwierające okno dialogowe logowania) lub rejestrację w AltiumLive, jeśli nie masz jeszcze danych logowania. Po zalogowaniu na konto zazwyczaj następuje połączenie z przestrzenią roboczą, o ile ją masz i została ustawiona jako domyślna.
-
Jeśli jesteś zalogowany na swoim koncie Altium i próbujesz udostępnić otwarty projekt, który nie jest zarejestrowany w przestrzeni roboczej (tj. projekt lokalny lub VCS), a nie masz dostępu do żadnej przestrzeni roboczej, w oknie dialogowym pojawi się element sterujący umożliwiający aktywację przestrzeni roboczej dla Twojej firmy.
-
Jeśli jesteś zalogowany na swoim koncie Altium i próbujesz udostępnić otwarty projekt zarejestrowany w przestrzeni roboczej, z którą nie masz obecnie połączenia, w oknie dialogowym pojawi się element sterujący umożliwiający połączenie z tą przestrzenią roboczą lub przełączenie się na nią, jeśli masz obecnie połączenie z inną.
-
Jeśli jesteś zalogowany na swoim koncie Altium i próbujesz udostępnić otwarty projekt, który nie jest zarejestrowany w przestrzeni roboczej (tj. projekt lokalny lub VCS), a nie masz obecnie połączenia z żadną przestrzenią roboczą, w oknie dialogowym pojawi się lista wszystkich dostępnych dla Ciebie przestrzeni roboczych z prośbą o wybranie tej, w której projekt ma zostać zarejestrowany.
-
Jeśli jesteś zalogowany na swoim koncie Altium i próbujesz udostępnić otwarty projekt, ale nie masz do tego uprawnień, w oknie dialogowym pojawi się odpowiedni komunikat. Może się tak zdarzyć, jeśli nie masz uprawnień do edycji tego projektu lub jeśli administrator przestrzeni roboczej albo właściciel projektu ograniczył osobom z uprawnieniami do edycji możliwość dalszego udostępniania w obrębie przestrzeni roboczej lub poza nią.
Udostępnianie projektu na żywo
Gdy projekt jest zarejestrowany w przestrzeni roboczej Altium 365 (udostępniony w niej), możesz udostępniać go innym osobom. Mogą to być inni członkowie zespołu Twojej przestrzeni roboczej lub osoby spoza zespołu. Aby udostępnić projekt w ten sposób, kliknij pozycję
po lewej stronie okna dialogowego Share.
Dostęp do elementów sterujących umożliwiających udostępnianie innym projektu na żywo / w toku (WIP). Ilustracja przedstawia projekt, który jest już dostępny w połączonej przestrzeni roboczej.
Użyj elementu sterującego Copy Link, aby skopiować bezpośrednie łącze do projektu. Osoby, które mają już dostęp do projektu, mogą użyć tego łącza, aby otworzyć go w Web Viewer przestrzeni roboczej.
Udostępnianie nowym osobom
Po zakończeniu przygotowań, wybraniu projektu i połączeniu z docelową przestrzenią roboczą możesz wskazać osobę lub osoby, którym projekt ma zostać udostępniony. Aby sprawdzić, kto ma już dostęp do projektu, kliknij element sterujący Shared with. Sekcja rozwinie się i pokaże, komu udostępniono projekt oraz czy te osoby mają uprawnienia do edycji (Can Edit), czy mogą jedynie przeglądać i komentować projekt (Can View).

Sprawdź, komu projekt jest obecnie udostępniony, klikając pole Share with. Najedź kursorem na ilustrację, aby zobaczyć wynik.
Możesz udostępnić projekt dowolnej osobie — innym użytkownikom AltiumLive z Twojej organizacji, użytkownikom AltiumLive z innych organizacji oraz osobom niekorzystającym z AltiumLive (które będą musiały zarejestrować konta AltiumLive). Pamiętaj, że po połączeniu z przestrzenią roboczą Enterprise Server możesz udostępniać projekt w toku (WIP) wyłącznie zarejestrowanym użytkownikom tej przestrzeni roboczej. Aby udostępnić projekt osobom z zewnątrz, zapoznaj się z sekcją Udostępnianie migawki projektu lub z metodą udostępniania dostępną w Twojej przestrzeni osobistej Altium 365.
Aby dodać wpis, zacznij wpisywać w polu imię i nazwisko, adres e-mail lub rolę, a następnie wybierz pasującego użytkownika lub rolę z dynamicznej listy. Lista będzie zawierać wyłącznie pasujących użytkowników z zespołu Twojej przestrzeni roboczej lub Twojej organizacji oraz istniejące role zdefiniowane dla przestrzeni roboczej. Możesz wybrać wielu użytkowników i wiele ról. Aby usunąć dodanego użytkownika lub rolę, kliknij element sterujący
przy danym wpisie.
Ustaw uprawnienia dostępu dla dodanych osób lub ról w powiązanym menu rozwijanym, wybierając Can View lub Can Edit , przy czym druga opcja obejmuje również możliwość przeglądania. Początkowo ustawienie dotyczy wszystkich wpisów (osób i ról) dodanych w polu. W opcjonalnym polu notatki możesz podać informacje dotyczące zasad udostępniania tego projektu.
Tylko użytkownicy, którym udostępniono projekt z uprawnieniami Edit, mogą udostępniać go dalej innym osobom. Wszyscy użytkownicy, którym udostępniono projekt z uprawnieniami Edit, mogą pobierać jego pliki projektowe. Dodatkowe uprawnienia udostępniania są dostępne dla administratorów i właściciela projektu w oknie dialogowym Share. Użyj Advanced Settings opcje umożliwiające określenie uprawnień do dalszego udostępniania i pobierania dla użytkowników, którym projekt ma zostać udostępniony.
Dodatkowe opcje udostępniania i pobierania są pogrupowane następująco:
-
Member Rights – dla członków obszaru roboczego:
-
Editors can share – zezwalaj członkom obszaru roboczego mającym uprawnienia
Editdo udostępnionego projektu na dalsze udostępnianie go innym osobom. -
Viewers can download – zezwalaj członkom obszaru roboczego mającym uprawnienia
Viewdo udostępnionego projektu na pobieranie plików projektu.
-
-
Guest and External Share Rights – dla zewnętrznych użytkowników-gości, którym udostępniono projekty:
-
Editors can share – zezwalaj osobom nienależącym do obszaru roboczego, które mają uprawnienia
Editdo udostępnionego projektu, na dalsze udostępnianie go innym osobom. -
Viewers can download – zezwalaj osobom nienależącym do obszaru roboczego, które mają uprawnienia
Viewdo udostępnionego projektu, na pobieranie plików projektu.
-
Zmiany w ustawieniach zaawansowanych zatwierdza się, klikając przycisk
po powrocie do głównego okna dialogowego Share.
Po określeniu odbiorców i uprawnień dostępu kliknij przycisk
, aby udostępnić projekt. W oknie dialogowym pojawi się komunikat o pomyślnym udostępnieniu projektu. Następnie możesz kliknąć element Who has access, aby wrócić do listy użytkowników mających dostęp do projektu, kliknąć przycisk
, aby skopiować bezpośredni link do projektu, lub po prostu zamknąć okno dialogowe, klikając OK.
Udostępnianie osobie spoza zespołu
Jeśli spróbujesz udostępnić projekt z obszaru roboczego Altium 365 osobie spoza zespołu, pojawi się okno dialogowe Confirm z ostrzeżeniem, że użytkownik uzyska dostęp do dokumentów źródłowych udostępnianego projektu, zamieszczonych komentarzy i pakietów wydania. Kliknij OK, aby kontynuować udostępnianie projektu.
Projekt można udostępnić dowolnej osobie spoza zespołu obszaru roboczego do edycji lub przeglądania.
Udostępnianie projektu lokalnego
Jeśli udostępniasz projekt lokalny (nieobjęty zewnętrznym systemem VCS), zostanie on umieszczony w aktualnie połączonym obszarze roboczym w momencie udostępniania go wskazanym osobom. Dalszy przebieg zależy od tego, czy udostępniasz go do przeglądania, czy do edycji:
- Przy udostępnianiu tylko do przeglądania (i po połączeniu z obszarem roboczym Altium 365) — projekt jest udostępniany za pośrednictwem Simple Sync. W tym trybie projekt może być edytowany tylko przez jedną osobę (właściciela projektu). Zalety Simple Sync są szczególnie przydatne, gdy nie chcesz, aby inne osoby edytowały Twój projekt, ale chcesz korzystać z modelu Global Sharing w Altium 365 i udostępniać projekt wielu innym osobom do przeglądania i komentowania. Więcej informacji o tej funkcji znajdziesz w sekcji Tworzenie kopii lustrzanej projektu w obszarze roboczym za pomocą Simple Sync.
- Przy udostępnianiu do edycji — projekt musi zostać dodany do repozytorium projektów Git Versioned Storage obszaru roboczego. W tym trybie można udostępniać projekt wielu osobom do edycji, a także korzystać z funkcji globalnego udostępniania Altium 365, umożliwiającej wspólne przeglądanie i komentowanie. Pojawi się okno dialogowe z odpowiednią informacją oraz opcją Use Altium 365 VCS umożliwiającą wykonanie tej operacji. Kliknij Learn More , aby przejść do strony udostępniania, która przeprowadzi Cię przez proces udostępniania projektu.
Przy udostępnianiu projektu lokalnego (nieobjętego systemem VCS) innej osobie do edycji projekt musi zostać objęty kontrolą wersji przez dodanie go do repozytorium projektów Git Versioned Storage obszaru roboczego.
Wynik udostępniania
Dalszy przebieg zależy od typu zapraszanego użytkownika:
- Użytkownik, który należy już do zespołu obszaru roboczego, zostanie bezpośrednio dodany do listy osób mających dostęp do projektu i otrzyma wiadomość e-mail z powiadomieniem o udostępnieniu mu projektu. Może otworzyć projekt w Altium Designer lub uzyskać do niego dostęp przez interfejs obszaru roboczego (ze strony Projects ).
- Po dodaniu istniejącej roli obszaru roboczego pojawi się ona na liście dostępu do projektu, a wszyscy użytkownicy z przypisaną tą rolą otrzymają wiadomość e-mail z powiadomieniem o udostępnieniu im projektu. Mogą otworzyć projekt w Altium Designer lub uzyskać do niego dostęp przez interfejs obszaru roboczego (ze strony Projects ).
-
Jeśli korzystasz z obszaru roboczego Altium 365, aby udostępnić projekt osobie spoza zespołu obszaru roboczego, zostanie ona dodana do listy udostępniania i otrzyma wiadomość e-mail z powiadomieniem o udostępnieniu jej projektu. Może otworzyć projekt w Altium Designer za pomocą opcji Udostępnione mi lub uzyskać do niego dostęp przez interfejs przestrzeni osobistej na platformie Altium 365 (ze strony Shared with Me ). Otrzymana wiadomość e-mail zapewnia bezpośredni dostęp do projektu przez Altium 365. Po kliknięciu przycisku
w wiadomości e-mail użytkownik zostanie przeniesiony na stronę Altium 365 Sign In (chyba że jest już zalogowany na platformie lub na swoim koncie AltiumLive). Po zalogowaniu zostanie przeniesiony bezpośrednio do przeglądarki internetowej z załadowanym udostępnionym projektem.

Otwieranie udostępnionego projektu na podstawie zaproszenia e-mail otrzymanego przez użytkownika, który nie należy do zespołu obszaru roboczego.
Zmienianie uprawnień dostępu istniejących użytkowników
Administrator (lub członek zespołu obszaru roboczego z uprawnieniami do edycji) może w dowolnym momencie zmienić istniejące uprawnienia dostępu do projektu. Aby wyświetlić listę osób i ról, którym obecnie udostępniono projekt, kliknij pozycję
po lewej stronie okna dialogowego Share , a następnie rozwiń pole Shared with po prawej stronie.
Wyświetlanie listy osób i ról, które obecnie mają dostęp do udostępnionego projektu.
Warto pamiętać:
- Osoba lub rola ma pełne uprawnienia do edycji projektu, gdy wybrana jest opcja Can Edit W przeciwnym razie ma dostęp tylko do odczytu
- Owner oraz rola Administrators zawsze mają pełne uprawnienia do edycji (Can Edit).
-
Z wyjątkiem Owner i roli Administrators uprawnienia wszystkich uwzględnionych osób i ról można ustawić indywidualnie na Can View lub Can Edit albo całkowicie odebrać im dostęp. Można również przenieść własność projektu na innego użytkownika (patrz poniżej). Kliknij bieżące ustawienie uprawnień, aby wyświetlić dostępne opcje.
- Projekt można udostępnić określonym osobom lub rolom albo po prostu wszystkim członkom zespołu obszaru roboczego. W tym drugim przypadku ustaw wymagany poziom dostępu dla pozycji Workspace Members . Aby nie udostępniać projektu całemu zespołowi, ustaw tę pozycję na None.
Wprowadź odpowiednie zmiany uprawnień dostępu. Każda zmieniona pozycja zostanie wyróżniona na liście ciemniejszym tłem.
Przykładowe zmiany uprawnień dwóch osób, którym obecnie udostępniono projekt.
Aby zastosować zmiany, kliknij przycisk
. Zmiany zostaną zastosowane, a w oknie dialogowym pojawi się potwierdzenie. Aby wyświetlić zaktualizowaną listę uprawnień dostępu, kliknij link Who has access.
Po zapisaniu zmian uprawnień możesz sprawdzić ich wynik bezpośrednio w oknie dialogowym Share.
Przenoszenie własności projektu
Administratorzy i właściciele mogą przenieść własność na innego użytkownika za pomocą opcji Owner z listy rozwijanej bieżącego ustawienia uprawnień. Z tej opcji może skorzystać bieżący właściciel projektu lub administrator obszaru roboczego.
Po wybraniu opcji Owner dla użytkownika otworzy się okno dialogowe Transfer Ownership. Kliknij Yes, aby kontynuować.
Zmiany uprawnień bieżącego właściciela i nowego właściciela zostaną odzwierciedlone w oknie dialogowym. Kliknij Save, aby zastosować zmiany.
Użytkownik, na którego zostanie przeniesiona własność, otrzyma powiadomienie e-mail.
Uzyskiwanie dostępu do udostępnionego projektu
Sposób uzyskania dostępu do projektu udostępnionego użytkownikowi zależy od tego, czy należy on do zespołu obszaru roboczego, czy jest osobą spoza tego zespołu.
Członek zespołu obszaru roboczego
Członek zespołu obszaru roboczego może uzyskać dostęp do udostępnionego projektu przez Altium Designer lub przez stronę Projects w interfejsie obszaru roboczego. Pamiętaj, że edycja projektu — o ile użytkownik ma uprawnienia do edycji — jest możliwa tylko w Altium Designer.
W Altium Designer otwórz projekt za pomocą polecenia File » Open Project lub przycisku wielokropka przy pozycji obszaru roboczego w panelu Projects. Pojawi się okno dialogowe Open Project, w którym możesz wybrać projekt do otwarcia z połączonego obszaru roboczego. Po nawiązaniu połączenia obszar roboczy będzie widoczny w sekcji Locations tego okna, oznaczony ikoną
i wyświetlany pod nadaną mu nazwą. Na liście pojawią się tylko projekty obszaru roboczego, które zostały Ci udostępnione i do których masz uprawnienia dostępu.
Po otwarciu projekt pojawi się pod pozycją obszaru roboczego w panelu Projects.
Wybieranie w Altium Designer projektu do otwarcia z połączonego obszaru roboczego spośród projektów aktualnie Ci udostępnionych.
Zaproszony interesariusz spoza zespołu obszaru roboczego
Osoba spoza zespołu obszaru roboczego Altium 365, której udostępniono projekt, może uzyskać do niego dostęp przez Altium Designer lub przez interfejs platformy Altium 365 (ze strony Udostępnione mi). Aby otworzyć projekt, zaznacz jego kafelek i kliknij nazwę projektu albo wybierz opcję Open z menu wielokropka na kafelku. Możesz też kliknąć kafelek dwukrotnie. Pamiętaj, że edycja projektu — o ile użytkownik ma uprawnienia do edycji — jest możliwa tylko w Altium Designer.
W Altium Designer uzyskaj dostęp do projektu za pomocą polecenia File » Open Project. Pojawi się okno dialogowe Open Project, w którym możesz wybrać projekt obszaru roboczego do otwarcia z lokalizacji Shared With Me.
Po otwarciu projekt pojawi się pod pozycją Shared with me w panelu Projects. Dostępne działania zależą od przyznanych Ci praw dostępu do projektu. Jeśli przyznano Ci uprawnienia do edycji, możesz edytować projekt w standardowy sposób, co zazwyczaj ma miejsce w przypadku zewnętrznych wykonawców — ponieważ projekt jest udostępniony z obszaru roboczego, zmiany są synchronizowane w obu kierunkach. Jeśli masz jedynie uprawnienia do przeglądania, nadal możesz dodawać komentarze do projektu będącego w toku.
W Altium Designer wybierz projekt obszaru roboczego do otwarcia spośród projektów aktualnie udostępnionych Ci jako zewnętrznemu uczestnikowi. Pamiętaj, że dostęp do takich projektów nie wymaga dostępu do obszaru roboczego.
Udostępnianie migawki projektu
Utworzenie migawki projektu tylko do odczytu umożliwia szybkie udostępnienie projektu — w stanie z konkretnego momentu jego rozwoju — w celu szerszej współpracy z innymi przez Internet. Może to być przydatne do przeprowadzenia doraźnego przeglądu projektu, udostępnienia określonego kamienia milowego, a nawet zainicjowania dyskusji w kontekście projektu. Aby udostępnić projekt w ten sposób, kliknij pozycję
po lewej stronie okna dialogowego Share.
Dostęp do elementów sterujących udostępnianiem migawki projektu.
Udostępnianie za pomocą łącza
Domyślnie w oknie dialogowym wybrana jest opcja Udostępnij za pomocą łącza, co oznacza, że każda osoba, która otrzyma łącze, będzie mogła przeglądać migawkę projektu w przeglądarce przez ograniczony czas 48 godzin. Ten poziom udostępniania nie umożliwia komentowania projektu.
Kliknij przycisk
, aby wygenerować łącze do migawki projektu. W tle projekt jest pakowany do archiwum ZIP za pomocą narzędzia Project Packager w Altium Designer. Gdy łącze będzie gotowe, kliknij przycisk
, aby je skopiować, a następnie udostępnij je odpowiednim osobom.
Generowanie łącza o ograniczonym czasie ważności, które można udostępnić dowolnej osobie w dowolnym miejscu.
Gdy odbiorca otworzy łącze w przeglądarce, zostanie przekierowany do Altium 365 Viewer — w głównej witrynie altium.com — z przetworzonym i wczytanym projektem.
Korzystając z udostępnionego łącza, odbiorca może przeglądać migawkę projektu w Altium 365 Viewer, uruchomionym w głównej witrynie altium.com. Tutaj pokazano schemat — najedź kursorem na obraz, aby zobaczyć płytkę PCB.
Udostępnianie określonym osobom
Kliknięcie elementu Share with specific people przełączy tryb udostępniania migawki projektu, umożliwiając udostępnienie jej jednej lub kilku określonym osobom za pomocą zaproszenia e-mail. Odbiorcy będą mogli przeglądać, udostępniać lub pobierać migawkę projektu za pośrednictwem przeglądarkowego interfejsu platformy Altium 365. Taka migawka projektu jest stale dostępna na platformie, a ten poziom udostępniania umożliwia komentowanie projektu.
Przełącz tryb, aby móc na stałe udostępnić migawkę projektu określonym osobom.
Wprowadź pełny adres e-mail osoby, której chcesz udostępnić migawkę, i naciśnij Enter. W razie potrzeby możesz w ten sposób wskazać wiele osób. Możesz też dodać opcjonalną notatkę, aby przekazać im istotne informacje o udostępnianej migawce.
Przykład udostępniania migawki projektu określonej osobie za pomocą wiadomości e-mail.
Gdy wszystko będzie gotowe, kliknij przycisk
. Projekt zostanie spakowany do archiwum ZIP za pomocą narzędzia Project Packager w Altium Designer, a następnie przesłany na platformę Altium 365. Po zakończeniu procesu pojawi się potwierdzenie przesłania.
Udostępniana migawka jest pakowana, a następnie przesyłana na platformę Altium 365, gdzie pozostaje stale dostępna.
Osoba, której udostępniono przesłaną migawkę projektu, otrzyma wiadomość e-mail z zaproszeniem do uzyskania dostępu do tej migawki przez Altium 365. Po kliknięciu przycisku
w wiadomości e-mail zostanie przekierowana na stronę Altium 365 Sign In (chyba że jest już zalogowana na platformie lub na swoim koncie AltiumLive). Po zalogowaniu zostanie przekierowana do przeglądarki Web Viewer z wczytaną udostępnioną migawką projektu.
Uzyskiwanie dostępu do migawki projektu z zaproszenia e-mail otrzymanego przez użytkownika, któremu udostępniono migawkę.
Dostęp do udostępnionej migawki projektu
Oprócz skorzystania z łącza w zaproszeniu e-mail osoba, której udostępniono trwałą migawkę projektu, może w dowolnym momencie uzyskać dostęp do tej migawki (otwierać ją, udostępniać i przeglądać) ze Shared with Me strony interfejsu platformy Altium 365. Migawka projektu jest oznaczona ikoną
na swoim kafelku.
Aby otworzyć projekt w zintegrowanej przeglądarce, zaznacz jego kafelek i kliknij nazwę projektu lub wybierz opcję Open z menu wielokropka na kafelku. Możesz też kliknąć dwukrotnie bezpośrednio na kafelku. Pamiętaj, że udostępnionej migawki projektu nie można edytować, dlatego nie jest ona dostępna w Altium Designer w lokalizacji Shared With Me w oknie dialogowym Open Project — można ją jednak pobrać, jeśli podczas udostępniania włączono odpowiednie uprawnienie.
Dostęp do migawki projektu ze strony Shared with Me interfejsu platformy Altium 365. W tym przykładzie w udostępnionym projekcie umieszczono komentarz.
Wyłączanie udostępniania
Aby całkowicie wyłączyć udostępnianie, usuń zaznaczenie opcji Altium Cloud na stronie System – Network Activity w oknie dialogowym Preferences. Jeśli spróbujesz udostępnić projekt za pomocą okna dialogowego Share — na żywo lub w postaci migawki — pojawi się okno z ostrzeżeniem informującym, że ta opcja została wyłączona.

Wyłączenie łączności z chmurą Altium uniemożliwi udostępnianie projektów.
Obsługa przeglądów projektu
Okno dialogowe Share umożliwia przeglądanie listy instancji przeglądów danego projektu.
Po wybraniu pozycji
po lewej stronie okna dialogowego Share po prawej stronie wyświetlana jest lista aktywnych przeglądów projektu (w stanie In Progress), w których przypisano Ci rolę recenzenta. Dla każdej instancji przeglądu projektu wyświetlane są następujące dane:
-
Nazwa instancji. Kliknij łącze, aby otworzyć instancję w interfejsie przeglądarkowym Altium 365.
-
Opis.
-
Znacznik czasu zatwierdzenia/wydania, dla którego utworzono instancję przeglądu projektu.
-
Inicjator i znacznik czasu utworzenia instancji.
Jeśli projekt nie ma instancji w stanie In Progress, w prawym dolnym rogu okna dialogowego dostępny jest przycisk
. Kliknij go, aby zamknąć okno dialogowe i przejść do strony Design Reviews projektu w interfejsie przeglądarkowym przestrzeni roboczej. Otworzy się okno Create Design Review, w którym można określić recenzentów, opis oraz szablon listy kontrolnej, który ma zostać użyty.
).









).