Udostępnianie projektu

Ponieważ istotą współpracy jest wspólna praca wielu osób nad osiągnięciem jednego celu, jej kluczowym elementem jest możliwość udzielania dostępu do wspólnego zasobu i zarządzania tym dostępem — w tym przypadku chodzi o projekt i powiązane z nim dane. Przestrzeń robocza zapewnia tę możliwość dzięki kontrolowanemu, opartemu na uprawnieniach udostępnianiu projektu — w jego bieżącym stanie roboczym (WIP) lub w postaci utrwalonej migawki z danego momentu.

Należy pamiętać, że nowo utworzony projekt lub projekt udostępniony w przestrzeni roboczej jest domyślnie udostępniany następującym osobom i rolom:

  • Właścicielowi projektu, którym jest zazwyczaj projektant, który go utworzył (lub udostępnił w przestrzeni roboczej): z pełnymi uprawnieniami dostępu (odczyt/zapis).

  • Roli Administrators: z pełnymi uprawnieniami dostępu (odczyt/zapis).

Z poziomu Altium Designer obsługiwane są następujące poziomy udostępniania:

  • Sharing of a live design — sam projekt w toku (WIP), który można udostępniać:
    • Innym członkom zespołu w przestrzeni roboczej — do edycji i/lub przeglądania. Zaproszony członek zespołu może przeglądać projekt w Altium Designer lub w przestrzeni roboczej zespołu. Edycja odbywa się wyłącznie w Altium Designer. Zaproszony członek zespołu musi być zarejestrowany w AltiumLive i mieć aktywną subskrypcję licencji Altium Designer.
    • Osobom spoza zespołu w przestrzeni roboczej — do przeglądania lub edycji, za pośrednictwem zaproszenia e-mail. Ta funkcja jest dostępna tylko po połączeniu z przestrzenią roboczą Altium 365. Ten typ udostępniania umożliwia zaproszonym interesariuszom przeglądanie lub edytowanie (zależnie od uprawnień) aktualnego projektu w toku bez uzyskiwania dostępu do całej przestrzeni roboczej lub wszystkich danych projektowych. Zaproszona osoba musi być zarejestrowana w AltiumLive i może uzyskać dostęp do udostępnionego projektu ze swojej przestrzeni osobistej w Altium 365 (lub z przestrzeni roboczej swojej organizacji, jeśli jest dostępna) albo otworzyć go w Altium Designer.

    Jeśli zaproszonemu interesariuszowi przyznano wyłącznie dostęp do przeglądania, może on przeglądać projekt i dodawać do niego komentarze w Altium Designer lub za pośrednictwem interfejsu swojej przestrzeni roboczej Altium 365. Gdy osoby z uprawnieniami do edycji wprowadzają i zatwierdzają zmiany w projekcie, osoby zewnętrzne mogą na bieżąco je oglądać. Aby przeglądać udostępniony projekt w interfejsie przeglądarkowym z dowolnego miejsca, wystarczy zarejestrować się w AltiumLive.

    Jeśli zaproszonemu interesariuszowi przyznano uprawnienia do edycji projektu, może go otwierać i edytować w Altium Designer — to idealne rozwiązanie dla zewnętrznych wykonawców.

    Należy pamiętać, że udostępnianie aktualnych projektów WIP osobom spoza zespołu w przestrzeni roboczej jest możliwe po połączeniu z przestrzenią roboczą Altium 365, ale nie podczas korzystania z przestrzeni roboczej Enterprise Server. Można jednak udostępnić migawkę projektu do przeglądania i pobierania osobie spoza zespołu w przestrzeni roboczej (patrz poniżej).

    Altium Designer oferuje dodatkowe funkcje uzupełniające współpracę projektową opartą na udostępnianiu projektów w przestrzeni roboczej, w tym komentowanie dokumentów i zapobieganie konfliktom między współpracownikami.

    Po połączeniu z przestrzenią roboczą Altium 365 zaktualizowaną do nowego systemu dziedziczenia uprawnień (dowiedz się więcej) należy pamiętać, że nie można ograniczyć ani usunąć uprawnień do projektu, jeśli są one dziedziczone z folderu nadrzędnego. Przy próbie wykonania takiej operacji pojawia się komunikat o błędzie (). Aby świadomie wyłączyć dziedziczenie uprawnień z folderu nadrzędnego, należy wyłączyć opcję Inherit permissions from parent projektu w interfejsie przeglądarkowym przestrzeni roboczej.

  • Sharing of a design 'snapshot' — statyczna migawka projektu z określonego momentu, udostępniana:
    • Za pomocą łącza — dostępna dla każdego w przeglądarce. Dostęp do udostępnionego projektu na tym poziomie nie wymaga ani aktywnej subskrypcji licencji Altium Designer, ani rejestracji w AltiumLive. Odbiorca udostępnionego łącza otwiera samodzielną przeglądarkę Altium 365, aby przeglądać projekt (bez możliwości komentowania). Przeglądanie nie wymaga rejestracji w AltiumLive, a łącze jest dostępne przez 48 godzin.

    • Określonym osobom — dostępna dla wskazanych osób za pośrednictwem zaproszenia e-mail. Dostęp do udostępnionego projektu na tym poziomie wymaga rejestracji w AltiumLive, ale nie wymaga aktywnej subskrypcji licencji Altium Designer. Odbiorca uzyskuje dostęp do migawki projektu z zaproszenia e-mail za pośrednictwem przeglądarki internetowej w interfejsie przestrzeni roboczej platformy Altium 365. Przeglądanie wymaga rejestracji w AltiumLive, ale migawka jest dostępna bezterminowo. Dostępne jest również komentowanie projektu.

    Należy pamiętać, że udostępniona w ten sposób migawka projektu jest zasadniczo przeznaczona tylko do odczytu. Można ją pobrać lub przeglądać w przestrzeni roboczej Altium 365, ale w przeciwieństwie do udostępnionego projektu WIP nie można jej otworzyć do przeglądania ani edycji w Altium Designer.

    Jeśli odbiorca projektu (lub migawki projektu) udostępnionego za pośrednictwem platformy Altium 365 nie ma konta AltiumLive, musi je najpierw zarejestrować — łącze znajduje się na stronie Altium 365 Sign In.

W przypadku projektów Altium 365 obsługiwane jest tworzenie instancji przeglądu projektu i zarządzanie nimi. Instancje te można przeglądać w Altium Designer — dowiedz się więcej.  

Dostęp do opcji udostępniania

Opcje udostępniania projektu z poziomu Altium Designer znajdują się w oknie dialogowym Share, do którego można uzyskać dostęp w następujący sposób:

  • Dla aktywnego projektu — klikając przycisk w prawym górnym rogu głównego okna aplikacji lub wybierając polecenie Project » Share z menu głównego.
  • Dla projektu zaznaczonego w panelu Projects — klikając prawym przyciskiem myszy wpis projektu, a następnie wybierając polecenie Share z menu kontekstowego.
  • Podczas komentowania dokumentu projektowego — publikując komentarz ze wzmianką o użytkowniku, który nie ma dostępu do bieżącego projektu.

Jeśli nie ma aktywnego projektu — tzn. żaden dokument projektu nie jest obecnie otwarty — przycisk będzie działać na projekcie aktualnie zaznaczonym w panelu Projects.

Dostęp do okna dialogowego Share — centrum zarządzania udostępnianiem projektu z poziomu Altium Designer.
Dostęp do okna dialogowego Share — centrum zarządzania udostępnianiem projektu z poziomu Altium Designer.

Udostępnianie projektu na żywo

Gdy projekt jest zarejestrowany w przestrzeni roboczej Altium 365 (udostępniony w niej), możesz udostępniać go innym osobom. Mogą to być inni członkowie zespołu Twojej przestrzeni roboczej lub osoby spoza zespołu. Aby udostępnić projekt w ten sposób, kliknij pozycję po lewej stronie okna dialogowego Share.

Administratorzy zespołu przestrzeni roboczej mogą zawsze udostępniać projekt innym osobom do edycji lub przeglądania. Członkowie zespołu przestrzeni roboczej niebędący administratorami oraz użytkownicy spoza tego zespołu, którym udostępniono projekt, mogą udostępniać go innym do edycji lub przeglądania w zależności od własnego poziomu dostępu. Jeśli mają uprawnienia do edycji, mogą udostępniać projekt innym do edycji lub przeglądania. Jeśli mają jedynie uprawnienia do przeglądania, mogą udostępniać go innym użytkownikom wyłącznie do przeglądania i komentowania.

Dostęp do elementów sterujących umożliwiających udostępnianie innym projektu na żywo / w toku (WIP). Ilustracja przedstawia projekt, który jest już dostępny w połączonej przestrzeni roboczej.Dostęp do elementów sterujących umożliwiających udostępnianie innym projektu na żywo / w toku (WIP). Ilustracja przedstawia projekt, który jest już dostępny w połączonej przestrzeni roboczej.

Użyj elementu sterującego Copy Link, aby skopiować bezpośrednie łącze do projektu. Osoby, które mają już dostęp do projektu, mogą użyć tego łącza, aby otworzyć go w Web Viewer przestrzeni roboczej.

Udostępnianie nowym osobom

Po zakończeniu przygotowań, wybraniu projektu i połączeniu z docelową przestrzenią roboczą możesz wskazać osobę lub osoby, którym projekt ma zostać udostępniony. Aby sprawdzić, kto ma już dostęp do projektu, kliknij element sterujący Shared with. Sekcja rozwinie się i pokaże, komu udostępniono projekt oraz czy te osoby mają uprawnienia do edycji (Can Edit), czy mogą jedynie przeglądać i komentować projekt (Can View).

Sprawdź, komu projekt jest obecnie udostępniony, klikając pole Share with. Najedź kursorem na ilustrację, aby zobaczyć wynik.
Sprawdź, komu projekt jest obecnie udostępniony, klikając pole Share with. Najedź kursorem na ilustrację, aby zobaczyć wynik.

Możesz udostępnić projekt dowolnej osobie — innym użytkownikom AltiumLive z Twojej organizacji, użytkownikom AltiumLive z innych organizacji oraz osobom niekorzystającym z AltiumLive (które będą musiały zarejestrować konta AltiumLive). Pamiętaj, że po połączeniu z przestrzenią roboczą Enterprise Server możesz udostępniać projekt w toku (WIP) wyłącznie zarejestrowanym użytkownikom tej przestrzeni roboczej. Aby udostępnić projekt osobom z zewnątrz, zapoznaj się z sekcją Udostępnianie migawki projektu lub z metodą udostępniania dostępną w Twojej przestrzeni osobistej Altium 365.

Aby dodać wpis, zacznij wpisywać w polu imię i nazwisko, adres e-mail lub rolę, a następnie wybierz pasującego użytkownika lub rolę z dynamicznej listy. Lista będzie zawierać wyłącznie pasujących użytkowników z zespołu Twojej przestrzeni roboczej lub Twojej organizacji oraz istniejące role zdefiniowane dla przestrzeni roboczej. Możesz wybrać wielu użytkowników i wiele ról. Aby usunąć dodanego użytkownika lub rolę, kliknij element sterujący przy danym wpisie.

Aby udostępnić projekt osobie spoza Twojej organizacji — niezależnie od tego, czy ma konto AltiumLive — musisz wpisać jej pełny adres e-mail i nacisnąć Enter.

Ustaw uprawnienia dostępu dla dodanych osób lub ról w powiązanym menu rozwijanym, wybierając Can View () lub Can Edit (), przy czym druga opcja obejmuje również możliwość przeglądania. Początkowo ustawienie dotyczy wszystkich wpisów (osób i ról) dodanych w polu. W opcjonalnym polu notatki możesz podać informacje dotyczące zasad udostępniania tego projektu.

Administratorzy zespołu przestrzeni roboczej mogą zawsze udostępniać projekt innym osobom do edycji lub przeglądania. Członkowie zespołu przestrzeni roboczej niebędący administratorami mogą udostępniać projekt innym do edycji lub przeglądania w zależności od własnego poziomu dostępu.

Tylko użytkownicy, którym udostępniono projekt z uprawnieniami Edit, mogą udostępniać go dalej innym osobom. Wszyscy użytkownicy, którym udostępniono projekt z uprawnieniami Edit, mogą pobierać jego pliki projektowe. Dodatkowe uprawnienia udostępniania są dostępne dla administratorów i właściciela projektu w oknie dialogowym Share. Użyj Advanced Settings opcje umożliwiające określenie uprawnień do dalszego udostępniania i pobierania dla użytkowników, którym projekt ma zostać udostępniony.

Dodatkowe opcje udostępniania i pobierania są pogrupowane następująco:

  • Member Rights – dla członków obszaru roboczego:

    • Editors can share – zezwalaj członkom obszaru roboczego mającym uprawnienia Edit do udostępnionego projektu na dalsze udostępnianie go innym osobom.

    • Viewers can download – zezwalaj członkom obszaru roboczego mającym uprawnienia View do udostępnionego projektu na pobieranie plików projektu.

  • Guest and External Share Rights – dla zewnętrznych użytkowników-gości, którym udostępniono projekty:

    • Editors can share – zezwalaj osobom nienależącym do obszaru roboczego, które mają uprawnienia Edit do udostępnionego projektu, na dalsze udostępnianie go innym osobom.

    • Viewers can download – zezwalaj osobom nienależącym do obszaru roboczego, które mają uprawnienia View do udostępnionego projektu, na pobieranie plików projektu.

Zmiany w ustawieniach zaawansowanych zatwierdza się, klikając przycisk  po powrocie do głównego okna dialogowego Share.

Po określeniu odbiorców i uprawnień dostępu kliknij przycisk , aby udostępnić projekt. W oknie dialogowym pojawi się komunikat o pomyślnym udostępnieniu projektu. Następnie możesz kliknąć element Who has access, aby wrócić do listy użytkowników mających dostęp do projektu, kliknąć przycisk , aby skopiować bezpośredni link do projektu, lub po prostu zamknąć okno dialogowe, klikając OK.

Udostępnianie osobie spoza zespołu

Po połączeniu z obszarem roboczym Enterprise Server nie można udostępniać projektu w toku (WIP) osobom, które nie są zarejestrowanymi użytkownikami tego obszaru roboczego (osobom spoza zespołu). Informacje o udostępnianiu na zewnątrz obszaru roboczego Enterprise Server znajdziesz w sekcji Udostępnianie migawki projektu lub w opisie udostępniania przez przesyłanie, dostępnego w przestrzeni osobistej Altium 365.

Jeśli spróbujesz udostępnić projekt z obszaru roboczego Altium 365 osobie spoza zespołu, pojawi się okno dialogowe Confirm z ostrzeżeniem, że użytkownik uzyska dostęp do dokumentów źródłowych udostępnianego projektu, zamieszczonych komentarzy i pakietów wydania. Kliknij OK, aby kontynuować udostępnianie projektu.

Projekt można udostępnić dowolnej osobie spoza zespołu obszaru roboczego do edycji lub przeglądania.Projekt można udostępnić dowolnej osobie spoza zespołu obszaru roboczego do edycji lub przeglądania.

Udostępnianie projektu do edycji użytkownikowi spoza zespołu obszaru roboczego to idealne rozwiązanie w przypadku podwykonawców — gdy chcesz, aby aktywnie pracowali nad projektem, ale bez dołączania ich do zespołu.

Udostępnianie projektu lokalnego

Jeśli udostępniasz projekt lokalny (nieobjęty zewnętrznym systemem VCS), zostanie on umieszczony w aktualnie połączonym obszarze roboczym w momencie udostępniania go wskazanym osobom. Dalszy przebieg zależy od tego, czy udostępniasz go do przeglądania, czy do edycji:

  • Przy udostępnianiu tylko do przeglądania (i po połączeniu z obszarem roboczym Altium 365) — projekt jest udostępniany za pośrednictwem Simple Sync. W tym trybie projekt może być edytowany tylko przez jedną osobę (właściciela projektu). Zalety Simple Sync są szczególnie przydatne, gdy nie chcesz, aby inne osoby edytowały Twój projekt, ale chcesz korzystać z modelu Global Sharing w Altium 365 i udostępniać projekt wielu innym osobom do przeglądania i komentowania. Więcej informacji o tej funkcji znajdziesz w sekcji Tworzenie kopii lustrzanej projektu w obszarze roboczym za pomocą Simple Sync.
  • Przy udostępnianiu do edycji — projekt musi zostać dodany do repozytorium projektów Git Versioned Storage obszaru roboczego. W tym trybie można udostępniać projekt wielu osobom do edycji, a także korzystać z funkcji globalnego udostępniania Altium 365, umożliwiającej wspólne przeglądanie i komentowanie. Pojawi się okno dialogowe z odpowiednią informacją oraz opcją Use Altium 365 VCS umożliwiającą wykonanie tej operacji. Kliknij Learn More , aby przejść do strony udostępniania, która przeprowadzi Cię przez proces udostępniania projektu.

Przy udostępnianiu projektu lokalnego (nieobjętego systemem VCS) innej osobie do edycji projekt musi zostać objęty kontrolą wersji przez dodanie go do repozytorium projektów Git Versioned Storage obszaru roboczego.Przy udostępnianiu projektu lokalnego (nieobjętego systemem VCS) innej osobie do edycji projekt musi zostać objęty kontrolą wersji przez dodanie go do repozytorium projektów Git Versioned Storage obszaru roboczego.

Jeśli projekt lokalny jest już objęty kontrolą wersji (w zewnętrznym repozytorium projektów), pozostanie w zewnętrznym repozytorium VCS i nie zostanie dodany do wbudowanego repozytorium projektów VCS (Git) obszaru roboczego. W takim przypadku stosowana jest funkcja Simple Sync (tworzenie kopii lustrzanej), ale oczywiście wielu współpracowników może nadal pracować nad projektem i go edytować, ponieważ jest on objęty kontrolą wersji.

Pełna funkcjonalność platformy Altium 365 — a dokładniej obszaru roboczego Altium 365 — jest jednak dostępna tylko wtedy, gdy projekt jest w całości przechowywany w natywnym systemie VCS obszaru roboczego (w jego repozytorium Git Versioned Storage). Możesz przenieść projekt z zewnętrznego systemu VCS do natywnego systemu VCS obszaru roboczego za pomocą wbudowanej w Altium Designer funkcji migracji repozytorium VCS.

► Więcej informacji znajdziesz w sekcji Przechodzenie z zewnętrznego systemu VCS do natywnego systemu VCS obszaru roboczego.

  • Po połączeniu z obszarem roboczym Enterprise Server projekt lokalny udostępniany innemu użytkownikowi obszaru roboczego jest automatycznie dodawany do systemu VCS tego obszaru. Projekt, znajdujący się już w obszarze roboczym, zostanie udostępniony wskazanemu użytkownikowi z uprawnieniami do przeglądania lub edycji, zgodnie z wyborem dokonanym w oknie dialogowym Share.
  • Pamiętaj, że obszar roboczy Enterprise Server nie umożliwia udostępniania projektu w toku (WIP) osobom spoza zespołu obszaru roboczego, czyli osobom, które nie są jego zarejestrowanymi użytkownikami.

Wynik udostępniania

Dalszy przebieg zależy od typu zapraszanego użytkownika:

  • Użytkownik, który należy już do zespołu obszaru roboczego, zostanie bezpośrednio dodany do listy osób mających dostęp do projektu i otrzyma wiadomość e-mail z powiadomieniem o udostępnieniu mu projektu. Może otworzyć projekt w Altium Designer lub uzyskać do niego dostęp przez interfejs obszaru roboczego (ze strony Projects ).
  • Po dodaniu istniejącej roli obszaru roboczego pojawi się ona na liście dostępu do projektu, a wszyscy użytkownicy z przypisaną tą rolą otrzymają wiadomość e-mail z powiadomieniem o udostępnieniu im projektu. Mogą otworzyć projekt w Altium Designer lub uzyskać do niego dostęp przez interfejs obszaru roboczego (ze strony Projects ).
  • Jeśli korzystasz z obszaru roboczego Altium 365, aby udostępnić projekt osobie spoza zespołu obszaru roboczego, zostanie ona dodana do listy udostępniania i otrzyma wiadomość e-mail z powiadomieniem o udostępnieniu jej projektu. Może otworzyć projekt w Altium Designer za pomocą opcji Udostępnione mi lub uzyskać do niego dostęp przez interfejs przestrzeni osobistej na platformie Altium 365 (ze strony Shared with Me ). Otrzymana wiadomość e-mail zapewnia bezpośredni dostęp do projektu przez Altium 365. Po kliknięciu przycisku w wiadomości e-mail użytkownik zostanie przeniesiony na stronę Altium 365 Sign In (chyba że jest już zalogowany na platformie lub na swoim koncie AltiumLive). Po zalogowaniu zostanie przeniesiony bezpośrednio do przeglądarki internetowej z załadowanym udostępnionym projektem.

    Po połączeniu z obszarem roboczym Enterprise Server nie można udostępniać projektu w toku (WIP) osobom spoza zespołu (użytkownikom zewnętrznym). Jednak:

Jeśli dana osoba nie ma konta AltiumLive, musi je najpierw założyć — odpowiedni link znajduje się na stronie Altium 365 Sign In.

Otwieranie udostępnionego projektu na podstawie zaproszenia e-mail otrzymanego przez użytkownika, który nie należy do zespołu obszaru roboczego.
Otwieranie udostępnionego projektu na podstawie zaproszenia e-mail otrzymanego przez użytkownika, który nie należy do zespołu obszaru roboczego.

Zmienianie uprawnień dostępu istniejących użytkowników

Administrator (lub członek zespołu obszaru roboczego z uprawnieniami do edycji) może w dowolnym momencie zmienić istniejące uprawnienia dostępu do projektu. Aby wyświetlić listę osób i ról, którym obecnie udostępniono projekt, kliknij pozycję po lewej stronie okna dialogowego Share , a następnie rozwiń pole Shared with po prawej stronie.

Wyświetlanie listy osób i ról, które obecnie mają dostęp do udostępnionego projektu.Wyświetlanie listy osób i ról, które obecnie mają dostęp do udostępnionego projektu.

Warto pamiętać:

  • Osoba lub rola ma pełne uprawnienia do edycji projektu, gdy wybrana jest opcja Can Edit (). W przeciwnym razie ma dostęp tylko do odczytu ().
  • Owner oraz rola Administrators zawsze mają pełne uprawnienia do edycji (Can Edit).
  • Z wyjątkiem Owner i roli Administrators uprawnienia wszystkich uwzględnionych osób i ról można ustawić indywidualnie na Can View lub Can Edit albo całkowicie odebrać im dostęp. Można również przenieść własność projektu na innego użytkownika (patrz poniżej). Kliknij bieżące ustawienie uprawnień, aby wyświetlić dostępne opcje.

  • Projekt można udostępnić określonym osobom lub rolom albo po prostu wszystkim członkom zespołu obszaru roboczego. W tym drugim przypadku ustaw wymagany poziom dostępu dla pozycji Workspace Members . Aby nie udostępniać projektu całemu zespołowi, ustaw tę pozycję na None.

Wprowadź odpowiednie zmiany uprawnień dostępu. Każda zmieniona pozycja zostanie wyróżniona na liście ciemniejszym tłem.

Przykładowe zmiany uprawnień dwóch osób, którym obecnie udostępniono projekt.Przykładowe zmiany uprawnień dwóch osób, którym obecnie udostępniono projekt.

Aby zastosować zmiany, kliknij przycisk . Zmiany zostaną zastosowane, a w oknie dialogowym pojawi się potwierdzenie. Aby wyświetlić zaktualizowaną listę uprawnień dostępu, kliknij link Who has access.

Po zapisaniu zmian uprawnień możesz sprawdzić ich wynik bezpośrednio w oknie dialogowym Share.Po zapisaniu zmian uprawnień możesz sprawdzić ich wynik bezpośrednio w oknie dialogowym Share.

  • Pamiętaj, że udostępnienie projektu innemu użytkownikowi można w dowolnym momencie cofnąć, wybierając dla niego opcję Remove w oknie dialogowym Share.
  • Pamiętaj również, że jeśli zmieniasz uprawnienia na Can Edit dla osoby spoza zespołu obszaru roboczego Altium 365, w oknie dialogowym Sharing Outside of the Workspace pojawi się prośba o potwierdzenie, czy przyznać jej uprawnienia tylko do odczytu, czy do edycji.

Przenoszenie własności projektu

Administratorzy i właściciele mogą przenieść własność na innego użytkownika za pomocą opcji Owner z listy rozwijanej bieżącego ustawienia uprawnień. Z tej opcji może skorzystać bieżący właściciel projektu lub administrator obszaru roboczego.

Własność można przenieść wyłącznie na innego członka obszaru roboczego. Przeniesienie jej na użytkownika spoza obszaru roboczego nie jest dostępne.

Po wybraniu opcji Owner dla użytkownika otworzy się okno dialogowe Transfer Ownership. Kliknij Yes, aby kontynuować.

Zmiany uprawnień bieżącego właściciela i nowego właściciela zostaną odzwierciedlone w oknie dialogowym. Kliknij Save, aby zastosować zmiany.

Po przeniesieniu własności bieżącemu właścicielowi zostaną przypisane następujące uprawnienia dostępu:

  • Uprawnienia do edycji, jeśli projekt jest objęty kontrolą wersji.
  • Uprawnienia do odczytu, jeśli projekt korzysta z SimpleSync.

Użytkownik, na którego zostanie przeniesiona własność, otrzyma powiadomienie e-mail.

Uzyskiwanie dostępu do udostępnionego projektu

Sposób uzyskania dostępu do projektu udostępnionego użytkownikowi zależy od tego, czy należy on do zespołu obszaru roboczego, czy jest osobą spoza tego zespołu.

Członek zespołu obszaru roboczego

Członek zespołu obszaru roboczego może uzyskać dostęp do udostępnionego projektu przez Altium Designer lub przez stronę Projects w interfejsie obszaru roboczego. Pamiętaj, że edycja projektu — o ile użytkownik ma uprawnienia do edycji — jest możliwa tylko w Altium Designer.

W Altium Designer otwórz projekt za pomocą polecenia File » Open Project lub przycisku wielokropka przy pozycji obszaru roboczego w panelu Projects. Pojawi się okno dialogowe Open Project, w którym możesz wybrać projekt do otwarcia z połączonego obszaru roboczego. Po nawiązaniu połączenia obszar roboczy będzie widoczny w sekcji Locations tego okna, oznaczony ikoną i wyświetlany pod nadaną mu nazwą. Na liście pojawią się tylko projekty obszaru roboczego, które zostały Ci udostępnione i do których masz uprawnienia dostępu.

Po otwarciu projekt pojawi się pod pozycją obszaru roboczego w panelu Projects.

Wybieranie w Altium Designer projektu do otwarcia z połączonego obszaru roboczego spośród projektów aktualnie Ci udostępnionych. Wybieranie w Altium Designer projektu do otwarcia z połączonego obszaru roboczego spośród projektów aktualnie Ci udostępnionych.

Możesz otworzyć projekt w domyślnej lokalizacji kopii roboczej lub użyć menu rozwijanego , aby określić własną ścieżkę. Domyślna ścieżka kopii roboczej jest pobierana z pola Document Path na stronie System – Default Locations w oknie dialogowym Preferences.
Podczas przeglądania projektu w panelu Explorer programu Altium Designer — skonfigurowanym w domyślnym trybie Project View zamiast Classic View — kliknij przycisk w prawym górnym rogu panelu, aby otworzyć projekt w Altium Designer (i dodać go do panelu Projects). Użyj przycisku , aby otworzyć projekt do przeglądania w interfejsie internetowym połączonego obszaru roboczego.

Zaproszony interesariusz spoza zespołu obszaru roboczego

Osoba spoza zespołu obszaru roboczego Altium 365, której udostępniono projekt, może uzyskać do niego dostęp przez Altium Designer lub przez interfejs platformy Altium 365 (ze strony Udostępnione mi). Aby otworzyć projekt, zaznacz jego kafelek i kliknij nazwę projektu albo wybierz opcję Open z menu wielokropka na kafelku. Możesz też kliknąć kafelek dwukrotnie. Pamiętaj, że edycja projektu — o ile użytkownik ma uprawnienia do edycji — jest możliwa tylko w Altium Designer.

W przypadku korzystania z obszaru roboczego Enterprise Server projektu WIP nie można udostępniać poza zespołem (użytkownikom zewnętrznym).

Jeśli jednak jesteś odbiorcą projektu udostępnionego przez członka obszaru roboczego Altium 365, będzie on dostępny w Altium Designer w lokalizacji Shared with Me, jak opisano poniżej, a także do przeglądania w Twojej przestrzeni osobistej.

W Altium Designer uzyskaj dostęp do projektu za pomocą polecenia File » Open Project. Pojawi się okno dialogowe Open Project, w którym możesz wybrać projekt obszaru roboczego do otwarcia z lokalizacji Shared With Me.

Po otwarciu projekt pojawi się pod pozycją Shared with me w panelu Projects. Dostępne działania zależą od przyznanych Ci praw dostępu do projektu. Jeśli przyznano Ci uprawnienia do edycji, możesz edytować projekt w standardowy sposób, co zazwyczaj ma miejsce w przypadku zewnętrznych wykonawców — ponieważ projekt jest udostępniony z obszaru roboczego, zmiany są synchronizowane w obu kierunkach. Jeśli masz jedynie uprawnienia do przeglądania, nadal możesz dodawać komentarze do projektu będącego w toku.

W Altium Designer wybierz projekt obszaru roboczego do otwarcia spośród projektów aktualnie udostępnionych Ci jako zewnętrznemu uczestnikowi. Pamiętaj, że dostęp do takich projektów nie wymaga dostępu do obszaru roboczego.W Altium Designer wybierz projekt obszaru roboczego do otwarcia spośród projektów aktualnie udostępnionych Ci jako zewnętrznemu uczestnikowi. Pamiętaj, że dostęp do takich projektów nie wymaga dostępu do obszaru roboczego.

Możesz otworzyć projekt w domyślnej lokalizacji kopii roboczej lub użyć menu rozwijanego , aby określić własną ścieżkę. Domyślna ścieżka kopii roboczej jest pobierana z pola Document Path na stronie System – Default Locations w oknie dialogowym Preferences.

Udostępnianie migawki projektu

Utworzenie migawki projektu tylko do odczytu umożliwia szybkie udostępnienie projektu — w stanie z konkretnego momentu jego rozwoju — w celu szerszej współpracy z innymi przez Internet. Może to być przydatne do przeprowadzenia doraźnego przeglądu projektu, udostępnienia określonego kamienia milowego, a nawet zainicjowania dyskusji w kontekście projektu. Aby udostępnić projekt w ten sposób, kliknij pozycję po lewej stronie okna dialogowego Share.

Dostęp do elementów sterujących udostępnianiem migawki projektu.Dostęp do elementów sterujących udostępnianiem migawki projektu.

Każdy użytkownik, który aktualnie przegląda projekt w Altium Designer, może udostępnić jego migawkę.

Udostępnianie za pomocą łącza

Domyślnie w oknie dialogowym wybrana jest opcja Udostępnij za pomocą łącza, co oznacza, że każda osoba, która otrzyma łącze, będzie mogła przeglądać migawkę projektu w przeglądarce przez ograniczony czas 48 godzin. Ten poziom udostępniania nie umożliwia komentowania projektu.

Ten poziom udostępniania nie wymaga zalogowania się na konto Altium w Altium Designer.
Pamiętaj, że migawki projektu udostępniane za pomocą łącza mogą być indeksowane przez wyszukiwarki i dostępne dla ich użytkowników.

Kliknij przycisk , aby wygenerować łącze do migawki projektu. W tle projekt jest pakowany do archiwum ZIP za pomocą narzędzia Project Packager w Altium Designer. Gdy łącze będzie gotowe, kliknij przycisk , aby je skopiować, a następnie udostępnij je odpowiednim osobom.

Generowanie łącza o ograniczonym czasie ważności, które można udostępnić dowolnej osobie w dowolnym miejscu.Generowanie łącza o ograniczonym czasie ważności, które można udostępnić dowolnej osobie w dowolnym miejscu.

Gdy odbiorca otworzy łącze w przeglądarce, zostanie przekierowany do Altium 365 Viewer — w głównej witrynie altium.com — z przetworzonym i wczytanym projektem.

Korzystając z udostępnionego łącza, odbiorca może przeglądać migawkę projektu w Altium 365 Viewer, uruchomionym w głównej witrynie altium.com. Tutaj pokazano schemat — najedź kursorem na obraz, aby zobaczyć płytkę PCB.Korzystając z udostępnionego łącza, odbiorca może przeglądać migawkę projektu w Altium 365 Viewer, uruchomionym w głównej witrynie altium.com. Tutaj pokazano schemat — najedź kursorem na obraz, aby zobaczyć płytkę PCB.

Po przesłaniu projektu (w archiwum ZIP) do Altium 365 Viewer jest on usuwany natychmiast po przetworzeniu. W rezultacie możliwość przeglądania projektu jest ograniczona w czasie — jest on dostępny przez czas trwania sesji przeglądarki (i przestaje być dostępny po zamknięciu karty przeglądarki). Możesz też ponownie użyć łącza w dowolnym momencie w dozwolonym okresie 48 godzin.

Udostępnianie określonym osobom

Kliknięcie elementu Share with specific people przełączy tryb udostępniania migawki projektu, umożliwiając udostępnienie jej jednej lub kilku określonym osobom za pomocą zaproszenia e-mail. Odbiorcy będą mogli przeglądać, udostępniać lub pobierać migawkę projektu za pośrednictwem przeglądarkowego interfejsu platformy Altium 365. Taka migawka projektu jest stale dostępna na platformie, a ten poziom udostępniania umożliwia komentowanie projektu.

Ten poziom udostępniania wymaga zalogowania się na konto Altium w Altium Designer (przy użyciu danych logowania do konta AltiumLive). Jeśli nie jesteś obecnie zalogowany na konto Altium, w oknie dialogowym pojawi się łącze umożliwiające zalogowanie się (otwierające okno dialogowe Sign In) lub rejestrację w AltiumLive, jeśli nie masz jeszcze konta.

Przełącz tryb, aby móc na stałe udostępnić migawkę projektu określonym osobom.Przełącz tryb, aby móc na stałe udostępnić migawkę projektu określonym osobom.

Wprowadź pełny adres e-mail osoby, której chcesz udostępnić migawkę, i naciśnij Enter. W razie potrzeby możesz w ten sposób wskazać wiele osób. Możesz też dodać opcjonalną notatkę, aby przekazać im istotne informacje o udostępnianej migawce.

Przykład udostępniania migawki projektu określonej osobie za pomocą wiadomości e-mail.Przykład udostępniania migawki projektu określonej osobie za pomocą wiadomości e-mail.

Użyj opcji Advanced Settings w oknie dialogowym Share, aby określić uprawnienia dotyczące udostępnianej migawki projektu (). Wybierz Allow sharing, aby umożliwić wskazanej osobie dalsze udostępnianie migawki projektu, oraz opcję Allow downloading, aby umożliwić pobieranie migawki (w archiwum ZIP).

Gdy wszystko będzie gotowe, kliknij przycisk . Projekt zostanie spakowany do archiwum ZIP za pomocą narzędzia Project Packager w Altium Designer, a następnie przesłany na platformę Altium 365. Po zakończeniu procesu pojawi się potwierdzenie przesłania.

Udostępniana migawka jest pakowana, a następnie przesyłana na platformę Altium 365, gdzie pozostaje stale dostępna.Udostępniana migawka jest pakowana, a następnie przesyłana na platformę Altium 365, gdzie pozostaje stale dostępna.

Osoba, której udostępniono przesłaną migawkę projektu, otrzyma wiadomość e-mail z zaproszeniem do uzyskania dostępu do tej migawki przez Altium 365. Po kliknięciu przycisku w wiadomości e-mail zostanie przekierowana na stronę Altium 365 Sign In (chyba że jest już zalogowana na platformie lub na swoim koncie AltiumLive). Po zalogowaniu zostanie przekierowana do przeglądarki Web Viewer z wczytaną udostępnioną migawką projektu.

Jeśli ta osoba nie ma konta AltiumLive, musi je najpierw założyć — formularz tworzenia konta jest dostępny po otwarciu łącza Altium 365.

Uzyskiwanie dostępu do migawki projektu z zaproszenia e-mail otrzymanego przez użytkownika, któremu udostępniono migawkę.Uzyskiwanie dostępu do migawki projektu z zaproszenia e-mail otrzymanego przez użytkownika, któremu udostępniono migawkę.

Dostęp do udostępnionej migawki projektu

Oprócz skorzystania z łącza w zaproszeniu e-mail osoba, której udostępniono trwałą migawkę projektu, może w dowolnym momencie uzyskać dostęp do tej migawki (otwierać ją, udostępniać i przeglądać) ze Shared with Me strony  interfejsu platformy Altium 365. Migawka projektu jest oznaczona ikoną na swoim kafelku.

Aby otworzyć projekt w zintegrowanej przeglądarce, zaznacz jego kafelek i kliknij nazwę projektu lub wybierz opcję Open z menu wielokropka na kafelku. Możesz też kliknąć dwukrotnie bezpośrednio na kafelku. Pamiętaj, że udostępnionej migawki projektu nie można edytować, dlatego nie jest ona dostępna w Altium Designer w lokalizacji Shared With Me w oknie dialogowym Open Project — można ją jednak pobrać, jeśli podczas udostępniania włączono odpowiednie uprawnienie.

Dostęp do migawki projektu ze strony Shared with Me  interfejsu platformy Altium 365. W tym przykładzie w udostępnionym projekcie umieszczono komentarz.Dostęp do migawki projektu ze strony Shared with Me interfejsu platformy Altium 365. W tym przykładzie w udostępnionym projekcie umieszczono komentarz.

Osoba, która pierwotnie udostępniła migawkę projektu — przesyłając ją na stałe na platformę Altium 365 — również będzie mogła uzyskać do niej dostęp ze strony Files swojej przestrzeni osobistej.

Wyłączanie udostępniania

Aby całkowicie wyłączyć udostępnianie, usuń zaznaczenie opcji Altium Cloud na stronie System – Network Activity w oknie dialogowym Preferences. Jeśli spróbujesz udostępnić projekt za pomocą okna dialogowego Share — na żywo lub w postaci migawki — pojawi się okno z ostrzeżeniem informującym, że ta opcja została wyłączona.

Wyłączenie łączności z chmurą Altium uniemożliwi udostępnianie projektów.
Wyłączenie łączności z chmurą Altium uniemożliwi udostępnianie projektów.

Obsługa przeglądów projektu

Okno dialogowe Share umożliwia przeglądanie listy instancji przeglądów danego projektu.

Funkcja przeglądów projektu umożliwia tworzenie uporządkowanych instancji przeglądów projektów w przestrzeni roboczej Altium 365 oraz zarządzanie nimi.

Aby dowiedzieć się więcej, zapoznaj się ze stroną Przeglądy projektu.

Po wybraniu pozycji  po lewej stronie okna dialogowego Share po prawej stronie wyświetlana jest lista aktywnych przeglądów projektu (w stanie In Progress), w których przypisano Ci rolę recenzenta. Dla każdej instancji przeglądu projektu wyświetlane są następujące dane:

  • Nazwa instancji. Kliknij łącze, aby otworzyć instancję w interfejsie przeglądarkowym Altium 365.

  • Opis.

  • Znacznik czasu zatwierdzenia/wydania, dla którego utworzono instancję przeglądu projektu.

  • Inicjator i znacznik czasu utworzenia instancji.

Jeśli projekt nie ma instancji w stanie In Progress, w prawym dolnym rogu okna dialogowego dostępny jest przycisk . Kliknij go, aby zamknąć okno dialogowe i przejść do strony Design Reviews projektu w interfejsie przeglądarkowym przestrzeni roboczej. Otworzy się okno Create Design Review, w którym można określić recenzentów, opis oraz szablon listy kontrolnej, który ma zostać użyty.

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Nav
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents