Przygotowywanie plików wyjściowych i zwalnianie projektu

W skrócie

Przygotuj gotowy projekt PCB do produkcji dzięki temu samouczkowi, który krok po kroku przeprowadzi Cię przez cały proces w Altium Designer. Dowiedz się, jak tworzyć pliki Output Job, konfigurować dokumentację produkcyjną i montażową oraz uwzględnić kontrolę reguł projektowych w procesie wydania projektu. Po skonfigurowaniu plików wyjściowych projekt będzie gotowy do wydania. Czytaj dalej, aby przejść przez te końcowe etapy przygotowania projektu PCB.

- Skonfiguruj pliki wyjściowe Gerber i NC Drill, w tym jednostki, precyzję i lokalizacje zapisu.
- Skonfiguruj pliki wyjściowe BOM, Draftsman oraz Pick & Place na potrzeby dokumentacji montażowej.
- Dodaj raport weryfikacji DRC, aby sprawdzić zgodność z regułami projektowymi przed wygenerowaniem pozostałych plików wyjściowych do wydania.
Zagłęb się w temat dzięki AI:

Main page: Przygotowanie projektu do produkcji

Po zakończeniu projektowania i rozmieszczania elementów oraz prowadzenia ścieżek na PCB można przygotować dokumentację wyjściową potrzebną do weryfikacji, wykonania i montażu płytki.

Ponieważ w produkcji PCB stosuje się różne technologie i metody, Altium Designer umożliwia generowanie wielu typów danych wyjściowych do różnych celów, w tym plików Gerber, plików ODB++, plików Pick and Place, zestawień materiałowych itp.

Dodawanie pliku Output Job do projektu

Main page: Przygotowywanie danych produkcyjnych za pomocą plików Output Job

Choć wymagane dane wyjściowe można generować wybiórczo w poszczególnych edytorach (np. za pomocą poleceń w podmenu Fabrication Outputs i Assembly Outputs menu głównego File w edytorze PCB), Altium Designer obsługuje również pliki Output Job. Plik Output Job (w skrócie „OutJob”) przechowuje ustawienia każdego typu danych wyjściowych. Umożliwia on skonfigurowanie poszczególnych typów danych wyjściowych, ich nazewnictwa, formatu i lokalizacji zapisu. Dane wyjściowe można generować bezpośrednio z pliku OutJob lub w ramach zintegrowanego procesu wydawania projektu.

  1. Kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects i wybierz polecenie Add New to Project » Output Job File z menu kontekstowego. Otworzy się nowy plik Output Job, a powiązana z projektem pozycja tego pliku pojawi się w panelu Projects pod pozycją Settings\Output Job Files.

    Javascript ID: Tutorial_AddNewOutJob_AD25_4
  2. Kliknij prawym przyciskiem myszy pozycję pliku OutJob w panelu Projects i wybierz polecenie Save As. Otworzy się okno dialogowe Save As , umożliwiające zapisanie dokumentu w tej samej lokalizacji co plik projektu. Wpisz nazwę Fabrication w polu File name i kliknij przycisk Save.

  3. Dodanie pliku OutJob spowodowało zmianę projektu, dlatego zapisz projekt lokalnie, klikając prawym przyciskiem myszy pozycję projektu w panelu Projects i wybierając Save.

Dodawanie i konfigurowanie danych wyjściowych do wykonania płytki

Main page: Przygotowywanie danych do wykonania płytki

W tej części samouczka skonfigurujesz dane wyjściowe wymagane do wykonania płytki: pliki Gerber i NC Drill. 

  1. Aby dodać nowe dane wyjściowe Gerber, kliknij łącze Add New Fabrication Output w sekcji Fabrication Outputs obszaru Outputs pliku OutJob i wybierz Gerber Files » [PCB Document].

    Jeśli wybierzesz opcję [PCB Document], dokument PCB projektu zostanie automatycznie użyty jako źródło danych wyjściowych. Dzięki temu plik OutJob można też łatwo kopiować między projektami, ponieważ nie trzeba aktualizować tego ustawienia. Jeśli projekt zawiera wiele dokumentów PCB, należy wybrać konkretną płytkę.

  2. Kliknij dwukrotnie dodaną pozycję danych wyjściowych Gerber Files. Otworzy się okno dialogowe Gerber Setup. Skonfiguruj w nim opcje w następujący sposób:

    1. Ponieważ płytka została zaprojektowana w jednostkach metrycznych, upewnij się, że opcja Units jest ustawiona na Millimeters.

    2. Najmniejszy wymiar zastosowany na płytce dla ścieżek i odstępów wynosi 0,25 mm, ale ponieważ większość elementów ma punkt odniesienia w swoim środku geometrycznym (i została rozmieszczona na siatce 1 mm), niektóre ich pola lutownicze będą w rzeczywistości leżeć na siatce 0,01 mm. Ustaw opcję Decimal na 0.001 mm. Zapewni to rozdzielczość danych wyjściowych w pełni wystarczającą do odwzorowania tych położeń na siatce.

    3. Kliknij przycisk  u dołu karty Layer to plot i wybierz Select Used. Warstwy używane w projekcie zostaną włączone w kolumnie Plot powyższej tabeli.

  3. Kliknij Apply, aby zaakceptować pozostałe ustawienia domyślne i zamknąć okno dialogowe Gerber Setup.

  4. Ponieważ płytka ma otwory, należy również wygenerować plik NC Drill. W ten sam sposób dodaj dane wyjściowe NC Drill do pliku OutJob — kliknij łącze Add New Fabrication Output w sekcji Fabrication Outputs obszaru Outputs pliku OutJob i wybierz NC Drill Files » [PCB Document].

  5. Kliknij dwukrotnie dodaną pozycję danych wyjściowych NC Drill Files, aby otworzyć okno dialogowe NC Drill Setup. Aby pliki NC Drill były tworzone w tym samym formacie co pliki Gerber, ustaw Units na Millimeters, a Format na 4:3. Upewnij się, że opcja Coordinate Position jest ustawiona na Reference to relative origin.

  6. Kliknij OK, aby zaakceptować pozostałe ustawienia domyślne i zamknąć okno dialogowe NC Drill Setup.

  7. Po skonfigurowaniu ustawień Gerber i NC Drill następnym krokiem jest skonfigurowanie nazewnictwa plików oraz lokalizacji ich zapisu. W tym celu należy przypisać je do kontenera wyjściowego po prawej stronie pliku OutJob. W przypadku osobnych plików mających własny format użyj kontenera struktury folderów. Nowy plik OutJob domyślnie zawiera kilka kontenerów. Wybierz pozycję Folder Structure na liście kontenerów wyjściowych, a następnie kliknij przyciski opcji dla plików Gerber i NC Drill w kolumnie Enabled obszaru Outputs, aby przypisać te dane wyjściowe do wybranego kontenera, jak pokazano poniżej.

  8. Ostatnim krokiem jest skonfigurowanie kontenera. W tym celu kliknij łącze Change w zaznaczonej pozycji kontenera, aby otworzyć okno dialogowe Folder Structure settings. W górnej części okna znajduje się zestaw elementów sterujących służących do konfigurowania lokalizacji zapisu danych wyjściowych. Upewnij się, że pierwszy z nich jest ustawiony na Release Managed. Dolna część okna dialogowego pokazuje, jak nazwy i struktura folderów zmieniają się w zależności od wybranych opcji.

  9. Kliknij OK, aby zamknąć okno dialogowe Folder Structure settings.

Dodawanie i konfigurowanie raportu weryfikacji DRC

Main page: Przygotowywanie raportów weryfikacji

Altium Designer oferuje szereg kontroli weryfikacyjnych, które można uwzględnić podczas generowania danych wyjściowych. Każda z nich tworzy plik raportu HTML. Podczas procesu wydawania projektu kontrole te są wykonywane przed wygenerowaniem pozostałych danych wyjściowych. Jeśli którakolwiek z nich zakończy się niepowodzeniem, wydanie projektu nie powiedzie się.

  1. Aby dodać nowy raport weryfikacji DRC do danych wyjściowych, kliknij łącze Add Validation Output w sekcji Validation Outputs obszaru Outputs pliku OutJob i wybierz Design Rules Check » [PCB Document].

  2. Przypisz dodany raport do istniejącego kontenera Folder Structure. Wybierz pozycję Folder Structure na liście po prawej stronie pliku OutJob, a następnie kliknij przycisk opcji dla danych wyjściowych Design Rules Check w kolumnie Enabled obszaru Outputs.

  3. Zapisz plik Output Job lokalnie, klikając prawym przyciskiem myszy jego pozycję w panelu Projects i wybierając Save z menu kontekstowego.

  4. Zamknij plik Output Job, klikając prawym przyciskiem myszy jego kartę u góry obszaru projektowego i wybierając polecenie Close Fabrication.OutJob z menu kontekstowego. 

Dodawanie i konfigurowanie plików wyjściowych do montażu

Main page: Konfiguracja zestawienia BOM w menedżerze raportów

Właściwy plik wyjściowy BOM jest generowany za pomocą okna dialogowego Report Manager – wysoce konfigurowalnego narzędzia do generowania raportów, które umożliwia tworzenie plików wyjściowych w różnych formatach, w tym tekstowym, CSV, PDF, HTML i Excel. Do zestawień BOM w formacie Excel można również zastosować jeden z predefiniowanych szablonów lub własny szablon.

  1. Dodaj nowy plik OutJob do projektu, klikając prawym przyciskiem myszy pozycję projektu w panelu Projects i wybierając polecenie Add New to Project » Output Job File z menu kontekstowego.

  2. Kliknij prawym przyciskiem myszy pozycję OutJob w panelu Projects i wybierz polecenie Save As. Otworzy się okno dialogowe Save As, gotowe do zapisania dokumentu w tej samej lokalizacji co plik projektu. Wpisz nazwę Assembly w polu File name i kliknij przycisk Save.

  3. Zapisz projekt lokalnie, klikając prawym przyciskiem myszy pozycję projektu w panelu Projects i wybierając Save.

  4. Aby dodać nowe zestawienie BOM jako plik wyjściowy, kliknij łącze Add New Report Output w sekcji Report Outputs pliku OutJob i wybierz Bill of Materials » [ActiveBOM Document].

  5. Kliknij dwukrotnie dodaną pozycję wyjściową Bill of Materials, aby otworzyć okno dialogowe Report Manager.

  6. W obszarze Export Options panelu Properties po prawej stronie okna dialogowego wybierz Generic XLS (*.xls, *.xlsx, *.xlsm) z listy rozwijanej File Format, a następnie z listy rozwijanej Template wybierz szablon BOM Template Single Supplier spośród szablonów znajdujących się w Twoim obszarze roboczym.

  7. Kliknij OK, aby zapisać zmiany i zamknąć okno dialogowe Report Manager.

  8. Dodaj nowy plik wyjściowy Draftsman, klikając łącze Add New Documentation Output w sekcji Documentation Outputs pliku OutJob i wybierając Draftsman » All Draftsman Documents.

  9. Przypisz dodane pozycje wyjściowe BOM i Draftsman do istniejącego kontenera wyjściowego PDF. W tym celu wybierz pozycję PDF na liście kontenerów wyjściowych po prawej stronie pliku OutJob, a następnie kliknij przyciski opcji dla pozycji wyjściowych Bill of Materials i Draftsman w kolumnie Enabled obszaru Outputs.

  10. Po zaznaczeniu pozycji kontenera PDF kliknij znajdujące się w niej łącze Change, aby otworzyć okno dialogowe PDF settings.

  11. Kliknij pozycję Assembly.PDF u góry okna dialogowego PDF settings, wybierz Separate file for each output using output name i kliknij przycisk . Wyjściowemu zestawieniu BOM i rysunkowi zostaną przypisane nazwy ustawione dla tych plików wyjściowych w pliku OutJob (odpowiednio Bill of Materials.pdf i Draftsman.pdf), widoczne w obszarze Preview okna dialogowego.

    Javascript ID: Tutorial_Dlg_PDFsettings_Path_AD24
  12. Kliknij OK, aby zamknąć okno dialogowe.

  13. Dodaj nowy plik wyjściowy Pick & Place, klikając łącze Add New Documentation Output w sekcji Documentation Outputs pliku OutJob i wybierając Generates pick and place files » [PCB Document].

  14. Kliknij dwukrotnie dodaną pozycję wyjściową Generates pick and place files, aby otworzyć okno dialogowe Pick and Place Setup.

  15. W obszarze Output Setting w lewej dolnej części okna dialogowego ustaw Units na Metric.

  16. Kliknij OK, aby zaakceptować pozostałe ustawienia domyślne i zamknąć okno dialogowe Pick and Place Setup.

  17. Przypisz dodaną pozycję wyjściową Pick & Place do istniejącego kontenera wyjściowego Folder Structure. W tym celu wybierz pozycję Folder Structure na liście kontenerów wyjściowych po prawej stronie pliku OutJob, a następnie kliknij przycisk opcji dla pozycji wyjściowej Generates pick and place files w kolumnie Enabled obszaru Outputs.

  18. Zapisz plik Output Job lokalnie, klikając prawym przyciskiem myszy jego pozycję w panelu Projects i wybierając Save z menu kontekstowego.

  19. Zamknij plik Output Job, klikając prawym przyciskiem myszy jego kartę u góry obszaru projektowego i wybierając polecenie Close Assembly.OutJob z menu kontekstowego.

Wydawanie projektu

Main page: Wydawanie projektu płytki

Po skonfigurowaniu dokumentacji wyjściowej w plikach Output Job projekt jest gotowy do wydania w połączonym obszarze roboczym. Proces wydawania projektu płytki jest zautomatyzowany, co pozwala wydawać projekty płytek bez ryzyka związanego z ręcznymi procedurami wydawania. Podczas wydawania danego projektu tworzona jest migawka jego plików źródłowych, która jest archiwizowana wraz ze wszystkimi wygenerowanymi plikami wyjściowymi – odzwierciedlającymi fizyczny produkt wytwarzany na podstawie tego projektu i sprzedawany przez firmę.

Sam proces wydawania odbywa się za pomocą narzędzia Project Releaser programu Altium Designer, którego interfejs użytkownika jest dostępny w dedykowanym widoku Release. Proces wydawania jest podzielony na etapy, a pozycje po lewej stronie widoku pozwalają szybko sprawdzić, na którym etapie aktualnie się znajdujesz.

  1. Kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects i wybierz polecenie Project Releaser z menu kontekstowego. Widok Release otworzy się jako osobna karta dokumentu.

  2. Na pierwszym etapie – 1. Configure Server Release – określasz typy danych, które chcesz wygenerować. Kliknij elementy sterujące Details po prawej stronie nagłówka każdego zestawu danych, aby zobaczyć szczegółowe informacje o tym, co dokładnie zostanie wygenerowane w ramach danego zestawu.

  3. Kliknij przycisk  w lewym dolnym rogu widoku, aby otworzyć okno dialogowe Project Release Options. Na karcie Release Options tego okna upewnij się, że Managed - <WorkspaceName> jest wybrane jako Release Target, Fabrication jest przypisane do zestawu Fabrication Data, a Assembly jest przypisane do zestawu Assembly Data.

  4. Kliknij OK, aby zamknąć okno dialogowe i wrócić do widoku Release.

  5. Upewnij się, że obie opcje, Include Fabrication Data i Include Assembly Data for No Variant, są włączone.

  6. Kliknij przycisk  w prawym dolnym rogu widoku, aby kontynuować.

  7. Otworzy się okno dialogowe Item Creation z listą docelowych elementów wydania, które mają zostać utworzone w obszarze roboczym. Wybierz opcję Create items, aby potwierdzić utworzenie elementów.

  8. W otwartym oknie dialogowym Project Modified wybierz opcję Save and Commit changes, aby zapisać zmiany lokalnie i przejść do zapisywania zmian w obszarze roboczym.

  9. W otwartym oknie dialogowym Commit to Version Control wpisz treściwy komentarz w polu Comment (np. The project is ready for release), a następnie kliknij przycisk .

  10. Kolejny etap procesu publikowania – 2. Validate Project – jest uruchamiany automatycznie, ponieważ plik zadań wyjściowych Fabrication zawiera raport kontroli reguł projektowych.

    Jeśli którakolwiek kontrola walidacyjna zakończy się niepowodzeniem, publikowanie nie powiedzie się. W przypadku publikowania projektu w tym samouczku będzie to oznaczać, że dokument PCB zawiera co najmniej jedno naruszenie reguł DRC. W takiej sytuacji zatrzymaj proces publikowania przyciskiem  w prawym dolnym rogu widoku, otwórz dokument PCB, usuń naruszenia reguł DRC, a następnie ponownie rozpocznij proces publikowania.

  11. Po pomyślnej walidacji automatycznie uruchamiany jest kolejny etap procesu publikowania – 3. Generate Data. Na tym etapie generowane są wszystkie pozostałe dane wyjściowe, zdefiniowane w plikach OutJob przypisanych do uwzględnionych elementów danych. Dane te zostaną opublikowane w odpowiednich elementach docelowych w przestrzeni roboczej.

  12. Po pomyślnym zakończeniu wszystkich kontroli walidacyjnych i wygenerowaniu danych wyjściowych kolejny etap procesu publikowania – 4. Review Data – umożliwia przejrzenie wygenerowanych danych. Aby kontynuować publikowanie, kliknij przycisk  w prawym dolnym rogu widoku.

  13. Otworzy się okno dialogowe Confirm Release z podsumowaniem konfiguracji projektu, które zostaną opublikowane w przestrzeni roboczej. Wprowadź Release Note (np. Initial Release) i kliknij OK.

  14. Po potwierdzeniu publikowania na poprzednim etapie automatycznie rozpoczyna się kolejny etap – 5. Upload Data. Przedstawia on postęp przesyłania danych do rewizji odpowiednich elementów danych w przestrzeni roboczej.

  15. Ostatni etap procesu – 6. Execution Report – przedstawia podsumowanie publikacji. Zamknij widok publikowania, klikając przycisk  w prawym dolnym rogu widoku.

Wspólne projektowanie z wykorzystaniem przestrzeni roboczej

W projektowaniu i opracowywaniu produktu elektronicznego najczęściej uczestniczy wiele osób. Aby robić to efektywnie, członkowie zespołu projektowego muszą mieć możliwość współpracy. Altium Designer w połączeniu z podłączoną przestrzenią roboczą obsługuje szereg funkcji wspólnego projektowania. Poniżej wymieniono niektóre z nich.

  • Project history – dedykowany widok historii to zaawansowana, graficzna oś czasu historii projektu, która przedstawia chronologicznie najważniejsze zdarzenia związane z projektem: jego utworzenie, zatwierdzenia zmian, publikacje, klonowanie oraz wymianę danych MCAD. Tam, gdzie ma to zastosowanie, dostępne są różne działania (). Aby uzyskać dostęp do widoku historii projektu w przestrzeni roboczej z poziomu Altium Designer, kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects i wybierz polecenie History & Version Control » Show Project History z menu kontekstowego.

    Dowiedz się więcej: Historia projektu, Project History (Przestrzeń robocza Altium 365, Przestrzeń robocza Enterprise Server)

  • Web Viewer – interfejs przeglądarki internetowej przestrzeni roboczej zapewnia powszechny dostęp do dokumentów projektu za pośrednictwem standardowej przeglądarki. To znacznie więcej niż zwykła przeglądarka dokumentów: zaawansowana technologia umożliwia użytkownikom poruszanie się po strukturze projektu, interakcję z dokumentami projektowymi, wyróżnianie obszarów lub obiektów w celu dodawania komentarzy, a także wyszukiwanie, wzajemne wskazywanie, zaznaczanie i sprawdzanie komponentów oraz sieci w całym projekcie. Aby uzyskać dostęp do przeglądarki internetowej projektu w przestrzeni roboczej z poziomu Altium Designer, kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects i wybierz polecenie Show in Web Browser z menu kontekstowego.

    Dowiedz się więcej: Web Viewer (Platforma Altium 365, Przestrzeń robocza Enterprise Server)

  • Document commenting – komentarz to notatka dodana przez użytkownika, przypisana do określonego punktu, obiektu lub obszaru (zależnie od sytuacji) w obsługiwanym widoku danych, na którą inni użytkownicy mogą odpowiadać. Komentarze ułatwiają współpracę między użytkownikami bez zmieniania samych udostępnianych danych, ponieważ przestrzeń robocza przechowuje je niezależnie od tych danych. Komentarze dodane w interfejsie przeglądarki internetowej w poniższych miejscach stają się dostępne w Altium Designer i odwrotnie. W Altium Designer funkcją komentowania zarządza się za pomocą panelu Comments and Tasks ().

    Dowiedz się więcej: Komentowanie dokumentów, Web Viewer (Platforma Altium 365, Przestrzeń robocza Enterprise Server)

  • Sharing a project – po zapisaniu projektu w przestrzeni roboczej możesz określić, którzy użytkownicy będą mieli do niego dostęp w celu wspólnego projektowania lub przeglądania projektu. Służy do tego udostępnianie projektu, a dokładniej konfigurowanie jego uprawnień dostępu. W Altium Designer udostępnianiem projektu zarządza się w oknie dialogowym Share (), które otwiera się przez kliknięcie prawym przyciskiem myszy pozycji projektu w panelu Projects i wybranie polecenia Share z menu kontekstowego.

    Dowiedz się więcej: Udostępnianie projektu, Workspace Projects (Przestrzeń robocza Altium 365, Przestrzeń robocza Enterprise Server)

Gratulacje! Od pustego arkusza schematu do gotowej płytki PCB z danymi wyjściowymi opublikowanymi w przestrzeni roboczej — masz za sobą cały proces projektowania w Altium Designer!

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents