Criando o desenho de layout
Depois que o projeto do chicote for capturado na forma de um diagrama de fiação, a representação física do projeto pode ser criada como um desenho de layout de chicote (*.LdrDoc). Adicione este documento ao projeto de chicote a partir do painel Projects, clicando com o botão direito na entrada do projeto e, em seguida, selecionando Add New to Project » Harness Wiring Diagram no menu de contexto (ou use o comando File » New » Harness Layout Drawing nos menus principais).
Configurando um Documento de Desenho de Layout de Chicote
As opções de um documento de desenho de layout podem ser configuradas no painel Properties quando nenhum objeto estiver selecionado no espaço de projeto do documento. As principais configurações são:
-
Na região General da guia General do painel – selecione as unidades de medida aplicáveis ao documento e aos seus elementos gráficos e configure as grades para facilitar o posicionamento. O Altium Designer oferece três tipos de grade: grade visível para navegação, grade de snap para posicionamento e distância de snap para auxiliar na criação de conexões.
-
Na região Page Options da guia General do painel – configure o tamanho da folha do documento e o bloco de título ou selecione entre os modelos disponíveis de desenho de layout de chicote.

As guias General e Parameters do painel Properties quando nenhum objeto está selecionado no documento de desenho de layout de chicote
Importando Dados do Diagrama de Fiação
Selecione o comando Design » Import Wiring Diagram nos menus principais para importar os dados do projeto a partir do diagrama de fiação. O componente será posicionado na folha do desenho de layout nas posições relativas definidas no diagrama de fiação. Os pontos de conexão associados aos componentes também serão posicionados ao lado de cada componente no layout.

Um documento de desenho de layout de chicote com os dados importados do diagrama de fiação
Trabalhando com Componentes
Inicialmente, cada componente é representado no desenho de layout por seu símbolo. As propriedades de um componente posicionado podem ser configuradas no painel Properties quando o componente estiver selecionado no espaço de projeto. O painel Properties de um componente inclui as seguintes guias:
-
General – propriedades gerais do componente, como designador e comentário, localização, representação do modelo, parâmetros etc.
-
Pins – a lista de pinos do componente.
-
Cavities – uma visualização somente leitura das cavidades de soquete atribuídas ao componente. As atribuições de cavidades só podem ser modificadas no diagrama de fiação – saiba mais.
-
Associated Parts – permite que peças adicionais, como tubo termoencolhível, sejam atribuídas ao componente.
Configurando a Representação de um Componente
Usando a opção Graphical Symbol / Physical Model na região Model do painel Properties (na guia General) quando um componente estiver selecionado, você pode alternar entre a representação por símbolo (o símbolo do componente) e a projeção do modelo 3D (o footprint do componente). Use outras configurações na região do painel para configurar a representação.
|
Um componente representado por seu símbolo esquemático O mesmo componente representado pela projeção de seu modelo 3D |
Ao usar a representação Physical Model , use as opções Style para exibir o modelo como um Solid (sem linhas) ou como um Wireframe. Use as opções da lista suspensa Side para selecionar o lado desejado da visualização do modelo (há opções ortogonais e isométricas disponíveis). As imagens abaixo demonstram algumas das configurações com os resultados correspondentes no espaço de projeto.
Uma visualização de modelo físico pode ser girada graficamente no espaço de projeto arrastando uma alça de rotação localizada no canto inferior direito da visualização do modelo e usando o mouse; o campo Rotation será atualizado automaticamente (a rotação ocorre em incrementos de 1 grau). Você também pode manter pressionada a tecla Alt para restringir a rotação a incrementos de 45 graus. Como orientação útil, quando a visualização está sendo girada com o mouse, o ângulo atual é exibido em Status Bar.
Definindo a Disposição Física em um Desenho de Layout de Chicote
Todas as conexões físicas dentro do chicote são definidas como bundles de chicote (mesmo que um bundle contenha apenas um único fio). Cada bundle deve começar e terminar em um ponto de conexão. Na importação inicial dos dados do projeto de chicote (conforme descrito acima), cada componente tem um ponto de conexão automaticamente posicionado ao lado dele, e esse ponto de conexão é associado ao componente e a todos os seus pinos. Se necessário pela estrutura física do projeto, novos pontos de conexão podem ser posicionados, e os objetos atribuídos a um ponto de conexão podem ser configurados.
Trabalhando com Pontos de Conexão
Para posicionar um novo ponto de conexão, use o comando Place » Connection Point nos menus principais. Os pontos de conexão são exibidos no espaço de projeto conforme mostrado abaixo.
As propriedades de um ponto de conexão posicionado (sua localização, representação visual etc.) podem ser configuradas no painel Properties quando o ponto de conexão estiver selecionado no espaço de projeto.

O painel Properties quando um ponto de conexão está selecionado
Atribuindo Objetos a Pontos de Conexão
Os objetos atribuídos a um ponto de conexão podem ser configurados conforme necessário, de acordo com a intenção do seu projeto. Um ou vários objetos (componentes, splices/taps, objetos 'no connect' e blindagens com conexão) podem ser atribuídos a um ponto de conexão usando a caixa de diálogo Add Assigned Objects, acessada ao clicar no botão
na região Assigned Objects do painel Properties .
Quando um componente é atribuído a um ponto de conexão, uma linha tracejada-ponto é exibida no espaço de projeto entre o componente e o ponto de conexão, conforme mostrado abaixo. Em Properties, você pode selecionar quais pinos do componente são atribuídos. Clique na célula da coluna Pins da grade na região Assigned Objects para acessar a lista suspensa e selecionar os pinos necessários do componente.
Trabalhando com Bundles de Chicote
Para posicionar um novo bundle de chicote, use o comando Place » Harness Bundle nos menus principais (atalho: Shift+B).
Após selecionar o comando, clique em um ponto de conexão (uma cruz vermelha aparece no cursor quando ele está sobre o hotspot de um ponto de conexão) para posicionar o ponto inicial do bundle de chicote. Posicione o cursor e clique para ancorar uma série de pontos de vértice que definem a forma do bundle de chicote. Após posicionar o ponto de vértice final no hotspot de outro ponto de conexão, clique com o botão direito para concluir o posicionamento.
Por padrão, um bundle de chicote é posicionado usando o modo de posicionamento Any Angle. Ao posicionar um bundle de chicote, pressione Shift+Spacebar para alternar entre os modos de posicionamento. O modo especifica como os cantos são criados ao posicionar bundles e os ângulos em que os bundles podem ser posicionados. Enquanto estiver no modo 90 Degree ou 45 Degree (modos verdadeiramente ortogonais), pressione Spacebar para alternar entre os submodos inicial e final. O modo e o submodo atuais são mostrados na Barra de Status.

Um exemplo de um bundle de chicote posicionado entre os pontos de conexão CP1 e CP_P2.
Quando posicionado e selecionado, os vértices de um bundle de chicote podem ser arrastados para alterar o ângulo entre duas seções adjacentes.
As propriedades de um bundle de chicote posicionado (localização, representação visual etc.) podem ser configuradas no painel Properties quando o bundle de chicote estiver selecionado no espaço de projeto.

O painel Properties quando um bundle de chicote está selecionado
Cada conjunto de chicote conterá automaticamente os objetos (fios e/ou cabos) de acordo com a conectividade definida no diagrama de fiação. Esses objetos são listados na região Bundle Objects do painel Properties quando o conjunto está selecionado. Clique em um objeto nesta lista para destacar todos os conjuntos pelos quais o objeto selecionado passa.
Usando o campo Length na região Properties do painel, você pode definir o comprimento do conjunto selecionado. Os comprimentos dos fios e cabos que passam pelos conjuntos são calculados com base nos valores de Length desses conjuntos. Os valores calculados do comprimento do fio/cabo são mostrados na coluna Length Value da grade na região Bundle Objects do painel.
Adicionando uma visualização de segmento de fio
A visualização de segmento de fio exibe os fios que estão dentro do segmento, ou seja, fios individuais, pares trançados de fios e fios que fazem parte de cabos. Isso permite ver exatamente como os fios se encaixam fisicamente dentro do segmento do conjunto de chicote. Cada fio é rotulado e colorido usando a cor definida do fio, bem como sua espessura com base no valor do parâmetro Thickness (definido no diagrama de fiação (*.WirDoc)). Você pode inserir uma visualização de segmento de um segmento de conjunto já posicionado em um desenho de layout (*.LdrDoc) usando o comando Add Segment View na região Model do painel Properties . A região Segment View então exibe uma lista suspensa na qual você pode selecionar o nível de Zoom para a visualização adicionada. O espaço de projeto aplica zoom na visualização, como mostrado no exemplo de apresentação abaixo. Para excluir uma visualização de segmento, use o comando Delete na região Segment View. Clique para selecionar a visualização e mova-a para o local desejado no espaço de projeto.
Adicionando um ponto de quebra
Um ponto de quebra, que é usado como indicação de que o conjunto não está em escala (NTS), pode ser colocado em um conjunto de chicote. O conjunto exibirá um símbolo de quebra no meio do seu segmento mais longo, como mostrado na primeira imagem abaixo, e as propriedades exibirão o Drawn Length. Para inserir uma quebra, ative a opção Add Break Symbol na região Properties das propriedades do conjunto. As coberturas de chicote que cobrem um conjunto de chicote com um ponto de quebra também exibirão a quebra no mesmo local. Se a cobertura do chicote terminar no ponto de quebra do conjunto de chicote, a cobertura será desenhada ligeiramente mais longa, como mostrado na segunda imagem.
Bundles with Wires from Split Cables
Todos os conjuntos de chicote que incluem fios de um cabo de chicote dividido são destacados no desenho de layout quando o cabo é selecionado na região Bundle Objects do painel Properties. O comprimento de um cabo dividido é determinado pelo comprimento do fio mais longo.
|
O cabo C1 é dividido entre conectores diferentes. Ao clicar na entrada do cabo na região Bundle Objects do painel Properties para o conjunto selecionado, todos os conjuntos que incluem fios de C1 são destacados. O comprimento do cabo é determinado pelo comprimento do fio mais longo (neste caso, os fios que passam pelos conjuntos B1 e B3 são os mais longos). |
No Connect Objects Within a Cable
Se o diagrama de fiação incluir objetos "no connect" dentro de um cabo, não há necessidade de adicionar esses objetos aos pontos de conexão no desenho de layout. O conjunto de chicote reconhecerá corretamente os objetos do cabo. Veja um exemplo nas imagens abaixo.
|
Um cabo no documento do diagrama de fiação contém fios desconectados (W4 e W5). Os objetos "no connect" não são atribuídos aos pontos de conexão no desenho de layout. No entanto, o conjunto reconhece corretamente todos os objetos do cabo (incluindo os fios W4 e W5). |
Jumper Wires
Fios jumper podem ser exibidos no desenho de layout. Quando o diagrama de fiação de um projeto de chicote inclui um fio que conecta cavidades do mesmo conector de chicote, esse fio é mostrado no painel Properties como um objeto do conjunto de chicote que corresponde ao conector de chicote no desenho de layout do projeto quando o conjunto de chicote está selecionado no espaço de projeto.
Reatribuindo objetos do conjunto
Você pode reatribuir objetos do conjunto em um desenho de layout, onde um fio pode percorrer mais de um caminho entre seus conectores de origem e destino. Por padrão, esse fio será automaticamente atribuído ao caminho de conjunto mais curto, mas você tem a possibilidade de substituir isso. O controle Assign Objects to Bundle aparece na parte inferior da seção Bundle Objects do painel Properties (com o conjunto selecionado no espaço de projeto), e somente quando existir um caminho de roteamento alternativo. A caixa de diálogo Assign Objects to Bundle é aberta, na qual você pode selecionar objetos (fios/cabos) para mover entre os conjuntos aplicáveis e válidos.
Cobrindo conjuntos de chicote
Um objeto de cobertura de chicote (Place » Harness Covering) pode ser colocado sobre um conjunto de chicote. O comprimento da cobertura pode ser modificado graficamente no espaço de projeto durante ou após a colocação.
Após selecionar um comando de colocação de cobertura de chicote, um ponto laranja aparecerá no espaço de projeto quando o cursor estiver sobre um conjunto de chicote, o que significa que a cobertura de chicote pode ser colocada (um ponto cinza significa que uma cobertura de chicote não pode ser colocada naquele local específico). Clique onde deseja que a cobertura comece, depois mova o cursor ao longo do conjunto até o ponto em que deseja que a cobertura termine e clique novamente. Coberturas de chicote podem se sobrepor umas às outras, como demonstrado no vídeo abaixo. Além disso, você pode aplicar/estender uma cobertura de chicote sobre um ponto de junção (um ponto de conexão no desenho de layout onde dois ou mais conjuntos se unem). Isso elimina a necessidade de ter coberturas de chicote separadas entre pontos de junção em uma seção que contém vários conectores.
O início de uma cobertura é considerado o ponto mais à esquerda e mais acima de seu caminho, e o caminho inclui apenas os conjuntos sobre os quais a cobertura está posicionada.
As propriedades de uma cobertura de chicote colocada podem ser configuradas no painel Properties quando a cobertura de chicote está selecionada no espaço de projeto.

O painel Properties quando uma cobertura de chicote está selecionada
Você pode definir o tamanho de um objeto de cobertura de chicote em relação ao tamanho do conjunto que ele cobre (o Line Width do conjunto) usando a lista suspensa Size no painel Properties. Role pelas imagens abaixo para ver exemplos de coberturas de chicote de tamanhos diferentes com vários tamanhos de conjuntos de chicote.
Adicionando rótulos de layout
Rótulos físicos podem ser colocados no desenho de layout (Place » Layout Label).
As propriedades de um rótulo de layout colocado (seu designador, texto, representação visual etc.) podem ser configuradas no painel Properties quando o rótulo de layout está selecionado no espaço de projeto.

O painel Properties quando um rótulo de layout está selecionado
Ao definir o texto do rótulo no campo Text, use Ctrl+Enter ou Shift+Enter para adicionar uma nova linha de texto. Ative Show only first line para exibir apenas a primeira linha do campo Text no espaço de projeto. O texto do rótulo de layout também pode ser alinhado de acordo com suas necessidades usando os controles Alignment.
Atualizando objetos do desenho de layout a partir de bibliotecas
Os seguintes objetos podem ser atualizados a partir de sua biblioteca Workspace de origem:
-
Componentes de chicote
-
Peças associadas a componentes de chicote
-
Peças associadas a pontos de conexão
-
Coberturas de chicote
-
Rótulos de layout
Quando um objeto está selecionado, as informações sobre o componente Workspace vinculado podem ser encontradas no painel Properties (por exemplo, a guia Associated Parts para peças associadas de um componente de chicote ou a região General para um rótulo de layout).
Se houver uma revisão mais recente do componente Workspace disponível, a entrada para o status da revisão refletirá isso usando o texto Out of date. No nível do objeto individual, o vínculo pode ser atualizado para a revisão mais recente do componente Workspace clicando no botão
.
Um exemplo de indicação de uma revisão desatualizada de componente de chicote
O recurso Update from Libraries (Tools » Update from Libraries) também pode ser usado para atualizar componentes desatualizados vinculados aos objetos listados acima. Observe que, para que um objeto seja incluído na atualização usando o recurso Update from Libraries, um componente atribuído ao objeto deve incluir um vínculo para um símbolo esquemático.
Anotando objetos de desenho de layout de chicote
Use os comandos no menu Tools » Annotation para anotar os seguintes objetos no documento de desenho de layout de chicote:
-
Componentes de chicote
-
Pontos de conexão
-
Conjuntos de chicote
-
Coberturas de chicote
-
Rótulos de layout
Anotar objetos em um documento de desenho de layout de chicote é semelhante a anotar componentes em um documento esquemático (*.SchDoc) de um projeto de PCB. Use os links a seguir para saber mais sobre os comandos de anotação disponíveis para um documento de desenho de layout de chicote:
Cross-probing entre diagrama de fiação e desenho de layout
O cross-probing entre o diagrama de fiação e o desenho de layout de um projeto de chicote é suportado. O comando Cross Probe pode ser acessado no menu principal Tools e no menu de clique com o botão direito no espaço de projeto.
O cross-probing pode ser realizado:
-
Entre componentes no diagrama de fiação e no desenho de layout.
-
De um fio no diagrama de fiação para o(s) conjunto(s) pelo(s) qual(is) esse fio passa no desenho de layout.
-
De um conjunto no desenho de layout para o(s) fio(s) que passam por esse conjunto no diagrama de fiação.
|
Cross-probing de um componente no diagrama de fiação para o componente correspondente no desenho de layout. Cross-probing de um componente no desenho de layout para o componente correspondente no diagrama de fiação. Cross-probing de um fio no diagrama de fiação para os conjuntos correspondentes no desenho de layout. Cross-probing de um conjunto no desenho de layout para os fios correspondentes no diagrama de fiação. |
).






).
).
).
).
).
).




).










)
).
).



