Trabalhando com Blocos de Reutilização e Snippets (Painel Antigo de Reutilização de Projeto)

Num relance

Este artigo explica como o Altium Designer ajuda você a salvar e reutilizar seções comuns de circuitos por meio de blocos de reutilização e snippets, evitando a necessidade de recriar elementos recorrentes do projeto do zero. Ele apresenta o que cada opção de reutilização inclui, como acessar e usar o painel Design Reuse e como criar, gerenciar, renomear e organizar conteúdos de projeto tanto no Workspace quanto em locais de armazenamento locais. Se você trabalha regularmente com seções recorrentes de esquemáticos ou PCBs, este guia mostra como essas ferramentas se encaixam no seu fluxo de trabalho e como começar a usá-las de forma eficaz. Continue lendo para tornar seu processo de projeto mais rápido e consistente.

- Entenda a diferença entre blocos de reutilização, snippets de esquemáticos e snippets de PCB, e quando usar cada um deles.
- Veja como usar o painel Design Reuse para localizar, filtrar, ordenar, pesquisar e gerenciar conteúdos de projeto reutilizáveis.
- Siga as etapas para criar, salvar, renomear e organizar blocos de reutilização e snippets tanto no Workspace quanto em locais de armazenamento locais.
Aprofunde-se com a IA:

A interface de usuário da funcionalidade de reutilização de projetos descrita nesta página é a versão anterior do painel Design Reuse, disponível quando a opção UI.ModernDesignReusePanel está desabilitada na caixa de diálogo Advanced Settings. Quando essa opção está habilitada, é usada uma nova versão do painel, descrita nas páginas Trabalhando com blocos de reutilização e Trabalhando com snippets. O novo painel Design Reuse está em Beta Aberto.

Se os seus projetos costumam incluir 'seções' comuns de circuitos, o Altium Designer oferece uma maneira simples e fácil de salvar e reutilizar seções de circuitos do projeto, tanto baseadas no Workspace quanto em arquivos locais. Essas seções podem ser adicionadas a qualquer projeto de PCB sem precisar começar do zero a cada vez. Esse é um ótimo recurso para aqueles fragmentos usados com frequência e seções menores de circuitos que você deseja reutilizar. O sistema permite salvar qualquer seleção de:

  • Circuitos em uma única folha de esquemático (um snippet de esquemático).

  • Circuitos em um projeto de PCB, incluindo os componentes e o roteamento (um snippet de PCB).

Quando conectado a um Workspace, você pode criar uma única entidade — um bloco de reutilização — que pode conter tanto os circuitos do esquemático quanto sua representação física para a PCB. Quando esse bloco de reutilização é colocado em uma folha de esquemático, sua representação física é colocada automaticamente no documento de PCB durante o processo de ECO.

O painel Design Reuse é a central de comandos para criar, gerenciar e usar blocos de reutilização e snippets — tanto baseados no Workspace quanto em arquivos locais.

O painel Design Reuse
O painel Design Reuse

O painel pode ser acessado das seguintes maneiras:

  • Clique no botão Panels no canto inferior direito da área de projeto e, em seguida, clique em Design Reuse.
  • Selecione View » Panels » Design Reuse nos menus principais.
  • Selecione Place » Reuse Block nos menus principais.

O menu suspenso na parte superior do painel lista todas as pastas disponíveis no Workspace conectado que contêm blocos de reutilização e snippets baseados no Workspace. O número ao lado do nome de cada pasta mostra quantos blocos de reutilização de projeto e snippets essa pasta e suas subpastas contêm. Selecione uma pasta no menu suspenso para exibir os blocos de reutilização e snippets que essa pasta e suas subpastas contêm na seção principal do painel. Selecione a entrada do Workspace conectado no menu suspenso para exibir todos os blocos de reutilização e snippets disponíveis.

A estrutura de pastas do Workspace pode ser definida no Altium Designer usando o painel Explorer.

Use os botões de filtro no menu pop-up do ícone  para mostrar/ocultar o conteúdo de tipos específicos (Reuse Blocks, Schematic Snippets, PCB Snippets) no painel. Use o controle Sort By para selecionar a opção de ordenação de sua preferência.

Use as opções de filtragem e ordenação para configurar a exibição do conteúdo no painel
Use as opções de filtragem e ordenação para configurar a exibição do conteúdo no painel

Para pesquisar os blocos de reutilização e snippets disponíveis na pasta selecionada pelo nome ou pela descrição, insira uma expressão no campo Search para filtrar e restringir a listagem de acordo com suas necessidades específicas.

Cada bloco de reutilização e snippet é apresentado na seção principal do painel em um bloco que contém os seguintes dados:

  • Imagem de pré-visualização – clique nela para alternar entre os estados normal e em escala real. Para um bloco de reutilização, use o botão  Clique e arraste para mover​ para alternar entre as pré-visualizações dos documentos de PCB e de esquemático;

  • O ícone de tipo –  Clique e arraste para mover​ para um bloco de reutilização,  Clique e arraste para mover​ para um snippet de esquemático,  Clique e arraste para mover​ para um snippet de PCB;

  • Nome e descrição (se definida);

  • O ID da revisão mais recente, a data de criação e o autor de um bloco de reutilização ou de um snippet de esquemático/PCB do Workspace.

As informações e os controles de um bloco de reutilização ou snippet são apresentados em um bloco no painel.
As informações e os controles de um bloco de reutilização ou snippet são apresentados em um bloco no painel.

Criando um bloco de reutilização

Um novo bloco de reutilização pode ser criado das seguintes maneiras:

  1. Selecione o comando para criar um novo bloco de reutilização:

    • No painel Design Reuse, clicando no  botão na parte superior do painel.

    • Usando o comando File » New » Reuse Block no menu principal.

    • No painel Explorer, clicando no  botão localizado no canto superior direito do painel ao navegar por uma pasta do tipo Design Reuse Blocks.

  2. Uma estrutura temporária e editável do bloco de reutilização, semelhante à de um projeto de PCB, será aberta no painel Projects (sob uma entrada do Workspace ao qual você está conectado), e o editor de esquemáticos temporário será aberto na janela principal de projeto, pronto para definir o documento de esquemático do bloco de reutilização. Use os comandos e as técnicas de posicionamento padrão para definir o documento de esquemático do bloco de reutilização.

  3. Ao terminar, use o comando Design » Update PCB Document e o processo de ECO para transferir o esquemático capturado para o documento de PCB do bloco de reutilização e, em seguida, aplique as alterações necessárias a esse documento (definição das posições dos componentes, roteamento etc.).

    Vários documentos de PCB podem ser adicionados ao bloco de reutilização que está sendo definido. Para isso, use o comando Add New to Project » PCB no menu de contexto da entrada do bloco de reutilização no painel Projects.

    Use o comando Rename no menu de contexto da entrada do documento de PCB adicionado no painel Projects para definir um nome significativo para ele. Use um comando Design » Update no menu principal do editor de esquemáticos para atualizar o documento de PCB desejado.

    Quando os documentos de esquemático e de PCB do bloco de reutilização estiverem definidos, salve o bloco de reutilização no Workspace usando o comando Save to Server no menu de contexto da entrada do bloco de reutilização no painel Projects ou o controle Save to Server à direita da entrada.

    Como os blocos de reutilização são armazenados no Workspace conectado, eles devem usar componentes desse Workspace. Dessa forma, você aproveita todos os benefícios do sistema de conteúdo oferecido pelo Workspace.

    • Tanto o documento de esquemático quanto o de PCB do bloco de reutilização devem conter pelo menos um componente para que possam ser salvos no Workspace.

    • Se os documentos de esquemático e PCB do bloco de reutilização não estiverem sincronizados (forem detectadas diferenças entre eles), uma caixa de diálogo de aviso será exibida ao tentar salvar o bloco de reutilização no Workspace. Você pode cancelar o salvamento para retornar ao bloco de reutilização e corrigir as diferenças ou prosseguir com o salvamento.

  4. A caixa de diálogo New Reuse Block será exibida, na qual você poderá definir Name, Description e a Folder do Workspace em que o novo bloco de reutilização será salvo.

    A caixa de diálogo New Reuse Block
    A caixa de diálogo New Reuse Block

  5. Após clicar em OK, o bloco de reutilização será salvo no Workspace e sua estrutura temporária será fechada.

Um bloco de reutilização salvo poderá então ser encontrado no painel Design Reuse quando a pasta em que ele foi salvo (ou a entrada do Workspace conectado) estiver selecionada na lista suspensa superior. Pode ser necessário usar o comando Refresh no menu do botão para que o novo bloco de reutilização apareça no painel.

Renomear um bloco de reutilização

Após a criação de um bloco de reutilização, ele poderá ser renomeado com um título mais adequado, se desejado. Para renomear um bloco de reutilização, use o comando Rename , que pode ser acessado no submenu  e no menu de contexto exibido ao clicar com o botão direito no painel Design Reuse . Na caixa de diálogo Rename Reuse Block que se abre, insira o novo título e clique em OK. O bloco de reutilização passa a ter o nome desejado, conforme mostrado nas imagens a seguir.

Criar um snippet

Um novo snippet de esquemático ou PCB pode ser criado rapidamente a partir de um circuito existente em uma folha de esquemático ou em um documento de PCB:

  1. Selecione o circuito desejado no editor de esquemáticos ou de PCB.

  2. Clique com o botão direito e escolha Snippets » Create Snippet from selected objects no menu de contexto ou selecione o comando Tools » Convert » Create Snippet from selected objects nos menus principais.

  3. A caixa de diálogo New Schematic Snippet ou New PCB Snippet será exibida, na qual você poderá definir o nome, a descrição, o destino de salvamento (um Workspace ou uma pasta local) e a pasta em que o novo snippet será salvo.

    Ao salvar um snippet em uma pasta local, clique no botão  à direita do campo Path na caixa de diálogo para acessar a caixa de diálogo Choose Snippet Folder, que permite selecionar uma pasta local de snippets existente na qual o snippet será salvo ou criar uma nova subpasta dentro de uma pasta local de snippets existente.

    Para obter informações sobre como organizar os snippets locais em pastas, consulte a seção Organização de snippets locais abaixo.
  4. Após clicar em OK, o snippet será salvo.

Um snippet salvo poderá então ser encontrado no painel Design Reuse quando a entrada do Workspace conectado (ou a pasta em que ele foi salvo) estiver selecionada na lista suspensa superior.

Um snippet pode ser criado a partir de um conjunto de objetos selecionados. Aqui é mostrada a criação de um snippet de esquemático. Passe o cursor sobre a imagem para ver a criação de um snippet de PCB.
Um snippet pode ser criado a partir de um conjunto de objetos selecionados. Aqui é mostrada a criação de um snippet de esquemático. Passe o cursor sobre a imagem para ver a criação de um snippet de PCB.

Pode ser necessário usar o comando Refresh no menu do botão  do painel para que o novo bloco de reutilização apareça no painel.

Para acessar os snippets locais no painel Design Reuse, a opção Local Snippets deve estar habilitada no menu .

Um snippet baseado no Workspace também pode ser criado a partir de um snippet local existente clicando no botão  no bloco do snippet (ou clicando com o botão direito em qualquer lugar do bloco) e selecionando o comando Save to Server no menu. Na caixa de diálogo New Schematic Snippet ou New PCB Snippet que aparece, defina Name, Description e a Folder do Workspace em que o snippet será salvo.

Um snippet local pode ser salvo no Workspace conectado usando o comando Save to Server.
Um snippet local pode ser salvo no Workspace conectado usando o comando Save to Server.

Os snippets do Workspace devem usar componentes desse Workspace. Dessa forma, você aproveita todos os benefícios do sistema de conteúdo fornecido pelo Workspace.

Organização de snippets locais

O painel Design Reuse permite organizar os snippets locais em pastas de snippets para agrupar snippets relacionados, facilitando sua localização. As pastas de snippets são pastas existentes do Windows que não podem ser criadas no painel Design Reuse. Em vez disso, elas são “abertas” ou “fechadas” ao navegar pelos snippets locais que contêm. Essas pastas só podem ser criadas diretamente no disco rígido ou na rede, fora do Altium Designer.

As pastas de snippets podem ser abertas e fechadas na caixa de diálogo Available Snippets Folders, acessada clicando no botão no canto superior direito do painel Design Reuse e selecionando o comando Snippet Folders no menu. Clique em Open Folder para localizar a pasta desejada no disco rígido ou na rede. A pasta selecionada será adicionada à lista na caixa de diálogo e, em seguida, aparecerá na lista suspensa na parte superior do painel Design Reuse.

Para remover uma pasta de snippets da lista (essencialmente fechando-a para navegação), selecione a pasta na lista e clique em Remove Folder. Use os botões Move Up e Move Down para alterar a ordem em que os snippets locais serão apresentados no painel Design Reuse quando a entrada Local estiver selecionada na lista suspensa do painel.

Posicionar blocos de reutilização e snippets

Para posicionar um bloco de reutilização ou um snippet em um projeto, clique no respectivo bloco e depois no botão , clique no botão dentro do bloco ou clique com o botão direito em qualquer lugar do bloco e selecione um dos seguintes comandos:

  • Place – selecione para posicionar o bloco de reutilização ou snippet diretamente no documento de esquemático ou PCB ativo.
  • Place as Sheet Symbol – quando um documento de esquemático estiver ativo, selecione para posicionar o bloco de reutilização ou snippet de esquemático como um símbolo de folha na folha de esquemático. O conteúdo do bloco de reutilização ou snippet de esquemático será posicionado em uma folha de esquemático filha criada automaticamente, referenciada pelo símbolo de folha posicionado.

Posicione um bloco de reutilização ou snippet usando o menu do botão Place no respectivo bloco do painel. Aqui, é mostrada a seleção do comando Place, que posiciona o bloco de reutilização / snippet de esquemático na folha de esquemático ativa. Passe o cursor sobre a imagem para visualizar a seleção do comando Place as Sheet Symbol, que posiciona o bloco de reutilização / snippet de esquemático na folha filha referenciada pelo símbolo de folha posicionado.
Posicione um bloco de reutilização ou snippet usando o menu do botão Place no respectivo bloco do painel. Aqui, é mostrada a seleção do comando Place, que posiciona o bloco de reutilização / snippet de esquemático na folha de esquemático ativa. Passe o cursor sobre a imagem para visualizar a seleção do comando Place as Sheet Symbol, que posiciona o bloco de reutilização / snippet de esquemático na folha filha referenciada pelo símbolo de folha posicionado.

Clique no controle Show more no bloco de reutilização do painel para exibir a seção PCB , que contém a lista de documentos de PCB do bloco de reutilização. Selecione o documento de PCB desejado na lista, e o bloco de reutilização será posicionado com esse documento. O documento de PCB selecionado é mostrado na área de pré-visualização do bloco de reutilização quando PCB está selecionado para pré-visualização.

Selecione um documento de PCB a ser posicionado com o bloco de reutilização para exibir sua pré-visualização.
Selecione um documento de PCB a ser posicionado com o bloco de reutilização para exibir sua pré-visualização.

Após posicionar o documento de esquemático de um bloco de reutilização, seu documento de PCB pode ser posicionado no documento de PCB por meio do processo de ECO. No editor de esquemáticos, use o comando Design » Update PCB Document nos menus principais e, em seguida, valide e execute as alterações usando a caixa de diálogo Engineering Change Order. O documento de PCB será posicionado no documento de PCB como uma união e poderá ser gerenciado no modo Unions do painel PCB.

Quando um componente de esquemático ou de PCB selecionado faz parte de um bloco de reutilização posicionado no projeto, você pode inspecionar suas propriedades clicando no link Reuse Block fornecido no painel Properties . As propriedades do bloco de reutilização ao qual o componente pertence serão apresentadas no painel. Para retornar às propriedades do componente inicialmente selecionado, use o link Component .

Acesse as propriedades do bloco de reutilização a partir de um componente que faz parte dele. As imagens acima mostram o acesso às propriedades a partir de um componente de esquemático. Passe o cursor sobre a imagem para ver o acesso a partir de um componente de PCB.
Acesse as propriedades do bloco de reutilização a partir de um componente que faz parte dele. As imagens acima mostram o acesso às propriedades a partir de um componente de esquemático. Passe o cursor sobre a imagem para ver o acesso a partir de um componente de PCB.

Para um bloco de reutilização, seu documento de esquemático ou de PCB será usado ao executar o comando de posicionamento, dependendo do tipo de documento ativo no momento da execução.

Para um snippet, certifique-se de que o documento de destino correto esteja aberto e ativo antes de posicioná-lo. O comando de posicionamento só estará disponível se o snippet puder ser posicionado corretamente nesse documento, ou seja, o tipo de snippet e o tipo de documento devem ser iguais.

Edição de blocos de reutilização e snippets

Para editar um bloco de reutilização ou snippet baseado no Workspace, clique no botão no respectivo bloco do painel (ou clique com o botão direito em qualquer lugar desse bloco) e selecione o comando Edit no menu.

Abra um bloco de reutilização ou snippet baseado no Workspace para edição usando o comando Edit no respectivo bloco do painel.
Abra um bloco de reutilização ou snippet baseado no Workspace para edição usando o comando Edit no respectivo bloco do painel.

O editor temporário será aberto com o documento (que contém o bloco de reutilização/snippet de origem) da revisão mais recente do item do Workspace, pronto para edição. Faça as alterações necessárias e salve o documento na próxima revisão do bloco de reutilização/snippet usando o comando File » Save to Server no menu principal ou o comando Save to Server no menu de contexto da entrada do bloco de reutilização/snippet no painel Projects.

As propriedades (Nome, Descrição e Caminho) de um snippet local podem ser editadas na caixa de diálogo Snippet Properties , acessada clicando no botão  no bloco do snippet local no painel (ou clicando com o botão direito em qualquer lugar desse bloco) e selecionando o comando Edit Properties no menu.

Edite as propriedades de um snippet local usando a caixa de diálogo Snippet Properties, acessada no painel Design Reuse.
Edite as propriedades de um snippet local usando a caixa de diálogo Snippet Properties, acessada no painel Design Reuse.

Exclusão de blocos de reutilização e snippets

Para excluir um bloco de reutilização ou snippet, clique no botão  no bloco do snippet no painel (ou clique com o botão direito em qualquer lugar desse bloco) e selecione o comando Delete no menu.

  • Para um bloco de reutilização ou snippet baseado no Workspace, a caixa de diálogo Delete Items será exibida para confirmar a exclusão. Na prática, trata-se de uma “exclusão lógica”, em que o bloco de reutilização ou snippet será movido para a área Trash do Workspace. A área Trash é, essencialmente, uma lixeira para a qual qualquer conteúdo do seu Workspace pode ser movido (por meio de uma ação de exclusão lógica). Ela fica isolada do restante do Workspace. Para um bloco de reutilização, você também pode optar por excluir o conteúdo relacionado a ele (por exemplo, snippets de esquemático e de PCB).

    Execute a exclusão lógica de um bloco de reutilização ou snippet usando o comando Delete no respectivo bloco do painel.
    Execute a exclusão lógica de um bloco de reutilização ou snippet usando o comando Delete no respectivo bloco do painel.

  • Para um snippet local, a caixa de diálogo Confirm será exibida para confirmar a exclusão. A ação removerá os arquivos do snippet do seu disco rígido.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents