Trabalhando com snippets

Num relance

Este artigo explica como criar, localizar, posicionar, organizar, editar e gerenciar snippets no Altium Designer usando o painel Design Reuse. Ele aborda snippets locais e do Workspace, mostra como eles podem armazenar circuitos de esquemáticos ou PCBs para reutilização e descreve as principais ações disponíveis para mantê-los, incluindo a organização de pastas, detalhes relacionados a revisões e opções de gerenciamento de conteúdo do Workspace. Se você quer entender melhor como reutilizar conteúdo de projeto com mais eficiência e usar os controles de snippets disponíveis com confiança, continue lendo.

- Aprenda a criar snippets de esquemáticos e PCBs a partir de conteúdo de projeto existente e a salvá-los em um Workspace ou em uma pasta local.
- Veja como pesquisar snippets, consultar seus detalhes e posicioná-los nos documentos de destino adequados, inclusive como posicionar um snippet de esquemático como um símbolo de folha.
- Entenda como organizar pastas de snippets locais e gerenciar edições e ações de snippets, tanto locais quanto armazenados no Workspace.
Aprofunde-se com a IA:

O Design Reuse painel usado para gerenciar snippets e descrito nesta página está em Beta Aberto e disponível quando a opção UI.ModernDesignReusePanel está habilitada na caixa de diálogo Configurações Avançadas. Quando essa opção está desabilitada, é usada a versão anterior do painel, descrita na página Trabalhando com blocos de reutilização e snippets.

O recurso snippets permite salvar qualquer seleção de circuitos em uma única folha de esquemático ou circuitos em um projeto de PCB, incluindo os componentes e o roteamento, e depois reutilizá-la em qualquer projeto. O painel Design Reuse permite acessar rapidamente todos os controles necessários para trabalhar com sua coleção de snippets e gerenciá-la.

Criando um snippet

Um novo snippet de esquemático ou PCB pode ser criado a partir de circuitos existentes em uma folha de esquemático ou em um documento de PCB:

  1. Selecione os circuitos desejados no editor de esquemáticos ou de PCB.

  2. Selecione o comando Tools » Convert » Create Snippet from selected objects nos menus principais (no editor de PCB, você também pode clicar com o botão direito na seleção e escolher Snippets » Create Snippet from selected objects no menu de contexto).

  3. A caixa de diálogo New Schematic Snippet ou New PCB Snippet será exibida, na qual você poderá definir Name, Description, o destino de salvamento (Save to – o Workspace conectado ou uma pasta local) e a pasta na qual o novo snippet será salvo (Path).

    Clique no botão  à direita do campo Path na caixa de diálogo para acessar a caixa de diálogo Choose Folder (ao salvar um snippet no Workspace) ou Choose Snippet Folder (ao salvar um snippet em uma pasta local), que permite selecionar uma pasta existente na qual o snippet será salvo ou criar uma nova pasta na hora.

    • Na caixa de diálogo Choose Snippet Folder, clique no botão  e use a caixa de diálogo Folder Properties que será aberta para adicionar uma nova subpasta à estrutura geral de pastas de snippets locais (). Na caixa de diálogo, você pode especificar um nome para a nova pasta e determinar em qual pasta pai ela será criada.

    • Para obter informações sobre como organizar snippets locais em pastas, consulte a seção Organizando snippets locais abaixo.

  4. Clique em  na caixa de diálogo para salvar o snippet.

Ao salvar um snippet no Workspace conectado, é recomendável usar componentes desse Workspace no snippet. Dessa forma, você aproveita todos os benefícios do sistema de conteúdo que o Workspace oferece.

Buscando e posicionando um snippet

Os snippets do Workspace e os locais estão disponíveis para posicionamento no painel Design Reuse.

  • Quando o painel está configurado para exibir recursos do Workspace (), ele pode ser usado para acessar snippets armazenados no Workspace conectado.

  • Quando o painel está configurado para exibir recursos locais (), ele fornece acesso aos snippets armazenados em pastas no seu disco rígido (as pastas são configuradas conforme descrito acima).

Você pode navegar pelas pastas do Workspace ou pelas pastas locais para encontrar o snippet desejado. Como alternativa, use o campo Search na parte superior do painel para buscar um snippet pelo nome ou pela descrição.

  • Somente a revisão mais recente de cada snippet do Workspace é apresentada no painel Design Reuse.

  • Se a revisão mais recente de um snippet do Workspace estiver em um estado do ciclo de vida cuja opção Visible in Vault panels esteja desabilitada (saiba mais), esse snippet, por padrão, não será exibido no painel. Para exibir os snippets que não estão visíveis no momento, clique no botão  no canto superior direito do painel e habilite a opção Show Hidden Revisions no menu associado.

Clique no controle Details na parte inferior do painel para expandir o painel Details, que exibe detalhes do bloco de reutilização selecionado, incluindo:

  • Nome do snippet.

  • O ícone do estado do ciclo de vida e a revisão (somente para snippets do Workspace; clique no link para abrir a visualização detalhada do Histórico do Item de Bloco de Reutilização com a revisão mais recente selecionada).

  • Descrição do snippet.

  • Informações gerais do snippet.

  • Imagens de pré-visualização do snippet.

Usando o acesso controlado ao conteúdo do Workspace, em conjunto com um esquema de ciclo de vida adequado, o pessoal autorizado (bibliotecários e gestores seniores de projetos) pode aprovar e disponibilizar apenas os snippets do Workspace que devem ser usados nos projetos. Isso permite que o projetista trabalhe com a tranquilidade de saber que está usando apenas snippets autorizados.

Antes de posicionar um snippet, certifique-se de que o documento de destino correto esteja aberto como documento ativo. O comando de posicionamento só funcionará se o snippet puder ser posicionado corretamente nesse documento, ou seja, o tipo de snippet e o tipo de documento devem ser iguais.

Para posicionar um snippet, passe o cursor sobre sua entrada no painel Design Reuse, clique no botão  (ou clique com o botão direito na entrada) e selecione o comando Place (para um snippet de esquemático ou PCB) ou Place as Sheet Symbol (somente para um snippet de esquemático) no menu. Quando a segunda opção é selecionada, o snippet é posicionado na folha de esquemático ativa como um símbolo de folha. O símbolo de folha posicionado incluirá entradas de folha correspondentes às portas do snippet. O conteúdo do snippet será posicionado em uma folha de esquemático filha criada automaticamente e referenciada pelo símbolo de folha.

Organizando snippets locais

Os snippets locais podem ser organizados em pastas de snippets, para que os snippets relacionados sejam agrupados, facilitando sua localização. As pastas de snippets são pastas existentes do Windows que não podem ser criadas no painel Design Reuse. Em vez disso, elas são “abertas” ou “fechadas” durante a navegação pelos snippets locais que contêm. Essas pastas só podem ser criadas diretamente no seu disco rígido ou na rede, fora do Altium Designer.

Quando o painel Design Reuse está configurado para exibir recursos locais (clique no ícone mais à esquerda na barra de endereços na parte superior do painel e selecione a entrada Local – o ícone será exibido como ), as pastas de snippets podem ser abertas e fechadas na caixa de diálogo Available Snippets Folders, acessada ao clicar no botão  no canto superior direito do painel e selecionar o comando Snippet Folders no menu.

  • Clique em  para procurar a pasta desejada no seu disco rígido ou na rede. A pasta selecionada será adicionada à lista na caixa de diálogo e, em seguida, aparecerá no painel Design Reuse.

  • Para remover uma pasta de snippets da lista (essencialmente fechando-a para navegação), selecione a pasta na lista da caixa de diálogo Available Snippets Folders e clique em .

Editando um snippet

Para editar um snippet do Workspace, passe o cursor sobre sua entrada no painel Design Reuse, clique no botão  (ou clique com o botão direito na entrada) e selecione o comando Edit no menu. Um editor temporário será aberto, com o snippet de documento contido na revisão mais recente do Item de snippet aberto para edição. Faça as alterações necessárias e salve o snippet na próxima revisão do Item (File » Save to Server).

Para editar o conteúdo de um snippet local, abra o documento <SCHSnippetName>.SchDoc ou <PCBSnippetName>.PcbDoc na pasta do Windows onde o snippet está armazenado (usando o comando File » Open nos menus principais do Altium Designer ou por meio do Windows Explorer), faça as alterações necessárias e salve o documento (File » Save).

As propriedades de um snippet local (nome, descrição e caminho) podem ser editadas na caixa de diálogo Snippet Properties. Para acessar essa caixa de diálogo, passe o cursor sobre sua entrada no painel Design Reuse, clique no botão  (ou clique com o botão direito na entrada) e selecione o comando Edit no menu de contexto. Use a caixa de diálogo para fazer as alterações necessárias.

Outras ações de snippet

O menu do botão  (e o menu de contexto) de uma entrada de snippet no painel Design Reuse também oferece acesso aos seguintes comandos:

  • Move (somente para snippets do Workspace) – use para alterar a localização do Item de snippet na estrutura de pastas do Workspace. Ao executar o comando, será aberta a caixa de diálogo Move Item, na qual você poderá selecionar a pasta de destino em que o Item deverá ser colocado.

  • Share (somente para snippets do Workspace) – use para definir as permissões de compartilhamento do snippet. Após selecionar o comando, a caixa de diálogo Share For Item será aberta, permitindo configurar o compartilhamento conforme necessário. Saiba mais sobre compartilhamento no nível do Item.

  • Operations (somente para snippets do Workspace) – use para acessar um menu suspenso com funções adicionais para snippets, conforme descrito abaixo.

    • Make a Copy – use para copiar o snippet. Um editor temporário do snippet será aberto com o mesmo conteúdo do snippet original. Faça as alterações necessárias e salve o snippet no Workspace. 

    • Change Revision State – use para alterar o estado de revisão da revisão mais recente do snippet. Após selecionar o comando, a caixa de diálogo de alteração de estado em lote será aberta, permitindo alterar o estado de revisão do snippet.

    • Download – use para baixar os dados armazenados no snippet. Os dados associados serão baixados para uma subpasta no diretório escolhido, nomeada com o ID da revisão do Item. O arquivo pode ser encontrado na(s) pasta(s) Released dentro dela.

  • Delete – use para excluir o snippet.

    • Para um snippet do Workspace, a caixa de diálogo Delete Items será exibida para confirmar a exclusão.

      Na verdade, a ação é uma “exclusão lógica”, na qual o snippet será movido para a área Trash do Workspace. Saiba mais sobre exclusão lógica.

    • Para um snippet local, a caixa de diálogo Confirm será exibida para confirmar a exclusão. A ação removerá os arquivos do snippet do disco rígido.

  • History (somente para snippets do Workspace) – use para acessar uma visualização detalhada do snippet, aberta como uma nova aba no Altium Designer.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents