Trabalhando com blocos de reutilização

Num relance

Este artigo explica como usar o painel Design Reuse no Altium Designer para criar, gerenciar, pesquisar, posicionar, editar e organizar blocos formais de reutilização armazenados em um Workspace conectado. Ele descreve como os blocos de reutilização podem incluir dados tanto de esquemáticos quanto de PCB e como esses elementos de PCB são transferidos para uma placa por meio do processo de ECO. Também apresenta as principais ações do painel, como navegar pelos recursos do Workspace, visualizar detalhes, selecionar opções de posicionamento, salvar revisões e executar tarefas de gerenciamento, como renomear, mover, compartilhar, baixar e excluir. Se você busca uma maneira mais clara e eficiente de reutilizar seções de projeto já validadas em diferentes projetos, este artigo mostrará por onde começar e como trabalhar com confiança com as ferramentas disponíveis. Continue lendo.

- Aprenda como os blocos formais de reutilização são criados, salvos em um Workspace e reutilizados em projetos de esquemáticos e de PCB por meio do painel Design Reuse.
- Veja como encontrar, inspecionar e posicionar blocos de reutilização, incluindo opções de posicionamento direto, posicionamento como símbolo de folha e tratamento de múltiplos documentos de PCB.
- Entenda as principais ações de gerenciamento disponíveis para blocos de reutilização, incluindo edição, atualização de revisões, compartilhamento, movimentação, download e exclusão lógica.
Aprofunde-se com a IA:

O painel Design Reuse usado para gerenciar blocos de reutilização e descrito nesta página está em Beta Aberto e disponível quando a opção UI.ModernDesignReusePanel está habilitada na caixa de diálogo Configurações avançadas. Quando essa opção está desabilitada, é usada a versão anterior do painel, descrita na página Trabalhando com blocos de reutilização e snippets.

Se os seus projetos costumam incluir 'seções' comuns de circuitos de esquemático e PCB, o Altium Designer oferece maneiras simples e fáceis de salvar e reutilizar essas seções, eliminando a necessidade de criá-las do zero a cada vez.

Quando estiver conectado a um Workspace, você poderá criar um reuse block que pode conter tanto os circuitos do esquemático quanto sua representação física para a PCB. Quando esse bloco de reutilização é inserido em uma folha de esquemático, sua representação física é inserida automaticamente no documento de PCB durante o processo de ECO.

O painel Design Reuse permite acessar rapidamente todos os controles necessários para trabalhar com seus blocos de reutilização e gerenciá-los.

  • O painel também oferece meios de acessar suas folhas de esquemático gerenciadas e seus snippets.

  • Além dos outros métodos padrão de acesso a um painel (o menu do botão  e o submenu View » Panels dos menus principais), o painel Design Reuse pode ser acessado selecionando o comando Place » Reuse Block nos menus principais, no editor de esquemático ou de PCB.

Para trabalhar com blocos de reutilização por meio do painel Design Reuse, certifique-se de que o painel esteja configurado para navegar pelos recursos do Workspace. Para isso, clique no ícone mais à esquerda na barra de endereços, na parte superior do painel, e selecione a entrada do Workspace ao qual você está conectado. O ícone será exibido como .

Criando um bloco de reutilização

Um novo bloco de reutilização pode ser criado conforme descrito abaixo.

  1. Clique no botão  no canto superior direito do painel Design Reuse. Como alternativa, selecione o comando File » New » Reuse Block nos menus principais.

  2. Uma estrutura temporária e editável do bloco de reutilização, semelhante à de um projeto de PCB, será aberta no painel Projects (sob uma entrada do Workspace conectado), e o editor temporário de esquemático será aberto, pronto para definir o documento de esquemático do bloco de reutilização. Use os comandos e as técnicas padrão de posicionamento para definir o documento de esquemático do bloco de reutilização.

    Se desejar criar um bloco de reutilização apenas de esquemático ou apenas de PCB, você poderá remover o documento de PCB ou de esquemático da estrutura do snippet clicando com o botão direito do mouse no documento de PCB ou de esquemático, respectivamente, no painel Projects e selecionando o comando Remove from Project.

  3. Use o comando Design » Update PCB Document e o processo de ECO para transferir o esquemático capturado para o documento de PCB do bloco de reutilização e, em seguida, aplique as alterações necessárias a esse documento (definição das posições dos componentes, roteamento etc.).

    É possível adicionar vários documentos de PCB ao bloco de reutilização que está sendo definido. Para isso, use o comando Add New to Project » PCB no menu de contexto da entrada do bloco de reutilização no painel Projects.

    Use o comando Rename no menu de contexto da entrada do documento de PCB adicionado no painel Projects para definir um nome significativo para ele. Use um comando Design » Update do menu principal do editor de esquemático para atualizar o documento de PCB desejado.

  4. Quando os documentos de esquemático e de PCB do bloco de reutilização estiverem definidos, salve o bloco de reutilização no Workspace usando o comando Save to Server no menu de contexto da entrada do bloco de reutilização no painel Projects ou o controle Save to Server à direita da entrada.

    Como os blocos de reutilização são armazenados no Workspace conectado, recomenda-se usar componentes desse Workspace no bloco de reutilização. Dessa forma, você aproveita todos os benefícios do sistema de conteúdo oferecido pelo Workspace.

    • Os documentos de esquemático e de PCB do bloco de reutilização devem conter pelo menos um componente cada para que possam ser salvos no Workspace.

    • Se os documentos de esquemático e de PCB do bloco de reutilização não estiverem sincronizados (forem detectadas diferenças entre eles), uma caixa de diálogo de aviso será exibida quando você tentar salvar o bloco de reutilização no Workspace. Você poderá cancelar o salvamento para retornar ao bloco de reutilização e resolver as diferenças ou prosseguir com o salvamento.

  5. A caixa de diálogo Create New Reuse Block será exibida, na qual você poderá definir Name, Description e a Folder do Workspace na qual o novo bloco de reutilização será salvo.

  6. Após clicar em OK na caixa de diálogo Create New Reuse Block, o bloco de reutilização será salvo no Workspace e sua estrutura temporária será fechada.

Pesquisando e inserindo um bloco de reutilização

Os blocos de reutilização armazenados no Workspace conectado podem ser explorados e usados pelo painel Design Reuse quando ele estiver configurado para exibir os recursos do Workspace (). Nesse modo, o painel apresenta a estrutura de pastas do seu Workspace para que você possa navegar pelas pastas em que seus blocos de reutilização estão armazenados. Cada pasta e bloco de reutilização são apresentados na lista na parte superior do painel com seu nome e sua descrição.

Para encontrar o bloco de reutilização desejado, você pode navegar pelas pastas ou usar o campo Search na parte superior do painel Design Reuse para pesquisar um bloco de reutilização pelo nome ou pela descrição ().

  • Apenas a revisão mais recente de cada bloco de reutilização é apresentada no painel Design Reuse.

  • Se a revisão mais recente de um bloco de reutilização estiver em um estado de ciclo de vida com a opção Visible in Vault panels desabilitada (saiba mais), esse bloco de reutilização não será exibido no painel por padrão. Para exibir os blocos de reutilização que não estão visíveis no momento, clique no botão  no canto superior direito do painel e habilite a opção Show Hidden Revisions no menu correspondente.

Clique no controle Details na parte inferior do painel para expandir a seção Details, que exibe detalhes do bloco de reutilização selecionado, incluindo:

  • Nome do bloco de reutilização.

  • O ícone do estado do ciclo de vida e a revisão (clique no link para abrir a visualização detalhada do histórico do item de bloco de reutilização com a revisão mais recente selecionada).

  • Descrição do bloco de reutilização.

  • Informações gerais do bloco de reutilização e seus parâmetros.

  • Imagens de pré-visualização dos documentos de esquemático e de PCB do bloco de reutilização.

  • Lista de projetos () e versões liberadas de projetos () em que o bloco de reutilização é usado (a região Where Used).

Usando o acesso controlado ao conteúdo do Workspace, em conjunto com um esquema de ciclo de vida adequado, o pessoal autorizado (bibliotecários, gerentes seniores de projetos) pode aprovar e disponibilizar apenas os blocos de reutilização que devem ser usados nos projetos. Isso permite que o projetista trabalhe com a tranquilidade de estar usando apenas blocos de reutilização autorizados.

Para inserir um bloco de reutilização em um projeto, passe o cursor sobre sua entrada no painel Design Reuse, clique no botão  (ou clique com o botão direito na entrada) e selecione um dos seguintes comandos no menu:

  • Place – selecione para inserir o bloco de reutilização diretamente no documento de esquemático ou de PCB ativo. Dependendo do tipo de documento ativo ao executar o comando, será inserido o documento de esquemático ou de PCB do bloco de reutilização.

     
  • Place as Sheet Symbol – quando um documento de esquemático estiver ativo, selecione para inserir o bloco de reutilização como um símbolo de folha na folha de esquemático. O símbolo de folha inserido incluirá entradas de folha correspondentes às portas do bloco de reutilização. O conteúdo do bloco de reutilização será inserido em uma folha de esquemático filha criada automaticamente e referenciada pelo símbolo de folha. O símbolo de folha de um bloco de reutilização inserido terá um ícone distintivo.

Se o bloco de reutilização incluir mais de um documento de PCB, selecione o documento de PCB desejado clicando em sua aba abaixo da imagem de pré-visualização do documento de PCB na região Preview do painel Details antes de inserir o bloco de reutilização (). Quando o bloco de reutilização for inserido no esquemático, o documento de PCB selecionado será associado ao bloco de reutilização e inserido na PCB quando ela for atualizada por meio do processo de ECO.

Após inserir o documento de esquemático de um bloco de reutilização, seu documento de PCB poderá ser inserido no documento de PCB por meio do processo de ECO. No editor de esquemáticos, use o comando Design » Update PCB Document nos menus principais e, em seguida, valide e execute as alterações usando a caixa de diálogo Engineering Change Order.

Edição de um bloco de reutilização

Para editar um bloco de reutilização, passe o cursor sobre sua entrada no painel Design Reuse e clique no botão  (ou clique com o botão direito na entrada) e selecione o comando Edit no menu.

A estrutura temporária do projeto do bloco de reutilização que contém a revisão mais recente do Item de Bloco de Reutilização será aberta para edição. Faça as alterações necessárias e salve o bloco de reutilização em sua próxima revisão (File » Save to Server).

Outras ações para blocos de reutilização

O menu do botão  (e o menu de contexto) de uma entrada de bloco de reutilização no painel Design Reuse também fornece acesso aos seguintes comandos:

  • Rename – use para alterar o nome do bloco de reutilização. Após selecionar o comando, insira o novo nome desejado na caixa de diálogo Rename Reuse Block exibida e, em seguida, clique em OK.

  • Move – use para alterar a localização do Item de Bloco de Reutilização na estrutura de pastas do Workspace. Ao executar o comando, será aberta a caixa de diálogo Move Item, na qual você poderá selecionar a pasta de destino em que o Item deverá ser inserido.

  • Share – use para definir as permissões de compartilhamento do bloco de reutilização. Após selecionar o comando, a caixa de diálogo Share For Item será aberta, na qual você poderá configurar o compartilhamento conforme necessário. Saiba mais sobre compartilhamento no nível do Item.

  • Operations – use para acessar um menu suspenso com funções adicionais para blocos de reutilização, conforme descrito abaixo.

    • Make a Copy – use para copiar o bloco de reutilização. Uma estrutura temporária do projeto do bloco de reutilização será aberta, com o mesmo conteúdo do bloco de reutilização original. Faça as alterações necessárias e salve o bloco de reutilização no Workspace. 

    • Change Revision State – use para alterar o estado da revisão mais recente do bloco de reutilização. Após selecionar o comando, a caixa de diálogo de alteração de estado em lote será aberta, permitindo alterar o estado da revisão do bloco de reutilização.

    • Download – use para baixar os dados armazenados no bloco de reutilização (seus documentos de esquemático e/ou de PCB). Os dados associados serão baixados para uma subpasta no diretório escolhido, nomeada com o ID da Revisão do Item de Bloco de Reutilização. Os arquivos podem ser encontrados na(s) pasta(s) Released dentro dela.

  • Delete – use para excluir o bloco de reutilização do Workspace ao qual você está conectado. Após selecionar o comando, a caixa de diálogo Delete Items será exibida para confirmar a exclusão. Você também pode optar por excluir o conteúdo relacionado ao bloco de reutilização (ou seja, trechos de esquemático e de PCB).

    A ação é, na verdade, uma “exclusão reversível”, na qual o bloco de reutilização será movido para a área Trash do Workspace. Saiba mais sobre a exclusão reversível.

  • History – use para acessar uma visualização detalhada do bloco de reutilização, aberta como uma nova aba no Altium Designer.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents