Проверка компонента
Перед сохранением компонента библиотеки Workspace, определенного/отредактированного в редакторе компонентов (в режиме Single Component Editing или Batch Component Editing), в подключенное Workspace и перед тем, как сделать компонент доступным для использования в проектах, крайне важно убедиться, что этот компонент соответствует требованиям согласно заданным настройкам. При попытке сохранить компонент обратно в Workspace редактор компонентов запускает проверку — Component Rule Check. Эту функцию также можно запустить вручную в любое время, выбрав команду Tools » Component Rule Check в главном меню. Перед этим обязательно сохраните компонент локально (File » Save).
Подобно тому как в проекте платы используется процесс проверки для обнаружения нарушений, в редакторе компонентов предусмотрена функция валидации компонентов. Все обнаруженные нарушения перечисляются в панели Messages.
Валидация компонента проверяет широкий спектр потенциальных проблем, связанных с компонентом и заданными для него моделями, — как встроенные проверки, так и ряд типов нарушений, которые пользователь может определить на глобальном уровне.
Следующие встроенные проверки валидации имеют режим отчета
:
Путь к папке не указан для компонента
Сводка
Это нарушение возникает, когда не указана папка в целевом Workspace, в которой должен быть сохранен компонент, определяемый в Component Editor.
Уведомление
В панели Messages будет показано уведомление в следующем формате:
Folder path not specified for component <ItemID>
где:
- ItemID — это идентификатор, используемый для компонента в Workspace.
Рекомендации по устранению
-
В Component Editor в режиме Single Component Editing mode используйте поле Folder в Component, чтобы указать папку в целевом Workspace, куда будет сохранен компонент. Чтобы указать целевую папку вручную, нажмите кнопку
, чтобы открыть диалог Choose Folder. Перейдите к существующей папке и выберите ее либо создайте новую папку на лету.
-
В Component Editor в режиме Batch Component Editing mode используйте поле FolderPath (в группе столбцов Component) в области определения компонента редактора, чтобы указать папку в целевом Workspace, куда будет сохранен компонент. Чтобы указать целевую папку вручную, один раз щелкните внутри поля FolderPath для компонента, чтобы появилась кнопка
, и нажмите ее для открытия диалога Choose Folder. Перейдите к существующей папке и выберите ее либо создайте новую папку на лету.
Компонент не имеет уникального идентификатора
Сводка
Это нарушение возникает, когда Item ID компонента, определяемого в Component Editor, совпадает с Item ID другого элемента в подключенном Workspace.
Уведомление
В панели Messages будет показано уведомление в следующем формате:
Duplicate Component Id: "<ItemID>"
где:
- ItemID — это идентификатор, используемый для компонента в Workspace.
Рекомендации по устранению
-
В Component Editor в режиме Single Component Editing mode используйте поле Id в области Component, чтобы указать другой идентификатор, уникальный для содержимого подключенного Workspace.
-
В Component Editor в режиме Batch Component Editing mode используйте поле Item ID в группе столбцов Component области определения компонента, чтобы указать другой идентификатор, уникальный для содержимого подключенного Workspace.
Примечание
Это нарушение обычно возникает, когда автоматически назначенное компоненту значение Item ID было вручную переопределено. Для нового компонента, созданного с помощью команды File » New » Component или панели Components panel, это поле заполняется в соответствии с шаблоном компонента, заданным для типа компонента, выбранного в диалоге Create new component dialog. Если шаблон отсутствует или в диалоге выбрана запись <Undefined> , используется схема именования по умолчанию; CMP-{00000}. Для нового компонента, созданного через панель Explorer panel, это поле заполняется в соответствии со схемой именования по умолчанию, указанной для родительской папки компонента. Если к родительской папке привязан шаблон компонента, то из него будет взято заданное наименование компонентов. Программное обеспечение автоматически назначит следующий доступный уникальный идентификатор на основе этой схемы, просканировав все Workspace и идентификаторы существующего содержимого.
Пользовательские проверки настраиваются на странице Data Management – Component Rule Checks page диалога Preferences.
Любая не пройденная встроенная проверка или пользовательская проверка с уровнем Fatal Error предотвратит сохранение компонента в Workspace.
Настройки пользовательских проверок по умолчанию могут не подходить вашим компонентам, поэтому важно ознакомиться с доступными параметрами и с тем, как настроить их в соответствии с вашими проектами. Информация о каждой пользовательской проверке ошибок приведена ниже.
Нарушения, связанные с компонентами
Дублирующийся компонент по имени
Default report mode:
Сводка
Это нарушение возникает, когда имя компонента, определяемого в Component Editor, совпадает с именем компонента в подключенном Workspace.
Уведомление
В панели Messages отображается уведомление в следующем формате:
Duplicate component by Name
Рекомендации по устранению
Назначьте компоненту(ам) другие уникальные имена, как требуется.
-
В Component Editor в режиме Single Component Editing mode используйте поле Name в области Component , чтобы указать другое имя, уникальное для компонентов в подключенном Workspace.
-
В Component Editor в режиме Batch Component Editing mode используйте поле Item ID в группе столбцов Component области определения компонента, чтобы указать другое имя, уникальное для компонентов в подключенном Workspace.
Дублирующийся компонент по PCL
Default report mode:
Сводка
Это нарушение возникает, когда компонент, определяемый в Component Editor, имеет Part Choice, который уже используется другим компонентом в подключенном Workspace.
Уведомление
В панели Messages отображается уведомление в следующем формате:
Duplicate component by Part Choice list
Рекомендации по устранению
Назначьте компоненту(ам) другие уникальные Part Choice, как требуется.
-
В Component Editor в режиме Single Component Editing mode используйте область Part Choices , чтобы изменить список Part Choice компонента на уникальный для компонентов в подключенном Workspace.
-
В Component Editor в режиме Batch Component Editing mode используйте группу столбцов Part Choice n области определения компонента, чтобы изменить список Part Choice компонента на уникальный для компонентов в подключенном Workspace.
Недопустимые сопоставления выводов
Default report mode:
Сводка
Это нарушение возникает, когда компонент, определяемый в Component Editor, имеет неоднозначное сопоставление между символом компонента и посадочным местом(ами). Например, нарушение возникает, если у символа в полях Designator выводы заданы как 1, 2, 3, а у посадочного места в полях Designator контактные площадки заданы как B, C, E, либо когда число выводов символа больше числа контактных площадок посадочного места.
Уведомление
В панели Messages отображается уведомление в следующем формате:
Pin <PinDesignator> of the symbol <SymbolName> (<SymbolRevisionID>) does not have corresponding pad <PadDesignator> in footprint <FootprintName> (<FootprintRevisionID>)
где:
-
PinDesignator— это Designator вывода символа. -
SymbolName— это имя символа. -
SymbolRevisionID— это Item-Revision ID символа. -
PadDesignator— это Designator контактной площадки посадочного места. -
FootprintName— это имя посадочного места. -
FootprintRevisionID— это Item-Revision ID посадочного места.
Рекомендации по устранению
Отредактируйте уже добавленную модель или выберите другую, чтобы обеспечить взаимно-однозначное соответствие выводов символа контактным площадкам посадочного места.
-
В Component Editor в режиме Single Component Editing mode:
-
нажмите элемент управления
в правом верхнем углу предварительного просмотра модели, чтобы изменить модель, которая в данный момент используется (на которую ссылается) компонент, в соответствующем временном редакторе для этого типа модели;
-
нажмите элемент управления
в правом верхнем углу предварительного просмотра модели и выберите запись Select Model из меню, чтобы найти и выбрать другую модель или другую редакцию той же модели;
-
нажмите элемент управления
в правом верхнем углу предварительного просмотра символа, чтобы открыть панель Pins panel и напрямую изменить цели сопоставления площадка/вывод, щелкнув по ячейке модели и введя требуемое значение.
-
-
В Component Editor в режиме Batch Component Editing mode:
-
щелкните правой кнопкой мыши по записи модели в области Model Links и выберите команду Edit в контекстном меню, чтобы изменить модель, которая в данный момент используется (на которую ссылается) компонент, в соответствующем временном редакторе для этого типа модели;
-
щелкните по полю Item ID модели в области Model Links , затем нажмите кнопку
, чтобы найти и выбрать другую модель или другую редакцию той же модели.
-
Отсутствует описание компонента
Default report mode:
Сводка
Это нарушение возникает, когда для компонента, определяемого в Component Editor, не задано описание.
Уведомление
В панели Messages отображается уведомление в следующем формате:
Component Description is not specified
Рекомендации по устранению
При необходимости задайте описание для проблемного компонента(ов).
-
В Component Editor в режиме Single Component Editing mode используйте поле Description в области Component , чтобы задать описание.
-
В Component Editor в режиме Batch Component Editing mode используйте поле Description в группе столбцов Component области определения компонента, чтобы задать описание для проблемного компонента(ов).
Отсутствует имя компонента
Default report mode:
Сводка
Это нарушение возникает, когда для компонента, определяемого в Component Editor, не задано имя.
Уведомление
В панели Messages отображается уведомление в следующем формате:
Component Name is not specified
Рекомендации по устранению
При необходимости задайте имя для проблемного компонента(ов).
-
В Component Editor в режиме Single Component Editing mode используйте поле Name в области Component , чтобы задать имя.
-
В Component Editor в режиме Batch Component Editing mode используйте поле Name в группе столбцов Component области определения компонента, чтобы задать имя для проблемного компонента(ов).
Тип компонента не указан
Default report mode:
Сводка
Это нарушение возникает, когда для компонента, определяемого в Component Editor, не задан тип.
Уведомление
В панели Messages отображается уведомление в следующем формате:
Component Type is not specified
Рекомендации по устранению
При необходимости задайте тип для проблемного компонента(ов).
-
В Component Editor в режиме Single Component Editing mode используйте поле Type в области Component , чтобы задать тип.
-
В Component Editor в режиме Batch Component Editing mode используйте поле Type в группе столбцов Component области определения компонента, чтобы задать тип для проблемного компонента(ов).
Редакция модели находится в неприменимом состоянии
Default report mode:
Сводка
Это нарушение возникает, когда обнаруживается, что связанная модель, используемая (на которую ссылается) в определении компонента, находится в неприменимом состоянии. Например, модель сейчас имеет состояние Obsolete и поэтому не должна использоваться. Применимость определяется параметром Allowed to be used in designs в диалоге State Properties dialog. Из диалога Edit Lifecycle Definitions dialog этот диалог можно открыть для нужного состояния либо двойным щелчком по записи состояния в родительском определении жизненного цикла, либо выбрав эту запись и нажав появившийся значок редактирования Когда этот параметр включен, модель в данном состоянии разрешено использовать в компоненте. Она считается Applicable. Если параметр отключен, модель в данном состоянии не может использоваться корректно и считается Inapplicable (или неприменимой).
Уведомление
В панели Messages отображается уведомление в следующем формате:
<ModeName> (<ModelRevisionID>) revision is in inapplicable state
где:
-
ModelName— это имя модели. -
ModelRevisionID— это Item-Revision ID модели.
Рекомендации по устранению
Выберите заменяющую модель или редакцию той же модели, допустимую для использования в компоненте.
-
В Component Editor в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра модели и выберите запись Select Model из меню, чтобы найти и выбрать другую модель или другую редакцию той же модели.
-
В Component Editor в режиме Batch Component Editing mode щелкните по полю Item ID модели в области Model Links , затем нажмите кнопку
, чтобы найти и выбрать другую модель или другую редакцию той же модели.
Редакция модели устарела
Default report mode:
Сводка
Это нарушение возникает, когда обнаруживается, что связанная модель, используемая (на которую ссылается) в определении компонента, устарела. Если доступна более поздняя редакция модели, поле Revision State будет отражать это текстом Out of date, справа от состояния жизненного цикла текущей редакции под предварительным просмотром модели (в Component Editor в режиме Single Component Editing), либо поле Revision Status в области Model Links будет помечено текстом Out of date, отображаемым полужирным шрифтом (в Component Editor в режиме Batch Component Editing).
Уведомление
В панели Messages отображается уведомление в следующем формате:
<ModelName> (<ModelRevisionID>) revision is Out of Date
где:
-
ModelName— это имя модели. -
ModelRevisionID— это Item-Revision ID модели.
Рекомендации по устранению
Обновите ссылки на модели компонента, которые устарели, чтобы использовать последние редакции моделей.
-
В Component Editor в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра модели и выберите запись Update to Latest из меню.
-
В Component Editor в режиме Batch Component Editing mode щелкните правой кнопкой мыши в любом месте записи модели в Model Links region и выберите Update to Latest Revision в меню.
Number of Pads exceeds Number of Pins
Default report mode:
Сводка
Это нарушение возникает, когда модель посадочного места, используемая (на которую ссылается) в определении компонента, содержит больше площадок (SMD-площадок, размещенных на медных слоях, и металлизированных сквозных площадок), чем выводов в связанном с ней схематическом символе.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Number of pads in the footprint <FootprintName> (<FootprintRevisionID>) (<FootprintNumberOfPads>) exceeds number of pins in the symbol <SymbolName> (<SymbolRevisionID>) (<SymbolNumberOfPins>)
где:
-
FootprintName— имя посадочного места. -
FootprintRevisionID— Item-Revision ID посадочного места. -
FootprintNumberOfPads— количество площадок в посадочном месте. -
SymbolName— имя символа. -
SymbolRevisionID— Item-Revision ID символа. -
SymbolNumberOfPins— количество выводов в символе.
Рекомендации по устранению
Измените уже добавленную модель или выберите другую модель символа/посадочного места, чтобы количество площадок в посадочном месте не превышало количество выводов символа.
-
В редакторе компонентов в режиме Single Component Editing mode:
-
нажмите элемент управления
в правом верхнем углу предварительного просмотра модели, чтобы изменить модель, которая сейчас используется компонентом (на которую он ссылается), в соответствующем временном редакторе для этого типа модели;
-
нажмите элемент управления
в правом верхнем углу предварительного просмотра модели и выберите пункт Select Model в меню, чтобы найти и выбрать другую модель или другую редакцию этой же модели.
-
-
В редакторе компонентов в режиме Batch Component Editing mode:
-
щелкните правой кнопкой мыши запись модели в области Model Links и выберите команду Edit в контекстном меню, чтобы изменить модель, которая сейчас используется компонентом (на которую он ссылается), в соответствующем временном редакторе для этого типа модели;
-
щелкните поле Item ID модели в области Model Links , затем нажмите кнопку
, чтобы найти и выбрать другую модель или другую редакцию этой же модели.
-
Revision that is being edited is not latest
Default report mode:
Сводка
Это нарушение возникает, когда редактируемая редакция компонента не является последней доступной редакцией в подключенном Workspace.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
<ComponentName> (<ComponentRevisionID>) revision is Out of Date
где:
-
ComponentName— Name компонента. -
ComponentRevisionID— Item-Revision ID компонента.
Рекомендации по устранению
Выберите для редактирования последнюю редакцию компонента. Для этого найдите компонент на панели Components panel, щелкните его запись на панели правой кнопкой мыши и выберите Edit.
Unrecognized combination of Manufacturer+Part Number in Part Choice
Default report mode:
Сводка
Это нарушение возникает, когда для варианта выбора детали компонента добавлена некорректная запись, и Workspace не может получить эту деталь.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Manufacturer+Part Number combination was not found in the available Part Sources ("Part Choice <n>")
где:
-
n— порядковый номер проблемного варианта выбора детали.
Рекомендации по устранению
Укажите корректный вариант выбора детали для проблемного компонента (или компонентов).
-
В редакторе компонентов в режиме Single Component Editing mode удалите недопустимые варианты выбора детали из области Part Choices и добавьте новые, корректные варианты.
-
В редакторе компонентов в режиме Batch Component Editing mode введите корректные значения в поля Part Choice n в области определения компонента. Обратите внимание: пока в поле варианта выбора детали содержится некорректная запись, текст будет отображаться серым цветом и курсивом. Когда обе записи будут корректны, текст будет отображаться как обычный белый текст.
Нарушения, связанные с посадочными местами
Duplicate Pad Designator
Default report mode:
Сводка
Это нарушение возникает, когда модель посадочного места, связанная с компонентом, определяемым в редакторе компонентов, содержит несколько объектов Pad с одинаковым значением свойства Designator.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Duplicate Pad Designator On Pads Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>
где:
-
Identifier1— идентификатор первого экземпляра площадки с дублирующимся позиционным обозначением, представленный парой сеть-обозначение и координатами площадки. -
Layer1— слой, на котором размещен первый экземпляр площадки с дублирующимся позиционным обозначением. -
Identifier2— идентификатор второго экземпляра площадки с дублирующимся позиционным обозначением, представленный парой сеть-обозначение и координатами площадки. -
Layer2— слой, на котором размещен второй экземпляр площадки с дублирующимся позиционным обозначением.
Рекомендации по устранению
Назначьте разные уникальные позиционные обозначения площадкам связанной модели посадочного места.
-
В редакторе компонентов в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра посадочного места.
-
В редакторе компонентов в режиме Batch Component Editing mode щелкните правой кнопкой мыши запись посадочного места в области Model Links и выберите команду Edit в контекстном меню.
Модель посадочного места, которая сейчас используется компонентом (на которую он ссылается), откроется во временном редакторе PCB Footprint. Выберите проблемные площадки и измените значения их свойства Designator в режиме Pad mode of the Properties panel.
Duplicate Primitives
Default report mode:
Сводка
Это нарушение возникает, когда модель посадочного места, связанная с компонентом, определяемым в редакторе компонентов, содержит одинаковые объекты, размещенные в одном и том же месте на одном и том же слое.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Duplicate Primitives: <ObjectType1> <Identifier1> on <Layer1> And <ObjectType2> <Identifier2> on <Layer2>
где:
-
ObjectType1— тип первого экземпляра дублирующегося объекта. -
Identifier1— идентификатор первого экземпляра дублирующегося объекта; способ представления идентификатора зависит от типа объекта. -
Layer1— слой, на котором размещен первый экземпляр дублирующегося объекта. -
ObjectType2— тип второго экземпляра дублирующегося объекта. -
Identifier2— идентификатор второго экземпляра дублирующегося объекта; способ представления идентификатора зависит от типа объекта. -
Layer2— слой, на котором размещен второй экземпляр дублирующегося объекта.
Рекомендации по устранению
Удалите дублирующиеся объекты из модели посадочного места.
-
В редакторе компонентов в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра посадочного места.
-
В редакторе компонентов в режиме Batch Component Editing mode щелкните правой кнопкой мыши запись посадочного места в области Model Links и выберите команду Edit в контекстном меню.
Модель посадочного места, которая сейчас используется компонентом (на которую он ссылается), откроется во временном редакторе PCB Footprint. Выберите дублирующиеся объекты и удалите их с помощью сочетания клавиш Delete.
Mirrored Footprint (designed on bottom layer)
Default report mode:
Сводка
Это нарушение возникает, когда модель посадочного места, связанная с компонентом, определяемым в редакторе компонентов, содержит значимые примитивы (площадки, дорожки, дуги, заливки, области, прямоугольники, текстовые строки, объекты keepout), размещенные на Bottom Layer, но не содержит таких примитивов на Top Layer.
В редакторе PCB Footprint посадочное место создается для верхней стороны платы; при необходимости в процессе проектирования PCB его можно перевернуть на нижнюю сторону.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Bottom Layer Component
Рекомендации по устранению
Переверните примитивы посадочного места с Bottom Layer на Top Layer.
-
В редакторе компонентов в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра посадочного места.
-
В редакторе компонентов в режиме Batch Component Editing mode щелкните правой кнопкой мыши запись посадочного места в области Model Links и выберите команду Edit в контекстном меню.
Модель посадочного места, которая сейчас используется компонентом (на которую он ссылается), откроется во временном редакторе PCB Footprint. Выберите примитивы на Bottom Layer и измените их свойство Layer в соответствующем режиме панели Properties на Top Layer.
Missing Pad Designator
Default report mode:
Сводка
Это нарушение возникает, когда модель посадочного места, связанная с компонентом, определяемым в редакторе компонентов, содержит объект Pad, для которого не указано значение свойства Designator.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Missing Pad Designator on Pad: Pad <Identifier> on <Layer>
где:
-
Identifier— идентификатор площадки, для которой не указано позиционное обозначение, представленный сетью площадки и координатами. -
Layer— слой, на котором размещена площадка без указанного позиционного обозначения.
Рекомендации по устранению
Укажите значения позиционных обозначений для площадок связанной модели посадочного места.
-
В редакторе компонентов в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра посадочного места, чтобы открыть посадочное место, которое сейчас используется компонентом (на которое он ссылается), во временном редакторе PCB Footprint.
-
В редакторе компонентов в режиме Batch Component Editing mode щелкните правой кнопкой мыши запись посадочного места в области Model Links и выберите команду Edit в контекстном меню.
Модель посадочного места, которая сейчас используется компонентом (на которую он ссылается), откроется во временном редакторе PCB Footprint. Выберите проблемную площадку и укажите значение ее свойства Designator в режиме Pad mode of the Properties panel.
Offset Footprint Reference
Default report mode:
Сводка
Это нарушение возникает, когда у модели посадочного места, связанной с компонентом, определяемым в редакторе компонентов, опорная точка (origin) находится вне ограничивающего прямоугольника, образованного объектами посадочного места.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Offset Component Origin
Рекомендации по устранению
Измените положение опорной точки так, чтобы она находилась внутри ограничивающего прямоугольника, образованного объектами посадочного места.
-
В редакторе компонентов в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра посадочного места, чтобы открыть посадочное место, которое сейчас используется компонентом (на которое он ссылается), во временном редакторе PCB Footprint.
-
В редакторе компонентов в режиме Batch Component Editing mode щелкните правой кнопкой мыши запись посадочного места в области Model Links и выберите команду Edit в контекстном меню.
Модель посадочного места, которая сейчас используется компонентом (на которую он ссылается), откроется во временном редакторе PCB Footprint. Используйте команды подменю Edit » Set Reference главного меню, чтобы изменить текущее положение опорной точки посадочного места.
Shorted Copper
Default report mode:
Сводка
Это нарушение возникает, когда модель посадочного места, связанная с компонентом, определяемым в редакторе компонентов, содержит объекты Pad, которые соединены друг с другом объектами на медном слое.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Shorted Copper Connection Between Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>
где:
-
Identifier1— идентификатор первого экземпляра площадки в паре закороченных площадок, представленный парой сеть-обозначение и координатами площадки. -
Layer1— слой, на котором размещен первый экземпляр площадки в паре закороченных площадок. -
Identifier2— идентификатор второго экземпляра площадки в паре закороченных площадок, представленный парой сеть-обозначение и координатами площадки. -
Layer2— слой, на котором размещен второй экземпляр площадки в паре закороченных площадок.
Рекомендации по устранению
Удалите объекты на медном слое, которые соединяют площадки связанной модели посадочного места.
-
В редакторе компонентов в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра посадочного места.
-
В редакторе компонентов в режиме Batch Component Editing mode щелкните правой кнопкой мыши запись посадочного места в области Model Links и выберите команду Edit в контекстном меню.
Модель посадочного места, которая сейчас используется компонентом (на которую он ссылается), откроется во временном редакторе PCB Footprint. Выберите объекты на медном слое, которые соединяют площадки, затем измените их так, чтобы они не соединяли площадки, либо удалите эти объекты.
Unconnected Copper
Default report mode:
Сводка
Это нарушение возникает, когда модель посадочного места, связанная с компонентом, определяемым в редакторе компонентов, содержит объекты на медном слое, и эти объекты не подключены ни к каким объектам Pad. Когда такое посадочное место будет размещено в проекте PCB, этим объектам на медном слое не будет назначена цепь, и они станут «мертвой» медью.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Unconnected Copper on primitive : <ObjectType> <Identifier> on <Layer>
где:
-
ObjectType— тип экземпляра объекта, который не подключен ни к одному объекту Pad в модели посадочного места. -
Identifier— идентификатор объекта, который не подключен ни к одному объекту Pad в модели посадочного места; способ представления идентификатора зависит от типа объекта. -
Layer— слой, на котором размещен экземпляр объекта, не подключенного ни к одному объекту Pad в модели посадочного места.
Рекомендации по устранению
Измените модель посадочного места так, чтобы объекты, которые в настоящее время не подключены ни к одному объекту Pad в модели посадочного места, были подключены к площадкам.
-
В редакторе компонентов в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра посадочного места.
-
В редакторе компонентов в режиме Batch Component Editing mode щелкните правой кнопкой мыши запись посадочного места в области Model Links и выберите команду Edit в контекстном меню.
Модель посадочного места, которая сейчас используется компонентом (на которую он ссылается), откроется во временном редакторе PCB Footprint. Разместите объекты на медном слое (или слоях), чтобы сформировать соединение между площадками посадочного места и объектами, которые в настоящее время не подключены ни к одному объекту Pad, либо удалите эти неподключенные объекты.
Нарушения, связанные с символами
Different pins between modes
Default report mode:
Сводка
Это нарушение возникает, когда в одном из режимов отображения символа имеется лишний вывод.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Extra Pin in display mode <DisplayMode> of the symbol <SymbolRevisionID>. Part <PartDesignator>. Pin Name "<PinName>"
где:
-
DisplayMode— это конкретный режим графического представления символа, в котором был обнаружен лишний вывод (или выводы). Символ имеет режим Normal и может иметь до 255 определенных режимов Alternate. Подробнее о создании нескольких режимов графического отображения одного и того же символа компонента. -
SymbolRevisionID— это Item-Revision ID символа. -
PartDesignator— это Designator части символа. -
PinName— это Name проблемного вывода.
Рекомендации по устранению
Это нарушение обычно возникает, когда для символа определен альтернативный графический режим и при этом:
- в один режим отображения был добавлен лишний вывод, который не указан в другом режиме отображения, или
- для вывода были указаны другие Designator и/или Name по сравнению с выводом, указанным в другом режиме отображения.
Между режимами графического отображения должно совпадать не только количество выводов, но и сами выводы должны быть идентичными как по Designator, так и по Name. Подробнее о создании нескольких режимов графического отображения одного и того же символа компонента.
Измените Designator и/или Name проблемного вывода (или выводов) так, чтобы количество выводов и их свойства Designator и Name были одинаковыми между режимами отображения символа, либо удалите лишний вывод из режима отображения.
-
В редакторе Component Editor в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра символа.
-
В редакторе Component Editor в режиме Batch Component Editing mode щелкните правой кнопкой мыши запись символа в области Model Links и выберите команду Edit в контекстном меню.
Модель символа, которая в настоящее время используется (на которую ссылается) компонент, откроется во временном редакторе библиотек схем. Выберите проблемные выводы и измените значения их свойства Designator и/или свойства Name в режиме Pin панели Properties, либо удалите эти выводы с помощью сочетания клавиш Delete.
Duplicate Pin Designators
Default report mode:
Сводка
Это нарушение возникает, когда два или более выводов в модели символа компонента имеют одинаковый designator.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Duplicate Pin Designator(s) (mode <DisplayMode>): <PinDesignatorList>
где:
-
DisplayMode— это конкретный режим графического представления символа, в котором были обнаружены дублирующиеся выводы. Символ имеет режим Normal и может иметь до 255 определенных режимов Alternate. -
PinDesignatorList— это список через запятую designator'ов выводов, которые дублируются в проблемном символе.
Рекомендации по устранению
Соответствующим образом измените designator проблемного вывода (или выводов), чтобы у каждого было уникальное значение.
-
В редакторе Component Editor в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра символа.
-
В редакторе Component Editor в режиме Batch Component Editing mode щелкните правой кнопкой мыши запись символа в области Model Links и выберите команду Edit в контекстном меню.
Модель символа, которая в настоящее время используется (на которую ссылается) компонент, откроется во временном редакторе библиотек схем. Выберите проблемные выводы и измените значения их свойства Designator в режиме Pin панели Properties, либо удалите эти выводы с помощью сочетания клавиш Delete.
Missing Default Designator
Default report mode:
Сводка
Это нарушение возникает, когда для модели символа компонента не указан designator по умолчанию.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Missing Default Designator
Рекомендации по устранению
Укажите designator по умолчанию для проблемной модели символа.
-
В редакторе Component Editor в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра символа.
-
В редакторе Component Editor в режиме Batch Component Editing mode щелкните правой кнопкой мыши запись символа в области Model Links и выберите команду Edit в контекстном меню.
Модель символа, которая в настоящее время используется (на которую ссылается) компонент, откроется во временном редакторе библиотек схем. Откройте режим Symbol панели Properties (активен, когда в рабочей области не выбран ни один объект) и укажите требуемый префикс designator, за которым следует символ '?', в поле Designator (например, C?). Вопросительные знаки в designator'ах компонентов, размещенных на листе схемы, будут заменены фактическими номерами в процессе Design Annotation.
Missing Pin Designator
Default report mode:
Сводка
Это нарушение возникает, когда для вывода в модели символа компонента не указан designator.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Missing Pin Designator of the symbol <SymbolRevisionID>
где:
-
SymbolRevisionID— это Item-Revision ID проблемного символа.
Рекомендации по устранению
Укажите designator для каждого вывода в проблемной модели символа.
-
В редакторе Component Editor в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра символа.
-
В редакторе Component Editor в режиме Batch Component Editing mode щелкните правой кнопкой мыши запись символа в области Model Links и выберите команду Edit в контекстном меню.
Модель символа, которая в настоящее время используется (на которую ссылается) компонент, откроется во временном редакторе библиотек схем. Выберите проблемные выводы и укажите значения их свойства Designator в режиме Pin панели Properties, либо удалите выводы с помощью сочетания клавиш Delete.
Missing Pin Name
Default report mode:
Сводка
Это нарушение возникает, когда для вывода в модели символа компонента не указано имя.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Missing Pin Name of the symbol <SymbolRevisionID>. Pin Designator "<PinDesignator>".
где:
-
SymbolRevisionID— это Item-Revision ID проблемного символа. -
PinDesignator— это Designator проблемного вывода.
Рекомендации по устранению
Укажите имя для каждого вывода в проблемной модели символа.
-
В редакторе Component Editor в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра символа.
-
В редакторе Component Editor в режиме Batch Component Editing mode щелкните правой кнопкой мыши запись символа в области Model Links и выберите команду Edit в контекстном меню.
Модель символа, которая в настоящее время используется (на которую ссылается) компонент, откроется во временном редакторе библиотек схем. Выберите проблемные выводы и укажите значения их свойства Name в режиме Pin панели Properties, либо удалите эти выводы с помощью сочетания клавиш Delete.
Примечание
На панели Messages для каждого отдельного компонента будет указан только один экземпляр нарушения. Компонент вполне может иметь символ, в котором несколько выводов без заданного имени.
Missing Pins in Sequence
Default report mode:
Сводка
Это нарушение возникает, когда в числовой последовательности значений designator выводов проблемного символа обнаружены пропущенные выводы. Например, если у символа есть выводы с designator'ами 1, 2, 5, а выводы с designator 3 и 4 отсутствуют.
Уведомление
Уведомление отображается на панели Messages в следующем формате:
Missing Pin Designator In Sequence : <PinDesignatorList> [<LowerPinDesignator>..<UpperPinDesignator>]
где:
-
PinDesignatorList— это список через запятую отсутствующих designator'ов выводов в числовой последовательности, обнаруженной в проблемном символе. -
LowerPinDesignator— это минимальное числовое значение designator'ов выводов, обнаруженных в проблемном символе. -
UpperPinDesignator— это максимальное числовое значение designator'ов выводов, обнаруженных в проблемном символе.
Рекомендации по устранению
В проблемной модели символа добавьте выводы с отсутствующими designator'ами в последовательности или измените designator'ы выводов так, чтобы они образовывали непрерывную последовательность целочисленных значений.
-
В редакторе Component Editor в режиме Single Component Editing mode нажмите элемент управления
в правом верхнем углу предварительного просмотра символа.
-
В редакторе компонентов в режиме Batch Component Editing щелкните правой кнопкой мыши по записи символа в области Model Links и выберите команду Edit в контекстном меню.
Модель символа, которая в данный момент используется (на которую ссылается) компонент, откроется во временном редакторе библиотеки схем. Используя команду Place » Pin в главном меню, добавьте необходимое количество выводов и задайте значения их свойства Designator в режиме Pin mode of the Properties panel так, чтобы позиционные обозначения выводов в символе образовывали непрерывную последовательность целых значений. Вы также можете изменить свойство Designator у выводов, уже размещенных в символе.
Примечание
Существуют компоненты, в которых не используется последовательная нумерация выводов, например BGA с непоследовательной нумерацией выводов: A1, A3, A5 (и так далее). В этом случае рекомендуется выпустить компонент с этим нарушением и указать причину в примечаниях к выпуску. Либо установите проверку Missing Pins in Sequence на странице Data Management – Component Rule Checks диалогового окна Preferences в значение No Report.


