Работа с контактными площадками и переходными отверстиями

Краткий обзор

В этой статье рассказывается о контактных площадках и переходных отверстиях в Altium Designer: что они собой представляют, чем отличаются, где используются, а также как их размещать и редактировать в редакторах печатных плат и посадочных мест. Кроме того, в статье рассматриваются основные типы переходных отверстий, способы их непосредственного размещения и создания путём преобразования других объектов, а также возможности работы с шаблонами и переходными отверстиями, влияющие на производительность программы. Если вы хотите лучше разобраться в основных объектах печатной платы, обеспечивающих подключение компонентов и трассировку между слоями, читайте дальше — эта статья поможет вам уверенно освоить ключевые понятия.

- Вы узнаете, чем контактные площадки отличаются от переходных отверстий на практике, как они устроены и для чего предназначены, а также какие основные типы переходных отверстий используются при проектировании печатных плат.
- Вы увидите, как размещать, перемещать, преобразовывать и назначать контактные площадки и переходные отверстия в Altium Designer.
- Вы получите общее представление об управлении свойствами контактных площадок и переходных отверстий, включая использование шаблонов и основные возможности редактирования на панели Properties.
Узнайте больше с ИИ:

Общие сведения о контактных площадках и переходных отверстиях

Контактные площадки обеспечивают механическое крепление и электрическое соединение выводов компонента Контактные площадки обеспечивают механическое крепление и электрическое соединение выводов компонента

Контактная площадка — это примитивный объект проекта. Контактные площадки используются для крепления компонента к плате и создания точек соединения выводов компонента с проводниками на плате. Площадки могут располагаться на одном слое, например площадки компонентов поверхностного монтажа, или представлять собой трехмерные площадки со сквозным отверстием, имеющие цилиндрическую стенку вдоль оси Z (по вертикали) и плоскую область на каждом (горизонтальном) медном слое. Цилиндрическая стенка площадки формируется при сверлении и сквозной металлизации платы в процессе производства. В плоскости XY площадки могут иметь круглую, прямоугольную, восьмиугольную форму, форму прямоугольника со скругленными или срезанными углами либо произвольную форму. Площадки могут использоваться в проекте по отдельности как свободные площадки, но чаще они используются в редакторе библиотек печатных плат, где вместе с другими примитивами входят в состав посадочных мест компонентов.

Переходное отверстие, проходящее от верхнего слоя (красного) до нижнего слоя (синего), соединяющее их и также подключенное к одному из внутренних слоев питания (зеленому). 
Переходное отверстие, проходящее от верхнего слоя (красного) до нижнего слоя (синего), соединяющее их и также подключенное к одному из внутренних слоев питания (зеленому).

Переходное отверстие — это примитивный объект проекта. Переходные отверстия используются для создания вертикального электрического соединения между двумя или более электрическими слоями печатной платы. Переходные отверстия — трехмерные объекты, имеющие цилиндрическую стенку вдоль оси Z (по вертикали) и плоское кольцо на каждом (горизонтальном) медном слое. Цилиндрическая стенка переходного отверстия формируется при сверлении и сквозной металлизации платы в процессе производства. В плоскости XY переходные отверстия имеют круглую форму, как и круглые контактные площадки. Главное отличие переходного отверстия от контактной площадки заключается в том, что переходное отверстие может не только проходить через все слои платы (от верхнего до нижнего), но и соединять внешний слой с внутренним или два внутренних слоя между собой.

Переходные отверстия могут быть следующих типов:

  • Thru-Hole — переходное отверстие этого типа проходит от верхнего слоя до нижнего и позволяет подключаться ко всем внутренним сигнальным слоям.
  • Blind — переходное отверстие этого типа соединяет внешний слой платы с внутренним сигнальным слоем.
  • Buried — переходное отверстие этого типа соединяет один внутренний сигнальный слой с другим внутренним сигнальным слоем.

Типы переходных отверстий, которые можно использовать в проекте, задаются в Layer Stack Manager. Подробнее см. на странице Определение глухих, скрытых и микропереходных отверстий.

Определения контактных площадок и переходных отверстий также можно хранить в библиотеках шаблонов контактных площадок и переходных отверстий. Подробнее см. на странице Работа с шаблонами и библиотеками контактных площадок и переходных отверстий.

Шаблоны контактных площадок и переходных отверстий, не связанные с внешней библиотекой контактных площадок и переходных отверстий, хранятся внутри документа печатной платы, что ускоряет загрузку.

Эта функция доступна, если параметр PCB.Performance.PadViaTemplate.LoadingOptimization включен в диалоговом окне Расширенные настройки.

Редактор печатных плат использует концепцию «создания экземпляров переходных отверстий» — подход, при котором строится геометрия экземпляра переходного отверстия, а не его шаблона. Это повышает производительность, одновременно снижая потребление памяти и сокращая время построения сцены.

Эта функция находится на этапе открытого бета-тестирования и доступна, если параметр PCB.ViaInstancing включен в диалоговом окне Расширенные настройки.

Непосредственное размещение контактных площадок и переходных отверстий

Контактные площадки и переходные отверстия можно размещать как в редакторе печатных плат, так и в редакторе посадочных мест. Переходные отверстия обычно размещаются автоматически в ходе интерактивной или автоматической трассировки, но при необходимости их можно размещать вручную. Переходные отверстия, размещенные вручную, называются «свободными». После запуска команды размещения контактной площадки (Place » Pad) или переходного отверстия (Place » Via) курсор примет вид перекрестия и включится режим размещения.

  1. Установите курсор в нужное место, затем щелкните мышью или нажмите Enter, чтобы разместить контактную площадку или переходное отверстие.
  2. Продолжайте размещать контактные площадки или переходные отверстия либо щелкните правой кнопкой мыши или нажмите Esc, чтобы выйти из режима размещения.
Контактная площадка или переходное отверстие получит имя цепи, если разместить этот объект поверх объекта, уже подключенного к цепи.

Во время размещения нажмите клавишу Alt, чтобы ограничить перемещение горизонтальной или вертикальной осью в зависимости от начального направления движения.

Обычно переходные отверстия не размещают вручную: они размещаются автоматически в процессе интерактивной трассировки. Подробнее см. в разделе Размещение переходных отверстий при интерактивной трассировке.

Свободные контактные площадки на слое Multi-layer можно преобразовать в переходные отверстия. Свободная площадка — это площадка, не входящая в состав родительского объекта компонента. Преобразование свободных площадок в переходные отверстия может быть полезно при ручном преобразовании импортированных файлов Gerber обратно в формат печатной платы. Выберите в рабочей области все свободные площадки, которые требуется преобразовать, и в главном меню выберите команду Tools » Convert » Convert Selected Free Pads to Vias. Свободные площадки будут преобразованы в переходные отверстия с тем же размером отверстия. В качестве диаметра переходного отверстия будет использовано наибольшее значение среди всех доступных пар размеров X и Y площадки (соответствующих размерам площадки на разных слоях).

Переходные отверстия также можно преобразовать в свободные контактные площадки. Такое преобразование может быть полезно при импорте файлов PADS-PCB и PADS 2000, в которых переходные отверстия используются для подключения к слоям питания и земли. Это позволяет обеспечить правильное подключение к внутренним слоям питания с помощью редактируемых площадок. Выберите в рабочей области все переходные отверстия, которые требуется преобразовать, и в главном меню выберите команду Tools » Convert » Convert Selected Vias to Free Pads. Переходные отверстия будут преобразованы в свободные площадки того же типа (Simple, Top-Middle-Bottom или Full Stack) и с тем же размером отверстия. Диаметр переходного отверстия используется для задания размеров X и Y площадки на соответствующих слоях. Для формы площадки будет установлено значение Round.

Графическое редактирование

Графически можно изменить только положение контактных площадок и переходных отверстий; остальные их свойства таким способом не изменяются.

  • Чтобы переместить свободную площадку вместе с подключенными проводниками, нажмите на площадку и, удерживая кнопку мыши, переместите ее. Подключенные проводники останутся соединенными с площадкой при ее перемещении. Обратите внимание: площадка не будет перемещаться, если она принадлежит компоненту.
  • Чтобы переместить свободную контактную площадку, не перемещая подключенные к ней дорожки, в редакторе печатных плат или редакторе библиотек печатных плат выберите команду Edit » Move » Move, затем нажмите на площадку и, удерживая кнопку мыши, переместите ее.
  • Если выделить площадки component прямоугольной рамкой, они не будут выбраны, поскольку фактически являются дочерними объектами компонента. Чтобы выбрать только площадки, удерживайте Ctrl при создании рамки выделения мышью.
  • Если переходное отверстие перемещается вместе с дорожками, чтобы освободить место для трассировки или компонентов, повторная трассировка может оказаться эффективнее перемещения дорожек. В программе предусмотрена функция Loop Removal. Когда она включена, можно проложить новый маршрут, начав и закончив его в точках исходной трассы. Как только вы щелкнете правой кнопкой мыши, чтобы выйти из режима интерактивной трассировки, старая трасса (петля) будет удалена вместе со всеми избыточными переходными отверстиями.

Неграфическое редактирование через панель Properties

При этом способе редактирования для изменения свойств контактной площадки или переходного отверстия используется соответствующий режим панели Properties.

Тепловые барьеры контактных площадок и переходных отверстий

Поле Thermal Relief в области Pad Stack / Via Stack панели Properties содержит сводную информацию о текущей конфигурации теплового барьера. Например, Relief, 15mil, 10mil, 4, 90 означает, что:

  • применяется подключение через тепловой барьер;
  • ширина зазора составляет 15 мил;
  • ширина проводников теплового барьера составляет 10 мил;
  • угол поворота проводников теплового барьера составляет 90 градусов.

Когда флажок в поле Thermal Relief снят, тепловые барьеры контактных площадок и переходных отверстий при подключении к полигону имеют состояние rules-driven, то есть определяются применимыми правилами проектирования «Стиль подключения к полигону». Для отдельных контактных площадок конфигурацию теплового барьера можно настроить, включив соответствующий параметр Thermal Relief для нужного слоя. В этом случае тепловые барьеры считаются custom. Подробнее см. в разделе Настройка пользовательских тепловых барьеров.

Расширения паяльной маски и маски паяльной пасты

Паяльная маска автоматически создается для каждой контактной площадки и каждого переходного отверстия на слое Solder Mask. Паяльная маска задается в негативе: размещенные объекты определяют окна в слое паяльной маски. Маска паяльной пасты автоматически создается для каждой контактной площадки на слое Paste Mask. Форма, создаваемая на слое маски, повторяет форму контактной площадки или переходного отверстия с расширением или сужением на величину, заданную правилами проектирования Solder Mask Expansion и Paste Mask Expansion в редакторе печатных плат либо указанную на панели Properties.

Контактные площадки с отображением паяльной маски.
Контактные площадки с отображением паяльной маски.

При редактировании контактной площадки или переходного отверстия настройки расширения паяльной маски и маски паяльной пасты отображаются соответственно в областях Pad Stack и Solder Mask Expansion панели Properties. Эти настройки позволяют индивидуально управлять расширением маски для контактной площадки или переходного отверстия, однако обычно использовать их не требуется. Как правило, требования к маске паяльной пасты и паяльной маске проще задавать с помощью соответствующих правил проектирования в редакторе печатных плат. При таком подходе одно правило задает расширение маски для всех компонентов на плате, а при необходимости добавляются другие правила для конкретных случаев: например, для всех экземпляров определенного типа посадочного места на плате или для конкретной контактной площадки определенного компонента и т. д.

  

Чтобы задать расширение масок в правилах проектирования:

  1. Убедитесь, что в области Pad Stack панели Properties (для контактных площадок) в качестве Shape выбрана опция Rule Expansion и/или что в области Solder Mask Expansion панели Properties (для переходных отверстий) выбрана опция Rule.

  2. В редакторе печатных плат выберите Design » Rules в главном меню и проверьте правила проектирования категории Mask в диалоговом окне Редактор правил и ограничений печатной платы. Эти правила будут применяться при размещении посадочного места на печатной плате.

Чтобы переопределить правила расширения маски и задать расширение как атрибут контактной площадки или переходного отверстия, выберите Manual Expansion в качестве Shape в области Pad Stack панели Properties (для контактных площадок) и/или Manual в области Solder Mask Expansion панели Properties (для переходных отверстий) и введите требуемые значения.

Слой маски паяльной пасты для контактных площадок сквозного монтажа поддерживается в документах Draftsman и при выводе в форматы Gerber, Gerber X2, ODB++, IPC-2581, а также при печати печатной платы (PCB Print).
Для контактных площадок также можно вручную выбрать форму маски из стандартного набора предопределенных форм или создать собственную форму — подробнее.

Закрытие контактных площадок и переходных отверстий паяльной маской

Частичное или полное закрытие контактных площадок и переходных отверстий паяльной маской можно обеспечить, задав подходящее значение Solder Mask Expansion. Это ограничение расширения можно задать индивидуально для каждого объекта на панели Properties или с помощью соответствующих правил проектирования Solder Mask Expansion. Выбрав подходящее значение расширения, можно получить следующие результаты:

  • Чтобы частично закрыть контактную площадку или переходное отверстие маской — только металлическую область вокруг отверстия, — задайте отрицательное значение Expansion, при котором маска будет доходить до края отверстия.
  • Чтобы полностью закрыть контактную площадку или переходное отверстие маской — и металлическую область, и отверстие, — задайте отрицательное значение Expansion, модуль которого равен радиусу контактной площадки или переходного отверстия либо превышает его.
  • Чтобы закрыть маской все контактные площадки и переходные отверстия на одном слое, задайте подходящее значение Expansion и убедитесь, что область действия (Full Query) правила Solder Mask Expansion охватывает все контактные площадки и переходные отверстия на нужном слое.
  • Чтобы полностью закрыть маской все контактные площадки и переходные отверстия в проекте с переходными отверстиями разных размеров, задайте отрицательное значение Expansion, модуль которого равен наибольшему радиусу контактной площадки или переходного отверстия либо превышает его. При закрытии отдельной контактной площадки или переходного отверстия можно использовать расширение, заданное применимым правилом проектирования, либо переопределить правило и задать расширение непосредственно для этого объекта.

Контрольные точки

Related page: Назначение контрольных точек на плате

Программное обеспечение обеспечивает полную поддержку контрольных точек: контактные площадки (для сквозного или поверхностного монтажа) и переходные отверстия можно назначать контрольными точками для проверки платы на этапе изготовления и/или сборки. Для этого задаются соответствующие свойства контактной площадки или переходного отверстия: на каком этапе будет использоваться контрольная точка — при изготовлении или сборке — и с какой стороны платы она должна быть доступна. Эти свойства находятся в области Testpoint панели Свойства.

Чтобы упростить процесс и избавить пользователя от необходимости вручную задавать свойства контрольных точек, предусмотрено их автоматическое назначение на основе заданных правил проектирования с помощью Диспетчера контрольных точек (Tools » Testpoint Manager). В каждом случае при автоматическом назначении задаются соответствующие свойства контактной площадки или переходного отверстия.

Особенности контактных площадок

Обозначения контактных площадок

Каждой контактной площадке следует присвоить обозначение длиной до 20 буквенно-цифровых символов, обычно соответствующее номеру вывода компонента. Если обозначение исходной контактной площадки заканчивается цифрой, при размещении площадок оно автоматически увеличивается на единицу. Перед размещением измените обозначение первой контактной площадки на панели Свойства.

Чтобы задать буквенное приращение, например 1A, 1B, или числовое приращение, отличное от 1, используйте диалоговое окно Настройка вставки массива, которое открывается нажатием кнопки Paste Array в диалоговом окне Специальная вставка (Edit » Paste Special).

Функция вставки массива

Задав обозначение контактной площадки перед копированием в буфер обмена, можно использовать диалоговое окно Setup Paste Array для автоматического присвоения последовательных обозначений при размещении площадок. С помощью поля Text Increment в диалоговом окне Setup Paste Array можно размещать контактные площадки со следующими последовательностями обозначений:

  • Числовые (1, 3, 5)
  • Буквенные (A, B, C)
  • Буквенно-цифровые (A1 A2, 1A 1B, A1 B1 или 1A 2A и т. д.)

Для числового приращения задайте в поле Text Increment величину, на которую должно увеличиваться обозначение. Для буквенного приращения задайте в поле Text Increment букву, порядковый номер которой в алфавите соответствует требуемому шагу. Например, если исходная контактная площадка имеет обозначение 1A, задайте в поле A (первую букву алфавита), чтобы увеличивать обозначение на одну букву. Если задать в поле C (третью букву алфавита), обозначения будут иметь вид 1A, 1D (на три буквы после A), 1G и т. д.

Соединения перемычками

Соединения перемычками задают электрические соединения между контактными площадками компонентов, которые не разведены физически с помощью примитивов на печатной плате. Они особенно полезны на однослойных платах, где проволочная перемычка позволяет пересечь дорожки единственного физического слоя.

Контактным площадкам компонента можно назначить значение Jumper в панели Properties. Контактные площадки с одинаковым значением Jumper, принадлежащие одной электрической цепи, указывают системе, что между ними существует допустимое соединение, хотя физически они не соединены.

Соединения перемычками отображаются в редакторе печатных плат в виде изогнутых линий соединений. Средство проверки правил проектирования не будет сообщать о соединениях перемычками как о неразведенных цепях.

Особенности переходных отверстий

Настройка свойств переходных отверстий

Требования к слоям, которые соединяет каждый тип переходных отверстий (по оси Z), задаются на вкладке Via Types в диспетчере стека слоев, а размеры переходного отверстия определяются следующим образом:

Настройка правила проектирования Routing Via Style

Main page: Создание правил проектирования печатной платы, настройка области их действия и управление ими

Размеры переходных отверстий, размещаемых при интерактивной трассировке, трассировке ActiveRouting или автоматической трассировке, определяются применимым правилом проектирования Routing Via Style. Чтобы задавать переходные отверстия, на которые распространяется правило, можно использовать набор связанных с ними ключевых слов запросов в области действия правила (Where the Object Matches); они подробно описаны ниже.

При смене слоя во время трассировки программа определяет начальный и конечный слои перехода и выбирает допустимый тип переходного отверстия из Layer Stack Manager. Затем она определяет применимое правило проектирования Routing Via Style с наивысшим приоритетом и применяет настройки размеров из раздела Constraints этого правила к переходному отверстию, которое будет размещено.

Например, у вас может быть набор цепей DRAM_DATA, для которых требуются микропереходные отверстия (µVia) при переходе со слоя TopLayer на слой S2 и со слоя S2 на слой S3, а для всех остальных переходов между слоями — сквозное сверленое переходное отверстие (которое также отличается от отверстий, требуемых для других цепей). Для этого можно создать два правила проектирования Routing Via Style, действующих на эти цепи DRAM_DATA. Ниже приведен пример подходящего правила для µVia; наведите курсор на изображение, чтобы увидеть правило для сквозных переходных отверстий.

Область действия правил проектирования можно настроить для определенных типов переходных отверстий.
Область действия правил проектирования можно настроить для определенных типов переходных отверстий.

При размещении переходного отверстия в свободном пространстве программа не может применить правило стиля переходных отверстий во время размещения. В этом случае будет размещено переходное отверстие с параметрами по умолчанию.

Query Keywords

Для упрощения настройки области действия правил проектирования Routing Via Style доступны следующие ключевые слова запросов, относящиеся к переходным отверстиям:

Via Type Query Returns
IsVia Все объекты переходных отверстий независимо от их типа.
IsThruVia Все переходные отверстия, соединяющие верхний и нижний слои.
IsBlindVia Все переходные отверстия, начинающиеся на внешнем слое и заканчивающиеся на внутреннем слое, кроме µVia.
IsBuriedVia Все переходные отверстия, начинающиеся на внутреннем слое и заканчивающиеся на другом внутреннем слое, кроме µVia.
IsMicroVia Все переходные отверстия с включенной опцией µVia, соединяющие соседние слои.
IsSkipVia Все переходные отверстия с включенной опцией µVia, охватывающие 2 слоя.

Используйте функцию Mask в помощнике запросов Query Helper, чтобы найти доступные ключевые слова, относящиеся к переходным отверстиям. Выберите ключевое слово запроса в списке и нажмите F1, чтобы получить справку по нему.

Размещение переходных отверстий при интерактивной трассировке

При смене слоя во время интерактивной трассировки программа автоматически вставляет переходное отверстие. Выбор переходного отверстия зависит от следующих факторов:

  • Доступные типы переходных отверстий для соединения слоев, между которыми выполняется переход.
  • Применимое правило проектирования Routing Via Style для типа переходного отверстия, выбранного для этого перехода между слоями.

Чтобы сменить слой во время интерактивной трассировки:

  • Нажмите клавишу * на цифровой клавиатуре, чтобы перейти к следующему сигнальному слою.
  • Используйте сочетание клавиш Ctrl+Shift+WheelRoll для перехода вверх или вниз по слоям.

Размещение стека µVia при переходе со слоя L1 на слой L4. В режиме Interactive Routing панели Properties отображаются типы переходных отверстий, которые будут размещены; нажимайте 6 для перебора возможных стеков переходных отверстий; нажмите 8, чтобы отобразить список возможных стеков переходных отверстий.

Управление переходными отверстиями, размещаемыми при интерактивной трассировке

  • При смене слоев трассировки программа автоматически выбирает наиболее подходящий тип переходного отверстия для соединения этих слоев.

  • Если можно использовать несколько типов или комбинаций переходных отверстий (стеков переходных отверстий), нажимайте сочетание клавиш 6, чтобы интерактивно перебирать все стеки, доступные для этого перехода между слоями, или нажмите сочетание клавиш 8, чтобы отобразить список. Стеки переходных отверстий представлены в следующем порядке: µVia, µVia с пропуском слоя (Skip µVia), глухое переходное отверстие (Blind via), сквозное переходное отверстие (Thruhole via). Стеки переходных отверстий можно размещать, если переход выполняется более чем на один слой и заданы подходящие типы переходных отверстий. Предлагаемые типы переходных отверстий отображаются в строке состояния и на экранном индикаторе Heads Up, например [µVia 1:2, µVia 2:3, µVia 3:4], как показано на изображении выше.

  • Последний использованный стек переходных отверстий сохраняется как вариант по умолчанию для следующей трассируемой цепи. Стек переходных отверстий по умолчанию сохраняется только в течение текущего сеанса редактирования.

  • Размеры переходного отверстия задаются применимым правилом проектирования Routing Via Style; подходы к созданию подходящего правила Routing Via Style рассмотрены выше.

  • Чтобы интерактивно изменить размеры переходного отверстия при смене слоя, нажмите сочетание клавиш 4. Это позволит переключаться между режимами выбора размера переходного отверстия: Rule Minimum; Rule Preferred; Rule Maximum; User Choice; текущий режим выбора размера отображается на экранном индикаторе Heads Up и в строке состояния (как показано на изображении выше). Если выбран режим User Choice, нажмите Shift+V, чтобы открыть диалоговое окно Choose Via Sizes, и выберите предпочтительный размер переходного отверстия. Список доступных размеров в этом диалоговом окне формируется на основе переходных отверстий, уже используемых в проекте; их можно просмотреть в режиме Pad and Via Templates панели PCB.

    Если в применимом правиле проектирования Routing Via Style используется режим Template preferred, сочетание клавиш 4 позволяет перебирать включенные шаблоны переходных отверстий.

  • Вид сбоку предлагаемых типов переходных отверстий отображается в панели Properties, как показано выше.

  • Чтобы разместить переходное отверстие и продолжить трассировку на том же слое, нажмите сочетание клавиш 2.

  • Чтобы разместить переходное отверстие и приостановить трассировку этого соединения, нажмите сочетание клавиш / на цифровой клавиатуре.

  • Если трассируемая цепь должна подключаться к внутреннему слою питания, нажмите клавишу / на цифровой клавиатуре, чтобы разместить переходное отверстие, соединенное с соответствующим слоем питания. Это работает во всех режимах размещения дорожек, кроме режима Any Angle .

  • Во время трассировки нажмите Shift+F1, чтобы открыть меню всех сочетаний клавиш, доступных в текущей команде.

Работа со стеками переходных отверстий

  • С переходными отверстиями, образующими непрерывное соединение в стеке, можно работать как с одним переходным отверстием: используйте click and drag на стеке, чтобы переместить все отверстия вместе с подключёнными дорожками.

  • Щёлкните один раз, чтобы выбрать самое верхнее переходное отверстие в стеке. Если не перемещать мышь, последующие одиночные щелчки будут поочерёдно выбирать остальные переходные отверстия в стеке.

    Если на странице «Редактор PCB — Общие» диалогового окна Preferences включена опция Display popup selection dialog, при щелчке по стеку переходных отверстий откроется всплывающее окно выбора, в котором можно выбрать нужное отверстие.

  • Ctrl+Click and drag, чтобы переместить только выбранное переходное отверстие вместе с подключёнными дорожками.

  • Чтобы выбрать все переходные отверстия в стеке, щёлкните один раз для выбора одного из них, затем нажмите Tab, чтобы расширить выделение на все переходные отверстия этого стека.

Настройка отображения переходных отверстий

Для удобства работы с переходными отверстиями предусмотрен ряд настроек отображения.

Цвета переходных отверстий

Цвета переходных отверстий настраиваются на панели View Configuration. Медное кольцо переходного отверстия отображается цветом, заданным текущей настройкой Multi-Layer в разделе Layers . Цвет отверстия задаётся настройкой Via Holes в разделе System Colors . Также можно отключить отображение отверстий, переключив  для нужных настроек.

На первом изображении показано сквозное переходное отверстие. На втором — глухое переходное отверстие; его отверстие отображается цветами начального и конечного слоёв.
На первом изображении показано сквозное переходное отверстие. На втором — глухое переходное отверстие; его отверстие отображается цветами начального и конечного слоёв.

Переходные отверстия и паяльная маска

По умолчанию в редакторе PCB слой Multi-Layer всегда отображается поверх остальных слоёв. Это может затруднять точный просмотр содержимого слоёв паяльной маски, особенно если для контактной площадки или переходного отверстия задано отрицательное расширение маски: содержимое слоя паяльной маски будет скрыто под многослойным объектом. Это можно исправить, изменив порядок отрисовки слоёв на странице «Редактор PCB — Отображение» диалогового окна Preferences. Настройте отрисовку текущего слоя поверх остальных.

Если изменить порядок отрисовки так, чтобы текущий слой отображался сверху, и сделать Top Solder текущим слоем, окна паяльной маски будут отображаться корректно, как показано на изображении ниже. Зелёные стрелки показывают размеры окна паяльной маски: слева — для переходного отверстия, в центре — для контактной площадки с уменьшенным окном маски, справа — для контактной площадки с увеличенным окном.

Настройте отображение так, чтобы можно было рассмотреть окна паяльной маски.
Настройте отображение так, чтобы можно было рассмотреть окна паяльной маски.

Отображение стеков переходных отверстий

Для стеков переходных отверстий отображаемые числа обозначают начальный и конечный слои всех отверстий в стеке. Наведите курсор на изображение ниже, чтобы показать переходные отверстия в 3D; справа на изображении расположен стек из трёх переходных отверстий.

В переходных отверстиях можно отображать номера охватываемых слоёв. Наведите курсор, чтобы показать переходные отверстия в 3D.В переходных отверстиях можно отображать номера охватываемых слоёв. Наведите курсор, чтобы показать переходные отверстия в 3D.

Другие настройки отображения переходных отверстий

Чтобы отображать имя цепи переходного отверстия и номера слоёв в его диапазоне, включите опции Via Nets и Via Span соответственно в области Additional Options на вкладке View Options панели View Configuration.

Просмотр отверстий контактных площадок и переходных отверстий

В режиме Hole Size Editor панели PCB её три основные области отображают следующие данные (сверху вниз):

  • Общие фильтры по типам отверстий и их состоянию, а также подраздел с парами слоёв сверления, заданными для платы.
  • Unique Holes, объединённые в группы по размеру и форме.
  • Отдельные Pads/Vias, входящие в каждую группу объектов отверстий.

Разделы панели показывают совокупный результат фильтрации по типам, формам и состоянию отверстий.
Разделы панели показывают совокупный результат фильтрации по типам, формам и состоянию отверстий.

Группы отверстий можно редактировать целиком в области Unique Holes панели, вводя значения в ячейки соответствующих столбцов. Чтобы изменить текущий размер отверстий контактных площадок и переходных отверстий, введите числовое значение в столбце Hole Size .

Изменение размера отверстия для выбранной группы из шести отверстий с одинаковыми параметрами.
Изменение размера отверстия для выбранной группы из шести отверстий с одинаковыми параметрами.

Также можно изменить соответствующие значения Hole Length, Hole Type и Plated для отверстий, к которым они применимы.

Изменение типа отверстия для выбранной группы из шести отверстий с одинаковыми параметрами.
Изменение типа отверстия для выбранной группы из шести отверстий с одинаковыми параметрами.

Отдельные объекты контактных площадок и переходных отверстий, принадлежащие выбранной группе отверстий, перечислены в нижнем разделе Pad/Via панели PCB. Щёлкните правой кнопкой мыши по объекту в списке и выберите Properties (или дважды щёлкните непосредственно по записи), чтобы открыть панель Properties в соответствующем режиме для этого примитива и просмотреть или изменить его свойства.

Чтобы обновить панель PCB в режиме Hole Size Editor актуальными данными об обозначениях сверления из PCB, щёлкните правой кнопкой мыши в одной из областей панели в этом режиме и выберите команду Refresh.

Данные об обозначениях сверления автоматически обновляются при сохранении документа PCB и при формировании любых выходных данных, содержащих эти сведения.

Для повышения производительности данные об обозначениях сверления не обновляются автоматически на панели PCB. Возможность ручного обновления этих данных доступна, когда опция PCB.LiveDrillSymbols отключена в диалоговом окне Advanced Settings.

Поддержка обратного высверливания

Режим Hole Size Editor панели PCB также можно использовать для просмотра контактных площадок и переходных отверстий, предназначенных для обратного высверливания. Пары слоёв обратного высверливания отображаются в списке Layer Pairs с добавлением текста [BD].

При выборе размера отверстия обратного высверливания значение Kind объектов отображается как Backdrill. Используйте эту возможность для быстрого поиска и просмотра отверстий с обратным высверливанием. Обратите внимание: настройки обратного высверливания нельзя редактировать на панели.

Отчёт об обратном высверливании

Чтобы сформировать отчёт обо всех операциях обратного высверливания, щёлкните правой кнопкой мыши в списке Unique Holes и выберите Backdrill Report в контекстном меню.

В отчёте подробно описана каждая операция обратного высверливания, включая расположение, диаметр сверла и глубину сверления.

Поддержка цековки и зенковки

Режим Hole Size Editor панели PCB также можно использовать для просмотра контактных площадок с включённой цековкой или зенковкой отверстий. Если в проекте PCB есть контактные площадки с цековкой или зенковкой, включённой для одной или обеих сторон, соответствующие группы Counterholes Top и/или Counterholes Bottom отображаются в списке Layer Pairs. Столбцы Counterhole Depth и Counterhole Angle можно отобразить в Unique Holes области панели. Обратите внимание, что параметры цековки нельзя редактировать в этой панели.

Информация о цековках в проекте отображается в панели PCB в режиме Hole Size Editor.
Информация о цековках в проекте отображается в панели PCB в режиме Hole Size Editor.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents