Altium Designer Documentation

Управление проектами в Altium Designer

Информация на этой странице на данный момент не обновлена в соответствии с интерфейсом и функциональными возможностями Altium Designer 18.0. Перейдите на страницу для версии 19.0 для получения актуальной информации.

Начальной точкой любого устройства, создаваемого в Altium Designer, является проект. Проект Altium Designer объединяет набор документов, которые, в конечном итоге, определяют то, что вы хотите создать. Например, документы схемы и платы в проекте платы составляют набор файлов, необходимых для изготовления печатной платы, а документ схемы и файл Hardware Description Language в проекте ПЛИС составляют набор файлов, необходимых для программирования ПЛИС.

Набор документов, которые составляют проект, может быть собран в любом доступном ресурсе, локальном для компьютера или нет. Изменения над каким-либо отдельным документом проекта синхронизируются с другими документами при компиляции проекта, что позволяет передавать изменения между различными аспектами проекта, например, между схемой и платой.

Проект Altium Designer и его файл проекта (*.Prjxxx, где xxx обозначает тип проекта) определяют связь между входящими в этот проект документами, а также сохраняют настройки и данные на уровне проекта. Файл проекта и типы его документов зависят от типа создаваемого проекта.

Файлы проекта

Altium Designer поддерживает ряд проектов различных типов:

  • PCB Project (*.PrjPcb) – набор проектных документов, необходимых для изготовления печатной платы.
  • Integrated Library (*.LibPkg) – набор проектных документов, необходимых для создания интегрированной библиотеки (*.IntLib).
  • Script Project (*.PrjScr) – набор проектных документов, которые хранят один или множество скриптов Altium Designer.
  • FPGA Project (*.PrjFpg) – набор проектных документов, которые могут быть обработаны для программирования ПЛИС.
  • Embedded Project (*.PrjEmb) – набор проектных документов, необходимых для создания программного приложения, которое может быть встроено в электронное устройство с исполняемым это приложение процессором.
  • Core Project (*.PrjCor) – набор проектных документов, необходимых для создания EDIF-представления (модели) функционального компонента, который может быть встроен в ПЛИС.

Подробнее о типах проектов

PCB Project (Проект печатной платы)

В проекте печатной платы осуществляется ввод электрической схемы, которая формируется из компонентов, размещаемых из библиотек и связываемых между собой.

После этого проект передается в редактор плат, где каждый компонент представлен посадочным местом, а цепи становятся линиями соединения между точками. Здесь задается форма печатной платы, а также структура ее слоев. Правила проектирования задают требования к конструкции, такие как ширина и зазоры трасс. Компоненты размещаются в пределах контура платы, а линии соединения затем заменяются трассами, вручную или автоматически.

По завершении проекта формируется набор выходных файлов, которые можно использовать для изготовления печатной платы, настройки сборочного станка и т.д.

Altium Designer также поддерживает концепцию проектов, которыми можно полностью управлять в Altium Vault. Проект любого типа можно создать как управляемый проект (или преобразовать в такой проект), который хранится в надежном репозитории в системе контроля версий Altium Vault (лицензируемый на уровне Enterprise). Этот подход в значительной степени упрощает процесс управления хранением проектов и совместное проектирование.

► Узнайте подробнее: Управляемые проекты.

Integrated Library (Интегрированная библиотека)

В проекте интегрированной библиотеки, в библиотеке SchLib создаются схемные символы, а ссылки задают соответствующие модели для других областей проектирования. Моделями, на которые указывают ссылки, могут быть посадочные места, математические модели, модели целостности сигналов и трехмерные механические модели.

Файлы, которые содержат модели (PCBLib и т.д.) добавляются в пакет интегрированной библиотеки (*.LibPkg), либо задаются пути поиска для определения их места. Исходные библиотеки схемных символов и требуемые модели затем компилируются в единый файл (*.IntLib), который называется интегрированной библиотекой.

Компоненты также могут храниться в Altium Vault как в корпоративном решении для управления данными о компонентах. Vault обеспечивает надежное хранение проектных данных, наряду с дополнительными возможностями, такими как управление жизненным циклом и актуальной информации о цепочке поставок.

► Узнайте подробнее: Управление компонентами Vault.

Script Project (Проект скрипта)

Скрипт содержит набор инструкций (автоматизированных команд), которые интерпретируются и исполняются в Altium Designer. Написание и отладка скриптов осуществляется в среде соответствующего редактора.

Существует два типа скриптов: блок скрипта (Script Unit) и форма скрипта (Script Form). Блок скрипта может использовать интерфейс API платформы DXP для изменения объектов в документах проекта и управления ими. Форма скрипта содержит в себе элементы управления интерфейса и использует API для формирования диалоговых окон, которые работают в активных проектных документах.

FPGA Project (Проект ПЛИС)

Проект ПЛИС формируется в редакторе схем и/или кода HDL (VHDL или Verilog). В проект добавляются файлы ограничений для определения требований проекта, такие как целевое программируемое устройство, внутреннее отображение цепей в устройства, требования к частоте цепей, назначение тактовых выводов и т.д.

Синтез проекта транслирует исходные данные в набор вентилей низкого уровня в стандартный файл формата EDIF. Инструментарий производителя устройства затем обрабатывает данные EDIF и пытается разместить и трассировать проект таким образом, чтобы встроить данные в указанное целевое устройство, и формирует программный файл устройства. Проект затем может быть применен в целевом устройстве, смонтированном в подходящей отладочной плате, после чего осуществляется проверка и отладка проекта.

Embedded Project (Встроенный проект)

Для встроенного проекта, исходный проект формируется на языке С и/или языке ассемблера. По завершении написания кода, все исходные файлы компилируются в файлы языка ассемблера, и системный ассемблер преобразует их в машинный язык низкого уровня (объектный код).

Объектные файлы затем связываются между собой и отображаются в выделенное пространство в оперативной памяти, формируя единый целевой выходной файл для целевого процессора.

Core Project (Проект логического ядра)

В проекте логического ядра функциональный компонент формируется в редакторе схем и/или кода HDL (VHDL или Verilog). В проект добавляются файлы ограничений для определения поддерживаемого целевого устройства (или устройств) ПЛИС.

Синтез проекта транслирует исходные данные в набор вентилей низкого уровня в стандартный формат файла EDIF. Формируется символ компонента для его представления на листе схемы, который затем ссылается на свое описание EDIF.

Открытие проекта

Хранение и последующее открытие проектов Altium Designer доступно во множестве расположений. Соответствующие команды меню для открытия проекта зависят от типа и места хранения проекта.

На диске

Чтобы открыть существующий проект Altium Designer, выберите команду File » Open Project из главного меню и перейдите к файлу проекта (*.Prjxxx) в диалоговом окне Choose Project to Open.

Установка Altium Designer включает в себя несколько примеров проектов, которые находятся в папке Examples в области документов Windows – например, для Altium Designer, установленного в системе Windows® 7, перейдите в C:\Users\Public\Documents\Altium\xxx\Examples, где xxx обозначает версию Altium Designer.

В проектном репозитории

Чтобы открыть проект из репозитория, выберите команду File » Check Out из главного меню. Будет открыто диалоговое окно Check Out, где вы можете выбрать один из доступных репозиториев (верхнее выпадающее меню) и указать папку проекта для локального извлечения, т.е. создать локальную рабочую копию. Создание и подключение проектных репозиториев осуществляется на странице Data Management – Design Repositories диалогового окна Preferences (DXP » Preferences).

В Altium Vault как управляемый проект

Чтобы открыть управляемый проект из Altium Vault, выберите команду File » Open Managed Project и затем выберите существующий проект в диалоговом окне Open Managed Project – используйте параметры Advanced Mode диалогового окна для определения альтернативных репозиториев и путей хранилища. Подключение к Altium Vault задается на странице Data Management – Vaults диалогового окна Preferences (DXP » Preferences).

Altium Vault предоставляет функциональные возможности, необходимые для хранения управляемых проектов и работы с ними, когда доступна серверная лицензия Enterprise.

► Перейдите на страницу Лицензирование Altium Vault для получения более подробной информации.

Настройки проекта

Набор настроек проекта будет зависеть от типа проекта. Настройки проекта задаются в диалоговом окне Options for Project. Вы можете открыть его с помощью команды Project » Project Options главного меню или щелкнуть ПКМ по имени проекта в панели Projects и выбрать команду Project Options контекстного меню.

Настройки проекта задаются в диалоговом окне Options for Project. Нажмите F1 в какой-либо вкладке, чтобы получить справку по ней.
Настройки проекта задаются в диалоговом окне Options for Project. Нажмите F1 в какой-либо вкладке, чтобы получить справку по ней.

Подробнее о настройках проекта

Настройки, заданные в диалоговом окне Options for Project, сохраняются в файле проекта (*.PrjPcb). Настройки проекта, которые задаются в других диалоговых окнах и сохраняются в файле проекта:

  • Настройки аннотирования схемы.
  • Настройки выходных документов, таких как отчеты, распечатки, файлы Gerber и т.д. Обратите внимание, что здесь идет речь о настройках выходных документов, доступных через меню редакторов схем и плат, а не о настройках, определяемых в файле OutJob.

Панель Projects

Панель Projects является центром управления для работы с проектами и их документами в Altium Designer. Чтобы открыть панель, используйте команду View » Panels » Projects или нажмите кнопку Panels в нижней правой части окна приложения и выберите Projects.

Содержимое панели Projects отражает логическую структуру открытого проекта.
Содержимое панели Projects отражает логическую структуру открытого проекта.

Решение большинства связанных с проектами задач доступно из панели Projects, которая в сочетании с панелями Files и Storage Manager обеспечивает полное управление проектами всех типов и из любых источников.

► Чтобы узнать больше о панели Projects, в том числе о настройках отображения и иконках, перейдите на страницу Панель Projects.

Project Insight – это средство навигации, доступное из панели Projects, которое позволяет осуществлять графический предварительный просмотр документов текущего проекта – см. Project Insight.

Пространство проектирования – Design Workspace

В Altium Designer вы можете открывать и редактировать множество проектов и, если необходимо, сохранять набор проектов в качестве пространства проектирования – Design Workspace.

В частности, это может быть полезно, если проекты связаны между собой, например, проект платы, который включает в себя встроенный проект или проект ПЛИС. В этом случае, эти проекты могут содержать в себе встроенное программное/аппаратное обеспечение, которое будет загружено в устройство в проекте печатной платы. Создание пространства Design Workspace, которое включает в себя все связанные проекты, позволяет открывать, сохранять и управлять множеством проектов как единой сущностью.

Подробнее о пространствах проектирования Design Workspace

  • В панели Projects самая верхняя запись отображает текущее пространство Design Workspace – либо по умолчанию, либо то, которое вы создали или открыли.
  • Чтобы сохранить открытый набор проектов в качестве пространства проектирования Design Workspace или открыть существующее пространство (*.DsnWrk), нажмите кнопку в верхней части панели Projects или используйте команды меню File.
  • При открытии другого пространства, текущее пространство необходимо закрыть. У вас будет запрошено сохранение любых несохраненных документов, проектов и изменений текущего пространства.
  • Чтобы добавить проекты в пространство Design Workspace, скомпилируйте все проекты пространства или сохраните пространство под другим именем или другим названием, выберите соответствующую команду из выпадающего меню кнопки .
  • Текущее пространство Design Workspace и его проекты, а также входящие в их состав документы можно графически отобразить на виде Workspace страницы Home page Altium Designer. Ее можно открыть с помощью команды View » Workspace главного меню, нажатием » Workspace в панели Projects или с помощью сочетания клавиш Ctrl + `.

Работа с набором связанных проектов как с пространством проектирования Design Workspace.
Работа с набором связанных проектов как с пространством проектирования Design Workspace.

Создание нового проекта

Создать новый проект Altium Designer можно разными способами, из различных расположений:

Диалоговое окно New Project

Выберите команду File » New » Project из главного меню и выберите тип проекта, шаблон и настройки хранения в диалоговом окне New Project.

► Чтобы узнать подробнее о параметрах диалогового окна, перейдите на страницу New Project.

Такой подход обеспечивает наиболее полную настройку при создании нового проекта, которая включает в себя возможность указания имени проекта и его папки, будет ли проект добавлен в проектный репозиторий под управлением системы контроля версий или он будет находить в Altium Vault в качестве управляемого проекта.

Меню панели Projects

Если в панели Projects нет открытых проектов, щелкните ПКМ внутри панели (или нажмите кнопку ) и выберите Add New Project и тип нового проекта из контекстного меню.

При создании нового проекта одним из обозначенных здесь методов запись соответствующего проекта появится в панели Projects. Документы, которые являются частью этого проекта, и новые добавляемые документы будут появляться в подпапках (группах) в соответствии с назначением и/или типом этих документов.

Новый файл проекта, который не был добавлен через диалоговое окно New Project, существует только в оперативной памяти. Используйте команду File » Save Project или File » Save Project As, чтобы сохранить новый проект с подходящим именем в нужном расположении.

Панель Files

Выберите подходящую запись в одном из разделов панели Files. Откройте панель с помощью команды View » Workspace Panels » System » Files или нажмите кнопку System в правой нижней части окна приложения и выберите Files.

Разделы панели включают в себя:

  • New — Blank Project (xxx): создает базовый проект с настройками по умолчанию.
  • New from existing file — Choose Project: создает переименованную копию указанного существующего проекта.
  • New from template — xxx Projects: открывает диалоговое окно New Project (см. выше) для предварительной настройки проекта и целевого места хранения.

Обратите внимание, что имена файлов проектов FPGA, Core и Embedded не должны включать в себя пробелы.

Веб-интерфейс Vault (управляемый проект)

Для создания нового управляемого проекта (под управлением системы контроля версий) непосредственно в Enterprise Altium Vault откройте веб-интерфейс Vault и нажмите (или ссылку 'Add a Project') на вкладке PROJECTS.

Созданный документ проекта можно открыть в Altium Designer следующими способами:

  • выберите опцию Open Managed Project (), связанную с проектом на вкладке PROJECTS в веб-интерфейсе Vault, затем нажмите кнопку на странице проекта.
  • используйте команду File » Open Managed Project в Altium Designer, затем выберите новый проект из списка в диалоговом окне Open Managed Project.

Работа с проектными документами

После того, как проект создан и сохранен в нужное расположение, можно добавлять проектные документы в активный проект, редактировать их и удалять из проекта.

Эти действия можно осуществить в панели Projects, которая отражает структуру проекта и входящих в него проектных документов. Большинство команд, необходимых для работы с проектными документами, доступны в контекстных меню панели.

► Для получения более подробной информации перейдите на страницу панели Projects.

Обратите внимание, что представление документов в панели Projects не отражает того, как документы сохранены на жестком диске или где-либо еще. Содержимое панели следует рассматривать как логическое представление проекта, где физическое расположение и организация хранения файлов документов (и ее тип) зависит от вас – документы могут быть сохранены в папке на локальном компьютере или в локальной сети, в локальном или удаленном репозитории под управлением системы контроля версий или быть управляемыми проектами в Altium Vault.

При работе с проектными документами в Altium Designer, панель Projects с помощью иконок состояния каждого проектного документа и файла проекта отображает, какие файлы документов изменены, сохранены или скрыты. Иконки документов и их значения приведены ниже:

[пусто] Закрыт – документ не открыт.
Открыт – Документ открыт в качестве вкладки в главном окне.
Скрыт – документ скрыт (открыт, но не отображается в рабочей области).
Изменен – документ открыт и изменен (еще не сохранен).
Изменен (проект) – иконка появляется рядом с главным документом проекта, когда его структура изменена (еще не сохранен).

Измененный документ или проект, который еще не сохранен, также отличается символом звездочки рядом со своей записью в панели. Измененные документы также обозначаются звездочкой внутри своих вкладок в главном окне.

Добавление и удаление проектного документа

Проще всего добавить новый или существующий проектный документ в проект, щелкнув ПКМ по имени проекта в панели Projects и выбрав команду Add New to Project или Add Existing to Project соответственно из контекстного меню. Эти команды также доступны через кнопку .

Добавление документа определенного типа в проект.
Добавление документа определенного типа в проект.

В проект также можно добавить другие относящиеся к проекту документы, такие как файлы Word®, PDF, электронные таблицы и т.д. Для этого выберите команду Add Existing to Project и задайте в выпадающем меню диалогового окна Choose Document to Add тип файлов All Files (*.*), чтобы стали доступными файлы всех типов.

Чтобы удалить документ из структуры проекта, щелкните ПКМ по его названию в панели Projects и выберите команду Remove from Project контекстного меню, либо выберите эту команду, выделив документ и нажав кнопку . Обратите внимание, что этот процесс удаляет лишь ссылку на этот документ из проекта, но не удаляет сам документ.

Изменение порядка документов проекта

Документы в панели Projects автоматически группируются в логические группы, или "папки", такие как исходные документы (схемы, платы и т.д.), документы настроек (определения жгутов, файлы Outjob и т.д.) и, в случае иерархического проекта, документы схем верхнего уровня. Документы в каждой их этих групп отображаются по умолчанию в том порядке, в котором они были добавлены, но внутри группы их порядок можно изменять перетаскиванием мышью.

В случае нового иерархического проекта, взаимосвязь между документами будет отображена в панели после компиляции проекта. Обратите внимание, что эту взаимосвязь нельзя определить с помощью перетаскивания документов схем мышью, поскольку соединения между листами и иерархия проекта, по сути, определяются символами листов (Sheet Symbol) и портами (Port).

► Для получения более подробной информации об иерархии проекта перейдите на страницу Создание связности и в справку о разделе Net Identifier Scope вкладки Options диалогового окна Project Options.

Использование документов во множестве проектов

Поскольку проект Altium Designer определяет и сохраняет ссылки на файлы документов, может быть создано любое количество проектов, которые ссылаются на одни и те же файлы документов.

Хотя такой способ повторного использования проектных документов может быть удобен (например, стандартная схема источника питания добавляется в несколько проектов), такой подход не является рекомендуемым, поскольку изменение в этих документах повлияет на всех проекты, которые ссылаются на них. Намного лучшим подходом повторного использования проектных данных является использование управляемых листов Managed Sheets.

► Для получения более подробной информации о повторном использовании проектных документов и управляемых листах перейдите на страницу Управляемые листы в разделе Повторное использование проектных данных.

Сохранение документа под новым именем

Проектный документ можно сохранить под новым именем с помощью команды File » Save As, которая создает копию файла документа под указанным новым именем. Эта команда доступна, когда документ открыт.

Этот процесс автоматически добавляет копию нового документа в активный проект вместо существующего (исходного) документа. Таким образом, команда выполняет роль переименования документа, но изначальный документ остается неизменным, и он заменяется в проекте новой переименованной копией. Если открытый документ не является частью какого-либо проекта (является свободным документом), то в редакторе будет просто открыто новая копия вместо изначального документа.

Если нужно просто сделать резервную копию документа, используйте команду File » Save Copy As. Будет создана копия файла документа с новым именем, без изменения проекта.

Сохранение документа проекта под новым именем

Так же, как и в процессе, описанном выше, сохранение документа проекта под новым именем создает копию файла проекта и соответствующим образом обновляет его ссылки – новая копия проекта будет ссылаться на те же самые проектные документы, что и изначальный проект.

Этот процесс не создает копию всего проекта, даже если файл проекта сохраняется в другом месте. Для создания полной копии проекта используйте операционную систему, чтобы скопировать директорию проекта в новое расположение, или средство Project Packager Altium Designer (см. ниже).

Панель Storage Manager

Чтобы обеспечить лучший контроль над файлами документов в проекте, в Altium Designer присутствует панель Storage Manager. Панель Storage Manager отображает вид файлов/папок документов активного проекта и включает в себя подробную информацию о каждом документе, в том числе его состояние в системе управления версиями и, когда документ выделен, его историю изменений.

Чтобы открыть панель Storage Manager, нажмите кнопку System в нижней части окна приложения и выберите пункт Storage Manager либо используйте команду View » Workspace Panels » System » Storage Manager из главного меню.

Панель Storage Manager предоставляет доступ к командам и опциям для управления проектными документами из одного расположения. Используйте контекстное меню, чтобы осуществить операции, относящиеся к контролю версий (фиксация, обновление и т.д.), и стандартные действия по управлению файлами (открытие, копирование, переименование и т.д.). В нижней части панели отображается временная шкала выделенного документа, и контекстное меню здесь предлагает расширенные действия, такие как сравнение версий файла и возврат к предыдущей версии документа.

Некоторые возможности, доступные в панели Storage Manager, также доступны и в других панелях, например в панели Projects (управление файлами и контроль версий), и в диалоговом окне Local History (сравнение версий) – Project » Local History » Show Local History. Тем не менее, панель панель Storage Manager объединяет эти и многие другие возможности в одно расположение для управления файлами проектных документов.

► Чтобы получить более подробную информацию, перейдите на страницу Storage Manager

Средство Project Packager

Средство Project Packager применимо в ситуациях, когда необходимо создать резервную копию всего проекта или передать его в другое расположение.

Средство в формате мастера архивирует весь проект Altium Designer, дерево проектов или пространство Design Workspace (и входящие в него проекты) в указанное расположение в качестве единого архива с отметкой времени. Открытие мастера осуществляется из главного меню (Project » Project Packager) или с помощью команды Project Packager контекстного меню проекта.

Используйте средство Project Packager для передачи всего проекта (или дерева проектов) и связанных документов в zip-файл с отметкой времени.
Используйте средство Project Packager для передачи всего проекта (или дерева проектов) и связанных документов в zip-файл с отметкой времени.

Мастер предлагает параметры для определения:

  • Где необходимо сохранить архив.
  • Как необходимо обработать пути к директориям файлов.
  • Должны ли быть включены выходные, системные или внешние файлы.
  • Должна ли быть включена история проекта.
  • Какие связанные с проектом документы необходимо включать в конечный архив.

Смотрите также

Навигация по проекту

Автоматическое сохранение и локальная история

Управление версиями и проектные репозитории

Варианты проекта

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: