在Altium Designer中定义线束布线图

Created: March 28, 2023 | Updated: March 28, 2023

上级页面:线束设计

请注意,Altium Designer Standard Subscription不支持线束设计功能。

新建一个线束接线图文档

Harness Wiring Diagram(.WirDoc)指定了线束中包含的各个导线接头。请右键单击项目,然后从上下文菜单中选择Add New to Project » Harness Wiring Diagram(或使用主菜单中的File » New » Harness Wiring Diagram命令),将该文档添加到项目面板中的Harness项目中。

从Projects面板右键菜单向Harness项目中添加线束接线图文档。 从Projects面板右键菜单向Harness项目中添加线束接线图文档。

一个新的空白文档将打开。接着,请使用主菜单中的File » Save As命令保存新的线束接线图文档。

您还可以以ASCII格式保存Harness Design Wiring Diagram文档(*.WirDoc);此举将便于您共享文档。使用File » Save As命令,然后从打开的Save as对话框中的Save as type下拉菜单中选择Harness Wiring ascii(*.WirDoc)。

使用File » Save命令保存ASCII Wiring Diagram时,File Format对话框将打开并提示您所使用的格式为ASCII。在对话框中选择ASCII Version,继续使用该格式。

您可以在Document Options模式(当文档设计区中没有选择任何对象时,该模式处于活动状态)下的Properties面板中,对接线图文档选项进行配置。主要设置是:

  • 在面板General选项卡的General区域中——选择适用于接线图文档及其图形元素的测量单位,并设置栅格以便于放置。Altium Designer提供三种栅格类型:用于导航的可见栅格、用于放置的捕捉栅格,以及用于帮助创建连接的捕捉距离。
  • 在面板General选项卡的Page Options区域中——配置文档图纸大小和标题栏,或者从可用原理图模板(*.SchDot)中选择。

Properties面板的Document Options模式(General和Parameters选项卡) Properties面板的Document Options模式(General和Parameters选项卡) Properties面板的Document Options模式(General和Parameters选项卡)

同步多板和线束项目

当Multi-board设计项目包含线束项目时,您可以从Multi-board原理图文档数据同步线束接线图。如需这样做,请从主菜单中选择Design » Import Changes From <Multi-board Project>命令。

如果Multi-board原理图文档包含多个线束连接定义,则Select Harness Definition对话框将打开。请指定与当前线束项目有关的定义。

Select Harness Definition对话框 Select Harness Definition对话框

此时,Engineering Change Order将打开并显示Multi-board原理图中定义的、将构成线束接线图基础的线束连接器部件和线束网络。

Engineering Change Order对话框 Engineering Change Order对话框

执行更改(Execute Changes)后,来自Multi-board原理图的数据将被导入到线束接线图。连接器将出现在接线图上(最初出现在任意位置上),并通过其符号表示。

导入后,连接器在接线图上的初始位置。您可以根据需要更改其位置。 导入后,连接器在接线图上的初始位置。您可以根据需要更改其位置。

图中将显示管脚之间的网络线,以表示Multi-board原理图中定义的逻辑连接。请注意,此阶段的设计中尚不存在物理导线。

使用元器件

将元器件拖到所需位置,使用Spacebar将元器件旋转90度,然后分别使用X和Y键水平和垂直翻转元器件。

移动元器件后的线束接线图。 移动元器件后的线束接线图。

除了从Multi-board原理图文档中同步线束连接器外,您还可以手动将元器件放入接线图中。通过手动放置,您不仅可以将连接器放入独立线束项目(不属于Multi-board项目的一部分)中,而且还可以将其他元器件放入Multi-board项目的接线图中。

使用Components面板放置所需元器件的符号。元器件放置过程与原理图编辑器中的放置过程相似。如需了解更多信息,请参阅Searching for & Placing Components页面的Components Panel部分。

请注意,由于缺少用于驱动手动添加元器件的高级别逻辑设计,因此不会显示手动添加元器件的网络线。

单击设计区中的连接器以在Properties面板中显示其选项。

显示General、Pins、Crimps和Associated Parts选项卡的Properties面板Harness Component模式 显示General、Pins、Crimps和Associated Parts选项卡的Properties面板Harness Component模式

在接线图中创建连接

通过从主菜单中选择Place » Harness Wire命令或从编辑器Active Bar中选择Harness Wire命令,将物理导线放置在接线图文档中。

选择命令后,单击连接器符号的管脚(当光标停在管脚连接点上方时,会出现一个红色十字)以放置导线起点,然后单击另一个管脚以放置导线另一端点。右键单击,退出命令并确认导线放置完毕,或单击另一条导线的起点。

Javascript

放置一条代表物理连接的导线

放置导线时,按Shift+Spacebar在放置模式之间循环。放置模式规定了放置导线时的转角创建方式以及导线放置角度。在90 Degree或45 Degree模式(被称为真正交模式)下,按Spacebar,在Start和End子模式之间循环。

请注意,上图中连接P1[1]和P2[1]的网络线消失了,但是连接P2[1]和P3[1]的网络线仍然存在,这是因为尚未使用导线完成该连接。

放置并选择后,您可以拖动线束导线的顶点,以更改两个相邻导线段之间的角度。

在设计区中选择一条导线以在Properties面板中更改该导线。通过该面板,您可以重命名选中的导线,更改其宽度和颜色,并添加可以在设计区中显示或隐藏的参数。

当两条导线以T型结构连接时,如下图所示,软件会自动将一个接头放置在T型结合点位置。

我们将在未来更新中增加从库中分配制造商零部件编号的功能。

Properties面板的Harness Wire模式 Properties面板的Harness Wire模式

压接

可以向元器件分配插槽压接。如需这样做,请在设计区中选择一个线束元器件,然后打开Properties面板。在Crimps选项卡上,选择一个管脚,然后单击。在打开的Select Connector对话框中,浏览并从可用库中选择一个元器件。带有已分配压接的管脚将在设计区中用符号表示。下图显示了一个示例。

您可以在Crimps选项卡的栅格区域对选定入口进行多选和复制/粘贴/删除操作。

  • 您可以使用Click、Hold&Drag、Ctrl+Click、Shift+Click或 Ctrl+A快捷方式选择多个管脚入口。
  • 选择多个管脚入口后,单击以将压接元器件添加到所有选定管脚,或者单击或按Delete,将已分配压接从选定入口移除。
  • 选择一个或多个管脚入口,使用Ctrl+X/Ctrl+C快捷方式剪切/复制选定入口,然后使用Ctrl+V快捷方式在当前选定入口粘贴剪切/复制的内容。

添加线缆

如需定义一条或多条导线被添加到线缆中,您可以使用Active Bar关联菜单或Place主菜单中的Harness Cable命令,将Cable对象放置到接线图上。

放置Harness Cable以定义一条或多条导线被添加到线缆中。请注意,选中线缆对象后,该线缆所包含的导线将在设计区中高亮显示。 放置Harness Cable以定义一条或多条导线被添加到线缆中。请注意,选中线缆对象后,该线缆所包含的导线将在设计区中高亮显示。

在设计区中选中对象后,您可以在Properties面板中配置已放置Cable对象的属性(位置、视觉表示和参数)。

Properties面板的Cable模式 Properties面板的Cable模式

未连接导线

导线端不得处于未连接状态。未连接导线端将用实心正方形表示。

用实心正方形表示的未连接导线 用实心正方形表示的未连接导线

如果设计需要使用未连接导线端,则应在导线端放置No Connect指令。您可以使用Active Bar关联菜单中的No Connect命令来放置No Connect对象。

将No Connect对象放置在应保持未连接状态的导线末端。 将No Connect对象放置在应保持未连接状态的导线末端。

在设计区中选中对象后,您可以在Properties面板中配置已放置No Connect指令的属性(位置和视觉表示)。

Properties面板的No Connect模式 Properties面板的No Connect模式

添加接头和分接头

若设计需要将新导线连接到已放置导线,则您必须首先放置一个Splice或Tap。

  • Splice – 接头将原始导线一分为二,使其变成两条独立的导线。

    Javascript

    放置在导线上的接头。请注意,接头在接头位置处将原始导线一分为二。

  • Tap – 原始导线仍然完好无损。

    Javascript

    放置在导线上的分接头。请注意,分接头不会拆分原始导线。

使用Active Bar关联菜单中的命令来放置所需的对象。

在设计区中选中对象后,您可以在Properties面板中配置已放置接头或分接头的属性(位置和视觉表示)。

Properties面板的Harness Splice模式 Properties面板的Harness Splice模式

通过Properties面板的Associated Parts区域,您可以将热缩管等部件分配给选中的实体(这将在项目BOM中体现)。

导线绞合和屏蔽

您可以通过放置一个Twist符号来表示导线绞合在一起。在编辑器Active Bar中选择Twist命令以放置Twist符号。

Twist符号可以跨两条或多条导线放置。在以下示例中,红色和绿色导线绞合在一起,黄色和橙色导线绞合在一起。

放置一个Twist符号以表示两条或多条导线绞合在一起。 放置一个Twist符号以表示两条或多条导线绞合在一起。

在设计区中选中对象后,您可以在Properties面板中配置已放置绞线的属性(位置和视觉表示)。面板的Twist Objects区域将列出被选中绞线包覆的导线。

Properties面板的Twist模式 Properties面板的Twist模式

通过放置Shield或Shield with Connection,可以将屏蔽罩(带或不带加蔽线)连接到一组导线。使用Active Bar关联菜单中的命令来放置所需的对象。

在以下示例中,四条导线均被屏蔽罩(不带和带加蔽线)屏蔽。

已放置的Shield。请注意,选中Shield后,被包覆的导线将在设计区中高亮显示。 已放置的Shield。请注意,选中Shield后,被包覆的导线将在设计区中高亮显示。

在以下示例中,相同的四条导线被带连接的屏蔽罩屏蔽。如果屏蔽罩不带加蔽线,则必须将导线放置在屏蔽罩与其连接点之间。

已放置的Shield with Connection。请注意,选中Shield with Connection后,被包覆的导线将在设计区中高亮显示。 已放置的Shield with Connection。请注意,选中Shield with Connection后,被包覆的导线将在设计区中高亮显示。

如果屏蔽罩带有一条加蔽线,则您可以使用线(Place » Drawing Tools » Line)将屏蔽罩连接到其连接点。

在设计区中选中对象后,您可以在Properties面板中配置已放置的Shield或Shield with Connection的属性(位置和视觉表示)。面板的Shield Objects区域将列出被选中对象包覆的导线。

Properties面板的Shield模式 Properties面板的Shield模式

完整布线图示例如下所示。

完整线束布线图示例 完整线束布线图示例

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: