孔径支持

概览

了解 Altium Designer 的 CAMtastic 编辑器如何处理光圈定义,从导入光圈列表到在光圈表中创建和编辑形状。本文介绍光圈列表向导如何识别不同的文件格式、如何通过尺寸和参数定义受支持的形状,以及如何着手将绘制的焊盘转换为闪光光圈。继续阅读,助您更自信地管理 CAM 文档中的光圈。

- 了解何时会自动导入光圈定义,以及何时需要单独的光圈列表。
- 学习如何自定义光圈列表向导,并利用错误信息修正导入或模板问题。
- 探索如何创建和编辑光圈定义,包括 D 码、尺寸以及复杂形状的参数。
使用 AI 深入了解:

PCB 各层的图形通过感光胶片曝光制成。光圈是供光线穿过并照射到胶片上的实体开口。CAM 数据包括光圈定义(尺寸和形状),以及有关在何处通过光圈进行闪光曝光、在何处保持光束开启并在不同位置之间移动以在胶片上绘制线条的指令。通过不同光圈在胶片上进行闪光曝光,可形成不同尺寸的焊盘;让光束穿过较大或较小的光圈并在胶片上移动,则可绘制较粗或较细的走线。

随着技术的发展,实体光圈可能会完全退出 PCB 制造流程。即使在今天,许多现代激光绘图仪也已不再需要实体镜头光圈,而是通过光栅操作在胶片上模拟相应的形状。

迄今为止,这些技术进步并未改变我们描述 CAM 图像的方式。每个 CAM 文件都需要光圈列表,无论这些图像最终是否真的会通过实体光圈转印到胶片上。每个新建的 CAM 文档都包含一个空白的光圈表。当您导入包含嵌入式光圈定义的 CAM 数据(例如 RS-274-X Gerber 格式或 ODB++ 数据)时,该表会自动填充。如果导入的格式不包含嵌入式光圈定义,例如 Gerber 的 RS-274-D 格式,则还需要提供光圈列表。

光圈列表

Gerber 格式已实现标准化,但光圈列表尚未标准化。每种 CAM 导出工具都有自己的光圈关键字和说明符格式,这可能会给光圈列表的导入带来困难。CAM 编辑器提供了数十种光圈列表向导,涵盖您可能遇到的主流格式以及许多旧版格式,从而减轻这一负担。如果需要修改某个向导以适应您通常收到的数据,或者希望从头创建一个新向导,都可以通过编辑各个行格式来实现。

导入光圈列表时,可以将检测方式设为自动,系统会搜索所有已定义的光圈向导,找到能够无错误导入文件的向导。CAM 编辑器允许您完整访问所有这些向导,以便在需要时进行修改。

所有光圈列表向导都包含常规设置和行格式指令。常规设置包括从何处开始和停止读取光圈行、使用何种单位和比例,以及一行中是否允许存在多个光圈定义等信息。

各个行格式通过每种形状对应的标记和关键字来定义。CAM 编辑器内置了丰富的形状,包括 ODB++ 格式支持的所有形状。有些形状使用相同的标记:菱形、子弹形、椭圆形、矩形和长圆形都通过宽度和高度来定义。其他形状则更复杂,需要额外的参数。创建新的光圈向导或编辑现有光圈向导时,必须使标记的顺序和格式与要导入的光圈列表中提供的值相匹配。

例如,CAM 编辑器自身的向导以 D 码标记 <D> 作为每个行格式的开头。接下来用名称标识形状,后面跟随其尺寸。行格式中标记之间的空格表示字符之间的间隔,因此可以对应一连串空格或制表符分隔符。字符串标记 <S> 表示由此类间隔分隔的任意一组字符。

导入光圈列表时发生的错误会被报告。尽管列表可能仍会继续导入,但最佳做法是找出错误,相应地更新向导,然后重新导入光圈列表。

下表完整列出了 CAM 编辑器可识别的所有标记。本文后半部分提供了编辑器支持的每种形状的示例及尺寸,说明这些标记与各个形状之间的对应关系。

通过从主菜单中选择 Tables » Aperture List Wizard 命令打开的 Aperture Wizard 对话框,用于创建新的光圈向导模板 或编辑现有模板。CAMtastic 编辑器使用光圈模板识别导入文件中使用的光圈,从而建立准确的 DCode 列表。

该对话框分为以下三个选项卡:

  • Settings 选项卡 – 使用此选项卡为所需模板定义名称及关联的扩展名。此选项卡上的其他选项可用于指定在特定文件的何处查找光圈定义、使用的单位,以及是否在导入文件的每一行中搜索多个光圈定义。
  • Line Formats 选项卡 – 使用此选项卡定义模板能够识别的所有形状和数据序列。在 Shape 字段中,从下拉列表中选择适用的形状。在 Line Format 字段中,输入所选形状的数据序列。对于指定的每种形状,行格式必须包括以下内容:

    • 光圈位置类型标记(例如 <A> 或 <D>)。
    • 形状描述(例如 "ROUND"、"RECTANGULAR"、"OCTAGONAL" 等)。
    • 至少一个尺寸类型标记(例如 <W>宽度、<H>高度等)。

    为特定形状创建行格式的最简单方法,是将光圈文件中该形状的信息行粘贴到 Line Format 字段中,然后逐项处理该行,将实际数据替换为从类型标记下拉列表(位于 Shape 按钮右侧)中选择的相应类型标记。

    使用 Shape 按钮可将形状模板条目 - "MyShape" - 输入到 Line Format 字段中。只需将其更改为所需形状的名称即可。
  • Parse Errors 选项卡 – 尝试保存模板时,此选项卡会列出在 Settings 或 Line Formats 选项卡中输入的信息里发现的所有错误。

按要求定义向导模板后,单击 Save 按钮。如果输入的所有信息均无错误,系统将创建模板文件(<WizardName>.awr),并将其存储在软件安装目录下的 System\aptwiz 文件夹中。如果存在错误,则会在对话框的 Parse Errors 选项卡中列出。根据其中列出的错误信息解决问题,然后再次单击 Save 按钮。

光圈表

光圈表用于在一个表格中列出当前文档中定义的所有光圈。该表显示在 Edit Apertures 对话框中,可通过从主菜单中选择 Tables » Apertures 命令或使用 Shift+A 键盘快捷键打开。每个光圈都分配有一个 DCode。例如,在工作区中绘制对象时,DCode 用于指定绘制时使用的关联光圈。创建的每个光圈都必须定义形状和尺寸。某些形状还可以指定其他特殊属性。使用此对话框可以编辑现有光圈的定义或创建新的光圈。

没有任何标记适用于所有光圈形状。因此,光圈表中提供了“尺寸 (X:Y)”列,其中的值仅在某些情况下对应水平和垂直尺寸。对于正方形、圆形等只有一个尺寸的形状,您在此表中输入的 Y 值将被忽略,并由 X 值覆盖。

对于所有其他形状,X 值表示水平尺寸或主要尺寸,Y 值表示垂直尺寸或次要尺寸。例如,圆环有两个尺寸:内径和外径。由于外径限制了内径,因此 X 值表示外径。其他标记均对应 Aperture Data 对话框中的字段。对于莫尔纹等复杂形状,可单击相应的“参数”列打开此对话框。复杂形状还可以使用 Rotation (deg)下拉列表,从中选择所需的旋转角度。

将鼠标悬停在 Edit Apertures 对话框的光圈表中的 Size 或 Parameters 字段上时,将显示工具提示信息,其中各个值会与该形状的相应标记关联显示,如图所示。

  • 导入 Gerber、DXF 或 DWG 文件时,将自动创建光圈列表。
  • 分配给光圈的 D 码范围为 D10 至 D9999。所有当前正在使用的 D 码旁边都会显示一个小的“度”符号。
  • 在 Tool Table 对话框 (Tables »  NC Tools) 中定义的每个工具,在光圈列表中都有对应的条目。分配给工具的 D 码范围为 D9500 至 D9999。
  • 所有 Gerber 格式的光绘机都使用光圈。光圈描述了可用于在胶片上绘图的工具。对于矢量绘图机,这些光圈对应光圈轮或滑板上各种尺寸和形状的孔。光线穿过这些光圈,投射到胶片的感光乳剂上。

支持的光圈形状

以下列出了 CAM 编辑器支持的光圈形状,同时还显示了用于定义每种形状属性的相关标记。

Bullet

 

 

Butterfly

 

Butterfly Square

 

 

Diamond

 

Donut

 

 

Donut Square

 

Ellipse

 

 

Hexagon Horizontal

 

Hexagon Vertical

 

 

Moire

 

Oblong

 

 

Octagon

 

Rectangle

 

 

Rectangle Chamfered

 

Rectangle Rounded

 

 

Round

 

Square

 

 

Target

 

Thermal

 

 

Thermal Rectangle

 

Thermal Rectangle Open

 

 

Thermal Round

 

Thermal Square

 

 

Thermal Square Open

 

Thermal Square Round

 

 

Triangle

 

将绘制焊盘转换为闪光光圈

要将选定的绘制焊盘转换为闪光光圈,并根据所表示的对象自动创建和分配新光圈,请从主菜单中选择 Edit » Groups » Automatic 命令。启动该命令后,光标将变为一个小方块,并进入转换模式。操作步骤如下:

  1. 单击要转换为闪光焊盘的绘制焊盘,将其选中。
  2. 按需选中所有焊盘后,单击鼠标右键。此时将显示 Draw Flash (Auto-Detect) 对话框。该对话框提供以下选项:
    • 在对话框的 Shape/Dcode for New Flashes 区域中,您可以选择为选定的焊盘分配现有 D 码,也可以创建新的 D 码。如果选择 Create New Dcode 选项,则在 Shape 字段中选择的形状将应用于所有选定焊盘,并根据所表示的焊盘自动调整尺寸。CAMtastic 编辑器将检测所需尺寸,并从第一个可用(空)D 码开始,为每个新实例自动分配 D 码。
    • 如果选择 Use Dcode 选项,则所有选定焊盘都将使用相同的 D 码,而不考虑它们之间的差异。
    • 您可以选择将生成的闪光图形绘制在同一层、新层或当前文档中的任意现有层上。
    • 该对话框还提供了其他各种转换选项,包括设置闪光容差(用于匹配选定对象中相同的焊盘),以及选择保留旧焊盘还是将其彻底删除。
  3. 根据需要设置选项后,单击 OK 即可执行转换,所有选定焊盘都将被相应的闪光光圈替换。
  4. 继续将其他绘制焊盘转换为闪光光圈,或单击鼠标右键或按 Esc退出。

要搜索与选定绘制焊盘匹配的所有实例,并将其替换为用户定义的闪光光圈,请从主菜单中选择 Edit » Groups » Selective 命令。启动该命令后,光标将变为一个小方块,并进入转换模式。操作步骤如下:

  1. 单击要用于转换的绘制焊盘,将其选中。
  2. 选中作为模板的绘制焊盘后,单击鼠标右键。此时将显示 Draw Flash (Selective) 对话框。该对话框提供以下选项:
    • 在对话框的 Shape/Dcode for New Flashes 区域中,您可以选择使用现有 D 码,也可以创建新的 D 码。如果选择 Create New Dcode 选项,则可以指定新光圈的形状和尺寸。CAMtastic 编辑器将自动为此新光圈分配下一个可用(空)D 码。
    • 您可以选择将生成的闪光图形绘制在同一层、新层或当前文档中的任意现有层上。
    • 该对话框还提供了其他各种转换选项,包括设置闪光容差(用于搜索与最初选定焊盘匹配的焊盘),以及选择保留旧焊盘还是将其彻底删除。
  3. 根据需要设置选项后,单击 OK 将返回设计空间,系统会提示您选择要进行闪光转换的整个区域。只需拖动选择框框住整个设计,然后在选中该区域后单击鼠标右键。系统会将选定对象与最初选定的焊盘进行比较,并将找到的所有匹配对象转换为所定义的光圈。
  4. 继续有选择地将其他绘制焊盘转换为闪光光圈,或右键单击,或按 Esc 退出。

创建自定义光圈

可以使用当前文档中选中的一个或多个绘制对象创建新的自定义光圈。为此,请从主菜单中选择 Edit » Groups » Draw to Custom Aperture 命令。 启动该命令后,光标将变为一个小方块,您将进入自定义光圈创建模式。操作步骤如下:

  1. 单击要包含在转换中的绘制对象,将其选中。
  2. 按需选中所有绘制对象后,右键单击。此时将出现 Enter Value 对话框,您可以在其中输入自定义光圈的名称。
  3. 定义名称并单击 OK 后,选中的绘制对象将从文档中移除,生成的新自定义光圈将添加到 Edit Apertures 对话框(Tables » Apertures)中。该光圈将被分配下一个可用的(空闲)D 码,其形状将设置为 Custom,您为其指定的名称将显示在 Parameters 字段中。
  4. 继续将其他选定对象转换为自定义光圈,或右键单击,或按 Esc 退出。
  • 新建的自定义光圈将成为当前 D 码,可在 CAMtastic 面板中查看。
  • 在 Edit Apertures 对话框中选中该光圈的条目时,可以在预览窗口中看到先前选中并构成该自定义光圈的对象。
  • 可以根据需要在 Edit Apertures 对话框中更改光圈的 X、Y 方向尺寸。默认情况下,这些尺寸表示包围最初所选组成对象的边界形状的范围。当您使用该光圈关联的 D 码放置对象时,随光标移动的正是此边界形状。

要将自定义光圈对象转换为构成它的基本对象,请从主菜单中选择 Edit » Explode » Custom Apertures 命令。 启动该命令后,光标将变为一个方块,您将进入自定义光圈分解模式。操作步骤如下:

  1. 选择要分解的自定义光圈对象。只需将光标置于要选中的自定义光圈对象上并单击即可。在对象之外单击并拖动,可以框选多个对象。选择操作可累加。
  2. 选中所有自定义光圈对象后,右键单击。选中的自定义光圈对象将转换为构成它们的基本对象。
  3. 继续选择其他要分解的自定义光圈对象,或右键单击,或按 Esc 退出自定义光圈分解模式。
  • 在首次右键单击之前的任何阶段,都可以按 Esc 取消该命令。
  • 使用 Undo 命令可以还原所有已分解的自定义光圈对象。
AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents