管理图层

概览

了解如何管理 Altium Designer CAM 文档中的图层,从添加和对齐图层,到复制对象、移动图层数据、合并图层以及调整 X 和 Y 方向的缩放比例。本文还介绍了如何创建复合图层、控制其极性和编译顺序,以及如何将其分解以进行图层级编辑。继续阅读,了解如何在 CAM 文档中使用这些图层管理命令。

- 了解如何使用选定对象或匹配的边框对齐图层,以及如何在图层之间复制或移动数据。
- 掌握合并和缩放图层的方法,包括缩放会改变哪些特征,以及哪些特征会保持不变。
- 探索复合图层的创建和编辑方法,了解如何设置极性、调整图层顺序,以及将复合图层分解为其组成图层。
使用 AI 深入了解:

图层

添加新图层

要在当前文档中添加新图层,请从主菜单中选择 Edit » Layers » Add 命令。启动该命令后,将显示 Enter Value 对话框。在此对话框中输入新图层的名称。默认情况下,图层将以下一个可用的图层编号命名,例如 layer19。

输入所需名称并单击 OK 后,新图层将添加到 CAMtastic 面板的图层列表中。

新图层的名称必须使用小写字母输入。

对齐所选图层

要根据所选图层对象对齐当前文档中的图层,请使用主菜单中的 Edit » Layers » Align Selective 命令(快捷键: Ctrl+L)。

首先,确保仅启用需要操作的图层。可以通过 Layers Table 对话框(Tables »  Layers)或 CAMtastic 面板中的图层区域来实现。

启动该命令后,光标将变为方形,并进入对齐模式。按以下步骤执行对齐操作:

  1. 系统将提示您选择一个基准对象。该对象位于目标图层上,用于将其他图层与此图层对齐。只需将光标置于目标图层上的某个对象上,然后单击即可。
  2. 接着,系统将提示您在要与目标图层对齐的图层上选择一个对象。同样,只需将光标置于所需对象上并单击即可。所选图层将移动并与目标图层对齐,使所选对象的中心与基准对象的中心重合。
  3. 继续通过选择对象来对齐其他图层,或右键单击,或按 Esc 退出对齐模式。
完成对齐后,基准对象所在的图层(即目标图层)将成为当前图层。

对齐图层边框

要根据匹配的图层边界对齐当前文档中的图层,请从主菜单中选择 Edit » Layers » Align Border (Auto-Detect) 命令。启动该命令后,光标将变为方形,并进入对齐模式。系统将提示您选择一个闭合边框。只需将光标置于目标图层边框的一条边上并单击,即可将所有其他具有匹配边框的图层与该目标图层对齐。

继续通过边框对齐图层,或右键单击,或按 Esc 退出对齐模式。

  • 未检测到匹配边框的图层将保持不变。
  • 所选边框应为闭合边界的一条直边。

复制到图层

要将所选对象复制到当前文档中的一个或多个图层,请从主菜单中选择 Edit » Layers » Copy to Layers 命令。

启动该命令后,光标将变为方形,并进入复制模式。操作步骤如下:

  1. 选择要复制的对象。只需将光标置于要选取的对象上并单击即可。也可以在没有对象的位置单击并拖出一个选择区域,以一次选中多个对象。选择结果可以累积。
  2. 选中所有所需对象后,右键单击。此时将显示 Select Layers To Copy 对话框。在此对话框中选择要将所选对象复制到的一个或多个图层。
  3. 单击 OK 后,所选对象将复制到指定图层,并返回复制模式。
  4. 继续选择更多要复制的对象,或右键单击,或按 Esc 退出。
在右键单击之前的任何阶段,都可以按 Esc 取消该命令。在 Select Layers To Copy 对话框出现时按 Esc after ,将取消当前选择并返回复制模式,以便重新选择。

移动图层数据

要在当前文档的图层之间快速移动数据,请从主菜单中选择 Edit » Layers » Swap Layers Data 命令。启动该命令后,将显示 Swap Layers Data 对话框。该对话框在 Before swap 和 After swap 列中列出文档中当前定义的所有图层。最初,这两列中的列表完全相同,表示不会移动任何数据。如果要将数据从一个图层移动到另一个图层,只需在 Before swap 列中找到源图层,然后在 After swap 列的对应行中单击 Layer Name 字段,选择数据要移入的目标图层。对所有需要移出数据的图层执行此操作。

按需配置好图层映射后,单击 OK ,每组已配置映射中的数据都将从源图层移至指定的目标图层。

创建新的合并图层

要通过合并当前文档中的现有图层来创建新图层,请从主菜单中选择 Edit » Layers » Merge 命令(快捷键: L)。启动该命令后,将显示 Select Layer for Merging 对话框。在此对话框中输入新图层的名称,并选择文档中要合并的现有图层。使用 Select All 按钮可将所有现有图层合并到新图层中。

单击 OK 后,将创建新图层,并将其添加到 CAMtastic 面板的图层列表中。

  • 使用标准多选操作(Ctrl+Click、Shift+Click、Click&Drag)选择要参与合并的图层。
  • 新图层将添加到 Layers Table 对话框(Tables »  Layers)中,并初始指定为 Temporary 图层类型。可根据需要更改此类型。
  • 使用此命令不会对参与合并的原始图层进行任何修改。

缩放图层

要沿 X 和/或 Y 方向缩放当前文档中的图层,请从主菜单中选择 Edit » Layers » Scale(X:Y) 命令。启动该命令后,将显示 Scale Layers 对话框。该对话框列出当前 .Cam 文件中的所有图层。每个图层都提供可编辑的 X 和 Y 缩放字段,初始缩放比例为 100%(正常导入尺寸)。

在此对话框中,根据需要更改任意图层沿 X 和/或 Y 轴的缩放比例。单击 OK 后,将重新绘制可见图层,受影响的图层将根据所定义的选项放大或缩小。

  • 大于 100% 的值将使图层放大。介于 0% 和 100% 之间的值将使图层缩小。
  • 闪光对象的位置将以原点为基准,按照所应用的缩放比例移动,但其尺寸不会改变。
  • 走线(绘制线)会根据所选比例沿长度方向(而非宽度方向)放大或缩小。

复合层

创建复合层的优势在于,可以通过叠加不同层上相互重叠的对象,创建无法在单个层上通过绘制或闪绘生成的对象。

自动创建复合层

要使用当前文档中现有层上选定的对象自动构建复合层,请从主菜单中选择 Edit » Composite Layers » Auto Create Composite 命令。启动该命令后,光标将变为一个小方块,系统会提示您选择要包含在复合层中的对象。只需将光标移至各个对象上并单击,即可将其加入选择集,也可以使用多种可用选择工具中的任意一种。

选中所有所需对象后,单击鼠标右键。此时将显示 Auto-create Composite 对话框。在该对话框中,选择新层的极性是正片(不透明图像)还是负片(透明图像)。

单击 OK后,将生成复合层,并将其添加到 CAMtastic 面板的层列表中。

默认情况下,新层的名称基于层列表中下一个可用的层编号(例如 layer18)。您可以在 Layers Table 对话框(Tables » Layers)中重命名该层,也可以在 CAMtastic 面板中右键单击该层的条目,然后选择 Rename 命令。

创建复合层

要将当前文档中选定的现有层合成为一个复合层,请从主菜单中选择 Edit » Composite Layers » Build Composite 命令。启动该命令后,将显示 Merge Composite 对话框,其中提供以下控件:

  • 对话框顶部的控件用于指定新层的名称及其极性。
  • 对话框的主表格区域用于指定要包含在合并后的复合层中的层。从相应的下拉列表中选择一个层,该列表包含设计中当前已定义并加载的所有层。
  • 为每个层指定极性: Dark 或 Clear。如果选择 Dark,该层的内容将添加到合并后的复合层中。如果选择 Clear,则将从中减去该层的内容。
  • Spread 字段用于指定相应层中光圈的放大或缩小量。

设置好要包含在合并中的所有层后,单击 OK ,新层即会创建,并添加到 CAMtastic 面板的层列表中。

  • 选择要合并的层的顺序,就是这些层的合成顺序。这一点很重要,因为如果顺序不符合您希望通过复合层实现的效果,结果可能不尽如人意。例如,如果希望在一个较大的多边形中挖空一小块区域,请确保先列出包含该多边形的层,再列出包含挖空区域的层。
  • 不应使用现有复合层来创建新的复合层。
  • 复合层的极性选项仅用于控制(切换)各个层的极性设置。

分解复合层

要将复合层永久分解为其组成层,以便进行层级编辑,请使用主菜单中的 Edit » Composite Layers » Explode Composite 命令。

首先,确保要分解的复合层已开启显示。关闭所有其他层的显示也可能会使操作更方便。您可以在 CAMtastic 面板中选择所需的复合层,然后使用 Left Arrow 键盘快捷键来快速完成此操作。

启动该命令后,光标将变为一个小方块,系统会提示您选择要分解的复合层。只需将光标移至该层中各组成层相互重叠的区域,然后单击。系统将基于复合层的名称创建各组成层。复合层本身将从层列表中删除。

例如,如果复合层名为 compro 且包含三个合并的层,则 CAMtastic 面板的层列表中将显示以下组成层:

  • compro - 第一个组成层。
  • compro-1 - 第二个组成层。
  • compro-2 - 第三个组成层。

继续分解其他复合层,或单击鼠标右键,或按 Esc退出。

  • 此命令的操作是永久性的,无法撤消。
  • 如果要分解的复合层不是真正的复合层,即合并各成员层后未产生任何重叠区域,则无法使用此命令。

修改复合层

要修改当前文档中所选复合层的合并属性,请使用主菜单中的 Edit » Composite Layers » Modify Composite 命令。

首先,确保要修改的复合层已开启显示。关闭所有其他层的显示也可能会使操作更方便。您可以在 CAMtastic 面板中选择所需的复合层,然后使用 Left Arrow 键盘快捷键来快速完成此操作。

启动该命令后,光标将变为一个小方块,系统会提示您选择要修改的复合层。只需将光标移至该层中各组成层相互重叠的区域,然后单击。此时将显示 Merge Composite 对话框。在该对话框中进行所需的更改,然后单击 OK 应用这些更改。

继续修改其他复合层,或单击鼠标右键,或按 Esc退出。

  • 如果要修改的复合层不是真正的复合层,即合并各成员层后未产生任何重叠区域,则无法使用此命令。
  • 您会注意到,原始成员层的名称已被替换为 C1: CompositeLayerName、 C2: CompositeLayerName 等。这些条目可以删除,也可以替换为其他层。最初构建复合层时提供的所有选项,在修改时同样可用。

打开复合层进行编辑

要将复合层临时分解为其组成层,以便进行层级编辑,请使用主菜单中的 Edit » Composite Layers » Open Composite for Editing 命令。

首先,确保您要打开的复合层已开启。您也可以关闭所有其他层,以便操作。在 CAMtastic 面板中选择所需的复合层,然后使用 Left Arrow 键盘快捷键,即可快速完成此操作。

启动命令后,光标将变为一个小方框,系统会提示您选择要打开的复合层。只需将光标移至该层中组成层相互重叠的区域,然后单击。系统将根据复合层名称创建各个组成层。复合层本身则会从层列表中删除。

例如,如果您的复合层名为 compro 且包含三个合并的层,则在 CAMtastic 面板的层列表中将显示以下组成层:

  • compro - 第一个组成层。
  • compro-1 - 第二个组成层。
  • compro-2 - 第三个组成层。

如果您要打开的复合层不是真正的复合层,即成员层合并后未产生任何重叠区域,则无法使用此命令。

关闭复合层

要将先前为进行层级编辑而打开的复合层的各个组成层重新合并,请从主菜单中选择 Edit » Composite Layers » Close Composite 命令。各个组成层将重新合并,原始复合层将重新出现在 CAMtastic 面板的层列表中。

此命令仅适用于您最后打开的复合层。如果文档包含多个复合层,建议一次只打开、编辑并关闭一个复合层。

层表

管理层

在 Layers Table 对话框中,您可以定义当前文档中各个可用层的各种属性。要打开此对话框,请从主菜单中选择 Tables » Layers 命令。

启动命令后,将显示 Layers Table 对话框。使用此对话框可定义文档中各个可用层的名称和层类型。您还可以指定各层的绘制颜色和闪光颜色,并控制层的开启或关闭状态(即切换其显示状态)。

此对话框还允许您锁定层。层被锁定后,您将无法执行任何涉及该层上对象的编辑命令。

您也可以在此对话框中删除层。

单击 View Layer Order 按钮将打开 View/Change Layers Order 对话框,您可以在其中定义层的绘制顺序和绘制方向,即从上到下或从下到上。

  • 您也可以在 CAMtastic 面板中定义层名称、可见性、锁定状态和层颜色。
  • 如果已有任何层被指定为钻孔层,则可以据此创建制造图;否则,必须先指定顶层和底层的层类型,才能创建钻孔图。
  • 在 View/Change Layers Order 对话框中拖放各层,即可获得所需的层绘制顺序。

管理层类型检测

要定义可与 CAMtastic 编辑器中各种可用层类型关联的字符串/扩展名模板,请从主菜单中选择 Tables » Layer Type Detection 命令。此模板用于在导入 Gerber 文件时自动检测层。启动命令后,将显示 Layer Types Detection Template 对话框。对于 CAMtastic 编辑器中的每种可用层类型,模板均已根据常见的层命名扩展名/字符串填入一系列预定义字符串,用于识别设计中的各个层。您只需直接在相应字段中输入,即可编辑模板中的任何条目。向模板添加新的字符串/扩展名时,请使用逗号分隔符 (,) 分隔各个条目。

  • 导入 Gerber 文件时,此模板用于自动检测应为各个层分配的层类型。层类型信息显示在 Layers Table 对话框(Tables » Layers)中相应层的旁边。如果自动检测无法确定某个层的层类型,该层将显示在 Layers Table 对话框中,并被分配为 Temporary 层类型。
  • 必须为设计中的每个层分配层类型。如果自动检测无法确定应分配的层类型,则必须手动为该层分配层类型。

管理层集

对于包含盲孔和埋孔的设计,要定义层集并将其分配给指定的钻孔层,请从主菜单中选择 Tables » Layers Sets 命令。例如,在提取/导出网表或运行 DRC 时,需要用到此信息。

启动命令后,将显示 Create/Update Layers Sets 对话框。单击 Insert Layers Set 按钮,在对话框的主区域中添加新的层集条目,然后按以下方式定义该条目:

  • 单击该条目的 Layer Set Name 字段,并输入一个有意义的名称,例如根据钻孔涉及的层来命名。
  • 在 Assigned Drill Layer 列中,选择应分配给该层集的钻孔层。钻孔层包含钻孔点位置等钻孔信息。
  • 单击该条目的 Signal/Plane Layers In Set 字段,打开 Select Layer Pairs 对话框。您可以在此对话框中定义钻孔涉及的层。
  • 如果 Gerber 文件是由 Altium Designer 的 PCB 编辑器生成的,则 Create/Update Layers Sets 对话框中已包含相关信息,并且与 层叠管理器中定义的过孔类型一致。
  • 使用第三方软件生成 Gerber 文件时,Create/Update Layers Sets 对话框将为空,您需要手动定义钻孔层集。
  • 对于盲孔/埋孔,必须选择钻孔穿过的所有层,而不仅仅是起始层和终止层。对于通孔,选择起始层和终止层即可。

管理层顺序

在 Create/Update Layers Order 对话框中,您可以定义设计的物理层顺序。从主菜单中选择 Tables » Layers Order 命令,即可打开此对话框。

此对话框列出了当前设计中的各个信号层和内电层,以及它们的逻辑顺序和物理顺序。使用此对话框可定义层的物理顺序,即 PCB 层叠中的顺序。

逻辑层顺序是各层在 CAMtastic 面板的层列表中的显示顺序。物理层顺序则是信号层和内电层的实际层叠顺序。以 ODB++ 和 IPC-D-356 等格式导出设计时,此顺序非常重要。
AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents