元件布置和电路板布线

概览

了解如何在 Altium Designer 中放置元件并对 PCB 进行交互式布线。本教程将引导您排列元件和位号、配置布线设置、使用走线连接焊盘,以及在 3D 视图中查看已完成布线的电路板。跟随教程操作,将元件布局转变为完成电气连接的电路板,为设计验证做好准备。

- 利用捕捉网格和连接线辅助定位,放置并旋转元件。
- 配置交互式布线,并使用快捷键放置走线、绕过障碍物和完成连接。
- 切换到 3D 布局模式,使用缩放、平移和旋转控件查看电路板。
使用 AI 深入了解:

现在可以将元件放置在电路板上的合适位置,然后进行布线了。

在 PCB 上放置元件

Main page: 元件布局

有一种说法,PCB 设计中 90% 是布局,10% 是布线。虽然这两个比例可能存在争议,但大家普遍认为,良好的元件布局对于优秀的电路板设计至关重要。请记住,在布线过程中,您可能还需要调整布局。

要移动元件,请 Click, Hold&Drag,将元件移动到所需位置,使用 Spacebar 旋转元件(每次逆时针旋转 90º),然后松开鼠标按钮以放置元件。移动元件时,连接线会自动重新优化。利用这些连接线来辅助调整元件的方向和位置,以减少连接线的交叉。

元件放置完成后,PCB 应如下图所示。

元件已放置在电路板上,可以开始布线。
元件已放置在电路板上,可以开始布线。

  1. 缩放视图以显示电路板和元件。

  2. 元件将按当前捕捉栅格定位。对于这样一个简单的设计,没有特定的设计要求来规定应使用何种放置栅格。作为设计人员,您可以自行决定合适的放置栅格。为了简化元件定位过程,可以使用较大的放置栅格。检查状态栏,确认 Snap Grid 已设置为 1 mm。如有需要,可使用主菜单中的 View » Grids » Set Global Snap Grid 命令。

  3. 要放置连接器 P1:

    1. 将光标置于连接器轮廓的中间,并使用 Click, Hold&Drag。光标将变为十字光标,并跳转到该元件最近焊盘的中心。

    2. 继续按住鼠标按钮,移动鼠标以拖动元件。注意连接线会随元件一起移动。

    3. 如有需要,按 Spacebar 旋转元件,并将其放置在电路板左侧附近,如上图所示。

    4. 连接器元件到达合适位置后,松开鼠标按钮将其放下。

  4. 参照上图,重新放置其余元件。拖动元件时,使用 Spacebar 旋转元件,使连接线与图中所示一致。

  5. 重新放置元件位号。操作方式与移动元件类似。使用 Click, Hold&Drag 移动文本,按 Spacebar 旋转文本。或者,在设计空间中选中位号后(),使用 Properties 面板中的 Autoposition 选项。

  6. 在 Projects 面板中右键单击 PCB 文档条目,然后从右键菜单中选择 Save,将 PCB 文档保存到本地。

元件放置完成,现在可以开始布线了!

对电路板进行交互式布线

Main page: 交互式布线

在本教程的这一部分,您将对电路板进行布线。

布线是在电路板上铺设走线和过孔以连接元件引脚的过程。PCB 编辑器提供了先进的交互式布线工具,让这项工作变得轻松。这些工具以直观的方式帮助您最大限度地提高布线效率和灵活性,包括引导光标放置走线、单击完成连接布线、推挤障碍物以及自动沿现有连接布线,所有操作均遵循适用的设计约束。

演示电路板布线过程的视频。部分连接使用 Ctrl+Click 自动完成布线。

  1. 开始布线前,请在 Preferences 对话框的 PCB Editor – Interactive Routing 页面中配置交互式布线选项。

    1. 单击 设计空间顶部的按钮以打开 Preferences 对话框,然后展开左侧树中的 PCB Editor 类别,并选择该类别中的 Interactive Routing 条目以打开该页面。

    2. 在页面的 Routing Conflict Resolution 区域中,将 Current Mode 设置为 Walkaround Obstacles。

    3. 在页面的 Interactive Routing Width Sources 区域中,确保 Track Width Mode 和 Via Size Mode 选项均设置为 Rule Preferred。

    4. 单击 OK 以保存更改并关闭对话框。

     
     
     
     
     

  2. 使用 Snap Grid 对话框(View » Grids » Set Global Snap Grid)将捕捉栅格设置为 0.25 mm。

  3. 单击设计空间底部的 Top Layer 选项卡,将其设为活动层,以便在该层上布线。

  4. 从主菜单中选择 Route » Interactive Routing 命令(快捷键: Ctrl+W)。光标将变为十字形,表示您已进入交互式布线模式。

  5. 将光标移到连接器 P1 下方的焊盘上。

  6. 单击以固定走线的起点。

  7. 将光标移到焊盘下方,然后单击以放置一段垂直走线。

  8. 通过单击来确认各段走线,最终连接到 R2 下方的焊盘。

  9. 继续完成电路板上所有连接的布线。上方的视频演示了对该电路板进行交互式布线的过程。

  10. 完成布线后,在 Projects 面板中右键单击 PCB 文档条目,然后从右键菜单中选择 Save,将其保存到本地。

Altium Designer 的一项强大功能是能够以三维形式查看电路板。要切换到 3D 视图,请从主菜单中执行 View » 3D Layout Mode 命令(快捷键: 3)。电路板将以三维形式显示。本教程中的电路板如下所示。

要在 3D 视图中浏览电路板,可以使用以下操作:

  • 缩放 – Ctrl+Mouse Wheel

  • 平移 – Right-Click, Hold&Drag。

  • 旋转 – Shift+Right-Click, Hold&Drag。模型围绕方向球的中心旋转;按下 Shift 时,方向球会出现在当前光标位置。

有关更多信息,请参阅 控制 3D 视图页面。

PCB 设计已完成。现在,通过验证电路板设计,确认 PCB 符合所定义的约束。 

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents