输出文档和项目发布

概览

通过这篇 Altium Designer 分步教程,为已完成的 PCB 设计做好制造准备。了解如何创建输出作业文件、配置制造和装配文档,以及在发布流程中加入设计规则检查。完成输出配置后,您的项目即可发布。继续阅读,带您完成 PCB 设计的这些最终准备步骤。

- 配置 Gerber 和 NC 钻孔输出,包括单位、精度和输出位置。
- 设置用于装配文档的 BOM、Draftsman 和拾放文件输出。
- 添加 DRC 验证报告,在生成其他发布输出之前检查设计规则。
使用 AI 深入了解:

Main page: 为设计的制造做好准备

现在,您已完成 PCB 的设计和布局,可以开始生成电路板审核、制造和装配所需的输出文档了。

由于 PCB 制造涉及多种技术和方法,Altium Designer 能够针对不同用途生成多种类型的输出,包括 Gerber 文件、ODB++ 文件、贴片坐标文件、物料清单报告等。

向项目添加输出作业文件

Main page: 使用输出作业准备制造数据

虽然您可以从特定编辑器中有选择地生成所需的输出(例如,使用 PCB 编辑器中 File 主菜单下的 Fabrication Outputs 和 Assembly Outputs 子菜单中的命令),但 Altium Designer 也支持使用输出作业文件。输出作业文件(简称“OutJob”)用于存储各类输出的设置。通过 OutJob,您可以配置每种输出类型,以及相应的输出命名、格式和输出位置。您可以直接从 OutJob 生成输出,也可以在集成式项目发布流程中生成输出。

  1. 在 Projects 面板中右键单击项目条目,然后从右键菜单中选择 Add New to Project » Output Job File 命令。系统将打开一个新的输出作业文件,并在 Projects 面板的 Settings\Output Job Files 条目下显示一个与项目关联的文件条目。

    Javascript ID: Tutorial_AddNewOutJob_AD25_4
  2. 在 Projects 面板中右键单击 OutJob 条目,然后选择 Save As 命令。系统将打开 Save As 对话框,默认将文档保存到项目文件所在的位置。在 File name 字段中输入名称 Fabrication,然后单击 Save 按钮。

  3. 添加 OutJob 后,项目已发生更改,因此请在 Projects 面板中右键单击项目条目,然后选择 Save,将项目保存到本地。

添加和配置制板输出

Main page: 准备制板数据

在本教程的这一部分,您将配置制造电路板所需的输出:Gerber 文件和 NC 钻孔文件。 

  1. 要添加新的 Gerber 输出,请单击 OutJob 的 Outputs 区域中 Fabrication Outputs 部分的 Add New Fabrication Output 链接,然后选择 Gerber Files » [PCB Document]。

    如果选择 [PCB Document] 选项,系统将自动使用项目的 PCB 文档作为输出源。选择此选项也便于在项目之间复制 OutJob,因为无需更新此设置。如果项目中有多个 PCB 文档,则需要选择具体的电路板。

  2. 双击添加的 Gerber Files 输出条目。系统将打开 Gerber Setup 对话框。请按如下方式配置对话框中的选项:

    1. 由于电路板采用公制设计,请确保将 Units 选项设置为 Millimeters。

    2. 电路板上布线和间距所使用的最小单位为 0.25mm,但由于大多数元件的参考点位于其几何中心(并且放置在 1mm 栅格上),其中一些焊盘实际上会位于 0.01 栅格上。将 Decimal 选项设置为 0.001 mm。这样可确保输出数据的分辨率足以精确表示这些栅格位置。

    3. 单击 Layer to plot 选项卡底部的  按钮,然后选择 Select Used。设计中使用的层将在上方表格的 Plot 列中启用。

  3. 单击 Apply,接受其他默认设置并关闭 Gerber Setup 对话框。

  4. 由于电路板上有孔,因此还需要生成 NC 钻孔文件。以同样的方式将 NC 钻孔输出添加到 OutJob 文件中:单击 OutJob 的 Outputs 区域中 Fabrication Outputs 部分的 Add New Fabrication Output 链接,然后选择 NC Drill Files » [PCB Document]。

  5. 双击添加的 NC Drill Files 输出条目,打开 NC Drill Setup 对话框。为确保生成的 NC 钻孔文件与 Gerber 文件采用相同的格式,请将 Units 设置为 Millimeters,将 Format 设置为 4:3。确保将 Coordinate Position 选项设置为 Reference to relative origin。

  6. 单击 确定,接受其他默认设置并关闭 NC Drill Setup 对话框。

  7. 配置好 Gerber 和 NC 钻孔设置后,下一步是配置它们的命名和输出位置。这需要将它们映射到 OutJob 右侧的输出容器来完成。对于各自具有独立文件格式的文件,请使用文件夹结构容器。新建的 OutJob 默认包含一些容器。在输出容器列表中选择 Folder Structure 条目,然后单击 Outputs 区域的 Enabled 列中 Gerber 和 NC 钻孔文件对应的单选按钮,将这些输出映射到所选容器,如下所示。

  8. 最后一步是配置容器。选中容器条目后,单击其中的 Change 链接,打开 Folder Structure settings 对话框。对话框顶部有一组用于配置输出位置的控件。确保将第一个控件设置为 Release Managed。当您选择不同选项时,对话框下部会显示名称和文件夹结构的相应变化。

  9. 单击 OK,关闭 Folder Structure settings 对话框。

添加和配置 DRC 验证报告

Main page: 准备验证报告

Altium Designer 包含多项验证检查,可在生成输出时将其作为输出内容。每项检查都会生成一个 HTML 报告文件。在项目发布过程中,这些检查将在生成其他输出之前执行;如果有任何验证检查未通过,发布将失败。

  1. 要添加新的 DRC 验证输出,请单击 OutJob 的 Outputs 区域中 Validation Outputs 部分的 Add Validation Output 链接,然后选择 Design Rules Check » [PCB Document]。

  2. 将添加的报告映射到现有的 Folder Structure 容器。在 OutJob 右侧的列表中选择 Folder Structure 条目,然后单击 Outputs 区域的 Enabled 列中 Design Rules Check 输出对应的单选按钮。

  3. 在 Projects 面板中右键单击输出作业文件的条目,然后从右键菜单中选择 Save,将文件保存到本地。

  4. 右键单击设计空间顶部的输出作业文件选项卡,然后从右键菜单中选择 Close Fabrication.OutJob 命令,关闭该文件。 

添加和配置装配输出

Main page: 在 Report Manager 中配置 BOM

实际的 BOM 输出文件通过 Report Manager 对话框生成。该对话框是一个高度可配置的报表生成引擎,可以生成多种格式的输出,包括文本、CSV、PDF、HTML 和 Excel。对于 Excel 格式的 BOM,还可以应用预定义模板或您自己的模板。

  1. 右键单击 Projects 面板中的项目条目,然后从右键菜单中选择 Add New to Project » Output Job File 命令,为项目添加一个新的 OutJob 文件。

  2. 右键单击 Projects 面板中的 OutJob 条目,然后选择 Save As 命令。系统将打开 Save As 对话框,准备将文档保存到项目文件所在的位置。在 File name 字段中输入名称 Assembly,然后单击 Save 按钮。

  3. 右键单击 Projects 面板中的项目条目,然后选择 Save,将项目保存到本地。

  4. 要添加新的 BOM 输出,请单击 OutJob 的 Report Outputs 部分中的 Add New Report Output 链接,然后选择 Bill of Materials » [ActiveBOM Document]。

  5. 双击已添加的 Bill of Materials 输出,打开 Report Manager 对话框。

  6. 在对话框右侧 Properties 窗格的 Export Options 区域中,使用 File Format 下拉列表选择 Generic XLS (*.xls, *.xlsx, *.xlsm),然后使用 Template 下拉列表,从工作区中的模板中选择 BOM Template Single Supplier 模板。

  7. 单击 OK,保存更改并关闭 Report Manager 对话框。

  8. 单击 OutJob 的 Documentation Outputs 部分中的 Add New Documentation Output 链接,然后选择 Draftsman » All Draftsman Documents,添加新的 Draftsman 输出。

  9. 将已添加的 BOM 和 Draftsman 输出映射到现有的 PDF 输出容器。为此,请在 OutJob 右侧的输出容器列表中选择 PDF 条目,然后在 Outputs 区域的 Enabled 列中,单击 Bill of Materials 和 Draftsman 输出对应的单选按钮。

  10. 选中 PDF 容器条目后,单击该条目中的 Change 链接,打开 PDF settings 对话框。

  11. 单击 PDF settings 对话框顶部的 Assembly.PDF 条目,选择 Separate file for each output using output name,然后单击  按钮。 输出的 BOM 和图纸将采用 OutJob 中为相应输出设置的名称(分别为 Bill of Materials.pdf 和 Draftsman.pdf),您可以在对话框的 Preview 区域中查看这些名称。

    Javascript ID: Tutorial_Dlg_PDFsettings_Path_AD24
  12. 单击 OK 关闭对话框。

  13. 单击 OutJob 的 Documentation Outputs 部分中的 Add New Documentation Output 链接,然后选择 Generates pick and place files » [PCB Document],添加新的贴片坐标输出。

  14. 双击已添加的 Generates pick and place files 输出,打开 Pick and Place Setup 对话框。

  15. 在对话框左下方的 Output Setting 区域中,将 Units 设置为 Metric。

  16. 单击 OK,接受其他默认设置并关闭 Pick and Place Setup 对话框。

  17. 将已添加的贴片坐标输出映射到现有的 Folder Structure 输出容器。为此,请在 OutJob 右侧的输出容器列表中选择 Folder Structure 条目,然后在 Outputs 区域的 Enabled 列中,单击 Generates pick and place files 输出对应的单选按钮。

  18. 右键单击 Projects 面板中的输出作业文件条目,然后从右键菜单中选择 Save,将该文件保存到本地。

  19. 右键单击设计空间顶部的输出作业文件选项卡,然后从右键菜单中选择 Close Assembly.OutJob 命令,关闭该文件。

发布项目

Main page: 设计项目发布

在输出作业文件中配置好输出文档后,即可将项目发布到已连接的工作区。电路板设计发布流程是自动化的,因此您可以发布电路板设计项目,而无需承担手动发布流程带来的风险。发布某个项目时,系统会为设计源文件创建快照,并将其与所有生成的输出一起归档。这些输出代表了基于该设计项目制造并由公司销售的实体产品。

发布流程本身通过 Altium Designer 的 Project Releaser 执行,其用户界面由专用的发布视图提供。发布流程分为多个阶段,视图左侧的条目可让您一目了然地了解当前所处的阶段。

  1. 右键单击 Projects 面板中的项目条目,然后从右键菜单中选择 Project Releaser 命令。发布视图将作为单独的文档选项卡打开。

  2. 在第一阶段(1. Configure Server Release),您需要指定要生成的数据类型。单击各数据集标题最右侧的 Details 控件,可查看该数据集将生成的具体内容。

  3. 单击视图左下角的  按钮,打开 Project Release Options 对话框。在对话框的 Release Options 选项卡上,确保已选择 Managed - <WorkspaceName> 作为 Release Target,并将 Fabrication 分配给 Fabrication Data 数据集,将 Assembly 分配给 Assembly Data 数据集。

  4. 单击 OK,关闭对话框并返回发布视图。

  5. 确保 Include Fabrication Data 和 Include Assembly Data for No Variant 选项均已启用。

  6. 单击视图右下角的  按钮继续。

  7. 系统将打开 Item Creation 对话框,其中列出了将在工作区中创建的目标发布条目。选择 Create items 选项,确认创建条目。

  8. 在随后打开的 Project Modified 对话框中,选择 Save and Commit changes 选项,将更改保存到本地,然后继续将更改保存到工作区。

  9. 在打开的 Commit to Version Control 对话框中,在 Comment 字段中输入 有意义的注释(例如 The project is ready for release),然后单击  按钮。

  10. 发布流程的下一阶段 – 2. Validate Project – 将自动运行,因为 Fabrication 输出作业文件包含设计规则检查报告。

    如果任何验证检查未通过,发布将失败。对于本教程中的项目发布,这意味着 PCB 文档中至少存在一项 DRC 违规。在这种情况下,请单击视图右下角的  按钮停止发布流程,打开 PCB 文档,解决 DRC 违规,然后重新启动发布流程。

  11. 验证成功后,发布流程的下一阶段 – 3. Generate Data – 将自动运行。在此阶段,将执行为所包含的数据项分配的 OutJob 文件中定义的所有其他输出,以生成要发布到工作区中相应目标项的数据。

  12. 所有验证检查通过 且输出数据生成后,发布流程的下一阶段 – 4. Review Data – 可让您查看生成的数据。单击视图右下角的  按钮继续发布。

  13. 随后将打开 Confirm Release 对话框,汇总即将发布到工作区的项目配置。输入 Release Note(例如 Initial Release),然后单击 OK。

  14. 在上一阶段确认发布后,将自动进入下一阶段 – 5. Upload Data。此阶段仅显示将数据上传到工作区中相应数据项修订版的进度。

  15. 流程的最后阶段 – 6. Execution Report – 提供发布摘要。单击视图右下角的  按钮关闭发布视图。

使用工作区进行协同设计

电子产品的设计和开发通常需要多人 共同 参与。为了高效开展工作,设计团队成员需要能够协同工作。 Altium Designer 与连接的工作区配合使用,可支持多种协同设计功能。下面列出了其中的一些功能。

  • Project history – 专用的历史记录视图是一个高级图形化项目历史时间轴,按时间顺序展示与项目相关的重大事件,包括创建、提交、发布、克隆以及 MCAD 数据交换,并在适用时支持各种操作()。要在 Altium Designer 中访问工作区项目的历史记录视图,请右键单击 Projects 面板中的 项目条目,然后从上下文菜单中选择 History & Version Control » Show Project History 命令。

    了解更多: 项目历史记录、Project History(Altium 365 工作区、Enterprise Server 工作区)

  • Web Viewer – 工作区的 Web 查看器 界面可让用户通过标准浏览器随时访问项目文档。它远不止是一个基于浏览器的查看器,其先进的浏览器技术允许用户浏览项目结构、与设计文档交互、高亮显示区域或对象以添加评论,以及在整个设计中搜索、交叉探查、选择和检查元件及网络。 要在 Altium Designer 中访问工作区项目的 Web 查看器,请右键单击 Projects 面板中的 项目条目,然后从上下文菜单中选择 Show in Web Browser 命令。

    了解更多: Web Viewer(Altium 365 平台、Enterprise Server 工作区)

  • Document commenting – 评论是用户添加的备注,可关联到受支持数据视图中的特定点、对象或区域(视具体情况而定),其他用户可以回复。评论可促进用户之间的协作,而不会更改共享数据本身,因为工作区会将评论与数据分开存储。在以下位置的 Web 查看器界面中添加的评论也会显示在 Altium Designer 中,反之亦然。在 Altium Designer 中,可通过 Comments and Tasks 面板()管理评论功能。

    了解更多: 文档评论、Web Viewer(Altium 365 平台、Enterprise Server 工作区)

  • Sharing a project – 将项目保存到工作区后,您可以决定哪些用户能够实际访问该项目,以进行协同设计和/或项目审查。这可以通过共享项目来实现,更准确地说,是通过配置项目的访问权限来实现。在 Altium Designer 中,可通过 Share 对话框()管理项目共享。 要打开此对话框,请右键单击 Projects 面板中的 项目条目,然后从上下文菜单中选择 Share 命令。

    了解更多: 共享设计、 Workspace Projects (Altium 365 工作区、Enterprise Server 工作区)

恭喜! 您从一张空白原理图开始,一步步完成了 PCB 设计,并将输出发布到了工作区,这就是 Altium Designer 中的完整设计流程!

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents