Altium Designer Documentation

ODB Setup

Modified by Phil Loughhead on Jun 19, 2017
此文档页面引用了不再受支持的产品 Altium Vault, Altium Vault 及其组件管理功能已迁移到 Altium Concord Pro

The ODB++ Setup dialog

Summary

This dialog provides the user with tools to completely configure ODB++ file output options. ODB++ is a CAD-to-CAM data exchange format used in the design and manufacture of printed circuit boards. The format was originally developed by Valor Computerized Systems, Ltd., as an open database that could provide a more information-rich data exchange between PCB design software and Valor CAD-CAM software used by PCB fabricators.

Access

The ODB++ Setup dialog is accessed in one of the following ways:

  • Using an ODB output generator in an OutputJob Configuration file (*.OutJob). The output is generated when the configured output generator is run.
  • In an active PCB document, click File » Fabrication Outputs » ODB Files. The output will be generated immediately upon clicking OK in the dialog.
The settings defined in the ODB++ Setup dialog when generating output directly from the PCB are distinct and separate to those defined for the same output type in an OutputJob Configuration file. In the case of the former, the settings are stored in the project file, whereas for the latter, they are stored in the OutputJob Configuration file.

Options/Controls

Layers to Plot

Check the box next to each specific layer(s) you wish to plot as part of the generated output.

Mechanical Layer(s) to Add to All Plots

Check the box next to each mechanical layer(s) you want added to all plots.

Miscellaneous Options

  • ​Include unconnected mid-layer pads - check to allow unconnected pads in the mid-layer on ODB++ plots.
  • Generate DRC Rules export file (.RUL) - check to generate a .RUL file that contains all design rules defined for the source document from which the ODB++ data is being generated.
  • Export only the objects inside the board outline - check to specify the source that is to be used to create the ODB++ profile layer. The profile layer contains the enclosing boundary of the board. By default, this field is set to Board Outline (also referred to as the board shape, it is a closed polygonal shape that defines the boundary, or extents, of the PCB). Created with each new PCB, this is perhaps the best source for creation of the Profile layer. If your design has no associated board shape, you can choose which source PCB layer has been used to define the closed polygon representing the boundary of the board (e.g., the KeepOut layer or a specific Mechanical layer). This option is only available when the source document contains an embedded board array object and it provides control over the extent of objects exported. Note that if an object (e.g., text) is outside of, but touching the board outline and this option is enabled, that object will still be exported.
  • Select the PCB layer / Board Outline that will be used to create the ODB++ 'profile' layer - use the drop down to select the desired layer/board outline:

Plot Layers

Use the drop-down to easily select a group of layers to plot:

  • All On - click to check all boxes in the Plot column (ODB++ data will be created for all checked layers).
  • All Off - click to clear all checked boxes in the Plot column (no ODB++ data will be created). 
  • Used On - click to check all boxes in the Plot column of the layers that are used in the project.

The drop-down also allows you to add and edit a layer class:

  • Add Layer Class - click to add a layer class.
  • Edit Layer Class - click to edit the layer class name. This option is only available when a layer class is selected in Layers to Plot.

NOTES

Generating from an Embedded Board Array

When generating an ODB++ output from a PCB design that contains an embedded board array, the following statements apply:

  • The design is analyzed automatically for layer stackup violations.
  • Embedded boards that are flipped will display their layer stacks as flipped.
  • Mid-signal layers and internal planes that are different can still appear on the same mid-layer panel.
  • Mid-signal layers and internal planes can be flipped against each other.

When generating ODB++ output from the PCB design, all objects on all layers enabled for plotting will be exported. If you only want to export design objects residing within the board outline, ensure that all additional layers containing objects outside of this boundary are disabled for plotting.

Location of Generated Files

The output path for generated files depends on how the output was generated:

  • From an OutputJob file - the generated files are stored in a folder within the project folder. The naming and folder structure is defined in the Output Container that the ODB++ output is targeting.
  • Directly from the PCB - the output path is specified in the Project Options - Options dialog. By default, the output path is set to a sub-folder under the folder that contains the Project file and has the name Project Outputs for <ProjectName>. The output path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options tab, then the ODB++ files will be written to a further sub-folder named ODB++ Output.

Automatically Opening the Generated Output

When generating ODB++ output, you can specify that the output be opened automatically in a new CAM document. The way in which this is accomplished depends on how you are generating the output:

  • From an OutputJob file - enable the ODB++ Output auto-load option in the Output Job Options dialog (Tools » Output Job Options from the OutputJob Editor).
  • Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Project Options dialog (Project » Project Options).

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。