Erstellen des BOM-Dokuments
Auf einen Blick
- Sie lernen, wie Sie ein BomDoc erstellen, was beim Hinzufügen zu einem Projekt geschieht und warum pro Projekt nur ein BomDoc zulässig ist.
- Sie erfahren, wie die Liste der Stücklistenpositionen aufgebaut ist – einschließlich Ansichtsmodi, Spaltensteuerung, Bearbeitungswerkzeugen, Gruppierungsverhalten und Optionen zur Anzeigekonfiguration.
- Sie verstehen, wie ActiveBOM mit gruppierten Bauteilen und benutzerdefinierten Stücklisteneinträgen umgeht, sodass Sie sowohl Bauteile aus dem Design als auch zusätzliche Projektpositionen berücksichtigen können.
Erstellen des BOM-Dokuments
Das Arbeitsdokument für die Stückliste in ActiveBOM wird als BomDoc bezeichnet. Fügen Sie dem Projekt über das Untermenü File » New oder per Rechtsklick auf das Projekt im Panel Projects ein neues BomDoc hinzu. Wenn das Projekt mindestens ein Bauteil enthält, kann ein neues BomDoc erstellt werden, indem Sie auf das Steuerelement + Create neben dem Eintrag ActiveBOM in der Projektstruktur im Panel Projects klicken. Beachten Sie, dass jedes PCB-Projekt nur ein BomDoc enthalten kann.
Wenn Sie Ihrem Projekt ein neues BomDoc hinzufügen, wird der Schaltplan automatisch kompiliert und alle vorhandenen Bauteile werden im BomDoc aufgelistet. Bei Bauteilen aus der Workspace-Bibliothek, die eine Bauteilauswahl enthalten, werden im unteren Bereich der Benutzeroberfläche Beschaffungslösungen aufgeführt, wie im nachfolgenden Abschnitt Beschaffungslösungen verstehen erläutert.
Weitere Bauteile, die im Schaltplan platziert werden, werden automatisch zum BomDoc hinzugefügt. Zusätzliche Stücklistenpositionen und Parameter können auch manuell direkt in ActiveBOM über die Schaltfläche Add new oberhalb der Bauteilliste hinzugefügt werden. Weitere Informationen finden Sie im Abschnitt Benutzerdefinierte Stücklistenpositionen und Spalten.
Die Stücklistenpositionsliste
Der obere Bereich des BomDoc enthält eine tabellarische Liste aller im PCB-Designprojekt erkannten Bauteile sowie zusätzlicher Stücklistenpositionen, die Sie direkt im BomDoc hinzugefügt haben. Dieser Bereich wird als Stücklistenpositionsliste bezeichnet.

Die Bauteil- bzw. Stücklistenpositionsliste in der Basisansicht.
Für die Anzeige der Stücklistenpositionen stehen drei Ansichtsmodi zur Verfügung. Wählen Sie den gewünschten Modus über die Schaltflächen oberhalb der Liste aus:
Flat view – eine Zeile pro Bauteil.
Base view – eine Zeile für jedes eindeutige Bauteil im Projekt; die Spalte „Designator“ enthält die Bezeichner aller Bauteile dieses Typs. Für gruppierte Bezeichner stehen mehrere Darstellungsoptionen zur Verfügung. Wählen Sie im Panel Properties den gewünschten Modus Designator Grouping aus.
Consolidated view – wird bei Projekten mit Varianten verwendet, um eine zusammengefasste Stückliste für alle Varianten anzuzeigen.
Bearbeitungsfunktionen der Stücklistenpositionsliste
Die Bauteilliste unterstützt eine Reihe von Bearbeitungsfunktionen wie in einer Tabellenkalkulation, darunter:
- Verwenden Sie die Registerkarte Column des Panels Properties, um eine Spalte ein- oder auszublenden und einen Aliasnamen für eine Spalte festzulegen. Ein Alias kann auch über das Dialogfeld Enter Column Properties festgelegt werden. Klicken Sie dazu mit der rechten Maustaste auf einen Spaltennamen im Spaltenkopfbereich des BomDoc und wählen Sie anschließend den Befehl Rename Column aus dem Kontextmenü. Beachten Sie, dass der Alias als Spaltenname in den generierten Stücklistenausgaben verwendet wird.
-
Spalten können auch über das Dialogfeld Select Columns hinzugefügt und entfernt werden. Öffnen Sie dieses, indem Sie mit der rechten Maustaste auf einen Spaltennamen im Spaltenkopfbereich des BomDoc klicken und anschließend Select Columns auswählen.
Optionen/Steuerelemente des Dialogfelds Select Columns
- Search – geben Sie Zeichen in das Feld ein, um die Spaltenliste zu filtern. Es werden nur die Spalten angezeigt, deren Name die eingegebenen Zeichen enthält.
-
Visibility column – steuert, ob eine ActiveBOM-Spalte im ActiveBOM-Dokument (
*.BomDoc) sichtbar ist. Klicken Sie auf das Augensymbol, um die Sichtbarkeit einer Spalte umzuschalten. Sichtbare Spalten werden stets oben im Dialogfeld in der Reihenfolge aufgeführt, in der sie im BomDoc erscheinen. -
Data Source column – zeigt die Datenquelle der Spalte an. Folgende Datenquellen werden unterstützt:
-
– direkt zur Stückliste hinzugefügte Positionen
-
– Parameter von Schaltplanbauteilen
-
– Parameter von Workspace-Bauteilen
-
– Parameter verknüpfter Datenbanken (DbLink, DbLib)
-
– Parameter von Schaltplandokumenten
-
– Altium Cloud Services
-
- Column Name – zeigt den Namen der Datenquelle an, der im BomDoc als Spaltenname erscheint.
- Up / Down – verschiebt die aktuell ausgewählte Spalte in der Liste nach oben oder unten. Dadurch wird die Spalte im BomDoc nach links oder rechts verschoben, wenn Sie auf OK klicken. Beachten Sie, dass nur die Reihenfolge sichtbarer Spalten geändert werden kann.
-
– klicken Sie auf das Filtersymbol neben der jeweiligen Überschrift, um die Informationen in der Tabelle nach dem ausgewählten Listeneintrag zu filtern.
- Ändern Sie die Reihenfolge der Spalten per Drag-and-drop.
- Sortieren Sie nach einer beliebigen Spalte. Halten Sie Shift gedrückt, um zusätzlich nach weiteren Spalten zu sortieren.
-
Klicken Sie auf das Filtersymbol, um nach Spaltenwerten zu filtern.
- Wählen Sie Zellen mit den üblichen Windows-Auswahlmethoden aus.
- Kopieren Sie Zellinhalte aus ActiveBOM und fügen Sie Werte aus einem externen Tabellenkalkulationsprogramm in benutzerdefinierte ActiveBOM-Spalten ein.
- Benutzerdefinierbare Zeilennummern können festgelegt werden, wenn die Stückliste in der Basisansicht angezeigt wird. Klicken Sie in der Basisansicht auf die Schaltfläche Set line numbers , um jeder Zeile eine Zeilennummer hinzuzufügen. Klicken Sie auf das Dropdown-Symbol rechts auf der Schaltfläche, um das Dialogfeld Line # Options zu öffnen, in dem Sie den Startwert und die Schrittweite festlegen können. Weitere Informationen finden Sie im Abschnitt Zeilennummernspalte.
- Klicken Sie auf das Dropdown-Menü Add New , um zusätzliche Zeilen oder Spalten hinzuzufügen. Weitere Informationen finden Sie im Abschnitt Benutzerdefinierte Stücklistenpositionen und Spalten.
- Klicken Sie auf die Schaltfläche Group by , um die Tabelle nach der aktivierten Spalte zu gruppieren. Mehrere Gruppierungsspalten können aktiviert (Bild anzeigen) und ihre Reihenfolge per Drag-and-drop geändert werden. Dies ist eine Funktion zur Tabellendarstellung; die Gruppierung wird beim Ausführen des Befehls Bill of Materials nicht in das Dialogfeld Report Manager übernommen.
- Klicken Sie auf die Schaltfläche „Reset Supply Chain“ , um die benutzerdefinierte Rangfolge der Lösungen und die manuell zugewiesenen SPN-Prioritäten aus den ausgewählten Stücklistenpositionen zu entfernen.
- Die aktuelle Konfiguration der Tabelle der Stücklistenpositionen kann als BOM-Set gespeichert werden. Weitere Informationen finden Sie im Abschnitt Anzeige der Tabelle der Stücklistenpositionen konfigurieren und speichern.
-
Verwenden Sie die standardmäßigen Windows-Tastenkombinationen, um durch die Liste der Stücklistenpositionen zu scrollen:
- Vertikal scrollen = MouseWheel Roll
- Horizontal scrollen = Shift + MouseWheel Roll
Die Spaltengruppen

Die Bauteilliste von ActiveBOM umfasst verschiedene Spaltengruppen, die in jedem Ansichtsmodus angezeigt werden. Die obige Abbildung zeigt die Ansicht „Base“.
Die Tabelle der Stücklistenpositionen ist in die folgenden Hauptgruppen unterteilt:
- Item Details (in der Abbildung orange hervorgehoben) – diese Spalten zeigen parametrische Bauteildetails wie Referenzbezeichner, Beschreibung, Bibliotheksreferenz und weitere Bauteilparameter an.
- Solutions (in der Abbildung grün hervorgehoben) – der am höchsten eingestufte Hersteller und die zugehörigen Lieferanten aus der Lieferkette. Die Anzahl der Lösungen (Herstellerteile) und die Anzahl der Lieferanten für jede Lösung werden im Properties-Panel von ActiveBOM konfiguriert. Diese werden durch einen durchgehenden farbigen Balken in der Lieferantenkachel gekennzeichnet. Die Rangfolge wird automatisch ermittelt und kann auch manuell festgelegt werden, wie im nachfolgenden Abschnitt Die Lösung verstehen erläutert.
- BOM Status (in der Abbildung türkis hervorgehoben) – eine Anzeige des aktuellen Risikos für jedes Bauteil. Bewegen Sie den Mauszeiger über ein Symbol, um eine Beschreibung anzuzeigen, oder aktivieren Sie alternativ die detaillierte Spalte BOM Status im Panel Properties, um die Beschreibung einzublenden.
Benutzerdefinierte Stücklistenpositionen und Spalten
Die Stücklistenverwaltung für ein PCB-Designprojekt erfordert auch die Verwaltung von Bauteilen und Stücklistenpositionen, die nicht im Schaltplan oder auf der Leiterplatte platziert sind, beispielsweise noch nicht näher spezifizierte Teile, Befestigungselemente, die unbestückte Leiterplatte oder Montagekleber. In vielen Fällen werden im PCB-Designprojekt benutzerdefinierte Stücklistenpositionen oder Parameter verwendet. Für diese Situationen unterstützt ActiveBOM das Hinzufügen zusätzlicher Stücklistenpositionen und Spalten (Parameter), die anschließend in die generierte Stückliste aufgenommen werden können:
- Custom row – eine einfache Möglichkeit, eine benutzerdefinierte Stücklistenposition hinzuzufügen, die im Design berücksichtigt werden muss (unbestückte Leiterplatte, Kleber usw.). Alle Felder einer benutzerdefinierten Zeile werden vom Benutzer festgelegt. Benutzerdefinierte Zeilen werden nicht von ActiveBOM verwaltet. Wenn die Menge beispielsweise auf 3 gesetzt wird, werden in der Ansicht „Flat“ nicht 3 separate Positionen angezeigt. Auch die Suche in der Lieferkette wird für benutzerdefinierte Zeilen nicht unterstützt.
- Custom column – eine zusätzliche, in ActiveBOM verwaltete Stücklistenspalte, die beliebigen benutzerdefinierten Text enthalten kann.
- Custom Item – eine zusätzliche Stücklistenposition, typischerweise für benötigte Teile, die noch nicht vollständig spezifiziert sind oder noch nicht in der Bibliothek existieren. Dadurch können die Kosten dieser Positionen in die Gesamtkostenschätzung der Leiterplatte einbezogen werden.
-
Managed Component – eine zusätzliche Stücklistenposition, die manuell im Stücklistendokument verwaltet wird. Der Dialog Component Search wird geöffnet und listet die Bauteile im aktuell verbundenen Workspace auf.
Optionen und Bedienelemente des Dialogs „Component Search“
- Search – verwenden Sie das Suchtextfeld, um manuell nach einem bestimmten Bauteil zu suchen.
-
– klicken Sie hier, um ein Menü zu öffnen und eine der folgenden Optionen auszuwählen:
- File-based Libraries Preferences – klicken Sie hier, um den Dialog „Available File-based Libraries“ zu öffnen und Bibliotheken hinzuzufügen oder zu entfernen.
- File-based Libraries Search – klicken Sie hier, um den Dialog „File-based Libraries Search“ zu öffnen und nach Bibliotheken zu suchen.
- Refresh – klicken Sie hier, um den Dialog zu aktualisieren.
-
– klicken Sie hier, um den Details Bereich des Dialogs zu öffnen oder zu schließen (nachfolgend beschrieben).
Kategorien
Verwenden Sie diesen Filter, um bestimmte Bauteiltypen oder alle verfügbaren Bauteile anzuzeigen. Verwenden Sie
, um auf die Suchleiste Categories zuzugreifen, mit der Sie manuell nach einem bestimmten Bauteil oder einer .IntLib-Datei suchen können.
Filter
Klicken Sie auf das Filters -Symbol , um den Bereich Filters zu öffnen. Dort können Sie die in der Liste Components ausgewählten Kategorien weiter filtern.
Bauteile
- Name - der Name des Bauteils.
- Description - die Beschreibung jedes Bauteils.
- Footprint - der Footprint des Bauteils.
- Operating Temperature Range - der geeignete Temperaturbereich, in dem diese Bauteile betrieben werden.
- Package Description - die Gehäusebeschreibung des Bauteils.
- Manufacturer Part Search – klicken Sie hier, um das Panel Herstellerteilsuche zu öffnen und nach dem am besten geeigneten Bauteil zu suchen und es auszuwählen.
- Create component – klicken Sie hier, um den Dialog Create new component zur Auswahl des Bauteiltyps zu öffnen.
- Results - zeigt die Gesamtzahl der bei der Suche gefundenen/aufgelisteten Bauteile an.
Details
- Component Revision ID - zeigt die Revisions-ID und den Preis eines bestimmten Bauteils an. Klicken Sie auf die Revisions-ID, um das Explorer-Panel mit weiteren Informationen zu einem Bauteil zu öffnen.
- References - klicken Sie hier, um Referenzinformationen zum Bauteil in einem Webbrowser zu öffnen. Über die Dropdown-Liste können Sie auf Manufacturer URL oder Datasheet zugreifen.
- Place – klicken Sie hier, um das ausgewählte Bauteil auf einem Schaltplandokument zu platzieren.
- Component information – zeigt relevante Informationen zum Bauteil an, darunter Hersteller, Veröffentlichungsdatum und beschreibende Informationen. Klicken Sie auf den Link Show More , um alle Informationen anzuzeigen; klicken Sie auf Show Less , um die Informationen einzuklappen.
- Models - klappen Sie diesen Bereich auf, um die bereitgestellten Modelle anzuzeigen. Über die verfügbaren Links können Sie verschiedene Teile eines einzelnen Modells anzeigen.
- References - klappen Sie diesen Bereich auf, um auf Manufacturer URL oder Datasheet zuzugreifen.
- Part Choices - klappen Sie diesen Bereich auf, um die Bauteiloptionen anzuzeigen. Name, Preis und Beschreibung werden angegeben. Das Datenblatt des Bauteils wird ebenfalls aufgeführt.
- Where Used – klappen Sie diesen Bereich auf, um die Projekte anzuzeigen, in denen das Bauteil verwendet wird.
Kontextmenü
- Place <component> – klicken Sie hier, um das Bauteil im entsprechenden Dokument zu platzieren.
- Edit – klicken Sie hier, um die Bauteilbibliotheksdokumente des ausgewählten Bauteils zu öffnen.
- Navigate to <revision> – klicken Sie hier, um das ausgewählte Bauteil im Explorer-Panel zu öffnen.
- Operations – bewegen Sie den Mauszeiger über diesen Eintrag, um auf Submit Request, Create, Download, Make a copy, Change Component Type, Create / Edit PCL und Full Item History zuzugreifen.
- Refresh – klicken Sie hier, um die Ansicht zu aktualisieren und die neuesten Aktualisierungen oder Änderungen anzuzeigen. Sie können die Ansicht auch mit dem Tastenkürzel F5 aktualisieren.
Instanzen eines verwalteten Bauteils oder einer benutzerdefinierten Position hinzufügen
Nachdem Sie ein verwaltetes Bauteil oder eine benutzerdefinierte Position hinzugefügt haben, klicken Sie mit der rechten Maustaste darauf und wählen Sie den Befehl Operations » Add Instances of, um den Dialog Add to BOM Components zu öffnen. In diesem Dialog legen Sie die Anzahl der Bauteilinstanzen fest, die der Stückliste hinzugefügt werden sollen.
Geben Sie Designator prefix, optional Separator (dies kann so definiert werden, dass Ergebnisse wie X-1 oder X:1 entstehen) und Quantity der benötigten Bauteile an (dieser Wert dient zur Festlegung des Bezeichnerbereichs und wird auch in der ActiveBOM-Spalte Quantity angezeigt). Alle anderen Parameter, beispielsweise die Beschreibung, können direkt in der Tabelle der Stücklistenpositionen bearbeitet werden.
Ein verwaltetes Bauteil oder eine benutzerdefinierte Position ändern/entfernen
Um den Bezeichner zu bearbeiten oder eine Instanz eines verwalteten Bauteils oder einer benutzerdefinierten Position zu entfernen, klicken Sie mit der rechten Maustaste darauf und wählen Sie den Befehl Operations » Edit item. Der Dialog Change / Remove wird geöffnet.
Optionen und Bedienelemente des Dialogs „Ändern/Entfernen“
- BOM Components – der Tabellenbereich des Dialogs listet jede Instanz der neuen Position auf. Um das Präfix oder den Wert des Bezeichners zu bearbeiten, klicken Sie in die entsprechende Zelle New Designator und nehmen Sie die gewünschten Änderungen vor.
- Remove All – durch Klicken auf diese Schaltfläche werden alle im Dialog aufgeführten Instanzen der zusätzlichen Stücklistenposition ausgewählt und zum Entfernen markiert. Wenn Sie auf die Schaltfläche OK des Dialogs klicken, werden alle zum Entfernen markierten Positionen aus der Tabelle der Stücklistenpositionen in ActiveBOM entfernt. Beachten Sie, dass auch die neue Position selbst entfernt wird, da keine Instanzen dieser Position mehr vorhanden sind. Diese Aktion kann nicht rückgängig gemacht werden.
- Remove None – klicken Sie auf diese Schaltfläche, um alle Markierungen zum Entfernen aufzuheben.
- Remove Selected – wenn eine Instanz ausgewählt ist, die nicht zum Entfernen markiert ist, können Sie mit der dritten Schaltfläche die aktuell ausgewählten Instanzen zum Entfernen markieren.
- Restore Selected – wenn eine Instanz ausgewählt ist, die derzeit zum Entfernen markiert ist, können Sie mit der dritten Schaltfläche die Markierung zum Entfernen für die aktuell ausgewählten Instanzen aufheben.
Datenquellen
Die standardmäßig in ActiveBOM verfügbaren Datenquellen sind die Schaltplan-Bauteilparameter , die Workspace-Bauteilparameter für Workspace-Inhalte und die von ActiveBOM bereitgestellten Daten Aus diesen Quellen erzeugt ActiveBOM die Haupttabelle der Stücklistenpositionen des Projekts. Datenquellen werden auf der Registerkarte Columns des ActiveBOM-Eigenschaften-Panels aktiviert; dort wird auch ihre Anzeige gesteuert.
Durch Aktivieren der entsprechenden Schaltfläche Sources (oberhalb der Spaltenliste) kann die Stückliste auch Informationen aus den folgenden zusätzlichen Datenquellen enthalten:
The PCB – aktivieren Sie diese Optionen, um für jedes Bauteil Daten zu PCB-Position, Drehung und Platinenseite in die verfügbaren Columns aufzunehmen. Wenn das Projekt mehrere PCB-Dokumente enthält, wird der Dialog Zu verwendende PCB auswählen geöffnet, in dem Sie die gewünschte PCB auswählen können.
Database – zum Laden zusätzlicher Bauteilparameter aus einer externen Datenbank (über *.DbLib, *.SVNDbLib oder *.DbLink).
Altium Cloud Services – aktivieren Sie diese Option, um auf eine breite Palette zusätzlicher Bauteildaten für diejenigen Stücklistenpositionen zuzugreifen, die vom Altium Parts Provider erkannt wurden und eine Lieferkettenlösung aufweisen.
Document Parameters – aktivieren Sie diese Option, um alle erkannten Schaltplandokumentparameter aus sämtlichen Schaltplänen des PCB-Projekts in die verfügbaren Columns aufzunehmen.

Die Quelle jedes Parameters wird durch das Symbol in der Spaltenliste angezeigt.
Priorität der Datenquellenparameter
Wenn derselbe Parameter in mehreren Datenquellen vorhanden ist, gelten in ActiveBOM die folgenden Prioritäten (von der höchsten zur niedrigsten):
- Stückliste
- PCB
- Dokumente
- Server
- Datenbank
- Cloud
- Schaltplan
- Manuell
Spalte für Positionsnummern
Bei Leiterplattendesigns mit Bestückungszeichnungen oder beim Austausch von Stücklistendaten zwischen Entwicklungsingenieuren, Kosteningenieuren oder Einkaufsspezialisten ist die Stücklistenpositionsnummer eine einfache Möglichkeit, Stücklistenzeilen eindeutig voneinander zu unterscheiden. Damit lassen sich anschließend die zugehörige Positionsangabe, das Bauteil und dessen Darstellung im Design eindeutig identifizieren oder find.
Als Datenquelle für die Projektstückliste unterstützt ActiveBOM benutzerdefinierte Positionsnummern für die Projektstückliste und bietet Funktionen zur manuellen und automatischen Verwaltung der Positionsnummern.
-
Um die Positionsnummern für alle Einträge der Projektstückliste automatisch festzulegen (in der Ansicht „Base“), klicken Sie auf die Schaltfläche Set Line #
. Die Positionsnummern werden in der Spalte Line # in der Spaltengruppe „Item Details“ angezeigt. Klicken Sie auf das Dropdown-Symbol rechts in der Schaltfläche, um den Dialog Line # Options zu öffnen, in dem Sie den Startwert und die Schrittweite festlegen können.

Der Dialog Line Number Options- Start number – der zu verwendende Wert, wenn die erste Zelle Line # leer ist.
- Increment – jedes leere Feld Line # um diesen Wert erhöhen.
-
Um Positionsnummern manuell zu ändern, wechseln Sie in den Ansichtsmodus „Base“, wählen Sie die gewünschten Zellen in der Spalte „Line #“ aus und:
- Drücken Sie Delete auf der Tastatur, um die Zellen zu leeren. Anschließend
- geben Sie neue Werte manuell ein oder
- fügen Sie einen Wertebereich aus der Windows-Zwischenablage ein.
-
Um die Nummerierung neu zu vergeben oder ab einer benutzerdefinierten Nummer fortzusetzen, klicken Sie auf die gewünschte Zelle in der Spalte „Line #“ und anschließend auf die Schaltfläche Set Line #
. Der Dialog Line Numbering wird geöffnet. Dort können Sie die vorhandenen Nummern als Referenz verwenden und die ausgewählten oder alle leeren Zellen fortlaufend nummerieren, ausgehend von den nächstgelegenen nicht leeren Zellen oberhalb (Continue numbering), oder alle vorhandenen Nummern löschen und sämtliche Zeilen neu nummerieren (Renumber all). Zur Berechnung der hinzugefügten Nummern werden der zuletzt im Dialog Line # Options festgelegte Startwert und die Schrittweite verwendet. Bei Bedarf können Sie in der ausgewählten Zelle der Spalte „Line #“ einen Ausgangswert eingeben, um die Startnummer festzulegen.
Anzeige der Stücklisteneinträge konfigurieren und speichern
Wie in jeder guten Tabellenkalkulation lässt sich die Tabelle der Stücklisteneinträge an Ihre Anforderungen anpassen. Neben den üblichen Funktionen zum Anordnen und Sortieren der Spalten können Sie die aktuelle Konfiguration als Stücklistensatz speichern.
Funktionen zur Tabellenkonfiguration
- Beliebige Spalten ein- oder ausblenden – über die Funktion „Columns“ im Panel Properties. Verwenden Sie das Feld Search oben im Panel, um eine Spalte schnell zu finden.
- Reihenfolge der Spalten ändern – klicken Sie auf den Spaltentitel, halten Sie die Maustaste gedrückt und ziehen Sie die Spalte an die gewünschte Position.
- Breite einer Spalte ändern – bewegen Sie den Mauszeiger im Titelbereich auf den Spaltenrand und ziehen Sie ihn bei gedrückter Maustaste (achten Sie auf den Mauszeiger Alternativ können Sie dort doppelklicken, um die Breite automatisch an den Spalteninhalt anzupassen.
-
Gesamte Tabelle nach einer Spalte sortieren:
- Klicken Sie auf den Spaltentitel, um die Tabelle alphanumerisch nach dem Inhalt dieser Spalte zu sortieren.
- Klicken Sie erneut, um die Sortierreihenfolge umzukehren.
- Halten Sie die Umschalttaste gedrückt und klicken Sie auf einen weiteren Spaltentitel, um den Inhalt dieser Spalte als zusätzliches Sortierkriterium zu verwenden.
-
Tabelle nach einem bestimmten Wert filtern – klicken Sie auf das Filtersymbol
, um die Tabelle nach einem in dieser Spalte verwendeten Wert zu filtern. Wählen Sie (Custom) aus, um den Dialog Filter Editor zu öffnen. Dort können Sie Bedingung, Operator, Wert, Operatortyp usw. für die Filterung der ausgewählten Spalte festlegen.
- Konfiguration als Stücklistensatz speichern – mehr dazu weiter unten.
Mit Stücklistensätzen arbeiten
Sie können beliebig viele Konfigurationen der Tabelle mit den Stücklisteneinträgen speichern. Jede dieser Konfigurationen wird als Stücklistensatz bezeichnet. Nachdem Sie die Tabelle nach Ihren Anforderungen konfiguriert haben, klicken Sie auf die Schaltfläche Add im Bereich BOM Sets des ActiveBOM-Panels Properties, um der Liste einen Stücklistensatz hinzuzufügen.

Klicken Sie auf das Augensymbol, um einen Stücklistensatz zu aktivieren.
Stücklistensätze werden im ActiveBOM-Panel Properties konfiguriert.
Ein Bauteil ersetzen
Es kommt häufig vor, dass beim Prüfen des BomDoc und bei der Vorbereitung der Bauteilbestellung ein Problem mit einem Bauteil festgestellt wird. Beispielsweise hat der Entwickler möglicherweise vergessen, die Auswahl eines Bauteils abzuschließen, oder ein Bauteil wurde abgekündigt (EOL) und der Entwickler möchte Preise und Verfügbarkeit möglicher Ersatzbauteile prüfen. Bisher bestand die einzige Lösung darin, zum Schaltplan zurückzukehren, das Bauteil zu bearbeiten, ein geeignetes Bauteil auszuwählen und anschließend das BomDoc zu aktualisieren.
Alternativ können Sie ein Bauteil im BomDoc ändern und diese Änderung anschließend über einen Engineering Change Order an den Schaltplan übertragen. Klicken Sie mit der rechten Maustaste auf die ausgewählten Bauteile und wählen Sie den Befehl Operations » Change <ComponentName>. Der Dialog Replace Component wird geöffnet, in dem Sie nach dem Ersatzbauteil suchen können.
Wenn Sie auf die Schaltfläche Replace Component OK klicken, wird der Dialog Engineering Change Order geöffnet. Darin werden die Änderungen aufgeführt, die zur Synchronisierung des Schaltplans mit dem BomDoc erforderlich sind.
Arbeiten mit Varianten
ActiveBOM unterstützt PCB-Projekte mit Designvarianten. Mit der Funktion „Designvarianten“ lässt sich ein einziges Basis-Leiterplattendesign erstellen, das anschließend auf unterschiedliche Weise bestückt wird. Jede unterschiedliche Bestückung der fertigen Leiterplatte wird als design variant bezeichnet.
Arbeiten mit Designvarianten:
- Designvarianten werden im Dialog „Variantenverwaltung“ oder im Variantenmanager (Project » Variants) konfiguriert.
- Um eine Variante zu prüfen, doppelklicken Sie im Ordner „Varianten“ des Projekts im Panel Projects auf ihren Namen, wie in der folgenden Abbildung gezeigt.
ActiveBOM unterstützt Varianten auf folgende Weise:
- Anzeige der Stückliste für eine bestimmte Variante im Basisansichtsmodus oder im flachen Ansichtsmodus
- Option zum Einbeziehen nicht bestückter Positionen in die Liste der Stücklistenpositionen
- Anzeige einer zusammengefassten Liste aller in sämtlichen Varianten verwendeten Teile im konsolidierten Ansichtsmodus
- Definition manueller Lösungen sowohl für Basisbauteile als auch für variierte Bauteile
Varianten im Basisansichtsmodus
Aktivieren Sie für die ausgewählte Variante die Option Show Not Fitted im Panel Properties, um diese Teile in die Tabelle der Stücklistenpositionen aufzunehmen. Wenn diese Option aktiviert ist, wird die Spalte Fitted automatisch in den Positionsdetails angezeigt.
Im Basisansichtsmodus wird in der Spalte Fitted entweder Fitted oder Not Fitted angezeigt. Wenn ein Teil variiert wird (für diese Variante wurde ein alternatives Teil ausgewählt), werden die Details des alternativen Teils automatisch für diese Stücklistenposition angezeigt.

Beachten Sie, dass die aktuelle Variante in der ActiveBOM-Statuszeile angezeigt wird.
Varianten im konsolidierten Ansichtsmodus
Der konsolidierte Ansichtsmodus zeigt alle Bauteile an, die in sämtlichen Varianten verwendet werden. Die konsolidierte Ansicht bietet folgende Funktionen:
- Wenn ein Bauteil variiert wird, gibt es für jedes verwendete alternative Bauteil eine Stücklistenposition, wobei alle diese Stücklistenpositionen denselben Bezeichner haben. Beispielsweise sind in der folgenden Abbildung die Bauteile DS1 und DS2 jeweils zweimal aufgeführt, da die BGA-Variante eine LED mit einer anderen Farbe verwendet als die TSOP-Variante. Das Bauteil R1 erscheint dreimal, da sowohl die BGA- als auch die TSOP-Variante einen anderen Widerstand als das Original im Basisdesign verwenden.
-
Im konsolidierten Ansichtsmodus wird bei aktivierter Option Show Not Fitted in der Spalte Fitted entweder
FittedoderVariedangezeigt. Da die konsolidierte Ansicht alle in sämtlichen Varianten verwendeten Bauteile zeigt, wird jedes angezeigte Bauteil entweder im Basisdesign oder in einer Variante bestückt. - Für jede Variante gibt es eine Spalte <VariantName> - Qty (die angibt, wie viele Exemplare dieses Bauteils in dieser Variante verwendet werden) und eine Spalte <VariantName> - Price, deren Wert dem Stückpreis multipliziert mit dem Wert in der Mengenspalte entspricht.
- Da einige Entwickler Fertigungsunterlagen sowohl für das Basisdesign als auch für die Varianten erstellen, gibt es außerdem eine Spalte Quantity. Diese gibt die Anzahl der Exemplare dieses Bauteils an, die bei der Fertigung des Basisdesigns verwendet werden. Blenden Sie diese Spalte aus, wenn Sie keine Fertigungsunterlagen für das Basisdesign erstellen.
- Die Tabelle im konsolidierten Ansichtsmodus kennzeichnet Zellen farblich, deren Wert vom Wert der entsprechenden Zelle im Basisdesign abweicht, wie unten gezeigt.

Eine farblich markierte Zelle zeigt an, dass ihr Wert vom Wert der entsprechenden Zelle im Basisdesign abweicht.
Weitere Informationen zu Varianten finden Sie auf der Seite Designvarianten.
Arbeiten zwischen BomDoc, Schaltplan und Leiterplatte
Zwei Funktionen unterstützen Sie bei der Arbeit zwischen BomDoc, Schaltplan und Leiterplattendesign: Querauswahl und Querverfolgung. Das Verhalten dieser Funktionen wird auf der Seite „System – Navigation“ des Dialogs Preferences konfiguriert.
Mit beiden Funktionen können Sie dasselbe Bauteil in anderen Dokumenten finden. Der Unterschied zwischen Querauswahl und Querverfolgung besteht darin, dass der Querauswahlmodus das Bauteil im Zieldokument auswählt, dieses Dokument jedoch nicht aktiv in den Vordergrund bringt. Die Querverfolgung hingegen bringt das Zieldokument aktiv in den Vordergrund und kann auch zum Editor des Zieldokuments wechseln und diesen zum aktiven Editor machen.
Sie können die Querauswahl oder Querverfolgung vom BomDoc zum Schaltplan und zur Leiterplatte verwenden, jedoch nicht vom Schaltplan oder von der Leiterplatte zum BomDoc.
Querauswahlmodus
Der Querauswahlmodus muss in jedem Editor aktiviert werden, in dem Sie ihn verwenden möchten. Wählen Sie den Befehl Tools » Cross Select Mode (Shift+Ctrl+X). Wenn der Querauswahlmodus aktiviert ist, wird das Menüsymbol durch eine Umrandung hervorgehoben
.
Für den Querauswahlmodus muss das Zieldokument geöffnet sein. Wenn Sie ein Bauteil in der Liste der Stücklistenpositionen des BomDoc auswählen, wird dieses Bauteil in den Ziel-Schaltplan- und Leiterplattendokumenten ausgewählt und zentriert (sofern Zooming in den Optionen Cross Select Mode auf der Seite „System – Navigation“ des Dialogs Preferences aktiviert ist). Beachten Sie, dass das Zieldokument nicht zum aktiven Dokument wird.
Wenn sich das BomDoc im Basisansichtsmodus befindet, werden alle Instanzen dieses Teils im Schaltplan und auf der Leiterplatte ausgewählt, wie in der folgenden Abbildung gezeigt.

Verwenden Sie die Querauswahl, um das in der Liste der Stücklistenpositionen gewählte Bauteil im Schaltplan und auf der Leiterplatte zu finden und auszuwählen.
Querverfolgung
Während die Querauswahl lediglich ein Modus ist, der bei Aktivierung das Ergebnis jedes Mal anzeigt, wenn Sie in die Liste der Stücklistenpositionen klicken, ist die Querverfolgung eine gezielte Aktion.
Wählen Sie Tools » Cross Probe Befehl aus den Hauptmenüs oder klicken Sie mit der rechten Maustaste auf eine Stücklistenposition und wählen Sie Cross Probe aus dem Kontextmenü, um per Cross-Probing zu diesem Bauteil im Schaltplan zu navigieren. Wenn die Leiterplattendatei geöffnet ist, wird auch das entsprechende Leiterplattenbauteil per Cross-Probing ausgewählt.
Eine wichtige Funktion von Cross-Probing ist die Möglichkeit, zum Editor des Zieldokuments zu wechseln. Um Cross-Probing auszuführen und den Editor zu wechseln, halten Sie die Taste Ctrl gedrückt, während Sie den Befehl Cross Probe auswählen.

Klicken Sie mit der rechten Maustaste, um auf den Befehl Cross Probe zuzugreifen. Für den Bezeichner jedes Bauteils in dieser Stücklistenposition ist ein Eintrag vorhanden.
Panel „Properties“
Wenn das aktive Dokument ein Stücklistendokument (*.BomDoc) ist, zeigt das Panel Properties die Document Options an.
Die folgenden ausklappbaren Abschnitte enthalten Informationen zu den verfügbaren Optionen und Steuerelementen:
Allgemein
- Production Quantity – die Anzahl der zu fertigenden Leiterplatten. Dieses Feld muss unbedingt ausgefüllt werden, da es bei der Lieferkettensuche verwendet wird, um die Verfügbarkeit von Bauteilen bei den Lieferanten zu prüfen.
- Currency – die bevorzugte Währung für die Anzeige der Bauteilpreise. Die Wechselkurse für die Währungsumrechnung werden täglich aktualisiert, sofern Sie bei Ihrem Altium-Konto angemeldet sind. Wenn Sie sich von Altium abmelden (auf der Seite System – Account Management des Dialogs Preferences), verlieren Sie den Zugriff auf diese aktualisierten Kurse. In diesem Fall können Sie im Dialog für Stücklistenberichte eine Option zur Verwendung zwischengespeicherter Daten auswählen.
- Price Per Board – wird aus den lieferantenbezogenen Daten abgeleitet und ist die Summe von Supplier Subtotals per Board, wie unten beschrieben. Beachten Sie, dass Price Per Board keine Mindestbestellmengen (MOQs) berücksichtigt.
- Order Price – Summe von Supplier Subtotals. Beachten Sie, dass Order Price etwaige Mindestbestellmengen berücksichtigt. Dies ist der Betrag, der an den Lieferanten gezahlt wird.
Lieferkette
Lieferketteninformationen werden im unteren Bereich der ActiveBOM-Oberfläche angezeigt. Links wird ein Herstellerbauteil dargestellt, rechts daneben eine oder mehrere farbige Lieferantenkacheln. In diesem Bereich werden Daten angezeigt, wenn gültige Lieferketteninformationen für eine Stücklistenposition ermittelt werden können. Jede dieser Manufacturer & Supplier(s) Details-Zeilen wird als Lösung bezeichnet. Die Herstellerangaben werden als MPNs (Manufacturer Part Numbers, Herstellerteilenummern) und die Lieferantenangaben als SPNs (Supplier Part Numbers, Lieferantenteilenummern) abgekürzt.
- Solutions per Item – die Anzahl der Herstellerteile, die für jede Stücklistenposition ermittelt werden sollen.
- Suppliers per Solution – die Anzahl der Lieferanten, die für jedes Herstellerteil ermittelt werden sollen.
-
Solutions
- Exclude Invalid SPNs – aktivieren Sie diese Option, um ungültige SPNs auszuschließen.
- Favorite Suppliers List – öffnet den Dialog Favorite Suppliers, in dem die gesamte Lieferantenliste für dieses BomDoc konfiguriert werden kann.
-
Manufacturer Link – öffnet den Dialog Define Manufacturer Link Fields, in dem die Schaltplanbauteilparameter angegeben werden, die den Herstellernamen und die Herstellerteilenummer enthalten. Wenn der Entwurf Bibliotheksbauteile enthält, die nicht aus einem Workspace stammen und auch keine Lieferantenangaben haben, kann ActiveBOM den Altium Parts Provider abfragen, um geeignete Lieferkettenlösungen zu ermitteln. Es können mehrere Parameterpaare aus Name und Teilenummer definiert werden. Klicken Sie im Dialog auf die Schaltfläche Detect fields, um automatisch alle Parameterpaare hinzuzufügen, deren Namen den Begriff
manufacturerenthalten und die sich logisch zuordnen lassen.
Stücklistenpositionen
In diesem Bereich wird konfiguriert, wie die Stücklistenpositionen in der Stücklistenpositionstabelle gruppiert werden sollen.
-
Items
-
Show not Fitted – wenn das Leiterplattenprojekt Varianten enthält und für die ausgewählte Variante Bauteile auf
Not Fittedgesetzt sind, aktivieren Sie diese Option, um die nicht bestückten Positionen in der Stücklistenpositionstabelle anzuzeigen. - Designator Grouping – die Ansichtsmodi „Base“ und „Consolidated“ zeigen gleiche Bauteile in einer einzigen Zeile der Stücklistenpositionstabelle an. Mit dieser Option legen Sie fest, ob die Bezeichner einzeln oder als Bereiche angezeigt werden, wenn eine Zeile mehrere Bauteile enthält.
- Component Grouping – durch Klicken auf die Schaltfläche Edit wird der Dialog Component Grouping geöffnet. In der Ansicht Base oder Consolidated erkennt ActiveBOM Bauteile als identisch, wenn sie dieselbe ItemID (Workspace-Bibliothek) oder LibRef (dateibasierte oder Datenbankbibliothek) aufweisen. Aktivieren Sie Parameter im Dialog, um die Gruppierung der Bauteile weiter zu verfeinern. Beachten Sie, dass die Schaltfläche Edit nicht verfügbar ist, wenn das Projekt ausschließlich verwaltete Bauteile enthält, da diese immer nach ItemID gruppiert werden.
-
Show not Fitted – wenn das Leiterplattenprojekt Varianten enthält und für die ausgewählte Variante Bauteile auf
Stücklistensätze
Mit Stücklistensätzen können Sie das Layout und die Konfiguration der Stücklistenpositionstabelle erfassen und als benannten Satz speichern. Es können beliebig viele Stücklistensätze definiert werden.
-
Current BOM Set – klicken Sie auf das Augensymbol, um diesen Stücklistensatz auf die Stücklistenpositionstabelle anzuwenden.
-
Add – konfigurieren Sie die Sichtbarkeit, Reihenfolge und Breite der Spalten und klicken Sie anschließend auf Add, um diese Konfiguration als BOM-Set zu speichern. Um den Namen des BOM-Sets zu bearbeiten, klicken Sie einmal darauf, um es auszuwählen, und anschließend ein zweites Mal, um den Text zu bearbeiten.
-
Update – wenn die Konfiguration der Tabelle mit den Stücklistenpositionen geändert wurde, klicken Sie auf Update, um diese Konfiguration erneut zu speichern.
-
Delete – klicken Sie auf
, um das aktuell ausgewählte BOM-Set zu entfernen.
Stücklistenprüfungen
ActiveBOM führt umfassende Prüfungen jeder Stücklistenposition und aller für diese Position ermittelten Lieferkettendaten durch.
- Violation Type grid – zeigt eine Liste der Arten und der jeweiligen Anzahl der aktuell im BomDoc vorhandenen Verstöße an. Klicken Sie auf das Filtersymbol, um nur diejenigen Stücklistenpositionen anzuzeigen, die diese Stücklistenprüfung nicht bestehen. Beachten Sie, dass eine Stücklistenposition mehrere Stücklistenprüfungen nicht bestehen kann.
-
BOM Checks – klicken Sie auf
, um den Dialog „Stücklistenprüfungen“ zu öffnen, in dem der Berichtsmodus für jede mögliche Verstoßart konfiguriert werden kann.
Spalten
In diesem Bereich des Panels werden die Parameter konfiguriert, die für jede Stücklistenposition angezeigt werden, sowie die für diese Parameter verfügbaren Datenquellen.
-
Sources – zusätzlich zu den direkt in das BomDoc eingefügten Daten stehen in ActiveBOM standardmäßig die Schaltplan-Bauteilparameter und die Parameter der Workspace-Bibliotheksbauteile für Workspace-Inhalte als Datenquellen zur Verfügung. Aus diesen Quellen erstellt ActiveBOM die Haupttabelle der Stücklistenpositionen des Projekts. Die Stückliste kann außerdem Informationen aus den folgenden zusätzlichen Datenquellen enthalten:
-
PCB – aktivieren Sie diese Option, um Daten zu PCB-Position, Drehung und Platinenseite in die verfügbaren Columns für jedes Bauteil aufzunehmen.
-
Database – aktivieren Sie diese Option, um zusätzliche Bauteilparameter aus einer externen Datenbank (*.DbLib,*.SVNDbLiboder*.DbLink) zu laden. -
Document – aktivieren Sie diese Option, um alle erkannten Schaltplandokumentparameter aus sämtlichen Schaltplänen des PCB-Projekts in die verfügbaren Columns aufzunehmen.
-
Altium Cloud Services – aktivieren Sie diese Option, um auf eine breite Palette zusätzlicher Bauteildaten für diejenigen Stücklistenpositionen zuzugreifen, die vom Altium Parts Provider identifiziert wurden und eine Lieferkettenlösung aufweisen.
-
-
Columns – Liste aller Quellen für Bauteilinformationen, die ActiveBOM zur Verfügung stehen. Der Bereich „Spalten“ kann durch Klicken auf eine beliebige Spaltenüberschrift sortiert werden.
- Visibility – jede Zeile verfügt über ein Augensymbol. Klicken Sie darauf, um die Sichtbarkeit dieser Spalte in der Haupttabelle der Stücklistenpositionen zu steuern.
- Source – zeigt ein Symbol an, das die Quelle dieses Parameters kennzeichnet.
- Name – der Name der Eigenschaft bzw. des Parameters, wie im Quelldokument definiert oder für eine benutzerdefinierte BomDoc-Spalte eingegeben.
- Alias – bei Bedarf kann ein Alias definiert werden, um eine Spalte umzubenennen.
- Add – klicken Sie hier, um der Tabelle mit den Stücklistenpositionen eine neue benutzerdefinierte Spalte hinzuzufügen.






